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Building an Architectural
Model from a Concept
Sketch
Sitting over a cup of coffee, an architect works on
a conceptual sketch of a new art museum. Slowly
the wastebasket fills up with crumpled paper,
each with a different museum design. After a few
hours, all of the hard work pays off. The sketch is
a concept that embodies the idea of the museum,
a modern structure with a contrast of style and
material.

Skill Level: Beginner

Time to complete: 45 minutes

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Start with a sketch to complete a 3D conceptual
design.

• Use Booleans.

• Use the Spacing Tool.

• Use Daylight to create a shadow study.

Tutorial Files

The files for this tutorial can be found on the
Tutorial Files CD, in the \tutorials\arch folder.
Before doing the tutorials, copy the \tutorials
directory from the CD to your \3dsmax8 local
installation.

Incorporating the Sketch

In this section, you will bring in the sketch that
will be used as the basis of the final building. The
sketch has been specially prepared by making
it negative, and reducing the brightness and
contrast. This makes it easier to see what you are
doing when building on top of the sketch.

Incorporate the sketch as a background image:

1. On the menu bar, choose File > Open.

AEC
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The Open File dialog appears.

2. Open modelfromsketch_01.max from the
\tutorials\arch directory.

3. Verify that the Top viewport is active. If it isn’t,
right-click in the Top viewport to make it active.

4. If any floating toolbars appear over the
viewports, close them or dock them so they are
not in your way.

5. On the menu bar, choose Views > Viewport
Background.

6. In the Viewport Image dialog >
Background Source group, click Files.

7. In the Select Background Image dialog,
select sketch.gif located in the \tutorials\arch
directory, then click Open to close the dialog.

8. In the Viewport Background dialog > Aspect
Ratio group, choose Match Bitmap. Also to its
right turn on Lock Zoom/Pan if it isn’t already
on.

9. Click OK to close the dialog.

The image appears in the center of the viewport,
but needs to be sized to fit the current viewport.

10.On the menu bar, choose Views > Reset
Background Transform.

Sketch displayed in viewport background

The image is sized to fit the viewport
background.

Creating the Building

You will begin creating the building, starting with
the main entrance rotunda. Because you are not
building this to scale, disregard the dimensions
on the sketch.

Set up:

• Continue from the previous step, or open the
tutorial file modelfromsketch_02.max from the
\tutorials\arch directory.

Note: If you do open the provided file, the
viewport background will not be visible in
the Top viewport. To display the viewport
background, activate the Top viewport and
choose Views > Viewport Background. In the
Background Source group click Files, and then
navigate, if necessary, to the \tutorials\arch
folder and highlight sketch.gif.

Start the main entrance rotunda:

1. In the viewport navigation tools, click
Region Zoom.

2. In the Top view, drag a rectangle to zoom in on
the main entrance in the lower left of the sketch.
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Note: If you zoom in too far, a dialog will appear
indicating that the amount of RAM needed to
display the background image may exceed the
available amount. Answer NO to the warning.
To display your viewport after you’ve answered
NO to the warning, right-click the viewport
label and choose Show Background.

3. On the Create panel, choose Shapes.

4. On the Object Type rollout, click
Circle.

5. In the Top viewport, position the mouse cursor
in the center of the rotunda, and then click and
drag outward to draw a circle that lines up with
the glass walls of the rotunda. If necessary,
right-click and choose Move, then move the
circle into place.

6. On the menu bar, choose Edit > Clone.

7. In the Clone Options dialog, make sure Copy is
chosen, enter the name Steel Ring 01, and then
click OK to make a copy of Circle01.

A new copy of the circle is on top of the original
circle.

8. Press H to open the Select Objects dialog,
choose Circle01 in the list, and click Select.

9. From the Modifiers menu > Mesh Editing
category, apply an Extrude modifier. On the
Modify panel, set Amount to 18.3m.

10.Again press H, and select the Steel Ring 01
object.

11.On the Modify panel > Rendering rollout,
turn on the Enable in Renderer and Enable in
Viewport check boxes.

This option makes the spline visible in the
viewport and when rendered.

12.Set Thickness to 0.61m.

This parameter determines the thickness of the
spline when rendered.

13. On the toolbar, click Select And Move.

14.In the status bar (bottom of the screen) >
coordinate display > Z field, enter 6.1m.

This moves the ring up 6.1 meters.
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15.From the Tools menu choose Array.

16.In the Array dialog, under Incremental, set the
Move Z axis to 6.1m.

17.In the Type Of Object group, choose Instance.

18.In the Array Dimensions group > 1D Count,
enter 3.

19.Click OK.

This closes the dialog and creates two additional
steel holding rings around the glass rotunda.

Add the outer wall and central column:

You’ll use the rotunda circle to create the outer
wall.

1. Select the Circle01 object.

2. From the Edit menu, choose Clone.

3. In the Clone Options dialog > Object group,
choose Copy.

4. Click OK to make a copy of Circle01.

5. In the Modify panel, under the modifier
stack display, click Remove Modifier.

6. In the Modify panel > Parameters rollout,
change the Radius amount to match the outer
circle in the sketch (about 15.0m).

7. On the menu bar, choose Edit > Clone.

8. In the Clone Options dialog > Name group,
type Large Column. Make sure Copy is still
on, then click OK.

9. In the Modify panel > Parameters rollout,
change the Radius amount to 2.4m to match
the small solid circle in the sketch.

You needn’t move the column to match the
sketch. Remember, this is just a quick sketch,
not a precise design.

10.Apply an Extrude modifier and set Amount to
21.3m.
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11.Press H and select Circle01 from the list.

12.In the Modify panel, rename Circle01 to
Rotunda Glass.

13.In the modifier stack display, choose Circle.

If you can no longer see the extrusion, it is
because you’ve moved "down" the stack to the
original shape. In order to see "up" the stack,
you must turn on Show End Result. If this is
already on you will see the extrusion without
problem.

14.From the Modifier List, from the Object Space
Modifiers category choose Edit Spline.

15. On the Modify panel > Selection rollout,
click the Spline button.

This places you at the spline sub-object level,
so you can edit the original shape prior to the
Extrude modification.

16.In the Modify panel > Geometry rollout, next
to the Outline button, enter 0.03m.

This creates a nested shape, like the letter O.
Notice that the outline field returns to 0.0
value after you have created the outline. This
is because Outline is an action, rather than a
parameter.

17.In the Modify panel > Selection rollout, click
Spline to exit the sub-object level.

18.In the modifier stack display, choose Circle.
When the warning appears, click Yes to
continue.

You can now see the result of outlining the
spline: Instead of a solid column, you have a
thin, circular wall.

Create doorways with Boolean:

Next, you’ll create a box and then use Boolean to
subtract its shape from the rotunda.

1. In the Create panel > Geometry
> Standard Primitives > Object Type rollout,
click Box.

2. In the Top viewport, click and drag out a box
as shown below.
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Tip: Right-click the Top viewport label and
change the viewport to Smooth+Highlights.

3. In the Modify panel > Parameters rollout,
change the Length amount to 9.0m, the Width
to 36.5m, and the Height to 6.0m.

4. On the toolbar, click Align.

5. Press H, choose Rotunda Glass from the list,
and then click Pick.

6. In the Align Selection dialog > Align Position
group, turn on X Position and Y Position.

7. Click OK to close the dialog.

8. On the toolbar, click Select And Rotate.

9. In the Coordinate Display > Z field, enter 45.0.

This rotates the box into the same position and
orientation as the rotunda openings in the plan.

10.Select the Rotunda Glass object.

11.Go to the Create panel, and from the
drop-down category list, choose Compound
Objects.

12.In the Object Type rollout, click Boolean.

13.In the Parameters rollout, make sure the
Subtraction (A-B) item is active.

14.In the Pick Boolean rollout, click Pick Operand
B, and then click the box.

The box is subtracted from the rotunda object,
leaving two open doorways.

15.Right-click in the viewport to exit the Boolean
operation.
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Create the roof:

Here you’ll clone the topmost ring and then
extrude the clone, producing a roof.

1. Press H and select Steel Ring 03 from the list.

This is the topmost ring.

2. On the menu bar, choose Edit > Clone.

3. Name the clone Roof, click Instance, and then
click OK.

4. In the Modify panel, add an Extrude modifier.

The roof appears at the top of the rotunda.

5. In the Modify panel > Parameters rollout, set
the Amount to 0.15m.

This gives the roof the appropriate thickness.

Creating the Outer Columns

In the next few steps, you will create columns from
cylinders and make multiple copies using Array.

Create columns using the cylinder object:

1. In the Create panel > Geometry drop-down
list, choose Standard Primitives.

2. In the Create panel > Object Type
rollout, click Cylinder.

3. In the Top viewport, create a cylinder near
the entrance opening in the lower left of the
rotunda.

4. In the Parameters rollout, change Radius to
0.5m and Height to 19.5m.

5. On the toolbar, click Select And Move.

6. In the Coordinate Display > X field, enter
-57.037m, set Y to 32.79m, and make sure
Z is set to 0.0m.

The cylinder lines up with the right side of the
opening in the Rotunda Glass object, with the
Rotunda Glass passing through the center of
the cylinder.
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7. In the Modify panel, rename the cylinder to
Thin Column 01.

8. In the Top viewport, hold the SHIFT key and
move the Thin Column 01 cylinder so it lines
up with the left side of the opening in the
Rotunda Glass, with the Rotunda Glass passing
through the center of the cylinder.

9. When the Clone Options dialog appears,
choose Instance, and then click OK.

10.In the status bar > Coordinate Display > X
field, enter -63.4m, set Y to 26.52m, and
make sure Z is set to 0.0m.

Array the columns:

Next, you’ll create a circular array of thin columns
with the large column as the center.

1. On the toolbar, choose Select And Rotate,
then click the Reference Coordinate System
drop-down and choose Pick from the list.

2. In a viewport, select the Large Column object.

The name of the object appears in the Reference
Coordinate System field.

3. On the toolbar, from the Use Center flyout,
choose Use Transform Coordinate Center.

This tells to use the Large Column object as the
center point for the cylinders to rotate around
in the array.

4. Press H and select Thin Column 01 from the
list.

5. Right-click in the Top viewport to make it
active.

6. From the Tools menu, choose Array.

7. In the Array dialog, click Reset All Parameters.

8. In the Array Transformation group, under
Incremental, set the Rotate Z axis amount to
23.5 degrees.

9. In the Array dialog > Type Of Object group,
click Instance.

10.In the Array dialog > Array Dimensions group,
enter a 1D Count of 7.

Using instances lets you change all the columns
by editing only one.

11.Click OK to close the Array dialog.

A semicircular array of columns appears on one
side of the rotunda.
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12.Press H and select Thin Column 02from the list.

13.From the Tools menu, choose Array.

You’ll create the same number of instances on
the other side, so you need change only one
setting.

14.In the Array Transformation group, under
Incremental, set the Rotate Z axis amount to
-23.5 degrees.

15.Click OK to close the Array dialog.

A semicircular array of columns appears on the
other side of the rotunda.

Save your work:

• On the menu bar, choose File > Save As. Name
your scene myrotunda.max.

Creating the Main Building

In the next few steps you will use a combination
of 2D Booleans and 3D Booleans to create the
foundation.

Set up:

To start from this point, do one of the following:

1. Continue from the previous step, or open your
saved file, myrotunda.max.

2. If you want to begin the tutorial at this point,
open rotunda.max from the \tutorials\arch
directory. You will have to reassign the viewport
background as you did the previous lessons.

Create the foundation:

In this procedure you will use 2D Booleans to
create a shape and then extrude it to make the
foundation.

1. Right-click in the Top viewport to make it
active.

2. In the navigation controls, click Zoom.
Zoom out of the Top viewport.

3. In the navigation controls, click Pan. Pan
until you see the entire two-story atrium.

4. In the Create panel > Shapes > Splines >
Object Type rollout, click Line.
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5. Create a line following the outline of the
foundation, as shown in the following
illustration. Click at each point, and to end,
click the starting point. When you’re prompted,
Close Spline?, click Yes.

6. In the Rendering rollout, turn on the Enable in
Renderer and Enable in Viewport check boxes.

7. In the Create panel > Name And Color rollout,
enter Foundation.

8. In the Modify panel > Geometry
rollout, click Attach.

9. Press H, select Circle02 from the list, and then
click Pick.

10.In the Geometry rollout, click Attach to
deactivate it.

11. In the Modify panel > Selection rollout,
click the Spline button.

12.In the Top viewport, select the Foundation
spline.

13. In the Modify panel >
Geometry rollout, click Boolean.

By default, Boolean is set to Union. This lets
you combine shapes, eliminating overlapping
geometry.

14.In the Top viewport, click the attached Circle02
object.

The Union operation results in a single spline.

15.In the Modify panel > Selection rollout, click
the Spline button to exit the sub-object level.

This also turns off Boolean.

16.Apply an Extrude modifier.

17.In the Modify panel > Parameters rollout, set
Amount to 1.8m.
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18.On the toolbar, click the Reference Coordinate
System drop-down and choose View.

Create the entrance ramp:

You’ll create a second box and use Boolean to
subtract its shape from the foundation, producing
an entrance ramp for the rotunda.

1. In the Create panel > Geometry > Standard
Primitives > Object Type rollout, click Box.

2. In the Create panel > Keyboard Entry rollout,
set the X axis to -51.041m, the Y axis to
-20.26m, and the Z axis to 0.914m. Set the
Length to 13.7m, Width to 36.5m, and the
Height to 4.5m, then click Create.

Using keyboard entry lets you create an object
of an exact size at a specific location.

3. On the toolbar, click Select And Rotate.

4. Choose Use Pivot Point Center from the
Use Center flyout.

5. On the status bar, set the coordinate display Y
field to 4.0. and the Z field to 45.0.

6. On the toolbar, click Select and Move.

7. On the status bar, set the Coordinate Display
Z field to 1.0.

8. Press H and select Foundation from the list.

9. On the Create panel, click the drop-down list
and choose Compound Objects. On the Object
Type rollout, click Boolean.

10.In the Create panel > Pick Boolean rollout,
click Pick Operand B.

11.In the Top viewport, click the box you just
created.

12.Right-click anywhere in the Top viewport to
exit Boolean.
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This creates a sloped ramp for the entrance.

Save your work:

• On the menu bar, choose File > Save As. Name
the file mybuilding_nowalls.max.

Adding Glass and Columns

In this section you’ll create lines to be used as paths
with the Spacing Tool. You’ll then use the Spacing
Tool to create more columns around the building.

Set up the tutorial:

To start from this point:

1. Continue from the previous step, or open your
saved file, mybuilding_nowalls.max.

2. If you want to start the tutorial from
here, choose File > Open and browse to
\tutorials\arch\ building_nowalls.max.
Highlight the filename and click Open.

Use the Spacing Tool to add columns:

1. In the Create panel > Shapes > Object Type
rollout, click Line.

2. In the Top viewport, create a line for the front
wall.

3. In the Create panel > Name And Color rollout,
enter Front Wall Glass.

4. In the Top viewport, create a second line for the
left wall and rear wall.

5. In the Create panel > Name And Color rollout,
enter Rear Wall Glass.

6. In the viewport navigation controls, click
Region Zoom. Zoom in, centering the region
at the spot where the Front Wall Glass meets
the Rotunda.

The illustration below gives you a rough idea
of how far to zoom in.

7. When the Display Background warning
appears, click No.
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8. Right-click twice in the viewport; once to turn
off Region Zoom, and again to exit the Line
tool.

9. On the toolbar, click Select And Move.

10.Click the Front Wall Glass and move its
endpoint to the center of the nearest column.

Tip: You might not be able to move the line in
two dimensions at first. Because you’re zoomed
in, you can’t use the Transform Gizmo. If you
find this is the case, right-click the blank area
of the toolbar, and display the Axis Constraints
toolbar. Then on the Constraints toolbar, click
XY.

11.Select the column at the endpoint of the
Front Wall Glass and press DELETE on your
keyboard.

12. In the viewport navigation controls, click
Zoom Extents.

13.Press H and select Thin Column 01 from the
list.

14. On the Tools menu choose the Spacing Tool.

15.In the Spacing Tool dialog, click the Pick Path
button.

16.Press H and select Front Wall Glass from the
list.

17.In the Spacing Tool dialog, set Count to 10. If
you use the keyboard, be sure to press the TAB
or ENTER key after typing the number so the
new value registers with the software.

18.Click Apply.

19.In the Spacing Tool dialog, click Pick Path.

20.Press H and select Rear Wall Glass from the list.



14 Chapter 4: AEC

21.In the Spacing Tool dialog, set Count to 18. If
you use the keyboard, be sure to press the TAB
or ENTER key after typing the number so the
new value registers with the software.

22.Click Apply.

23.Close the Spacing Tool dialog.

Attach and clone the wall splines:

Next, you’ll combine the two wall splines and
clone them, as you did with the rings around the
rotunda, to create horizontal steel beams.

1. Press H and select Rear Wall Glass from the list.

2. In the Modify panel > Geometry rollout, click
Attach.

3. Press H and select Front Wall Glass from the
list.

4. Click the Attach button again to deactivate it.

5. On the menu bar, choose Edit > Clone.

6. In the Clone Options dialog > Object group,
choose Copy.

7. In the Clone Options dialog > Name group,
type Steel Wall.

8. Click OK to close the dialog.

9. On the toolbar, click Select And Move if
necessary.

10.In the status bar > Coordinate Display > Z field,
enter 6.1m.

This moves the Steel Wall object up 6.1 meters.

11.In the Modify panel > Rendering rollout, turn
on the Enable in Renderer check box, if it’s not
already on.

12.In the Rendering rollout, set the Thickness to
0.61m.

You can see the result of these settings when
you render your scene or by turning on Enable
in Viewport.

Array the wall splines:

1. On the Tools menu, choose Array.

2. In the Array dialog, click Reset All Parameters.

3. In the Array dialog, under Incremental, set the
Move Z axis to 6.1m.

4. In the Type Of Object group, choose Instance.

5. In the Array Dimensions group > 1D Count,
enter 3.

6. Click OK to close the dialog.

This creates the steel beams that will make up
the horizontal detail of the atrium.

Create the walls:

Now you’ll use Outline to give the wall some
thickness, and then extrude it.

1. Press H and select Rear Wall Glass from the list.
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2. In the Modify panel > Selection rollout,
click Spline to access this sub-object level.

3. Press CTRL+A to select both the splines.

4. In the Modify panel > Geometry rollout, enter
0.03m in the Outline amount field.

You need not click the Outline button.

5. In the Modify panel > Selection rollout, click
Spline to return to object level.

6. From the Modifier menu > Mesh Editing
category, apply an Extrude modifier. Set
Amount to 12.2m.

7. Press H and select Steel Wall 01 and Steel Ring
02 from the list.

Tip: CTRL adds to a selection.

8. On the menu bar, choose Edit > Clone.

9. In the Clone Options dialog > Object group,
choose Copy, and name the clone Main Roof,
and then click OK.

10.Press H and select Main Roof from the list.

Note that the objects were cloned separately,
and the Main Roof name was applied to
the cloned ring; the cloned wall object was
automatically named Steel Wall 03.

Complete the walls:

1. Apply an Edit Spline modifier.

2. In the Modify panel > Geometry rollout, click
Attach Multi.

3. Select Steel Wall 03 from the list and click
Attach.

4. In the viewport, right-click and choose Hide
Unselected.

5. In the Modify panel > Selection rollout,
click Vertex.

6. In the Modify panel > Geometry rollout, locate
the Weld button, then just below it, click the
Connect button.

7. Click and drag to connect the adjacent
endpoints of the splines that made up the walls.

You’ll be creating two splines: one across the
rotunda, and one on the right side of the
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building as viewed from the top. The spline
across the rotunda is necessary because you’ll
be cutting the rotunda shape out of the building
with Boolean, which requires closed splines to
work.

8. In the Modify panel > Selection rollout
click Spline selection, then select the spline that
you just connected.

9. In the Modify panel > Geometry rollout,
choose Boolean Subtraction.

10.Click the Boolean button, and then in the Top
viewport, select the Circle shape.

The circle is subtracted from the building
outline, leaving an arc-shaped cutout.

11.In the Modify panel > Selection rollout, click
Spline to return to the object level.

12.Apply an Extrude modifier and set Amount to
0.15m.

13.In the viewport right-click and choose Unhide
All.

Add the six large columns:

You’ll finish this lesson by using Array to make six
shorter copies of the Large Column object.

1. Press H and select Large Column from the list.

2. On the toolbar, choose Select And Move, if
necessary.

3. In the Top viewport, hold down the SHIFT Key
and move the Large Column over the lower-left
column of the sketch.
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4. In the Clone Options dialog > Object group,
click Copy, then click OK.

5. In the Modify panel > Parameters rollout, set
Amount to 18.0m.

6. Open the Array dialog and click Reset All
Parameters.

7. In the Array dialog, under Incremental, set X
to 23.0m.

8. In the Type Of Object group, choose Instance.

9. In the Array Dimensions group, do the
following:

• Set the 1D Count to 2.

• Click 2D and then set the 2D Count to 3.

• Under Incremental Row Offsets, set Y to
24.0m.

10.Click OK to close the dialog.

This creates a two-dimensional array of six
columns, approximately where they’re drawn
in the sketch.

Save your work:

• On the menu bar, choose File > Save As. Name
the file mybuilding.max.

Creating the Second Building

In this section, you will create a simple primitive
to represent the second part of the building. The
shape is a trapezoid with no visible windows.

Set up:

To start from this point, do one of the following:

1. Continue from the previous step, or open your
saved file, mybuilding.max.

2. If you want to begin the tutorial at this point,
open building1_complete.max from the
\tutorials\arch directory.

Create and modify a box:

1. In the Top viewport, use the Pan tool to
bring the brick building area of the drawing
(labeled "4 story red brick") into view. Zoom
back a little so the entire new building is visible.
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2. In the Create panel > Geometry > Object Type
rollout, click Box.

3. In the Top viewport, create a box as shown,
with a height of 30.0m.

4. In the Create panel > Name And Color rollout,
type Brick Building.

5. Apply an Edit Mesh modifier.

6. Go to the Vertex sub-object level

7. In the Top viewport, use Rectangular Region
Selection to select the vertices on the right side.
Move them down in the Y axis until they line
up with the sketch.

8. Select the vertices along the bottom of the box.

9. Move them up in the Y axis, until they line up
with the sketch.

10.In the Modify panel > Selection rollout, click
Vertex to return to the object level.

Save your work:

• On the menu bar, choose File > Save As. Name
the file mybuildings.max.

Producing a Shadow Study

There are many cases in designing a structure
when you will be required to perform a shadow
study. 3ds Max allows you to easily perform
shadow studies by using the built-in Daylight
system.

Set up:

To start from this point:

1. Continue from the previous step, or open your
saved file, mybuildings.max.
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2. If you want to begin the tutorial at this
point, open shadow_study.max from the
\tutorials\arch directory.

Use a Daylight system:

1. In the Create Panel, choose Systems.

2. In the Object Type rollout, click Daylight.

3. In the Top viewport, drag a short distance in
the Brick Building to create a Daylight compass
and light.

4. Release the mouse button, and move the mouse
while watching the Site group > Orbital Scale
setting. When Orbital Scale reaches about 120,
click to complete the system.

Tip: You can also adjust the Orbital Scale to 120
immediately after you click the mouse.

5. In the Control Parameters rollout > Time
group, change Hours to 9, Mins. (Minutes) to
0, and Secs. (Seconds) to 0.

This changes the sun’s position. Click Zoom
Extents if necessary to see the sun object in the
viewport.

Note: The month and day settings default to the
summer solstice. You can change them if you
like to the winter for more dramatic shadows.

6. In the Location group, click Get Location.

7. In the Geographic Location dialog, choose San
Jose and click OK.

Tip: You can click the map or choose San Jose
from the list.

8. Right-click in the viewport to end the Daylight
creation command mode.

9. On the Rendering menu choose Environment.

10.In the Exposure Control rollout, click the
drop-down list, and choose Automatic
Exposure Control. Make sure Active is turned
on, then close the dialog.

11.If you have a single viewport maximized, press
ALT + W on the keyboard, to display four
viewports.

12.On the Rendering menu, choose Render. At
the bottom of the Render dialog, make sure
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the Viewport is Perspective, if not choose
Perspective from the drop-down list.

13. On the Render Scene dialog, click Render.

Note: This render might take a while because
of the extensive sky calculations required. If
you need to view only shadows from direct
sunlight, you can improve the rendering time
by deactivating the skylight contribution. For
the most detailed rendering, select the Daylight
icon in the viewport, then go to the Modify
panel and choose IES Sun from the Sunlight
drop-down, and IES Sky from the Skylight list.

Save your work:

• On the menu bar, choose File > Save As. Name
the file myshadowstudy.max.

Summary

In this tutorial you have modeled a 3D building
starting from a sketch. You have learned to use a
viewport background as a guide for your work.
You have created geometry using extruded lines,
primitive objects and booleans. You have repeated
objects using Array and the Spacing tool. And
finally you have created a shadow study using the
Daylight system.

Polygon Modeling Features
In this tutorial, you will create a mechanical design
for a toy power charger. The lessons in this tutorial
will teach you to model using Editable Spline and
Editable Poly tools and techniques.

Skill Level: Beginner

Time to complete: 1 hour

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Use Copy Connect with an Editable Spline.

• Use Extrude and Bevel Polygons.

• Use Cut and Slice Tools

• Use Chamfer and Inset

• Compare the use of the Surface modifier with
Editable Poly tools.

Tutorial Files

All the necessary files to do the tutorials can be
found on the Tutorial And Sample Files CD, in the
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\tutorials\new_modeling\ folder, unless otherwise
specified. Before beginning the tutorials, copy the
\tutorials directory from the CD to your \3dsmax8
local installation.

In This Tutorial

Using Editable Spline and Poly Tools (page 2–21)

Creating the Generator Housings (page 2–24)

Fine-Tuning the Housings (page 2–31)

Adding the Power Conduit (page 2–42)

Cutting Holes in Objects (page 2–45)

Finishing the Power Charger Model (page 2–47)

Using Editable Spline and Poly
Tools

The new Copy Connect feature, and other
modeling features, can help you create custom
objects more quickly than before. In this lesson,
you will work with some of these features to create
the base for the toy power charger.

Set up for this lesson:

1. Choose File menu > Open and browse to the
tutorials\new_modeling folder. Open the file
tut_powercharger_start.max.

This file shows a picture of a power charger
design in the Right viewport. You will use this
image as a reference while modeling.

2. Choose Create panel > Shapes >
Rectangle.

3. In the Top viewport, create a rectangle with a
Length of 140 and a Width of 90.

4. In the Right viewport, move the rectangle so it
aligns with the bottom of the reference picture.

5. In the Modify panel, right-click the Rectangle
listing, and choose Convert To Editable Spline.

This makes the Editable Spline parameters
available.

Use Copy Connect to create a spline cage:

1. On the Selection rollout, click Spline to
access the Spline sub-object level.

2. Click the rectangular spline to select it. The
spline turns red to indicate it is selected.

3. In the Geometry rollout > Connect Copy
group, turn on Connect.

4. In the Right viewport, hold down SHIFT
while moving the rectangle upward. Move the
rectangle by about 20 units.
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Tip: Watch the Z coordinate display on the
status bar to determine the number of units you
have moved the object.

This action creates a new spline above the
original, and connecting lines between the two
rectangles form a box-shaped spline cage. You
can see this cage most clearly in the Perspective
viewport.

5. Hold down SHIFT again, and move the
rectangle up by about 2 units.

6. In the Selection rollout, click Vertex.

7. In the Right viewport, move vertices to match
the reference picture.

8. Use the Spline sub-object and Copy Connect to
make additional rectangles from the topmost
one, and adjust vertices to make the object’s
cage match the reference picture.

Note: If segments curve or bend at odd angles,
select all the vertices, right-click, and choose
Corner from the quad menu. This will change
all vertices to the Corner type, and remove
curves from the spline cage.

9. Apply the Surface modifier to the spline cage.
Turn on Flip Normals if necessary, and turn on
Remove Interior Patches.

This puts a surface over the spline cage, forming
a 3D object.

10.Save the scene as my_powercharger_
surface.max.
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You can find a finished version of this scene in
the file tut_powercharger_surface.max.

Create an editable poly:

You can create the same object using the new
Extrude and Bevel dialogs, available for Editable
Poly objects.

1. Load the file tut_powercharger_start.max
again.

2. Choose Create panel > Shapes > Rectangle.
In the Top viewport, create a rectangle with a
Length of 140 and a Width of 90.

3. Apply the Extrude modifier to the rectangle,
and set Amount to 20.

4. In the Modify panel, right-click the extruded
rectangle, and choose Collapse All. If a dialog
appears asking you to confirm that you want
to continue, click Yes.

This converts the object to an Editable Mesh.

5. Right-click the Editable Mesh listing in the
Modify panel, and choose Convert to Editable
Poly.

This causes the Editable Poly options to become
available.

Use Extrude and Bevel dialogs:

1. In the Selection rollout, click Polygon.

2. In the Perspective viewport, select the polygon
at the top of the object.

3. In the Edit Polygons rollout, click the
Settings button next to Bevel.

This displays the Bevel Polygons dialog.

4. Change Height to about 2, and Outline Amount
to about -5.

5. Click Apply.

This sets the bevel, and displays the next bevel
for the same Height and Outline Amount.

6. Set Height to 9, and Outline Amount to -3.
Click Apply.
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7. Continue to extrude and bevel the polygon to
match the left side of the reference picture.

In the Perspective viewport, you can see that
the object created with the Bevel option is quite
different from the one created with the spline
cage and the Surface modifier.

Adjust the bevels:

1. In the Selection rollout, click Vertex.

2. In the Right viewport, adjust vertices to match
the reference picture.

Tip: It can be easier to shape the object if you
make it see-through. To do this, right-click
the base and choose Properties from the quad
menu. In the Object Properties dialog >
Display Properties group, click By Layer to
change to By Object, and turn on See-Through.
Click OK to close the dialog.

3. In the Front viewport, move the vertices at
the top of the base to straighten them out, if
necessary.

4. Save the scene as my_powercharger_
bevel.max.

You can find a finished version of this scene in
the file tut_powercharger_bevel.max.

Creating the Generator Housings

Now you’ll use some sculpting tools to begin to
carve and shape the base.

Load the sample file:

1. Continue from the previous lesson, or
choose File > Open and browse to the
\tutorials\new_modeling folder. Open the file
pcharger_powerbase.max.

This scene shows two viewports, Top and
Perspective. A sketch of the powercharger from
an angle is displayed in the Top viewport, while
the base shows in the Perspective viewport.
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2. If you are continuing from before
you can hide the frozen template shape. On
the Display panel > Hide rollout, turn on Hide
Frozen Objects.

3. Also, if you are continuing from the previous
section, activate the User viewport and then
press P on the keyboard.

The User viewport is changed into a Perspective
viewport. This will let you model while seeing a
more natural view.

4. Press G on the keyboard to turn off the display
of the grid, if your viewport doesn’t match the
following illustrations.

Press G whenever you want to turn the grid on
or off. Keep in mind that the grid no longer
stretches infinitely. In this scene, the grid is
turned on, but hidden under the base object.

Convert to editable poly:

You’ll start by adjusting the extrusion amount,
and then converting the object to an Editable
Poly object. The latter step gives you access to
polygon-modeling tools.

1. Select the object in the viewport, if it’s not
already selected.

2. In the Modify panel, increase the
extrusion Amount setting to 50.

3. Right-click the object and from the quad menu
choose Convert to > Convert To Editable Poly.

The Modify panel now shows the editable poly
parameters and tools. You no longer have
access to the extrusion settings.

Tip: Only convert objects to Editable Poly, or
similar, if you’re certain you won’t need to alter
the original primitive object or any modifiers
you’ve applied to it. If you’re not sure, perform
a Save As to give yourself a version of the scene
that you can reload.

Scale the bottom polygon:

1. Rotate the viewport so you can see the
bottom of the base.

2. On the Selection rollout, click the Polygon
button.

3. Select the bottom polygon.

If the polygon does not turn red, press the F2
key to turn on the Shade Selected Faces feature.
This will cause any selected polygons to turn
red in viewports.

4. On the toolbar, click the Scale button.

5. Position the cursor over the selected polygon,
and then drag upward to enlarge it slightly.
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Make sure your cursor is in the center triangle
of the scaling gizmo. If you place it over one of
the extended handles, like the X or Y axis, you
will mistakenly scale the surface along one axis.

6. Use SHIFT+Z to undo the viewport rotation.

You see the base from the original vantage point
again.

Now it’s starting to look like a good solid base.

Cut vertices to make new edges:

The Cut tool lets you cut new edges between
vertices and edges. This is a fundamental
technique for adding extra surfaces for sculpting.

You’ll be working on the top surface of the
power base, so you might want to use Arc Rotate to
rotate the view so you have a better view of the top.

1. In the Modify panel, click the Vertex
button, and then in the Edit Geometry rollout,
click Cut.

2. On the top of the polygon cut from one vertex
to another as shown in the first illustration
below. Click one vertex, then move the cursor
and click the next vertex to create the cut.
Right-click to stop cutting temporarily. Make
a second cut across the top as shown in the
second illustration. At the end of the second
cut, right-click twice to exit Cut.

Left: The first cut across the rear. Right: The second cut
across the front.

3. Change the selection level to Edge, and
again turn on Cut.

The edges you just cut are now red. When you
use Cut at the Edge sub-object level, you can
cut anywhere along an edge.

4. Make two cuts between the two new edges to
create a new polygon on the top of the base.



Creating the Generator Housings 27

Tip: To better see the cut being made, you
can watch the narrow, Top viewport to
make sure the new edge is relatively straight.
Before making the cuts, right-click the Top
viewport label and temporarily turn off Show
Background.

Next you’ll select the new polygon you’ve cut in the
top of the base to bevel and extrude it.

Bevel polygons:

1. In the Selection rollout, click the Polygon
button.

2. Select the new polygon inside the edges you
just created.

3. Right click the polygon and, from the
quad menu > Tools 2 quadrant, choose Bevel
Settings.

The Bevel Polygons dialog appears.

4. Set the Height setting to 20 units. Set the
Outline Amount to -2. Click Apply.

5. Set a new Height of 50 units. Leave the Outline
Amount at-2 units. Click OK to complete the
Bevel operation.

6. Right-click the polygon and choose Rotate
from the quad menu.

7. Using the following illustration as a
guide, rotate the top polygon in the Perspective
viewport. Use the Transform gizmo to rotate
the polygon about the X axis. Move your cursor
over the X, and when it turns yellow, drag to
rotate the polygon.
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8. Right-click and choose Move from the quad
menu.

9. Move the top polygon back and up to form
a slope, again trying to match the following
illustration (don’t worry about being too
precise). Use the Transform gizmo handle (the
box at the intersection of the Y and Z axes) to
move in the YZ plane.

10. Use Arc Rotate to rotate the viewport all
around to see the object from different angles.

11. Turn on Vertex mode and select the
two topmost vertices, then scale them together
slightly to taper the shape.

When scaling the vertices, place your cursor
over the X axis handle to scale only along that
axis.

12. Select the next set of vertices down, as
shown in the following illustration. Move those
vertices backward, along the Y axis using the
transform gizmo.

Tip: When the Y handle turns yellow, you can
move the vertices only along the Y axis.

Select and move the red vertices.
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Tip: You can achieve the same result by
moving the edge between the two vertices, at
the Edge sub-object level.

Next you’ll slice the object into two parts, deleting
one half and replacing it in the viewport with an
instance of the other side. That way any further
sculpting you do will be repeated automatically
in the instance. This cuts down your work and
ensures the object will appear symmetrical.

Slice the object in half:

1. In the Selection rollout, click the Polygon
button.

2. Drag a selection rectangle around the entire
object.

All the polygons are selected in the viewport.

3. In the Edit Geometry rollout of the modify
panel, find and turn on Slice Plane.

The slice plane appears in the viewport.

4. Rotate the slice plane 90 degrees about
the Y axis, so it is vertical. Watch the coordinate
display near the bottom of the screen as you
rotate the Slice Plane.

Tip: To be precise, you can also type 90 in the Y
coordinate field. The Slice Plane does not have
to be centered on the object to slice it properly.

5. When the Slice Plane is appropriately
positioned, click the Slice button.

Notice that the object has new edges following
the slice plane.

Rotate the slice plane, and then click Slice.

6. Turn off Slice Plane.

7. Arc Rotate the viewport so you are looking
at the base directly from behind. Right-click in
the viewport to exit Arc Rotate mode.

8. Hold down the ALT key and drag a selection
window around the polygons on the right side
of the cut.

Tip: Start the selection window outside the
object.

Also, if you don’t succeed in selecting
all the polygons, first make sure the Crossing
Selection toggle on the main toolbar, is active.
That is, the button image depicted here should
appear, not the highlighted Window Selection
image. If the latter is true, click the button to
return to Crossing Selection.
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Holding down the ALT key while selecting subtracts
from the selection set.

9. Press DELETE to remove the selected polygons.
Click Yes to delete isolated vertices.

Now half the object has disappeared.

10.Use Arc Rotate to rotate the viewport around
the object.

You can see through the polygons when looking
from the inside of the object. That’s because, by
default, 3ds Max shades only the "outward" side
of polygons. The visible side of a polygon is
determined by the direction of its face normal,
which you can specify. For detailed information
on this topic, see Normals in the 3ds Max
online reference.

Direction of face normals makes polygons see-through.

11.Rotate the viewport back so you can see the
visible half of the base.

12. Using the following illustration as a guide,
select the uppermost edge and move it along
the Z and Y axes. Don’t move it along the X axis
or you will disrupt the symmetry of the object.

13.Again, following the illustration, select the next
edge down and move it up along the Z axis as
well.

Select and move these edges.

14.Swing the view around to the other end and
raise the middle edge, as shown in the following
illustration.

3dsviz.chm::/normal_glossary.html
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Select and move the forward edge.

Make the instance of the opposite half:

1. Click Edge selection again to turn it off.

2. On the toolbar, click Mirror.

3. In the Mirror dialog that appears, choose
Instance.

4. Move the Mirror dialog so it is not obstructing
your view of the object and the mirrored
instance in the viewport.

Mirrored instance

5. Adjust the Offset spinner until the two objects
are touching.

Offset closes the gap.

The new object is named Line - Base Extrusion01.

6. Choose File > Save As and save your scene as
my_charger3.max.

Fine-Tuning the Housings

Next, you will select and chamfer various edges
to round the base, and then select and extrude
polygons to create an indentation in the charger.

Load the starting file:

• Choose File > Open and browse to the
\tutorials\new_modeling folder. Open the file
pcharger_powerbase2.max.

Chamfer the edge:

1. Select the Line - Base Extrusion object.

2. Turn on the Edge selection level. Select all
the edges illustrated; these make up the upper
edge of the base of the charger. You might need
to use Arc Rotate to move around the object to
get all the edges. After selecting the first edge,
hold down the CTRL key to add to the selection
of edges.
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Select all these red edges.

3. When all the edges are selected, turn on
Chamfer Settings on the Edit Edges rollout to
display the Chamfer Edges dialog, and set the
Chamfer Amount to 5 units. Click OK to close
the dialog and set the chamfer.

Chamfered edges

Change the color:

To make it easier to see the selected edges while
working, you will lighten up the Gray Block
material color.

1. Open the Material Editor. Click Pick
Material From Object, and click the base in any
viewport.

This selects the material assigned to the selected
object.

2. In the Blinn Basic Parameters rollout, click the
Ambient or Diffuse color swatch and change
the Red, Green, and Blue Values to lighten the
Gray Block color. Make it a lighter gray by
setting all three values to 150.

3. Close the Material Editor.

Chamfer more edges:

Next, you will chamfer more edges to continue
rounding the generator housing.

1. Select the edges shown in the illustration below.
These make up the profile of the upper front
of the power charger.

Selected edges

2. Turn on Chamfer, then position your cursor
over a selected edge, and drag the mouse to
chamfer. Watch the edges chamfer on the
instanced half.
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Chamfer the edges.

Now you will create an indented area at the front
of the base.

Create an inset:

1. Turn on the Polygon level, and then
select the two polygons shown in the following
illustration.

Select these red polygons.

2. Click Extrude Settings and set the Extrusion
Height to -10 units. Click OK.

Negative extrusion creates inset.

3. Select the polygons illustrated below, left
behind from the extrusion on the inner side of
the base, and delete them. In the Delete Isolated
Vertices dialog, answer Yes.

4. Choose File > Save As and save the scene as
my_charger4.max.

Round the base:

1. Turn on Edge mode.

2. Select and chamfer the edges shown in red in
the following illustration, along the outer top
edge of the charger.
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Select these edges.

3. Drag the mouse to create a chamfer that is close
to matching the following illustration.

Chamfer to round the base.

4. Use Arc Rotate in the viewport so you can
see the other side of the base.

5. Select the edges at the rear of the charger.
Select the edges shown red in the following
illustration; these make up the rear corner of
the charger.

Select these edges.

6. Chamfer these edges to round the back of the
generator housing.

Chamfer more edges.

Next you’ll cut some new edges in preparation
to make a cleaner model.

Cut new edges:

1. In the Edit Geometry rollout, click Cut. Cut two
new edges as shown in red in the illustration.
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Cut two new edges, as shown in red.

2. Select the red edges between the new cuts.

Select these three edges.

3. Press the Delete key to remove the edges.

This leaves a hole in the object that you will
have to fill.

Deleting the edges leaves a hole in the mesh.

4. Turn on the Polygon sub-object level. On
the Edit Geometry rollout, click Create. Move
your cursor over one of the corners of the
opening created by deleting the edges and click.
Move the cursor to the next corner and click.
Continue clicking each corner and be sure to
click the first corner again to complete polygon.
In total, you will click five times.

The polygon is selected when the polygon is completed.

5. Turn on the Edge sub-object level again.
On the Edit Geometry rollout, turn off Create,
and click Cut. Make four cuts across the rear
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polygon, as pictured below. Turn off Cut when
you’re finished.

Add four cuts to these edges.

6. In the Selection rollout, change to the
Vertex sub-object selection level.

7. Start by selecting the top, center vertex of the
first new edge, and then on the toolbar, change
the Reference Coordinate to Local.

Notice the change in the transform gizmo.

8. Move the top vertex along the Local X
axis so it moves up along the plane of the back
of the base.

9. Keep selecting and moving the vertices on
the new edges, one at a time, to resemble the
illustration below.

Tip: Use Arc-Rotate to look at the vertices from
the side to make sure they haven’t moved off the
plane of the back of the base. Press SHIFT+Z
to undo the viewport rotation.

Reposition these vertices one at a time.

10. Turn on the Polygon sub-object level.
Select the two polygons outlined by the vertices
you moved in the previous step (they form
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a rough semicircle), and then extrude them
inward about -30.

Tip: By clicking the Settings button next to
Extrude, you can enter a precise Extrusion
Height value.

Negative extrusion creates an indentation.

11.Select and delete the polygons that divide the
extrusions.

Now you have a hollow in the base.

Remove the dividing polygons.

12.Save your scene as my_charger5.max.

Repeat the same edge creation and extruding
process on the side (as shown) to create another
indentation in the base.

Create another inset:

1. On the toolbar, change the Reference
Coordinate to View.

2. Turn on Edge sub-object level and make
the first cut across two edges.

Cut two edges at once.

3. Make a second cut parallel to the first but a little
forward.

Add a second parallel cut.

4. Turn off Cut and select the middle edge.
Move it upward, as shown in the illustration.
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Lift up this red edge.

5. Turn Cut on again, and make another cut
between the new edges.

Add a cut parallel to lifted edge.

6. Turn on Vertex sub-object level and
move the two new vertices created by the cut
to resemble the hexagonal shape shown in the
illustration.

Move each vertex outward to form a hexagonal border.

7. Select the two polygons and Bevel them
inward. Click Bevel Settings and set the Height
to -10 units. Set the Outline Amount to -5.
Click OK.

Negative bevel and extrusion

8. Hold down the CTRL key and add the new
interior bevel faces to the selected polygons,
then move the inset upward, as shown.
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Raise the inset up.

Cut from vertex to edge:

You’ll use Cut to add more detail.

1. Turn on Edge sub-object level, and then
turn on Cut.

2. Make a cut as shown in this illustration.

Cut to add this red edge.

You’ll use Cut again on the back side, and then
combine the two new corner vertices into one
using Weld.

Weld vertices:

1. Cut another edge along the back of the base, as
shown by the red line in this illustration.

2. Turn on the Vertex sub-object level,
and then drag a selection window to include
the ends of the two edges. Be careful to only
encompass the two vertices.

The two vertices turn red.

3. Click the Weld Settings button and set the
Weld Threshold to 10, then click OK. If the
selected vertices are not within the threshold,
nothing will happen. If this happens, increase
the threshold, and click OK again.
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The vertices are welded.

4. Save your scene as my_charger6.max.

Complete the power base:

As you can tell, it can be a complicated and
time-consuming process to build a model using
polygon modeling techniques. To create the
intended power generator housing, you need to
repeat the things you’ve learned; cutting, beveling
and extruding, and then moving vertices and
edges, over and over again.

You can repeat these steps and techniques to make
your own version of the base. But rather than ask
you to go through all of these steps now, we’ll just
give you a quick overview of the remaining steps.
You can try them yourself, or simply go to the next
procedure and unhide the finished power base,
which is currently hidden from view.

By following the upcoming illustrations, you can
add an inset by cutting many extra edges, then
select polygons and give them a shallow negative
extrusion and a wider outline.

1. Cut extra edges as shown in the following
illustration.

Selection set of the newly made polygons

2. Use the Bevel tool to create the indentation
shown below.

Bevel an inset

3. You can select polygons around the corner and
use a positive extrusion and negative bevel
outline.
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Select polygons around a corner to create a blister.

4. Clean up the rear center by deleting polygons
and moving vertices together.

Cleaned up center-line

5. You can extrude and bevel a plate on the sloped
top of the power base.

Create a top plate.

6. Cut new edges in that plate, then reposition the
edges and vertices to round the top.

Round the top plate by lifting edges.

Unhide the finished model:

1. In the modifier stack, click the Editable Poly
to return to the base level of the object. The
Editable Poly listing turns gray.

2. Drag a selection rectangle around the two
objects in the viewport to select them.
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3. Go to the Display panel. On the Hide
rollout, click Hide Selected.

4. Now choose Unhide By Name. Hold down
CTRL and choose Generator Housing Left
and Generator Housing Right Instance. Click
Unhide.

Completed model of power charger base unit

5. If you like, you can unhide half of your model
and half of the completed model as a template
to help you shape your own work.

Unhide right half as a template.

Adding the Power Conduit

In this exercise you will add a primitive object: a
cylinder to create a power conduit. You’ll rotate it
and then move it into place in the base.

Open a starting file:

• Choose File > Open and browse to the
\tutorials\new_modeling folder. Open the file
pcharger_powerbase3.max.

This file has a different viewport configuration,
with four visible viewports instead of two.

Enlarge the viewport:

1. Click anywhere in the Left viewport to activate
it.

The viewport outline changes color to show it
has been activated.

2. Position the mouse cursor over the divider bar
at the top of the Left viewport, so it becomes a
vertical two-headed arrow. Move it upward so
the Perspective viewport becomes smaller.

The Left viewport is now larger and ready for
your work.

Create a cylinder:

1. On the Create panel, go to the Geometry
section, and then in the Object Type rollout,
click the Cylinder button.

Now 3ds Max is ready to create a cylinder,
wherever you want.

2. Drag the mouse to the left of the generator
housing to define the radius of the cylinder.
Any radius will do; you’ll set the proper size in a
few steps. Release the mouse button.

3. Now, move the mouse to define the height of
the cylinder; again, any height will do for the
moment. Click to set the height.
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4. In the Create panel > Parameters rollout, set
Radius=36 and Height=60.

Transform the cylinder:

1. Right-click to end the cylinder creation, then
right-click the object to access the quad menu.

2. From the Transform quad choose Rotate.

3. If necessary, press the = key on the keyboard to
increase the size of the Transform gizmo.

4. Move your mouse over the Y axis; when it turns
yellow, drag to rotate the cylinder. Watch the
coordinate readout above the rotation gizmo
as you drag. When Y gets to -90, release the
mouse button.

Now the cylinder is pointing away from the
power base.

Cylinder from the side

5. Rotate about the Z axis -35 degrees.

Note: You can see only the blue tip of the
Transform gizmo Z axis, but you can still use it
for rotation.

Rotated cylinder

6. Right-click, and from the Transform quadrant,
choose Move.

7. Use the corner handle to move the cylinder
along the XY plane. Position it so the pivot
point is inside the indented socket in the power
base, as shown in the following illustration.

Position the cylinder like this.

8. Right-click the viewport label, and change the
viewport shading from Wireframe to Smooth
+ Highlights. Also turn on Edged Faces, if it
isn’t on already.

9. Name the cylinder Power Conduit - Base.

10. Rotate the viewport so you can see how
the cylinder fits in the socket.



44 Chapter 4: AEC

11.Go to the Modify panel, and in the Parameters
rollout, set Height Segments to 1 and Sides to
10.

Keeping geometry simple is an important
aspect of designing game art.

Now that the cylinder is rotated you can choose
to move it along its own rotated local axis. This
is handy when objects have been aligned to other
object surfaces.

Move in the local coordinate system:

1. On the toolbar, click the Move button.

2. Also on the toolbar, click the Reference
Coordinate System drop-drown, which
currently displays "View," and choose Local.

Tip: The Reference Coordinate System list name
doesn’t appear in the user interface, but you can
see it in the tool tip that appears if you hold the
mouse cursor over the list for a moment.

Tooltip shows the name

The Transform gizmo arrows in the viewport change.

Transform gizmo arrows align to the local axes of
selected objects.

3. Move the power conduit up along the local Y
axis.

Tip: Choose the transform first, then the
reference coordinate system. Each transform
(move, rotate or scale) can use a different
system.

The Power Conduit - Base moved closer to the top of the
Generator Housing.

4. Right-click and convert the cylinder to an
Editable Poly, then bevel and extrude the
cylinder cap to create a more interesting
conduit. Repeat the techniques you already
know for bevel and extrude.

Tip: Or you can hide your conduit and unhide
the object named Cylinder01.

Finished power conduit

Next, you’ll apply the Gray Block material to the
cylinder.
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Change the conduit material:

1. On the toolbar, click the Material Editor
button.

2. Drag the Gray Block material to the cylinder
in the viewport.

Except for the edges, now the power conduit
looks like it is made of the same material as the
power base.

Note: If you want the edges to appear black, like
the power base, remember to change the object
color in the Name and Color field. Click the
color swatch and change it to the black color in
the Custom Colors line.

3. Save your work as my_charger7.max.

Next you will build the two-hole housing. You
will learn to cut holes in geometry using the
Boolean compound object while you make this
next part of the charger.

Cutting Holes in Objects

You can combine multiple primitive objects
together in a compound object. In this lesson, you
will use two cylinders to cut out holes when you
model the two-hole housing.

Open a starting file:

• Continue with the file from the previous lesson,
or choose File > Open and browse to the
\tutorials\new_modeling folder. Open the file
pcharger_powerbase4.max.

You can build primitive objects directly on the
surface of another object with the AutoGrid
feature. Here you will create the cylinders directly
on the side of the housing.

Create primitives with AutoGrid:

1. On the Create panel, in the Object Type rollout,
click Cylinder.

2. In the same rollout, turn on AutoGrid.

Before you proceed, examine the illustration
below to see what you’ll be creating. You will
create two cylinders to use as boolean cutout
objects.

3. In the Left viewport, drag to create the radius of
a cylinder near the rounded back corner. When
you release the mouse button, you will then
set the height. Drag downward so the Height
setting is a positive number. Set the Height to
about 25.

4. In the Parameters rollout, set Height Segments
to 1, if necessary, and Sides to 10.

5. Create another, smaller cylinder near the lower
right of the housing. Again, drag downward so
the cylinder has a positive height.

6. Right-click to finish adding cylinders.

7. Hold down the CTRL key and click the first
cylinder.

Both cylinders should now be selected.

8. On the toolbar, click the Move button
and change the reference coordinate system to
Local.

9. Move the two cylinders so they intersect the
housing.
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They should just be sticking through the
housing.

Position the two cylinders so they protrude like this.

You can use the Boolean compound object to cut
holes in other objects.

Create the Boolean compound object:

1. Select the housing.

2. In the Create panel, to the right of Standard
Primitives, click the down arrow and choose
Compound Objects from the list.

3. In the Object Type rollout, click Boolean.

4. In the Pick Boolean rollout, click Pick Operand
B. Then click the larger cylinder in the viewport.

The cylinder disappears and a hole appears in
the housing.

Hole created through Boolean subtraction

5. Click the Boolean button again (even though
it’s already highlighted).

This "sets" the first subtraction.

6. Click Pick Operand B again, and this time click
the smaller cylinder.

Subtract the second cylinder to create another hole.

The cylinder disappears and a second hole has
been cut in the housing.

Tip: You can pick each operand in the modifier
stack and make changes to it to move the
position or depth of the holes.
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7. Hide your work and unhide Two-hole
Housing-Left and Two-hole Housing-Right.
The finished model of the two-hole housing
appears.

8. Save your work as my_charger8.max.

Next you will make another power conduit and
some struts.

Finishing the Power Charger
Model

You’ll complete the power charger using versions
of methods you learned earlier in the tutorial,
but you’ll also learn a new technique that lets you
create a new object based on an existing object’s
position and orientation.

Open a starting file:

• Choose File > Open and browse to the
\tutorials\new_modeling folder. Open the file
pcharger_powerbase5.max.

Clone the conduit:

1. Click to select the Power Conduit - Base object
in the viewport.

2. Right-click and choose Rotate from the
Transform quadrant.

3. If necessary, press the = key to enlarge the
Transform gizmo.

You’ll clone the object as you rotate it.

4. Hold down the SHIFT key and then rotate the
object about the X axis by 90 degrees.

Watch the coordinate display in the status bar
or next to the gizmo as you rotate the object.

5. In the Clone Options dialog, make sure Copy
is chosen, name the object Power Conduit -
Midlink. Click OK.

6. On the toolbar, click the Select And
Move button, and then make sure the reference
coordinate system is set to Local.

7. Position the clone so it is between the four
strut landings (the flat planes on the top of the
two-hole housing). First move it in the YZ
plane, then on the X axis.

8. Use Arc Rotate to rotate the viewport so
you can see the new position from another
angle.

Move in local YZ plane.
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Move on local X axis.

Rotate the view.

9. Zoom in and position the clone so it
intersects with the two-hole housing.

Position the clone like this.

10. On the toolbar, click and hold the Scale
button to show the Select And Scale flyout.
Choose Non-Uniform Scale, and then set the
reference coordinate system to Local.

Choose local coordinate system.

11.Scale the conduit along the local Z axis to
shorten it.

You can use the same technique to make the struts.
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Create a strut:

1. Hold down the SHIFT key and then use Select
And Non-Uniform Scale in the Local Z Axis
so the clone (Copy) is taller than the conduit.
Name the new object PowerStrut.

2. Use the corner gizmo to select the XY plane and
scale the PowerStrut object so it has a narrow
radius.

Non-Uniform scale to narrow the radius.

3. Move the PowerStrut so it is positioned directly
over one of the strut landings.

Position the PowerStrut object like this.

You’ll employ a neat trick now, by choosing the
reference coordinate system of the two-hole
housing to clone the other struts.

Instance the other struts:

1. Make sure the Move tool is still active,
and then from the reference coordinate system
list, choose Pick. Then click either side of the
two-hole housing in the viewport.

The name of the object you have selected (either
Two-hole Housing - Left or Two-hole Housing
- Right) appears in the reference coordinate
system field.

2. Now use Shift-Move to position a clone of the
strut object to the other side of the two-hole
housing. In the Clone Options group, choose
Instance. Click OK.

Moving in another object’s coordinate system

Since you are in the coordinate system of the
housing, the new strut aligns easily.

3. Hold down the CTRL key and click the original
strut. Now, with the two struts selected, use
Shift-Move again to create the two back struts.
Again, in the Clone Options group, choose
Instance and click OK.



50 Chapter 4: AEC

The strut instances

4. Click Select and Non-Uniform Scale, and
choose Use Pivot Point Center. Scale the struts
along the Z axis using the Two-hole Housing -
Left coordinate system. Scale them so they are
just slightly taller than the power conduit.

Tip: Watch the struts in the Left viewport to
better gauge the size of the struts.

Unhide more components:

1. Select and hide the Power Conduit - Midlink
and the PowerStruts objects.

2. Unhide Cylinders 02 - 06 to display the
pre-modeled power conduit - midlink and
powerstruts.

3. Unhide Box03 and Box04 to display the
one-hole housing.

4. Unhide Box01 and Box05 to display the no-hole
housing.

5. Unhide Cylinders 07 - 12 to display the upper
power conduit and the additional struts.

These parts were all made with techniques you
have already learned.

You’re almost finished creating the power charger.
All that remains is to model the turret and barrel.

Create the turret and barrel:

1. Rotate your viewport so you can see the
front of the no-hole housing.

Starting viewport looks like this.

2. On the Create panel, choose Sphere from the
Object Type rollout.

3. Turn on AutoGrid.

4. Create a sphere at the front of the no-hole
housing.

5. In the Parameters rollout, turn on Base To
Pivot.

This moves the base of the sphere to its pivot
point, which is normally in the center. That way
the sphere is fully visible when using AutoGrid.

6. Set Hemisphere to 0.5. Use the spinner and
watch in the viewport.

7. Set Radius to 40 units.

8. Set Segments to 15.
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Create a hemisphere for the turret.

There are many objects in the viewport now,
so it’s getting difficult to see what’s going on.
Next, you’ll use the Isolate function to make
modeling the barrel easier.

Isolate the turret:

• With the sphere selected, from the Tools menu,
choose Isolate Selection.

All the objects in the scene are hidden except
for the turret.

Tip: If you still see the original Start Shape
object, go to Display panel > Hide rollout and
turn on Hide Frozen Objects.

Model in Isolate mode:

1. Right-click the hemisphere and choose Convert
To > Convert To Editable Poly.

2. If necessary, rotate the view until you can see
the front of the hemisphere.

3. On the toolbar, from the Region
Selection flyout, choose Circular Selection
Region.

4. In the modifier stack, expand Editable Poly and
click Polygon.

5. In the Selection Rollout, turn on Ignore
Backfacing.

Tip: This step is important. If you don’t turn
on Ignore Backfacing, you’ll be selecting more
polygons than you need.

6. On the toolbar, click Select Object.

7. Starting at the center, drag a selection circle to
select the top two rings of polygons at the top
of the hemisphere. You need only drag outside
the innermost circle of polygons to pick up
both rings.

Drag a selection circle within the second ring of
polygons.

Result: all these polygons are selected.
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8. Flatten the top of the hemisphere by
non-uniform scaling the faces along the Local
Z axis.

Remember to change the reference coordinate
system.

9. Once the faces are flat, move the
polygons back toward the hemisphere.

Scale and move along the local Z axis.

10. On the toolbar, click the Select Object
button, and then select only the inner circle of
polygons, by dragging a circle. Once you’ve
selected these polygons, extrude them, and
then bevel and extrude a few times to create the
charger gun barrel. Use a negative extrusion to
create the hole in the barrel.

Select these red polygons.

11.Use Extrude to begin building the barrel. Use
the following illustration as a guide for the
extrusion height.

Creating the barrel.

12.Next, use Bevel to construct the end of the
barrel. Use Bevel Settings because you’ll make
several extrusions and bevel to form the end.
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Bevel and finish with negative extrusion.

13.Click the yellow Exit Isolation button to exit
Isolate mode and view your finished model. If
necessary, move or rotate the gun barrel a little
to align it better with the rest of the model. You
can also open the Material Editor and drag the
Gray Block material to the barrel.

If you don’t see all the geometry click Zoom
Extents in the viewport navigation controls,
and the entire model should reappear.

Finished model of the power charger.

You can find a finished version of this model in
the file tut_powercharger_complete.max.

Summary

In this tutorial, you learned how to convert 2D
shapes to 3D objects. Then, using low polygon
modeling techniques, you learned how the
sculpting tools in 3ds Max can be used to create
more complex objects.

Creating a Luminaire
Assembly
An assembly is a special collection of objects that
exposes a set of new parameters on the Create
and Modify panels. With a luminaire assembly,
you can expose several parameters used by lights,
and use parameter wiring to make the luminaire’s
parameters control other parameters in the scene.
Then you can interact with the light quickly and
easily when using it in a scene.

Set up for this lesson:

1. From the tutorial\luminaire_assembly folder,
open the file tut_luminaire_assembly_
start.max.
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This file contains a light fixture that has been set
up with inverse kinematics. You can cause the
light to point in different directions by moving
the light target. When you do so, the light head
and yoke swivel to accommodate the light’s
direction.

2. Select the parts of the model, and observe the
object names in the Create or Modify panel.

In this lesson, you will wrap the bracket, yoke,
and head into a luminaire assembly, which will
expose the dimmer and color settings for the
light source.

Create the assembly:

1. Select all objects in the scene except the light
target.

2. Choose Group menu > Assembly > Assemble.

The Create Assembly dialog is displayed, with
the Luminaire head object selected.

3. On the Create Assembly dialog, enter the name
MyAssembly, and click OK.

4. Go to the Modify panel. The luminaire
assembly has two parameters: Dimmer and
Filter Color.

Open the assembly and check the pivot point:

To work with the assembly, you will need to check
its pivot point, then wire the assembly’s parameters
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to parameters in the scene. To accomplish these
things, you will need to open the assembly.

1. With the luminaire assembly selected, choose
Group menu > Assembly > Open.

The luminaire icon appears in viewports near
the bracket. You can see it most clearly in the
Top and Perspective viewports.

This icon represents the luminaire helper
object, which is created automatically when
you create luminaire assembly. You can see and
select it only when the assembly is open.

2. Select the luminaire icon.

3. On the Hierarchy panel, click Pivot, and
turn on Affect Pivot Only.

The luminaire icon’s pivot point is at the bottom
of the bracket. This location will work well for
this lesson.

4. Turn off Affect Pivot Only.

Wire the light’s intensity to the Dimmer parameter:

Parameter wiring causes one parameter in the
scene to control another. Next, you will use
parameter wiring to make the Dimmer parameter
control the light’s intensity. The assembly should
still be open for this procedure.

1. Select the luminaire helper icon, if it is not
already selected.

2. In the Front viewport, right-click the object,
and choose Wire Parameters from the quad
menu.

3. From the menu that pops up, choose Object
(Luminaire) > Dimmer.

4. Move the cursor to the light itself to create a
dotted line connecting the icon to the light, and
click the light.

5. From the menu that pops up, choose Object
(Target Point) > Multiplier.

The Parameter Wiring dialog is displayed. In
the window on the left, the Dimmer parameter
is selected, and in the window on the right,
Multiplier is selected. On this dialog, you will
establish the relationship between these two
parameters.

6. Click the double-headed arrow at the top center
of the dialog to establish a two-way relationship
between the parameters.

7. Click Connect to establish the relationship.

Now you will wire the luminaire’s and light’s
Filter Color parameters together.

8. Highlight the Filter Color parameters on both
the left and right sides of the dialog.

9. Click the double-sided arrow, and then click
Connect.
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10.Close the Parameter Wiring dialog.

Test the wiring:

1. Choose Group menu > Assembly > Close to
close the assembly.

2. Create an object to illuminate, such as a box or
a sphere.

3. Move the light target to point at the object, and
arrange the Perspective view to show side of the
object that is illuminated.

4. Render the Perspective view.

5. Select the luminaire assembly. On the Modify
panel, change the Dimmer value and Filter
Color.

You should see the light intensity and color
change in the viewport.

6. Render the Perspective view again.

The lighting on the object has changed to reflect
the luminaire parameter changes.

7. Save the scene as my_luminaire.max.

You can find a finished version of this scene in
the file tut_luminaire_assembly_finish.max.

Working with the Layer
Manager
The Layer Manager in 3ds Max is a powerful tool
for organizing and managing objects in complex
scenes. In this lesson, you will use the Layer
Manager to create a new layer from a selection set,
to change the properties of a group of objects, and
then to turn off a group of lights.

Note: The Layer Manager can be accessed from the
main toolbar; however, this lesson uses additional
layer commands found on the Layers toolbar,
which is hidden by default. To display the Layers
toolbar, right-click a blank space on the main
toolbar and choose Layers from the pop-up menu.

Set up the scene:

1. From the \tutorials\layer_manager directory,
open library.max.

If you see the File Load: Units Mismatch dialog,
choose the option Adopt The File’s Unit Scale.
This will change your system unit, so be sure
to reset your system unit after completing this
tutorial.

To reset your system unit, go to the Customize
menu and choose Units Setup > System Unit
Setup > System Unit Scale > Inches.

2. If necessary, click the Zoom Extents All
button to display the geometry correctly in all
the viewports.

3dsmax.chm::/file_load_units_mismatch_dialog.html
3dsmax.chm::/system_unit_setup_dialog.html
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Create a new layer:

1. Press H to open the Select Objects dialog.

2. On the Select Objects dialog > List Types group,
turn off Lights and click Invert.

The list displays all of the lights in the scene.

3. Click the All button at the lower left, under the
object list and then click Select.

All of the lights in the scene are selected.

4. On the Layers toolbar, click Create New
Layer.

If the Layers toolbar is currently turned off, you
can right-click to the right of the main toolbar
and choose Layers from the menu.

5. In the Create New Layer dialog, set the name to
Lights and make sure Move Selection To New
Layer is turned on, then click OK.

All of the lights in the scene are moved to the
new layer, Lights.

6. On the Layers toolbar, click Layer
Manager.

The Layer Manager appears.

In 3ds Max 8, the Layer Manager is modeless;
you can leave it open while you work in
your scene, making it a useful tool for object
selection and manipulation.

7. In the Layer Manager, click the Hide column
for the Furniture layer row.

The mask icon appears in the Layer Manager
and all of the furniture in the scene is hidden.

The Layer Manager is useful for freezing and
hiding large collections of objects; however, one
particularly handy use is for turning lights on
and off in renderings.

8. Making sure the lights are still selected,
right-click in a viewport, and from the
Transform quad of the quad menu, choose
Properties.

9. In the Object Properties dialog > General panel
> Rendering Control group, click the By Object
button.

It changes to read By Layer. Click OK to dismiss
the Object Properties dialog.

When a light’s Rendering Control group is set
to By Layer, you can use the Renderable layer
property to easily control the renderability of
a group of lights.

Tip: By default, lights are created with their
Rendering Control set to By Object, but you
can reset the default so that all new lights will
be created with their Rendering Control set
to By Layer. To change the default, choose
Customize > Preferences from the Main menu
to display the Preference Settings dialog, and
in the dialog’s General panel > Layer Defaults
group turn on New Lights Renderable By Layer.

10. In the Layer Manager, click the Render column
next to the Lights row.
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The teapot symbol disappears in the Layer
Manager and all of the lights on the layer are
turned off when you render.

Using the Layer Manager to control lights like
this can be extremely useful for experimenting
with different light setups, or for simulating
daytime and nighttime lighting.

Reset your system units:

If you had to adopt file unit scaling at the beginning
of this lesson, you can use these steps to reset the
system units.

1. Choose Customize menu > Units Setup.

2. In the Units Setup dialog, click the System Unit
Setup button.

3. On the System Unit Setup dialog, click the unit
type list and choose Inches in the System Unit
Scale group.

Summary

You have used the Layer Manager to control the
visibility of objects in your scene, and to turn sets
of lights on and off.

Animating a Mechanical
Design
A mechanical animation illustrates the sequence
of putting a group of parts together, or the design’s
function once it is built. This kind of animation
can be very useful for instructional or promotional
purposes.

In this tutorial, you will create a mechanical
animation of an automotive suspension, and add a
sound file that narrates the assembly.

Skill Level: Intermediate

Time to complete: 45 minutes

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Create an instructional animation of a
mechanical design.

• Add a sound file to an animated sequence.
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• Set up an inverse kinematics hierarchy with
joint limits.

• Use Interactive IK.

• Use Applied IK.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\mech_design folder, unless otherwise
specified. Before doing the tutorials, copy the
\tutorials directory from the CD to your \3dsmax8
local installation.

Creating the Assembly Animation

In this lesson, you will animate the parts of the
design coming together.

Open a file and set the animation range:

The animation range is the number of frames over
which 3ds Max will render. In this step, you will
open a file that contains the suspension assembly
and set the required animation range.

1. On the menu bar, choose File > Open to display
the Open File dialog.

2. Choose mech_01.max located in the
\tutorials\mech_design folder, and click Open.

3. On the menu bar, choose File > Save As.

4. In the Save As dialog, name the file myassy.max
and click Save.

5. In the time controls, click Time
Configuration to display the Time
Configuration dialog.

6. In the Time Configuration dialog > Animation
area, set the End Time field to 450.

7. Click OK to close the dialog.

8. Notice that the time slider now displays 450
frames.

Animate the LOWER ARM:

The parts of the assembly are already in their
assembled positions. To animate a part going into
position, you must first set a key for the part in its
assembled position, at a frame later than 0. Then,
at frame 0, you can pose the part away from its
assembled position. This will cause the part to
animate into its assembled position over time.

1. Use the time slider to move to frame 100, or
type 100 in the Go To Frame box under the
playback controls.

2. On the main toolbar, click Select By
Name.

The Select Objects dialog appears.
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3. Choose LOWER ARM from the list and click
Select to close the dialog.

The LOWER ARM is selected in the viewports.

4. In the Motion panel > PRS Parameters
rollout > Create Key area, click Position.

This sets a key for the LOWER ARM in its
current position at frame 100. The key dot is
displayed under the time slider in the track bar.

5. In the time controls, click Go To Start.

This moves the time slider to frame 0.

6. Turn on Auto Key.

7. Click and then right-click the Select And
Move tool.

The Move Transform Type-In dialog appears.

8. In this dialog, type 500 in the Offset:World X
field and press ENTER.

The LOWER ARM moves out from its installed
position, and a key is set for this position at
frame 0.

9. Scrub the time slider, or press Play to play
the animation.

The LOWER ARM moves to its installed
position over frames 0 to 100.

Animate the UPPER ARM:

Next, you will use the same technique to animate
the UPPER ARM moving into its assembled
position from frame 100 to 200.

1. Use the time slider to move to frame 200, or
type 200 in the Go To Frame box.

2. Select the UPPER ARM by clicking it in the
Perspective viewport.

3. In the Motion panel > PRS Parameters rollout
> Create Key area, click Position.

A key is created for the UPPER ARM.
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4. Scrub the time slider to frame 100.

5. Make sure Auto Key is still turned on.

6. In the Move Transform Type-In dialog, type
500 in the Offset:World X field and press
ENTER.

The UPPER ARM moves out from its assembled
position.

7. Turn off the Auto Key button.

8. Close the Move Transform Type-in dialog.

9. Scrub the time slider, or press Play to play the
animation.

The LOWER ARM moves into its assembled
position at frame 100 and the UPPER ARM
reaches its assembled position at frame 200.

Fade in the CARRIER:

In this step you will make the CARRIER fade into
view between frames 200 and 320.

The CARRIER is located inside the WHEEL. It is
currently not visible in the Perspective viewport.
To see the visibility change, you will adjust the
viewpoint in the Perspective viewport.

1. Click Arc Rotate in the viewport
navigation controls at the lower-right corner of
the screen. Rotate the Perspective view to show
the CARRIER.

2. On the main toolbar, click Select By
Name and choose CARRIER from the list.

3. Scrub the time slider to frame 0.

4. In the Perspective viewport, right-click the
CARRIER.

5. From the Transform quadrant of the quad
menu, choose Curve Editor.

6. Click the CARRIER listing in the Curve Editor
hierarchy to select it.

7. On the Curve Editor menu bar, choose Tracks
> Visibility Track > Add.

A visibility track appears in the hierarchy under
CARRIER.
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8. Highlight the Visibility listing in the hierarchy
to select it.

The graph’s vertical axis represents the value
of the controller, while the horizontal axis
represents time in frames. The visibility curve
is initially a horizontal dashed line with a value
of 1 throughout the entire animation range. A
value of 1 means the object is completely visible
and 0 means it is invisible. Values between 0
and 1 yield a partial visibility.

9. On the Curve Editor toolbar, click Add
Keys.

Add Keys allows you to add keys by simply
clicking the function curve (the dashed line
currently set at 1 all the way across the graph).

10.Create two new keys by clicking the dashed line
close to frames 200 and 320.

11. On the Curve Editor toolbar, click Move
Keys.

12.Click the key close to frame 200. Its frame
number and controller value will appear in the

two value fields at the bottom edge of the Track
View dialog. Note that a selected key appears in
white while an unselected key appears in black.

13.Enter 200 and 0 respectively in the two value
fields.

This sets the key value to 0 at frame 200.

14. At the lower right of the Track View
window, click Zoom Value Extents.

This zooms the graph, making it easier to see
the visibility change from 0 to 1.

15. To the right of the value fields, click Show
Selected Key Stats. This causes key values to
appear adjacent to a selected key.

16.Click the key close to frame 320. In the value
fields type 320 and 1 respectively.

Now the visibility will animate from invisible
(0) at frame 200 to fully visible (1) at frame 320.
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17.Scrub the time slider, or press Play to play the
animation.

The CARRIER fades into view between frames
200 and 320.

Note that the CARRIER doesn’t become fully
invisible in the viewport. 3ds Max uses a
dithered shading to represent an invisible part.
However, when you render the animation,
the renderer will make it completely invisible
before frame 200. Your results may be different
if 3ds Max is configured to use a driver other
than Software Z-Buffer.

Fade in the wheel:

In this step you will add a visibility track to the
WHEEL. It will change from completely invisible
at frame 320 to fully visible at frame 380.

1. Press H and select WHEEL from the list.

2. Click WHEEL in the Curve Editor hierarchy
to select the track.

3. On the Curve Editor menu bar, choose Tracks
> Visibility Track > Add.

A visibility track appears.

4. Select the Visibility track, and on the
Curve Editor toolbar, click Add Keys.

5. Place one key close to frame 320, and a second
close to frame 380.

6. On the Curve Editor toolbar, click Move
Keys.

7. Click the key close to frame 320. Its frame
number and controller value will appear in the
value fields at the lower edge of the Track View
dialog. Type 320 and 0 respectively in the value
fields.

8. Click the key close to frame 380. In the Value
fields, type 380 and 1 respectively.

9. Close the Track View dialog.

10.Scrub the time slider, or press Play to play the
animation.

The WHEEL fades in and out of view.

Move the WHEEL into position:

The WHEEL now fades in as required. Now you’ll
make it move into position.

1. Select the WHEEL.

2. Scrub the time slider to frame 450.

3. In the Motion panel > PRS Parameters rollout,
click Position.

This plants a key for the WHEEL in the
assembled position.

4. Scrub the time slider to frame 380.
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5. Turn on Auto Key.

6. Click and then right-click the Select
And Move tool to display the Move Transform
Type-In dialog.

7. In this dialog, type 400 in the Offset:World
X-axis and press ENTER.

8. Close the Move Transform Type-In dialog.

9. Turn off the Auto Key button.

Test the animation:

1. Move the time slider to frame 0.

2. Click Arc Rotate and adjust the Perspective
viewport as shown.

3. Scrub the time slider, or press Play to play the
animation.

The parts move and fade into position over
frames 0 to 450.

Save your work:

• On the menu bar, choose File > Save to save
your scene as myassy.max.

Animating a Suspension
Operation

In this section you will use the 3ds Max Inverse
Kinematics tools to create a second animation of
the suspension. You could look at this as a second
segment to a much larger animation that you began
in the first part of this tutorial. In this segment you
will show the suspension in operation.

Before starting, a discussion of the term kinematics
may be useful.

Kinematics

Kinematics refers to the position, velocity, and
acceleration of an object or group of objects.
When a group of objects are connected, they
are said to form a kinematic chain. In 3ds Max,
a kinematic chain is formed by linking objects
in an appropriate order called a hierarchy. The
kinematic chain uses the concept of a family
hierarchy to establish rules of motion.

Consider the human arm. It can be considered
as a kinematic chain consisting of an upper arm,
a forearm, and a hand. If the concept of a family
hierarchy is applied, we would say the hand is a
child of the forearm, and the forearm is a child of
the upper arm.

When a parent object moves, the child object
inherits its motion. However, parent objects don’t
inherit the motion of their children.

There are two ways to solve for the positions
and orientations of objects in a kinematic chain:
forward and Inverse Kinematics.

Forward Kinematics

Animating with Forward Kinematics involves
adjusting the position of each object in the
kinematic chain, starting with the highest level
parent and working toward the child. Each child
object in the chain inherits its parent’s motion.
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Forward Kinematic solutions are mathematically
stable and yield well defined results; however, they
do have limitations.

Consider the problem of trying to animate the
human arm using Forward Kinematics. Getting
the hand into a specific position and orientation
may require several trial movements of the upper
arm and forearm.

Inverse Kinematics

When animation is performed with Inverse
Kinematics (IK), the lowest level child object is
moved into the desired position and 3ds Max
calculates the required position of all parent
objects. For several types of animation, IK
solutions provide the quickest results. One of the
drawbacks of IK is that solutions are not unique.
Depending on the kinematic chain, there may be
several valid solutions and it may be difficult to
predict which one is obtained.

In this section you will perform the following
main steps:

• Establish an upper and lower kinematic chain.

• Adjust object pivots so they rotate about the
correct position.

• Set active joint axes.

• Animate the lower kinematic chain.

• Bind an object in the upper kinematic chain to
a follow object in the lower chain.

• Use Applied IK to solve the Inverse Kinematic
solution of the upper chain.

Set up:

1. On the menu bar, choose File > Open,
and open the file mech_03.max in the
\tutorials\mech_design directory.

2. Right-click the Front viewport to activate it.

3. In the viewport navigation controls, click
Min/Max toggle.

4. In the viewport navigation controls, click
Region Zoom and Zoom in on the outer end
of the UPPER ARM.

Create a dummy object:

1. In the Create panel, click Helpers.

2. In the Create panel > Object Type rollout, click
Dummy.

3. Place your cursor at the center end of the Upper
Arm.

4. Press the mouse button and drag out to create a
square dummy object.
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5. In the Create panel > Name and Color rollout,
type UpperArmDummy to rename the
dummy.

6. Press T to switch to the Top viewport.

7. Right-click the viewport label of the Top
viewport and choose Smooth + Highlights.

8. On the main toolbar, click Select And
Move.

9. Adjust the position of the UpperArmDummy
as shown.

10.On the menu bar, choose File > Save As. Name
your scene myassyb.max.

Establish UPPER ARM hierarchy:

In this step you set up an object hierarchy between
the WHEEL and the UPPER FRAME.

1. On the main toolbar, click Select By
Name.

2. Select WHEEL from the list and click Select to
close the dialog.

3. On the toolbar, click Select And Link.

When linking objects, you select the child
object first, then its parent. Since the WHEEL
is already selected, it will be taken as the child
object in the next step. You need only select
the parent. This can be done by dragging from
the child to the parent in the viewports, or by
selecting the parent by name. Here you will
select the CARRIER by name.

4. On the main toolbar, click Select By
Name.

Because you clicked Select and Link before
clicking Select By Name, the dialog is titled
Select Parent. This indicates that you are
picking the parent object for the currently
selected object.

5. Choose CARRIER from the list and click Link
to close the dialog.

The WHEEL is now a child object of the
CARRIER.
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6. Press F to switch to the Front viewport.

7. Click the CARRIER and drag until the cursor is
over the UpperArm Dummy, then release.

The CARRIER is now a child object of the
UpperArmDummy.

8. Link the UpperArmDummy to UPPER ARM.

9. Link the UPPER ARM to UPPER FRAME.

Tip: You may need to adjust your view to see
both objects.

10. On the toolbar, click Select Object to
cancel the Link tool.

This completes the hierarchical linking for the
upper portion of the suspension. We can verify
the hierarchy in the Select Objects dialog.

11. On the main toolbar, click Select By
Name.

12.In the Select Objects dialog, turn on Display
Subtree.

The hierarchy is displayed from the Parent
object and descending to the lowest child
object. Click Cancel to close the dialog.

13.On the menu bar, choose File > Save As. Name
your scene myassyc.max. You can find a
version of this scene in the file mech_03a.max.

Adjusting Pivots

When animating the suspension system, you will
rotate several objects. Each object will rotate about
its own pivot. To make your suspension behave
correctly, you will have to move each object’s pivot
to coincide with its logical center of rotation.

The WHEEL and UpperArm Dummy are already
correctly placed; the UPPER FRAME will not
move in this animation so you need not be
concerned with its pivot. The remaining items in
our hierarchy are the CARRIER and the UPPER
ARM. You will adjust these objects’ pivots in this
lesson.

Adjust the UPPER ARM pivot:

1. Continue with the file from the previous lesson,
or load the file mech03a.max.

2. Press H and select UPPER ARM from the list.

3. In the Hierarchy panel, click Pivot.

4. In the Hierarchy panel > Adjust Pivot rollout,
click Affect Pivot Only.

The pivot point is clearly identified by an RGB
axis tripod in viewports. The pivot is currently
at the center of the UPPER ARM. You can see
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that if you rotated the UPPER ARM about this
pivot, the animation would not work correctly.

5. In the Front viewport, region zoom around the
UPPER ARM so you can see the object clearly.

6. On the toolbar, click Select And Move.
Move the pivot point to the center of the
bushing as shown.

Adjust the CARRIER pivot:

1. Switch to a Top view.

2. Press H and select CARRIER from the list.

3. Move the CARRIER Pivot to align with the
ends of the arms.

4. Switch to a Front view, and change the view to
Smooth+Highlights.

5. Align the CARRIER pivot to the end of the
LOWER ARM.

6. In the Hierarchy panel > Adjust Pivot rollout,
turn off Affect Pivot Only.

Establish LOWER ARM hierarchy:

The LOWER ARM hierarchy will consist of three
objects: a dummy object at the end of the LOWER
ARM, the LOWER ARM itself, and the LOWER
FRAME. You will create the dummy object and
place it at the end of the LOWER ARM.

1. Right-click in the Front viewport to make it
active.

2. Zoom out, then into the assembly at the bottom
of the wheel.

3. On the Create panel, click Helpers.

4. On the Create panel > Object Type rollout,
click Dummy.

5. Place your cursor above the LOWER ARM.
This initial position is not critical since we will
be using the Align tool to position it precisely.

6. Press the mouse button and drag out to create
a dummy.
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7. In the Create panel > Name and Color rollout,
type LowerArm Dummy.

Align the LowerArmDummy to the CARRIER pivot:

1. On the toolbar, click Select And Move.

2. On the toolbar, click Align.

3. Press H and select CARRIER from the list then
click Pick.

The Align dialog appears.

4. In the Align dialog > Align Position group,
click Pivot Point in both the Current Object and
Target Object groups.

5. In the Align dialog > Align Position group, turn
on each check box of X Position, Y Position,
and Z Position.

6. Click OK to close the dialog.

The LowerArm Dummy pivot moves to the
same position as the CARRIER pivot.

Link LowerArmDummy to LOWER ARM:

Now you create the link hierarchy from the
LowerArmDummy to the LOWER ARM and then
to the Lower Frame.

1. On the toolbar, click Select And Link.
Click and drag from the LowerArm Dummy
to the LOWER ARM.

2. Link the LOWER ARM to the LOWER FRAME.



70 Chapter 4: AEC

3. On the toolbar, click Select Object to
cancel the Link tool.

Now you can verify the hierarchy.

4. On the main toolbar, click Select By
Name.

5. In the Select Objects dialog, turn on Display
Subtree. The hierarchy should appear as
follows.

Adjust the LOWER ARM pivot:

1. Press H and select LOWER ARM from the list.

2. On the Hierarchy panel > Adjust Pivot rollout,
click Affect Pivot Only.

3. Region zoom on the LOWER ARM in the
Front viewport.

4. On the main toolbar, click Select And
Move. Move the pivot to the center of the
bushing as shown.

5. In the Hierarchy panel > Adjust Pivot rollout,
turn off Affect Pivot Only.

6. Save the scene as myassy_pivots.max.

Specifying Active Joint Axes

You have established the correct hierarchy for all
components in the suspension. Now you must
specify which axes each object can rotate about. If
an object is free to move in space, it is said to have
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6 degrees of freedom. This means that it has 6 ways
it can move. It can translate along each of the X, Y,
and Z-axes, and it can rotate about each of the X,
Y, and Z-axes. In a practical mechanism, such as
this suspension, each object must have less than
6 degrees of freedom; otherwise, it would simply
fall apart. Therefore you have to specify motion
restrictions for each object.

In this section, you will be working on the IK
portion of the Hierarchy panel. It will be helpful at
this point to look at the rollouts available in IK.

Set up:

1. Continue from the previous lesson, or open
mech_03b.max in the \tutorials\mech_design
directory.

When you create an object that is intended to
be part of an IK hierarchy, and you want to
set joint parameters before you have applied
IK to the object, you must change the object’s
Position controller to make the joint limits
available. This task has already been performed
for the objects in the scene you initially opened,
but has not been performed for the new dummy
objects.

2. With UpperArmDummy selected, go to the
Motion panel.

3. Expand the Assign Controller rollout.

4. In the Assign Controller rollout, highlight
the Position track, and click Assign Controller.

5. Choose the Bezier Position controller.

This controller makes both the Sliding Joints
and Rotational Joints rollouts available for
the object. You will use these rollouts in the
procedures that follow.

6. Repeat these steps for LowerArmDummy.

Specify active joint axes:

1. On the Hierarchy panel, click IK. The IK
section of the panel has many controls.

2. Select the WHEEL object.

3. Close each of the rollouts to get an overall view
of the categories.

There are 5 rollouts within IK. For specifying
active axes we will use the lower two rollouts,
the Sliding Joints and Rotational Joints. The
Sliding Joints rollout controls translation along
X, Y and Z while the Rotational Joints rollout
controls rotation about X, Y, and Z.

Each object’s motion is specified in terms of
its parent’s coordinate system. Therefore the
reference coordinate system should be set to
Parent prior to setting active joint axes.

There are two kinematic chains in the
suspension. The upper kinematic chain has the
following hierarchy:

UPPER FRAME -> UPPER ARM ->
UpperArmDummy -> CARRIER -> WHEEL

The active axes for each object in the hierarchy
are indicated as follows:

UPPER ARM: Rotational Joints in Y axis

UpperArmDummy: Rotational Joints in XYZ
axes

WHEEL: Rotational Joints in X axis
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No other objects have active axes for either
sliding or rotational joints.

In the following steps, the active joint axes are
set for each object in the upper kinematic chain.

4. On the toolbar, click Reference Coordinate
System, then choose Parent.

5. Right-click in the Perspective viewport to
make it active, then click Min/Max toggle.

Set up UPPER FRAME:

1. Press H and select the UPPER FRAME from
the list. The UPPER FRAME is fixed and will
not move in the animation.

2. In the Hierarchy panel > IK > Sliding Joints
rollout, verify that the Active check box is
turned off for each of the X, Y and Z-axes.

3. Close the Sliding Joints rollout.

4. In the Hierarchy panel > IK > Rotational Joints
rollout, turn off the Active check boxes for each
of the X, Y and Z-axes.

5. Close the Rotational Joints rollout.

Set up UPPER ARM:

1. Press H and select UPPER ARM from the list.
The UPPER ARM should rotate about the
Y-axis only.

2. In the Hierarchy panel > IK > Rotational Joints
rollout, turn off the Active check box on both
the X and Z-axes.

3. The UPPER ARM should not be free to slide
along any axis direction. As a default, Sliding
Joints is turned off for all object’s axes.

Set up UpperArm Dummy:

• The UpperArm Dummy is the next object in
this hierarchy. It should be free to rotate about
all axes, but restricted from sliding along all
axes. Verify that this is the case.

Set up CARRIER:

1. Press H and select CARRIER from the
list. The CARRIER is a child object of the
UpperArmDummy and should be restricted
from all motion relative to it.

2. In the Hierarchy panel > IK > Rotational Joints
rollout, turn off the Active check box for each
axis.

Set up WHEEL:

1. Press H and select WHEEL from the list. The
WHEEL should be free to rotate about the
X-axis only.

2. In the Hierarchy panel > IK > Rotational Joints
rollout, turn off the Active check box for both
the Y and Z-axes.

This completes the Active Joint axis settings for
the upper kinematic chain.

Next the active joint axes for the lower kinematic
chain are set.
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The lower kinematic chain has the following
hierarchy:

LOWER FRAME -> LOWER ARM ->
LowerArmDummy

Joint constraints for the lower kinematic chain are
summarized as follows:

LOWER ARM: Rotational joint in Y-axis

No other objects have active axes for either sliding
or rotational joints.

Set the active joint axes for the lower kinematic
chain:

1. Press H and select LowerArmDummy from the
list. The LowerArmDummy should be fixed
with respect to its parent, the LOWER ARM.

2. In the Hierarchy panel > IK > Rotational Joints
rollout, turn off the Active check box for each
of the X, Y and Z-axes.

3. Press H and select LOWER ARM from the list.
The LOWER ARM should be free to rotate only
about the Y-axis.

4. In the Hierarchy panel > IK > Rotational Joints
rollout, clear the Active check box for both the
X and Z-axes.

5. Press H and select LOWER FRAME from the
list.

6. In the Hierarchy panel > IK > Rotational Joints
rollout, turn off the active check boxes for
LOWER FRAME.

Now you will establish the relationship between
the two kinematic chains. You will be animating
the LOWER ARM, and you want the upper
kinematic chain to follow. To accomplish this, you
will bind the CARRIER to the LowerArmDummy.

Bind CARRIER to LowerArm Dummy:

1. Press H and select the CARRIER from the list.

2. In the Hierarchy panel > IK > Object
Parameters rollout > Bind To Follow Object
area, click Bind.

3. On the main toolbar, click Select By Name
and from the list choose LowerArmDummy.

4. Click Pin to close the dialog.

5. In the Object Parameters rollout, turn off Bind.

Using Interactive IK
Set up:

• Continue from the previous lesson or open
mech_03c.max in the \tutorials\mech_design
directory.

Use Interactive IK:

1. Be sure your Perspective viewport is active and
full screen.

2. On the toolbar, click Select And Rotate.

3. Press H and select LOWER ARM from the list.

In the next step, you will rotate the LOWER
ARM to see the effect. You don’t want the
transform to be permanent, so be sure to
right-click before you release the mouse
button. This will cancel the transform and
return the object to its original position. If you
inadvertently release the mouse button, click
Undo to reverse the operation.

4. Place your cursor over the Y-axis of the LOWER
ARM transform gizmo. Click and drag up and
down, then right-click to cancel.
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The LOWER ARM rotates up and down, but
the rest of the assembly does not move with it.

In order to have the rest of the assembly
follow the LOWER ARM, you have to set the
Interactive IK toggle. This causes 3ds Max to
recalculate the positions of objects in kinematic
chains when a child object is transformed.

5. On the command panel, click the
Hierarchy tab.

6. On the Hierarchy panel, click IK.

7. In the Inverse Kinematics rollout, turn on
Interactive IK.

8. Rotate the LOWER ARM along the Y axis of the
transform gizmo. Right-click to cancel.

The LOWER ARM rotates, and the rest of the
assembly follows as required.

9. On the Hierarchy panel, turn off Interactive IK.

Save your work:

• On the menu bar, choose File > Save As. Name
your scene myassy01.max.

Using Applied IK

If you work with the Inverse Kinematics toggle
on, it is termed Interactive IK. Another mode of
Inverse Kinematics is Applied IK. With Applied
IK, you can independently animate the follow
object or any object in its kinematic chain, and get
3ds Max to solve the IK solution for all frames in
the animation.

In the next section, the LOWER ARM is animated,
and Applied IK is used to animate the remainder
of the assembly.

Set up:

To start from this point, do one of the following:

1. Continue from the previous lesson, or open
your saved file, myassy01.max.

2. If you want to begin the tutorial at this
point, open mech_04.max from the
\tutorials\mech_design directory.

Set the animation range:

1. In the time controls, click Time
Configuration.

2. In the Time Configuration dialog > Animation
area, set the End Time to 300 frames and press
OK to close the dialog.

3. Right-click in the Perspective viewport to
make it active, and click Min/Max toggle to
make the viewport full screen.

4. Click Arc Rotate. Rotate the Perspective
viewport to see the LOWER ARM.
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5. Press H and select the LOWER ARM from the
list.

6. Turn on Auto Key.

7. Scrub the time slider to frame 100.

8. On the toolbar, click and then right-click
Select And Rotate.

The Rotate Transform Type-In dialog appears.

9. In the Rotate Transform Type-In, enter 8
degrees in the Offset: World Y-axis field and
press ENTER.

Don’t be concerned that the remainder of the
assembly doesn’t follow. It will do so later when
you use Applied IK.

10.Scrub the time slider to frame 200.

11.In the Rotate Transform Type-In dialog, enter
16 degrees in the Offset:World Y-axis field.
Press ENTER.

12.Scrub the time slider to frame 300.

13.In the Rotate Transform Type-In dialog, enter
8 degrees in the Offset: World Y-axis field.

This will bring the LOWER ARM back to its
original orientation.

14.Turn off Auto Key.

15.Close the Rotate Transform Type-In dialog.

16. On the toolbar, click Select Object to
cancel Rotate.

17. In the time controls, click Play. The
LOWER ARM moves up, down, and then back
to its original position.

Use Applied IK:

1. Press H and select CARRIER from the list.

2. In the Hierarchy panel > IK > Inverse
Kinematics rollout, set the End frame field to
300.

This will make 3ds Max calculate the IK
solution for every frame in the animation.

3. In the Hierarchy panel > Inverse Kinematics
rollout, click Apply IK.
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The solution is determined for all frames in the
specified range. The time slider moves across
the screen as each frame is solved.

4. In the time controls, click Play.

The suspension moves as required.

5. In the time controls, click Stop.

Animate WHEEL rotation:

In this step you will add WHEEL rotation to the
animation.

1. In the time controls, click Go to Start.

2. Press H and select WHEEL from the list.

3. Right-click the WHEEL and choose Curve
Editor from the quad menu.

4. Select the Rotation track.

5. Right-click the Rotation track and select Assign
Controller from the quad menu.

6. In the Assign Rotation Controller dialog, select
Euler XYZ, then click OK to close the dialog.

The Euler XYZ rotation controller lets you
animate each axis individually.

7. Select the X Rotation track.

8. On the Track View toolbar, click Add
keys.

9. Click the curve at approximately frames 0 and
300.

10. On the Track View toolbar, click Move
Keys.

11.Click the Keyframe at frame 0 and enter a value
of 0 degrees. There are two small fields at the
bottom of the Track View dialog. The second
field is the value field.

12.Click the Keyframe at frame 300 and enter a
value of 720 degrees (two revolutions).

13. Click Zoom Value Extents, at the
bottom-right of the Track View.

This will compress Track View graph so that
you can view the values.

14.Close the Track View dialog.
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Play the animation:

1. In the time controls, click Time
Configuration.

2. In the Time Configuration dialog > Playback
area, click Speed ¼x then click OK.

3. In the time controls, click Play.

The WHEEL rotates as the suspension moves
up and down. If the animation is not playing
back smoothly, right-click the Perspective
viewport label and select Wireframe.

4. Stop the animation and return the time slider
to frame 0.

Notice that the dummy objects are visible.
Although dummy objects will not appear in the
rendering you may wish to turn them off in
the viewport. To accomplish this, you use the
Display panel.

5. In the Display panel > Hide By Category
rollout, click the Helpers check box.

The Dummy objects disappear from view.

The final step in the animation is the WHEEL
turning angle.

Animate WHEEL turning angle:

The WHEEL turning angle can be animated by
rotating the CARRIER. Since the WHEEL is a
child of the CARRIER, it will inherit its rotation.

1. On the toolbar, click Select And Rotate.

2. Press H and select CARRIER from the list.

3. Scrub the time slider to frame 100.

4. Turn on Auto Key.

5. In the toolbar, right-click Select And
Rotate.

The Rotate Transform Type-In dialog appears.

6. In this dialog, enter 20 in the Z Offset:World
field and Press ENTER.

7. Scrub the time slider to frame 300.

8. In the Rotate Transform Type-in dialog, enter
20 in the Offset:World Z axis field and press

ENTER.

9. Turn off Auto Key.

10.Close the Rotate Transform Type-In dialog.

11. In the time controls, click Play. The
WHEEL rotates, turns, and moves up and
down.

12.Stop the animation and return the time slider
to frame 0.
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Save your work:

• On the menu bar, choose File > Save As. Name
your scene myassy02.max. You can see a
finished version of this animation in the file
suspen3.avi.

Summary

In this tutorial, you have learned several key
concepts and tools for animating mechanical
assemblies with 3ds Max:

• How to keyframe individual object movements,
and how to fade objects in and out by editing
the Visibility track in Track View.

• The difference between forward kinematics
and inverse kinematics (IK), and their role in
animating object assemblies.

• Manipulating pivot points.

• The fundamentals of Interactive IK and Applied
IK.

3D DWF Support

Publishing to DWF

In this tutorial, you learn how to publish (export)
to a 3D DWF format. The DWF format allows
people to view your designs without having
3ds Max installed on their system. With the free
DWF viewer available for download, you can
email your 3D concepts or simply post them on
the Internet to painlessly reach a wider audience.

You will learn how to export a scene to a DWF
file, and you will also learn about the limitations
pertaining to this format and how to overcome
them.

The DWF Viewer inside Internet Explorer

Skill level: Beginner

Time to Complete: 30 minutes

Features Covered in This Tutorial

• Invoking the DWF Export dialog

• Adjusting parameters

• Using Render To Texture to overcome the
limitations of the DWF Export command

• Viewing the exported scenes in Internet
Explorer with the help of the DWG Viewer

Tutorial Files

All the necessary files for this tutorial can be
found on the Tutorial Files CD in the \tutorials\viz
directory. Before starting the tutorials, copy
the \tutorials folder to your local \3dsmax8
installation.

Lessons in This Tutorial

Using 3D DWF Export (page 2–79)

Overcoming the Limitations of DWF Export (page
2–80)
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Using DWF Export

In this lesson, you learn how to use the DWF
Export tool and set it up to export a 3D scene. You
will also learn to view the exported or published
scene in the Autodesk DWF Viewer and use the
Layers table to control the visibility of objects.

Set up the lesson:

1. From the\tutorials\VIZ directory, open
dining_room.max.

2. The scene shows a dining room with various
objects and materials applied. It is illuminated
by a single hidden main light and three hidden
fill lights to simulate global illumination.

Tip: If the Units Mismatch dialog displays,
choose Adopt Unit Scale, and then click OK.

Using the DWF Export dialog:

1. From the main toolbar, click the Quick
Render button to view the rendered scene with
lights and shadow effects.

2. From the File menu, choose Export.

Note: Make sure the Camera viewport is the
active viewport. as this will be used as the initial

view in the DWF Viewer when you choose
Export.

3. In the Select File to Export dialog, click the Save
as Type drop-down menu and choose Publish
to DWF.

4. In the file name box, enter Dining Room for
the name of the exported file. Click Save.

The DWF Publish Options dialog opens.

5. In the General group, check the Show DWF
in Viewer option. The DWF Viewer window
automatically opens with the exported file after
clicking OK.

Note: If you choose to not to have the DWF
Viewer open automatically in future use, you
can open it from the Start button > Programs >
Autodesk > Autodesk DWF Viewer.

Note: Although the default publishing options
for DWF export work well in most situations,
you may consider changing the Rescale Bitmaps
option. The higher this value, the larger the
file size and the longer it takes to display in
the DWF Viewer. This is especially true if the
file is accessed on the Internet. The lower the
maximum resolution, the faster the file loads
but the quality of the display is reduced.

6. Make sure that Group by Layer is turned on in
the Grouping Options group. This is because
you will be able to view objects in the DWF
Viewer by layer.

7. Click OK to export the scene and view your
exported file.

The scene is now visible in the DWF Viewer
where you can view the geometry and textures
applied, but notice that lighting effects and
shadows have not been exported.

8. On the DWF
Viewer toolbar, use the navigation tools to
orbit, pan and zoom around your project.
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Note: If you have a mouse with a wheel, you can
roll the wheel to zoom. To pan, press the wheel
and drag. You can also use the Orbit tool by
pressing SHIFT while pressing the wheel and
dragging rotates the view around a vertical axis
through the middle of the model.

9. Click the Home button to revert the
model back to its original position as it was
when the DWF Viewer was opened.

Note: The original position in the DWF Viewer
is automatically derived from the current active
viewport in 3ds Max when the DWF Export
command was completed.

10.In the Navigation panel to the left of the DWF
Viewer, right-click the Fireplace layer and
choose Hide. The fireplace is now hidden in
the scene.

11.Expand the Furniture layer. Right-click
on Table and then choose Hide. The table
disappears but other entities (chairs) on that
same layer are still visible.

12.Zoom back and orbit so that your viewpoint is
from outside the room.

13.Right-click the Walls layer in the Navigator
and choose Transparent. This is an alternative
to hiding a layer (or entity) as it becomes
transparent so you can still see what is behind it.

Overcoming the Limitations of
DWF Export

In the previous lesson, you learned how you can
export 3D scenes to the DWF format preserving
geometry, materials and layers. You have also
learned that by default, the DWF file format does
not recognize lighting effects and shadows.

In this lesson, you learn how to overcome these
limitations by using Render to Texture.

Set up the lesson:

• From the\tutorials\\VIZ directory, open
dining_room.max.

The scene shows a dining room with various
objects that have pre-applied materials. A single
main light illuminates the scene and three fill lights
have been added to simulate global illumination.

Using Render to Texture

1. From the Rendering menu, choose Render to
Texture.

The Render to Texture dialog opens.

2. Press CTRL+A to select all objects in the scene.

In the Objects to Bake rollout, all the object
names display in the Objects to Bake list.
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3. In the Output rollout, click Add.

The Add Texture Elements dialog opens.

Note: If you can’t see the Add button, resize the
dialog or use the pan cursor to drag the panel
upwards.

4. Choose CompleteMap, and then click Add
Elements to close the dialog.

Note: As the name implies, a complete map
contains all subset maps like diffuse, shadows,
specular highlights and others.

5. In the Selected Element Common Settings
group, click the button labeled 512.

Note: This value defines the resolution of
the output bitmap in pixels. 512 is a good
compromise between image quality and display
speed. The higher the value, the better the
quality but be aware that increasing texture
resolution increases display speed and render
time.

6. In the Baked Material rollout, click the Create
New Baked radio button below the Save Source
(Create Shell) radio button.

7. From the Create New Baked drop-down menu,
choose Architectural.

Note: The Architectural material type is in
this case is favorable as the baked material is
automatically set in self illumination mode.
This ensures that the baked material is no more
dependent on lighting setups in the scene and
makes it a good candidate for DWF Export.

8. Go back to the Output rollout. In the Selected
Element Common Settings group, click the
Target Map Slot drop-down menu and set it to
Diffuse Map.

Note: Setting the Diffuse map as a target ensures
the newly created map goes into the Diffuse
map channel, which will now contain color
information, highlights, shadows and other
elements

9. At the bottom of the dialog, click Render.

Rendering the textures may take a few minutes,
depending on system performance. When the
textures are rendered, you should be able to see
the end result in the Camera viewport.
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10.From the File menu > Save As and name the
finished model dining room_baked.max.

11.From the File menu, choose Export.

Ensure the Save as Type drop-down is set
to Publish to DWF. Name your file dining
room-shadows and click on Save.

12.In the DWF Publish Options dialog, turn off
Use Default DWF Lights, and then click OK.

You won’t need to use the DWF Viewer’s
lighting because the lighting effects in your
scene will now be published.

The file takes a little longer to load in the DWF
viewer but when it does, you notice that lighting
effects and shadows are now included in the file.

Tip: All the materials in the 3ds Max scene have
now been replaced with a Shell material type.
To reassign the original materials, in the Baked

Material rollout, select Keep Source Materials,
then click the Clear Shell Materials button.

Summary

In this tutorial, you learned how to access the DWF
Publish Options dialog, export your 3D scene in
DWF format , and how to set up Render to Texture
for baking textures in order to see the lighting
effects and shadows in the Autodesk DWF Viewer.

AutoCAD Interoperability
A key feature of 3ds Max is its ability to let you work
with drawings and models you’ve created with
AutoCAD and Autodesk Architectural Desktop,
or drawings you’ve exported from Autodesk Revit.
3ds Max gives you the advantage of being able to
improve on sound, precise drawings by letting you
create realistic design visualization presentations.

The integration of drawings created with
AutoCAD, Architectural Desktop or exported
from Revit and 3ds Max scenes has never been
tighter than it is with 3ds Max 8. DWG files
convert cleanly and maintain their layer identities
and you have control over import smoothing,
normal unification, and several other geometry
specifications. You have the capability to
import entire drawings, merge specific layers or
components and even create a live link between
3ds Max and AutoCAD.
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Skill Level: Beginner

Time to Complete: 45 minutes

Features Covered in This Tutorial

• Preparing an AutoCAD drawing for import

• Creating AEC objects using a 2D CAD drawing
as a template

• Importing a 3D CAD model and making final
adjustments

• Using the File Link Manager to create a live link
between AutoCAD and 3ds Max

• Diagnosing problems you might encounter
with the File Link Manager

• Fixing problems you might encounter with
CAD drawings

• Solving common problem with CAD drawings
and models

Files for This Tutorial

You can find the files for this tutorial in the
tutorials/designviz folder on the Tutorial Files
CD that ships with 3ds Max. Before starting the
tutorials, copy the \tutorials folder from the CD to
your \3dsmax8 local installation.

See also

Fixing Problems in CAD Models (page 2–112)

Eliminating Errant Objects (page 2–113)

Resolving Other Common CAD Problems (page
2–117)

Preparing AutoCAD Drawings for
Import

In this lesson, you will clean a 2D AutoCAD
drawing, by deleting unnecessary objects and
freezing unnecessary layers to prevent them from
being imported into 3ds Max. You will also prepare
a 3D AutoCAD file for import, taking advantage of
the benefits of both 3ds Max and AutoCAD.

To successfully and efficiently use AutoCAD
objects in a 3ds Max scene, it’s imperative that
the files be properly prepared. Specifically, you’ll
need to pay attention to layer management in the
AutoCAD drawing.

Understanding ByLayer Drawing Import

The 3ds Max 8 Layer Manager is similar to the
Layer Properties Manager in AutoCAD. Both
enable you to hide and freeze layers, and to
control the visibility and color of objects on those
layers. You can also determine whether a layer’s
objects are plotted in AutoCAD or rendered in
3ds Max, regardless of the visibility of the objects
in viewports.
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3ds Max Layer Manager

AutoCAD Layer Properties Manager

Once imported, each layer in AutoCAD becomes
a new layer in 3ds Max, and each object becomes
a new object on its respective layer. Because
AutoCAD generally produces a new object with
each entity created, this can translate to an
enormous number of entities that are imported
into 3ds Max. This number can be significantly
reduced by converting and consolidating lines
into polylines and combining objects into blocks,

which are then converted into groups during
import.

Tip: Objects that are imported from AutoCAD,
with the ByLayer color assigned, will maintain that
color. Objects with a specific color assigned in
AutoCAD will be changed to match the layer color.

Next, you’ll learn how to control layers in
AutoCAD.

Set up the scene:

• AutoCAD 2000 or later—From AutoCAD,
choose File menu > Open and browse to
the \tutorials\designviz folder and open
ww_cad_drawings1.dwg.

• AutoCAD R14—From AutoCAD, choose
File menu > Open and browse to the
\tutorials\designviz folder and open
ww_cad_drawings1_r14.dwg.

Note:

• If you are opening the drawing in the latest
version of AutoCAD, you will see a warning
stating that the drawing was last saved in an
earlier version. Click OK.

• You may also see a Proxy Objects Detected
dialog while opening the drawing. This
means that the drawing was created in another
program like Autodesk Architectural Desktop
and you are missing some Object Enablers.
This will not adversely affect this part of the
tutorial so you can click OK.
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This is a floor plan drawing of a small
condominium complex. You’ll focus on the
interior views of the lower-right tenant space.

Control the layers:

One thing most people notice about architectural
drawings is the fact that there is a lot of
information necessary for all the contractors who
will eventually construct the building. Hopefully,
the architect took advantage of AutoCAD’s layer
features to separate information and organize the
drawing.

1. Switch to the Model tab.

3ds Max will only import objects in model
space. Objects in paper space are ignored.

2. Open the Layer Properties Manager.

3. Select and freeze the following Layers and click
OK when done:

• 05MED

• 05THIN

• 14archdimensions

• A-14ARCH

• A-Flor-Pfix

• door tag

• lite

• noplot

• Park-Strip

• room tag

• SQ_ft_UP

• Trash-DET1

• xref14archdimensions

• xrefdoor tag

• xrefEQUIP-APPLIANCES

The designer who’s charged with making the
presentation model doesn’t need the more
detailed layer data pertaining to the electrical
or heating, ventilation and air conditioning
(HVAC) systems, dimensioning, drawing
borders, etc. They primarily need the floor plan
of the structure. The layers you’ve just frozen
contain objects that are not required when this
drawing is used as a template for building the
3D model.

The drawing after unnecessary layers are frozen.

Tip: Although you can control the layers to
be imported in the AutoCAD DWG/DXF
Import Options dialog in 3ds Max (explained
in another lesson), it is often easier to define
the layer states in AutoCAD or Architectural
Desktop where the results of the import can be
immediately seen.

4. Save the file as my2Ddrawing1.dwg.
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Editing and Creating Objects

In AutoCAD, when line segments meet at a corner,
they are usually joined with crisp, sharp angles.
This may translate to an unappealing or unrealistic
appearance in 3ds Max, as most real world objects
have some amount of curve or fillet on their edges.

In this lesson, you will prepare the drawing for
import by breaking some of the extreme angles
with fillets, creating a floor/ceiling shape and using
3ds Max AEC objects to build a 3D model.

Fillet the Column:

1. In AutoCAD, zoom into the central column
near the origin.

2. From the toolbar, choose Modify > Fillet.

3. Press the R key and ENTER so you can specify
a fillet radius. Set the radius to 0.125 and press
ENTER.

4. Press the P key and ENTER so you can select
a polyline and click the square shape of the
central column.

Tip: This is the advantage to using polylines to
create your drawings as opposed to individual
lines and arcs. Since the central column shape
is a 2D polyline, you can fillet all the corners
at once. Otherwise, you’d have to repeat the

fillet command three more times to break all
the corners.

Create the Floor Perimeter:

At this point, the drawing doesn’t contain an
object that you can extrude to create the floor or
ceiling. Next, you’ll create a polyline that you’ll
later import into 3ds Max.

1. From the toolbar, choose Tools > Drafting
Settings.

The Drafting Settings dialog is displayed.

2. On the Object Snap panel of the Drafting
Settings dialog, make sure Endpoint and
Intersection are active, and click OK.

This will snap the endpoints of your new
polyline to the endpoints or intersections of the
existing AutoCAD lines.

3. In the Layer Properties Manager, create a new
layer named Floor and make that layer current.
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4. Click the color swatch for the Floor layer to
open the Select Color dialog and change the
layer color to cyan.

Tip: Objects imported into 3ds Max retain their
assigned layer’s color rather than any color
assigned to them. To avoid confusion, steer
clear of using AutoCAD layer colors that are
white, red or blue, as these colors are used, by
3ds Max, to designate selected objects (white),
selected sub-objects (red), or sub-objects
(blue), respectively.

5. Click OK to close the Select Color dialog and
then click OK to close the Layer Properties
Manager dialog.

6. Use the Polyline command to draw a polyline
around the perimeter of the tenant space.

Include the balcony and hallway as shown
below.

7. Save the file as my2Ddrawing2.dwg.

Import the Drawing:

Now that you have a polyline representing the
floor or ceiling of the apartment, you can import
it into 3ds Max and start building the 3D model.
You can continue from the previous lesson and use
your drawing or you can use the sample file that
ships with 3ds Max.

1. Open or reset 3ds Max 8.

2. Choose File menu > Import. In the Select File
To Import dialog, set the Files Of Type field to
AutoCAD Drawing (*.DWG,*.DXF).

3. Open my2Ddrawing2.dwg from the previous
section or ww_cad_drawings2_clean.dwg from
the \tutorials\designviz folder.

4. On the Geometry panel of the AutoCAD
DWG/DXF Import Options dialog, turn on
Rescale and set the Incoming File Units field
to match the default unit size in the AutoCAD
drawing. In this case, Inches.
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Note: This panel also controls what types of
objects (hatches, points) are imported, and
whether AutoCAD lights, views, and UCSs are
converted to 3ds Max lights, cameras or grids.

5. Switch to the Layers tab. By default, the Skip All
Frozen Layers option is active, which allows the
drawing to be imported just as it was last seen in
AutoCAD. If a different layering scheme should
be employed, the Select From List option allows
you to select the layers to be imported manually.

6. Click OK.

The file is imported into 3ds Max 8.

Create AEC Walls:

Now that the floor plan is imported into 3ds Max,
you can use it as a template to create a 3D model.
You’ll start this process by adding Wall objects.
However, before adding walls you should review
the scene and note the different types of walls you
will have to build.

Three different types of walls.

You can see that there are at least three different
types of walls used in the structure. You have
heavy, exterior walls (A), medium weight walls
(B), that separate the apartments and the thinner,
interior walls (C), that separate the rooms in each
apartment.

You’ll start this section by creating the medium
weight walls that are highlighted in the following
image. They run along the upper part of the
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drawing and wrap around to the lower left where
they meet the exterior wall.

Build medium weight walls:

1. Continue from the previous section or
open ww_cad_drawing.max from the
\tutorials\designviz folder.

2. Click the Snap Toggle button to activate
it, then right-click the Snap Toggle button.

Right-clicking the button opens the Grid and
Snap Settings dialog.

3. On the Snaps panel, make sure Endpoint is the
only snap setting that is turned on. Close the
dialog.

Tip: Correctly setting the snaps will significantly
help this process.

4. Open the Customize menu and choose Units
Setup.

The Units Setup dialog is displayed.

5. In the Display Unit Scale group, turn on US
Standard, set the units to Feet w/ Fractional
Inches and then click OK.
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6. From the Command panel, open the Geometry
list and choose AEC Extended.

7. Click the Wall tool.

8. Set the Width to 0’8 3/8”, the Height to 9’0”
and the Justification to Right.

When using a 2D drawing as a template for
building the 3D model, you will commonly set
the justification to left or right so you can trace
the floor plan. In this case the wall will be built
to the right side of the line you are tracing.

9. Click the upper intersection where the master
bedroom wall meets the exterior wall (inset),
then click again where the wall turns at the
outside of the closet. Continue following the
floor plan until you get to the foyer. Right-click
to finish the wall.

The inset shows the endpoint snap cursor at the first
point of the wall.

Note: While building walls, you can use the
mouse wheel to zoom in and out and use the I
(letter “i”) key to pan the view.

10.Click the inside intersection where the second
bedroom wall meets the exterior wall, then
click again at the corner where the wall turns
toward the foyer. Click at the intersection where
the closet starts, forming an “L” shaped wall.
Right-click again to end the wall command.

11.Save the scene as my_Walls1.max.
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Next, you’ll continue to use the Wall command
to build the interior walls.

Interior wall construction:

The interior walls are the thinnest of the three
types of walls you need to create. There are also
many more of them as highlighted in the following
image.

1. Click the Wall tool again and set the Width to
0’5”.

Leave the Height at 9’0” and leave the
Justification at Right, for now.

2. Click the intersection where the fireplace wall
meets the exterior wall , then click again where
the wall turns into the master bedroom. Click
again where the wall intersects the rear wall
that separates the apartments. Disregard door
openings and build walls right over them.

The inset shows the endpoint snap cursor at the first
point of the interior wall.

3. Continue creating interior walls until you’ve
filled the apartment.

If you notice that the justification of a wall is
incorrect, change the justification setting after
the wall is completed and it will align itself
properly.

All of the interior wall.

4. After you’ve created all the interior walls, save
the scene as my_Walls2.max.

Exterior wall construction:

There are three exterior walls that you need to
build to finish enclosing the apartment as shown
in the following image.
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1. Click the Wall tool again and set the Width to
1’2” and change the justification to Left.

Leave the Height at 9’0”.

2. Click the intersection where the second
bedroom wall meets the exterior wall , then
click again where the wall meets the angled
patio door wall. Continue around to finish at
the corner where the master bedroom walls
intersects with the exterior wall.

The inset shows the first endpoint to select. (For clarity,
the other walls are turned off.)

3. Right-click to end the wall command.

All of the walls are built.

4. Save the scene as my_Walls3.max.

Adjust the walls:

Now that you’re familiar with the Wall command,
you may find the need to adjust a wall that you’ve
already constructed or you may want all the walls
you create to be a single object.

You’ll notice that the angled wall where the patio
door is supposed to go is supposed to be thicker
than the other exterior walls. This section of the
tutorial will show you how to adjust an existing
wall and how to attach all the walls so they are a
single object.

1. Continue using the model from the previous
section or open ww_cad_drawing2.max from
the \tutorials\designviz folder.

2. Select the wall along the balcony and switch to
the Modify panel.

3. Open the Wall object in the modifier stack and
select the Segment sub-object level and then
select the angled wall segment where the patio
door should be located.

4. In the Edit Segment rollout, set the width to
1’5”.
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The selected wall is now 1’ 5” thick.

5. Go back to the Wall level in the modifier stack.

You cannot select another wall or object until
you’ve turned off sub-object mode.

6. Select the first wall you created that separates
this apartment from the one behind it. The wall
is named Wall01.

Tip: You can also select the wall by pressing the
H key to open the Select Objects dialog.

7. In the Edit Object rollout, choose Attach
Multiple.

The Attach Multiple dialog is displayed.

8. Click the All button at the lower left to select
all the wall objects and then click the Attach
button.

The walls are now a single object.

9. Save your work as my_Walls_Complete.max.

Create AEC Doors:

AEC doors and windows, when properly created,
will generate their own openings in AEC walls,
thereby reducing the need to use a Boolean
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subtraction or otherwise edit the walls to
accommodate them. To do this correctly, the Edge
snap must be used.

1. Continue using the model from the previous
section or open ww_cad_drawing3.max from
the \tutorials\designviz folder.

2. Ensure that the Snap Toggle is still active, then
right-click it to open the Grid and Snap Settings
dialog.

3. Turn off the Grid Points snap option, and make
sure the Edge/Segment option remains on.
Close the Grid and Snap Settings dialog.

4. Select the wall object, Wall01, right-click, and
choose Properties from the quad menu.

5. On the General panel turn off By Layer in the
Display Properties group and turn off Backface
Cull.

When adding a door, you need to be able to set
two points for the width of the door and a third
point to set the depth corresponding to the wall
thickness. You need to turn off Backface Cull
so you can see the back edges of the wall for
setting the depth.

6. Click OK to close the Object Properties dialog.

7. Right-click the name of the Perspective
viewports, and choose Wireframe from the
pop-up menu.

8. Zoom in and Pan to the doorway leading into
the master bedroom on the fireplace wall.
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9. On the Layers toolbar, open the Layer list and
click the eyeball symbol to hide layer A-Wall.

In order for a door or window to open a wall
properly, you must select the edges of the wall
and not the lines of the floor plan. Temporarily
hiding the A-Wall layer ensures that you will be
selecting AEC Wall edges when placing doors
or windows.

Hidden layers show a mask symbol instead of an open
eye.

10.On the Create panel, open the Geometry list
and choose Doors. Click the Pivot command in
the Object Type rollout.

11.Place the cursor at the base of the interior wall
near the external wall, where the door opening
begins.

12.With the Edge snap indicated, click and drag
the cursor to the opposite side of the door
opening (nearer to the fireplace), then release
to set the width of the door.

13.Move the cursor over the inside-bottom edge of
the wall until the edge snap indicator is visible.
Click to set the depth of the door.

14.Drag the mouse upward, then click to set the
height of the door.

You can tell a door or window is inserted into
a wall correctly because there are additional
edges in the wall object.

15.In the Parameters rollout set the Height to 7’0”,
Width to 2’6”, and Depth to 5”. Set the Open
value to 30.0 degrees and turn on Flip Swing so
the door swing matches the direction shown on
the imported drawing.
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16.Click the object color swatch next to the name
of the door to open the Object Color dialog.
Select a new color for the door so it isn’t the
same blue as the walls.

17. Right-click to end the Pivot door
command and click the Quick Render button
to render the scene.

Now you’ve added a door but it doesn’t really
match up with the floor plan drawing. Next you’ll
adjust the door.

Adjust the Door:

If you look closely at the blue, door swing symbol
that was imported with the floor plan, you’ll
see that the width of the door is too narrow.
Furthermore, the panel in the door defaults to
glass and that’s not necessarily what you want for a
bedroom door.

1. Open the Modify panel while the door
is selected.

2. Change the width of the door to 3’0”.

3. Click the Quick Render button again.

The door looks much better.

4. Scroll down to the Leaf Parameters rollout and
change the Stiles/Top Rail setting to 6”, the #
Panels Horizontal setting to 2 and the # Panels
Vertical setting to 3.

5. Click the Quick Render button again.

The door is much more detailed.

6. In the Panels group, turn on the Beveled option.

7. Click the Quick Render button once more.
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8. Save your work as my_Wall_Door.max.

Experiment by adding more doors to the model.
Some of the closets use the BiFold door type.

Create AEC Windows:

AEC windows are created in much the same
manner as the AEC doors.

1. Continue using the model from the previous
section or open ww_cad_drawing4.max from
the \tutorials\designviz folder.

2. Ensure that the Snap Toggle is still active, then
right-click it to open the Grid and Snap Settings
dialog.

3. Make sure that Edge/Segment is the only active
snap setting and then close the Grid and Snap
Settings dialog.

4. Right-click the name of the Perspective
viewports, and choose Wireframe from the
pop-up menu.

5. If necessary, use Arc Rotate, Pan
and Zoom to display the exterior wall along the
side balcony.

6. Just like you did for the previous Doors section,
hide the A-Wall layer from the Layers toolbar, if
it’s not already hidden.

The A-Wall layer is hidden again.

7. From the Create panel, open the Geometry list
and choose Windows.

8. Choose Fixed from the Object Type rollout.

Create a single fixed window as wide and deep
as indicated in the template and nearly as tall
as the walls.

9. Using the imported, blue window as a guide,
place the cursor at the base of the wall at the side
of the window nearest the angled, exterior wall.

10.With the Edge snap indicated, click and drag
the cursor to the right (toward the second
bedroom), then release to set the width of the
window.
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11.Move the cursor over the outside-bottom edge
of the wall until the edge snap indicator is
visible. Click to set the depth of the window.

12.Drag the mouse upward, then click to set the
height of the window.

13.In the Parameters rollout set the Height to
8’10”, Width to 9’0”, and Depth to 1’2”.

14.Click the object color swatch next to the name
of the window to open the Object Color dialog.
Select a new color for the window so it isn’t the
same blue as the walls.

15. Right-click to end the Fixed window
command and click the Quick Render button
to render the scene.
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Now you’ve added a window into a wall. Next,
you’ll make some final adjustments.

Adjust the Window:

The window needs a little adjustment to
its positioning and to some of the window
characteristics.

1. From the main toolbar, click the Select
and Move button and then right-click it to open
the Move Transform Type-In dialog.

2. In the Offset:World group, enter 1” in the Z
field.

By shifting the window 1” along the Z axis, the
window creates its own opening and leaves a
sill.

A floor to ceiling window centered in the wall.

3. From the Modify panel, in the Parameters
rollout, set the # Panels Horizontal value to 3 to
place three vertical mullions in the window.

4. Experiment by creating the floor to ceiling
window on the angled wall. Set the same height
and width and use the Move tool to shift the
window along the Z axis as you did before.
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5. From the Layer toolbar, open the Layer list and
turn on the A-Wall layer.

You’ll need it visible for the next part of the
tutorial.

6. Save the scene as my_Wall_Window.max.

With the window additions completed, you can go
on to build the floor, ceiling and column.

Create the Floor, Ceiling and Column:

Building the floor, ceiling and column will
demonstrate the use of the Extrude modifier to
quickly create 3D objects using a 2D shape as a
basis.

1. Continue using the model from the previous
section or open ww_cad_drawing5.max from
the \tutorials\designviz folder.

2. Press the H key and select the Layer:Floor
object from the Select Objects dialog and then
click Select.

This is the floor perimeter object you created in
AutoCAD at the beginning of this tutorial.

3. On the Modify panel, expand the Modifier
List and choose the Extrude modifier.

4. In the Parameters rollout, set Amount to -1”.
This allows the template to remain visible while
you continue to work.

5. Select the Layer:A-Wall object.

6. Go to the Spline sub-object level and
select the column spline object.

7. In the Geometry rollout, click the Detach
button and name the new object Column.
Click OK.
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8. Turn off the Spline sub-object mode and select
the Column shape.

9. Open the Modifier List and apply an Extrude
modifier to the Column. Set the Amount to
9’0”.

10.Select the Layer:Floor object, choose Edit menu
> Clone. On the Clone Options dialog, turn on
Copy in the Object group and name the new
object Ceiling.

11.Move the Ceiling object 9’0” along the Z axis.

12.Make sure the Perspective viewport is active
and press the C key.

This will change the Perspective view to a
Camera view.

Tip: If there is no camera in your scene, press
Ctrl-C instead to convert the Perspective view
to a new Camera view.

13. Click the Quick Render button to render
the scene.

14.Save your work as my_Apartment.max.

From here, you can start adding materials and
other objects to furnish the flat.

Importing 3D AutoCAD Models

AutoCAD creates both 3D solids and 3D surfaces,
both of which are imported into 3ds Max as surface
models. In most cases, the conversion process is
completed with no problems; however, there are
occasional errors that must be addressed.

1. Reset 3ds Max.

2. Choose File menu > Import and browse to
the \tutorials\designviz folder. Import the
normals.dwg file.

3. On the AutoCAD DWG/DXF Import Options
dialog, turn off Auto-Smooth in the Geometry



102 Chapter 4: AEC

Options group and turn on Views (Cameras) in
the Include group and then click OK.

4. Make sure the Perspective viewport is active
and press the C key.

This activates the Camera:Globe1 viewport.

5. From the toolbar, choose Quick Render.

As you can see, the surfaces are not smoothed,
and several faces on the globe and base do
not appear because their surface normals are
flipped.

6. Reset 3ds Max, and then re-import the
normals.dwg file.

This time, turn on Auto-smooth and Unify
Normals, as well as Views (Cameras) in the
Include group. Click OK.
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7. View the scene through the Camera:Globe1
camera again.

8. Render the scene again.

The imported objects now appear smooth and
the face normals are all properly unified to face
the same direction.

Adjust the Smoothing and Normals Manually

If you’ve imported a large DWG file, you might not
want to re-import the model. Especially, if there
are only a couple of objects that have insufficient
smoothing or flipped normals. You can adjust
those faulty objects manually using the Smooth
and Normal modifiers.

1. Reset 3ds Max and then re-import the file.

Make sure the Auto-smooth and Unify Normals
switches are turned off, and turn on Views
(Cameras) in the Include group. This duplicates
the settings you used at the beginning of this
tutorial.
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Click OK to import the DWG file.

2. Change the Perspective viewport to view the
scene through the Camera:Globe1 camera by
pressing the C key.

3. Select the Layer:Globe object.

4. Open the Modify panel, and unroll the
modifier list.

5. Scroll down the list and choose the Normal
modifier.

Now the face normals of the globe are reversed.

6. In the Parameters rollout, turn on Unify
Normals and turn off Flip Normals.

The object’s normals all face in the correct
direction.

7. Open the modifier list again and add a Smooth
modifier.

8. In the Parameters rollout, turn on Auto
Smooth.

The Layer:Globe object is smooth.
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Tip: Keep in mind that modifiers are evaluated
from the top of the stack to the bottom. By
adding the Normal modifier before the Smooth
modifier, the faces that were originally flipped
will also have their smoothness corrected by
the Smooth modifier. If you reversed the order,
you would have a model that has all the faces
visible, but the newly flipped faces would not
be smooth.

The same model with swapped modifiers.

9. Repeat the process on the Layer:Base object.

Using File Link with AutoCAD
Drawings

As you experienced in the previous lessons, the
Import functionality of 3ds Max allows you to
load drawings and models that were created with
AutoCAD, Autodesk Architectural Desktop or
Autodesk Mechanical Desktop. A drawing or
model is imported and you can begin making
alterations using the tools in 3ds Max.

Importing is fine for a drawing or model that
is no longer being updated, but what about a
drawing that is still being developed? Architectural
drawings can change greatly in a matter of hours,
so if you’re building an 3ds Max model based on an
imported drawing that is still in flux, you will find
yourself changing and rebuilding many objects
before the project is finished. Perhaps, completely
starting over if the drawings change a lot.

This is a situation where using the File Link
Manager is invaluable. This lesson will show you
the advantages of the tool and how it will save
modeling time.

Set up the lesson:

1. Start AutoCAD and choose File menu > Open.

2. Browse to the \tutorial\designviz folder and
open ww_cad_drawing2Link.dwg.

3. If you see the Proxy Information dialog, it
means there are custom objects in the drawing
that require special Object Enablers if you plan
to edit them. Click OK for now.

4. Choose File menu > Save As and save the
drawing as myDrawing2Link.dwg to the
\tutorial\designviz folder.

This is to preserve the original drawing so the
tutorial can be easily repeated.

5. Minimize the AutoCAD window.
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Make the link:

1. Start 3ds Max or choose File menu > Reset to
rest the program.

2. Choose Files menu > File Link Manager.

The File Link Manager dialog is displayed.

Note: The File link Manager can also be accessed
from the Utilities panel.

3. On the Attach panel, click the File button.

4. From the Open dialog, browse to the
\tutorials\designviz folder and choose
myDrawing2Link.dwg and click the Open
button.

The drawing appears in the file list.

5. Turn on Rescale and make sure the Incoming
File Units are set to Inches.

You want the units to match the default unit size
in the AutoCAD drawing.

6. Click Attach This File.

You’ll see the Status Bar is replaced with the
Linking AutoCAD Drawing progress bar.

Larger, more complex drawing files will take
longer to link.

The drawing is linked to 3ds Max.

7. Click the Files tab on the File Link Manager
dialog.
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This panel shows you have one drawing file
linked to the scene and the status of the linked
file. It also gives you the opportunity to reload,
detach or bind a linked file. You’ll experiment
with these options later.

8. Use Pan, Zoom and Arc Rotate
to display the apartment you worked on earlier.

What you’ve just done is create an active link from
3ds Max to a drawing file and verified that the file
is linked. Next, you’ll start building the model and
see how changes to the drawing affect the scene.

Start building a model:

After you’ve linked a drawing to 3ds Max, you’re
going to start building walls, adding doors and
assigning materials to objects you’ve created. In
this section, you’ll start modeling by adding a wall.

1. Continue from the previous section.

2. Click the Snap Toggle button to activate
it, then right-click the Snap Toggle button.

Right-clicking the button opens the Grid and
Snap Settings dialog.

3. On the Snaps panel, make sure Endpoint is the
only snap setting that is turned on. Close the
dialog.

4. Open the Customize menu and choose Units
Setup.

The Units Setup dialog is displayed.

5. In the Display Unit Scale group, turn on US
Standard, set the units to Feet w/ Fractional
Inches, and then click OK.
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6. On the Create panel, open the geometry list and
choose AEC Extended.

7. Click the Wall button.

8. In the Parameters rollout, set the Width to 5”,
the Height to 9’0” and the Justification to Right.

9. Build the wall enclosing the kitchen and end
where the fireplace wall meets the exterior wall
at the right.

10.Minimize 3ds Max and restore AutoCAD.

The drawing, myDrawing2Link.dwg should
still be open from earlier when you set up the
lesson.

11.Using the Stretch command, make a crossing
selection at the end of the wall that separates
the kitchen from the living/dining room.

12.Specify a base point and then enter @3’,0 for
the second point of displacement.

The kitchen wall is extended to facilitate extra
cabinet and counter space.

13. Save the drawing and then minimize the
AutoCAD window.

14.Restore 3ds Max and notice the entry in the File
Link Manager.

The red flag in the document symbol next to
the linked file indicates a change has occurred
in the master drawing.

15.Turn off Show Reload Options and click the
Reload button on the File Link Manager dialog.

You’ll see the Linking AutoCAD Drawing
progress bar, again.
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The wall in the drawing is extended but the
Wall you built is not.

This situation is easy to fix by editing the Wall
object at a sub-object level and moving the vertex
to match the new endpoint. If you want to add a
door, its insertion into the wall will be treated just
as you learned in the Editing and Creating Objects
tutorial (page 2–86).

Next, after resetting the lesson, you’ll learn how to
manage layers when a drawing is linked.

Reset the lesson:

1. Restore the AutoCAD window and choose File
menu > Close.

2. Open ww_cad_drawing2Link.dwg again.

3. Choose File menu > Save As and resave the
drawing as myDrawing2Link.dwg again to the
\tutorial\designviz folder.

4. Click Yes when asked if you want to save over
the existing file.

5. Minimize the AutoCAD window.

Manage layers:

In this section, you’ll work on a scene that already
has a drawing linked but you’re going to use some
of the layer management features of the File Link
Manager.

1. In 3ds Max, choose File menu > Reset.

2. Choose File menu > Open and open the
scene named ww_cad_file_link.max from the
\tutorials\designviz folder.

If you see the Units Mismatch dialog, choose to
Adopt The File’s Unit Scale.

This scene already has a drawing file linked to
it, but one of the layers you need was frozen in
AutoCAD and by default, frozen layers do not
link unless you specify them.

3. Open the Utility panel and click File Link
Manager. Click the Files tab if the Files panel
is not shown.

Note: If you see a question mark (?) displayed
next to the linked file’s name in the File Link
Manager, it means that the linked file is “lost”.
In this situation, you should click the file name
and then click the folder icon to browse for the
“lost” file. This can occur if you changed the
drive location where 3ds Max is installed. The
sample files assume an installation using default
drive paths.

4. Make sure Show Reload Options is active and
click the Reload button on the Files panel.

The File Link Settings dialog appears.
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5. Click the Advanced tab and then click the Select
Layer To Include button.

This opens the Select Layers dialog.

6. Turn on the Select From List option and
deselect all the layers that are frozen except for
B-Wall.

The frozen layers show a snowflake symbol in
the middle column. A check mark next to a
layer means it will be included when you link a
DWG file.

7. Click OK after you’ve deselected the frozen
layers and then click OK on the File Link
Settings dialog.

The drawing is reloaded and includes the
Layer:B-Wall object.

8. Open the Layer list on the Layers toolbar and
hide the A-Wall layer.
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Now that the new layer has been included, you’ll
use some of the linked geometry to build your
model.

Model with linked geometry:

1. Continue from the previous section and select
the Layer:B-Wall object.

2. Open the Modify panel and choose Edit
Mesh modifier from the Modifier List.

Doing this assigns an Edit Mesh modifier to the
linked geometry.

3. From the Selection rollout, turn on the
Polygon sub-object level.

4. Select all the faces by dragging a window
around the entire object.

Selected faces are displayed in red.

5. In the Edit Geometry rollout, turn on Extrude
and set the Amount to 9’0”.

All the walls and the column are extruded.

Note: The objects on the B-Wall layer are
polylines that enclosed each room. If the
extrusion were done to the objects on the
A-Wall layer, there would have been some flaws
in the extrusion due to gaps and incorrectly
attached lines in the drawing.

6. Minimize 3ds Max and restore AutoCAD.

7. Open the Layer list and do the following:

• Freeze the A-Wall layer.

• Thaw the B-Wall layer and make it the
current layer.
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8. Use the Stretch command and stretch the end
of the kitchen wall 3’0” to the right.

9. Use the Move command and move the column
shape 5’1” to the right.

The kitchen wall is extended and the column is
lined up with the bedroom wall.

10.Save the drawing, minimize AutoCAD and
then restore 3ds Max.

11.On the File Link Manager dialog, turn off Show
Reload Options and click the Reload button.

The drawing changes are reflected in the model.

This last set of steps demonstrated how you can use
linked geometry as a basis for building a model.
Since linked geometry is the basis for this set of
walls, they will change as the drawing changes;

however, they are only simple extrusions. If, for
instance, you wanted to add a door, these walls
will not automatically create an opening when the
door is placed. You will have to perform a Boolean
operation to manually create the opening in the
wall where the door is placed.

Summary

In this tutorial, you learned about the File Link
Manager and how a linked file will update in an
3ds Max scene.

When well-prepared AutoCAD drawings are
imported or file linked, they greatly reduce
the need to make changes after they appear in
3ds Max. In this tutorial, you will identify and
repair errors in a drawing, look at the import and
file link process itself, and learn methods that will
help make importing or file linking AutoCAD
drawings into 3ds Max go smoothly.

Features Covered in This Tutorial

• Pinpointing problematic objects in a drawing
and fixing them during import.

• Fixing problems caused by AutoCAD thickness
settings.

• Understanding problems caused when vast
distances occur between AutoCAD objects and
the drawing origin.

• Reloaded drawing causes materials to change.

Skill Level: Beginner

Time to complete: 45 minutes

Files for This Tutorial

You can find the files for this tutorial in the
tutorials/designviz folder on the Tutorial Files
CD that ships with 3ds Max. Before starting the
tutorials, copy the \tutorials folder from the CD to
your \3dsmax8 local installation.
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Eliminating Errant Objects

With several different layout tab and paper space
options available, objects in AutoCAD drawings
can be widely separated throughout model space.
As a result, objects that are located far from objects
you want to import may be imported as well,
greatly increasing the extents of the 3ds Max scene.

Set up the scene:

• Identify which version of AutoCAD you have
then do one of the following:

• AutoCAD 2000 or later—Start AutoCAD
and choose File menu > Open. Browse to
the \tutorials\designviz folder and open
ts_cad_1.dwg.

• AutoCAD R14—Start AutoCAD and
choose File menu > Open. Browse to
the \tutorials\designviz folder and open
ts_cad_1_r14.dwg.

You’re presented with a 2D drawing of an office
building. Views have been set up to show plan
and perspective views.

Delete errant objects:

When drawings are imported into 3ds Max,
the importance of good layer management is
tantamount. If two objects are on the same
layer and separated by a great distance, you can
start running into problems when the model is
imported into 3ds Max.

1. Open 3ds Max or choose File menu > Reset to
reset the scene.

2. Choose Files menu > Import.

3. In the Select File To Import dialog, set the Files
Of Type field to AutoCAD Drawing (*.DWG,
*.DXF) and navigate to the \tutorials\designviz
folder.

4. Select ts_cad_1.dwg or ts_cad_1_r14.dwg,
depending on your version of AutoCAD.

5. In the AutoCAD DWG/DXF Import Options
dialog, click the Geometry tab if necessary and
turn on Rescale and set the Incoming File Units
to Inches. Click OK.

Note: If you’ve worked through some of the
tutorials, your import settings may differ.
Compare your settings with the settings shown
in the following graphic.
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After the drawing is imported into 3ds Max,
you’ll notice that the viewport does not seem to
have been automatically zoomed to the extents
of the imported drawing, thus causing the
building to appear very small. This is a clear
indication that an errant object is located a
great distance from the scene. In the AutoCAD
file, this object is located on the same layer
as several other objects. When it is imported
into 3ds Max, the objects sharing a layer are
consolidated into a single entity. This wayward
object cannot be deleted without also deleting
the other objects that were imported with it.

6. Reset the 3ds Max scene without saving
anything and minimize the program.

7. Go back to AutoCAD. At the AutoCAD
command line, enter Zoom, then E and
ENTER.

The model space window is increased to
show the entire drawing and since the main
part of the drawing is condensed toward the
lower left corner, it means the errant objects
are somewhere in the upper right part of the
viewport.

8. Use the Erase command and drag a selection
window around the upper right corner of the
AutoCAD viewport until the small line objects
(there are four) are selected. Delete these
objects.

9. Do another Zoom > Extents to display the
drawing properly.

10.Save the drawing as myImport.dwg, then
import it into 3ds Max again.

This time the file imports and displays correctly.

Tip: Another way to ensure that only the
required objects are imported is to execute the
WBlock command in AutoCAD and select only
the essential objects to be incorporated into a
new DWG file.

Make sure to close polylines:

Most designers whose primary tool is AutoCAD,
create drawings with lines, arcs and circles.
However, using polylines to create perimeter
objects offers the quickest means of converting a
2D drawing into a 3D model. If drawn correctly, a
polyline can be quickly extruded into a large solid
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surface like a poured concrete floor or a set of walls
when the drawing is imported into 3ds Max.

1. Continuing from the previous section, select
the Layer:LEASELN2 object and apply an
Extrude modifier.

2. Adjust the Amount value so that you can see
the extrusion in the viewport.

Notice that the spline that follows the perimeter
of the building is extruded, but the top is not
capped. This is an indication that the polyline
was not closed in the AutoCAD drawing.

3. Delete the Layer:LEASELN2 object.

4. In AutoCAD, open the myImport.dwg. Select
the blue polyline on the LEASELN2 layer.

5. At the AutoCAD command line, enter Pedit,
then press ENTER. Type C for Close, then press
ENTER twice.

You have closed the gap in the polyline with an
additional segment.

6. Save the drawing.

7. In 3ds Max, begin the process of importing
the drawing again. Stop when the AutoCAD
DWG/DXF Import Options dialog opens.

8. In the AutoCAD DWG/DXF Import Options
dialog, switch to the Layers panel.

9. Activate the Select From List option. Select only
the LEASELN2 layer, then click OK.

Only the objects on the LEASELN2 layer are
imported.

10.Select the Layer:LEASELN2 object again and
apply the Extrude modifier.

This time the spline is capped.

Tip: If several polylines must be closed in
AutoCAD, type Pedit on the command line,
the press ENTER. Type M to allow multiple
selection and select all the polylines that need
to be closed.

Use File Link instead of Import:

The section you just completed made exclusive use
of the Import functionality of 3ds Max, but what
would have been different if you had used the File
Link Manager?

1. Using AutoCAD, open the file ts_cad_file_
link.dwg and choose File menu > Save As.

2. Name the file myImport2.dwg.

Doing this preserves the original drawing so
the tutorial can be easily repeated.

3. In 3ds Max, choose File menu > Reset and
discard the current scene without saving.

4. Choose File menu > File Link Manager and
click the File button on the Attach panel.

5. Open myImport2.dwg, turn on Rescale and
click the Attach This File button.

There is now an active link between the drawing
in AutoCAD and 3ds Max.
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6. Select the Layer:LEASELN2 object and apply
an Extrude modifier.

7. Adjust the Amount value so that you can see
the extrusion in the viewport.

Just as in the last section, the object is not
capped due to the open polyline. Here’s where
the workflow process differs.

Fix the drawing and reload the link:

1. In AutoCAD, enter the Pedit command and
select the blue polyline on the LEASELN2 layer.

2. Type C for Close and press ENTER twice to
complete the command.

3. Save the drawing.

4. In 3ds Max, click the Files tab of the File Link
Manager dialog.

The red flag means the drawing has been
updated.

5. Make sure Show Reload Options is active and
click the Reload button.

6. Click the Advanced tab and turn on Selective
Reload.

7. Turn on Selected In Scene and click OK.
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Since the Layer:LEASELN2 object was left
selected after applying the extrude modifier
only that object is reloaded from the drawing
file. You could have also chosen from
the list of linked objects by choosing the
Layer:LEASELN2 object and clicking the Invert
button.

Resolving Other Common CAD
Problems

Many companies that use AutoCAD have vast
archives of drawings that were originally created
many years ago. If you need to work with any
of these drawings or models, you can encounter
problems in 3ds Max because of the way older
AutoCAD settings and objects are now interpreted.
Such common problems involve the following:

• Great distances between objects in the CAD
drawing and the drawing origin.

• The use of the Thickness setting to display
objects that projected into the Z-axis, like
extrusions.

• Imported objects are not as smooth as you
would like them.

• Unit settings saved with the CAD model need
rescaling.

• Texture maps applied to a CAD model, are not
found when the model is opened in 3ds Max.

Drawing origin placement:

Large scale drawings can pose problems due to
objects being placed at vast distances from the
drawing origin.

1. In AutoCAD, open ts_cad_2.dwg or
ts_cad_2_r14.dwg, depending on the version of
AutoCAD you’re running.

2. Choose File menu > Save As and save the file as
myImport3.dwg.

Once again, you’re doing this to preserve the
original drawing so the tutorial can be easily
repeated.

3. Minimize AutoCAD.

4. Open 3ds Max or choose File menu > Reset to
reset the scene.

5. Choose File menu > Import and open
myImport3.dwg.

6. On the AutoCAD DWG/DXF Import Options
dialog, turn on Rescale in the Scale group and
set the Incoming File Units to Feet.

7. After you click OK in the AutoCAD DWG/DXF
Import Options dialog, a warning indicates a
potential problem with the file. Click Yes to
proceed. You’ll deal with this in a later step.

8. In the Perspective viewport, zoom in to get
a better view of the scene. You’ll see several
objects, but not all of them on the ARWALL
layer. These objects have vertical faces with
normals pointing in a number of directions.

9. Reset and minimize 3ds Max.
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10.Restore AutoCAD and initiate the Move
command.

11.Select the entire drawing and when asked to
specify a base point, pick a point near the center
of the drawing.

12.When asked to specify a second point of
displacement, enter the coordinates 0,0,0 and
press ENTER.

This moves all the objects to the origin and
allows 3ds Max to more accurately determine
location data.

13.Perform a Zoom Extents and then save the
drawing.

14.Restore 3ds Max and choose File menu >
Import.

15.Open myImport3.dwg and make sure to turn
on Rescale.

16.Set the Incoming File Units to Feet and click
the OK button.

You have now eliminated the warning message
that displays while importing the drawing.

For more information about the importance
of keeping the model close to the scene origin,
refer to the System Unit Setup Dialog topic.

Remove line thickness:

While a drawing that contains lines with thickness
may give the appearance of a 3D model in
AutoCAD, the lines only display a framework.
These can sometimes pose problems when
imported to 3ds Max so this section demonstrates
how to quickly rest them.

1. Continue from the previous section and
minimize 3ds Max.

2. Restore AutoCAD and open the Layer
Properties Manager and then make ARWALL
the current layer while freezing all the others.

3. From the menu, choose View > Named Views.
In the View dialog, select West, then click Set
Current. Click OK.

The view adjusts to a perspective orientation.
Only lines have a Thickness value; therefore
only they should be selected so the values can
be adjusted at the same time.

4. Use Zoom Extents to see the entire drawing.

5. At the AutoCAD command line, type Change,
press ENTER, then type ’filter to begin the
command and open the Object Selection Filters
dialog.

6. From the Select Filter drop-down list, choose
Line, then click Add To List, then Apply.

3dsmax.chm::/system_unit_setup_dialog.html
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7. Using a selection window, select all the objects
in the scene, then press ENTER twice to return
to the Change command.

Only the Line objects, as defined by the Filter
command, are selected.

8. Type P (for Properties) then T (for Thickness)
and then enter 0 when prompted to specify a
new thickness. Press ENTER twice.

The lines on ARWALL layer are now uniformly
at zero thickness.

9. Save the drawing, then import the file into
3ds Max again.

Adjust smoothness:

There are two ways to deal with smoothness when
you import or file link a 3D object to 3ds Max.
You can make adjustments to smoothing groups
that will give the illusion of smoothness when a
model is rendered or you can increase the number
of faces and surfaces of an object to get smooth
results. This section addresses the two methods of
handling smoothness.

1. Reset 3ds Max and choose File menu > Import.

2. Open canopy.dwg from the \tutorials\designviz
folder, stopping when the AutoCAD DWG/DXF
Import Options dialog opens.

3. Turn on Rescale and set the Incoming File Units
to Inches.

4. In the Geometry Options group, turn on
Combine Objects By Layer and set the
Smooth-Angle setting to 15, if necessary and
then click OK.

5. Switch to the Perspective viewport to a User
viewport by pressing U.

6. Using Zoom Region and Pan, zoom
into the central part of the model until you can
clearly see the canopy overhanging the main
doors.
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You might have to use Zoom Region a couple of
times and pan around a little.

7. Choose Rendering menu > Environment and
turn off the Active switch in the Exposure
Control rollout.

If left on, the colors in the scene are over
saturated and appear to be self-illuminated.

8. From the toolbar, choose Quick Render.

Notice that the cylindrical canopy element is
segmented rather than smooth. This is because
the Smooth-angle value was set too low during
import.

9. Press H to open the Select Objects dialog and
select the Layer:CanopyEnd object.

10.Delete the Layer:CanopyEnd object.

11.Import the file again. Stop when the AutoCAD
DWG/DXF Import Options dialog opens.

12.On the Geometry panel, make sure Rescale is
on and set to Inches, Combine Objects By Layer
is turned on and set the Smooth-Angle to 60.

13.Open the Layers panel and activate Select From
List.

14.Click the None button, scroll to the bottom of
the list and then choose the CanopyEnd layer.
Click OK.
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15.Zoom and Pan to the canopy and render the
scene again.

Notice that the object looks much smoother.

16.Right-click the User viewport label and change
it to Wireframe.

In this display mode, you can see that the
Layer:CanopyEnd object does not have much
detail and relies upon smoothing groups to
derive its smoothness.

Adjust smoothness with File Link:

This section will basically repeat the previous
section but incorporates the File Link Manager
and also highlight the Surface Deviation setting for
3D solids. Surface Deviation is very useful when
dealing with 3D objects that always seem to have
jagged edges when they’re imported or linked to
3ds Max.

1. Reset 3ds Max and choose File menu > File
Link Manager.

2. Click the Files button and open canopy.dwg
from the \tutorials\designviz folder.

3. Turn on Rescale, set the Incoming File Units to
Inches and click Attach This File.

4. Switch the Perspective viewport to a User
viewport by pressing U.

5. Use Zoom Region and Pan to zoom
into the central part of the model so you can
see the canopy again.

6. Choose Rendering menu > Environment and
make sure the Active switch in the Exposure
Control rollout is turned off.

7. From the toolbar, choose Quick Render.
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The cylindrical canopy element is segmented
again. When doing a File Link, you initially do
not have control over settings like smoothness.

Note: If your cylinder is already smooth, it is
most likely because you already have a low
surface deviation setting from a previous file
link procedure.

8. In the File Link Manager dialog, click the Files
tab.

9. Make sure Show Reload Options is active and
click the Reload button.

The File Link Settings: DWG Files dialog is
displayed.

10.On the Basic panel, reduce the Surface
Deviation For 3D Solids to .05.

Note: Lower Surface Deviation settings result in
greater detail in the geometry.

11.On the Advanced panel, turn on Selective
Reload and click the Linked Objects button.

The Select Linked Objects dialog is displayed.

12.Click the None button, scroll to the bottom of
the list and then choose the Layer:CanopyEnd
object.

13.Click OK twice to reload the element.



Resolving Other Common CAD Problems 123

14.Render the scene again.

The object is reloaded and is smoother just like
the previous exercise using the Smooth-Angle
setting but there is a key difference that is most
apparent when viewing the scene in Wireframe
mode.

15.Right-click the User viewport label and choose
Wireframe.

Notice how many segments make up the
geometry of Layer:CanopyEnd. The key benefit
to using the Surface Deviation setting for 3D
Solid objects is the amount of detail that comes
across to 3ds Max. Geometry with higher
quantities of faces and surfaces are more refined
which results in a smoother model.

If detail is still missing, you can choose Reload
and further reduce the Surface Deviation
setting.

Rescale units and find missing maps:

The units used in the AutoCAD drawing must
match the units used in the 3ds Max scene. The
scene can either adopt the unit system used in the
AutoCAD file, or objects can be rescaled as they
are imported into 3ds Max.

Note: Photometric lights in 3ds Max are, by default,
set to use international units as their unit scale. If
the objects are rescaled and photometric lights are
used, you must change the Lighting Units value
in the Units Setup dialog to allow for the proper
inverse square falloff calculations.

1. Reset 3ds Max and choose File menu > Open.
Set the Files Of Type to VIZ Render (.drf)
format.

2. Browse to the \tutorials\full_house folder
and open tut_living_room06.drf. This is
an Autodesk VIZ Render file created with
Architectural Desktop 2004 that causes the
Units Mismatch dialog to appear.

3. The dialog indicates the DRF unit scale is in
meters while the 3ds Max unit scale is in inches.
Select Rescale The File Objects to the System
Unit Scale. Click OK.

If you installed 3ds Max to a drive path other
than the default path, you may encounter the
Missing External Files dialog. The Missing
External Files dialog appears and lists missing
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map files that 3ds Max cannot locate. If the
map files are stored on your system, you will
need to add their folder path in the Configure
External File Paths dialog when you click the
Browse button. If the files are not available, you
will need to substitute them from the Material
Editor.

4. Choose Customize > Units Setup. Set the
Lighting Units to American and click OK.

5. Render the scene.

Summary

In this tutorial, you learned about diagnosing and
fixing problems you might come across when
working with 2D CAD drawings and 3D models.
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Inventor Interoperability

Inventor Interoperability:

Autodesk Inventor parts and assemblies can be
imported directly from the Import command in
the File menu. To use this feature, Inventor has to
be loaded on the same machine as 3ds Max. This
tutorial covers the options available within the
Autodesk Inventor File Import dialog.

Note: Inventor 10 is required to open the files
within this tutorial.

Skill Level: Beginner

Time to Complete: 1 hour

Features Covered in This Tutorial:

• Merge/Replace file options

• Mesh resolution setting

• Importing Inventor Assemblies

• Importing Inventor Materials

• Controlling vertical axis direction

Tutorial Files

All the necessary files for this tutorial can be found
on the Tutorial Files CD in the \tutorials\inventor
directory. Before starting the tutorials, copy
the \tutorials folder to your local \3dsmax8
installation.

In This Tutorial

Using the Mesh Resolution Option (page 2–125)

Importing an Assembly (page 2–127)

Importing an Assembly with Materials (page
2–128)

Controlling Vertical Axis Direction (page 2–130)

Using the Mesh Resolution Option

The inventor translator can generate different
mesh resolutions. When importing, you can
choose the resolution that suits the needs of the
project.

1. From the File menu select Import.

2. In the Select File to Import dialog, set the file
type to Autodesk Inventor (*.IPT,*.IAM).

3. Select Brake Rotor.ipt, and click Open.

4. Set the Completely Replace Current Scene
option.

5. Set the Mesh Resolution to –10 by moving the
slider all the way to the left.

6. Verify the Inventor File Vertical Direction is set
to Z Axis.
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7. Click OK to import the file.

8. Press F4 to view edged faces.

Now you’ll import the same file using a higher
resolution.

9. From the File menu, select Import.

10.Select Brake Rotor.ipt and click OK.

11.Set the Merge with Current Scene option. This
will bring in the rotor and retain the current
one in the scene.

12.Set the Mesh Resolution to 10 by moving the
slider all the way to the right.

13.Click OK to import the file.

14.A warning appears indicating there is an Import
Name Conflict.

15.Click OK to accept the new name offered.
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16.The new Brake Rotor comes in on top of the
old one.

17. Click, and then right-click, the Move tool.

18.Enter 12 in the X axis field.

The two rotors illustrate the different settings for mesh
resolution.

Next

Importing an Assembly (page 2–127)

Importing an Assembly

Inventor assemblies, (*.iam) can be imported in
the same fashion as individual Inventor parts,
(*.ipt). Part names applied in Inventor are
preserved in the translation.

1. From the File menu, select Import.

2. Set the file type to Inventor (*.IAM, *.IPT)

3. Select Turbocharger.iam.

4. Click Open.

5. Select Completely Replace Current Scene.

6. Click OK to import.
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7. Press H to open the Select By Name dialog.

The names are consistent with those applied in Inventor.

The portion of the Inventor Browser bar
shown illustrates the part names in the
Turbocharger.iam file.

Next

Importing an Assembly with Materials (page
2–128)

Importing an Assembly with
Materials

In this section, you’ll see how the Inventor
translator handles materials and material IDs.

Note: You will need Inventor 10 to open the sample
files in this tutorial.

1. Start Inventor.

2. Open Turbocharger.iam.

The components of the turbocharger model
have materials applied to them. Two of the
components, the compressor and turbine
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housings, have different materials assigned to
individual surfaces, the equivalent of multi
sub-object materials within 3ds Max. The
translator recognizes these materials and will
bring in both materials and material ID’s.

3. Start 3ds Max.

4. From the File menu, select Import.

5. Set the file type to Inventor (*.IAM, *.IPT)

6. Select Turbocharger.iam.

7. Click Open.

8. Select Completely Replace Current Scene.

9. Select the Import Inventor Materials option.

10.Select the Assign Material IDs option.

11.Click OK to import the assembly.

12.Press M to open the Material Editor.

13. Click Get Material.

14.From the Browse from group of the
Material/Map Browser, set the Scene option.

15.The materials assigned to the scene objects are
listed.

16.The compressor and turbine housings have
Multi/Sub-Object materials, while the center
section has an Architectural material.

Next

Controlling Vertical Axis Direction (page 2–130)
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Controlling Vertical Axis Direction

Autodesk Inventor allows you to model with either
the X, Y or Z axis vertical. In 3ds Max, the Z axis
is the vertical direction. When Autodesk Inventor
models are imported you specify whether the X,
Y or Z axis in the Inventor file is aligned with the
3ds Max Z axis.

1. From the File menu, select Import.

2. Set the file type to Inventor (*.IAM, *.IPT).

3. Select Axis Tripod.iam, and click Open.

4. Set both materials options.

5. Verify the Vertical Direction is set to Z Axis.
6. Notice how the X, Y and Z axes of the imported

Inventor file match those of the 3ds Max axes.

Now you’ll import the same file again with X
Axis as Vertical.

7. From the File menu, select Import.

8. Select the Axis Tripod.iam file again.
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The X axis is aligned with the 3ds Max Z axis.

Next import the file with Y defined as vertical.

9. From the File menu, select Import.

10.Select the Axis Tripod.iam file again.

11.Adjust the viewing direction to see the axis
labels.

The Y axis is aligned with the Z axis in 3ds Max.

Summary

In this tutorial you worked with several options
available in the Autodesk Inventor Import dialog.
Mesh resolution can be adjusted up or down
from the default setting to suit the needs of the
project. An Inventor assembly file, (*.iam) can
be imported in the same fashion as an Inventor
part file, (*.ipt). The names of the parts within the
assembly retain their Inventor names. You have
the option of including materials that were applied
to parts within Inventor. If multiple materials were
applied to a single part, the materials IDs can also
be imported. The materials appear in the 3ds Max
material/map browser after import. Finally, you
can control which Inventor axis is aligned with the
Z axis in 3ds Max.
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Revit Interoperability

Revit Interoperability

In this tutorial, you learn how to use 3ds Max
in conjunction with Autodesk Revit 7. Autodesk
Revit is a building system that lets you
conceptualize your architectural designs quickly
and efficiently. Once you have created your design
in Revit, you can export it and link it to 3ds Max to
create high quality renderings and animation.

Skill Level: Beginner

Time to Complete: 2 hours

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Configure map paths

• Export Revit designs in DWG format

• Link Revit files to 3ds Max

• Manage scene data

• Change the Revit design and update the 3D
scene

Tutorial Files

All the necessary files for this tutorial can be found
on the Tutorial Files CD in the \tutorials\revit
directory. Before starting the tutorials, copy
the \tutorials folder to your local \3dsmax8
installation.

Lessons In This Tutorial

Configuring Map Paths (page 2–132)

Linking Autodesk Revit to 3ds Max (page 2–133)

Managing Scene Data (page 2–134)

Adjusting Materials in 3ds Max (page 2–135)

Maintaining the Link between Autodesk Revit and
3ds Max: (page 2–137)

Configuring Map Paths

Autodesk Revit assigns different types of materials
to objects. Some of the materials are based on
bitmap images found in the Revit installation
folder.

When you plan to link Autodesk Revit scenes
into 3ds Max it’s best to set up map paths so that
3ds Max is able to find the needed bitmaps so you
do not have to look for them manually. You can
achieve this by configuring the paths to locate
different kinds of files including bitmaps. In this
lesson, you add a path to the folder that contains
all of Revit’s bitmaps.

Add a map path:

1. Start 3ds Max.

2. From the Customize menu, choose Configure
Paths.

3. In the Configure Paths dialog. open the
External Files panel.

4. Click the Add button to add a map path to the
list.
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5. Navigate to the following folder:

C:\Documents and Settings\All
Users\Application Data\Autodesk\Revit
7.0\Rendering

6. Turn on the Add Subpaths option. This ensures
that all subfolders under Rendering are added
to the list.

7. Click Use Paths to exit the dialog, and then click
OK to exit the Configure Paths dialog.

8. Close 3ds Max.

Next

Linking Autodesk Revit to 3ds Max (page 2–133)

Linking Autodesk Revit to 3ds Max

In this lesson, you learn how to export Revit
designs using the DWG output. You will then link
the DWG file to 3ds Max using File Link Manager.
The advantage of using File Link Manager instead
of simply importing the file is that you keep a “live
link” between the DWG file that was exported
from Revit and 3ds Max. If you decide to make a
change in the Revit file, that change can easily be
updated in 3ds Max.

Set up the lesson:

1. Start 3ds Max.

2. Go to the File menu, choose Open and
navigate to the \tutorials\revit folder. Highlight
detached_garage.max and click Open.

The scene is empty except for a daylight system
that is hidden from view at this time. The
renderer has been set to use the mental ray
rendering engine, and the units were set in feet
and inches to match the units setup in Autodesk
Revit.

3. Minimize 3ds Max.

4. Start Autodesk Revit.

5. Go to the File menu, choose Open and navigate
to the \tutorials\revit folder.

6. Highlight detached_garage.rvt and click Open.
The scene shows a detached garage made of
various parametric components. Materials are
also attached to the various objects.

Export Autodesk Revit designs to DWG format:

1. From the File menu, choose Export, and then
choose the option, DWG, DXF, DGN from the
cascading menu.

2. In the dialog that appears, ensure the Save as
type option is set to AutoCAD 2004 DWG Files.

3. Browse to a location on your hard drive where
you want the files to be saved.

4. Name the file detached_garage.dwg, and then
click Save.

Note: Your viewport in Revit has to be set to a
3D view in order for objects to be exported to
the DWG file as 3D objects.

Use File Link Manager:

1. Restore 3ds Max.

2. Go to the File menu and choose File Link
Manager.

The File Link Manager dialog appears.

Tip: You can also access the File Link Manager
from the Utilities panel.
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3. On the Attach panel of the File Link
Manager dialog, click the File button, and
then browse to the folder where you saved
detached_garage.dwg.

4. Double-click the file name to select it.

5. From the Preset drop-down menu, choose
Revit. This preset has been optimized to ensure
a better translation between Revit objects and
3ds Max.

6. In the File Link Manager dialog, turn on
Rescale.

Note: With the Rescale option turned on,
3ds Max automatically detects the incoming
file’s units setup and displays it in the
drop-down menu. Leave this option to Inches
for this lesson as it matches the units set in
PRODNAME (1 unit = 1 inch).

7. Click Attach this File to link the Revit design to
3ds Max. Once the design is loaded, you can
close the File Link Manager dialog.

8. Adjust your perspective view to get a better
look at the geometry.

Next

Managing Scene Data (page 2–134)

Managing Scene Data

3ds Max organizes and names file linked objects to
reflect their structure in Revit, using a parent-child
hierarchy. The parent object is a node that has one
or more child objects. In addition, objects of the
same nature (based on categories in Revit), are
mapped to layers via the Revit Export Layers table
to simplify object selection and management in
3ds Max.

Use hierarchies:

1. In 3ds Max, select the decorative door in the
Perspective viewport. Using the Select and
Move tool, try to move the door in the scene.
Notice that the door frame remains in place.

2. Cancel or undo the door move command.

Tip: Another way to do this is to go to the
Modify panel while the door is selected and
click Reset Position.

3. Press H on the keyboard to access the Select
Objects dialog. If you need to, resize the dialog
so you can see the extents of object names in
the list.

4. Notice that the selected door is only one part of
a hierarchy of objects.

Note: At the bottom of the dialog, make sure the
Display Subtree option is active. This displays
the hierarchy of objects and shows which child
nodes belong to which parents.

5. Select the parent of that hierarchy, the object
called Doors <Single-Decorative 2 : 36”x84”>

Note: If the Select Subtree option at the bottom
of the dialog is turned on, selecting a parent
selects the whole hierarchy, which can be very
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useful if you want to overwrite a material as you
will see in a later lesson.

6. Click the Select button to exit the dialog. Try
to move the selected object and notice that all
elements that define the door move with it.

Use layers:

1. Make sure the Layers toolbar is visible. If not,
right-click an empty area of the main toolbar
and choose Layers.

Tip: You can also right-click at the edge of the
main toolbar or any toolbar when it’s docked,
or right-click the toolbar’s title bar if it’s
undocked to access the right-click menu.

2. In the Layer toolbar, click the arrow on the layer
drop-down list. Notice all the names that were
derived from the Revit Export to DWG.

3. Select one of the burgundy shaded walls in the
scene.

4. On the Layer toolbar, click the Set Current
Layer to Selection’s Layer button. This will
make the wall layer (3D-WALL) current.

5. On the Layer toolbar, click the Select
Objects in Current Layer button. All objects

sharing the same layer (all four burgundy
shaded walls) are now selected.

Next:

Adjusting Materials in 3ds Max (page 2–135)

Adjusting Materials in 3ds Max

The Revit DWG Exporter embeds material
information on objects it exports. 3ds Max uses
this information to translate and maintain the
material assignment to the resulting scene object.
The results you see in the 3ds Max scene, in
terms of how the materials are applied, should
match what you see in the Revit model, with the
exception of Revit’s procedural materials. In this
case, only the top-level definition is retained.

Verify material translation:

1. In 3ds Max, press M to open the Material
Editor.

2. Choose an empty material slot.

3. Click the Pick Material from Object
button, and click on the grass in the scene.

Notice the Default Zoning Envelope material
displays in the Material Editor and that it has a
bitmap associated with it.

4. If not already turned on, turn on Show
Map in Viewport to see the texture in the
scene. This material is based on a bitmap
(GRASS-1.jpg) and has translated properly in
3ds Max.

5. Choose another empty sample slot in the
Material Editor. Using the eyedropper, click on
the roof in the viewport.

The Roofing – Asphalt Shingle material appears
in the Material Editor.

6. If not already turned on, turn on Show Map
in Viewport to see the texture on the roof.
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Although texture scaling seems accurate, the
orientation of the shingles on all 4 sides of the
roof is incorrect. You will fix that in a moment.

7. Choose another empty sample slot in the
Material Editor.

8. Using the eyedropper, click on one of the
burgundy walls.

The Masonry - Brick material appears in the
material editor.

9. Expand the Special Effects rollout. Notice
that both the Diffuse Map and the Bump Map
channels are empty. This material definition in
Revit was not based on a bitmap but instead is
based on a procedural map. You will need to
make the necessary adjustments in 3ds Max.

Fix the orientation of the shingles:

1. Click the roof to select it.

2. Go to the Modify panel. From the
Modifier list, under World Space Modifiers,
choose MapScaler (WSM). The orientation of
the shingles is now correct on all 4 sides of the
roof.

Note: : The MapScaler modifier is mostly used
to change the scale of the map, but in this
case, you use it as a quick fix for orientation
purposes. Notice the default scale of 1 inch
(one unit) on the MapScaler’s scale value. This
means that the scale translated from Revit is
retained. Feel free to change the scale value if
you need to change the size of the shingles.

Edit the Brick material:

1. In the Material Editor, make sure the Masonry
– Brick sample slot is selected.

2. Click the Diffuse Color swatch and change it to
beige or a light tan color. If you wish, you can
use RGB values of R=230, G=220, B=200.

3. In the Special Effects rollout, set the Bump
value to 250, and then click the None button.

4. From the Material/Map Browser that appears,
double-click on Bitmap.

5. Locate the file called Brick_BUMP jpg, and
double-click to select it.

Note: This image file shows a stack of brick that
are two across by six down. This translates into
16” x 16” in real-world measurements.

6. In the Coordinates rollout, make sure the Use
Real-World Scale option is turned on. Set both
the Width and Height sizes to 1’4” (16”).

7. Turn on Show Map in Viewport to see the
properly sized brick layout in the scene.

Overwrite the Door material:

1. Press H to access the Select Objects dialog.

2. At the bottom of the dialog, turn on Select
Subtree.

3. Click the object named Doors <Single-
Decorative 2 : 36”x84”>. The parent object and
all its children are highlighted.
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4. Click Select to select the objects in the scene
and close the dialog.

5. In the Material editor, choose an empty slot.

6. If the Material type is listed as Standard, click
the Standard button and use the Architectural
material instead.

7. Name the new material White Paint.

8. From the Templates drop-down list, choose
Paint Semi-gloss.

9. Change the Diffuse Color to white or to
off-white. If you want, you can use these RGB
values R=250, G=240, B=230.

10. Click the Assign Material to selection to
assign the new material to the selected objects.

Assign the new White Paint material to all the
window frames:

1. Zoom in on one of the windows and select the
window frame.

2. In the Material Editor make sure the white paint
material is still selected.

3. From the Options menu, make sure that
Propagate Material to Instances is active.

This ensures that objects of the same type in the
Revit DWG file get the same material treatment.

4. Click Assign Material to selection to
overwrite the existing window frames material
with the White Paint material.

Next:

Maintaining the Link between Autodesk Revit and
3ds Max: (page 2–137)

Maintaining the Link between
Autodesk Revit and 3ds Max:

When you decide to make changes to your Revit
design, you can export the edited design to the
same DWG file you used previously. This way,
changes to the DWG will be recognized by the File
Link Manager in 3ds Max.

Change the Revit design:

1. Start Autodesk Revit 7 if it is not already
running.

2. Make sure the detached_garage.rvt file you
used earlier is opened.

3. In the Project Browser window, under Floor
Plans, double-click on Ground. The view
changes to a top view.

4. Select the door on the left wall.

Notice the door is 3’-0” away from the garage
entrance wall and 21’-0” away from the back
wall. You are going to invert that.

5. Click once on the 3’-0” dimension label to edit
it.

6. Type in a value of 21, and then press ENTER.

The door is now 3’ away from the back wall.

7. Select the planter object outside the left wall.
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It is presently 11’-0” away from the back wall.

8. Click once to select the 11’-0” dimension label.

9. Type in a value of 20, and then press ENTER.
The planter is now closer to the front wall. On
the main toolbar, click the 3D button to revert
back to a 3D view.

10.From the File menu, choose Export and
choose the option, DWG, DXF, DGN from the
cascading menu.

11.In the dialog that appears, ensure the Save as
type option is set to AutoCAD 2004 DWG Files.

12.Browse to the location on your hard drive
where you saved detached_garage.dwg earlier.

13.Select that file and then click Save.

A warning box appears.

14.Answer Yes to overwrite the existing DWG file.

Reload the scene in 3ds Max:

1. In 3ds Max, go to the File pull-down menu and
choose File Link Manager.

On the Files panel, notice the red flag that
appears informing you that the linked file has
changed.

2. On the Files panel, make sure the Show Reload
Options check box is active.

3. Click the Reload button. From the dialog that
appears, go to the Advanced tab.

4. Turn on Use Scene Material Definitions and
Use Scene Material Assignments on Reload.

These two options ensure that any editing of
materials in 3ds Max is retained.

5. Click OK to reload the updated Revit design.
The positions of the door and planter are
updated, but their materials still retain the
changes made in the Material Editor.

6. Render the scene to view the results.
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ADT Interoperability

Working with Architectural
Desktop Files

Drawings and models that are created in Autodesk
Architectural Desktop can greatly differ from
AutoCAD drawings and models in that you can
build with specialized objects like Walls, Doors,
Windows, etc. These objects have the advantage
of utilizing styles that set certain characteristics.
But, that still doesn’t mean you have to rely on
Architectural Desktop to build and manage the
model. This tutorial shows you how you can
use 3ds Max in conjunction with Architectural
Desktop to improve on, and detail a model.

Skill Level: Beginner

Time to Complete: 1 hour

Features Covered in This Tutorial

• Linking an Architectural Desktop drawing

• Using the Substitute modifier to replace objects
in a scene

• Adjusting the positions of instanced objects

• Assigning materials by using the “drag and
drop” method

• Edited object style definitions

• Solving common problem with CAD drawings
and models

Tutorial Files

All the necessary files for this tutorial can
be found on the Tutorial Files CD in the
\tutorials\small_office directory. Before starting
the tutorials, copy the \tutorials folder to your local
\3dsmax8 installation.

Managing Architectural Desktop
Data in 3ds Max

Now that you’ve had a chance to use the File Link
Manager with AutoCAD drawings, let’s explore
more tools for handling Autodesk Architectural
Desktop data using a small office layout. You will
learn how to substitute for Architectural Desktop
blocks in 3ds Max, how to manage the substitute
objects, and create a rendering.

Substitute for Architectural Desktop blocks:

1. Start Architectural Desktop, and choose File
menu > Open.

Find the \tutorials\small_office folder on your
hard drive and highlight small office.dwg, then
click Open.



140 Chapter 4: AEC

2. Minimize Architectural Desktop and start
3ds Max.

3. Choose File menu > File Link Manager.

4. On the Attach panel, click the File button
and open small office.dwg from the
\tutorials\small_office folder.

5. Turn on Rescale and make sure Incoming File
Units are set to Inches and then click the Attach
This File button.

If this is the first time you have used File Link
Manager, you will see the File Link Settings:
DWG dialog. Accept the defaults by clicking
OK.

When the scene data is loaded, you will see a
shaded 3D view of your Architectural Desktop
scene.

6. On the Layers list, click the down arrow to
see the list of layers you have inherited from
Architectural Desktop.

7. Click the eyeball symbol next to the
A-Glaz-Curt layer name to hide this layer in
3ds Max.

8. Click the Arc Rotate button on the
viewport navigation controls, and drag your
mouse in the viewport to adjust your view
so you can see all the blocks. Right-click
the Perspective label in the upper left of the
viewport. Choose Wireframe. Right-click the
Perspective label again and turn off Show Grid
to simplify your view in the viewport.

9. Select one of the chair shapes in the larger part
of the office.



Managing Architectural Desktop Data in 3ds Max 141

A three-arrow axis tripod is displayed at the
insertion point of the chair block.

10.With the shape selected, click Modify panel
and choose Substitute from the Modifier List.
In the Parameters rollout, click the Select XRef
Object button.

An Open File dialog is displayed. Choose the file
admin chair.max in the \tutorials\small_office
folder, and click Open.

Note: Only a single object can be used as the
substitute when using the Substitute modifier.
For example, let’s say the admin chair was made
of three components; the cushions, the frame
and casters. You could only use one of those
objects as the Substitute modifier replacement.
If you run into this problem, attach all three
components together to form a single object
first, then use it with the Substitute modifier.

11.An XRef Merge dialog is displayed. Highlight
the secretarial chair in the list and then click
OK.

You might encounter the Substitution Question
dialog at this point, asking if you want to assign
the substitute object’s material to this object.
Click Yes to continue.

Several instances of a 3D secretarial chair appear
in the proper location and orientation in the
viewport. All of the 2D block representations
of the chair have been substituted.

12.Repeat the previous steps, but this time
substitute manager chair.max for the remaining
chair shape in the smaller office.
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13. Use the Arc Rotate tool to tilt the view so
that you are almost looking directly down from
the top of the office area and then substitute
workstation.max for the 2D desk blocks.

The 3D workstations come in and the 2D
blocks disappear as before - but now there is a
problem. The origin point of workstation.max
does not correspond to the insertion point
of the Architectural Desktop chair block, so
that the workstations appear to be hanging off
the edge of the floor slab. This is a common
situation, in which you will wish to adjust all
the substitute objects in relationship to the
original objects you replace.

Adjust the position of substitute objects:

1. Click the Select Object button on the
toolbar to turn it on. Click any portion of the
3D workstation to select it.

Make sure you selected the workstation and not
the chair!

2. Right-click the 3D workstation object, and
choose Move from the quad menu.

The Transform gizmo appears.

3. Move the cursor to the square between the X
axis and the Y axis arrows on the Transform
gizmo, until the horizontally-aligned square
turns yellow and your cursor changes to a black
crossed-arrow shape. This means that you can
move the object in any direction on the XY
plane. Hold the left mouse button down and
drag the 3D workstation until the admin chair
is centered behind the main work surface, and
then release the mouse button.
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Not only is the workstation aligned properly,
but all the other workstations are aligned
correctly as well.

Use the Asset Browser to drop in overhead lights:

Since the Substitute modifier is only able to xref
one object and that object cannot be a light source,
you’re going to have to use a different method to
bring lights into the scene.

1. With Move still active, select one of the yellow
light fixture blocks.

2. Select Customize menu > Units Setup and turn
on US Standard. From the measurement style
drop-down list, choose Feet w/ Fractional
Inches.

3. Adjust your view with Arc Rotate so you
see more of an elevation view of the office.

4.

In the Z: coordinate display field, enter a

reasonable height value for the light fixtures,
such as 8’6”.

The light fixture blocks both move to 8’6”
above the floor.

5. Open the Utility panel and choose Asset
Browser.

6. Browse to the \tutorials\small_office folder.
Left click and drag overhead fluorescent.max
from the Asset Browser to the scene. Release
the mouse button.
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7. Choose Merge File and place the fixture and
light source.

You don’t have to be precise about where you
place the fixture. You’ll reposition it next.

8. On the main toolbar, click the Align
button and then choose one of the original
overhead fluorescent blocks.

The Align Selection dialog is displayed.

9. In the Align Position (World) group, turn on
the X, Y and Z Position switches and make sure
that Pivot Point is active in both the Current
and Target Object groups.

10.Repeat these steps to drag a second overhead
fluorescent light and align it to the other
overhead fluorescent block.

Don’t worry about rotating the overhead
fixtures 90 degrees. They will work better for
us in this orientation.

Drag and drop standing lamps:

The office also contains blocks for four standing
lamps. You’ll use the same technique to drag them
into the scene and position them.

1. From the Asset Browser, select standing
lamp.max.

2. Left click and drag it into the scene, as you did
the overhead fluorescent.max file.

3. Choose Merge File and place the standing lamp.

4. Click the Align button and then choose
the standing lamp block in the smaller office,
on the left.

5. In the Align Position (World) group, turn on
only the X and Y Position switches and make
Center active in both the Current and Target
Object groups. Click OK.
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The first standing lamp is added to the scene.

6. Repeat these steps to add standing lamps to the
other three standing lamp blocks.

When you see the Duplicate Material Name
dialog, choose Use Scene Material.

Now we have Architectural Desktop geometry,
new 3D geometry substituting for our blocks and
lights added to the scene. So we have all we need to
create our first rendering.

Create a rendered image, and correct the lighting:

1. In 3ds Max, adjust the perspective view of the
scene so that you have a nice view of the whole
office area.

2. On the toolbar, click Quick Render.

A new window appears, with Perspective, frame
0 (1:1) in the title bar. This window is called the
Rendered Frame Window. In a few seconds, a
rendered image of your scene appears against a
black background.

Note: The Quick Render button simply renders
the active viewport using the rendering
parameters that have already been established.
You will learn in a later tutorial about how to
fine-tune these parameters to get the precise
rendering effects you want, but for this lesson
we will just stick to the defaults.

The image is nice, significantly easier for a client
to understand than the simple Architectural
Desktop drawing we started with. But now that
we have object substitutions taking place and
can see the lighting effects, we see problems.
The middle workstation in the larger room and
the manager’s workstation in the smaller room
aren’t getting enough light.

We need more overhead fluorescent fixtures.

3. Select both of the overhead fixtures and turn on
Select and Move if it’s not already active.

4. While holding down the SHIFT key, drag the
overhead fixtures along the X axis until the
right hand light is centered between the two
original lights. The light in the small office is
placed over the desk.
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5. Click OK in the Clone Options dialog.

6. Render the scene again by clicking Quick
Render.

Summary

To sum up what this lesson has covered:

• You can substitute linked Architectural Desktop
objects and blocks with replacement geometry
using the Substitute Manager utility.

• You can adjust the position of replacement
objects so that all instances of the objects are
correctly positioned.

Sharing Materials with
Architectural Desktop

As you will learn in other tutorials, 3ds Max
contains powerful tools for creating, adjusting,
and assigning materials to objects in 3ds Max

scenes. But the rendering materials you can
create in 3ds Max are not just for using within
your 3ds Max scene; they can be shared with
Autodesk Architectural Desktop and assigned
to Architectural Desktop objects so that other
members of the design team can share the same
material.

Set up the lesson:

In order to complete this lesson, you will have to
overwrite the original drawing file so that your
changes can be reloaded into 3ds Max. This will
mean that others will not be able to complete the
tutorial as you have. This is why you begin the
tutorial by making copies of the supplied files,
and renaming them. Make sure you keep them in
the same directory so that required bitmaps are
available during the lesson.

• Using Windows Explorer or My Computer,
locate the \tutorials\small_office\ folder.
Make copies of the files original small
office material.dwg and original small office
material.drf in the same folder, and rename the
copied files small office material.dwg and small
office material.drf, respectively.

Assign materials to objects in 3ds Max:

This time, you will start in 3ds Max with a more
developed version of the small office you worked
with before.

1. Start 3ds Max.

2. Choose File menu > Open and browse to the
\tutorials\small_office\ folder. Change the Files
Of Type to VIZ Render (.drf) and open small
office material.drf.

If you see the File Load: Units Mismatch dialog,
choose to Adopt The File Unit Scale and click
OK.
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A shaded perspective view of the small office.

3. From the main menu, choose Rendering >
Material/Map Browser.

4. In the Browse From group, turn on Mtl Library
and in the File group, click Open.

The Open Material Library dialog opens.
Browse to the \tutorials\small_office\ folder
and open small office material.mat.

5. In the Material/Map Browser, click the
View Large Icons button and turn on Root Only
in the Show group, if it’s not already active.
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The materials from the library appear as
large samples. If you want, you can resize the
Materials/Map Browser dialog so more samples
appear and you won’t have to scroll as much
when choosing the materials to apply in your
scene.

6. Scroll through the material samples until you
find Rug pattern. Left-click and drag the
material to the orange rectangle on the floor.

As you drag the material to the scene, watch
for the object tag, Layer:_tut1-Rug.01 next to
your cursor. This means that if you release the
mouse button, the material will be assigned to

that object in the scene. “Drop” the material
onto the object by releasing the mouse button.
Repeat the process by dragging Hardwood
floor over the blue object, Slab<Standard>Slab,
and then release the mouse.

The objects in the viewport change color to
reflect the new material assignments.

7. On the main toolbar, click the Quick
Render button.

The rendered image reflects the new materials
assigned to the rug and the slab.

The image looks promising, though the
glass and the interior partition still show the
materials assigned to them in Architectural
Desktop, and are not the color we would like
to see. You could continue assigning materials
to the glass and the partition in 3ds Max, but
that raises a workflow issue. It is logical to
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assign a fanciful pattern to a rug in 3ds Max
strictly for visualization purposes. Likewise, it
is convenient to assign a wood material to the
Slab object in 3ds Max, though you would not
specify that material for a slab in Architectural
Desktop. But if you assign new materials to the
glass and interior partition only in 3ds Max,
you are losing an opportunity for others to
use the same material you are using, or to
automatically be aware of our choice when they
access the Architectural Desktop drawing.

8. Close the Rendered Frame Window containing
the rendered image.

9. Minimize 3ds Max to get it out of the way.

Edit an Architectural Desktop material definition:

1. Start Architectural Desktop and choose File
menu > Open.

Browse to the \tutorials\small_office\ folder
and open small office material.dwg.

2. In Architectural Desktop, choose Main menu
> Format > Style Manager to display the Style
Manager dialog. In the explorer view on the left
of the dialog, expand Multi-Purpose Objects
and then expand Material Definitions to view
the materials that have already been defined for
this drawing.

3. Right-click Material Definitions, and choose
New from the menu. Overwrite “New Style”
with New Glass for Curtain Wall, and press
ENTER to give the new material a recognizable
name.

4. Double-click New Glass for Curtain Wall in the
right pane to display the Material Definition
Properties dialog. Open the Display Properties
panel. On the General Medium Detail line,
click the Style Override box to display a Display
Properties dialog, and go to the Other panel.

5. Under Surface Rendering > Render Material,
the current selection is *NONE*. Click the
down arrow to see a list of render materials
that have been defined in this drawing. You
will see New Glass in the list. Choose New
Glass to make it a component of the New
Glass for Curtain Wall material definition in
Architectural Desktop. Click OK to confirm the
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choice, and OK again to dismiss the Material
Definition Properties dialog.

6. Repeat steps 3–5 above to create a new material
definition named Textured Blue Interior
Painted Wall, and assign the Light blue textured
paint rendering material to that material
definition. When complete, press OK on the
Style Manager dialog to dismiss it.

Now small office material.dwg contains two
new material definitions that are available
for use, but these new materials have not
been assigned to any Architectural Desktop
components. You will do that in the next
procedure.

Assign the material definitions to Architectural
Desktop object components:

1. In Architectural Desktop, click the Interior
Partition - Painted wall object.

2. Right-click the wall and choose Edit Wall
Style from the menu to display the Wall Style
Properties dialog. Confirm that the Materials
panel is active.

Click the Paint.Flat.Lavender material
definition that is currently assigned to the
Unnamed component. Choose Textured Blue
Interior Painted Wall from the drop-down list
to replace the old material definition with the
new one. Click OK to confirm the change of
material definition assignment.
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The partition changes to a blue color, reflecting
the change in material.

3. Click the curtain wall, and then right-click
it and choose Edit Curtain Wall Style from
the menu to display the Curtain Wall Style
Properties dialog. On the Materials panel,
change the material definition assignment for
the Default Infill component to New Glass for
Curtain Wall.

Click OK to confirm the change in material
assignment.

The glass panels in the curtain wall object
change to a noticeably more transparent
material, while the other components remain
the same color.

4. You have finished with small office
material.dwg. Save the drawing and exit.

View the newly assigned materials in 3ds Max:

1. Press ALT+TAB and choose 3ds Max to switch
between applications.

We want to reload the link between
Architectural Desktop and 3ds Max as in
previous lessons.

This will update the linked geometry and
materials with our recent changes to the
drawing.

2. From the File menu, choose File Link Manager
to display the File Link Manager dialog. Make
sure Show Reload Options is turned off and
click Reload. Close the File Link Manager
dialog.
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The partition turns blue and the glass in the
curtain wall turns more transparent as the
material definitions and assignments from the
linked Architectural Desktop drawing override
the previous materials and assignments. The
materials for the slab and the rug do not change,
because these objects in Architectural Desktop
have no rendering material assigned to them.

Note: If you see a question mark (?) displayed
next to the linked file’s name in the File Link
Manager, it means that the linked file is “lost”.
In this case, you should click the file name and
then click the folder icon to browse for the
“lost” file. This can occur if you changed the
drive location where 3ds Max is installed. The
sample files assume an installation using default
drive paths.

3. On the Rendering toolbar, click Quick
Render.

The rendered image reflects both the materials
that were originally assigned in 3ds Max and
those that are saved with the Architectural
Desktop drawing.

Common File Link Troubleshooting:

If your final rendering looks like the previous
image, you didn’t run into any of the possible
problems you could have encountered while
working on this tutorial. Here are a few of the
problems you may have run into at the end during
the File Link Reload stage as well as their solutions.

• Common File Link problems include:

• If nothing happens when you click the
Reload button in the File Link Manager
dialog, it probably means you forgot to save
your drawing file in Architectural Desktop.
When a linked file is updated and saved, the
File Link Manager will show a red flag in the
icon to the left of the linked files name.

This linked file has been saved and will Reload
successfully.

• Another reason a Reload could fail is
because the File Link Manager can’t locate
the file in the location specified in the File
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Link Manager, perhaps because the file was
renamed or moved. If the linked file is has
been renamed or moved, a question mark
(?) is displayed next to the linked file’s name
in the dialog. In this case, you should click
the file name and then click the folder icon
to browse for the file.

This linked file is lost.

• After clicking the Reload button on the
File Link Manager dialog, the model
appears to get compressed and becomes
indecipherable.

This is caused by incorrect System Unit
Settings. If, when you first opened the small
office materials.drf file in 3ds Max, you were
shown the File Load: Units Mismatch dialog,
you chose Rescale The File Objects To The
System Unit Scale. You should have chosen
the Adopt The File’s Unit Scale setting.

Summary

To sum up what this lesson has covered:

• You learned to assign materials in 3ds Max
by dragging them from a panel of the
Material/Map Browser to an object.

• You edited object style definitions to
override the material definitions that certain
components used, and replaced them with the
new material definitions you created.

• You used the File Link Manager to combine
the rendering materials from Architectural
Desktop with the materials you assigned
in 3ds Max, and used this combination of
materials in your revised rendered image.

Land Development
In this tutorial, you will construct a design for a
specific site, the Marin County Civic Center. This
tutorial asks the question, What if Frank Lloyd
Wright had access to design visualization software?
How could he have used it in his design process?

Frank Lloyd Wright was famous for his horizontal
and cantilevered structures inspired by the
American Midwestern prairies. The Marin County
Civic Center is a fine example of this, with two
long horizontal spans radiating from a central
domed hub, bridging the hillsides. You will follow
Wright’s design process and create two long boxes
to represent the exteriors of the buildings.

You will pretend you are the famous architect,
creating the design for the Library, Hall of Justice,
and Administration buildings. You will create a
virtual model of your design including the terrain
of the site, and then add lighting and animate a
fly-around of your design.
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You will start by importing a 2D AutoCAD
drawing of contour lines. You will use the terrain
object to generate a virtual 3D model of the site.
You will then build a conceptual design model of
the proposed building and fly a virtual camera to
circle the design.

Skill level: Beginner to intermediate

Time to complete: 2 hours

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

• Import a 2D AutoCAD file.

• Create a contour model using Terrain objects.

• Apply materials to the terrain.

• Model a massing study using primitive objects.

• Animate a fly-around of the design.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\land folder, unless otherwise specified.
Before doing the tutorials, copy the \tutorials
directory from the CD to your \3dsmax8 local
installation.

Importing the AutoCAD File

There will be times when the drawing necessary
for a project has already been created and you
need to import it. In this case you will be using an
AutoCAD DWG file that consists of contour lines
needed to create the terrain. The drawing and
aerial photograph of the site have been provided
by the Marin County Department of Public Works.

Note: The drawing used here is a simplified version
of the real topographic file. It is a “lightweight”
file so it is easier to learn from. In the real world,
these type of files will take a longer time to open
and navigate.

Setup the defaults:

3ds Max is a product used in many industries. You
can choose some custom settings provided for the
Design Visualization customer.

1. On the Customize menu choose Load Custom
UI Scheme.

2. Load modulartoolbarsui.ui

This is a user interface that displays such
toolbars as the Layers toolbar.

Import the AutoCAD file:

1. On the menu bar, choose File > Import.
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2. In the Select File to Import dialog, change the
Files of Type to All formats and navigate to the
\tutorials\land directory on your local hard
disk.

You could also change the Files of Type to DWG
rather than All formats, either method will
work in this case.

3. Highlight 3hills.dwg and click Open.

The AutoCAD DWG/DXF Import Options
dialog appears. Here you can make adjustments
and set options for the file you are importing. In
this case you don’t need to make any changes,
so just click OK.

Import the AutoCAD DWG file

4. Now you can see the contour lines in the
viewport.

Navigate the viewport:

1. In the viewport navigation controls,
click the Zoom button. Try to zoom into the
viewport.

You can also zoom with the wheel of
your mouse, if you have a middle wheel.
If you don’t have a wheel, hold down
CTRL+ALT+middle-mouse button to zoom
instantly.

2. In the viewport navigation controls, click
Arc Rotate Selected.

In the viewport, a yellow orb appears.

3. Move the mouse inside the yellow circle and
press to rotate the viewport.

In the illustration, you can see the three hills
that compose the building site and a yellow
object indicating north. You can also see
the "blank spots" in the contour where the
buildings are today.

The topographic survey information comes
from after the building was built.

Three-quarter view from above



156 Chapter 4: AEC

4. Zoom and rotate so you can see the hills from
ground level. This will give you an idea of the
profiles of the hills.

View from the ground

5. Press SHIFT+Z on the keyboard to undo the
viewport rotation.

The viewport returns to the previous view.

6. Repeatedly press SHIFT+Z to undo viewport
changes until you are back to a three-quarters
view from above the three hills.

There are separate Undo stacks for each
viewport.

Create the contour lines:

• When you do your own projects, you might not
have access to a DWG contour line file, like this
one. It’s not too hard to make your own. You
can load an aerial photo of the site into the Top
viewport as a viewport background, then draw
contour lines using the 3ds Max Line tool. After
you have drawn the contour lines you can raise
them up off the ground by typing the elevation
into the Z field of the Coordinate display. You
can get this elevation information from survey
data. This is a long and tedious process, so
we’re not asking you to do this as part of this
tutorial. Instead we provide you with a file of
contour lines at the correct elevations.

Creating the Terrain

In this section, you will use the Terrain object to
turn the contours into a geometric object.

Set up:

• Continue from the previous step, or open the
tutorial file \tutorials\land\make_terrain.max.

Create a new layer:

1. On the Layers toolbar, click Create New
Layer.

Tip: If the Layers toolbar isn’t displayed,
right-click a blank area of the main toolbar,
then choose Layers.

2. Name the New layer Terrain, and then click
OK.

You have just created a new layer called Terrain.

Whatever you create next will be on that layer.

Create the terrain:

1. On the toolbar, click the Select by name
button.

2. From the list choose the object names Layer
820_01.01 then click Select.

The object name Layer 820_01.01 is displayed
in the Name And Color rollout on the Create
panel. The object is named based on its
AutoCAD Layer name.

3. In the Create panel > Geometry, click the
drop-down arrow next to Standard Primitives,
then choose Compound from the list.
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4. In the Create panel, Object Type rollout click
the Terrain button.

If the Terrain button is unavailable, be sure that
you have selected a spline object first, such as
Layer 820_01.01.

After a brief wait, the terrain appears in the
viewport.

Terrain object

A colored surface has been built on the contour
lines. Don’t worry if your terrain is a different
color than that one illustrated here.

5. In the Create panel, scroll down (if necessary)
to the Pick Operand rollout, and click the Pick
Operand button.

6. Press H on the keyboard to display the Select
By Name dialog, and then choose the object
named Layer 800_.01.01 to add this set of
contour lines to the Terrain object.

After a moment, adds the splines of that object
to the Terrain, building additional faces.

7. Scroll down to the Display group and turn on
Both.

Now the viewport displays both the terrain
surface and the contours.

Both contours and terrain displayed

8. Click the Arc Rotate Selected button and
rotate the viewport so you can see some of the
side of the model.

9. In the Form group, turn on Graded Solid.

If you look carefully, you will notice that the
surface now has a solid base extended from it.
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Graded solid

10.One of the objects in the viewport is a yellow
box with a yellow arrow. Rotate the viewport so
that this object is on the left and the arrow is
pointing up, as shown below.

Convert to Editable Mesh:

Once you’ve created your terrain, you can collapse
it from a parametric object to an editable mesh or
editable poly object. This will speed up viewport
performance and file load times.

1. With the terrain object selected, right-click to
launch the quad menu.

2. On the Transform quad highlight Convert To:
> Convert to Editable mesh

3. Save your file as myterrain01.max.

Next you will add some materials to make your
terrain more realistic.

Adding a Material to the Terrain

Now you have a single color landscape. In the next
few steps, you will apply a textured material to
the terrain. You’ll use a bitmap based on an aerial
photo of the site.

• Open \tutorials\land\add_terrain_
materials.max.

Create a material:

1. Go to the Customize menu > Preferences. In
the Texture Coordinates group, make sure Use
Real-World Texture Coordinates is turned off.

This preference is useful when you’re working
with textures that can be measured, such as
bricks or ceramic tiles. You’ll be working
with a texture that is irregular and requires a
traditional approach where you’ll be making
some adjustments at the UVW Map level.

2. Press M to open the Material Editor.

The Material Editor appears as a floating
window.

3. In the Material Editor, look at the material
sample in the top left slot, which is already
highlighted. Name this material Terrain by
typing in the name in the field to the right of
the eyedropper.

4. In the Material editor, on the Anistropic Basic
Parameters rollout, click the Diffuse color
swatch.

The color selector appears.

5. Change the color of the material so it’s a light
green. Here we’ve used RGB values R144,
G188, and B44. Click Close to choose the color.
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Simple color material

Assign the material to the terrain:

1. Drag the material from the sample sphere to the
Terrain object in the viewport.

The green material appears on the terrain. Any
changes you make to the material will now
show up in the viewport.

2. Click the Diffuse color swatch again, and
change the color from a green to a sand color.

Here we use RGB value R222, G199, and B123.

Color selector RGB values

Notice that the material sample now has
filled-in corners to show that the material is
active, and in the scene on the selected object.

Filled corners

Next you will add a bitmap to the material.

Add a texture bitmap:

There are many ways to obtain a nice texture on
the terrain. You can add color using the Color By
Elevation rollout, or use an aerial photo if one is
available. To paint a texture, take a screen capture
(Print Screen) of the Top viewport of your model
and then paint it in Adobe Photoshop or other
paint program.

In this case, we’ve taken a black and white aerial
photo of the site, and then tinted it with a paint
program.

Painted aerial photograph

1. Click the blank button to the right of the
Diffuse color swatch, then pick Bitmap from
the list. Navigate to \tutorials\land and choose
painted_aerial.bmp.



160 Chapter 4: AEC

A thumbnail of the file is displayed in the
browser.

2. Click Open.

The sample sphere now shows the material with
the texture.

3. Click the Show Map In Viewport button
in the Material Editor.

There is a delay, then the terrain turns a
gray color. The map doesn’t show up in the
viewport, because the terrain doesn’t have
mapping coordinates assigned yet.

Add mapping coordinates:

1. To add mapping coordinates, select the terrain,
then on the menu bar choose Modifiers > UV
Coordinates > UVW Map.

The terrain is now textured with the painted
aerial bitmap.

2. In the modifier stack, expand the UVW
Mapping entry by clicking the black button
marked with a white plus sign. Click Gizmo.

3. On the Modify panel, scroll down to the
Alignment area and choose Bitmap Fit. Select
painted_aerial.bmp.

Now the proportions of the UVW mapping
gizmo match the selected bitmap.

Something is still wrong, however. The map is
the right proportion, but it’s too big. You can
change that by scaling the gizmo, or simply
changing its length and width.

Adjust the mapping:

1. In the Parameters rollout change the length for
the mapping gizmo to: 180’1".

2. Change the width of the gizmo to 203’2".

3. In the Material Editor, turn off Tile for U and V
for the material by turning off the Tile boxes.
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Turn off tiling and resize the gizmo

Now the texture is smaller and doesn’t tile. The
sand diffuse color is visible beyond the frame
of the texture bitmap. The mapping coordinate
is the correct size now, but still it needs to be
registered, or lined up, with the terrain. You’ll
use a trick to do this.

Align the gizmo with the terrain:

1. Activate the Top viewport. Click the Min/Max
Toggle or ALT+W on the keyboard if you only
have a single viewport displayed. Click Zoom
Extents if your top viewport is zoomed in too
far.

2. Press H to Select By Name, then select the
object Layer 800_01.01.

3. On the toolbar, click Select And Move.

Notice the Z height for the object in the
coordinate display, on the Coordinate display
in the status bar.

4. On the coordinate display, in the Z field type 9’,
and press Enter.

You’ve just raised the elevation lines up slightly
above their previous position. They are now
visible above the terrain.

5. Click the terrain to select it in the viewport,
then choose the UVW Mapping Gizmo
sub-object level in the modifier stack.

6. Now drag the transform gizmo to move the
mapping coordinates so the texture registers
with the visible terrain lines.

The map moves beneath the stationary terrain
lines.

Use contour lines to align the terrain texture.

7. Once you’re satisfied with your mapping, select
the Layer 800_01.01 object and set its Z height
to 6’. This will get it out of the way.

The terrain lines are no longer visible.

8. Rotate the Perspective viewport and zoom in so
you can see the terrain with the texture.

Terrain with texture

Save your work:

• Save you file as myterrain_textured.max.
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Your site is complete, and you can now begin
conceptual modeling.

Conceptual Modeling

Frank Lloyd Wright was famous for his horizontal
and cantilevered structures inspired by the
American Midwestern prairies. The Marin County
Civic Center is a fine example of this, with two
long horizontal spans radiating from a central
domed hub, bridging the hillsides. You will follow
Wright’s design process and create two long boxes
to represent the exteriors of the buildings.

You’ll freeze the terrain layer so you can
concentrate on your design. Then you will create
objects to represent the exterior masses of the
buildings. You will add details for the roofs, a deck
in the shape of a ship’s prow, and a tower. You will
use material map tiling to play with the design for
the repetition of arches that create the sunscreen
and the parapets.

Adding the Buildings (page 2–162)

Adding the Roof (page 2–165)

Adding the Arches (page 2–168)

Adding the Prow and the Spire (page 2–172)

Adding the Arcade (page 2–176)

Adding the Buildings

First, you’ll freeze the terrain layer so you can
concentrate on building design. Then you will
create objects to represent the exterior masses of
the buildings. You will add details for the roofs,
a deck in the shape of a ship’s prow, and a tower.
You will use material map tiling to play with the
design for the repetition of arches that create the
sunscreen and the parapets.

To begin the building, you begin with a long box
that you will position as a bridge between two of
the hills. You will experiment, changing its length
and width by eye to fit the site. You will clone the
second building from the first, rotating it into
place fill the available space.

You will not be directed to make the objects an
exact size. The modeling will all be done "to taste"
rather than to precise dimensions.

Set Up:

• Continue from before or open
\tutorials\land\add_buildings.max.

Create a new layer:

1. On the Layers toolbar, click Create New
Layer.

2. Name the New layer Civic Center, and then
click OK.

You have just created a new layer called Civic
Center.

Whatever you create next will be on that layer.

Create a box:

1. On the Create panel, click the Box button.

The button turns yellow to show it is active and
ready to create.
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2. Drag out a box on the grid in the viewport next
to the terrain, as shown below.

Create a box

The dimensions of the box are not too
important, since you will adjust them once the
box is over the site. Here we’re using a box
approximately 10’ x 90’ x 10’.

The dimensions of the box are not too
important, since you will adjust them once the
box is over the site. Here we’re using a box
approximately 10’ x 90’ x 10’.

3. To change the color of the box to a sandy
color, click the Layer Manager button on the
Layers toolbar. Then in the Layer Manager
dialog, click the color box for the Civic Center
layer.

If necessary, change from the Default palette
to AutoCAD ACI palette, then select ACI #31,
as shown below.

4. Click OK to close the color selector. Click the
X button at the upper right to close the Layer
Manager Dialog.

5. Rename the box object Hall of Justice by typing
the new name in the Name and Color rollout.

6. Right-click the viewport label and turn on
Edged Faces.

The viewport changes to edged face mode.

7. In the Parameters rollout change the Box
parameters to:

• Length Segs=3

• Width Segs=2

• Height Segs=4

Tip: Use the Tab key to move from field to
field while typing.

You’ll see the segments update in the
viewport.

The four height segments will represent the
four floors of the building.

8. Press F4 to turn off edged faces.

Now that you know the edges are there, you
don’t need to see them.

Tip: Learn the keyboard shortcuts and then use
them to speed your workflow.

Position the box using move and rotate:

1. On the toolbar, click Select And Move.
Press G on the keyboard to hide the grid.

2. Drag the transform gizmo arrows to move the
box over the terrain. Move the box in the Y
direction until it is over the small hill as shown
below.
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Move the building over the terrain

3. Rotate the box about the Z-axis using the
Transform gizmo . Rotate the box so it spans
the hillside like a bridge.

4. Adjust the height of the box, so it sticks up
slightly from the top of the hills.

The building spans the northern hills

5. Hold down the SHIFT key and then rotate the
box again. This time a clone of the first box
appears. In the Clone Options dialog choose
Copy. Name this new box Administration
Building.

Copy the building

6. Move the Administration Building so it spans
the two hills on the left. Adjust the dimensions
of the box so this bridge is a bit taller than the
first one. These hills are higher and closer
together, so this box needs to be a bit shorter.
Adjust its dimensions as you like. Position the
building so it intersects with the first one a little.

Move so the buildings intersect

7. Rotate the viewport so you can see what you’re
making from another perspective. Rotate
around so you are looking from the west, as
shown below. Rotate all around the site so you
can see it from all sides.
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Look at the buildings from another perspective

Adding the Roof
Set up:

• Continue from before or open
\tutorial\land\add_roof.max.

Add the library roof:

You’ll use a cylinder and a hemisphere to create a
dome that will be the roof for the library. This is
situated at the intersection of the two buildings.

1. Zoom in so you have a close-up view of
the intersection of the two halls. Use Arc Rotate
Selected so you can see the tops of the two
buildings.

Adjust the view

2. On the Create panel, Object type rollout, click
Sphere.

3. In the Parameters rollout for the Sphere, turn
on Base To Pivot.

You are going to create a sphere. The sphere’s
pivot point will be at its base, not it’s center.

4. In the Extras toolbar, turn on AutoGrid.

If the Extras toolbar is not visible, right-click
a blank area of the Main toolbar and choose
Extras.

Note: The same AutoGrid functionality can
be accessed on the Object Type rollout of the
Create panel.

5. Move your cursor over the Hall of Justice, then
press and drag out a sphere.

The AutoGrid temporarily creates a grid on top
of the object.

Tip: if you want the grid to remain rather
than disappear, hold down the ALT key when
creating the object.

Sphere built with AutoGrid

6. Name the object Library Dome.

7. Turn off AutoGrid.

Adjust the library roof:

1. In the Parameters rollout, turn on Squash, then
set Hemisphere to 0.75.

2. Lower the segments of the Dome=18.
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3. Click the color swatch at the top of the Create
panel and change the color of the object to a
blue color. The illustration uses ACI 160.

Frank Lloyd Wright wanted this to be a golden
roof, but they couldn’t find a suitable gold that
would hold up outdoors, so the roof ended up
blue.

4. Increase the radius so the dome overhangs the
walls, creating the eaves. Depending on the
angle between your two wings you may need
to move the dome so it covers both buildings.
Experiment with changing the radius and
hemisphere until you have a roof you like.

5. On the toolbar, choose Select and
Non-Uniform Scale from the Scale flyout.

6. Use the transform gizmo to flatten the Dome
slightly in the Z axis.

Tip: In general it’s a bad habit to use
Non-Uniform Scale like this if you’re going to
animate your model. In this case however, since
the building won’t be animated, this technique
is OK.

Flatten the dome using non-uniform scale.

7. If necessary, move the Dome so it rests on
the Hall of Justice and intersects with the
Administration building. Use Arc Rotate to
view the result from several angles.

Tip: if you have viewport performance
problems, turn on Degradation Override by
pressing O (the letter “o”) on the keyboard.
When you rotate the viewports, they will switch

to box mode, and return to shaded mode when
you release the mouse button.

Faster viewport performance with degradation override

Shaded viewport when you release the mouse button

Turn off the terrain and contour layers:

For the next step, it will be easier to work if the
Terrain is not visible. You’ll do this by using Layers.

1. Click the Layer Manager button, then
in the dialog, click in the Hide column to the
Terrain layer. Also hide layers 800_01 and
850_01.
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Turn off layers in Layer manager dialog

2. Click the Civic Center layer and then click
Current to make that layer the current layer.
Close the Layer manager dialog.

Now the terrain, the contour lines, and the
elevation text are hidden from view.

Turn off terrain layer

Now you can add the roof for the wings.

Create the roof for the wings:

The roof treatment of the wings will consist of
a pair of blue covers with a clear canopy in the
center. Wright envisioned an open-air atrium,
open to all four floors down the center of each long
building. You will create these using an extended
primitive, a Capsule object with AutoGrid.

1. In the toolbar, turn on AutoGrid, if it
isn’t already.

2. On the Create panel, click the drop-down arrow
next to Standard Primitives, and then select
Extended Primitives from the list.

3. In the Object Type rollout, click Capsule.

4. Move the cursor over the end of the Hall of
Justice object, then drag out a capsule.

Create a capsule using AutoGrid

5. Name this object HOJ roof east.

6. In the Create panel, turn Slice on and slice the
capsule from 180 to 0.

7. Change the color of the roof to match the blue
of the library dome.

8. Turn off AutoGrid.

9. On the toolbar, click Select and Move,
then choose Local from the Reference
coordinate drop-down list.
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10.Move the capsule using the transform gizmo so
it covers one edge of the Hall of Justice object,
and intersects with the library dome roof.

11.Adjust the height and the radius of the capsule
so it covers the length of the building.

12.Right-click and pick Move if its not already
on, then hold down the SHIFT key and clone
a copy of this roof. Move so it covers the other
edge of the building.

13. Name this object HOJ roof west.

14.Select both HOJ roof objects and non-uniform
scale them on the local Y-axis to flatten them,
just like you did to the roof.

Remember, this is something you should avoid
if your model will be animated.

15.Use SHIFT+Rotate to create two more copies
for the roof for the administration building.
Name the new objects Adm Blg roof west and

Adm blg roof east. Be sure to choose Copy and
not Instance this time. Adjust the dimensions
of the new roofs as necessary.

You can create a clear canopy between the two
long, blue roofs, by making a cylinder, slicing
it, and scaling it, as you did earlier. Or you can
skip that step, since it doesn’t add much to the
conceptual design at present. Details like that
can be added toward the end, if you prefer.

16.Using Layer Manager turn the Terrain layer
back on.

Save your work:

• Save your file as my_civic_center_with_
roof.max.

Adding the Arches

The next step is to cut out three arches from the
two buildings. You’ll use a Compound Object,
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the Boolean for this task. You will create three
cylinders and then subtract them from the wings
of the Civic Center.

Set up:

• Continue from before, or open add_arches.max.

If you are continuing from before you’ll need to
do the next steps. If you load add_arches.max
you can jump to the section below called
“Subtracting the Cylinders.” (page 2–170)

Lock the terrain:

1. Select the Terrain object in the viewport.

2. Open the Layer manager and click in the Freeze
column in the row labeled Terrain.

The Terrain turns gray. Now you can’t select it
inadvertently.

Create the cylinders:

You create some cylinders to use to cut holes in
your buildings.

1. On the Layer Manager. Select the Civic Center
layer, then click Current.

Now whatever you make will be on the Civic
Center layer.

2. Turn on AutoGrid if it isn’t already, and on the
Create panel, click Cylinder.

3. Create a Cylinder off the west side of the Hall of
Justice, as shown below.

4. Move the cylinder so it is half in the terrain and
half in the building.

5. Hold down the SHIFT key and clone a second
cylinder from the first.

6. In the Top viewport move the cylinders so they
extend beyond the buildings.

7. In the Perspective viewport create one
more cylinder to cut the arch through the
Administration Building.
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If you have loaded add_arches.max, the three
cylinders are already created for you.

Subtracting the cylinders:

Before you subtract the cylinders, you need to
increase the segmentation of the two boxes, so you
won’t be creating long skinny faces. Once you have
increase the segments, you will use Booleans to
subtract the cylinders.

1. Click the Administration Building object to
select it in the viewport.

2. Press F4 to turn on Edged Faces.

3. On the Modify Panel increase the Width
segments of the Box=8.

4. Repeat this process for the Hall of Justice object.

5. Press F4 again to turn off Edged Faces.

Now you will use Boolean objects to subtract
the cylinders.

6. Click the Administration Building object to
select it in the viewport.

7. On the Create panel, click the drop-down arrow
and choose Compound Objects from the list.

8. Click Boolean.

You have just created a Boolean object. It
consists of the Administration Building Object,
and is ready for you to add or subtract another
object. To do so, click Pick Operand B.

9. In the viewport, click the cylinder that is
intersecting the Administration Building
object.

The cylinder disappears and cuts an archway
into the building.

Boolean Subtraction

10.Open the Display/Update rollout for Boolean,
and turn on Result+Hidden Ops.

Now you can see a ghost image of the cylinder
operand and the hole that is the result.

Wireframe display of operand

If you make changes to the cylinder, the Boolean
will update with those changes. The next step uses
this feature to flatten and smooth the arches.

Adjust the Boolean object:

1. With the Administration Building still selected,
go to the Modify panel and select Boolean in
the stack.
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2. In the viewport, move the Transform gizmo in
the Z-axis.

The entire object moves up and down.

3. Press CTRL+Z to undo the transform moves
and restore the building to the correct position.

4. In the Modifier stack, click the plus next to
Boolean and then click Operands.

5. In the Operands list in the Parameters Rollout,
check to see if B:Cylinder05 is highlighted. If
it is not, then click it.

6. Now in the viewport, move the Transform
gizmo.

The building stays put and the archway moves.

7. In the Modifier stack, click Cylinder to go to
the Cylinder sub-object level in the stack.

8. In the Parameters rollout increase the Radius.

9. Click Operand to return to the Operand
sub-object level in the stack, then in the
viewport move the red operand down on the
Z-axis to create a wider archway.

Tip: when working on Boolean objects like the
cylinder, click the name of the object to access
its parameters, and click Operand to transform
it.

10.Click Cylinder again, then increase the number
of sides to make a smoother archway. Try
Sides=32.

11.When you are done, click Boolean in the
modifier stack to leave sub-object selection
mode.

Increase the radius and lower the cylinder to make a
wider archway

Add multiple Booleans:

The Hall of Justice has two archways. Here you will
use multiple Booleans to create the openings.

1. Select the Hall of Justice object in the viewport.
Navigate your view so you have a clear view of
the two cylinders.

Now you will repeat the process you went
through before:

2. Select the building.

3. Choose Create panel > Compound Objects >
Boolean.

4. Pick Operand B and select a cylinder.

5. Turn on Result+Hidden Ops in the
Display/Update rollout.

First subtract one cylinder
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6. Now, to make the second Boolean, just click
Boolean again, click Pick Operand B and select
the other cylinder. Again turn on Result +
Hidden Ops in the Display/Update rollout.

Note: You have to add another Boolean
compound object for each operand. You can’t
pick multiple objects as an operand unless they
are attached into a single object.

Add a second Boolean to the stack

Adjust the operands:

1. On the Modify panel, on the Parameters rollout
in the Operands list, click A: Hall of Justice.

Notice that the Modifier stack now shows you
both Booleans. You can navigate back and forth
between the two cylinders to make changes to
them. Click cylinder to adjust the radius, click
Operand to adjust the position.

Tip: When you have very complex Booleans, try
using Schematic view to navigate them.

2. Select each operand cylinder, increase the
radius of the cylinder and then click Operand
in the modifier stack. Use the Transform gizmo
to lower the opening. You can make both arches
have the same radius to use some repetition in
the design.

As you’re working you’ll notice that the operand
of the first Boolean won’t display again. But
if you use the Modify panel parameters and

transform gizmo to make the changes, you can
view the results.

Widen and lower the arches

3. Save your file as my_civic_center_arches.max.

Adding the Prow and the Spire

If you navigate around to the other side of the
building, you’ll see there is a problem where the
Administration Building sticks through the library
dome. You may see some other discontinuity
in your own design. Wright actually designed
this section to be like the prow of a ship with a
mast-like spire.

You’ll work on this section next.

Set up:

• Continue from before or open add_prow.max.

Add the prow:

A box will be used as a Boolean to notch the end
of the Administration building.

1. In the Create panel > Standard Primitives, on
the Object Type rollout, click Box, then turn on
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AutoGrid. Drag out a box from the top of the
Administration building.

2. Change the Box Parameters to:

• Length Segs=1

• Width Segs=1

• Height Segs=1

3. Turn off AutoGrid.

Make a box to cut the prow

4. On the toolbar click Select And Move,
then click the Reference Coordinate system
drop-down arrow and choose Local. Adjust the
size and position of the box so it intersected
with the offending corner. Be sure the box
extends through the end of the building.

5. Click to select the Administration Building
object.

6. On the Create Panel > Compound Objects >
Boolean, click Boolean and then select the box
you just created as Operand B. If the result is
not what you want, press CTRL + Z to undo
the Boolean, then adjust the box and repeat the
Boolean operation.

Cut off the corner

Next you will use an Edit Mesh modifier that will
let you get to the individual vertices that make up
your geometry. You will rotate the vertices at the
end of the building to model the prow.

Add an Edit Mesh modifier:

1. In the modifier stack, click the Boolean at the
top of the stack.

2. On the menu bar, choose Modifiers > Mesh
Editing > Edit Mesh.

An Edit Mesh modifier appears at the top of the
modifier stack.

3. In the Selection
rollout, click the vertex button.

The vertices are displayed in the viewport.

Tip: If you multiple transform gizmos you
can toggle their display using the X on the
keyboard.

4. Activate the Top viewport in the lower left
quadrant.

A layout like the following lets you select
vertices from the top and watch the effect from
the perspective view. If you like, you can resize
the viewports by moving the viewport dividers.
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Resize viewports by moving dividers

5. Zoom in on the Top viewport until you can
clearly see the area under the dome.

Edit the vertices:

1. Drag select in the Top viewport to select
the vertices at the end of the building. See
illustration for the selection rectangle.

Select these vertices

2. On the toolbar, choose Select and Rotate, then
change the Reference Coordinate system to
View.

Tip: Coordinate systems are on a transform by
transform basis, so choose the transform first,
then select the coordinate system.

3. In the Top viewport, rotate the vertices about
the Z-axis so that the vertices are square to the
viewport, as shown below.

Rotate the vertices

4. In the Top viewport, move these vertices
in X and Y-axis away from the dome to extend
the prow.

5. On the toolbar, choose Non-Uniform
Scale, and scale the vertices in the Top Viewport
along the X-axis slightly.

Extend the prow

Save your work

• Save your file as my_civic_center_prow.max.

Add the Spire

Here are the steps to create a tower similar to the
one Wright added to the Marin County Civic
Center.

Set up:

• Continue from before or load add_spire.max.
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Create a new layer

1. On the Layer toolbar, click the Layer Manager
button.

If the Layers toolbar is not visible, right-click a
blank space on the main toolbar and choose
Layers from the pop-up menu.

2. Make sure the civic center layer is current. If it
isn’t click to make it so.

3. On the Create panel > Standard Primitives >
Object Type rollout, click Pyramid.

4. Make sure AutoGrid is on.

5. Drag out a tall thin pyramid on the top of the
Administration Building, as shown below.

Adjust the spire

1. Press F4 to turn on Edged Faces.

2. Change the number of height segments in the
pyramid to 20.

In Edged face mode you can see the height
segments changing in the viewport.

3. Add a Skew modifier to the pyramid. On
the menu bar choose Modifiers > Parametric
Deformers > Skew.

4. On the Parameters rollout, set the Skew Axis
to X.

5. Set the Skew Amount to less than 2’.

6. Narrow the Width and Depth of the pyramid
as well.

To add some drama to the tower, you’ll use a
Lattice Modifier on a copy of the pyramid.

7. On the menu bar, choose Edit > Clone. On the
Clone Options dialog choose Copy to make a
copy of the pyramid object.

8. On the menu bar, choose Modifiers >
Parametric Deformers > Lattice.

There are two pyramids there now, one with
a lattice, one without.
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9. In the Parameters rollout, on the Geometry
group, choose Struts Only from Edges. Then in
the Struts group set the Radius to a small value
such as 0’1.5”.

10. Adjust the pyramid with the lattice so it is
slightly shorter, wider and deeper than the one
without. You might want to lower the number
of height segments on the Lattice pyramid to
16.

11.Make the pyramid without the lattice taller and
narrower to create the flagpole. Experiment
with the lattice settings to fine tune the effect.

The finished spire

Adding the Arcade

You can use a texture map material to create an
arcade of superimposed arches. You’ll use tiling to
explore the window treatment.

Set up:

1. Continue from before or open add_
arcade1.max.

2. Navigate the viewport so you have a good view
of the western side of the Hall of Justice.

View from the west

Create the new material:

1. Go to the Customize menu > Preferences. In
the Texture Coordinates group, make sure Use
Real-World Texture Coordinates is turned off.

2. Press M on the keyboard to open the Material
Editor.

3. In the upper right of the material editor, click
the unused material sample sphere to activate it.

You can tell this material is not in use, because
it doesn’t have any corners on the frame of the
sample.

4. Name the material Arcade.

5. Click the unmarked Map Selector button to the
right of the Diffuse color swatch.

The Material/Map Browser appears.

6. Choose Bitmap, then browse to the
\tutorials\land directory and choose
ill_tut_land_arcade_texture2.bmp. Click OK.

Here is the texture you will use



Adding the Arcade 177

Texture for the arcade

7. In the Material Editor, change the Sample
Type from sphere to box by clicking the sample
type button on the upper-right toolbar and
choosing the box icon from the flyout menu.

The sample is now a box showing the texture.

Material sample box

Assign the material:

1. Drag the material from the sample box to the
Hall of Justice object.

The object changes color in the viewport.

2. In the Material Editor click the Show Map
In Viewport button.

The object changes appearance, but doesn’t
show the map yet. Just like when you applied
the bitmap to the terrain, you need to add
mapping coordinates in order to see the texture.

Add UVW mapping coordinates:

1. Select the Hall of Justice object, then on the
menu bar, choose Modifiers > UV Coordinates
> UVW Map.

The building turns sand colored, but still has no
texture. That’s because the UVW map gizmo is
aligned to the wrong axis.

2. On the Modify panel, in the Alignment group,
change the alignment to Y.

Now the texture is visible on the side of the Hall
of Justice, although it is stretched out very wide.

3. In the Alignment group, choose Bitmap
Fit, and then browse to \tutorials\land\
ill_tut_land_arcade_texture2.bmp.
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Depending on your drivers, you might need to
apply Texture Correction. If the texture looks
funny in the viewport it might be because you
are using Software drivers (formerly known as
SZB or software Z buffer). If so, then right-click
the Perspective viewport label and choose
Texture Correction.

Tip: If Texture Correction isn’t available from
the right-click menu, it’s because you are using
OpenGL or Direct3D drivers.

4. In the Modify panel, expand the UVW
Mapping rollout and choose Gizmo.

5. Uniform Scale the gizmo down about 60
percent, then move it so the row of arches line
up with the top of the archways.

Move the gizmo to line up the arches

6. Change the U tiling by clicking the U tile
spinner in the Parameters rollout. Watch the
arches in the viewport as you click or drag the
spinner.

7. The design looks a little weak. Try replacing
ill_tut_land_arcade_texture2.bmp with
ill_tut_land_arcade_texture3.bmp. This has
the same design but uses a darker green.

There is a row of tiny green circles across the
bottom of the archway. You can remove these
by turning off the V tiling.

Change the tiling:

1. In the Material Editor click the button next to
the Diffuse color swatch which is now marked
with an M. Then, in the Coordinates rollout,
turn off the Tile check box for the V Coordinate
row, as shown below.

Turn off V tiling

The line across the bottom of the archways
disappears. But now there is a new problem.
The material color is now visible and must be
changed to match the bitmap color. The diffuse
color is a gray default.

2. In the Material editor, click the Diffuse color
swatch, then in the Color Selector change the
color so it is similar to the sand color in the
viewport.

The illustration shows RGB values R=255,
G=217, B=171.



Adding the Arcade 179

The color across the base of the archways
appears correctly now.

Add another material

There are complications when you look at the
northern end of the Hall of Justice. There are parts
of the building mapped with the texture where
you’d rather see just the sand color.

You can put a different material on the end of the
Hall of Justice object.

1. Right-click the Hall of Justice object and choose
Convert to: > Convert to Editable Mesh.

Tip: When you convert to an editable mesh
or editable poly object, you lose the object
parameters specific to the primitive and
extended objects you have used. Use Edit >
Hold or save your work before you convert.

2. Press F4 to turn on Edged Faces shading.

3. In the Selection rollout for Editable Mesh, click
the Polygon button.

4. Hold down the CTRL key and click each face at
the end of the building.

Select these polygons

5. In the Material editor, make a new material and
drag it onto the polygon selection. Match the
diffuse color of this material with the previous
one, R=255, G=217, B=171. Turn off Edged
Face Toggle.

Map the administration building:

You can repeat this process on the other building,
adding materials and mapping using the same
techniques you used on the first one. There are
some additional tricks you might find helpful:

1. Use the Slice feature of the Editable Mesh and
Editable Poly objects to add faces where you
need them. Position the slice plane wherever
you need to cut, and then click Slice.

2. Create new faces using the Extrude and Bevel
tools. In the illustration that follows, you can
see the end of the building has been extruded
inward to create a visual separation at the end.
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3. Select faces and then detach them into separate
objects. Then you can apply materials and
mapping independently of the other objects.

4. Add bump mapping to the dome using the
supplied file civic_center_bump.bmp. The
illustration uses spherical mapping.

Save your work:

• Save your work as my_civic_center.max.

Flying a Camera Around the
Design

You can quickly and easily create an animation
to present your ideas by flying a camera around
your design. This section will let you explore your
concept from many different angles.

Set up:

• On the menu bar, choose File > Open and
browse to \tutorials\land\add_flyaround.max.
A thumbnail is visible in the Open File dialog.
Highlight the file and click Open.

Create a camera:

For this simple fly-around animation, you’ll use a
target camera.

1. Activate a Top viewport or create a Top
viewport if you don’t have one by pressing T
on the keyboard.

2. On the Create panel click the Cameras button.

3. On the Object Type rollout, click Target.

4. In the Top viewport, put your cursor just above
the yellow objects at the lower-left corner of the
viewport.

5. Press and drag out a camera, positioning your
cursor over the library dome, then release
the mouse button. Don’t worry about the
placement, you’ll be changing it momentarily.

Target camera

Match the camera to the view:

1. Right-click the Perspective viewport to activate
it without affecting the current selection.

2. With the camera still selected, choose Views >
Create Camera from View.

The camera jumps back in the Top viewport.

Tip: The Create Camera from View command
will create a camera from a perspective view, if
no camera is selected. If an existing camera is
selected, this command will match the camera
to the view.

3. Press the C on the keyboard.

The viewport changes to a camera view and the
viewport label now reads Camera01.
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Create a dummy object:

You’ll use a helper object called a dummy to
animate the rotation of the camera around the
scene.

1. Switch to the Top viewport, then in the
viewport navigation controls click the Region
Zoom button. In the Top viewport, zoom into
the Civic Center buildings.

2. On the Create panel click the Helpers
button.

3. On the Object Type rollout, click the Dummy
button.

4. Move your cursor over the library dome and
drag out a dummy object a bit larger than the
dome object.

Link the camera to the dummy:

1. Press the H key to open the Select Objects
dialog, then highlight Camera01 and click
Select.

The Camera object is now selected.

2. On the toolbar click the Select And Link
button.

The program is now in Select and Link mode.

3. Press the H key again to open the Select Parent
dialog.

4. Highlight Dummy01 and then click Link.

The Camera01 object is now linked to the
dummy object.

5. On the toolbar, click the Select button to
leave Select And Link mode.

Tip: Train yourself to turn off tools when you
finish using them.

Increase the time segment:

1. Click the Time Configuration button in
the time controls.

2. On the Time configuration dialog:

• In the Playback area, turn off Real Time

• In the Animation area, change End Time to
180.

• Click OK

Next you will create an animation that flies 360
degrees in 180 frames.

Animate the dummy:

1. Turn on the Auto Key button.

2. Select the dummy object. Now you will set key
frames for the dummy object.

3. Right-click the time slider to display the Create
Key dialog.

4. Turn off Position and Scale, but leave Rotate
turned on.

5. Click OK to set a rotation keyframe at frame
zero for the dummy.
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6. Move the Time slider to frame 60 by typing 60
in Current Frame field in the time controls.

7. Choose Select and Rotate on the toolbar.
Rotate the dummy about the Z axis -120
degrees by typing that value into the Z-axis
field on the status bar.

8. Move the time slider to frame 120 by typing
that value in the Current Frame field.

9. Rotate the dummy about the Z axis again, by
typing -240 in the Z-axis field.

10. Move the time slider to frame 180 by
clicking the Go to End button.

11.Rotate the dummy by typing -358 into the Z
coordinate display field.

Since -360 degrees of rotation is the same as
0 degrees of rotation, you need to use --358.
Otherwise when the animation loops, it will
appear to pause.

12. Turn off the Auto Key button.

13. Click Play to play the camera fly-around in
the Camera viewport.

You can observe your animation from all angles
now. If you like you can scroll through the
animation using the < and > keys to move
forwards or backwards at your own pace.

14.To turn off the dummy in the viewport, go to
the Display panel, and in the Hide by Category
rollout, turn on the Helpers box.

Save your work:

• Save your work as my_civic_center_
flyaround.max.

There are two tutorials in the Advanced
Lighting Chapter that use this model to teach
you exterior lighting. One teaches you how to
use the daylight system, and the second uses
the light tracer.

Summary

In this tutorial you have created a conceptual
model for a specific site. You have learned to create
a terrain, then use primitives to create your model.
You have used booleans to cut out the arches in
your buildings, and have applied materials and
used uvw mapping controls to design the arcade.
Finally you have created a fly-around of your
design, to see if from all angles.

Working with LandXML Models

Skill Level: Beginner

Time to Complete: 20 minutes

Features Covered in This Tutorial

• Importing XML files

• Importing DEM Files
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• Applying maps to imported terrain surfaces

• Adding foliage to enhance terrain

Files for This Tutorial

Lessons

Import an XML file:

1. Open 3ds Max. If you are working on another
file, choose File menu > Reset.

2. From the File menu, choose Import.

The Select File to Import dialog appears.

3. In the Select File to Import dialog > Files of
Type drop-down list, choose LandXML/DEM
(*.DEM,*.XML, *.DDF).

4. In the Select File to Import dialog, navigate to
the \tutorials\land directory, choose olympus
subdivision.xml, and click OK.

The LandXML/DEM Model Import dialog
appears.

This dialog contains a great deal of information
about the XML file. It also contains several
import options. In general, you will not need to
change anything before you import, unless you
want to change the color of certain imported
objects, or you don’t want to include specific
Alignment (road) or Parcel data.

5. In the LandXML/DEM Model Import dialog,
click Import Now.

The XML file appears in the viewport. The land
surface is represented by a 3D editable mesh
object; the Parcel/Alignment data is imported
as shape objects, positioned above the land
mesh.

Now that your land is imported, you can add
materials, import geometry such as buildings
or trees, or add a daylight system to enhance the
visualization of the area. In the next exercise,
you will get to do this.

Import a DEM file:

Importing a DEM file works exactly the same
as with an XML file, however DEM files do not
contain parcel or alignment (road) data. In this
exercise, you will import a landscape and add
foliage.

1. Choose File menu > Reset.

2. From the File menu, choose Import.

The Select File to Import dialog appears.

3. In the Select File to Import dialog > Files of
Type drop-down list, choose LandXML/DEM
(*.DEM,*.XML).

4. In the Select File to Import dialog, navigate
to the \tutorials\land directory, choose
aspen.dem, and click OK.

The LandXML/DEM Model Import dialog
appears.
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Note: DEM files only contain elevation data,
therefore you don’t have to worry about
including Alignments (roads) or Parcels.

5. In the LandXML/DEM Model Import dialog,
click Import Now.

The elevation information appears in the
viewport, represented as a 3D editable mesh
object.

Next, you will add a material to your surface.

Add a material to the surface:

1. Go to the Customize menu > Preferences. In
the Texture Coordinates group, make sure Use
Real-World Texture Coordinates is turned off.

2. Press M to open the Material Editor.

3. Select an empty material slot, and in the
Physical Qualities rollout, next to Diffuse Map,
click None.

The Material/Map Browser appears.

4. In the Material/Map Browser, double-click
Bitmap.

The Select Bitmap Image File dialog appears.

5. In the Select Bitmap Image File dialog, navigate
to \tutorials\land, choose aspen.jpg, and click
Open.

The material is now ready for use in your scene.

Tip: Make sure that Show Map in Viewport
is turned on for this material.

Before you apply the material, you need to add
a UVW Map modifier to the surface.

6. With the surface selected, choose Modifiers
menu > UV Coordinates > UVW Map.

7. Drag the new material from the Material Editor
to the surface.
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The landscape looks much better, now that it
has its “skin”. All it needs now is some foliage.

Add foliage to the landscape:

1. On the Extras toolbar, turn on AutoGrid.

AutoGrid ensures that your foliage is created on
the surface of the mesh.

Note: If the Extras toolbar is not displayed, turn
it on by right-clicking an empty portion of any
toolbar, then choose Extras from the menu.

2. On the Create panel, choose AEC Extended
from the object type drop-down list, and click
Foliage.

3. Choose from the list of plants and click to add
them in your scene. You will probably need to
use the viewport controls to zoom, pan, and
rotate the landscape.
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Summary

In this lesson, you learned how to import two
types of LandXML files. You also learned how to
enhance your imported terrain with materials and
foliage.



Using Special Animation
Controllers

Limit Controller

Using the Limit Controller

In this tutorial, you will learn to limit the range of
a rotation by using the Limit Controller.

Features covered in this tutorial

• Assigning a Controller to an animation track

• Setting minimum and maximum limits to a
controller range

Skill Level: Beginner

Time to complete: 15 min

Tutorial Files

All the necessary files for this tutorial can
be found on the Tutorial Files CD in the
\tutorials\controllers directory. Before starting the
tutorials, copy the \tutorials folder to your local
\3dsmax8 installation.

Using the limit controller:

1. Open TreasureChest.max from the
\tutorials\controllers directory.

2. Select the Top.

Animation
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3. Rotate the Top about its X axis and note that
there’s no limit to its rotation range. It can
rotate quite far in either direction.

4. Click Undo to restore the top to its
original orientation.

In the following steps you will apply the limit
controller to restrict the Top’s range of motion
from 0 to –110 degrees.

5. Verify the top is still selected.

6. From the right-click quad menu, select Curve
Editor.

7. Expand the hierarchy and select the X Rotation
track.

8. From the right-click quad menu, select Assign
Controller.
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9. From the Assign Float Controller dialog, select
Float Limit and click OK.

10.Set the lower limit to –110 and the upper limit
to 0.

11.Close the dialog.

12.Close Curve Editor.

13.Select the rotate tool and rotate the Top about
its X axis. The Top will no longer rotate beyond
the specified limits.

Summary

In this tutorial, you learned to use the Limit
Controller to limit the range of another controller.
In this case, you limited the rotation controller
assigned to the lid of the treasure chest.

Wiring & Expressions

Introduction to the
Parameter Collector
As your scene becomes more complex, you will
find yourself spending more and more time
moving among objects to fine-tune and animate
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their parameters. The Parameter Collector tool,
allows you to accumulate selected parameters from
throughout the scene into a single dialog, and to
organize the parameters to suit your needs.

The end result? Animation is quicker and easier:
no more hunting for the right parameter in a long
list of parameters, or accidently animating the
wrong one.

In this tutorial, you will collect and organize the
parameters for a simple robotic arm in order to
position a sign it is holding in its hand.

Skill Level: Beginner/Intermediate

Time to complete: 40 minutes

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\parameter_collector folder. Before
doing the tutorials, copy the \tutorials directory
from the CD to your \3dsmax8 local installation.

Organizing the Collection

In this lesson, you will select a few important
parameters from a simple scene and organize them
in Parameter Collector.

Set up the scene:

• Open robot_spot01.max.

The scene shows a robotic arm assembly in
a small room. If you scrub the time slider,
you’ll see that the only animation is in a simple
camera move.

Organize the transforms:

First you will find the important rotation
transforms that you will need to animated the
robot assembly, and assemble them in Parameter
Collector for later adjustment.

1. On the main menu, choose Animation >
Parameter Collector.

The Parameter Collector dialog is displayed.
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2. On the Parameter Collector dialog, click
the Add To New Rollout button.

3. From the Track View Pick dialog, select Objects
> Robot Base Rotate Dummy > Transform >
Rotation > Z Rotation.

4. Click OK to accept.

The selected parameter appears in a new rollout
on the Parameter Collector dialog. Hold the left
mouse button down on the arrows to the right
of the Z Rotation value, and drag up and down
while you watch the robot base in the viewports.
The robot base rotates along the Z axis.

You’ve “captured” this single rotational
transform, and put it into the Parameter

Collector, where it will be handy when you
need it. Make sure you reset the value to 0.0
before proceeding.

5. In the Parameter Collector dialog, type Robot
Animate in the collection name entry box.
Press ENTER to accept the name.

6. In the Parameter Collector main menu, choose
Rollout > Rename Rollout. Enter the name
Robot Transforms in the Rename Rollout
dialog. Click OK to accept and close the dialog.

The revised name appears on the rollout panel.

Now you can add the additional parameters you
will need in order to animate the movement of
the robot arm.

7. On the Parameter Collector dialog, click
the Add To Selected Rollout button. On the
Track View Pick dialog, choose Objects > Robot
Base Rotate Dummy > Robot Base Rotate >
Robot Arm Pivot Dummy > Transform >
Rotation > Y Rotation. Click OK.

The Robot Transform rollout now has two
rotation parameters, but it would be easy
to forget which transform applies to which
component of the assembly, so rename the
rotation parameters.
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8. Right-click the box to the left of the Z Rotation
parameter, and in the Notes dialog, type Base:
Z Rotation in the Parameter Name edit box.
Click OK to accept and dismiss the dialog.

Repeat this step for the Y Rotation parameter,
and rename it Arm: Y Rotation.

The Parameter Collector dialog now has
two renamed parameters under the Robot
Transforms rollout.

9. Click the Add To Selected Rollout button
again. On the Track View Pick dialog, choose
Objects > Robot Base Rotate Dummy > Robot
Base Rotate > Robot Arm Pivot Dummy > Arm
Base > Robot 1 arm 2 > Arm Piston > Robot 1
End Piston > Robot 1 end effector16 > Pickup
rotate Dummy > Transform > Rotation > Y
Rotation. Click OK.

10.Right-click the rectangle to the left of the new Y
Rotation parameter as before, and rename this
parameter Gripper: Y Rot.

Now the three transforms that you will use
to animate the movement of the robot are
all accessible in a single Parameter Collector
rollout.

Collect the material property:

One more parameter needs to be added, to control
the Blend Material on the call letters. In this
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part, you will first set up the Blend material to
use a Linear Float controller for the material’s
Mix Amount parameter. Then you will add the
parameter to the existing collection.

1. On the main toolbar, click the Curve
Editor button. On the curve editor, click the +
icon for Scene Materials, in the scene list on the
left side of the Track View, to expand the list
and reveal the materials.

2. Expand the Orange Glow material by clicking
the + icon next to it. Select the Mix Amount
parameter in the material’s parameter list.

3. Right-click the Mix Amount parameter. From
the quad menu, choose Assign Controller to
display the Assign Float Controller dialog.

4. In the Assign Float Controller dialog, select the
Linear Float controller. Click OK to accept and
close the dialog.

5. On the Parameter Collector, click the Add
To New Rollout Button. On the Track View Pick
dialog, expand Scene Materials > Orange Glow,
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and double-click Mix Amount to create a new
rollout. Rename the new rollout Glow to Steel.

Animating the Parameters

Now that you have all the important parameters in
one place, you will use the Parameter Collector to
create a brief animation.

Continue from the previous lesson
or open robotspot02.max from the
\tutorials\parameter_collector folder. If
you haven’t already, choose Animation >
Parameter Collector from the main menu to open
the Parameter Collector dialog.

Animate the robot arm:

1. From the Parameter Collector dialog menu,
choose Show Selected Keys In Trackbar.

2. On the Robot Transforms rollout, click the
selector box to the left of the Arm: Y Rotation
label to select this parameter.

3. Click Auto Key to turn it on.

4. Move the time slider to frame 30.

5. On the Parameter Collector, set Arm: Y
Rotation to –95.0.

6. Move the time slider to 120.
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7. On the Parameter Collector, click the Key
Selected button to set a keyframe for Arm: Y
Rotation at the current frame.

8. Move the time slider to frame 200. Set Arm: Y
Rotation to –25.0.

9. Right-click the Left viewport to activate it,
and click the Play Animation button to view
the animation.

The robot arm rotates slowly until almost
parallel with the floor, then pauses, then rotates
until near vertical, then pauses again.

Stop the animation playback before continuing.

10.On the Parameter Collector, click the selector
box to the left of the Arm: Y Rotation label to
deselect this parameter.

Animate the robot base:

1. On the Parameter Collector, click the selector
box to the left of the Base: Z Rotation label to
select this parameter.

2. Move the time slider to frame 30.

Warning: Make sure Auto Key is still on.

3. Move the time slider to frame 30.

4. On the Parameter Collector, click the Key
Selected button to set a keyframe for Base: Z
Rotation at frame 30.

5. Move the time slider to 120. Set Base: Z
Rotation to 263.0.

6. Click the Play Animation button to see the
results.

Now the base starts rotating at frame 30, and
then spins three-fourths of a circle before the
arm rotates upward.

Stop the playback before proceeding.

Animate the gripper:

1. On the Parameter Collector, click the selection
box to the left of Base: Z Rotation to deselect
it, and click the selection box next to Gripper:
Y Rot. to select it.

2. Move the time slider to frame 0.

3. Make sure that Auto Key is still on, then
right-click the arrows to the right of the Grip: Y
Rot value to force the rotation to 10 at frame 0.

4. Move the time slider to frame 30, and
click Key Selected in the Parameter Collection
dialog.

5. Move the time slider to 120, and set Gripper: Y
Rotation to 75.0.
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6. Move the time slider to 180, and click Key
Selected in the Parameter Collection dialog to
set a key at the current frame.

7. Move the time slider to 220, and set Gripper: Y
Rotation to 29.0.

8. Activate the Camera01 viewport, and click
the Play Animation button to see the results.

Now the gripper rotates just in time to present
the logo to the camera in the final frames.

Stop the playback before proceeding.

9. On the Parameter Collector, click the selector
box to the left of the Gripper: Y Rot label to
deselect this parameter.

Animate the material parameters:

Earlier in the tutorial, you set up the material
so you could animate the Blend parameter with
a linear float controller. You then added a Mix
Amount parameter to the Parameter Collector.
Now you use the Parameter Collector to animate
this material parameter.

1. On the Parameter Collector dialog > Glow To
Steel rollout, click the selector box to the left of
the Mix Amount label to select this parameter.

2. Double-check to make sure the Auto
Key button is still on, and move the time slider
to frame 220.

3. Click Key Selected on the Parameter
Collection dialog to set a keyframe for the Mix
Amount at the current frame.

4. Click Quick Render to see a rendering
of frame 220.
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5. Move the time slider to frame 260. On the
Parameter Collector dialog > Glow To Steel
rollout, set Mix Amount to 100.0.

6. Click Quick Render to see a rendering
of frame 260.

The letters on the cast plate have turned blue, as
though they have cooled.

Note: Since this is a Blend Material change, it is
not reflected in the viewport.

Save your work

• From the main menu, choose File > Save As.
Save your work as my_robospot.max in your
appropriate local folder.

Note: You can compare your completed file
to the file robotspot_complete.max that is
available in the \tutorials\parameter_collector
directory.

Summary

In this tutorial, you learned how to collect
animatable parameters in the Parameter Collector,
and how to quickly create a keyframe animation
from those parameters without having to refer
back to the original object or material definition.
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Modeling a Low-Poly
Character

Modeling a Low-Poly Character

This tutorial explains how to model a character
much like the ones you see in today’s video games.
You will explore a variety of modeling techniques
starting with what is commonly called “box

modeling”, which means constructing your model
from a simple polygon box. You can model just
about anything using this creation method.

You will also make extensive use of the Editable
Poly object and Edit Poly modifier. You will use
the Symmetry modifier in some cases to help your
modeling approach. With practice, you will be
able to model any character you want in a simple
and fast manner.

Skill Level: Intermediate

Time to complete: 6–8 hours

Features Covered in This Tutorial

• Creating various complex, organic forms from
simple objects such as primitives and extruded
shapes.

• Using the Symmetry modifier to create a mirror
duplicate of half of the model.

• Transforming Editable Poly sub-objects for
fine-tuning the model shape.

• Inserting vertices to add resolution where
needed.

Tutorial Files

All the necessary files for this tutorial can
be found on the Tutorial Files CD in the

Game Design
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\tutorials\low_polygon_modeling directory.
Before starting the tutorials, copy the \tutorials
folder to your local \3dsmax8 installation.

In This Tutorial

Setting Up the Scene (page 2–200)

Creating the Boots (page 2–203)

Creating the Pants (page 2–208)

Creating the Torso (page 2–214)

Creating the Arms (page 2–219)

Creating the Helmet (page 2–225)

Creating the Visor (page 2–229)

Creating the Oxygen Mask (page 2–230)

Creating the Neck (page 2–233)

Adjusting Smoothing Groups (page 2–235)

Setting Up the Scene

Before you begin creating a 3D model, whether it
is a character or any other object for that matter,
you first need to do some research on the object
you wish to create. In this tutorial, you will be
modeling a helicopter pilot for a war game.

Plenty of research can be done on this subject,
whether in books or search engines on the internet.
Another method of working can be by taking
snapshots of a figurine bought in a toy store.

Better yet, you may be a talented illustrator and
can create the necessary drawings that you will use
as reference to build the character.

Creating a virtual studio

Before you start, take note of the resolution (in
pixels) of the reference images you created. If
you are using the reference files that have been
provided for this tutorial, their resolutions are as
follows:

Top reference image: 385(width) x 200 (height).

Front reference image: 385(w) x 440(h).

Side reference image: 200(w) x 440 (h).
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Creating a reference plane:

1. Start 3ds Max. Make sure the top view is active.

2. From the Create menu, choose Standard
Primitives > Plane.

3. Click and drag an area in the top view. Do
not worry about the size of the plane you are
creating.

4. Go to the Modify panel. In the Parameters
rollout, set the Length to 200 and the Width to
385.

5. Set the Length Segs and the Width Segs to 1.

6. From the Main toolbar, choose the Move
tool.

7. On the status bar, set the position values in X, Y
and Z to 0. This places the plane’s pivot point
on the World origin.

Map a reference image:

1. Press M to open the Material Editor.

2. In the Blinn Basic Parameters rollout, set the
Self Illumination value to 100%. This will help
with seeing the map without any help from
scene lights.

3. Click the little gray box next to the Diffuse color
swatch.

4. From the Material/Map Browser that appears,
double-click on Bitmap to select it.

5. Browse to the \Tutorials\low_polygon_
modeling folder and choose soldier-top.jpg.
Click Open to dismiss the dialog.

6. Click the Show Map in Viewport icon to
toggle it on.

7. With the plane still selected, click the
Assign Material to Selection icon to apply the
newly created material to the plane. The plane
is now textured in the Perspective view.

Create additional reference planes:

Now that you have created the first plane (top
plane), you need to repeat the procedure to create
an additional plane based on the Front view, and
another one based on the Left view. The sizes of
these planes should reflect the sizes of the reference
images that will be assigned to them. Therefore,
the plane you build in the Front view should be
440 in length by 385 in width, and the plane you
build in the Left view should be 440 in length by
200 in width. Remember to choose a new sample
slot in the material editor for every new material.
When you are done, the Perspective viewport
should look as follows:
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Adjust the virtual studio:

You will need to adjust the position of the three
reference planes before you start modeling the
character.

1. Activate each viewport in succession and press
G to toggle off the grid. At this time, the only
shaded viewport is the perspective view.

2. Make sure every viewport is shaded by first
activating it and then pressing the F3 keyboard
shortcut.

3. Select the top reference plane in the perspective
view. Using the Move tool, move the plane
down on the Z-axis (blue axis) until it is at the
bottom of the other two planes.

4. Select the side reference plane in the perspective
view. If you look closer, you’ll notice that the
height of the helmet in this reference plane does
not match that of the front reference plane.

5. Move the side plane up on the z-axis so that the
helmets’ heights match. You can keep an eye on
the pilot’s belt as well.

6. Once this is done, move the side reference plane
on the x-axis (red axis) to the right edge of the
virtual studio.
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7. 7. Finally, select and move the front reference
plane on the y-axis to the back edge of the
virtual studio.

Freeze the reference planes:

Once the reference planes are in place, you should
freeze them to prevent accidentally moving them
around.

1. Select one of the reference planes and go
to the Display panel.

2. In the Display Properties rollout, turn off Show
Frozen in Gray.

Note: Leaving this option on would turn an
object to dark gray after freezing it, preventing
you from seeing the reference image. In the
case of a virtual studio, you want to disable this
option.

3. Expand the Freeze rollout and choose Freeze
Selected.

4. Repeat the procedure for the other two reference
planes. You will need to turn off Show Frozen
in Gray for each individually selected item.

5. Save your file naming it my_virtual_
studio.max.

Next

Creating the Boots (page 2–203)

Creating the Boots

In this lesson, you create the boots of the helicopter
pilot by using a simple box primitive. You will then
convert the box to and Editable Poly object and
start sculpting the boot using sub-objects such as
vertex, edge and polygon.

Create a box primitive:

1. Continue working on your file from
the previous exercise, or load the
file virtual-studio.max found under
\tutorials\low-polygon-modeling.

2. Zoom in on the pilot’s foot in the left viewport.

3. From the Create menu, choose Standard
Primitives > Box.

4. Create a box to use as a heel. Make the Length
about 6 units and Width and Height about 18.
Do not worry about being too accurate, you
will be adjusting the inner components of this
box in a short while.

5. In the top view, move the box so that it is
aligned with the pilot’s right foot (to the left of
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the viewport). If you need to, adjust the height
of the box to conform to the width of the foot
in the reference image.

6. Right-click on the box and choose Convert to >
Convert to Editable Poly from the quad menu.

7. From the Modify panel, choose the
Polygon button.

8. In the top viewport, click the side of the
box facing you. The top polygon on the box
highlights in red.

9. Press the spacebar to lock your selection.

Note: Alternatively, you can lock a
selection by pressing the Lock Selection toggle
on the status bar.

10.From the Edit Polygons rollout, click the
Extrude button.

11.In the left view, click and drag to extrude the
selected polygon until it is right below the ankle.

Note: To better visualize the geometry structure,
press F4 to turn Edged Faces mode on. Repeat
the F4 procedure in all viewports.

12.Unlock the selection so you can select a
different polygon.

13.In the front view, click the upper polygon
representing the foot.

14.From the Edit Polygons rollout, click the
Extrude button again and click and drag the
selected polygon to extrude it until it reaches
the ball of the foot. Keep an eye on the left view
for reference.

15.In the Left view, slightly scale the selected
polygon on the vertical (Y) axis.
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16.Move the selected polygon down to level it on
the ground.

17.In the front view, scale the select polygon up
horizontally.

18.Perform one addition extrusion to create the
toes. Use Move and Scale on the various axes
to adjust the selected polygon as seen in the
following illustration.

19.In the top view, select the polygon representing
the heel.

20.Extrude the selected polygon to the ankle level.

21.From the Edit Polygon rollout, choose the Bevel
tool. Click and drag the selected polygon to
perform a regular extrusion, and then move
the mouse slightly up to perform a scale on the
selected polygon. Keep an eye on the image in
the viewport for reference.
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The bulk of the work is done, but you still need to
refine the boot to make it look better.

Refine the boot:

1. Continue working on your file.

2. From the selection rollout, choose Edge.

3. In the perspective view, select one of the vertical
edges near the ball of the foot or the toes.

4. In the Selection rollout, choose the Ring button.
Now all edges around the foot are selected.

5. In the Edit Edges rollout, choose the Connect
button. You now have an extra division running
horizontally across the previously selected
edges.

6. Uniform Scale the selected edges slightly (about
108 %) to tone down the “boxy” look of the
foot.

7. In the Perspective, use Arc Rotate
SubObject to view the back of the boot.

8. Select the top edge at the back of the boot.
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9. Hold Control down and then click the down
spinner of the ring tool. With every click, an
additional edge is selected around that ring.
Keep on clicking until all edges running down
the back side of the boot are selected.

10.In the Edit Edges rollout, choose Connect.
A new vertical division goes through the
previously selected edges.

11.In the top view, move the selected edges up on
the vertical axis (Y) so that the back of the boot
is slightly more rounded.

12.If you have time, continue refining the boot.
However, do not overdo it as you do not want
to have too many polygons in the model.

Finalize the boot:

1. Continue working on your file.

2. In the Modify panel, exit sub-object mode.

3. From the Modifier list, choose the Bend
Modifier.

4. Set the Bend Axis to Y and the Direction to 90
degrees.
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5. Adjust the Bend Angle so that the boot is
oriented with the reference image. An angle
of -15 to -16 degrees should be adequate. You
may want to slightly rotate the boot in the top
view as well.

6. Rename the object Boot-Right.

Mirror the boot:

1. Continue working on your file.

2. Right-click the Front viewport to activate it.

3. From the Main toolbar, choose the
Mirror tool.

4. Leave the Mirror axis as X and set the Clone
Selection method to Instance.

5. Click OK to dismiss the dialog.

6. Use the Move tool to position the new boot
based on the reference image.

7. Rename the clone Boot-Left.

8. Save your file as My-Heli-Pilot-Boots.max.

Next

Creating the Pants (page 2–208)

Creating the Pants

In this lesson, you create the pants for the
helicopter pilot. Much like you created the boots,
you will build the pants based on a primitive, this
time a cylinder. You will create one leg first and
then use the Symmetry modifier to create the
other leg.

Creating a leg:

1. Continue working on your file from the
previous exercise, or load the file soldier01.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the pilot’s right foot in the top
viewport.

3. From the Create menu, choose Standard
Primitives > Cylinder.

4. Create a cylinder in the top view centered on
the right boot.
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5. Go to the Modify panel. Set the cylinder
Parameters as follows:

Radius: 20

Height: 20

Height Segments: 1

Sides: 8

Smooth: Off

6. In the Left view, move the cylinder down until
it intersects slightly with the boot.

7. In the Front view, rotate the cylinder so that it is
aligned with the pant leg in the reference image.

8. From the Main toolbar, choose Scale and set
the Coordinate System to Local.

9. In the front view, scale the cylinder on its local
x axis so that it better fits the reference image.

10.Right-click the cylinder in any viewport and
choose Convert to > Convert to Editable Poly.

11. In the Modify panel, choose Polygon
mode.

12.In the top view, click the cylinder’s top polygon.

13.In the Edit Polygons rollout, choose the Extrude
button.

14.Click and drag the selected polygon in the top
view to extrude it by about half the original
height.

15.Use the Move tool and the Local Scale tool to
adjust the selected polygon to the reference
image in the various viewports.
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16.Perform another extrusion to right below the
knee. Again, use the transform tools such as
Move and Scale. You can also use Rotate to
match the polygon to the reference image.

Note: Joints such as knees and elbows require
special attention, mainly additional detail so
that they deform properly when animated.

17.Add two more extrusions/adjustments to
complete the knee.

18.Add one more extrusion to create the thigh, and
another all the way to the hip joint. Remember
that you can add more detail later if you miss
a spot.

19.Add two more extrusion to provide a reasonable
amount of detail for the hip joint.
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20.Add another extrusion to reach the lower part
of the belt. Use the transform tools to align the
polygon with the belt line. Do not worry about
the right side, This will be taken care of when
you apply the Symmetry modifier shortly.

21.Add one final extrusion for the belt.

Before you apply a symmetry modifier to create
the opposite leg, you need to adjust the buttocks
area, which is too flat at the moment.

22. In the Selection rollout, choose Edge
selection mode.

23.In the left view, select any of the vertical edges
below the belt.

24.In the Selection rollout, click the Ring button to
select all edges parallel to the selected one.

25.In the Edit Edges rollout, click on Connect.
This adds a series of edges connecting the
previously selected ones.

26. In the Selection rollout, choose Vertex
selection mode.

27.In the left view, use a Region selection to adjust
the position of vertices around the buttocks.

28.Exit sub-object mode when done.

Use the reset XForm utility:

Before you apply a Symmetry modifier to create
the other leg, you need to use the Reset XForm
utility to reset all rotation and scale on the existing
object. Failing to do so will result in symmetry
planes that do not work for your purposes.
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1. Continue working on your file from the
previous exercise.

2. With the leg selected, go to the Utilities
panel.

3. Click the Reset XForm button and then the
Reset Selected button.

4. Go back to the Modify panel and notice you
have a new XForm modifier added to the stack
that contains all the reset rotation and scale
values.

5. Collapse the stack by right-clicking the leg
in the viewport and choosing Convert to >
Convert to Editable Poly.

Use the symmetry modifier:

1. Continue working on your file from the
previous exercise.

2. Make sure the leg is selected. In the Modify
panel, choose Symmetry from the Modifier list.

3. Expand the Symmetry modifier and choose
Mirror to access this mode.

4. In the Parameters rollout, leave the axis at X
and enable the Flip option.

5. In the Front view, move the Mirror plane on
the X-axis to the appropriate location to get a
properly placed symmetrical leg.

6. Exit Mirror sub-object mode when done.

The pants are almost done. You still need to
fine-tune the area around the hips though; you will
use the Edit Modifier to correct that.
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Use the Edit Poly modifier:

1. Continue working on your file from the
previous exercise.

2. Make sure the leg is selected. In the Modify
panel, choose Edit Poly from the Modifier list.

3. Zoom in on the front of the belt in the
perspective view.

4. From the Selection rollout, choose the
Edge button.

5. Choose the center edge on the belt.

6. Hold the Control key and click the upper
spinner on the Loop tool twice. This will add
edges to the selection.

7. In the top view, move the selected edges on the
vertical (Y) axis so that you get a nice flowing
curve instead of an inverted V.

8. Repeat the procedure to adjust the edges on the
back side.

9. Continue fine-tuning the area around the
hips. Try alternating between edge and vertex
selection modes for better control.

10.Using edge selection mode, choose one vertical
edge on the belt line.

11.In the Selection rollout, choose Ring to select
all vertical edges around the belt.

12. Holding down the Shift key, click the
Polygon button to convert edge selection to
poly selection.

13.In the Edit Polygons rollout, click the little
Settings button near the Extrude tool.

14.In the dialog that appears, set the Extrusion
type to Local Normal and the Extrusion Height
to 1.5
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15.Click OK to dismiss the dialog.

Remove unwanted polygons:

1. Continue working on your file from the
previous exercise.

2. Holding down the Control key, select the two
polygons at the top of the pants.

3. In the Edit Polygons rollout, click the small
Settings button next to Inset. A dialog appears.

4. Set the Inset Amount to 5.0, and then click OK
to accept the changes and exit the dialog.

5. Press the Delete key to remove the selected
polygons.

6. Repeat the procedure to inset and then remove
the polygons at the bottom of the pants legs.

7. Right-click the pants and go to the Properties
dialog. Turn off Backface Cull and click OK.
This allows you to see the inside as well as the
outside of the pants.

8. Exit sub-object mode. In the Modify panel,
rename the object Pants.

9. Save the file as my-soldier-pants.max.

Next

Creating the Torso (page 2–214)

Creating the Torso

In this lesson, you create the torso for the helicopter
pilot, mostly the T-shirt he’s wearing. In previous
exercises, you used simple primitives such as a box
or a cylinder and you mostly extruded polygons to
create a volume. In this exercise, you use a slightly
different approach. You will use an even simpler
primitive, a plane object, but you will do most of
the work using edge sub-selection. You will find
this method of modeling extremely powerful and
intuitive.
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Create the T-shirt

1. Continue working on your file from the
previous exercise, or load the file soldier02.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the pilot’s mid-section in the front
viewport.

3. From the Create menu, choose Standard
Primitives > Plane.

4. Click and drag in the Front viewport to create a
plane object.

5. In the Modify menu, set the Length to 20, the
Width to 12 and set both Length & Width
Segments to 1.

6. Position the plane so that it intersects slightly
with the belt and with the symmetry plane.

7. In the top view, move the plane to the front
section of the pants.

8. Right-click the selected plane and choose
Convert to > Convert to Editable Poly.

9. In the Modify panel, choose Edge selection
mode in the Selection rollout.

10.In the front view, select the top edge of the
plane.

11.In the left view, move the selected edge slightly
to the left to follow the reference image.

Note: Because the plane appears as a line in the
left view, it takes some practice to properly
visualize where the selected edge is at any given
point. The transform gizmo is always a sure
hint where to look for a selection.

12.Holding Shift down, move the selected edge
up and to the right to extrude it once, always
conforming to the reference image.
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13.Continue using Shift + Move to extrude the
selected edge around the profile silhouette of
the helicopter pilot.

14.Right-click on the partially modeled T-Shirt
object and choose Properties from the Quad
menu.

15.In the Display Properties group, turn off
Backface Cull.

16.Click OK to exit dialog. You can now see both
sides of the flat polygons.

Edit the T-shirt:

1. Make sure you are still in Edge sub-object
mode.

2. In the front view, select any of the vertical edges
to the left of the viewport.

3. Click the Loop button to select all the edges to
the left side of the viewport.

4. Hold the Shift key down and then move the
selected edges to the left by about the same
amount as the original width.

5. In the left view, scale the selected edges on the
horizontal axis to bring them closer together.
Keep also an eye on the top view for reference.

6. Repeat the procedure to create one addition
edge extrusion as seen in the illustration below.
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7. In the left view, select inner vertical edges, right
above the belt line.

8. In the Edit Edges rollout, click the Bridge
button. The two edges are now connected by
a polygon.

9. Repeat the procedure for two more levels of
edges to bridge.

10. Switch to Vertex selection mode. Use the
Move tool to fine-tune the position of vertices
based on the reference images.

Create the sleeve:

1. In the Selection rollout, choose the Border
sub-object mode.

2. Select one of the edges around the sleeve
opening. The whole perimeter is now selected.

3. In the Front view, use Shift + Move to create
two extrusions, used to create the sleeve.
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4. Adjust the vertices in the various views to
follow the reference images.

Add detail:

1. Adjust the vertices in the various views to
follow the reference images.

2. Select an edge under the armpit.

3. Click the Ring button to expand the selection.

4. Click Connect to add a line of edges connecting
the previously selected edges.

5. Adjust the edges and vertices positions to get a
better sleeve opening.

Create the collar:

1. In the Selection rollout, make sure Edge
sub-object mode is still selected.

2. In the Top view, select the following edges:

3. Connect the selected edges.

4. Switch to Vertex selection mode. Use the
Move tool to fine-tune the shape of the collar
based on the reference images.
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5. In the selection rollout, choose Polygon
mode.

6. Select the polygons above the collar line.

7. Press delete to remove the unwanted faces.

8. Exit sub-object mode.

Add a symmetry modifier:

1. Make sure the partially built T-Shirt is selected
and that you are not in sub-object mode.

2. In the Modify panel, choose the Symmetry
modifier from the Modifier list.

3. Leave the Mirror Axis at X and turn on the Flip
option.

4. Expand the Symmetry modifier and select
Mirror.

5. In the Front viewport, move the mirror line
to the right until you get a properly adjusted
T-Shirt.

6. Exit sub-object mode and rename the object:
Shirt.

7. Save your file as my_soldier_Tshirt.max.

Next

Creating the Arms (page 2–219)

Creating the Arms

In this lesson, you create the arms of the helicopter
pilot. For the upper arm and forearm, you can
use the same modeling techniques that you used
to model the pants, that is, using a cylinder and
extruding polygons. To create the hand, you can
build it based on a box primitive. Later, you will
attach the hand to the arm and connect the gap
using the bridge tool.

Create the arm:

1. Continue working on your file from the
previous exercise, or load the file soldier03.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the T-Shirt sleeve in the left
viewport.

3. Create a Cylinder centered on the sleeve. Set
the parameters as follows:

Radius: 12



220 Chapter 6: Game Design

Height: 30

Height Segments: 1

Sides: 6

4. Move and rotate the cylinder in the top view so
that it is oriented with the sleeve and is slightly
protruding from the sleeve.

5. Right-click the cylinder and then choose
Convert to > Convert to Editable Poly.

6. In the Selection rollout, choose Polygon
mode.

7. In the left viewport, select the hexagon facing
you.

8. In the Edit Polygons rollout, choose Extrude.
Click and drag the selected polygon to create an
extrusion for the biceps.

9. Using Move and Local Scale, adjust the biceps
to make them bigger.

10.Create another extrusion to close the biceps
near the elbow. Use Move, Rotate and Scale to
adjust the polygon at that level.

11.Create an additional extrusion for the elbow.
This is needed to deform the elbow correctly
when it comes time to animate the character.
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12.Create two more extrusions to create the
forearm. Adjust them to fit the reference
images.

13.Right-click the front viewport to activate it.

14.Press F3 to set the viewport in wireframe mode.
Notice the arm inside the sleeve.

15. In the Selection rollout, choose Vertex
selection mode.

16.Adjust the vertices in the viewport to get a
better flow between the arm and the sleeve.

17.Press F3 again to set the viewport back in
shaded mode.

18.Exit sub-object mode when done.

Create the hand:

1. Continue working on your file.

2. Zoom in on the hand sketch in the top viewport.

3. Create a box with the following parameters.

4. Use the Move tool to position the box properly
in the top and the front views.

5. Right-click the box and then choose Convert to
> Convert to Editable Poly.

6. In the Selection rollout, choose Vertex
selection mode.

7. Using Region select, move vertices around in
the top view to follow the shape of the back of
the hand.



222 Chapter 6: Game Design

Note: It is important to use Region select in the
top view to ensure you are selecting the top and
the bottom vertices on a vertical edge.

8. In the Selection rollout, choose Edge
selection mode.

9. In the left view, select the three vertical edges
separating the fingers.

10.In the Edit Edges rollout, click the little Settings
button to the right of Chamfer. A dialog
appears.

11.Set the Chamfer amount to 0.5 to separate the
polygons that will be used to create the fingers.
Press OK to exit the dialog.

12. In the Selection rollout, choose Polygon
mode.

13.In the left view, choose the polygon that
represents the index finger.

14.In the Edit Polygons rollout, choose the Bevel
button.

15.Click and drag the selected polygon until you
reach the first knuckle. Move the mouse slightly
down to scale down the selected polygon.

Note: The Bevel tool acts like a combined
extrusion/scale tool. Alternatively, you can
use the Extrude command and then manually
scale the selected polygon in a uniform or
non-uniform way.

16.Create another extrusion/bevel for the knuckle.
The extra detail provided there will ensure the
finger will deform properly when animated.

17.Continue beveling the finger all the way to the
tip.
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18.Repeat the procedure with the other fingers.
When you are done, the hand should look like
the following illustration.

19.In the perspective view, select the polygon
representing the thumb.

20.Use the Bevel tool as you did earlier to create
the thumb. However, with every extrusion, you
will need to compensate with the rotate tool in
the top view to curve the thumb slightly.

21. In the Selection rollout, choose Vertex
selection mode.

22.Select all four of the vertices at the tip of the
index finger.

23.Expand the Soft Selection rollout and turn on
Use Soft Selection.

24.Turn on Edge Distance and set its value to 4.
This ensures that soft selection does not extend
beyond four edges and therefore will not affect
the neighboring finger.

25.In the Front view, move and rotate the finger to
give it a more relaxed look.

26.Adjust the other fingers as well. Use move
rotate and scale to give the hand reasonable
proportions.
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27.Adjust the vertices around the wrist to make
that side more rounded. This will make it easier
to connect the hand to the arm later.

Note: You may want to toggle Soft Selection
mode on or off to round off the wrist to your
liking..

28.Exit sub-object mode when done.

Attach and bridge the objects:

1. Continue working from the previous lesson.

2. Select the Arm object.

3. In the Edit Geometry rollout, choose the Attach
button.

4. Click on the hand in any viewport to attach it
to the arm.

5. Right-click to exit the Attach command.

6. In the Selection rollout, choose Polygon
mode.

7. Select the polygons on the hand and arm that
are facing each other.

8. In the Edit Polygons rollout, click the small
Settings button next to Bridge. A dialog
appears.

9. The default settings should work fine but try
out values for Twist and Segments to view the
end results. Remember that changes will only
be retained after you click OK.



Creating the Helmet 225

10.If you need to, go to Vertex selection mode and
fine tune the area around the wrist.

11.Exit sub-object mode when done.

12.Rename the Object: Arm_Right.

Mirror and clone the arm:

1. Continue working on your file from the last
exercise.

2. In the Front view, select the Arm_Right object.

3. From the Main toolbar, choose the
Mirror tool.

4. Leave the Axis as X and choose the Instance
clone option. Click OK to dismiss the dialog.

5. Move the cloned arm in the front or the top
view to reposition it properly.

6. Rename the clone: Arm_Left.

7. Save your file as my_pilot_arms.max.

Next

Creating the Helmet (page 2–225)

Creating the Helmet

In this lesson, you create the helmet for the
helicopter pilot. So far you have started modeling
parts using simple base objects such as a box, a
cylinder or a plane. You can certainly model the
helmet using one of these primitives but this lesson
will show you yet another approach, where you use
an extruded shape to act as a model base.

Create the helmet:

1. Continue working on your file from the
previous exercise, or load the file soldier04.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the helmet in the left viewport.

3. From the Create menu, choose Shapes > Line.

4. Before you start creating the helmet shape,
set the Line Creation mode to Corner in both
Initial Type and Drag Type. This will ensure all
line segments are linear.

Note: when you are creating low-polygon
models, you want to stay away from curves that
translate into multiple faces as much as possible.
You can always add more detail later as you
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have learned in previous exercises. It is easier to
add rather than remove detail from a mesh.

5. Create the contour of the helmet. Make sure
you close the spline by clicking on the starting
point.

6. Go to the Modify panel. From the Modify
list, apply an Extrude modifier.

7. Set the Extrusion Amount to about 10 units.

8. Right-click the object in any viewport and
convert it to an Editable Poly.

9. In the selection rollout, choose the Poly
button.

10.In the left view, select the polygon representing
the helmet.

11.In the Edit Polygons rollout, choose the small
Settings box next to Bevel.

12.In the dialog that appears, set the Height to
10 units and the Outline Amount to about -3.
Click the Apply button to apply the changes
without exiting the dialog.

Note: alternatively, you could have clicked the
bevel button and applied the bevel command
with a click and drag as you did in previous
exercises.

13.In the Bevel Polygons dialog, set the height
to 5 and the Outline Amount to -5. Another
extrusion is performed. Click OK to apply the
changes and exit the dialog.

14.Right-click the helmet in any viewport and
choose Properties.

15.In the dialog that appears, turn on See-Through
mode in the Display Properties group. Click
OK to dismiss the dialog. The helmet is
now semi-transparent and you can see the
background reference image.
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16. In the Selection rollout, choose Vertex
selection mode.

17.Using the Move tool, adjust the inner vertices
to follow the round bump around the ear.

18.Switch back to Polygon mode and notice the
“outside” polygon is still selected.

19.Extrude or bevel the selected polygon to create
the bump at the ear level.

20.Switch to vertex selection mode and, in the
front view, select the 3 columns of vertices to
the left of the helmet.

21.Use the Rotate tool to rotate the selected vertices
slowly to follow the reference image.

Creating the opening:

1. Continue working on your file.

2. Adjust the perspective view so that you are
looking at the helmet from a lower angle.

3. Make sure you are in Polygon selection
mode. Select the inner polygon, the one located
on the symmetry plane.

4. Press the keyboard Delete key to remove the
selected polygon.

5. Choose Edge selection mode and select the
following edges.
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6. In the Edit Edges rollout, click Connect to
create a set of edges connecting the previously
selected ones.

7. Go back to polygon selection mode, and then
select the polygons to be deleted.

8. Press the Delete key to remove the selected
polygons.

9. Go to vertex selection mode and adjust the
vertices in the Front and Left views so they
follow the reference image in the background.

10.Exit sub-object mode when done.

11.Right-click the object and go to Properties.
Turn off See-Through to go back to a
fully-shaded view of the object.

12.Turn off Backface Cull to view both sides of the
polygons that make the helmet and then click
OK to exit the dialog.

Apply a Symmetry Modifier:

1. Continue working on your file.

2. Make sure the helmet is selected and that you
are not in sub-object mode.

3. From the Modify panel, apply a Symmetry
modifier from the Modifier list.

4. Set the Mirror Axis to Z. No other adjustments
to the parameters should be needed.
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5. Rename the object: Helmet.

6. Save your file as my_soldier_helmet.max.

Next

Creating the Visor (page 2–229)

Creating the Visor

In this lesson, you create the visor for the helicopter
pilot. This approach will be similar to the one you
used to create the shirt. You will start with a simple
plane object and edit its edges.

1. Continue working on your file from the
previous exercise or load the file soldier05.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the helmet in the front viewport.

3. Create a plane object as a base for the visor. Set
the Length to 10, the width to 5 and make sure
the Length and Width Segments are set to 1.

4. Position the plane slightly to the left of the
symmetry axis of the head.

5. In the left view, move the visor into the proper
place, based on the reference image.

6. Convert the plane to an editable poly using the
quad menu.

7. Go to the Modify panel. In the Selection
rollout, choose Edge selection mode.

8. In the front view, select the vertical edge to the
left of the visor.

9. Hold Shift down and move the selected edge to
the left to create an extrusion.
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10.In the left view, move the selected edge slightly
to the left to follow the contours of the face.

11.Repeat the last three steps to bring the visor
into the helmet.

12. In the Selection rollout, choose Vertex
selection mode.

13.Adjust the vertices to give the visor a nicer
shape.

14.Exit sub-object mode when done.

Mirror the visor:

1. Continue working on your file.

2. Make sure the visor is selected and that you are
not in sub-object mode.

3. From the Modifier list, apply a Symmetry
modifier.

4. Leave the Mirror Axis at X and turn on the Flip
option.

5. Expand the symmetry modifier and choose
Mirror.

6. In the front view, move the Mirror line to the
right until you get a perfectly symmetrical left
side visor.

7. Exit sub-object mode when done.

8. Rename the object Visor.

9. Save your file as my_pilot_visor.max.

Next

Creating the Oxygen Mask (page 2–230)

Creating the Oxygen Mask

In this lesson, you create the Oxygen Mask for the
helicopter pilot. This approach is the same as for
the visor and the shirt, that is, you use a simple
plane object and edit its edges and vertices to build
the model.
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1. Continue working on your file from the
previous exercise or load the file soldier06.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the head in the front viewport.

3. Create a plane object as a base for the oxygen
mask. Set the Length to 10, the width to 5 and
make sure the Length and Width Segments are
set to 1.

4. Position the plane slightly to the left of the
symmetry axis of the head, with its top
intersecting the visor.

5. In the left view, move the mask so that it is
slightly inside the visor.

6. Convert the plane to an editable poly using the
quad menu.

7. Go to the Modify panel. In the Selection
rollout, choose Edge selection mode.

8. In the front view, select the horizontal edge at
the bottom of the plane.

9. In the left view, use Move and Shift + Move to
extrude the selected edge around the perimeter
of the mask. Use the background image as a
reference.

10.In the front view, select one of the vertical edges
to the left of the selected object.

11.In the Selection rollout, click Loop to select all
the vertical edges connected to the original.

12.Still in the front view, hold shift and then
move the selected edges to the left to create an
extrusion.

13.Using a uniform scale, scale the selected edges
down in the left view to about 80% their
original size.
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14.Switch to vertex selection mode. Using the
Move tool, adjust the position of vertices as
shown in the illustration below.

15.Switch back to Edge selection mode. Notice the
previously selected edges are still highlighted.

16.In the front view, create another extrusion
using Shift + Move.

17.In the left view, scale the selected edges to about
35% of their original size and then move them
inside the helmet area.

18.Switch back to vertex mode and fine-tune
the position of vertices to get a better-shaped
oxygen mask.

19.Exit sub-object mode when done.

Mirror the oxygen mask:

1. Continue working on your file.

2. Make sure the mask is selected and that you are
not in sub-object mode.

3. From the Modifier list, apply a Symmetry
modifier.

4. Leave the Mirror Axis at X and turn on the Flip
option.

5. In the front view, move the Mirror line to the
right until you get a perfectly symmetrical left
side mask. Expand the symmetry modifier and
choose Mirror.

6. In the front view, move the Mirror line to the
right until you get a perfectly symmetrical left
side mask.

7. Exit sub-object mode when done.
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8. Rename the object: Oxygen_Mask.

9. Save your file as my_pilot_mask.max.

Next

Creating the Neck (page 2–233)

Creating the Neck

In this lesson, you create the Neck of the helicopter
pilot. Because the neck has to conform to the
collar of the shirt, it’s best to use the collar to create
the base object you need to build the neck. That’s
the approach you will take.

Create the neck:

1. Continue working on your file from the
previous exercise, or load the file soldier07.max
found under \tutorials\low-polygon-modeling.

2. Zoom in on the neck area in all four viewports.

3. Select the Shirt object.

4. Right-click the shirt and convert it to an
Editable Poly using the Quad menu.

5. Go to the Modify panel.

6. In the Selection rollout, choose Border
selection mode.

Note: At this point, a few edges may already be
selected. Click anywhere outside of the shirt to
deselect any sub-objects.

7. Click any edge around the collar line. The
whole perimeter is now selected.

8. Holding down the Shift key, scale the selected
edges down to about 70% their original size.

9. Move the selected edges slightly up and towards
the pilot’s back.

10.In the Edit Geometry rollout, click the Detach
button. A dialog appears.

11.Change the object name to Neck and make sure
both options are turned off. Click OK to exit the
dialog. All selected edges and their connected
polygons get detached into a separate object.

12.Exit sub-object mode and then select the new
Neck object.

13.Change the object’s wire color to differentiate
it from the shirt.
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Adjusting the neck:

1. Continue working on your file.

2. In the Selection rollout, choose Edge selection
mode. Notice that the top edges are still
selected.

3. In the front view, hold shift and move the
selected edges slightly up to create a new
extrusion.

4. Using transform tools such as Move, Rotate,
and Non-Uniform Scale, adjust the selected
edges as seen in the illustration below.

5. Repeat the last two steps to create one last neck
extrusion. Position it inside the helmet and
adjust its proportions.

6. Exit sub-object mode when done.

7. Select the helmet, visor and oxygen mask.

8. In the front view, move the selected objects so
that they are centered to the neck and chest.

9. Save your file as my_pilot_neck.max.

Check the face count:

Your model is now complete. You will check the
scene’s summary info to verify the face count in
your scene. You can also check the face count
on a selected object by pressing the 7 key on
the keyboard. The face count for the selected
object is then displayed in the top left corner of
the viewport, which is a handy tool to activate
as you are modeling your objects. However, the
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Summary Info under the File menu counts the
faces that make out the whole scene.

1. Continue working on your file from the
previous exercise or load the file soldier08.max
found under \tutorials\low-polygon-modeling.

2. From the File menu, choose Summary Info.

3. In the Mesh Totals group, verify the number of
faces that make your scene. For this tutorial, the
face count should not exceed 1000 faces.

Next

Adjusting Smoothing Groups (page 2–235)

Adjusting Smoothing Groups

You have by now created all the components
that make the helicopter pilot. Still, as you look
at the results in the viewports, the objects look
faceted. Some modifiers that fix this issue such as
Meshsmooth and TurboSmooth do so by adding
geometry to the objects, which defeats the purpose
of low-poly modeling. It is best to keep the face
count low by adjusting smoothing groups on the
objects.

In a nutshell, two adjacent polygons that do
not share the same smoothing group become
separated by a visible edge, giving the shading
a faceted look. If the two polygons are sharing
the same smoothing group, the edge becomes
invisible, giving the illusion of a smooth, curved
surface.

Apply a smooth modifier:

1. Continue working on your file from the
previous exercise or load the file soldier08.max
found under \tutorials\low-polygon-modeling.

2. Select the shirt in any viewport.

3. From the Modify panel, apply a Smooth
Modifier.

4. In the Parameters rollout, choose any
smoothing group number. You have just forced
all polygons on this shirt object to share a single
smoothing group, eliminating any visible edges
between them.

5. Select the pants and apply a Smooth modifier
as you did with the shirt.

6. Select a smoothing group different than the one
you used for the shirt. Again, this smoothes the
edges between polygons. In this case though,
it might be slightly overdone, since you might
want a stronger edge between the belt and the
pants.
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7. Turn on Auto Smooth and set the Threshold to
70. Smoothing is now performed based on an
angle threshold that you specified, separating
the belt from the pants.

8. Continue applying Smooth Modifiers to the
rest of the objects. Try out both methods (Auto
Smooth versus manual) where you see fit. A
finished version of the file is provided and
named soldier09.max.

Note: Remember that you need to apply Smooth
to only one boot and one arm, as you instanced
these two objects to create the opposite limbs.

Summary

This tutorial has introduced you to several of the
tools you can use to make a low-polygon model

with an Editable Poly. These tools can be adapted
to the task of modeling any low-polygon character.

Mapping a Character

Mapping a Character

This tutorial explains how to map a character
working with the Unwrap UVW Modifier. This
modifier provides a wealth of tools that go well
and beyond traditional mapping techniques. You
will use the character you built in the Modeling a
Low-Poly Character (page 2–199) tutorial to that
effect.

You will use the Unwrap UVW modifier to map
textures using simple methods like planar or
cylindrical mapping. You will also use it to map
textures using more elaborate methods such as
Pelt mapping to seamlessly map the camouflage
texture around the pants.
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Skill Level: Intermediate

Time to complete: 1-2 hours

Features Covered in this Tutorial:

• Applying materials to objects

• Applying the UVW Modifier

• Using simple mapping techniques such as
Planar or Cylindrical

• Working with Material IDs to separate mapping
types

Tutorial Files

All the necessary files for this tutorial can
be found on the Tutorial Files CD in the
\tutorials\unwrap_uvw directory. Before starting
the tutorials, copy the \tutorials folder to your local
\3dsmax8 installation.

In This Tutorial

Mapping the Shirt (page 2–237)

Mapping the Helmet (page 2–240)

Mapping the Pants (page 2–243)

Mapping the Shirt

In this lesson, you use the UVW modifier to map a
T-shirt onto a helicopter pilot. The materials have
already been provided, you need only apply them
to the objects and then use the proper mapping
techniques.

Apply the material to the shirt:

1. Load the file pilot01.max found under
\tutorials\unwrap_uvw.

2. Zoom in on the pilot’s shirt in the perspective
viewport.

3. Press M to access the Material Editor.

4. Find the material named Pilot_Shirt_Boots_
&_Belt (it should already be selected). Drag
this material and drop it on the shirt in the
Perspective view. The shirt turns black.

5. Close the Material Editor.

1. Select the shirt and then go to the Modify
panel.

2. From the Modifier list, choose Unwrap UVW.

3. Expand the Unwrap UVW modifier and then
choose Face sub-object mode.

4. Press Alt+W to switch to a four-view
configuration.

5. Adjust the zoom factor in the Front view so that
you see the T-shirt in its entirety.

6. Using Region Select, make a window around
the shirt. Only those polygons facing the Front
viewport are selected. Notice in the Selection
Parameters rollout that face selection is set to
Ignore Backfacing by default.
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7. In the Map Parameters rollout, click the Planar
button. In this case the planar gizmo was
created using the correct orientation and the
correct size.

8. Click the Planar button again to turn it off.

9. In the Parameters rollout, click Edit. The Edit
UVWs dialog appears, displaying the selected
polygons against a checkered background.

10.In the top right corner of the dialog, from
the drop-down menu, choose the map that
displays the texture of the T-shirt. This turns
the checkered background into a tiled version
of the map that is part of the material applied
to the object.

11.In the bottom right corner of the dialog, click
the Options button.

12.In the Bitmap Options group that appears,
set the Brightness to 1.0. This will make the
background image easier to read.

13. On the dialog’s main toolbar, make sure
the Freeform Mode tool is selected.

14.Place the cursor on the bottom right corner
of the gizmo surrounding the red area
representing the selected polygons. You are
now in Scale mode. Click and drag to scale the
selection until it is about the size of the t-shirt
in the background.
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15.Zoom in on that area in the dialog. You can use
the mouse wheel to zoom and pan much like
you would do in a viewport.

16.Place the cursor anywhere inside the area of
the selected polygons. You are now in Move
mode. Reposition the selected polygons over
the T-shirt with the label “Army” on it.

17.In the Selection Modes group at the bottom of
the dialog, choose Vertex sub-object mode.

18.Using a region select, select all the vertices that
make the top half of the torso including the
arms.

19.Using Scale (corner boxes) and Move (cursor
inside the selection area), adjust the vertices so
they are all contained inside the t-shirt image.

20.Select the bottom vertices representing the
lower section of the shirt. Adjust scale and
position to equalize the flow of vertices on the
3d-object structure.

21.Continue selecting and adjusting groups of
vertices to fit the wireframe structure to the
image in the background. Always try to keep
the flow of the vertices even to prevent any
stretching in the texture, especially when the
texture has patterns or labels on it.
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Map the back of the shirt:

1. Right-click the label in the top left corner of the
Front viewport. From the menu that appears,
choose Views > Back.

2. In the Modifier stack, switch the Unwrap UVW
sub-selection mode to Face.

3. Do a region selection in the back viewport to
select all the polygons that make the back of the
T-shirt.

4. In the Map Parameters rollout, click the Planar
button once to reset the mapping coordinates
of the selected faces.

5. Click the Planar button one more time to turn
it off.

6. Using Scale and Move modes as you did earlier,
position the back faces on top of the back of the
T-shirt in the background picture.

7. In the Selection Modes group at the bottom of
the dialog, choose Vertex sub-object mode.

8. Adjust groups of vertices as you did earlier
to fit the wireframe structure on top of the
background image.

9. Exit the Edit UVWs dialog when done.

10.Turn the Back view into a Front view again.

11.In the Modifier stack, exit sub-object mode.

12.Save your file as my_pilot_shirt.max.

Next

Mapping the Helmet (page 2–240)

Mapping the Helmet

In this lesson, you use the Unwrap UVW modifier
to map the helmet of the helicopter pilot. Unlike
the shirt, the helmet cannot be easily mapped with
a Planar projection. You will use a cylindrical
projection instead.
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Apply the material to the helmet:

1. Continue working on your file from the
previous exercise or load the file pilot02.max
found under \tutorials\unwrap_uvw.

2. Zoom in on the pilot’s helmet in the perspective
viewport.

3. Press M to access the Material Editor.

4. Find the material named Pilot_Head. Drag
this material and drop it on the helmet in the
Perspective view.

5. Close the Material Editor.

Map the helmet:

1. Select the Helmet, and then go to the
Modify panel.

2. From the Modifier list, choose Unwrap UVW.

3. Expand the Unwrap UVW modifier, and then
choose Face sub-object mode.

4. In the Selection Parameters rollout, turn off
Ignore Backfacing.

5. Use a region selection to select all the faces that
make the helmet. The whole helmet turns red.

6. In the Map Parameters rollout, click the
Cylindrical button. A cylindrical mapping
gizmo appears but its size and orientation are
incorrect.

7. In the Map Parameters rollout, click on Align Y
to adjust the gizmo to the helmet.

Note: Look closely and notice the vertical green
edge at the front of the cylindrical gizmo. This
represents the edge that will be used to unfold
the map. You will need to rotate that edge to the
back of the helmet to better fit the map assigned
to the material.

8. From the main toolbar, choose the Rotate tool
and set the Coordinate System to Local.
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9. Press the A key to turn on Angle Snap.

10.In the perspective view, rotate the gizmo 180
degrees on the Z-Axis (blue axis) until the
green edge is at the back of the head.

11.In the Parameters rollout, click Edit to access
the Edit UVWs dialog. The selected faces are
unfolded against a checkered pattern, but it
may not be 100% symmetrical.

12.Rotate the cylindrical gizmo an additional 5
degrees on the Z-Axis. Notice how this fixes

the selected faces into a perfectly symmetrical
layout.

13.In the Map Parameters, click the Cylindrical
button to exit that mode.

14.From the map dropdown menu, choose the
helmet map defined in the material.

15.Make sure the Options button in the bottom
right corner of the dialog is active.

16.In the Bitmap Options group, set the Brightness
to 1.0. This will make the background image
easier to read.

17. On the dialog’s main toolbar, make sure
the Freeform Mode tool is selected.
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18.Position the cursor on one of the corner boxes
to scale the selected faces, or anywhere inside
the selection to move the selected faces.

19.Make a preliminary adjustment for the selected
faces to fit the background image.

20.In the Selection Modes group at the bottom of
the dialog, choose Vertex sub-object mode.

21.Adjust groups of vertices like you did in the
last exercise.

22.Exit the Edit UVWs dialog when done. In the
Modifier stack, exit sub-object mode.

Things to try:

If you have time, try to adapt this tutorial to the visor and the
oxygen mask. Both present the same workflow (cylindrical
mapping) as the helmet and they should be assigned the
same material.

When you are done, save your file as
my_pilot_helmet.max.

Next

Mapping the Pants (page 2–243)

Mapping the Pants

In this lesson, you use the Unwrap UVW modifier
to map the pants of the helicopter pilot using a
camouflage pattern. The pants would be difficult
to map using conventional mapping methods,
especially when you use a pattern like camouflage,
without getting smearing and stretching of pixels.
Using multiple planar and cylindrical maps might
work to keep the pattern equal but may give you
problems with stitching. It is best to use Pelt
Mapping in such a situation.

An added constraint is the belt, which is part of the
pants object. Since the belt will be using a different
material than the rest of the pants, you need to
apply a Multi/Sub-Object Material and map the
two elements differently, using pelt mapping for
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the pants and a simpler cylindrical mapping for
the belt.

Adjust material IDs:

1. Continue working on your file from the
previous exercise or load the file pilot03.max
found under \tutorials\unwrap_uvw.

2. Zoom in on the pilot’s pants in all viewports.

3. Select the Pants and go to the Modify
panel.

4. Expand the Edit Poly modifier in the stack and
choose Polygon Selection mode.

5. Using a Region Select in the Front view, select
all the faces that make out the pants object
(pants + belt).

6. Scroll down to the Polygon Properties rollout
at the bottom of the Modify panel. Set the
ID value to 1. The Set ID value sets all the
faces to be applied with the first material in a
multi/sub-object material definition.

7. Using a window selection, select all the
faces that make the belt.

8. In the Polygon Properties rollout, set the
material ID value to 2. The selected faces
representing the belt will be applied with the

second material in a multi/sub-object material
definition.

9. Click an empty area of the viewport to deselect
all polygons.

10.Exit Sub-object selection mode, and then go
to the top of the stack.

Apply the material to the pants:

1. In the perspective viewport, zoom in on the
pilot’s pants.

2. Press M to access the Material Editor.

3. Find the material named Pilot_Pants and select
it. This is a Multi/Sub-Object material with two
defined sub-materials.

4. Drag this material and drop it on the pants in
the Perspective view.

5. Close the Material Editor.

Create pelt seams:

When you use Pelt mapping, it is best to start by
defining pelt seams. Pelt seams are like virtual
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“cut” lines that the UVW Map modifier uses to
unfold the Pelt map.

1. Select the Pants and then go to the Modify
panel.

2. From the Modifier list, choose Unwrap UVW.

3. Maximize the Perspective view and press F4 to
turn Edged Faces mode on if it is not on already.

4. Press F3 to display the view in wireframe.

5. Expand the Unwrap UVW modifier and choose
Edge Selection mode.

6. In the Parameters rollout, set the Display option
to No Seams. The existing (green) seams will
make the Pelt (blue) seams difficult to see.

7. Select the vertical edge at the back center of the
belt.

8. In the Selection Parameters rollout, click on
Loop. The edges are now selected in a loop
from the back to the front passing between the
legs.

Note: At this point, you can convert this edge
selection to a Pelt Seam, but you really only
need the selected edges at the back of the pants.
You can deselect the edges you do not want or
use a different approach called Point to Point
Seam.

9. Click a blank area of the viewport to deselect
the edges. At the very bottom of the command
panel, click the Point to Point Seam button.
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10.Click a point on the belt where you want the
Pelt Seam to start.

11.Arc Rotate to view the pants from a lower angle
and click a point in the middle between the
pants legs.

12.Right-click to accept the seam. You now have a
pelt seam running along the buttocks.

13.Repeat the Point to Point procedure to create a
pelt seam running along the inside of a leg.

14.Repeat the procedure to create a pelt seam for
the inside of the other leg.

15.Press F3 to turn the view back in shaded mode.

16.In the Modifier stack, set the sub-selection
mode to Face.

17.In the Selection Parameters rollout, turn off
Ignore Backfacing.
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18.Using Region Selection, select all the faces
that make up the pants. They turn red in the
viewport.

19.In the Map Parameters rollout, click the Pelt
button. A gizmo not unlike the Planar mapping
type appears in the viewport.

20.Click the Align Y button to align the gizmo in
a Front direction.

21.At the very bottom of the panel, click the
Edit Pelt Map button. The Edit UVWs
dialog appears along with a floating Pelt Map
Parameters window.

Note: The display of the geometry in the Edit
UVWs dialog is slightly different from what
you have seen so far. A circular Stretcher is
displayed and is going to be used to simulate
Pelt mapping by stretching the geometry.
You need to adjust it slightly so that it works
properly.

22.In the Maps drop-down, choose the map that
was defined in the multi/sub material for the
pants. The camouflage texture appears in the
background.

Note: Because the material applied to the pants
is a multi/sub-object material, all maps used
in the material definition are automatically
displayed in the map drop-down menu, in this
case the camouflage and the belt map.

23. On the Edit UVWs main toolbar, choose
the Scale tool.

24.Position the cursor on one of the Stretcher
control points. Scale the stretcher up
slightly until it reaches the boundaries of the
camouflage map.

25. On the Edit UVWs toolbar, choose the
Rotate tool.

26.Make sure Angle snap is off. Position the cursor
on one of the stretcher’s control point, and
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rotate the stretcher to get a more symmetrical
layout.

27.In the Pelt Map Parameters floating dialog,
click the Simulate Pelt Pulling button. The faces
are stretched out based on the pelt seams you
created.

28.Click the Simulate Pelt Pulling button two more
times for more stretching. The end results are
getting better in the viewport, but the mapping
can be made better with a bit of “relaxing”.

29.On the Pelt Map Parameters floating dialog,
click three times on the Relax (Light) button.
Keep an eye on the viewport to compare the
results.
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Map the belt:

Unlike the pants, the belt is a simple cylindrical
mapping, much like the one you used on the
helmet in the previous exercise.

1. In the Modifier stack, switch the Unwrap UVW
selection mode to Face.

2. In the Map Parameters rollout, click the Pelt
button to exit this mode.

3. Click a blank area of the viewport to deselect
the faces.

4. In the Edit UVWs dialog, expand the face ID
dropdown menu.

5. Select 2:Pilot_Belt (Standard) from that list.
Only the faces that make out the belt are
selected.

Note: Notice how the background automatically
switched to reflect the map associated with the
faces associated with that Material ID.

6. Using a Region selection inside the Edit UVWs
window, select all the faces representing the
belt. The corresponding faces are selected in
the viewport.

7. Press F3 to turn wireframe mode on.

8. In the Map Parameters rollout, click Cylindrical,
and then click Align Z to align the cylindrical
gizmo to the belt.

9. Make sure Angle Snap is turned on and rotate
the gizmo 90 degrees on the Z-Axis (blue axis)
so that the green seam is at the back.

10.In the Map Parameters rollout, click the Fit
button to fit the gizmo to the belt.

11.Click the Cylindrical button to turn it off.

12.At the bottom right corner of the Edit UVWs
dialog, click the Options button.

13.In the extended group that appears, set the
Brightness value to 1 to get a better view at the
background.
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14. On the Edit UVWs toolbar, choose the
Freeform mode tool.

15.Make a preliminary adjustment using scale
(cursor on the corner control points) and Move
(cursor inside the selection) to position the
selected faces over the belt in the background
image.

16.Press F3 to turn the viewport into shaded mode
again.

17.In the Edit UVWs dialog, switch the selection
mode to Vertex.

18.Select all the bottom vertices on the belt line.

19. On the Edit UVWs window’s main toolbar,
choose the Scale Vertical tool from the Scale
flyout.

20.Place your cursor on one of the selected vertices
and then click and drag down to straighten the
belt line.

21.Select the upper belt line and straighten it as
well.

22.Select the vertices around the buckle.

23. Using Scale Horizontal and Move, adjust
the vertices to get a better looking buckle in the
viewport.

‘

24.Close the Edit UVWs dialog when done.

25.In the Modifier stack, exit sub-selection mode.

26.Save your file as my_pilot_pants.max.
Things to try:

You have used the Unwrap UVW modifier to apply various
types of maps such as Planar, Cylindrical and Pelt. If you
have time, continue mapping the rest of the objects that
make the character such as boots, arms and neck. All
materials have been already provided. Remember that you
only need to map one boot and one arm as you created
the opposite limb as an instance.A finished version named
pilot05.max can be found under \tutorials\unwrap_uvw.

Summary

This tutorial has introduced you to several
mapping methods using the Unwrap UVW
modifier. You have used simple mapping
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techniques such as planar and cylindrical, as well
as more elaborate techniques such as pelt mapping
to seamlessly wrap textures around objects. These
tools can be adapted to the task of mapping any
object in 3ds Max.

Normal Bump Mapping

Normal Bump Mapping refers to a new technique
for simulating high-resolution surface detail on
low-resolution polygonal models. Normal Bump
Mapping is similar in some respects to regular
bump mapping, but it conveys more complex
surface detail than is possible in regular bump
mapping. Normal bump maps store information
on the direction normal of the surface in addition
to the simple depth information used in regular
bump mapping.

The practical benefits of normal bump mapping
were first seen in real-time gaming platforms, but
the ability to create more realistic detail with fewer
polygons is common in all areas of digital content
creation. 3D artists of all stripes should take the
time to explore this powerful new tool in 3ds Max.

To get the best results with normal bump mapping,
you should be familiar with techniques for
managing texture coordinates in your models. If
you haven’t already done so, you might want to
review the topic Unwrap UVW Modifier in the 3ds
Max User Reference.

Skill Level: Intermediate/Advanced

Time to complete: 1 hour

Features Covered in This Tutorial

After completing this tutorial, you should be able
to:

1. Use Render To Texture to create a normal bump
map.

2. Use the new Projection modifier to “steal”
detail from a high-resolution mesh.

3. Use the new Normal Bump map type to render
the effects of a normal bump map.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\normal_bump folder. Before starting
any tutorials, copy the \tutorials folder from the
CD to your \3dsmax local installation.

Creating Normal Bump Maps

To create a normal bump map, you typically start
with two objects: a polygonally detailed object
whose high-resolution geometry will serve as the
source for the normal bump map information,
and a low-resolution target object that will receive

3dsmax.chm::/unwrap_uvw_modifier.html
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the normal bump map and use it to appear more
finely detailed than it really is. This tutorial uses
two versions of a chess pawn to demonstrate the
typical workflow.

Set up and examine the scene:

1. Files for this lesson are in the tutorials/
normal_bump folder. In 3ds Max, open
pawn_normalbump_01.max.

The only visible object is an editable mesh
model of a chess pawn with several gouges and
rough edges reflecting in its surface geometry.
This model will serve as the information source
for the normal bump map you will create.

2. Select the pawn in any viewport, and then
right-click it to display the quad menu. In the
Display quadrant, choose Hide Selection to
hide the pawn.

3. Right-click the active viewport again, and
select Unhide By Name from the quad menu
to display the Unhide Objects dialog. In the
list, click Pawn-LowRes to highlight it, and
then click Unhide to display the object in the
viewports.

This is the low-resolution target object to which
you will apply normal bump maps. Its surface
is smooth, and it has a checkered texture map
applied to it. The checker map was used as a
visual guide in setting up the texture mapping
of the surface. Let’s take a look at how that was
done.

4. Select Pawn-LowRes. From the Main menu
choose Modifiers > UV Coordinates > Unwrap
UVW.

5. On the Modifier panel > Parameters
rollout, click the Edit button.

The Edit UVWs dialog is displayed.
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The dialog shows how the object has been
unwrapped, and how the texture coordinates
have been mapped to the faces of the pawn.
This layout was made to facilitate painting,
which can be necessary for “touching up”
texture mapping.

You won’t be modifying the texture coordinates
in this lesson, so close the Edit UVWs dialog.
Delete the Unwrap UVW modifier from the
stack, and then continue.

6. Press M to display the Material Editor. The
top left material is named PAWN, and is
the material that has been assigned to our
low-resolution pawn. On the Maps rollout,
turn off the Diffuse Color map’s toggle to make
the map inactive.

The pawn loses its checkerboard texture in the
Camera01 viewport.

Now that you are familiar with the setup of the
scene, you can begin the process of creating a
new normal bump map.

7. Close the Material Editor before continuing.
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Set up Render To Texture (RTT ):

To generate normal bump maps, you will use the
Render To Texture tool.

1. Continue with the scene you have been using,
or open pawn_normalbump_02.max.

2. Right-click the active viewport, and choose
Unhide All from the quad menu to unhide
the high-resolution pawn, Pawn_SCAR. To
better see the edges of the two pawn objects,
right-click the Camera01 viewport label and
turn on Edged Faces.

The two pawns are the same size, and are
precisely aligned.

3. For the next several steps you will work in the
Front viewport. Maximize it, and press the
H key to display the Select Objects dialog.
Double-click Pawn_LowRES to select it and
dismiss the Select Objects dialog.

4. From the Main menu, choose Rendering >
Render To Texture to display the Render To
Texture dialog.

Tip: The default keyboard shortcut for the
Render To Texture dialog is 0.

There is a single entry under the Objects To
Bake rollout for the selected Pawn_LowRES
object.

5. In the Projection Mapping group, turn on
Enabled, and then turn off Sub-Object Levels.

6. Click the Pick button to display the
Add Targets dialog. Click Pawn_SCAR to
highlight it, and then click the Add button to
dismiss the dialog.
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The drop-down list in the Projection Mapping
group has changed from (No Projection
Modifier) to Projection.

A new Projection modifier has been placed
on the modifier stack for Pawn_LowRES, and
a rough wireframe cage appears around the
high-res pawn object in the viewport.

7. Click the Options button to display
the Projection Options dialog.

8. On the Projection Options dialog, make sure
Ray Miss Check is selected in the Resolve Hit
group, and that the Normal Map Space is set
to World.

Notice that the Ray Miss Color is set by default
to bright red. This color will be used later as
a visual cue for a common problem that you
are likely to encounter when creating normal
bump maps.

Tip: For an in-depth explanation of the controls
in the Projections Options dialog, see the
Render to Texture: Projection Options dialog
topic in the 3ds Max 8 User Reference.

9. Close the Projection Options dialog.

10.In the Render To Texture dialog > Objects To
Bake rollout > Mapping Coordinates group,
choose Use Existing Channel.

This is where you specify that you want to use
the pre-assigned texture mapping coordinates
you viewed earlier in this lesson, rather than

3dsmax.chm::/render_to_texture_projection_options_dialog.html
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letting 3ds Max create new texture mapping
coordinates on the fly.

11. On the Render To Texture dialog >
Output rollout, click the Add button.

The Add Texture Elements dialog appears.

12.On the Add Texture Elements dialog, click to
highlight NormalsMap, and then click Add
Elements.

A new NormalsMap entry appears on the
Output rollout of the Render To Texture dialog.

13.On the Output rollout, click to highlight the
NormalsMap entry, and then change these
settings:

• Click the 1024 button in the Selected
Element Common Settings group to set the
output size to 1024 x 1024 pixels.

• For the Target Map Slot, choose Bump from
the drop-down list.

• In the Selected Element Unique Settings
group, turn on Output Into Normal Bump.

14.On the Baked Material rollout, choose Output
Into Source.

At this point, you have defined all the basic
elements and settings for creating a normal
bump map.

15.At the bottom of the Render To Texture dialog,
click Render to render your normal bump map.
If you see a File Exists warning dialog, click
Overwrite Files.
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The rendered map shows an unwrapped diffuse
rendering of the high-resolution pawn, with a
suggestion of gouging on the surfaces.

Red splotches appear in the rendering.
These indicate regions where the bump map
projection rays have missed geometry. The
problem here is that the cage created by the
Projection modifier doesn’t completely enclose
the high-resolution pawn in these spots.
This would create problems if you applied
the normal bump map to the low-resolution
target. In the next lesson, you will adjust the
Projection modifier’s cage to eliminate these
errors, and apply the final normal bump map
to the low-resolution pawn.

Applying Normal Bump Maps to
Objects

In this lesson, you will refine how the normal
bump map information is derived from the
high-resolution source object, create a new normal
bump map, and then apply the new map to the
low-resolution object to see the effect of normal
bump mapping.

Adjust the projection modifier:

The Projection is designed to be part of your
workflow when you use normal bump mapping.
The Projection modifier is the go-between between
the source and target objects; it determines how
projected normals from the high-resolution object
should be mapped onto the low-resolution version.

In the previous lesson, the Projection modifier was
applied to the low-resolution object automatically,
while using the Render To Texture dialog. Since
the high-resolution object and the low-resolution
object have different geometries, 3ds Max had
to “guess” what you wanted when applying the
modfiier for the first time. You rendered a texture
using this guess, with the result that there were
detectable errors in the normal bump map, as
shown by red patches in the rendered map. In this
procedure, you will tune the Projection modifier
to eliminate those errors and get the precise
projection you are looking for.

1. Continue with your scene from the previous
lesson, or open PAWN_NormalBump_03.max.
Select the Pawn-LowRES object if it is not
already selected.

2. Click the Modifier tab, and toggle the
viewports so that you can see the objects in four
views while examining the Projection modifier
on the modifier stack.
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The additional cage around the pawns comes
from the Projection modifier that was applied
automatically by the Render To Texture dialog.
The cage needs to be corrected in some areas
to more faithfully reproduce the high-res
geometry.

3. On the Modifier panel, click to highlight
the Projection modifier in the stack. In the
Cage rollout > Display group, turn on Shaded.

When the cage is shaded, it is easier to see.

4. Click the Reset button at the bottom of the
Cage rollout.

The cage resets itself to fit tightly around the
target low-resolution pawn.

The shape of the cage is correct, but it is
important that the cage fully encompass the
source high-resolution object. Where source
geometry lies outside the cage, the result will be
ray intersection misses, which will cause flaws
in the normal bump map.

Note: In the previous lesson, in the Projection
Options dialog, you left Ray Miss Check turned
on, and left the Ray Miss Color set to pure
red. This means that whenever there are ray
intersection misses, they will be shown in the
normal bump map as pure red.

5. In the Cage rollout > Push group, set the
Amount to 6.5.
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The cage balloons outward slightly, so that most
of Pawn_SCAR fits within it.

Most of your mapping problems are now
settled, but if you Arc Rotate the Front view,
you will still detect areas in the top, middle rim,
and base, where the source object protrudes
through the projection cage.

You can correct these areas by hand. Press F to
reset the viewport to Front.

6. On the Selection rollout, turn on the
Vertex sub-object level.

7. In the Front viewport, select the top 3 rows of
vertices.

8. Move the vertices upward just a bit, until the
cage clears the geometry of Pawn_SCAR.

9. In the Front viewport, select the vertices in the
middle flange.

10.In the Camera01 viewport, uniformly scale
these vertices slightly outward. An additional
scale of 2 percent should suffice. Watch the
coordinate display at the bottom of the 3ds Max
window to check your progress.
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11.Finally, select the vertices in the base of the cage.
In the Camera01 viewport, uniformly scale
these vertices slightly outward, until the base of
the cage clears the geometry of Pawn_SCAR.

12. Your refinements to the cage are complete.
Click the Vertex button on the Selection rollout
to exit the Vertex sub-object level.

You are now ready to render the normal bump
map and apply it to the low-resolution object.

Use NormalBump to apply the normal bump map:

1. Continue with your scene from the previous
lesson, or open PAWN_NormalBump_04.max.
Select Pawn_LowRES if it is not already
selected.

2. From the Main menu, choose Rendering >
Render To Texture to display the Render To
Texture dialog. On the Render To Texture
dialog > Baked Material rollout, make sure that
Output Into Source is chosen.

3. Click the Render button at the bottom of the
dialog to render the normal bump map. If a File
Exists warning is displayed, click Overwrite
Files to continue.

The rendered normals map appears. It looks
like a diffuse pass that shows lighting and
shadows on the surfaces of Pawn_SCAR,
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flattened out on to match the mapping
coordinates for Pawn_LowRES. Even though
you can’t see it, the bump normal data has
also been generated and has been “baked”
into the PAWN material that is assigned to
Pawn_LowRES.

Note: If you see any red on the rendered image,
that indicates that you have ray misses from
the rendering pass, which means that the
Pawn_SCAR object is protruding through the
Projection modifier cage at these locations.
Using the red areas as a guide, locate these
regions in the cage as you did in the previous
sequence of steps, and adjust the geometry of
the cage just enough to make the red regions
disappear when you render a new normals map.

4. Close the rendered frame window, and close the
Render To Texture dialog. Hide Pawn_SCAR so
that only the low-resolution target pawn is left
visible. Press M to display the Material Editor.
Look at the PAWN material’s Maps rollout.

There is a new Normal Bump map assigned to
the Bump component.

5. Click the Bump map button to examine this
new map.

Under the Parameters rollout for the Normal
Bump map, you can see that the TGA file you
just rendered with the Render To Texture dialog
has been assigned as the Normal map. Also,
notice that the method has been set to World:
this corresponds to the choice of coordinates
you made on the Projection Options dialog.

Tip: The Additional Bump component is for
adding ordinary bump maps to your normal
bump map. When you complete this tutorial,
you might want to experiment with the effects
you can get from adding extra bump detail by
using this slot.

6. Click the Normal button to view the details of
this bitmap. In the Bitmap Parameters rollout
> Cropping/Placement group, click the View
Image button to view the normal map for the
first time.
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A false-color image appears that is similar to
the images you have seen previously from the
Render To Texture process. In the image, you
can clearly see the areas of scarring that have
been derived from the high-resolution source
pawn.

The colors on the image are significant. The
reason normal bump maps convey so much
more detail than regular bump maps is that
normal bitmaps use the entire RGB spectrum
for surface detail information, whereas regular
bump maps only use a single gray scale.
The blue channel conveys vertical depth
information, and the red and green channels
enhance this information by providing a
direction vector for the normal orientation of
the surface at each point. This results in higher
realism.

Close the dialog with the normal map image
before continuing.

7. In the Material Editor, click Show Map
In Viewport to display the map in shaded
viewports, then exit the Material Editor.

8. If it is visible, hide the Pawn_SCAR object. In
the Camera01 viewport, turn off Edged Faces
if it is on.

The normal map appears in shaded viewports,
draped over the target object in a way that
reflects the gouges from the source object.

Observe the normal map effects:

You have now created a normal bump map, based
on the geometry of Pawn_SCAR, and it has been
applied to Pawn_LowRES via the Normal Bump
map type. You’ll render the low-res and high-res
versions, and use the RAM Player to compare the
results.

1. Continue with your scene from the previous
lesson, or open PAWN_NormalBump_05.max.
Select Pawn_LowRES if it is not already
selected.

2. Unhide the hidden lights in the scene by
pressing SHIFT+L.

3. Press H to display the Select Objects dialog,
then double-click Sky01 to select the skylight
object.
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4. On the Modifier panel > Skylight Parameters
rollout, turn on the On option to activate the
skylight.

5. Click Quick Render to render the
Pawn_LowRES object.

6. From the Main menu, choose Rendering >
RAM Player.

7. In the RAM Player, click the Open Last
Rendered button for Channel A to load the
rendered image into Channel A.

8. In the active viewport, hide Pawn_LowRES and
unhide Pawn_SCAR. Click the Quick Render
button again to render the Pawn_SCAR object.

9. In the RAM Player, click the Open Last
Rendered button for Channel B to load the
rendered image into Channel B.

Using the RAM Player dialog to compare renderings of
the low-resolution pawn with normal bump map (left
half ) vs. the high-resolution pawn (right half ).

Portions of the two rendered images appear
side-by-side in the RAM Player. Drag the
split-screen controls (the white triangles above
and below the frame) horizontally across the
length of the image to compare the details of the
two renderings. There are differences, but given

the efficiency of the low-resolution version they
are not significant.

10.One way to improve the low-resolution version
is to remove the polygonal profile of the pawn
as seen against the background. You’ll do that
by applying the new TurboSmooth modifier to
the low-resolution pawn.

11.Hide Pawn_SCARagain, and unhide
Pawn_LowRES. Select Pawn_LowRES and add
a TurboSmooth modifier to it.

12.Click Quick Render again to render the
Pawn_LowRES object. On the RAM Player,
load the last rendered image into Channel A,
then compare the results to the full-resolution
version in Channel B.

There is still a slight difference between the
versions, but the TurboSmooth modifier has
significantly improved the edges of the Channel
A version on the left side of the RAM Player
image.
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In the sample renderings above, the
PAWN_LowRES object on the left is composed
of 3840 faces, a Normal Bump map, and a
TurboSmooth modifier. The Pawn_SCARobject
on the right is composed of 8589 faces, with no
Normal Bump map or modifier.

Summary

In this tutorial you have explored three features of
3ds Max that allow you to get greater realism and
efficiency from fewer polygons in your final scene:

1. The new features in Render To Texture that
allow you to render a normals map.

2. The new Projection modifier, and how the cage
it creates can be adjusted to optimize normal
bump mapping.

3. The new Normal Bump map type, which
enables the use of normal bump maps in
rendered scenes.

Modeling Level Design

In this tutorial, designed for games professionals,
you will rapidly build a level with some boxes
for buildings. You’ll learn about creating and
adjusting materials and mapping to design how
the neighborhood looks, and use XRef objects to
add street lamps and some trees. You’ll use vertex
lighting and vertex paint to prepare your model
for export.

Skill Level: Beginner

Time to complete: 45 minutes

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\level_design folder, unless otherwise
specified. Before doing the tutorials, copy the
\tutorials directory from the CD to your \3dsmax8
local installation.
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Creating a Building

In this lesson you’ll create a building from a Box
object with Taper and Bend modifiers applied.
This is probably the simplest modeling you can
possibly do; it’s the materials that do most of the
work in creating the art. To build this level, start
by building a box.

Create the box object:

1. In the Create Panel, on the Object Type
rollout, click Box.

2. In the Perspective Viewport, drag out a box.
First you define the width.

3. When you release the mouse button, continue
to drag to create the height interactively.

4. Click again to set the height of the box.

5. You can now adjust the box parameters from
the Create panel. Change the box parameters by
entering these values in the Parameters rollout:

Length=17

Width=19

Height=42

As long as the box remains a parametric object,
you can always access and change these values
by selecting the object and opening the Modify
panel.

The box is going to be deformed, so you’ll want
some extra segmentation in the object.

6. Click in the Length Segments field, and change
the Length Segments to 2.

7. Press the TAB key to move to the Width
Segments field, and change the width segments
to 2.

8. Press the TAB key to move to the Height
Segments field. Change the Height segments
to 4.

9. Right-click the Perspective viewport label and
turn on Edged Faces. Now you can see the
segments in shaded mode.
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Add modifiers:

1. Go to the Modify panel > Modifiers List, choose
Object-Space Modifiers > Taper from the list.

Tip: You can quickly find a modifier by typing
the first letter. In this case, entering T on the
keyboard will highlight Taper from the list.

Taper the box by changing the parameters in
the rollout.

2. On the Parameters rollout, in the Tapers group,
change Amount to 0.6.

Tip: You can click the spinner arrows, press the
spinner arrows or type in the values to change
the amount of the taper.

3. Change Curve to -0.61.

Next you’ll add a Bend modifier.

4. On the Modifiers List, choose Object-Space
Modifiers > Bend.

5. On the Parameters rollout, in the Bend group,
change Angle to 10.5.

6. Change Direction to 55.

You can adjust the height of the box after
applying the Taper and Bend modifiers.

7. In the modifier stack display, click Box.

It turns gray to show it is selected.
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8. In the Modify panel, make sure Show End
Result On/Off Toggle is on.

9. Change the height of the box using the spinner
arrows. Don’t make the box so high you can’t
see the top in the viewport.

10. Save your scene as mybuilding.max.

You’ve just made the form for a building with
cartoon attitude. Next you’ll add materials to
turn this pinched column into a cartoon garage.

Adding Mapping and Materials for
the Building

You are going to use three different mapping
and material channels to create the look of this
building. First, you will map the bricks and
windows to the walls. Then you’ll hang a sign on
the front of the garage and add a black tar roof.

Drag materials to box:

You’ll drag materials from the Asset Browser to the
box to transform it into a garage.

1. From the menu bar, choose Rendering >
Environment. The Environment dialog
appears. In the Global Lighting group click the
Ambient color swatch. Drag the Whiteness
slider down to a light grey and click Close.
Close the Render Scene dialog.

This will lighten up the scene so you can see the
results of any change to materials and rendering
tests.

2. Select the box in the viewport if it isn’t
still selected, and open the Modify panel.
Open the Modifier List and apply a UVW Map
modifier.

3. In the modifier stack display, drag the UVW
Mapping modifier downward, placing it
between the Taper and the Box.

Tip: You can drag and drop modifiers to
rearrange them in the stack display. Hold down
the SHIFT key to make a copy; hold down
CTRL to make an instance.

4. In the Parameters rollout, change the Mapping
style from Planar to Box.

Now any mapping you apply will appear on
each side of your building.

5. Turn off the Show End Result On/Off Toggle.

6. Press the plus button to expand the UVW
Mapping modifier in the modifier stack and
choose Gizmo.

You’ll see the original box without the Taper or
Bend.

7. From the Parameters rollout, adjust the Length
and Width of the gizmo so it conforms more
closely to the box. If necessary, move the gizmo
to encompass the box.

Important: The gizmo needs to be resized so that it

almost has the same dimensions of the box. If the

gizmo isn’t fitted properly, the mapping will not be

correct.
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Gizmo is resized so that it fits the box like a glove

8. On the Utilities panel, click Asset Browser.

9. Navigate the Asset Browser to the
\tutorials\level_design directory.

Minimize the Asset Browser for now. You’ll
need it later when you apply a map to your box.

10. Open the Modify panel and click Bend
in the modifier stack display to select the top
of the stack.

11.Go to the Modifiers menu, choose Mesh
Editing > Edit Mesh.

The Edit Mesh modifier appears at the top of
the stack.

12. On the Modify panel, in the Selection
rollout, click Polygon.

Tip: If you expand the Edit Mesh in the stack
display, the sub-object levels are displayed and
Polygon sub-object mode is selected.

13.Turn on Ignore Visible Edges.

14.Click the side of the box that will be the front of
the garage. All the polygons turn red.

15.Maximize the Asset Browser. Drag
bfrontgarage.jpg to the selected polygons.

The box will change to a white color once you
assign the map. This is normal.

16.Click the other side of the box that will be the
side of the garage.

Once you select the other side, the previous
bfrontgarage.jpg map appears on the box.

17.In the Asset Browser, drag bsidegarage.jpg to
the selected polygons.

You can now minimize the Asset Browser.

18.In the Selection Rollout, click the Polygon
button to deselect it.

Tip: You can also choose Edit Mesh from the
modifier stack.
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Your building shows the front and side mapping.

Add a garage sign texture:

You’ll now use the Material Editor to create a
multi/sub-object material that consists of the
materials that will transform the box into a
“cartoony” garage.

1. On the toolbar, click the Material Editor
button.

2. In the Material Editor, click the Pick
Material From Object button and then click
anywhere on the box.

The garage materials you applied appear in the
first sample slot.

3. The material is a bit dark. To make it easier
to see, you can increase the multiplier of the
lighting of the sample spheres. Right-click
on the highlighted sample sphere and choose
Options. On the Material Editor Options dialog
change the Top Light and Back Light Multipliers
to 2.0 and then click OK.

Name the material Garage.

Garage material shown on sample sphere

4. Change the sample
sphere to a box by clicking the box on the
Sample Type flyout on the toolbar on the right
side of the Material Editor.

The sample is now a box. If you don’t see
the two different sides of the mapped box,
right-click in the sample sphere and choose
Rotate, then rotate the box within the Material
Editor sample.

Magnified view of the Garage material
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Tip: Double-click the sample to magnify the
sample slot. This will give you a better view of
changes you make to the material.

Next you will replace one of the standard
materials with a blend material within the
multi-sub/object material.

5. On the Modify panel, click the Polygon button
and select the side of the box that is the front of
the garage. In the Surface Properties rollout, in
the Material group, make a mental note of the
ID number.

6. Click Polygon again to deselect it.

7. In the Material Editor, in the Multi/Sub-Object
Basic Parameters rollout, locate the material ID
for bfrontgarage, then click its material button.

The Material name changes to the name of the
material with the selected ID.

8. Click the Standard button to display the
Material/Map Browser.

9. Select Blend, then click OK. In the Replace
Material dialog that displays, click OK to keep
the old material as a sub-material.

This creates a blend material that will consist of
the bfrontgarage bitmap and the garage sign
bitmap you’ll add in the next step.

10.Open the Asset Browser again. Drag
garagesign.jpg to the Material 2 button in the
Blend Basic Parameters rollout in the Material
Editor.

11.Next drag bfrontgaragemask.jpg to the Mask
button labeled None.

The button label changes to reflect the filename.

12.Name the material Garage Front with Sign.

You will now make modifications to the size of
the garage sign bitmap so that it fits within the
opaque area in the mask.

13.Click the Material 2 button.

14.In the Blinn Basic Parameters rollout, click
the button labeled M next to the Diffuse color
swatch.

Tip: If you hold the mouse over the button,
garagesign.jpg should appear.

15.In the Bitmap Parameters rollout, in the
Cropping/Placement group, turn on Apply,
then click Place.

16.Click View Image to display garagesign.jpg in
the Specify Cropping/Placement dialog.
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Here you’ll change the overall dimensions of
the bitmap so that it will fit within the area
specified in the mask.

17.Enter the following values in the U, V, W, H
fields:

U=.11

V=.45

W=.80

H=.15

The garage sign changes size. Close the window
after entering the values.

Garage sign bitmap resized

18. Click the Go to Parent button three times.

19. On the toolbar, click the Quick Render
button or press F9 to render the scene.

You can see the Blend material displayed
in the Material editor and in the rendering.
But you can’t see the Blend material in the
viewport, unless you happen to have the right
combination of drivers and graphics card.

Make a black material for the roof:

1. In the Material Editor, in the Multi/Sub-Object
Basic Parameters rollout, click the Material
button for ID #1.

2. In the Blinn Basic Parameters rollout, click the
Diffuse color swatch.

The color selector appears.

3. Drag the Whiteness slider up to create a black
color, then close the color selector.

4. Name the material Black Roof.

The roof of the garage turns black in the
viewport.
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5. Click the Go to Parent button. Close the
Material Editor.

6. Render the scene to see the final results.

7. Save your work as mygarage.max.

Merging the Building into a
Neighborhood

In this procedure, you’ll merge the building into a
neighborhood.

Merge the building into a neighborhood:

1. On the File menu, choose Open, then navigate
to the \tutorials\level_design directory and
open city.max.

This might take a while, depending on the
speed of your machine.

2. Change three viewports to wireframe shading.
Leave the upper Perspective viewport shaded.

3. On the File menu, choose Merge, then navigate
to the \tutorials\level_design directory, and
choose garage.max.

4. Choose Garage from the list of objects you can
merge. Click OK.

The garage appears in the viewports. It is the
only one with a black roof.

5. Right-click Garage and select Move from the
quad menu.

6. Use the transform gizmo corner to move the
garage Instead of the arrowheads. This will let
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you move freely along the ground plane without
shifting the building up or down.

7. Move the garage into place between the third
and fourth buildings from the left.

8. Change the perspective viewport to wireframe
by right-clicking the viewport label and
choosing Wireframe.

9. Click the Region Zoom button in the
viewport navigation controls so you can see
the building up close. Drag a crossing window
around the building then release the mouse.

10.Change the viewport back to Smooth +
Highlights.
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11.Adjust the scale of the building so it fits better
with its neighbors. Right-click anywhere in
the viewport and choose Scale from the quad
menu. Then use the X axis of the Transform
gizmo to scale the building to fit in.

12.Save your file as mytoonstreet.max.

Adding a Streetlight Using XRefs

You can add a streetlight to the scene using XRef
Objects. First, you will open the streetlight scene
and use XRefs to help correct the scale of the
streetlight before you add it to the street.

Use XRef objects:

• Choose File > Open streetlight.max.

Instead of using measuring tools like the Tape
helper or the Measure utility, you will instead
use the scene itself, through XRefs.

Scale the street lamp:

1. Choose File > XRef Scene.

2. In the XRef Scene dialog, click Add.

3. Navigate to the \tutorials\level_design directory
and select toonstreet.max. A thumbnail
appears in the Open File dialog when you
highlight the name in the list.

The path and name of the XRef scene appears
in the XRef Scenes dialog. After a pause, the
scene also appears in the viewports.

4. Close the Xref Scene dialog.
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5. Click Select and Uniform Scale and then
select the street light. Scale down the street
lamp using the scale gizmo so that it fits in the
scene.

6. Move the scaled lamp so it’s on the street corner.

7. Use Arc Rotate to rotate the viewport for a
look from a different angle. Scale the streetlight
some more, if necessary.

8. Now remove the XRef Scene. Choose File >
XRef Scene to open the XRef Scene dialog.
Select toonstreet.max and then the Remove
button. The lamp post stands alone, in place
and proportionate to the street.

9. Save the lamp as mystreetlight.max.

10.Choose File > Open and choose toonstreet.max
again. After a pause the file opens.

11.In the Perspective viewport, navigate to the
street corner where you had moved the street
light. Zoom in if necessary.

12.On the File menu, choose XRef Objects.

13.In the XRef Objects dialog click Add, then
navigate to the \tutorials\level_design directory,
and chose mystreetlight.max.

14.In the XRef Merge dialog, choose the object
LampPostwSign. Click OK.

15.Click Close in the XRef Objects dialog. The
lamp appears on the street corner, where you
had scaled it.
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16.Select the street light, then right-click
and choose Move from the quad menu.
Move the streetlight to the corner near the
yellow-and-black striped barricade.

Next, you will create a light to associate with the
streetlight geometry.

Add lights:

1. Select the streetlight if it isn’t already selected.

2. In the Display panel, in the Hide rollout,
click Hide Unselected.

3. Use Zoom Extents Selected so the
streetlight is clearly visible in the viewport.

4. On the Create panel, click the Lights
button.

5. In the Object Type rollout, click Omni, and
then turn on AutoGrid.

6. Move your cursor over the streetlight. A
creation tripod is displayed and is projected
from whichever face you touch.

7. Click to create the light on the surface of the
globe.

8. Raise the light up slightly above the globe.

9. On the Modify panel, in the General Parameters
rollout, turn on Shadows.

10.On the Intensity/Color/Attenuation Parameters
rollout, in the Decay group, choose Inverse
Square as the type of Decay.

11.In the Near Attenuation group, turn on Show
and change Start to 20. You can see the Decay
Start Attenuation gizmo in the viewport.

12.On the Display panel, in the Hide rollout, click
Unhide All so that you can judge the decay size
in the scene geometry.

13.Go to the Modify panel, and turn off Show in
the Intensity/Color/Attenuation rollout when
you’ve set the Decay.



Adding a Streetlight Using XRefs 277

Clone the lamps and lights:

1. Change the lower Perspective viewport to
Wireframe shading.

Tip: If you want, you can disable the two
viewports on the left. Right-click to activate
the viewport, then press D to disable. This will
prevent unnecessary redraws.

2. Press H on the keyboard to select objects in
the scene by name. Choose Omni 01 and the
LampPostwSign object.

Tip: Press the CTRL key to select multiple
objects in the dialog.

3. On the Main toolbar, in the Named Selection
Sets field, name the selection lit lamp.

Now you can retrieve the light and the lamp in
one touch.

4. Hold down the SHIFT key, then move
the selection to create a clone of the lit lamp.

5. In the Clone Options dialog, choose Instance,
so you can control all the lights by changing
one.

6. Repeat the last two steps to add streetlights
up and down both sides of the street. If
performance is slow, use wireframe shading
when you drag in the lamps.

Add global lighting:

Next, you will give a little color to the Omni lights
and add directional lighting.

1. Select the light Omni01.

2. On the Modify panel, In the Intensity/Color/
Attenuation rollout, General Parameters
rollout, click the color swatch next to the
Multiplier field.

A color selector appears.

3. Click in the left middle of the color selector
to choose an orange color for the Omni light.
Close the dialog.

4. To add directional lighting to your scene,
right-click in the Top viewport and press ALT
W to maximize it.
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5. In the Create Panel, click the Lights icon.

6. On the Object Type rollout, click Target Direct.

7. In the Top viewport, click and drag from the
lower left of the geometry to the center of the
street.

The target directional light is displayed in the
viewport.

8. Adjust the size of the light coverage by using
the Hotspot/Beam spinner In the Directional
Parameters rollout. Notice that increasing
the hotspot/beam automatically expands
the falloff/field as well. When you decrease
the hotspot/beam, the falloff/field remains
unchanged.

9. Click Min/Max Toggle to display the four
viewports again, then rotate a perspective
viewport so you can see the directional light.

10.Select and move the directional light to raise it
up. The target stays on the street.

11.On the Modify panel, in the Name and Color
group, click the color swatch. Click Add
Custom Colors and select a medium to dark
blue to give the light a blue color for a moonlight
setting.

12.On the toolbar, in the Selection filters, choose
Geometry from the list. This excludes the lights
from the selection operation.
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13. In the Top viewport, drag a selection
rectangle around the entire scene in the
viewport. Do a Zoom Extents All out if
necessary.

All the geometry except for the lights are
selected.

14.You can name this selection Vertex Lighting
in the Named Selection Sets field on the Main
toolbar.

Create vertex lighting:

Here you can take the lighting information and
map it into the color of the vertices.

1. Continue from before, or load
city_vertex_color.max from the
\tutorials\level_design directory.

2. If you do choose to load the supplied scene file,
then choose Vertex Lighting from the named
selection sets on the toolbar.

3. On the Utilities panel, click the More button,
then choose Assign Vertex Colors.

4. If Mapping is on in the Render Options group,
turn it off. This means to use the map’s colors
rather than the scene lighting.

5. Turn on Shadows.

6. Click Assign To Selected.

A series of calculations will result. You will
observe a progress bar flying by furiously at
the bottom of the screen, rendering vertices
for each of the objects in the scene. When this
finishes, left-click in the viewport to deselect
everything in the scene to see the affect of the
lighting without any selection highlights.

The scene is a little dark, so you’ll make some
adjustments to the lights.

7. Right-click in the active viewport, and from the
Display quadrant, choose Unhide All.

8. Click Select by Name, and select Omni20
through Omni28. Make sure Omni01 is not
selected.

9. Right-click in the active viewport, and from the
Display quadrant, choose Hide Selection.

10.Select Omni01.

11.In the Modify panel, change the Multiplier
value to 2.

12.Select the Direct01 light and turn on Shadows.
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13.Choose Vertex Lighting from the named
selection sets on the toolbar, and in the Modify
panel > Assign Vertex Colors rollout, again
click Assign.

Next you’ll use Vertex Paint to change some of
the vertex lighting.

Painting Vertex Color in a Level

You can use Vertex Paint to change some of the
vertex lighting. You’ll notice a triangular dark
patch near the drain. You’ll paint in some more
shadows to fix those hard edges.

Paint vertex color in a level:

1. Continue from the previous lesson, or open\
tutorials\level_design\city_vertex_paint.max.

2. Select the street object and open the Modify
panel.

You’ll see there is a Vertex Color modifier in the
stack. An earlier version of the Assign Vertex
Color utility added this modifier.

Note: Files created with earlier version of
3ds Max will load with a Vertex Color modifier
instead of a VertexPaint modifier. If you add
a VertexPaint modifier to the stack and do a
Collapse All Layers, you can convert the old
info into the new modifier.

3. Click the drop-down arrow on the modifier list,
scroll down and select VertexPaint.

A new VertexPaint Modifier is placed in the
stack. Each layer of paint is accessed through a
different VertexPaint modifier in the stack.

The floating VertexPaint dialog appears. Here
you find the tools for Vertex Painting. You will
select a color to paint with and the faces you
want to paint.

4. Click the eyedropper icon, and then
choose a dark brown color from the area near
the drain. Press the eyedropper down and move
it around over the geometry. The eyedropper
will pick up the color from the map channel.

5. On the VertexPaint dialog, choose Face
selection then click on the face that has the hard
edge brown shadow near the drain.

The single polygon is selected in the viewport.

6. On the Selection group click Soft Selection,
then turn on Use Soft Selection.

In the viewport the adjacent faces to the original
are now selected.

7. On the VertexPaint dialog, lower the Size of the
brush to 3.0
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8. Click the Paint button, and
then paint the light areas around the hard edge
near the drain.

Darker color is blended near the drain to blend into
surrounding sidewalk

Increase the Soft Selection falloff if you want
to paint a wider area.

Painting without soft selection will let you paint
hard edges. Let’s suppose you want to paint in
a yellow brick road. You’ll add another layer
for the yellow tint.

9. On the VertexPaint dialog, in the Layer
group click New Layer.

Another VertexPaint modifier is added to the
stack.

10.Choose Face Selection again, Turn off Use Soft
Selection if needed, then hold down the CTRL
key and then in the viewport click to select
polygons in the street. Add the side streets if
you like.

Tip: You can drag a selection rectangle to select
many faces at once.

11. On the VertexPaint dialog, click the color
swatch and then choose a yellow color from the
color picker.

12.On the VertexPaint dialog, click the Paint All
button.

The selection fills with yellow color.

13.To tone down the effect, move the Opacity
slider in the Layer group. Watch the paint in the
viewport as you change the opacity of the layer.

14.For fun, click the drop-down arrow for the
Mode list in the Layer group, then choose a
different blending mode, such as Color Dodge,
for example. See what each of the different
modes does in the viewport.

15.Save your scene as myellowbrickroad.max.



282 Chapter 6: Game Design

The city needs some beautification, so you’ll
add some trees. In the next procedure, you can
use a sample script that comes with the software
to paint the XRef trees into the scene.

Using the Object Painter Script to
Add Trees

The Object Paint utility is a script that allows you
to select an object and then wherever you move
your cursor, it paints the object. The objects are all
placed on the world space grid, or whatever grid
is active.

• Continue from the previous topic or load File
> Open > city_noforest.max. Adjust your
viewport, if necessary, so you are looking down
the street.

Note: If you encounter an error message
regarding a missing XRef file, browse for
it in the current directory, or look in the
\tutorials\level_design directory.

Create an object painter toolbar:

1. Using Windows Explorer or My Computer,
copy macro_objectpaint.mcr from the
\tutorials\level_design directory into the
3dsmax8\ui\macroscripts directory.

Macro_ObjectPaint is a script that is one of
many samples that ship with the software. They

are available if you choose to install them by
selecting Samples.

All of these scripts can either be run by a
keyboard shortcut, a menu or a quad menu.
They do not appear in the interface until you
customize your UI to display them. When
they are run, all the scripts in the MAXScript
Utilities folder appear in a category called
MAXScript Utilities.

2. On the Utilities panel, click MAXScript > Run
Script.

3. Navigate to the ui\macroscripts directory and
run macro_objectpaint.mcr.

4. From the Customize menu, choose Customize
User Interface.

5. In the Customize User Interface dialog, click
the Toolbars tab.

6. Click New to create a new toolbar, and name
it Object Paint Tools.

The new toolbar appears as a small box in the
viewport.

7. In the Category drop-down list, choose MAX
Script Utilities.

You should now see the Object Painter available
from the Action table.

8. Drag Object Painter from the list to the Object
Paint Tools toolbar.
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Tip: If the Object Painter text does not display
correctly on the toolbar, then go to Customize
> Preferences. In the UI Display group of the
General tab, turn off Fixed Width Text Buttons.
Now the Object Painter button text displays
correctly on the floating toolbar.

9. Close the Customize User Interface dialog.

Use XRef object to add a tree:

1. On the File menu, choose XRef Objects.

2. In the XRef Objects dialog, click Add.

3. Select city_tree1.max. If necessary, navigate to
the \tutorials\level_design directory to locate
the object.

4. In the XRef Merge dialog, click Trunk02, and
close the dialog.

The tree appears in the scene.

5. Right-click in the Top viewport to activate it
without changing the selection. The tree is still
selected. Make sure the Top viewport display
is wireframe.

6. Click Object Painter in the floating dialog.

7. Set the Spacing to 30, and click the Paint button.

8. Move your cursor from the right to the left in
the top viewport, to paint a row of trees along
the street.

9. Save your work as mycitywithtrees.max.

Tip: Object Painter doesn’t work with grouped
objects. If you want to paint a group, open up
the group, then use Attach List to attach the
objects together.

Summary

In this tutorial you have modeled a city block
to be used as a game level. You have explored
modeling with primitives and modifiers, and have
used XRefs to add streetlights. You have used a
Blend material to create a decal on the garage.
And you’ve used the VertexPaint modifier to paint
shadows and tint the road. Finally you’ve used a
script to paint trees into your scene.

Vertex Color and Interactive
Shading
In this tutorial, you will load in a scene of a garage,
a typical games environment. You will take the
lighting information in the form of a radiosity
solution and learn to “bake” the radiosity into
Vertex Paint modifier layers. You’ll also get a
chance to explore painting on multiple layers and
animating the layer opacity to create the illusion of
flickering fluorescent tubes in the scene.

Skill Level: Intermediate
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Time to complete: 20 minutes

Features Covered in This Tutorial

• Generating radiosity solutions using Advance
Lighting Override Materials

• Adding radiosity into Vertex Color

• Using Blur selected to correct lighting problems

• Painting vertex color on layers

• Animating layer opacity to create flickering
lights

Tutorial Files

Files for this tutorial can be found on the Tutorial
Files CD in the \tutorials\vertex_color directory.
Before starting the tutorials, copy the \tutorials
folder to your \3dsmax8 directory.

Adding Radiosity to Vertex Color

You can take the lighting information from your
file and add it to the vertex color information. In
this exercise, you will open a scene of a garage,
a typical game environment. The skylights and
fluorescent tubes in the garage have advanced
lighting override materials applied to them. You
will calculate a radiosity solution and then “bake”
it in the vertex color channels using the Assign
Vertex Colors Utility.

Radiosity with advanced lighting override materials

Setup the tutorial:

• Open tut_vertexpaint_garage_start.max.

Files for this tutorial can be found in the
\tutorials\vertex_color folders on the Tutorial
Files CD.

This file has been prepared so that it has
advanced lighting override materials placed on
the fluorescent tubes, the overhead skylights, the
hanging lamp, and the rear red skylight in the back
of the garage. First, you will adjust the luminance
scale on these materials.

Adjust the Advanced Lighting Materials:

1. Open the Material Editor.

If you only see 6 material slots, do the next step.

2. Choose Material Options and set Slots to 5 x 3.

Now you should be able to see 15 material slots.

3. Find and highlight the Skylight Material.

4. Increase the Luminance Scale from 500 to
12000.

5. Select the Cone_Light material and increase the
Luminance Scale from 5000 to 10000.
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6. Select the Fluorescent_Light material and
increase the Luminance Scale to 10000.

The Advanced Lighting Override Material will
give the illusion that the objects are casting
lighting in the scene. By increasing these
Luminance Scale values the garage will become
more brightly lit, once the radiosity is solved.

Note: This tutorial does not use Exposure
Control. Generally, when working with
radiosity, you can turn on Logarithmic
Exposure Control for best results.

Next, you will calculate the radiosity solution.

Calculate the radiosity solution:

1. On the Rendering menu, choose Render.

2. On the Render Scene dialog, click the Advanced
Lighting tab.

3. Make sure Display Radiosity In Viewport is
turned on, and that Initial Quality is set to 70 %
Then click Start.

The Radiosity solution is created, and the
viewport displays the shadowing created using
the advanced lighting.

Radiosity displayed in viewport

You’ll repeat the technique you just used one
more time.

4. In the Material editor, select the material named
Red_Light.

5. In the Special Effects group, increase the
Luminance Scale to 40000.

6. Close the Material editor.

On the Render Scene dialog, there is a message
saying the Solution is invalid at the current time
frame.

7. On the Render Scene dialog in the Radiosity
Processing Parameters, click Reset. Click Yes
on the dialog that asks if you are sure.

The viewport updates to reflect the reset
Radiosity.

8. Click Start again.

The radiosity solution calculates then displays
in the viewport. The red light color is now
splashed prominently on the back walls.

Red skylight color increased

Next, you will take the radiosity lighting
information and add it to the vertex color
information by using the Assign Vertex Color
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Utility. This will create a vertex paint layer that you
can then manipulate.

Bake radiosity into the vertex paint layer:

1. On the toolbar, find the Named Selection Set
drop-down list and click the down arrow.
Choose VertPt_set from the list.

This will select all the objects in the scene
except for the lights.

2. On the Utilities panel, choose More >
Assign Vertex Colors.

3. In the Assign Vertex Colors rollout, leave the
Channel set to Vertex Color.

4. Make sure in the Light Model group that
Lighting + Diffuse is turned on.

5. In Color assignment, turn on Color By Vertex,
if it isn’t already.

6. In the Rendering Options rollout, make sure
Mapping is on, and choose Radiosity, Reuse
Direct Illum. From Solution.

7. Click Assign To Selected.

The Radiosity information is assigned object by
object throughout the scene. You will see each
object update in the viewport.

The vertex information has been applied to the
geometry, but the vertex isn’t really displaying
it yet. To see the vertex color information, you’ll
use the floating vertex paintbox

8. On the Utility panel > Assign Vertex Colors
rollout, click Edit.

The floating vertex paintbox appears, and the
Modify panel is now displayed instead of the
Utility panel. The VertexPaint modifier is
now visible in the stack. It appears in italics,
indicating that it is an instanced modifier,
shared by several objects in the scene.

Display the vertex color in the viewport:

At the top of the paintbox is a row of buttons which
allow you to control the viewport display as you
work.

Tip: It’s important you understand these modes.
For example you can find yourself painting on
something you can’t see, because you aren’t
displaying it in the viewport.

1. Click the Vertex color display – unshaded
button.
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Unshaded vertex color displayed

The viewport now displays the vertex color
without the viewport lighting.

2. Click the Vertex color display – shaded
button.

Shaded vertex color mode

The viewport now displays the vertex color
with the viewport lighting.

3. Click the Vertex color display – disable
vertex color button.

The vertex color is hidden.

Vertex color disabled

4. Turn display vertex color display –
shaded on.

This is the mode you will use when you do your
vertex painting.

In the next section, you will explore using
the vertex paint tools to blur shadows, adjust
color and paint directly on the garage floor
using multiple vertex color layers. But first you
should save your work.

5. Save your file as mygarage_
vertexcolor01.max.
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Painting the Garage with
VertexPaint

Now you will explore the vertex paint modifier
tools.

Set up the tutorial:

• Continue from the previous exercise, or
open \tutorials\vertex_color\tut_vertexpaint_
garage_blur.max.

If you are opening the provided file, select the
VertPt_set from the toolbar Named Selection
sets list. On the Modify panel, display the
floating vertex paintbox by clicking the Edit
button.

Blur the shadows:

1. Navigate the viewport to explore the scene. Use
the Zoom and Pan tools to see what the interior
of the garage looks like.

2. Use Arc Rotate to look at the skylights and
fluorescent fixtures. Look up at the ceiling from
the center of the room. You may notice the
lighting information around the skylight is a
bit coarse.

Problems on the ceiling

It’s easy to smooth this out using the blur
command.

3. Right-click the Perspective viewport label and
choose Edged Faces.

4. Press the H key on the keyboard and select the
GARAGE_WALLS object from the list.

Next you’ll select the faces that need work.

5. On the Parameters rollout in the
Selection group, turn on Ignore Backfacing,
then click the Face Selection button.

6. On the toolbar, turn on Window
selection, then drag a selection rectangle
around one of the skylight areas.

You can use Soft selection for the blur operation
since you want to make sure the blur happens
smoothly.

7. On the Parameters rollout, click the Soft
Selection button, then in the Soft Selection
dialog, turn on Use Soft Selection.
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Use Soft Selection

8. To blur the selected area, click the Blur
All button.

The lighting is smoothed out in the ceiling.

Blur applied to ceiling faces

If you like, you can repeat the blurring
procedure on the roof areas surrounding the
other two skylights.

9. Choose File > Save As to save your file. Use the
plus button to save to an incrementally named
scene.

Paint additional layers:

You can add as many layers as you want. Each layer
is applied as another VertexPaint modifier in the
stack. These layers can be adjusted or animated
individually.

1. On the vertex paintbox, click New Layer.
Accept the default setting in the dialog that
appears, then click OK.

A second modifier is added to the stack.

2. Navigate the viewport so you can see the floor
of the garage.

3. Click the color swatch next to the Pick Color
From Object (eyedropper) button, then choose
a bright yellow from the color selector.

4. Click the Paint button, then
move your cursor over the garage floor and
paint.

Painting a second layer
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This paint layer is very adaptable. In the next
few steps, you’ll see some of the adjustments
you can make to this layer.

5. Change the opacity of the Layer by dragging the
opacity slider to the left.

6. Change the Mode. Click the drop-down arrow
and choose Color Dodge, then set the opacity
back to 100.

This creates the effect of a washed out spot on
the floor.

You can use the Adjust Color command to
change the Hue, Saturation or Value.

7. Change the mode from Color Dodge back to
Normal and change the opacity to 39.

8. Click the Adjust Color
button. In the Adjust Color dialog, drag the hue
slider to change the color. Click Apply.

9. Drag the Saturation slider to the left to make
the effect more subtle. Click Apply, and then
click OK to close the Adjust Color dialog.

10.Save you work using File > Save As. Use
the plus button to increment the name to
mygarage_vertexcolor02.max.
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Animating Vertex Paint Layer
Opacity

In this lesson you will separate the lighting
information from the individual objects onto
independent layers. We’ll show you how its
done, then you will load a file that has the work
completed.

You’ll create the illusion of a flickering fluorescent
tube by animating the opacity value of the vertex
paint layer, and then keyframing the material self
illumination color.

Set up the tutorial:

• Continue from the previous procedure.

Create separate radiosity layers:

1. With the garage walls still selected, hold
down the CTRL key, then on the Modify panel
select the two VertexPaint modifiers in the stack
and delete them using the Remove Modifier
From Stack button below the modifier window.

You can use the Layer Manager to quickly hide
and unhide parts of your scene. You’ll hide all
the lights but one, then create a radiosity pass
for that and bake it into a vertex paint layer.

2. On the toolbar, click the Layer Manager
button.

3. On the Layer Manager dialog, click Hide for all
the objects except FlourescentFlicker and Misc.

Layer Manager

Now the only objects visible in the scene are the
garage elements and the one fluorescent tube.

4. On the Rendering menu, choose Render. Then
on the Advanced Lighting Tab, click Reset.
Then click Start.

The radiosity solution is calculated for the light
coming from the single fluorescent tube.

Radiosity from single fluorescent fixture

Of course, the next step is to create the vertex
color layer.

5. On the Utilities Panel, click More > Assign
Vertex Colors. Make sure the selection set
namedVertsPT_set is selected, then click Assign
To Selected.
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The lighting coming from the one fluorescent
tube is applied to this vertex color layer.

6. Click the Edit button to jump to the Modify
panel.

In the Modifier stack, highlight the Vertex
Paint layer and right-click, then rename it
VertexPaint Flicker.

7. Repeat the procedure for the another light layer.
On the Layer Manager, unhide the layer named
Fluorescent Lights, and hide the layer named
Fluorescent Flicker. Repeat the above steps to
reset radiosity, create a new radiosity solution,
and assign it to a vertex color layer.

Radiosity for the rest of the fluorescent tubes.

You could do the same for the skylights.

Radiosity for the skylights

We’ve provided a finished file that has all the
work done for you.

8. Save your file if you wish, then open
tut_vertexpaint_anim_start.max to continue.

Animate the layer opacity:

Now you can create the illusion of a flickering
fluorescent tube. The technique you use is simple.
You select the layer with the lighting information,
then in Auto Key mode, keyframe the opacity
of the layer. You’ll then complete the illusion by
keyframing the self-illumination color of the
material.

1. In the new file you just opened, look at the
modifier stack for the VertPT_set objects.

There are six vertex paint layers in this file.

2. In the modifier stack, highlight VertPT_Flicker,
then click the Edit button to display the vertex
paintbox if it isn’t already visible.

3. Turn on the Auto Key button.

4. Move the time slider to frame 10.

5. On the floating vertex paintbox, move the
opacity slider down a little, then back to 100.
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This sets a key at frame 10, and frame 0.

6. Move to frame 12 and slide the opacity slider
down to 0.

7. Move to frame 14 and slide the opacity slider
up a little, then back down to 0.

8. Advance to frame 16 and slide the opacity slider
up to 100.

9. Play the animation in the viewport. The light
flickers once.

10. Open the Material Editor and find the
Flourescent_light material. In the Advanced
Lighting Override Material rollout, click the
Base Material name.

The Base material parameters appear.

11.Move to frame 10 and click the Self-Illumination
color swatch. Move the whiteness slider toward
grey, then back to white.

The color swatch is outlined in red, to show it
is animated.

12. Move to frame 12. Change the
Self-illumination color to Black using
the Whiteness slider.

Move to frame 14, and keyframe the color as
Black again.

13. Move to frame 16 and keyframe the
Self-Illumination back to white.

14. Turn off Auto Key and close the
Material Editor.

15. In the track bar, drag a selection rectangle
around the keys. Hold down SHIFT and drag
the keys to make copies so the flickering repeats.

If you play the animation now, its a little slow.
You can improve the performance by collapsing
the layers.

Preserve the flickering layer:

You’ll use the Preserve Layer command to keep the
animated layer while condensing the remaining
ones.

1. On the Parameters rollout, with the
VertPt_Flicker layer still selected, turn on
Preserve Layer.

2. Now highlight the Layer at the top of the stack.

3. On the floating vertex paintbox, click
Condense To Single Layer.

The five other layers are collapsed into a single
layer, while the flicker layer is preserved.

4. In the Modifier stack drag the Flicker layer
so it is at the top of the stack, then play the
animation in the viewport.

Summary

In this tutorial you have explored the use of the
VertexPaint modifier. You have learned to bake
radiosity into vertex color using the Assign Vertex
Color Utility, and how to add paint layers in the
modify panel. You have learned to animate the
opacity of the layers to create a flickering lighting
effect that can be exported to a game engine.

Render to Texture
The Render To Texture tool in 3ds Max lets you
render, or “bake,” various scene elements into
your textures, including lighting and shadows.
You can use these special textures in real-time 3D
applications such as games to reduce the burden
on the renderer, thus improving the frame rate.

In this lesson, you’ll look at basic usage of this
feature.
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Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max. Before doing the tutorials, copy the
\tutorials directory from the CD to your \3dsmax
local installation.

Examine the setup:

1. Load the file tut_texturebake_start.max. This
file is in the \tutorials\vertex_color folder.

The scene consists of a texture-mapped biplane
model and a single shadow-casting Omni light.
First, you’ll see how the scene looks rendered in
3ds Max.

2. Make sure the Perspective viewport is active.
On the toolbar, click Quick Render, or press
SHIFT+Q to render the scene.

In the rendered image, note the presence of
shadows, particularly those cast by the propeller
blade and the vertical strut between the upper
and lower wings. These shadows don’t appear
in the Perspective viewport, though.

3. Close the rendered frame window.

4. Select the Fuselage object; this is the main body
of the biplane.

The Fuselage uses an Unwrap UVW modifier
for complex and precise texture mapping.
Because this is the only texture-mapped object
in the scene, you’ll concentrate on it for this
lesson. First, you’ll take a look at the texture.

5. Go to the Modify panel, and in the modifier
stack display, make sure the Unwrap UVW
entry is highlighted.

6. On the Parameters rollout, click Edit.

This opens the Edit UVWs dialog. You can see
how the texture map is divided into various
sections, with different face clusters overlaid on
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each. These face clusters are UVW mapping
coordinates that correspond to different parts
of the Fuselage mesh.

7. Close the dialog.

8. Press M to open the Material Editor, and note
that the fuselage is mapped with a standard
material named Fuselage. Close the editor
window.

Bake the texture:

1. From the Rendering menu, choose Render To
Texture.

The Render To Textures dialog opens.

2. On the Objects to Bake rollout, note that the
Fuselage is the only object listed. Also note that
the Selected Object Settings group > Enabled
check box is on, and All Selected is chosen.
This means that Render To Texture will use any
selected objects.

If you like, try selecting different objects in the
Perspective viewport, and note that the Objects
To Bake list updates dynamically. Finish by
selecting only the Fuselage object.

3. On the Output rollout, click the Add button.

This opens the Add Texture Elements dialog,
with a list of different types of texture elements
you can render. Typically, you want to combine
all elements into a single texture, so you use
CompleteMap.

4. In the Add Texture Elements dialog list,
double-click CompleteMap, or highlight it and
then click the Add Elements button.

5. When you use Render To Texture, the software
creates a new material. You must specify where
in this new material the rendered texture will
go. In the Selected Element Common Settings
group, click the drop-down list next to Target
Map Slot and choose Diffuse Color.

CompleteMap appears in the Output rollout
list, along with the default texture size to be

generated: 256 x 256. The original texture map
is fairly large, so you’ll probably want to render
it to a bigger size.

6. Near the bottom of the Output rollout, click the
768 button.

Other sizes are available from the preset
buttons, and you can use the Size setting to
specify any output size you want.

This size is lower than that of the original
texture; using it will help you see the differences
between it and the one that Render To Texture
generates.

7. In the Name field, change the “CompleteMap”
text to MyCompleteMap. Press TAB to refresh
the dialog.

The name in the output list changes to reflect
your edit, as does the File Name And Type
entry.

8. At the bottom of the Render To Textures dialog,
click the Render button.
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Alerts appear briefly, displaying the progress
of flattening UVs and baking the texture, and
then a virtual frame buffer window opens with
the newly rendered CompleteMap texture. This
image looks similar to what you saw in the Edit
UVWs window, but the texture is subdivided
differently.

9. Close the rendered frame window, and then
close the Render To Textures dialog.

Examine the results:

1. Take a look at the modifier stack display, and
then look at the biplane in the Perspective
viewport.

A second modifier, named Automatic Flatten
UVs, has been added to the Fuselage. This is an
Unwrap UVW modifier, but it was created and

applied automatically by the Render To Texture
function.

The Fuselage object is still mapped accurately,
but the cast shadows now appear in the
viewport. For example, if you move the light
source, you can see that the shadows cast onto
the fuselage from the propeller don’t change
with as the light source moves, because they’re
baked into the texture.

You can also see that the texture map as applied
to the fuselage in the viewport is of lower
quality, but if you render the image, the texture
is of its original high quality. In the next few
steps, you’ll see why that is.

2. Again open the Material Editor. Click the first
material, which was previously named Fuselage.

The software has renamed the material
orig_Fuselage.

3. Scroll down to find an unused sample
sphere, click it, and then click the Get Material
button.

4. From the Material/Map Browser dialog >
Browse From group, choose Selected.

A single material now appears in the list. Its
name is Fuselage (from the object it’s applied
to), and the type, Shell Material, appears next
to the name. This material was generated
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automatically by Render To Texture, and then
applied to the Fuselage object.

Basically, a Shell material lets you combine two
materials into one; you can see one material
in the viewports while rendering with the
other. When Render To Texture generates a
Shell material, it uses the original material
for rendering, and the baked material for
displaying in the viewports.

5. Double-click the texture in the list to add it in
the Material Editor. Close the Material/Map
Browser dialog.

You can find the scene to this point in
tut_texturebake_finish.max.

This material has only one rollout: Shell
Material Parameters. It shows that the original
material (orig_Fuselage) is to be rendered with,
while the baked material (baked_Fuselage,
generated by Render To Texture) is to be visible
in the viewports.

6. Click the Original Material button, and
then, on the Material Editor toolbar, click the
Show Map In Viewport button.

This step lets you see the material in the
viewport in the next step.

7. Return to the top level of the material, and
on the Shell Material Parameters rollout, under
Viewport, click the top radio button (next to
Original Material).

In the Perspective viewport, the Fuselage
returns to its previous appearance, and the
shadows go away.

8. Try moving the light source, and then rendering
with the baked texture.

The original shadows remain where you baked
them. Depending on where you position the
light source, you might see an additional set of
shadows, cast by the light during the rendering.

9. In the shell material, return viewport display
to the baked material.

Render other elements:

Besides the CompleteMap, you can render
individual elements, one or more at a time.

1. Open the Render To Texture dialog and on the
Output rollout, delete the MyCompleteMap
element, and then add a ShadowsMap element.
Set Target Map Slot to Diffuse Color.

2. Click Render.

The new material is unshaded, except where
the shadows fall. You can use this type of
texture if your target rendering engine supports
compositing multiple textures.

Note that the rendered frame window still
shows the CompleteMap, even though Render
To Texture didn’t save one. This is always the
case, no matter which types of elements you
render. You can turn off the automatic display
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of the frame window on the General Settings
rollout.

3. On the Render To Textures dialog, delete the
ShadowsMap texture element, and then add, at
the same time, DiffuseMap and LightingMap
elements.

They appear in that order in the list. With
multiple textures in the list, you can specify
output settings for each by clicking its list entry.

4. In the list, click the DiffuseMap entry, and then
set Target Map Slot to Diffuse Color.

5. Click Render. When the Missing Map Targets
alert appears, click the Continue button.

The Missing Map Targets dialog shows any
texture elements that aren’t assigned to target
map slots.

The new Shell material is created for the
first element in the list only, as shown in the
Perspective viewport. However, all textures
are saved in the target directory. You can see
the LightingMap texture in the viewport by
deleting the DiffuseMap.

6. Delete the DiffuseMap list entry, set the
LightingMap’s Target Map Slot to Diffuse Color,
and then click the Render button.

Render To Texture generates a new material
and applies it to the Fuselage, so it is now visible
in the viewport. The LightingMap element
includes all shading and shadows, but no
diffuse coloring.

Note: Only one texture element at a time can
be set to any given target map type. Also, if
you add a texture element that was previously
assigned a target map type, the software
automatically assigns the most recent target
map type that it used, if no other active texture
element is already using that target map type.
If another active texture element is using that
target map type, the target map slot for the
newly assigned texture element is blank.

Summary

Render To Texture is a versatile tool that can save
you time in generating texture maps for real-time
applications. In this tutorial you learned how to
bake different types of textures, and how to work
with the Shell material that Render To Texture
generates. Try generating other texture elements,
and then exporting them to your real-time 3D
engine.



Rigging

Basic Rigging
A character rig is a setup designed to facilitate
control of a character. You can think of a character
rig as the 3D equivalent of strings that control
a marionette. If the strings are well placed and
properly set up, the puppet is very easy to control.
The same is true for a character rig.

It is important to have rigging controls that are
easy to use and quick to manipulate. For example,
you could rotate each of the character’s bones
individually to animate the skeleton, but you
would soon find this difficult and tedious. Instead,
you can create controls that rotate the bones for
you, assisting with common animation tasks such

Bones & IK
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as making the character bend its knees or shake
its head.

A character rig can consist of IK chains, helpers,
sliders, objects with custom attributes, and
short scripts to specify how various elements of
the skeletal structure will react under different
conditions. The rig’s construction depends a
great deal on how the character will be animated.
For example, a character that plays a musical
instrument requires a detailed hand rig for
manipulating the fingers. On the other hand, a
fighting character might only need simple finger
controls sufficient to grasp a weapon, but must
have detailed controls on the legs and back for
jumping and kicking.

A complex or realistic character can require dozens
of controls, while simpler characters might require
only ten or twenty. In this tutorial, you will learn
to create a rig for a simple character. All the tools
you will learn in this tutorial can be easily adapted
to more complex characters.

Skill Level: Intermediate

Time to complete: 1 hour

Features Covered in This Tutorial

• Creating and placing bones

• Editing bones with the Bone Tools dialog

• Creating and using IK chains

• Using custom attributes and parameter wiring
to control character movement

• Using list controllers to facilitate parameter
wiring

Tutorial Files

You can find the files for this tutorial in the
tutorials\character_animation\intro_to_rigging
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the

\tutorials folder from the CD to your \3dsmax8
local installation.

Creating a Bone Structure

This lesson gets you started with bones by showing
how to create them for a simple character. Bones
are special objects that are ideal for a character rig.
Bones are automatically linked as you create them,
and can be shaped to resemble an actual bone
structure for a character’s skeleton.

A series of linked bones is called a chain. Two or
more chains linked or connected together forms a
hierarchy of bones.

Bones appear in viewports as ordinary objects, but
they have special properties. Essentially, a bone is
a visual representation of a pivot point, a direction,
and a length. The bone points from its pivot point
(the start of the joint). Its length is defined by the
distance between the bones, and it points in the
direction of the next child on the chain.
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1. Pivot point

2. Direction

3. Length

It is possible to set up unusual relationships
between bones, such as a bone that does not extend
all the way to the next child on the chain. However,
the most common uses for bones observe the
properties described above.

You’ll start this tutorial by creating
bones for a simple character. You
can find the files for this tutorial in the
\tutorials\character_animation\intro_to_rigging
folder.

Prepare the character:

1. Open the file tut_introrig_start.max.

This file contains a simple character named
Pluggo. The character has one leg, a torso and a
head, but no arms.

Tip: The character is standing on the
construction plane. This positioning makes
it easier to place bones and other character
rigging controls, and easier to animate the
character when the rig is complete.

2. Press the H key to open the Select Objects
dialog and see a list of objects in the scene.

The scene contains three objects: the character
body, and two eyes.

When rigging a character, you can make the
process easier by:

• Making a selection set for the character mesh
so you can easily select it while working.

• Making the character see-through so you
can see where you are placing the bones.

• Freezing the mesh to prevent you from
accidentally selecting it while working with
the bones.

3. On the Select Objects dialog, click All, then
Select.
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4. In the Named Selection Sets entry area, enter
the name Pluggo Mesh, and press ENTER.

5. Press ALT+X to make the character
see-through.

6. Right-click any viewport, and choose Freeze
Selection from the quad menu.

Create the leg and foot skeleton:

1. In the Left viewport, zoom in on the character’s
leg.

This is where you will work for now.

2. From the Character menu, select Bone Tools.

The Bone Tools dialog appears.

The Bone Tools floater provides functions for
creating and editing bones.

3. In the Bone Editing Tools rollout > Bone Tools
group, turn on Create Bones.

When creating the bones, don’t be too
concerned about exact placement. You will get
a chance to reposition the bones in the next
procedure.

4. Create the leg bones using the character mesh
as a reference. Click once at the hip, then click,
in sequence, the knee, the ankle joint, the ball
of the foot, and the tip of the toes.

5. Right-click to complete your bone chain.

This creates a fifth, small bone at the end of the
toes.

6. Right-click again to turn off bone creation.

Note: You can also turn off Create Bones in the
Bone Tools dialog.

7. In the Front viewport, check the bone
placement to make sure the entire bone
structure sits inside the character’s leg. If
the bones are not inside the leg in the Front
viewport, move the topmost bone to move the
entire structure.
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Next, you will name the bones. It is a common
practice to name the bones according to the
joints where they begin, such as hip, knee and
ankle.

8. Go to the Modify panel. Starting from the hip,
rename the bones to: BoneHip, BoneKnee,
BoneAnkle, BoneToe, and BoneToeTip.

Adjust the bone positions:

When placing bones for a character, it is more
important to have the joints (pivot points) at the
correct locations than it is to have the bones going
through the mesh. For this character, the calf bows
backward slightly, which makes it impossible to
place the calf bone so it passes through the leg.
You will simply position the bones so the pivots
are in the right locations.

Also, positioning the bones with a slightly bent
knee will help with a later procedure where you set
up IK controls for the leg.

1. On the Bone Tools dialog, turn on Bone Edit
Mode.

In Bone Edit mode, you can change the lengths
of bones and their positions relative to one
another. This mode can be used both before
and after assigning an IK chain to the bone
structure.

2. Select a bone and move it.

Notice that adjusting a bone visually alters the
length of the bone before it. However, it is
actually adjusting the pivot placement of the
selected bone.

3. Continue moving bones until they are
positioned similarly to the previous illustration.

Warning: To change the sizes of bones, always use

Bone Edit Mode rather than the Scale transform.

Scaling bones with the Scale transform can cause

bones to react unpredictably during animation.

4. Turn off Bone Edit Mode when you have
finished.

Create the spine bones:

With a character rig, it is usually desirable to keep
each limb as a separate linked chain. In other
words, you would have a chain for each arm and
leg and another for the torso, but you would not
link these chains to one another with Select and
Link. Instead, you would use rigging controls to
tie it all together.

The next step is to create a series of bones for
the spine and head. It seems logical to begin
creating the spine bones at the top of the hip bone.
However, if you do so, the first spine bone will
automatically link to the hip bone.

To get around this situation, you will create the
spine bones away from the character’s body, then
move them into place.

1. In the Bone Tools dialog, click Create Bones.

2. In the Left viewport, start creating the
character’s spine bones to the right of the
character mesh. Create two bones for the spine
and one for the head, then right-click to end
bone creation.
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3. In the Left viewport, move the lowest spine
bone so it sits just above the leg bone.

4. In the Bone Tools dialog, turn on Bone Edit
Mode. Adjust the bones so they follow the
center of the character’s body as closely as
possible. Turn off Bone Edit Mode when you
have finished placing the bones.

5. Starting from the lowest spine bone, name
the bones BoneSpine01, BoneSpine02,
BoneHead, and BoneHeadTip.

Create fins for the bones:

You can create fins, or extrusions, on the bones.
Later, when you add controls and animate the
character, your work will be easier if you can hide
the mesh and work with the bones alone. Fins will
cause the bones to approximate the volume of the
character’s body, which will help you effectively
animate the bones without having to display the
mesh.

1. Select BoneHip, the hip bone.

2. In the Bone Tools dialog, expand the Fin
Adjustment Tools rollout.

3. Turn on Side Fins, Front Fin, and Back Fin.

4. Adjust the Size parameter for each fin until the
hip bone fills out about 3/4 of the mesh. Check
your work in the Left and Front viewports.

5. Create fins for the remaining bones in the
skeleton as needed to make them fill about 3/4
of the mesh. Some bones might need only a
back fin or side fins, while others might not
need any fins at all to fill up 3/4 of the mesh.
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Make a named selection set for the bones:

1. Select all the bones.

2. In the Named Selection Set entry area, enter the
name Pluggo Bones.

Tip: You should always include the character’s
name in the selection set name, rather than
naming the selection set just Bones or Mesh.
If you add more characters to the scene, you
will know which selection set belongs to which
character.

3. Save the scene with the filename
my_introrig_bones.max.

You can find a scene with the correct
bone placement and names in the file
tut_introrig_bones.max.

Setting Up IK Solvers

In order to manipulate the leg and foot
interactively, you must apply an inverse kinematics
solver (IK solver) to selected parts of the skeleton.

An IK solver figures out (solves) how the bones
should move or rotate based on a goal object.
For example, you will place an IK solver on the
leg with a goal at the ankle. When you move the
goal, the ankle will move to the specified position,
and the hip and knee bones will move and rotate
accordingly.

There are several types of IK solvers in 3ds Max,
each with a different purpose and usage. For
rigging legs and arms, the HI solver is the most
effective and easiest to use. It is designed to work
with chains of two or more bones that bend in only
one direction, such as knees and elbows. You will
use this type of solver to rig the character’s leg.

After you create the IK chains, you will look
at their properties and parameters to gain an
understanding of how they work.

Prepare the scene:

1. Continue with the scene from the previous
lesson, or open the file tut_introrig_bones.max.
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You do not need to see the mesh to set up IK
solvers, and it will be easier to work with the
bones if the mesh is hidden.

2. Right-click any viewport, and choose Unfreeze
All from the quad menu.

3. From the Named Selection Sets drop-down
menu, choose Pluggo Mesh.

4. Right-click any viewport, and choose Hide
Selection.

This leaves just the bones in the scene.

Create the ankle IK chain:

An IK solver assigned to a hierarchy of bones is
called an IK chain. To create the IK chain for the
leg, you start by selecting the highest bone in the
hierarchy that will be part of the IK chain. Since
you are creating an IK chain from the hip to the
ankle, you will start by selecting the hip bone.

1. Select BoneHip.

2. Choose Animation menu > IK solvers > HI
Solver.

As you move the cursor, you will see a dotted
line extending from BoneHip. Now you will
choose the bone that defines the other end of
the IK solver.

A set of cross hairs is created at the base
of BoneAnkle, and a line appears between
BoneHip and BoneAnkle. This is a visual
representation of the IK chain.
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3. Click BoneAnkle to define the end of the IK
chain.

4. Name the IK chain IKAnkle.

5. Move the cross hairs around to see the leg bones
bend.

The cross hairs set the position of the IK goal.
As you move goal, the knee bends to make the
ankle reach the goal.

Note: Do not be concerned if the knee bends
the wrong way. You will solve this problem later
in this lesson.

6. Undo any movements you made so the IK goal
returns to its original position.

7. Rotate the IK goal to see how this affects the
bones.

Rotating the IK goal around its own pivot point
does not animate the bones in any way. In the
next procedure, you will learn how to rotate the
ankle so the heel lifts up.

8. If you have rotated the IK goal, undo any
rotation before continuing.

Create the second IK chain:

If you want to rotate the ankle to raise the heel off
the ground, you must rotate the IK goal around a
point other than its own pivot point, such as the
point between the foot and toe bones.

In animation of 3D objects, a common method for
making one object rotate around another’s pivot
point is to link one object to another, then rotate
the parent object. However, this approach will not
work with an IK chain. If you link the IK goal to
any of the bones with Select and Link, this will
break the IK chain.

Instead, you will create an IK goal at the point
between the foot and toe, and use this as the parent
object to control the ankle IK goal’s rotation.

1. Select BoneAnkle. This will be the start of the
second IK chain.

2. In the Animation menu, under IK solvers,
choose HI Solver.

3. Click BoneToes to define the end of the chain.
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The IK goal for this IK chain defines the ball
of the foot.

4. Name the IK chain IKBall.

5. Use Select And Link to link IKAnkle to
IKBall.

6. In the Left viewport, rotate IKBall to make the
ankle rise.

Now the ankle rotates, enabling you to make
the heel rise up. However, the toe rotates
downward as the heel goes up. You can force
the toe to stay still by creating another IK chain
that ends at the toe.

7. Undo any rotation before continuing.

Create the third IK chain:

1. Select BoneToe.

This will be the start of the third IK chain.

2. In the Animation menu, under IK solvers,
choose HI Solver.

3. Click BoneToeTip to define the end of the
chain.

4. Name the new IK chain IKToe.

5. Select IKBall, and rotate it in the Left viewport.
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The ankle rises, but the toe stays still.

6. Link IKBall to IKToe.

7. Rotate IKToe.

This rotates the entire foot. Undo any rotation
before continuing.

You can find a scene with the IK chains in the
file tut_introrig_ik.max.

Create a test animation:

As you have seen, rotating an IK chain itself has no
effect on the bones. You have learned how to make
an IK chain rotate around another point by linking
it to another IK chain, and you have seen how you
can use this to rotate the heel or entire foot upward.

However, the rotation of the linked IK chains does
not affect the direction in which the knee points.
The character rig will need to accommodate
animation where the character swivels his hip to
make the knee point in a different direction. To
make this type of rotation, you will need to work
with the IK chain’s parameters. To see how this
parameter works, you’ll animate the IK chains to
bend the knee. Working with a bent knee will
enable you to see the hip swivel more easily.

1. Go to frame 10, and turn on Auto Key.

2. Select IKBall. In the Left viewport, rotate it by
about 30 degrees on the Z axis to make the heel
rise and the knee bend.
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Note: Do not be concerned if the knee bends
in the wrong direction. You will correct this
problem with IK parameters.

3. Turn off Auto Key.

Work with IK parameters:

The first IK parameter you will work with is the
swivel angle. This parameter determines how the
bones in an IK chain will swivel (twist).

1. Select IKAnkle.

2. Go to the Motion panel.

3. In the IK Solver Properties rollout, locate the
Swivel Angle parameter. While watching the
Perspective view, use the spinner to increase or
decrease the Swivel Angle value.

When you change the swivel angle, the hip
swivels to point the knee in another direction.
The swivel angle is expressed in degrees, with
360 degrees making a full circle. This is the
parameter you will use in the character rig to
swivel the character’s hip.

However, the foot bones also twist when you
change the swivel angle, which is undesirable.
You can prevent the foot bones from rotating
by changing another IK parameter, the Parent
Space. This setting is located on the IK Solver
Properties rollout, just below the Swivel Angle
parameter.

The Parent Space determines how the bones in
an IK chain will twist when the IK chains are
animated. By default, the bone’s twist angle is
determined by the twisting of its parent, the
calf bone. When you change IKAnkle’s swivel
angle, the calf twists, and so does the ankle
bone.



Adding Control Objects 311

You can change the Parent Space setting so the
foot bones don’t inherit the calf bone’s twisting.
When you change an IK chain’s Parent Space
setting to IK Goal, the bones in the chain twist
according to the animation on the IK goal, not
the calf bone. This gives you more control over
the foot, so you can make it rotate only when
you want it to.

The ankle and toe bones are controlled by their
own IK chains, so you will need to change the
parameters for those IK chains.

4. Select IKBall.

5. On the Motion panel, in the IK Solver
Properties rollout > Parent Space group, choose
the IK Goal option.

Note: Changing this setting might cause the
foot to rotate to an orientation other than its
original orientation. You will fix this shortly.

6. Select IKToe, and set its Parent Space to IK
Goal.

7. Select IKAnkle and change the Swivel Angle
parameter.

This time, the foot bones don’t twist when the
swivel angle changes.

8. Set the Swivel Angle back to 0.

9. If the knee bends in the wrong direction,
change the Swivel Angle and swivel the hip until
the knee points straight forward.

Usually, the correct Swivel Angle value should
be 0, 90, 180 or 270 degrees to correspond to
the quarters of a 360-degree circle. You can also
use a negative value such as -90 degrees, which
is the equivalent of 270 degrees.

Tip: You can avoid the problem of an incorrectly
bending knee by taking care with bone
placement before you apply the IK solver.
Create the leg bones in such a way that the knee
already has a slight bend. When you apply
the IK solver, it will use the existing bend as a

“clue” as to which way to rotate the joints. This
means that a Swivel Angle of 0 will correspond
to a correctly bent knee. Having to change the
swivel angle after applying an IK solver does
not affect the validity of the rig, but it does add
an extra step to the rigging process.

Set the swivel angle for the ankle and toe bones:

When you set the Parent Space to IK Goal for
IKBall and IKToe, the ankle and toe bones might
have rotated to an orientation other than its
original setting. You can fix this by changing their
swivel angles.

1. Select IKBall.

2. On the Motion panel, change the Swivel Angle
until the bone is in its original orientation. Use
a setting of 90, 180, or 270.

3. Select IKToe, and change its Swivel Angle if
necessary to reset it to its original orientation.

The IK chains on the leg should work properly
now.

4. Scrub the time slider between frames 0 and 10
to see the heel come up. The knee should bend
in the correct direction, and the foot bones
should not twist or flip as the heel comes up.

5. Save the scene as my_introrig_swivel.max.

You can find a scene with correctly set swivel
angles and parent space settings in the file
tut_introrig_swivel.max.

Adding Control Objects

You can make it easier to manipulate the IK chains
and bones in a character rig by adding objects,
shapes, or helpers to the scene. You then connect
the bones and IK chains to the control objects in
such a way that you can use the control objects
to perform all the necessary animation on the
character.
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It is possible to use a mix of shapes, helpers,
and 3D objects as control objects, but many
animators find it more useful to use only one type
of object. This allows them to use a selection filter
during the animation process. The selection filter
limits selection of objects to one type of object
only. During the animation phase, you can use a
selection filter to make it easy to select the control
objects, and prevent accidental selection of bones,
IK chains, and the character mesh.

In this lesson you will use shapes as control objects,
and will use linking and other tools to connect the
bones and IK chains to them.

Prepare the scene:

1. Continue from the previous lesson, or open the
file tut_introrig_swivel.max.

2. Activate the Perspective viewport, and press the
G key to remove the grid from the viewport.

This will make it easier to see the control shapes
you are about to create.

Create the control shapes:

1. On the Create panel, click Shapes.

2. In the Top or Perspective viewport, create a
rectangle slightly larger than the foot. Name the
shape CtrlFoot.

This is the shape you will use to control the
foot. Because the character is standing on
the construction plane, the shape is already
positioned under the character’s foot.

3. Zoom out the Top viewport to give
yourself room to make the next shape.

4. In the Top viewport, create a rectangle about
four times as large as the first. Name the shape
CtrlBody.
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You will use this shape to control the entire
body.

5. In the Top viewport, create a Circle about twice
as wide as the widest bone. Name the shape
CtrlLeg.

You will use this shape to control the upper part
of the leg.

6. Use Align to align the circle with the
lowest spine bone, BoneSpine01. On the Align
dialog, choose Pivot Point for both the Current
Object and Target Object, and align the circle’s
position on the X, Y and Z axes.

Use a custom shape:

To control the spine and neck, you will use a
custom shape created from a circle and two lines.
This shape has been provided for you.

1. Choose File menu > Merge, and choose the file
tut_introrig_controlshape.max. On the Merge
dialog, select Control Shape, and click Merge.

The merged shape is a circle enclosed two
crossed lines. This shape was created by
converting a circle to an Editable Spline, and
drawing two lines across its center. The lines
will distinguish this shape from the circle.
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2. Name the shape CtrlSpine.

3. Align CtrlSpine with the lowest spine
bone, BoneSpine01. On the Align dialog,
choose Pivot Point for both the Current Object
and Target Object, and align the control shape’s
position on the X, Y and Z axes.

4. Make a copy of the control shape, and name
it CtrlNeck.

5. Align CtrlNeck with the head bone,
BoneHead. On the Align dialog, choose Pivot
Point for both the Current Object and Target
Object, and align the control shape’s position
on the X, Y and Z axes.

6. Save the scene with the filename
my_introrig_shapes.max.

You can find a scene with the rig control
shapes correctly placed and named in the file
tut_introrig_shapes.max.

Link the bones and IK chains to the control objects:

Now you will link bones and IK chains to their
appropriate control objects.

1. Use Select and Link to link IKToe, the IK
chain at the tip of the foot, to CtrlFoot.
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2. Link BoneHip to CtrlLeg, the circle
shape.

3. Link BoneSpine01 to CtrlSpine, the
control shape at the bottom of the spine.

4. Link BoneHead to CtrlNeck.

Until this point, BoneHead was linked to
BoneSpine02, the topmost spine bone. Now
that you have linked it to CtrlNeck, the head is
no longer linked to the body.

5. Link CtrlNeck to BoneSpine02.

Now the head is linked to the spine again via
the control shape CtrlNeck.

The spine and leg were not linked when you
created them. Now you will connect them
together by linking the control objects.

6. Link CtrlSpine to CtrlLeg.

Test the rig:

Now you will test the rig to see how well it works.
To avoid moving the bones in their initial states,
you will leave the pose intact on frame 0, and
animate the bone on another frame.

1. Turn on Auto Key.

2. Go to frame 10.

There is already animation on the IK chain at
the ball of the foot which makes the heel rise
at frame 10. You don’t need this animation to
test the rig.

3. Select IKBall. On the track bar, select the key at
frame 10, then right-click and choose Delete
Selected Keys.

4. Move CtrlLeg downward to bend the leg.

CtrlLeg moves and turns both the thigh and
spine.

5. Select CtrlSpine. In the Front viewport, rotate
this control to make the spine bend to your left.

CtrlSpine controls just the upper body.

6. In the Front viewport, rotate CtrlNeck to make
the head bend farther in the same direction as
the spine.
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Now the character looks out of balance.

7. In the Front viewport, move CtrlLeg to your
right to balance the character’s weight.

8. Pull the time slider to scrub the animation.

The rig makes the character very easy to
animate.

Note: If you rotate CtrlLeg, both the spine and
thigh will rotate. Some character riggers prefer
to keep the spine and thigh rotation separate
by creating another control around the hips
and linking both the spine and leg controls
to this additional control. This type of setup
allows you to rotate the thigh without rotating
the spine.

Finish the rig:

The last necessary part of the rig is a control
that allows you to move the entire character to
another part of the scene. The object CtrlBody
will accomplish this.

1. Link CtrlFoot to CtrlBody.

2. Link CtrlLeg to CtrlBody.

3. Test the setup by moving CtrlBody. The entire
character should move with it. Undo any
movements before continuing.

4. Save the scene as my_introrig_controls.max.
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You can find a version of this scene in the file
my_introrig_controls.max.

Wiring a Custom Attribute

In this lesson, you will create custom attributes to
control the foot. A custom attribute is a parameter
you create yourself.

The parameter doesn’t control anything until you
connect it to another parameter in the scene. You
will use parameter wiring to connect the custom
attributes to the rotation of the foot’s IK chains.

Prepare the scene:

1. Continue from the previous lesson, or open the
file tut_introrig_controls.max.

2. If you are continuing from the previous lesson,
go to frame 0.

Create custom attributes:

1. Select CtrlFoot.

2. Choose Animation menu > Parameter Editor.

The Parameter Editor dialog appears.
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3. On the dialog’s Attribute rollout, enter Roll as
the Name parameter.

4. Expand the Float UI Options rollout, and enter
a range from 0 to 60.

5. In the Attribute rollout, click Add.

6. Close the Parameter Editor dialog.

Determine the rotation axis to be wired:

You want the new Roll parameter to rotate the IK
chain at the ball of the foot so the character’s heel
will rise. In order to do this, you must find out
which of the IK chain’s axes of rotation should be
affected by the parameter.

1. Select IKBall.

2. On the Main Toolbar, turn on Select and
Rotate.

3. Change the reference coordinate system to
Local.

4. Rotate IKBall so the heel rises, and note which
axis is affected by the rotation.

You can easily see which axis is affected by
watching the display of numbers above the
rotation gizmo. The X axis value changes as
you rotate IKBall.

5. Undo any rotation you have done on IKBall
before continuing.

Wire the custom attribute to the IK chain’s rotation:

Now you are ready to wire the Roll parameter to
IKBall’s X rotation.

When you wire parameters, the wiring is limited to
the time segment that was active when the wiring
was set. You can change this setting in Track View
later on, but it is much easier to set the maximum
time segment you think you might need before
wiring. In this case, you will change the active time
segment to 1000 frames.

1. Click Time Configuration, and change the
Length parameter to 1000.

Now you will create custom attributes on
CtrlFoot, the control object for the foot. This
will allow you to roll the foot by changing
parameters on the Modify panel when CtrlFoot
is selected. The custom attribute will be called
Roll, and will range from 0 to 60 degrees.

2. Select CtrlFoot.

3. Choose Animation Menu > Wire Parameters >
Wire Parameters.

A pop-up menu appears, giving you a choice of
all parameter paths that are available for wiring.
In this case, there are only two, Transform and
Object.

4. On the pop-up menu, choose Object
(Rectangle) > Custom Attributes > Roll.

A dotted line appears, extending from
CtrlFoot’s pivot point to the cursor. The dotted
line indicates that you should choose an object
and parameter path for the second object in the
wiring pair.

5. Click IKBall.

6. On the pop-up menu, choose Transform > IK
Goal > Rotation > X Rotation.

The Parameter Wiring dialog appears.

This dialog shows you the parameters that
will be connected, and the direction in which
the control will occur. In this case, you want
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the Roll parameter to affect the IK chain’s X
Rotation parameter.

7. In the center of the Parameter Wiring dialog,
turn on the arrow that points to the right.

This will cause Roll to control the X Rotation
parameter.

8. Click Connect.

The parameters are now wired together. Leave
the Parameter Wiring dialog open as you test
the wiring.

Test the wiring:

1. Move the Parameter Wiring dialog so you can
clearly see the character’s foot.

2. On the Modify panel, increase the Roll
parameter.

The foot spins wildly.

What is actually happening is a result of how
3ds Max handles rotations internally. Most
people are familiar with degrees for rotation.
Ninety degrees is a quarter turn or rotation, 180
is half, and 360 is a full turn. However, many
3D applications use a different unit of measure
called radians to measure rotations. Radians
are based on the value of pi (approximately
3.1416).

With Radians, 2 times pi is a full 360–degree
spin. That is, 6.28 Radians equals 360 degrees.
Conversely, one radian is equal to about 57
degrees.

3ds Max comes with a built-in function,
degtorad, that you can use to convert the Roll
parameter to radians before passing it on to
IKBall’s X rotation.

3. In the Parameter Wiring dialog, replace the
expression Roll in the lower right entry area
with degtorad(Roll).

This tells the wiring to use this expression for
IKBall’s X rotation.

4. In the Parameter Wiring dialog, click Update.

5. On the Modify panel, increase the Roll
parameter.

The heel comes up as you increase the Roll
parameter, and stops rising when Roll reaches
its maximum value of 60.

6. Save the scene as my_introrig_toewiring.max.

You can find a version of this scene in the file
tut_introrig_toewiring.max.
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Set up toe rotation:

You can use CtrlFoot to move or rotate the entire
foot. However, if you tip CtrlFoot forward, it
rotates from the center of the control shape. You
can make it rotate from the toe tip by aligning its
pivot point with IKToe.

1. Select CtrlFoot.

2. On the Hierarchy panel, turn on Affect
Pivot Only.

3. Use Align to align its pivot point with
the pivot point of IKToe. On the Align dialog,
choose Pivot Point for both the Current Object
and Target Object, and choose the X, Y and Z
axes.

4. Turn off Affect Pivot Only.

Now, when you rotate CtrlFoot, it rotates from
the tip of the toe.

If you rotate CtrlFoot to test the setup, be sure
to undo any rotation before continuing.

Wire the knee’s swivel angle:

Now you will create and wire another custom
attribute, this one for the knee’s swivel angle.

1. Select CtrlFoot.

2. Choose Animation menu > Parameter Editor.

3. Enter KneeSwivel for the name, and enter a
range of –90 to 90. Click Add to create the
custom attribute, and close the Add Parameter
dialog.

This adds a KneeSwivel parameter to CtrlFoot.

4. Right-click CtrlFoot and choose Wire
Parameters from the quad menu.

Tip: You can access parameter wiring from the
quad menu, or by choosing Animation menu >
Wire Parameters > Wire Parameters.

5. On the pop-up menu, choose Object
(Rectangle) > Custom Attributes > KneeSwivel.

6. Click IKAnkle, and choose Transform > Swivel
Angle from the pop-up menu.

7. On the Parameter Wiring dialog, enter
degtorad(KneeSwivel) in the lower right entry
area.

8. Turn on the right arrow, then click Connect.

Test the knee swivel:

The easiest way to see the KneeSwivel parameter in
action is to look at the character with a bent knee.
You can see this by going to frame 10, where the
character is animated to bend its knee.

1. Go to frame 10.

2. On the Modify panel, change the KneeSwivel
parameter.
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The knee swivels without affecting the foot.

Save the file:

1. Reset Roll and KneeSwivel to 0.0.

2. Save the scene as my_introrig_wired.max.

You can find a version of this scene in the file
tut_introrig_wired.max.

Using List Controllers

When you create any object, including bones,
default controllers are placed on the object to
control its position, rotation, and scale.

For each transform, you can change the default
controller to a list controller. This type of
controller allows you to assign two or more
controllers to the transform. The controllers are
evaluated from first to last, and their values are
added up to give the final transform value.

When you assign a list controller to a transform,
the first controller on the list takes on the
transform’s current XYZ values, and the next
controller starts off with a value of [0,0,0]. Then
you can make the second controller active, so any

animation will change the second controller’s
values only.

By assigning a list controller to the objects in
your scene, you effectively set their animation
transforms to [0,0,0] on the second controller
regardless of how much you have moved, rotated
or scaled the objects up to that point. If you wire
parameters between two objects on the second
controller, the transform values will match, and
one object’s parameters will predictably affect the
other object’s parameters.

In the case of a character rig, you have probably
rotated the bones and controls to fit them to the
character. Wiring the rotation of these objects to
one another without using a list controller will
cause one object to take on the posed rotation of
another. For example, if you previously rotated
a control shape by 90 degrees on the X axis to
make it fit the rig, then you wire the control
shape’s X rotation to a bone’s X rotation, the bone
will suddenly rotate by 90 degrees to match the
wired parameter. In such a case, you can use list
controllers to cause both objects to start from a 0
rotation, and ensure that the control object will
predictably affect the bone.

This lesson illustrates how you can use list
controllers in a character rig.

Prepare the scene:

1. Continue from the previous lesson, or open the
file tut_introrig_wired.max.
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2. If you are continuing from the previous lesson,
go to frame 0.

Right now, the control object CtrlSpine at the
bottom of the spine can be used to rotate the
character’s entire spine. But when you twist
your spine, your upper body rotates more than
the lower part. You will simulate this motion by
causing the upper spine bone, BoneSpine02,
to rotate 1.5 times as much as CtrlSpine and
BoneSpine01.

To achieve this, you will wire the rotation of
BoneSpine02 directly to CtrlSpine. When you
rotate CtrlSpine, BoneSpine02 will rotate by the
same amount due to its linkage to BoneSpine01
and an additional half of the rotation due to the
wiring.

Align the pivot points:

Before you can wire BoneSpine02 to CtrlSpine,
you must make sure their pivot points are aligned.
Later, when you wire each rotation axis of
BoneSpine02 to CtrlSpine, you will know that the
rotation axes match.

1. Select CtrlSpine.

2. On the Hierarchy panel > Pivot > Adjust
Pivot > Move/Rotate/Scale group, turn on
Affect Pivot Only.

3. Use Align to align the CtrlSpine pivot
point with the pivot point of BoneSpine02. On
the Align dialog, choose Pivot Point for both
the Current Object and Target Object.

4. Turn off X Position, Y Position, and Z Position,
then turn on X Axis, Y Axis, and Z Axis in the
Align Orientation group. Click OK.

5. Turn off Affect Pivot Only.

Assign a rotation list controller:

Now you will assign a Rotation List controller to
CtrlSpine’s Rotation track.

1. With CtrlSpine selected, go to the
Motion panel.

2. On the Assign Controller rollout, highlight the
Rotation: Euler XYZ track.

Currently, the rotation track holds the default
rotation controller, Euler XYZ.

3. On the Assign Controller rollout, click the
Assign Controller button. Choose Rotation List
from the list of controllers, and click OK.

4. On the Assign Controller rollout, expand the
Rotation branch.
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The Rotation controller branch now contains
three items: Euler XYZ, Available, and Weights.
The Euler XYZ controller is the controller that
was previously on the Rotation track, and it
holds any rotation applied to the object up
to this point. The Available controller is a
placeholder for any controllers you want to add
to the list.

5. Highlight the Available item.

6. Click Assign Controller. Choose Euler XYZ
from the list of controllers, and click OK.

The Rotation List controller now shows two
Euler XYZ controllers.

Name the controllers:

When you wire the second controller later on, your
work will be much easier if you give each of the
controllers a unique name now.

1. On the Rotation List rollout, highlight the first
Euler XYZ listing under Layers.

2. In the entry area below the Layer listings, enter
InitialPose.

The name of the first Euler XYZ in the Layer
listings changes to reflect this new name. This
controller holds the initial rotation for the
object.

3. Highlight the second controller in the Layer
listing, and enter the name Wiring.

This is the controller you will use for wiring.

When a controller is active, a small arrow
appears to its left in the Layer listing. You will
need to have the Wiring controller active when
you animate the scene.
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4. On the Rotation List rollout, click Set Active to
make the Wiring controller active.

Tip: You can also double-click the controller in
the Layer list to make it active.

Assign a list controller to the spine bone:

1. Select BoneSpine02, the highest spine bone.

2. On the Motion panel, highlight the Rotation
track, and click Assign Controller. Choose the
Rotation List controller from the list.

3. On the Assign Controller rollout, expand the
Rotation listing. Highlight the Available listing,
and assign a Euler XYZ controller to it.

4. In the Rotation List rollout, name the two
controllers InitialPose and Wiring.

5. Make the controller named Wiring the active
controller.

6. Save the scene as my_introrig_
controllers.max.

You can find a version of this scene in the file
tut_introrig_controllers.max.

Wire the controllers together:

Now you can wire together the rotation axes on
each object’s Wiring controller.

1. Select CtrlSpine.

2. Right-click CtrlSpine, and choose Wire
Parameters. From the pop-up menu, choose
Transform > Rotation > Wiring > X Rotation.

3. Click BoneSpine02, and choose Transform >
Rotation > Wiring > X Rotation.

4. On the Parameter Wiring dialog, enter
X_Rotation / 2 as the expression.

This will add half of CtrlSpine’s rotation to
BoneSpine02 on the X axis.

5. Turn on the right arrow, and click Connect.

6. Highlight the Y Rotation listing on each side of
the dialog. Turn on the right arrow, and click
Connect.

7. Do the same for the Z Rotation listings.

8. Close the Parameter Wiring dialog.

Test the wiring:

1. Rotate CtrlSpine on any axis.

The lowest spine bone rotates by the same
amount, but BoneSpine02, the higher spine
bone, rotates a little more.

2. Turn on Auto Key.

3. Go to frame 10.

The animation on CtrlSpine was lost when you
assigned the list controller. The character is out
of balance on this frame.

4. In the Front viewport, rotate CtrlSpine so the
character leans in the direction opposite its
hips.

5. Turn off Auto Key.

6. Save the scene as my_introrig_
spinebend.max.

You can find a version of this scene in the file
tut_introrig_spinebend.max.



Skinning 325

Skinning

In this lesson, you will associate the bones with the
character mesh so the bones will deform the mesh.
This process is called skinning. In 3ds Max, you
skin a character with the Skin modifier.

Prepare the scene:

1. Continue from the previous lesson, or open the
file tut_introrig_spinebend.max.

2. If you are continuing from the previous lesson,
go to frame 0.

3. Unhide all the objects in the scene.

4. If you have not changed the rig on frame 0, the
bones should fit perfectly inside the mesh. If
they do not, make adjustments to the rig to fit
the bones inside the mesh.

5. Select Pluggo_Body, and press ALT-X to make
it solid.

Apply the Skin modifier:

You apply the Skin modifier the mesh that you
want to deform with bones.

1. Select Pluggo_Body.

2. On the Modify panel, click Editable Poly on the
modifier stack to highlight it.

If MeshSmooth has been applied to the
character, as it has in this case, it is usually
better to apply the Skin modifier below
MeshSmooth on the stack. With this technique,
you will have fewer vertices to control with
the Skin modifier, and the character will still
deform smoothly at the MeshSmooth level of
the stack.

3. On the Modify panel, turn on the Show
End Result On/Off Toggle if it’s not already
turned on.

This will show you the results of the
MeshSmooth modifier as you work, even
though it is higher on the stack than the current
level.

4. Apply the Skin modifier to the mesh.
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The Skin modifier is applied above Editable
Poly, but below MeshSmooth. Now you will
associate the bones with the mesh.

5. On the Parameters rollout, click Add. On the
Select Bones dialog, select all the bones except
BoneHeadTip and BoneToeTip. The selected
bones appear on the Parameters rollout.

There is no need to select the control objects,
as they will not deform the mesh. The control
objects move the bones, which in turn deform
the mesh. The bones at the tip of the head and
toe are not inside the mesh, and so should have
no influence on the mesh deformation.

Adjust the scene to help you see the skinning results:

It will be easier to use the animation between
frames 0 and 10 to test the skinning if the active
time segment is shorter.

1. Click Time Configuration, and change the
Length to 100. Click OK to close the dialog.

2. Scrub the time slider between frames 0 and 10.

The mesh follows the bones, but the eyes are
left behind. The eyes must be linked to the head
bone to animate correctly.

3. Select Pluggo_EyeLeft and
Pluggo_EyeRight, and link them to
BoneHead.

Now, when you scrub the time slider, the eyes
go with the head.

You could have applied the Skin modifier to the
eyes as well as the body, but this is not necessary
unless the head will deform. In this character
rig, the head will always be rigid, so it is easier
to link the eyes to the head bone.

Now that you have applied the Skin modifier,
you no longer need the bones in the scene, and
it will be easier to adjust the Skin modifier with
the bones and controls hidden.

4. Click Select to turn it on and turn off
Select And Link.

5. Select all the bones, IK chains, and control
objects. Right-click any viewport and choose
Hide Selection from the quad menu.
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Look at the envelopes:

When you apply the Skin modifier, each bone is
assigned a pair of envelopes that determine how
much the bone affects the vertices within it:

1. Select the mesh, and highlight the Skin modifier
in the stack.

2. On the Parameters rollout, click the Edit
Envelopes button to turn it on.

3. On the Parameters rollout, highlight different
bones on the list, and look at their envelopes
in any viewport.

Each envelope pair is defined by two distinct
splines:

• The inner envelope, where vertices receive
the fullest influence from the bone. This
envelope is displayed as a red spline.

• The outer envelope, where vertices between
the inner and outer envelopes receive less
influence from the bone. The farther the
vertex is from the inner envelope, the less
the bone’s influence on the vertex. This
envelope is displayed as a brown spline.

Any vertices that are not inside the outer
envelope are not influenced by the bone.
Where two envelopes overlap, the bones share
influence over the vertices.

Ideally, the inner envelope surrounds the
non-bending part of the skin, such as the main
part of the thigh or calf. Outer envelopes from
adjoining bones should overlap somewhat to
provide influence over joints, such as the knee
and ankle.

The initial size of the envelopes is determined
by the size of the bone at the time the Skin
modifier is applied. In shaded viewports, the
selected envelope’s influence is shown as a color
on the mesh. Red areas are the most influenced,
while yellow and orange areas receive some
influence. Blue areas receive no influence at all
from the selected envelope.

Envelope for BoneSpine01 with colors showing influence

4. Scrub the time slider and watch the animation
again.

The mesh goes with the bones, but the joints
are not well defined. For example, the crease
at the top of the thigh does not bend cleanly.
Instead, the entire thigh bends. This is because
the envelope around BoneSpine01 is too
large, and it encompasses half of the thigh. In
addition, the head envelope is very large, and it
encompasses the body.
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Adjust the envelopes:

Now you will adjust the head and lower spine
envelopes so they encompass more appropriate
parts of the mesh. You can adjust envelopes by
moving their handles. Handles appears as round
shapes on the envelope spline.

1. Go to frame 0.

2. On the Parameters rollout, highlight
BoneSpine01.

3. In the Front viewport, select one of the handles
near the bottom of the outer envelope. The
handle and its cross section turn purple when
they are selected.

4. Move the handle in toward the character’s body
until the outer envelope overlaps about half the
thigh.

5. Move one of the handles near the top of the
outer envelope to make the envelope overlap
the area where the top spine bone will have its
influence.
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6. On the Parameters rollout, select BoneHead.

7. Adjust the head envelopes in the same manner,
so the envelopes overlap the neck area slightly.
Also, move the inner handles along the length
of the bone to reduce the size of the envelope.
(The outer handles along the length of the bone
don’t move.)

Note: When you move the handle for an outer
envelope past its inner envelope, the inner
envelope is automatically reduced in size so it is
always inside the outer envelope.

Test the skinning:

1. Turn off Edit Envelopes.

2. Scrub the time slider to frame 10.

There is now a definite crease at the thigh, and
the thigh itself is no longer bending.
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If you continue to see problems after you adjust
a skin’s envelopes, one way to fix these is to
adjust vertex weights. That technique is shown
in the lesson, Applying Skin to the Alien (page
2–426).

3. Save the scene as my_introrig_skin.max.

You can find a version of this scene in the file
tut_introrig_skin.max.

In this case, you applied the Skin modifier to
just one object. You can also apply it to multiple
objects at the same time.

There are many more adjustments you could
make to the envelopes and vertex weights to
make the mesh deform more realistically. There
are several sample files you can look at to learn
more about rigging:

• You can find this character and rig
structure with completed skinning
and a little animation in the file
tut_introrig_complete.max.

• You can find fully skinned and
animated example of this character
with slightly different rigging in the file
tut_introrig_sample.max. You can also view

the animation from this scene in the file
tut_introrig_sample.avi.

Using Spline IK

Spline IK is a type of IK control that uses a spline
to control a bone structure.

Spline IK can be applied at the time bones are
created, or can be added to the bone structure
afterward.

Create a simple spline IK structure:

1. Reset 3ds Max.

2. Choose Character menu > Bone Tools.

3. On the Bone Tools floater, click Create Bones.

4. On the IK Chain Assignment rollout of the
command panel, choose SplineIKSolver as the
IK Solver, and turn on Assign To Children.

5. In any viewport, create a series of at least six
bones.

When you right-click to end bone creation, the
Spline IK Solver dialog appears.
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6. Change Number Of Spline Knots to 4, and click
OK.

A spline is created in the shape of the bone
structure. On the spline are box-shaped point
helpers.

7. Select and move a box helper.

Moving a helper changes the shape of the
spline, which in turn changes the shape of the
bone structure.

8. Turn on Auto Key.

9. Go to frame 20 and move a box helper.

The bone structure animates according to the
helper’s movement.

Apply IK after bone creation:

1. Load tut_splineik_start.max.

This scene contains a snake with a bone
structure. The Skin modifier has already been
applied to the snake. The snake is frozen so you
can easily select the bones.
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2. In the Top viewport, use Create panel > Shapes
> Line to draw a curvy line. Start the line near
the bottom of the viewport, then draw upward.

Drawing in this manner ensures the line’s first
vertex will correspond to the head of the snake.
The location of the first vertex sets the end at
which the first bone in the IK chain will be
placed. In this case, the first bone in the IK
chain is at the snake’s head.

3. On the Modify panel, apply the Spline IK
Control modifier to the spline.

This modifier creates helpers at each vertex
so you can alter the spline without having to
access the vertex sub-object level. When you
use the method in the previous procedure to
set up Spline IK, this modifier is automatically
applied to the spline.

4. In the Link Types group, choose Link All To
Root.

5. In the Helper Display group, change Size to 40.

6. Click Create Helpers.

Point helpers with a box shape are placed
at each vertex. You can move the helpers to
change the shape of the spline.

7. Select the snake’s head bone (Bone_Head).

8. Choose Animation menu > IK Solvers >
SplineIK Solver.

9. Click the snake’s end bone, then click the spline.

The snake jumps to the spline.
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10.If the snake turns to lie on its side, select the
spline IK control (the cross hairs between the
end bone and its parent). Go to the Motion
panel, and in the IK Solver Properties rollout,
change the Twist Start Angle to –90 or 90.

Now you can move or animate the box helpers
to change the shape of the snake.

Use spline IK with a path constraint:

1. Load the file tut_splineikpath_start.max.

This file contains the snake and a long, curvy
spline. The Spline IK Control modifier has
already been applied to the spline.

2. Select the snake’s head bone (Bone_Head).

3. Choose Animation menu > IK Solvers >
SplineIK Solver.

4. Click the snake’s end bone, then right-click the
viewport to end the process.

A spline IK solver has been added to the bones,
but is not associated with the spline.

5. Select the spline IK control by selecting the
cross hairs between the end bone and its parent
bone.
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6. Go to the Motion panel. In the Spline IK Solver
rollout, click the button under Pick Shape, and
click the spline.

Now that the spline is associated with the
spline IK solver, you have two choices for the
remainder of the setup:

You can use a Position Constraint to constrain
the head bone to the first node (helper) on
the spline. This is what happens automatically
when you pick a spline when you set up
the spline IK solver, as in the two previous
procedures.

You can use a Path Constraint to constrain the
head bone to the spline, which will allow us to
animate the snake along the spline.

The next steps use a Path Constraint.

7. Select the head bone.

8. Choose Animation menu > Constraints > Path
Constraint, and click the spline.

The snake jumps to the spline.

9. If the snake turns to lie on its side, select the
spline IK control and go to the Motion panel.
In the IK Solver Properties rollout, change the
Twist Start Angle to –90 or 90.

The snake is automatically animated moving
along the path, but it slithers backward.

10. Turn on Auto Key.

11.Select the head bone, and go to the Motion
panel.

12.In the Path Parameters rollout, set % Along
Path to 70.

13.Go to frame 100 and set % Along Path to 0.

14.Play the animation. The snake slithers along
the path.
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You can also animate the box helpers on the
spline to further control the animation.

Mirroring IK

It takes a lot of time to set up the rig for an arm
or a leg, and it’d be nice to not have to do all that
work twice. If you follow a few simple rules when
creating the bones and IK structure for a character,
you can set up the IK for one side (an arm or leg)
and then mirror it, and have it work.

In this tutorial you will learn:

• How to mirror bones with IK

• The rules for setting up mirrored bones

Set up the lesson:

• Choose File menu > Open, and open
tut_mirror_ik_start.max from the \tutorials\
character_animation\intro_to_rigging folder.

This file contains a simple leg bones setup.

Simple leg setup

Check the parent space and hierarchy:

1. On the animation playback controls, click
the Play button to play the animation.

The leg assembly takes a short hop.

2. Move the time slider back to frame 0.

You will explore this IK setup a little before you
mirror the IK.

There are two simple rules to follow when
mirroring a character rig with bones and IK.
The first is that the IK chain’s Parent Space has
to be set to Start Joint, not IK Goal.

3. Select either IK chain control (the blue crosses
at the ankle and ball of the foot), and then open
the Motion panel.

4. In the IK Solver Properties rollout, find the
Parent Space group and confirm that Start Joint
is turned on, not IK Goal.
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Tip: If this is not the case, turn IK Enabled off,
change to Start Joint, and turn IK Enabled back
on.

The second requirement is that the root of the
IK chain must be linked to something that
doesn’t have IK on it. You can tell whether this
is true by looking at the Motion panel.

5. Select Bone01, the thigh bone in the structure.

6. On the Motion panel > Assign Controller
rollout, you can see the Transform controller
is IK Control.

7. Now select the Hip Dummy at the top of the
thigh.

In the Assign Controller rollout on the Motion
panel, you can see the Transform Controller
does not say IK.

Rule number two is satisfied. The root is
parented (linked) to something that doesn’t
have IK.

8. In the Left viewport, move the hip dummy up
and down, left and right.

Move the dummy

You can see that the hip dummy is the parent
of the thigh bone.

9. Undo using CTRL+Z until the leg is back in its
original position.

Mirror the leg assembly:

1. Activate the Front viewport and select
everything.

When you mirror, it’s important that you select
the parent of the root bone.

2. On the main toolbar, click the Mirror
Selected Object button.

3. In the dialog that appears, choose Copy so you
create a mirrored clone of the leg.

4. Use the Offset field to move the two legs apart.
Change the Offset to 111.
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Mirrored IK

5. Play the animation.

The bones are successfully mirrored, and the
animation works.

Tip: Be sure to select the entire hierarchy when
you do the mirror. If you have anything that
is constrained to another object, be sure to
include the object that things are constrained
to. Otherwise your mirrored IK will become
confused.

6. Save your file as my_mirror_ik.max.

You can find a completed version of this scene
in the file tut_mirror_ik_finished.max.

Summary

In these lessons, you have learned how to use the
basic tools for creating a character rig. Now you
can try out these tools on your own characters.
You can also do the advanced rigging tutorials to
learn more character rigging techniques.

Creating and Editing
Character Bones
In this tutorial, you’ll create a bone assembly to
match the configuration of an existing character
mesh. To do this, you’ll use several features in
3ds Max, including Bone Tools and Spline IK. This
character is also used in the Character Rigging
tutorial (page 2–349) to demonstrate how to
fully articulate the assembly in preparation for
animation.

Skill Level: Beginner – Intermediate

Time to complete: 1 hour

Features Covered in This Tutorial

• Creating and editing bones

• Assigning a Spline IK solver during bone
creation

Tutorial Files

You can find the files for this tutorial in the
tutorials\character_animation\character_bones
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

Building the Leg Bones

In this lesson, you’ll use the 3ds Max Bones to
create a character’s leg bones.

If you have never created bones before, it is
recommended that you do the lesson Creating a
Bone Structure (page 2–300) in the Introduction
to Character Rigging (page 2–299) tutorial before
doing this lesson.
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Prepare the scene:

1. Open tut_char_bone_file01.max from the
tutorials\character_animation\character_
bones folder.

This character was built standing in what is
known as a neutral or initial pose, with its
arms outstretched and its feet planted a short
distance apart. The initial pose is extremely
practical for rigging and skinning a character.

2. Select the MESH_Character object and
right-click in a viewport to bring up the
quad menu. Choose Freeze Selection in the
upper-right quad.

Note: The Freeze Selection function is also
accessible from the Freeze rollout on the
Display panel.

The mesh turns grey and can no longer be
selected by the cursor. This effectively gets
the mesh out of the way, while maintaining its
visibility for reference during bone creation
and placement.

However, since you will be working
predominately in a shaded view during
the bone-creation lesson, it would also be
helpful if you could partially see through the
“solid” mesh. You will set the mesh object’s
See-Through property to accomplish this.

Unfortunately, because the mesh is now frozen,
it can no longer be selected. There are several
methods to access an object’s properties in this
case. The most obvious way is to unfreeze the
object, set its applicable property, and refreeze
it. Another way, however, is to set the object
property directly using MAXScript. A third
way, and the one you’re going to use, is to set the
object property graphically using Schematic
View.

3. On the Main toolbar, click Open
Schematic View.

Several items, or nodes, are displayed in the
Schematic View window. One of the nodes
is labeled MESH_Character; this is the frozen
character mesh.

4. Right-click the MESH_Character node, and
choose Edit Properties.

5. In the Object Properties dialog > General
tab > Display Properties group, turn on
See-Through, and click OK.

The character is now frozen and partially
transparent. This will allows you to easily see
the bones you create during this lesson.

6. Close Schematic View.
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Create the left leg bones:

In this lesson, you’ll create a total of five bones to
define the left leg: The upper and lower leg bones,
a foot bone, a toe bone, and the toe tip bone.

1. Choose Character menu > Bone Tools to open
the Bone Tools dialog.

2. On the Bone Tools dialog > Bone Tools group,
click Create Bones.

3. Click Min/Max Toggle to display four
viewports.

4. In the Left view, click once at the top of the
character’s thigh, once at the knee, once at the
ankle, once at the midpoint in the foot, and
once at the toe. Right-click to cancel out of
Bones create mode.

In the Perspective view, you’ll see that the
five bones have actually been created directly
between the mesh’s legs. This is because all
objects are created on the current construction
plane. The default construction plane consists

of three interpenetrating planes that intersect at
the world origin. The default grid in each view
represents one of these planes; in the case of the
Left view, the default grid is the YZ plane.

5. In the Front view, select the root bone (the
thigh bone) and move it left to sit inside the
mesh’s left thigh.

6. Moving down the hierarchy, move each bone to
sit inside the appropriate part of the mesh.

Tip: You can press PAGE UP and PAGE DOWN
to move up and down the hierarchy easily. In
some cases, such as when a spinner field is
selected, you might have to activate a viewport
to enable the shortcuts.

7. Select and rotate the foot bone (the third bone
from the top) so that both it and the toe bones
sit flat on the ground as seen from the Front
viewport.

Now would be a good time to rename each bone
for easier identification in future exercises. A
good naming convention helps to organize
the scene in a way that enables fast recall of
scene components. There are no hard rules for
object naming; the general rule of thumb is to
consider that someone else, let alone yourself,
should have easy access to any component of
your scene with minimal browsing.
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8. Select the root bone and rename it
BONE_L_Leg_Upper in the command panel.

The L in the object name refers to the left leg.

9. Moving down the hierarchy, select and name
each bone as follows:

• BONE_L_Leg_Lower

• BONE_L_Foot

• BONE_L_Toe

• BONE_L_Toe_Tip

Create the right leg bones:

You can take advantage of the time invested
making the left leg bones by using the Mirror tool
to construct the right leg bones quickly.

1. Select all the left leg bones.

Tip: You can select the entire leg by
double-clicking the thigh.

2. On the Main Toolbar, change the Reference
Coordinate System to World.

3. Also on the Main toolbar, change the
Use Pivot Center flyout to Use Transform
Coordinate Center.

These two toolbar controls are known as
transform managers. These settings determine
the behavior of certain transform operations
that depend on an object’s (or multiple objects’)
pivot point. Use Pivot Point is the default center
point for single selected objects, whereas Use
Selection Center is the default for multiple
selected objects.

Use Transform Coordinate Center places the
center point at the origin of the specified
reference coordinate system. In the case of the
World coordinate system, this places the center
squarely between the mesh’s legs.

You’ll now use the Mirror tool to copy the left
leg over to the right side.

4. On the Main toolbar, click Mirror
Selected Objects.

5. On the Mirror: World Coordinates dialog >
Clone Selection group, change Clone Selection
type to Copy, and click OK.

You now have a perfect replica of the left leg
bones at the correct position inside the mesh’s
right leg.

Rename the right leg bones:

When you mirrored and copied the left leg bones
to the right side, each bone name was appended
with the number 01. Next, you’ll quickly rename
the bones to reflect their switch to the right-hand
side using the Rename Objects tool. This tool
allows you to intelligently rename any number of
selected objects at once.

1. Select all the bones in the right leg.

2. Choose Tools menu > Rename Objects.

3. Make sure Base Name and Numbered are
turned off. Turn on Prefix, Remove First, and
Remove Last.

4. In the Prefix text field, type BONE_R.

5. Set Remove First Digits to 6, and the Remove
Last Digits value to 2.
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6. Click Rename.

The name of each bone in the right leg has
been changed to indicate that it is now on the
right-hand side of the character mesh. In this
case, the Rename Objects tool first removed the
first six digits and the last two digits of each
name (“BONE_L” and “01”).

Adjust the leg bone properties:

Now you’ll use Bone Tools to change the
appearance of the leg bones. These tools allow you
to adjust the properties of any number of bones
at one time. In this procedure, you’ll use Bone
Tools to add a different color gradient to each leg
for easy differentiation, and to add fins to the foot
and toe bones.

1. Select the entire left leg structure.

2. If the Bone Tools dialog isn’t open, choose
Character menu > Bone Tools.

3. In the Bone Coloring group, click the Start
Color swatch, and choose a light shade of blue.

4. Click the End Color swatch, and choose a dark
shade of blue.

5. Click Apply Gradient.

The left leg bones’ colors now range from light
blue at the upper leg to dark blue at the toe tip.

6. Repeat the process on the right leg, using two
different shades of green instead.

The different bone colors make it relatively easy
to differentiate between the start and end joints,
as well as between the left and right legs, even
when viewed from a distance.

Now you’ll add fins to the foot and toe bones.

7. Select the Foot bone in each leg.

8. In the Bone Tools dialog, expand the Fin
Adjustment Tools rollout. Turn on the Side Fins
and Back Fin settings, and set the Size spinner
for each fin type to 7.0.
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9. Select the Toe bone in each leg and enable the
Side, Front, and Back Fins, setting their Size
spinners to 7.0, 3.0, and 3.0, respectively.

The foot and toe bones now fit more snugly
within the boundaries of the character mesh.
This will be pertinent when you skin the
character (page 2–426) in later lessons.

10.Save your work as my_char_bone_legs.max.

You can also open tut_char_bone_file02.max
to examine the result of this lesson.

Building the Spine

In this lesson, you’ll use the Bones system along
with the Spline IK feature to create the character’s
spine. Spline IK uses a spline shape to constrain a
hierarchy along its length. This technique can be
very useful for creating assemblies such as tails,
snakes, or even hair.

If you are not familiar with the concept of IK
solvers, see the lesson Setting Up IK Solvers (page

2–305) in the Introduction to Character Rigging
(page 2–299) tutorial.

Prepare the scene:

1. Open the scene you saved from the previous
lesson, or open tut_char_bone_file02.max.

Creating the spine will be easier if you first hide
the leg bones. This will prevent the new spine
bones from automatically appending to any
existing bones.

2. Select the leg bones. Right-click to display the
quad menu, and choose Hide Selection.

3. If necessary, click Min/Max Toggle to
display four viewports.

It will be easier to create the spine bones if you
hide the grid and work in a shaded mode.

4. With the Left viewport active, press the G key
to turn off the grid.

5. Change the Left viewport display to Smooth
& Highlights.

Create spine bones using spline IK:

Next you will create the spine bones, and you will
apply a spline IK solver while you create the bones.
Creating the spline IK solver at the same time you
create the bones is easier than creating the bones
alone, then applying the spline IK solver later.

1. In the Create panel > Systems object type, click
Bones to enter Bone creation mode.

2. On the IK Chain Assignment rollout, choose
SplineIK Solver from the IK Solver drop-down
list.

3. Turn on Assign to Children.

Note: The Assign To Children option assigns
the specified IK solver to all newly created
bones. Its accompanying option, Assign To
Root, is active by default, and acts to assign
the IK system to the root node of the selected
hierarchy.
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4. In the Bone Parameters rollout > Bone Object
group, set Width and Height to 5.0.

Since you are creating several bones in a
relatively confined space, a smaller bone size
will help to make each bone more visible.

5. In the Left viewport, create five or six bones
starting at the hips and curving upward to the
base of the neck, then right-click to end Bone
creation mode.

The Spline IK Solver dialog appears with several
options for spline creation. The controlling
spline can either be a Bezier curve, a NURBS
Point curve, or a NURBS CV curve. Depending
on the particular application, each curve has its
advantages. In this case, you’ll use the default
Bezier curve type.

6. In the IK Name text field, change the name to
IK_Spline_Goal.

7. Set Number Of Spline Knots to 5.

Note: The number of spline knots doesn’t have
to coincide with the number of bones, although
that is the default behavior. In this case, five
knots are needed to provide sufficient spline
control that will be established later on in the
rigging tutorial for this character (page 2–349).

8. Make sure that the Create Helpers option is
enabled, and click OK.

The newly created bones are now constrained
to the Spline IK shape. Five helper objects
associated with the spline’s control knots have
also been created. These helpers are used to
control the spline shape and, hence, the spine
hierarchy when the character is rigged.
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Next, you’ll rename the newly created spine
bones to match the previously established
naming convention.

Rename the new objects:

1. Select the spline on the spine, and rename it
SplineIKSpline.

2. Select all bones in the spine, but do not select
the Spline IK shape, or any of the helper objects.

3. Choose Tools menu > Rename Objects.

4. In the Rename Objects dialog, turn on Base
Name, and type BONE_Spine in the text field.

5. Turn on Numbered, and set Base Number and
Step to 1.

6. Make sure all the other options are turned off,
and click Rename.

Now, you’ll do the same for the spine helper
objects. You’ll use the same settings that were

used for the spine bones, but change the base
name.

7. Select all of the helper objects.

8. In the Rename Objects dialog, change the Base
Name to HELPER_Spine.

9. Make sure that all other options are configured
as before, and click Rename.

10.Close the Rename Objects dialog.

Change the coloring and add fins:

Next, you’ll use Bone Tools to change the colors
of the spine bones.

1. Select all the bones in the spine.

2. Choose Character menu > Bone Tools.

3. In the Bone Tools dialog > Bone Coloring
group, apply a color gradient of your choosing
to the selected bones.

4. In the Fin Adjustment Tools rollout > Fins
group, turn on Side Fins, Front Fin, and Back
Fin, and set their Size values to 7.0, 3.0, and
7.0, respectively.

5. Select the last bone (at the neck) and turn off
all fins.
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Feel free to adjust each bone’s fin size and taper
to your liking. Also, you can adjust each bone’s
position relative to one another along the spline
by clicking the Bone Edit Mode button and
moving any spine bone.

You can also unhide the leg bones if you want to
check their relationship to the spine.

6. Save your work as my_char_bone_spine.max.

You can also open tut_char_bone_file03.max
to examine the result of this lesson.

Building the Arms

In this lesson, you’ll use the Bones system to create
the character’s arm bones.

Prepare the scene:

1. Open the scene you saved from the previous
lesson, or open tut_char_bones_file03.max.

You should hide all the bones from previous
lessons to prevent any newly created bones
from automatically appending to the existing
bones. To minimize clutter in the scene, it’s also
recommended that you hide the spine helper
objects and spline IK goal as well.

2. Select the bones, the spline IK goal, and the
helper objects. Right-click to display the quad
menu, and choose Hide Selection.

3. If necessary, click Min/Max Toggle to
display four viewports.

Create the left arm bones:

1. In the Create panel > Systems object type, click
Bones to enter creation mode.

2. In the Bone Parameters rollout > Bone Object
group, set Width and Height to 5.0.

3. Turn off Assign To Children.

Tip: With the arms, you will use the HI solver
later on. When you plan to assign a HI solver to
bones, you will usually create the bones without
a solver first, then apply the solver after the
bones have been created. This allows you to
create a chain of several bones but apply the HI
solver to only a few of the bones.

4. In the Top view, create three bones by clicking
first at the center of the shoulder blades, second
at the left shoulder, third at the left elbow, and
fourth at the left wrist, right-clicking twice to
cancel out of bone creation mode and create
a bone tip.

In the Perspective view, you can see that the arm
bones were actually created at ground level due
to the default placement on the construction
plane. Next, you reposition the bones to fit into
the mesh.
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5. In the Front view, select the root bone and
move it upward, placing it directly in between
the character’s shoulder blades.

6. Moving down the hierarchy, move each bone
to place it within the boundaries of the mesh’s
left arm.

7. Starting at the root, rename each bone as
follows:

• BONE_L_Arm_Clavicle

• BONE_L_Arm_Upper

• BONE_L_Arm_Lower

• BONE_L_Arm_Wrist

Note: The term clavicle is used to denote the
shoulder bone. In human anatomy, the clavicle
is the shoulder bone.

Create the wrist twist bones:

A lower arm bone can twist to rotate the wrist
without rotating the elbow. Now you will create
additional bones in the arm to simulate this type
of movement.

1. In the Top view, create a single bone with a
Width and Height of 5.0. Create it with the same
general alignment as the BONE_L_Arm_Lower
object. The bone should be one-quarter of the
length of BONE_L_Arm_Lower.

2. Delete the new tip bone from the newly created
twist bone; DO NOT delete the original wrist
bone

3. From the Main toolbar, use the Align tool
to align the Center X, Y, Z position and rotation
of the new bone to the BONE_L_Arm_Lower
object.

4. Click Select And Move, and change the
Reference Coordinate System to Local.

5. Move the bone down one-quarter of the way, so
it starts in the second quarter of the arm.

6. Hold down SHIFT and drag a copy to start at
the end of the first bone.

7. Repeat to create a third copy that starts at the
end of the second bone.

8. Link each newly created bone to the lower arm
bone (BONE_L_Arm_Lower).

9. Rename the bones to BONE_L_Twist_
Wrist01, BONE_L_Twist_Wrist02, and
BONE_L_Twist_Wrist03.

Create the hand bones:

Here, you’ll create the hand and finger joints. In
order to make sure the bones line up with the
wrist, you can click the lower arm bone. The
cursor changes to a cross hair, indicating that the
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new bone will be parented to this bone, and will
start at the end of it.

1. Create a one-bone chain and tip that goes from
the wrist to the start of the middle finger.

For this character rig, the hand bones will not
be connected hierarchically to the arm bones.
The rationale behind this is explored in detail
in the character rigging tutorial (page 2–349).

2. Select the newly created hand bone, and
click Unlink Selection on the Main toolbar.

3. Rename each bone to BONE_L_Hand and
BONE_L_Hand_Tip.

4. Create bones for each of the fingers and thumbs
by creating four separate chains, one for each
new finger, and then link the start of each finger
and thumb chain to the hand bone.

5. Move the finger and thumb bones up to the
proper height.

6. Adjust the colors and fins on the hand and
finger bones, as needed.

7. Rename each finger bone to BONE_L_
Finger1_01, BONE_L_Finger1_02, and so on.

8. Rename the thumb bones to BONE_L_
Thumb_01, and so on.

Mirror the left arm assembly:

Now that the left-hand arm assembly is completed,
it’s time to create the right-hand counterpart by
using the Mirror tool again.

1. Select all bones in the arm, wrist, and hand of
the left arm assembly.

2. On the Main toolbar, change the Reference
Coordinate System to World.

3. On the Use Pivot Center flyout, choose
Use Transform Coordinate Center.

4. On the Main toolbar, click Mirror
Selected Object.

5. On the Mirror: World Coordinates dialog, set
Clone Selection type to Copy, and click OK.

Now you have a mirrored copy of the left arm
assembly in its correct position.

6. Change the colors of the right arm bones to
green to distinguish them from the left arm.

If you like, you can unhide the other bones to
see their relationship to the arms.

7. Save your work as my_char_bone_arms.max.

You can also open tut_char_bone_file04.max
to examine the result of this lesson.
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Building the Neck, Head, and Hair
Bones

In this lesson, you’ll finish the bone structure by
creating the neck, head, and hair bones.

Prepare the scene:

1. Open the scene you saved from the previous
lesson, or open tut_char_bone_file04.max.

2. Select all the bones, helpers, and IK chains, and
hide them.

3. If necessary, click Min/Max Toggle to
display four viewports.

Create the final bones:

1. On the Create panel > Systems object type,
click Bones to enter creation mode.

2. In the Bone Parameters rollout > Bone Object
group, make sure the Width and Height values
are set to 5.0.

3. Make sure that the Assign To Children check
box is off.

4. In a side viewport, create two smaller neck
bones, then one bone for the entire head, and
then five more bones for the hair.

5. Right-click twice to end bone creation mode.

6. Use the Bone Tools dialog to create a color
gradient for the bones and add fins as desired.

7. Rename the bones to the following:

• BONE_Neck01

• BONE_Neck02

• BONE_head

• BONE_Hair01

• BONE_Hair02

• BONE_Hair03

• BONE_Hair04

• BONE_Hair05

Look at the bone structure:

At this point, all of the basic bone structure for
the rig is done. You can now unhide all objects to
show all the bones you created.

1. Right-click any viewport to display the quad
menu, and choose Unhide All.

2. Save your work as my_char_bone_
complete.max.

You can also open tut_char_bone_
complete.max to examine the result of this
lesson.

Summary

In this tutorial, you learned to create a bone
structure for a fully articulated character.

To learn to create a character rig from this bone
structure, see the tutorial Creating Complex
Character Rigs (page 2–349). If you have never
rigged a character before, you can do the rigging
lessons in the Introduction to Character Rigging
(page 2–299) tutorial before rigging this character.

To learn to skin this character, see the lesson
Applying Skin to the Alien (page 2–426).
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Complex Character Rigs
In this tutorial, you’ll create a character rig for
the skeletal structure created in the Creating and
Editing Character Bones (page 2–337) tutorial.
This character rig would be suitable for use in
a production environment, where an animator
would need to be able to animate the character in a
variety of ways with a minimum of work.

To do this tutorial, you will need to be familiar
with character rigging tools. It is recommended
that you do the Introduction to Character Rigging
(page 2–299) tutorial before doing this tutorial.

Tip: When you rig a model, 3ds Max performance
can sometimes slow. If you notice this happening,
toggle between one viewport to four, and back
again (press ALT+W twice). This will clear
viewport buffers. If the slowness persists, try
typing gc() in the MAXScript Mini Listener, then
press ENTER. This clears memory. It also clears
the Undo buffer, so be sure you don’t want to
undo any actions before you enter this MAXScript
command.

Skill Level: Intermediate – Advanced

Time to complete: 2 hours

Features Covered in This Tutorial

• Creating custom attributes

• Using scripts to control body motion

• Using quaternion rotation values

Tutorial Files

You can find the files for this tutorial in the
tutorials\character_animation\character_rigging
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

Rigging the Legs and Feet

In this lesson, you’ll begin rigging the character
from the previous Character Bones tutorial.

You’ll create IK chains and custom objects for
controlling the leg and feet, so you can simply
move or rotate the control object to affect the entire
leg rather than pose each leg bone individually.
You’ll also add custom attributes and wire them to
the IK chains so you can animate a foot roll just by
changing a parameter on the Modify panel.

If you are unfamiliar with the concept of IK chains,
do the lesson Setting Up IK Solvers (page 2–305)
in the Introduction to Character Rigging (page
2–299) tutorial before doing this lesson. If you are
not familiar with the concepts of custom attributes
and wiring, see the lesson Wiring a Custom
Attribute (page 2–317).

Open the scene file:

• Open char_rigging01.0.max from the
\tutorials\character_animation\character_
rigging folder.
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This file contains the character mesh and all its
bones. It is similar to the result of the Creating
and Editing Character Bones (page 2–337)
tutorial.

Create the IK chains:

In rigging the character, you want to make it
possible to control each part of the foot. You’ll
want to be able to roll the heel upward to start a
walking motion, then roll the toe upward when
the heel reaches a certain point. To create these
controls, you will need an IK chain for each
individual foot bone.

1. In a Front or Perspective viewport, select
the entire Left leg by double-clicking
upperLegLBONE. Then right-click, and choose
Hide Unselected from the quad menu.

This allows you to easily work with just the left
leg.

2. Select the upperLegLBONE only.

3. Choose Animation menu > IK Solvers > HI
Solver, and then click footLBONE, the bone
just below the ankle.

An IK chain is created. You can see the new
crosshair, which is the IK goal object, and a line
drawn from the start of the IK chain from the
thigh to the ankle. This shows which bones are
in the IK chain.

If you want to try out the IK, select the IK goal
(the crosshair at the ankle) called IK Chain
01 and move it around. The leg and foot will
move. Be sure to undo any moves you make.

4. Name the IK chain ankleLIKGOAL.

5. Select footLBONE.

6. Create another HI solver that ends at
toeLBONE, the very next bone, to create
a one-bone IK chain. Name this IK chain
ballLIKGOAL.

7. Create a third IK chain from toeLBONE
to toeTipLBONE. Name this IK chain
toeLIKGOAL.

These one-bone-length IK chains let you keep
the feet planted solidly, but also let you produce
other types of motion, such as heel lift and toe
rotation.

8. With toeLIKGOAL still selected, go to the
Motion panel > IK Solver Properties rollout >
IK Solver Plane group, and set Parent Space to
IK Goal.

Setting Parent Space to IK Goal will cause the
bone in this IK chain to rotate only when the IK
goal is rotated. If you leave Parent Space set to
Start Joint, the foot bone will rotate when you
swivel the knee, which is undesirable.



Rigging the Legs and Feet 351

9. If setting the Parent Space to IK Goal causes the
bone to rotate, change the Swivel Angle to 90,
180 or 270 to make the bone sit correctly.

10.Select ballLIKGOAL and make the same
change.

The file char_rigging01.1.max contains the
scene with the IK chains on the left leg.

Create the foot control shape:

When animating the character, the animator will
need to be able to move the entire foot at once. You
will create a shape to place around the foot and use
as a control for the entire foot. A shape takes up
little memory and does not render, so it’s ideal for
use as a control object.

1. On the Create Panel, choose Shapes
as the object type, then click NGon.

2. In any viewport, drag to create an NGon with
a radius of 30.0 units.

Next, you’ll align the NGon to the foot.

3. With the NGon selected, on the Main
toolbar, click Align Selection. Align the
shape to the XYZ position and orientation of
ballLIKGOAL, the IK goal at the ball of the foot.

4. In a side view, move the NGon down to the
ground (0.0 on the Z-axis).

Tip: You can do this easily by typing 0.0 in the
Z entry field of the Transform Type-in at the
bottom of the screen.

5. Now rename the shape to footLCTRL, and give
it a blueish wireframe color.

6. Right-click the NGon, and choose Convert To
> Convert To Editable Spline.

This converts the shape into a basic spline
shape so you can edit it.

7. In the Modify panel, go into Vertex
sub-object level and adjust the shape to match
the shape of the foot, as seen in the following
illustration.

Warning: Don’t perform a Non-uniform scale at the

object’s base level, as that will cause objects that

are linked to it to skew during animation. However,

you can scale at the Editable Spline sub-object level

without causing skewing.

The file char_rigging01.2.max shows the Spline
Shape control curve created.

Take a look at the IK rig you’ve created. Feel free to
select and move any of the IK Goals you created;
just make sure you undo any changes before you
continue.

• If you move the first IK goal, ankleLIKGOAL,
you’ll see that the foot stays in place fairly well,
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until you pull it too far. You can use this goal
to make the heel go up, while the ball and toe
stay planted on the floor.

• If you move the second IK goal, ballLIKGOAL,
you see that the rest of the foot tries to stay
planted. However, if you select this and the
third IK goal together, you see that the heel of
the foot stays planted but the main foot can
move or rotate. You’ll use these goals together
to make the foot roll on the heel.

• Finally, if you only select the third IK goal,
toeLIKGOAL, you’ll see that the toe will rotate,
which is what you will use that for.

For the goals to give the control you want, the real
motion that needs to occur is for the goals to move
in an arc.

You’ll get this effect by creating some helper
objects. By linking the IK goals to the helpers,
you can rotate the helpers to make the foot move.
Then you’ll also link the helpers together in such
a way that you get all the moves and control you
want. You’ll link all the helpers to the control shape
you made so you can move the entire foot at once.
(Note that if you move all three IK goals, the entire
foot moves).

In planning this rig, you should think about where
you want the foot to rotate. You’ll need a helper at
the heel so the foot can roll back on the heel. You’ll
need something at the ball so the heel can lift up
and rotate around while keeping the ball planted.
You’ll also need a second pivot at the ball so that
you can rotate the toe at the toe start there. And
you’ll also want a pivot at the toe tip so that the foot
can lift off while the toe still sticks to the ground.

You will start by creating the helpers you need.

Create the helpers:

1. Continue with your current file, or open
char_rigging_01.2.max.

2. On the Create panel, turn on
Helpers.

3. Turn on Point. Then, on the Parameters
rollout, turn on Box and turn off Cross.

This helps you distinguish the helpers from the
IK goals, which already look like crosses.

4. Click near the top of the Perspective viewport
to create a Point helper.

Note: It’s important to use the Top or Perspective
viewport to do this, since the Point helper
objects’ axes should be aligned to the world
XYZ coordinates. If you switch to a local
coordinate system, you can see that a helper
created in these viewports will be aligned to the
world, whereas a helper created in a different
view will have a different local alignment. Later
on, you’ll align the helpers anyhow; however,
it’s important to remember this fact when
rigging.

5. Create two more point helpers for a total of
three.

6. Align each helper to the XYZ position
of an IK goal. One should align to the
toeLIKGOAL, one to the ballLIKGOAL, and
one to the ankleLIKGOAL.

Tip: It might help to work in a wireframe view.

7. Create a fourth helper by selecting the middle
helper, at the ball, and SHIFT+scaling it up a
bit to create a copy.

Make sure you use Uniform scale, and not a
Non-uniform scale.

8. Select the helper at the ankle, and move it down
to the level of the other helpers.

9. Now you should rename the helpers. Name
the one at the ankle heelRotateLHELP. Name
the smaller ball helper heelLiftLHELP. Name
the larger ball helper toeRotateLHELP. Then
name the toe-tip helper to toeLiftLHELP.
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The file char_rigging01.3.max has the helpers
properly created and named.

At this point, you’ll link the IK goals to the helpers
to get the control you need to rotate the helpers.
You’ll also link the helpers together so everything
works.

Link the IK goals to the helpers:

Tip: In these steps, it is probably easiest to first
select the parent object, then press H to choose
the child object by name.

1. Select the last IK chain at the tip,
toeIKGOAL, and link it to the larger ball helper
called toeRotateLHELP.

Now you can make the toe rotate by rotating
toeRotateLHELP.

2. Select the first IK chain, ankleLIKGOAL,
and link it to the smaller ball helper
heelLiftLHELP.

Now you can make the heel roll by rotating
heelLiftLHELP.

3. Link ballIKGOAL to heelLiftLHELP.

This will help keep the foot bone stable when
the heel lifts up.

4. Select toeRotateLHELP and
heelLiftLHELP, and link them both to
toeLiftLHELP.

This allows the entire foot to pivot at the toe tip.

5. Link toeLiftLHELP to heelRotateLHELP.

This allows the entire foot to pivot with the heel
on the ground.

6. Finally, link heelRotateLHELP to the
footLCTRL shape you created earlier.

This lets you move the entire foot at once.

You can open char_rigging01.4.max to see all
the helpers and goals properly linked up. You
can test the rig by moving footLCTRL to move
the entire foot. You can also rotate each helper
up and down on the X-axis to see how each part
will give you the control for the foot.

At this point, you could directly manipulate the
helper object yourself, which would give you a lot
of freedom. However, you’ll simplify the rig by
creating an attribute and slider that will give you
the control to roll the foot from heel to toe. You’ll
create another attribute and slider that will let you
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rotate the toe. Both of these will be assigned to
footLCTRL, so that you need to animate only a
single thing.

You’ll start by creating the attributes. Then
you’ll use parameter wiring with some simple
MAXScript expressions to drive the rotation of the
helpers from the control attributes.

Add custom attributes:

1. Select footLCTRL.

2. Apply the Attribute Holder modifier to the
control.

3. From the Animation menu, choose Parameter
Editor.

The Parameter Editor dialog is displayed.

4. In the Parameter Editor dialog > Attribute
rollout > UI Type group, change Name to Roll.

5. In the Float UI Options rollout > Range group,
set From=–100.0 and To=100.0. You’ll use the
negative side to make the foot rotate back on
the heel, and the positive side to make it rotate
forward ball to toe.

6. In the Attribute rollout, choose Selected
Object’s Current Modifier from the Add to
Type drop-down list, and click Add.

7. Add another attribute that also goes from
–100.0 to 100.0, and call it toeRotate.

The file char_rigging01.5.max shows the
control with the attributes added.

Currently, changing the attributes values won’t
do anything, since you haven’t connected, or
“wired,” the spinner to anything yet. The next
procedure will connect these attributes to the
helpers’ rotations.

Wire attributes to helper rotation:

1. Set your Animation playback range from
–1000 to 10000.

Certain controllers, such as wire controllers,
expressions and others, will operate only over
the time range you specify. While you can go
into Track View to adjust this after the fact,
it’s much easier to simply create the controller
with a large enough time span to cover any
animation you might do.

The default time span for such controllers is the
current time range. By setting the time range to
a really large range, such as the –1000 to 10,000
range used here, you’ll be sure not to have any
problems later.

2. Select footLCTRL.

3. Right-click it, and choose Wire Parameters
from the Transform (lower-right) quadrant of
the quad menu.

4. On the pop-up menu, choose Modified Object
> Attribute Holder > Custom_Attributes >
Roll.

5. Click heelRotateLHELP. On the new pop-up,
choose Transform > Rotation > X Rotation.

The Parameter Wiring Dialog appears.

6. Change the expression in the lower right entry
area to degtorad(Roll).

The degtorad expression is necessary because
the foot’s X rotation uses a value in radians, not
degrees. A radian is approximately 57 times
larger than a degree. For more information
on the degtorad function, see the lesson
Wiring a Custom Attribute (page 2–317) in
the Introduction to Character Rigging (page
2–299) tutorial.

7. Click the right arrow, and click Connect.

Leave the Parameter Wiring dialog open, but
move it aside so you can try out the new control.
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Use an expression to better control the rotation:

1. Try changing the Roll value.

Now you have a problem. First, the foot rotates
down when Roll is positive. You want it to
remain flat when the value goes higher than
zero. Second, it rotates too far back with a value
of 100. A value of about –60 shows a more
realistic limit of movement.

2. In the Parameter Wiring dialog, change the
wiring expression to degToRad(0.6*Roll), and
click Update.

Here, you have told the script to multiply Roll
by 0.6, which limits the rotation to the 60 to –60
degree range.

Now you need to restrict the rotation to Roll
values less than 0.

3. You can do this with a basic “if ” statement. In
the Parameter Wiring dialog, change the wiring
expression to if (Roll < 0) then degToRad
(0.6*Roll); else 0.0.

4. Click Update, and close the Parameter Wiring
dialog.

The “if ” statement is a simple way to do
something based on a condition. In this case,
you are saying, “If the Roll is less than 0, then
do the regular calculation of 0.6 times the
Roll value, and convert the result to degrees.
Otherwise, just return the value of 0.0 for the X
rotation of the helper”.

In this way, the Roll attribute will make the foot
roll backwards when you go negative and (for
now) won’t do anything when you go positive.

Next, you’ll get the foot to roll forward on the
ball for the range of 0 to 50 degrees.

Wire the foot to roll forward:

1. Select footLCTRL again, and wire the Roll
attribute into heelLiftLHELP’s X rotation.

2. In the Parameter Wiring dialog, choose a
one-way wire.

3. You already know you’re going to need to
convert degrees to radians, so set the expression
to degToRad(Roll), then click the right arrow
and click Connect.

4. Try playing with the Roll attribute on the foot.

Things work pretty well; however, when Roll is
negative the helper is rotating, which makes the
ball helper rotate down. You’ll fix the negative
problem by adding an “if ” statement like you
did earlier.

5. Change the expression to: if (Roll > 0) then
degToRad(Roll); else 0.0 and click Update

Now things are stable when you go backwards.
However, you want to make the ball rotate from
0 to 50 degrees, and then hold at that value. You
can do that by expanding and limiting your “if ”
statement a little more, and using an “if-else if-
else” type flow.

6. Change the expression to if (Roll > 50) then
degToRad(50.0); else if (Roll > 0) then
degToRad(Roll); else 0.0. Click Update and
close the dialog.

The ball roll now works properly. For Roll
values over 50, you stop and convert the value
of 50 to radians, so the foot rotation stops at 50
degrees. If Roll is less than 50 but still greater
than 0, you increase the rotation up to that
point, as before. And if Roll is negative, the
helper rotation stays at 0.
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The final wiring for this roll is to make the foot
rotate up at the toe tip.

7. Select the footLCTRL object again.

8. Wire Roll to the X Rotation of the toeLiftLHELP
object.

Once again, create a one-way wire.

9. Enter the following expression: if (Roll > 50)
then degToRad (1.5*(Roll-50)); else 0.0, and
then click Connect.

10.Close the Parameter Wiring dialog.

Try playing with Roll values. As the Roll value goes
negative, the foot rolls back on the heel. As the foot
goes forward, it first rotates only on the ball. Then,
at 50 degrees, it shifts its rotation to the toe tip.

The expression works by causing the toe tip roll
to occur only when the roll is greater than 50,
which is when the ball rotation stops. You want to
rotate smoothly from 0, so you take “degToRad”
of “roll-50”: this produces values from 0 to 50, so
that the toe rolls up from zero. However, the final
high end of 50 isn’t really enough. So you take that
value and multiple by 1.5 times, so it goes from
0 to 75 degrees instead.

Note: Here are a couple of interesting notes for
animation as well. If you just click and drag the
attribute spinner, the value changes from –100 to
100 at a default rate. However, if you CTRL+drag,
the value changes faster. If you SHIFT+drag, the
value changes slower, in smaller increments. This
can be useful when animating, or when testing the
attribute out during rigging.

For a final wire, you’ll connect toeRotate to spin
the toe helper.

Wire an attribute to spin the toe helper:

1. Select footLCTRL.

2. Wire the toeRotate attribute to
toeRotateLHELP’s X rotation.

Choose a one-way wire.

3. Change the expression to:
degToRad(toeRotate), and click
Connect.

4. Close the Parameter Wiring dialog.

Changing toeRotate lets you rotate the toe itself
from –100 to 100 degrees, which is plenty.

At this point, the main foot control is done.

The file char_rigging01.6.max shows the Left foot
control with all the attributes and helpers wired
together.

In the next procedure, you’ll add a Swivel target
to control the knee.

Add a swivel target to control the knee:

Typically, the animator needs to manually decide
where the knee is pointing. Even if the character’s
foot is pointed in or out, the knee can be pointed a
different direction. The easiest way to do this is to
create an object that you can move. The position
of this object will cause the knee to try to point
towards it.

1. In the Top viewport, create a
Rectangle with Length and Width both equal
to 10.0.

Give it a blue wire color.

2. Move this shape in front of footLCTRL and at
knee height. Rename it kneeLCTRL.
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3. Select ankleIKGOAL. In the Motion Panel >
IK Solver Properties rollout > IK Solver Plane
group, click the Pick Target button currently
labeled None.

4. Click kneeLCTRL.

5. Link kneeLCTRL to footLCTRL.

Now try moving kneeLCTRL around. As you
do so, the knee tries to aim towards the control,
even though the feet are nicely locked down.
The effect is more noticeable when the leg is
bent. Now, fix the pivot point for footLCTRL.

6. Select footLCTRL.

7. In the Hierarchy Panel > Adjust Pivot rollout,
click Affect Pivot Only.

This allows you to move the pivot point of the
object, without affecting the children or object
itself.

8. In a side view, move the pivot to where the
ankle is.

This gives you a more natural animation
control.

With the swivel target parented to the foot, you
can rotate the foot and the knee and foot all at
one time. You can adjust the knee as needed
using the kneeLCTRL on top of that. You can
also animate and move the foot, and use the
attributes on it to do basic foot roll and toe
rotation.

9. Turn off Affect Pivot Only.

Add a helper for the leg as a whole:

Now you’ll add a point helper to the top of the
entire leg bone structure. This gives you a nice
layer of abstraction, should you decide to do
anything odd with the leg, and is also a good way
to keep things clean.

1. Create a point helper in the Top viewport.
Rename it legStartLHELP.

2. Align it to the position and orientation of the
upperLegLBONE.

3. Link upperLegLBONE to the helper.

The left leg is done. You can see how the feet stay
planted if you select and move legStartLHELP.
Later on, you’ll make this helper a child of the
hips and spine so the body works together.

The file char_rigging01.7.max shows the entire
left leg done. If you want, you can repeat the
leg rigging process described above for the
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right leg. If you would rather skip this process,
char_rigging01.8.max has both the left and
right legs finished.

Now that you have the basic working of both legs
complete, you’ll finish the legs off with two more
controls. One is the groundCTRL that will be used
to adjust both feet at the same time. The other is
a placementCTRL that eventually will control the
entire character.

Add character placement controls:

1. In the Top view, create an NGon.

This shape will be created world-aligned, at a
height of 0.

2. In the Transform type-in fields, enter 0.0
for the X position. Then move its Y position so
it is centered between the feet.

Tip: To set a spinner to 0 or 0.0, you can
right-click its up/down arrows.

3. Adjust the radius so the NGon surrounds both
feet controls.

A value of about 56.0 works well. You can also
adjust it to have a larger number of Sides, such
as 8, for more detail and points on the control.

4. Rename the shape groundCTRL.

5. Create another NGon shape in the Top
Viewport.

6. Enter an exact position of 0, 0, 0 in the
Transform type in fields, to move it to the world
origin.

7. Increase the radius to enclose the character. A
value of 90.0 works well.

8. Name this second shape placementCTRL.

Now you’ll parent these controls together.

9. Link both footLCTRL and footRCTRL
to the new, smaller groundCTRL shape.

10. Link groundCTRL to placementCTRL.

Normally, you’d also link the top leg start
helpers to the placement, but you’ll be linking
those to the spine later on.

For now, the feet and knee controls work the
legs. You can also control both legs together
by moving the ground control. Later on, the
placement control will cause not only the feet,
but the entire character to move, which is useful
for getting the character to some position and
rotation in a scene before you start animating it.
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Now let’s look at something important. Right now,
the controls are where we want them. What if
later on, after animating the character in various
ways, we want to go back to this position and these
settings? You can use the skin pose, which lets you
store and later retrieve the position, rotation, and
scale of the selected objects. You’ll set a skin pose
for this character right now.

Set the skin pose:

1. Select all of your created shape control
objects: the feet, knee, ground and placement
controls. The names of these all end in CTRL:
footLCTRL, footRCTRL, kneeLCTRL,
kneeRCTRL, groundCTRL, placementCTRL.

2. Hold down the ALT key and right-click to view
the animation quad menu.

3. On the Pose (lower-left) quadrant, choose Set
As Skin Pose. Answer Yes to the verification
dialog.

The skin pose is now set.

At this point, you can now move the controls
however you want. Rather than having to
undo any moves and rotations, you can select

the control object, ALT+right-click, and then
choose Assume Skin Pose. Try it out.

4. Select any control and move it around, leaving
it in a new position and rotation.

5. ALT+right-click and choose Assume Skin Pose.

Result: the control moves back to where you
had rigged it.

Important: Custom Attributes are not stored in

Skin Pose. This means that if you adjust the Roll or

toeRotate settings, you will have to manually set

those attributes back to zero to restore the skin pose.

Control-Object Positioning and “Zeroing
Out” Transform Values

There is one more important issue: the default
values for the control objects. In other words,
which numeric X, Y, and Z position and rotation
values they have. In 3ds Maxand most other
programs, these values depend on the parent
object. The child object’s position and rotation is
based on a relative change from the parent object.
For example, let’s say you have two objects, A and
B. Object A is at X=10 units, and object B is at X=
15 units. If neither object has a parent, then the
“world” is the parent and the X value shown for
A is 10, and the X value shown for B is 15. These
values are relative to the world origin (0,0,0).

Now suppose you link object B to object A. At this
point, object B is the child of A. Object B’s values
will be relative or offset from those of object A. In
this case, A’s X position still equals 10. But object
B’s X position now displays as 5, because it is +5
units away from its parent.

We can use this information to our advantage. If
you are in Move or Rotate mode and choose Parent
as the reference coordinate system, then Transform
type-in values will show you the values in parent
space. In fact, these values will be identical to the
ones you will see in the Motion panel and in Track
View when you are animating.
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Most animators prefer to have everything in Track
View start at 0,0,0. However, if you take the foot
control as an example, you’ll note that its position
is not 0,0,0 but three other numbers. It would be
nice if we could zero it out.

By zeroing out an object’s position, the animator
can reset that position by entering zeroes while
using Track View or the Motion panel. (This is in
addition to using Assume Skin Pose, as described
above.) And values relative to zero are easier to
read in the Track View Curve Editor.

The way to do this is to create a helper object
aligned to the object whose transform values we
want to “zero out.” By inserting the helper into the
hierarchy, and linking the real object to the helper,
the real object’s values will be zero because they
are not offset from those of the helper.

You’ll do this next for the left foot control.

Zero out the left foot control:

1. Create a new Point Helper object.
Set the options to have only a Center Marker
and Axis Tripod. Set the size to 30 so you can
see it easily.

2. Align the helper to the XYZ Pivot Point
(not Center) position of footLCTRL. It will
move to the ankle, which is where the foot’s
pivot is.

3. Name the helper footLZEROHELP.

Since footLCTRL is already a child of
groundCTRL, so you’ll make this helper a child
of groundCTRL as well.

4. Link footLZEROHELP to groundCTRL.

At this point, if you look at the values for the
helper and the foot control, they are identical.
This is because they have the same parent, and

are at the same place. Now you’ll zero out the
foot control by making it a child of the helper.

5. Link footLCTRL to footLZEROHELP.

6. Turn off the Axis Tripod option for the helper,
leaving on the Center Marker only. This will
make it less intrusive visually.

7. Now select footLCTRL. On the Main toolbar,
choose Parent as the reference coordinate
system.

The values are all zero. The same values will be
shown in the Motion panel and Track View.

You can repeat this process for all the other
control shapes. In the future, these lessons will
tell you to “zero out” controls. Do this the same
way: create a helper, align it to the object, insert
it into the hierarchy, then make the control
shape a child of the helper. Remember, though,
that this depends on the helper object already
being in the hierarchy. So the object you are
zeroing needs to have a parent already.

The final leg rig setup can be loaded from
char_rigging01.9.max. Later on you’ll hide all
of the helpers and goals so that the animator
doesn’t have to see them.
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Rigging the Spine

In this lesson, you will concentrate on articulating
the spine assembly.

You’ve already created the bones with the splineIK
goal. Unhide everything, in order to show the
spine curve, helpers, and IK goal. Then, hide
everything else except the placementCTRL and
these spine-related objects, to help see what you’re
doing.

Since you already have the IK working, and can
move the five splineIK helpers around, you only
now need to simplify the controls. Right now, you
can move each helper around, but rotating them
doesn’t do much. This is because bone rotation is
based on the spline, so moving the points causes
the bone to rotate.

However, what about twisting? Rotating in a top
view doesn’t cause the bones to twist. This is
because splineIK has a swivel “twist” value that
you have to animate in order to get the twist. Let’s
take a look at that.

Examine the spline IK goal:

1. Open char_rigging02.0.max from the
\tutorials\character_animation\character_
rigging folder.

2. Select the splineIK Goal object.

3. On the Motion panel > IK Solver Properties
rollout, adjust the Twist Start Angle and Twist
End Angle values.

As you can see, the first one controls the entire
chain twisting, while the second one only
affects the top, smoothly ramping down toward
the bottom. Unlike the HI IK setup, there is no
option for a swivel target object. So, you won’t
be able to use a control like a knee control as
you did earlier. Instead, you’ll set up a Script
expression to tie the twist into the control
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objects we’ll make, so that rotating our control
object drives the twist as one would expect.

You’ll now set up our basic control structure and
then link the helper objects to the controls. You’ll
want three basic controls:

• One control will allow you to move and rotate
the entire spine system at once. This is the basic
hip control that the animator will use to move
the character around.

• The second control will be another one located
at the hips, but that will give the animator
independent hip control to move just the lower
half of the spine. This allows the character to
swing the hips sideways, without affecting the
overall motion of the animation.

• A control for the top of the spine will allow the
animator to move and bend the spine around
from there as well.

Set up the basic spline controls:

1. On the Create panel > Shapes section, click
Star. In a Top viewport, draw out the star shape.
Click again to adjust how pointy the star is,
pick whatever you want: a radius of 32 and 22
works fine. Change points to 8 if you desire a
different looking shape, and rename the star
shape hipCTRL.

2. Align the hipCTRL to the first bottom helper,
spineHelper01. This will get the hips to be at
the proper position and orientation for the
bottom of the spine.

3. Create an NGon with 6 sides. Set the radius
smaller than the hipCTRL radius, but still
outside of the body geometry. A value of 20
works well. Color the new shape as you want,
and rename the shape spineBotCTRL.

4. Align this spineBotCTRL shape to the
hipCTRL.

5. Duplicate the spineBotCTRL by moving it and
holding down the SHIFT key. Rename the
duplicate spineTopCTRL.

6. Align the spineTopCTRL to the top helper
spineHelper05.

Now you will link the controls together.

7. Link both the spineTopCTRL and the
spineBotCTRL to the hipCTRL. This way, the
hipCTRL can move them both together as one,
or they can move independently.

8. Link the hipCTRL to the placementCTRL. This
way, the placement will let the entire character
move later.

9. Using the techniques learned earlier, zero out
these new spine and hip controls.

10.Press ALT+right-click and use the quad menu
to set the controls to Set As Skin Pose. The
software now remembers this as the default
pose for the controls, as earlier.

The file char_rigging02.1.max shows the
controls properly created and linked.
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The next step is to link the point helpers to the
two spine controls. The top helpers will go to the
top control, and the bottom ones to the bottom
control. However, the middle control needs
something that is somewhere in-between.

While you could do a simple Offset Point and
Offset Orient constraint that is halfway between
the top and bottom helpers that is close, but not
exactly what we want. The problem is that we
want that middle helper to appear to be parented
to both controls. With a simple point and orient
constraint, when we rotate the control, the helper
would indeed rotate; however, it would not move.
If you think about it, if the middle helper was
linked to the top control, when the top control was
rotated, the helper would move in an arc. The
same thing would happen if it was linked to the
bottom control.

In order to accomplish this, you’ll create three
helpers. Two helpers will be placed generally at
the position of the middle splineIK helper. Each
will be linked to a top or bottom control. Then
the third helper will be constrained between these
two; that way, it will be constrained to objects that
indeed are picking up the proper position and
orientation as if they were linked to the controls.
Then you’ll link the real splineIK middle helper to
the newly constrained one.

You’ll start by doing the simple linking of the top
and bottom helpers.

Link the helpers to the spline controls:

1. Link the bottom two helpers, splineHelper01
and splineHelper02 to the spineBotCTRL.

2. Link the top two helpers, splineHelper04 and
splineHelper05 to the spineTopCTRL.

3. Now create three Point helper objects. Any
options you want are fine, as long as you can
easily see the objects. Rename the helpers
to offsetTopHELP, offsetBotHELP and
betweenHELP.

4. Align the offsetTopHELP and the
offsetBotHELP to the middle spineHelper03
object.

5. In a side view, move the offsetTopHELP and
offsetBotHELP back a bit so you can see what
you are doing. You may need to use the Select
By Name or Selection Floater dialogs to find
and select them.

6. Move the offsetTopHELP up a bit vertically.
Move the offsetBotHELP down a bit vertically.
This way they are separated so you can easily
see and work with them, but are still relatively
close to behind the middle helper.

7. Link the offsetTopHELP to the spineTopCTRL.
Link the offsetBotHELP to the spineBotCTRL.
Now, when you rotate either spine control,
these offset helpers move and rotate properly
because they are parented to the control.
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8. Select the betweenHELP control. From the
Animation menu, choose Constraints >
Position Constraint.

9. Click the offsetTopHELP. The between helper is
now moved and constrained to the top helper.

10.With betweenHELP still selected, choose
Animation menu > Constraints > Position
Constraint. This time, click the offsetBotHELP
object. The helper is now constrained evenly,
with a 50/50 split between the two other helpers.
This way, it will always stay between them.

11.Now, create two more constraints to each of
the top and bottom helpers, this time using
an Orientation constraint to each. This way,
betweenHELP will also rotate 50/50 between
the two other helpers.

12.Finally, link the middle spine helper,
spineHelper03 to the betweenHELP object.

At this point almost all the control is in. You can
take the hipCTRL and move and rotate it, to adjust
the entire spine. You can move and rotate each of
the spine controls as well. For example, to make
the character lean forward, you can move the
spineTopCTRL forward and then also rotate it
down. However, twisting spine controls don’t do
anything, because the twist is controlled by the
IK Goal twist attributes. You’ll fix that soon by
creating an expression for the twist angles using
the Script controller.

It’s important to understand how the Script
controller works as it plays a major role throughout
this tutorial and others following it. Within the
Script controller, you can create expressions which

will change the value of the affected controller (i.e.
the controller onto which the Script controller is
applied). You can build these expressions in the
same way you would create a custom attribute,
by referring to values from other nodes and their
controllers.

Establishing these references can be easily done
using the Script controller variable toolset.
Variables are used as placeholder to store specific
data such as simple constant numbers (like a float
or an integer), nodes, which represent objects
in the scene, or animation tracks (such as the X
Position controller of a node).

When a variable is created, it defaults to a Constant
type. You can then choose to change its value or its
type by clicking the appropriate button.

Add controls to twist the spine:

1. Select the spineBotCTRL object, and click
Select and Rotate on the Main toolbar.

2. Set the Reference Coordinate System to Parent.

Note: Remember everything is always relative
to the parent. You will want to see which is the
twisting axis. By going to “parent” mode, you
will see the true axis that are used for the object.

3. Verify that the axis constraint is the Z-axis,
assuming you created everything in a top view
and followed the built-in splineIK creation.

If it’s different, just note that, and change Z to
whichever is the twist axis for the rest of the
spine setup steps below.

4. Select the splineIKGOAL object. This is the
blue IK goal object at the top of the chain. Go
to the Motion panel.
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You can see all of the regular spline IK items
listed. In addition, any object shows the
controllers here as well.

5. Expand the Assign Controller rollout to see the
list.

Note: Every animatable value in 3ds Max has a
controller assigned. A controller is the item that
stores all the keys that you animate, or holds
other data that describes how the values change
over time. The typical controller for the twist
angles is just a changing floating point number,
or a Float controller.

You will change the Twist Angle controller
into a Float Script controller, so that you can
override it with a MAXScript expression.

The first two items listed in the rollout under
the main transform items are Twist Start Angle
and Twist End Angle, which is exactly what you
want to adjust.

6. Make sure your time range is from –1000 to
10,000, or any other large range as mentioned

earlier, so that the script controller you create
will operate, even after frame 100.

7. Click Twist Start Angle to highlight it. Click the
Assign Controller button above the list. Choose
Float Script from the list of possible controllers,
and click OK.

The Script Controller dialog appears. You can
always restore this later by right-clicking the
item in the list and choosing Properties. By
default, the script simply contains the original
value for the controller, which was zero.

8. Enter bot in the Name field and click Create.

The new variable is automatically added to the
Variables list.

9. With the variable highlighted, click Assign
Track.

The Track View Pick dialog opens, listing the
contents of your scene.

10.Expand the Objects hierarchy until you
locate the Z Rotation controller track of the
spineBotCTRL node. Highlight it and click OK.
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The selected rotation track is now being
referred to by your variable. The variable
assignment information under the Description
window should read:

Target: $spineBotCTRL.rotation.controller.’Z
Rotation’

11.Create a second variable named hip. Assign
it to the Z Rotation controller track of the
hipCTRL node using the steps above.

The variable assignment information should
read:

Target: $hipCTRL.rotation.controller.’Z
Rotation’

12.Create a third variable named root. Assign
it to the Z Rotation controller track of the
placementCTRL node using the steps above.

The variable assignment information should
read:

Target: $placementCTRL.rotation.controller.’Z
Rotation’

13.In the Expression window, type the following
script:

Note: See this topic in the online User Reference
for sample MAXScript code in this location that
could not be formatted for print.

This tells the Script controller to add up the
rotation controller for all three controls, and
the convert the result from degrees to radians.

14.Click Evaluate.

You entire script is analyzed and any
encountered errors are prompted.

15.
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At this point, if you rotate spineBotCTRL,
hipCTRL, or placementCTRL, the entire spine will
twist. This is as desired, except you don’t want the
top to twist when you only use the spineBotCTRL.
So we’ll take this into account when you create the
expression for the Twist End Angle.

Create an expression for the twist end angle:

1. Select the splineIKGOAL object.

2. Click Twist End Angle in the Motion panel to
highlight it.

3. Click the Assign Controller button above the
list.

4. Choose Float Script from the list of possible
controllers to assign. Click OK.

The Script Controller dialog appears.

5. Create a variable named bot. Assign it to the Z
Rotation controller track of the spineBotCTRL
node using the steps from the previous
procedure.

6. Create a second variable named top. Assign
it to the Z Rotation controller track of the
spineTopCTRL node using the previous
procedure.

7. Type the following script:

Note: See this topic in the online User Reference
for sample MAXScript code in this location that
could not be formatted for print.

This script is similar to the one you entered
earlier for the bottom controller. It gets the
rotation in Z for each object, in radians. Finally,
it takes the top value and subtracts out any
rotation you did on the spine bottom controller.
By subtracting rotation, you effectively “twist
backward” the top twist value, which will make
the top appear to remain stationary, even when
you twist the bottom controller, thereby giving
you independent control of the top and bottom
twist with each controller.

8.

The file char_rigging02.2.max shows the spine
with all the basic controls in and scripted. You can
try moving the placement of the hips and spine
controls and rotating them to see how they work.
Make sure you reset things back to zero, or undo
any moves you have made before continuing.

At this point, you could leave the spine as-is.
However, for one more extra feature, you will add
a script to each bone, starting with the second
bone, in order to let the spine “stretch”. You’ll add
an attribute to the top spine control to allow the
animator to specify whether or not the spine will
be stretchy.

Add attribute for stretchy spine:

1. Select the spineTopCTRL object.

2. Add the Attribute Holder modifier if you have
it installed.
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3. From the Animation menu, choose Parameter
Editor.

4. In the dialog, name the attribute stretchable.

5. Choose Selected Object’s Current Modifier
from the drop-down list.

6. In the Float U.I. options, set the Range from 0
to 100 (the default is 100).

7. Click Add to add the attribute.

Wire bones to stretchy attribute:

Now you’ll wire each bone to use this value, as well
as the spline path length to determine stretching.
To do this, you’ll have to use a MAXScript
command that gets the length of the spline path,
the splineIKSpineCurve object. We’ll do the
following for each bone starting with the second,
and up to and including the last tip bone.

1. Open the MAXScript Listener window.

2. Type curveLength $splineIKSpineCurve and
then press the ENTER key on the numeric
keypad. This executes the command.

A number will be returned. This number is
the length of the curve path. Write down the
number, because you’ll use it in an expression
coming up. In the sample files, the number is
47.6604.

3. Select the Second bone, spine02BONE. On
the Motion panel, open the Assign Controller
rollout.

4. Expand the FK-Sub Control part of the tree.
Expand Position to show each X, Y, and Z
position controller.

5. Click the X Position controller.

The X position of the bone determines where it
is along its length. By moving the bones in the
X axis, you’ll effectively stretch the or squash
the bones.

6. Make sure you have a large time range for your
timeline, as mentioned earlier.

7. Click the Assign Controller button above the
list. Choose Float Script, and click OK.

Note: The default value for the bone position is
not zero. We’ll need to use that as well.

8. Create a variable named origBone.

9. Click Assign Constant.

A dialog opens. Enter 11.2722 in the Value
expression field.

Note: This value may vary depending on the
chosen bone.

10.Click Evaluate, then OK.

Tip: You can use the Script controller’s
Description window to add comments if
needed.

11.Create a second variable named origLen and,
using the same steps, assign it a constant of
47.6604.
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Note: This value may vary depending on the
chosen bone.

12.Create a third variable named pct.

13.Click Assign Track and, in the Track View Pick
dialog, highlight the stretchable attribute of the
spineTopCTRL node.

The variable assignment information should
read:

Target: $spineTopCTRL.modifiers[#Attribute_
Holder].Custom_Attributes.stretchable

14.Create a fourth variable named splIKSpineCrv.

15.Click Assign Controller and, in the Track View
Pick dialog, highlight the splineIKSpineCurve
node.

The variable assignment information should
read:

Object: $splineIKSpineCurve

16.Enter the following expression, replacing your
own default curve length from earlier, and
repositioning your own default initial bone
value into the proper places:

Note: See this topic in the online User Reference
for sample MAXScript code in this location that
could not be formatted for print.

Let’s take a look at the expression. The script
looks at the current or new curve length for the
spline curve. As the animator moves the spline
controls around, this will update because the
spline curve is assigned to the splIKSpineCrv
variable.

Next, the script calculates the new bone
position. There are two parts to the expression:

• The first part is simply the original bone
position. We multiple it by 1.0 minus the
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percentage normalized to 1. So that when
the user takes the “stretchable” down to 0,
we revert back to the default bone length.

• The right half of the line is what does the
actual stretching. We take the original bone
position and multiple it by the “New Length”
divided by the “Orig Length”. This tells
us how much the spline has stretched. By
increasing the bone position by the same
percentage, the bone will move with the
spline movement. We then multiply that
by the “percent” normalize to 0–1, so that
this only occurs when the animator has the
“stretchable” attribute up.

You can test this now by moving the
spineTopCTRL. The second bone will move
out, causing the first bone to appear to stretch.
You can slide the “stretchable” attribute
from 0 to 100 to blend between allowing and
disallowing the spine to squash and stretch.

Repeat the above process now for each bone,
replacing the proper origBone value for each.

The file char_rigging02.3.max has the spine rig
with all of the controls and scripts put in.

At this point, the hip and spine controls all move
and rotate properly. However, check the leg rig.

Link legs to spine control:

1. Unhide all.

2. Try moving the hips or bottom spine control.
The result is the legs are still not linked yet.

3. Undo any move changes you made.

4. Select both of the leg start dummies, the
legStartLHELP, and legStartRHELP Point
helpers, and link them to the spineBotCTRL
(not the hips).

This way, when you move the hips, the legs
stay connected, and if you offset or swing the
spineBotCTRL, the legs also stay connected.

In the next section, you’ll work on the arms. In
order to make the most stable arms, you’ll need
to anticipate some slight motion due to spline
IK on the top bone. For example, move the
spineBotCTRL object around. As you do so, look
at the topmost spine bone. It moves around a bit,
which is OK, but it also rotates just a little. It’d
be nice if you were able to parent the arms right
to the top bone, and have it still move, or placed
there, but rotate only when you rotate the upper
spine control. That will make the arms more
stable, as you might adjust the lower spine a bit
when animating, but you will want the upper spine
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rotation locked. This is a perfect case where you
can easily create a point helper and position and
orient constrain it to two different things.

Constrain the Point helper to the spine:

1. Create a new point helper.

2. Set the point helper size to 25.

3. Rename it spineLinkHELP.

4. Create a Position constraint to the very last
spine tip bone, spine06BONE.

5. Create an Orientation constraint to the top
spine control, spineTopCTRL.

You now have a helper that you can link the
head and arms to later, one that is properly
positioned at the end of the spine chain, and
that rotates only when you specifically rotate
the hips or top spine control.

Note: The spline IK setup created here will
allow you to animate the character’s spine for
natural bends and rotations. However, curling
the spine to a great degree will cause the spine’s
bones to rotate or flip unexpectedly.

The file char_rigging02.4.max has the final
spine rig, and shows the spine and legs all
working together.

Rigging the Arms

In this lesson, you’ll continue rigging the character
by creating an arm rig. You’ll set up IK chains for
the shoulder and arm, and include the ability to
switch the hand to be “relative” to the upper spine,
or “locked” to the world. That way, you can easily
keep the hands moving with the character, or lock
them down if the character has to push against a
wall or other object.

In this lesson, you will rig just the left arm. You
can repeat the steps to rig the right arm in the
same fashion.

Prepare the scene:

1. Open char_rigging03.0.max from the
\tutorials\character_animation\character_
rigging folder.

2. Hide all objects except the arm and hand bones,
and placementCTRL and spineLinkHELP.

Create the HI solver for the arm:

The first step in rigging any limb is the creation
of IK solvers.

1. Select clavLBONE. Choose Animation menu >
IK Solvers > HI Solver, and click the next bone
in the chain, upperArmLBONE.

This creates a one-bone-length IK chain for the
clavicle.

2. Name the new IK chain clavLGOAL.

3. Create another HI solver from
upperArmLBONE to wristLBONE, the
last tip bone on the arm.

4. Name the IK chain handLGOAL.

Set up the overall arm control:

Next, you will link the entire arm chain to a
starting point helper that is aligned with the
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clavicle bone. This will allow you to move the
entire arm by moving the point helper.

1. Create a point helper anywhere in the scene.

2. Rename the point helper to armLStartHELP.

3. Align armLStartHELP to clavLBONE.

4. Link clavLBONE to armLStartHELP.

At this point, the basic IK chain goals let
you control the shoulder and arms. The file
char_rigging03.1.max shows the file at this
stage. The hand is still detached for now; you’ll
take care of that later.

Create controls for the shoulder, hand, and elbow:

Now you’ll create the real animator controls for
the shoulder and hand, plus a control to point the
elbow. The elbow control works similarly to the
knee control described in the lesson Rigging the
Legs and Feet (page 2–349).

1. Create a shape to use as a shoulder control.
Name the shape shoulderLCTRL

Tip: A rectangle shape with a size of 15 x 15
works well as a shoulder control.

2. Align the shape to the clavLGOAL.

3. If necessary, rotate the shape so it surrounds
the arm, rather than lies flat upon it.

4. Create a 6-sided NGon shape with a radius of
15.

5. Align the NGon to the handLGOAL. Rename
the NGon to handLCTRL.

6. Create a third shape for the elbow swivel
control. A 10 x 10 rectangle works well.

7. Align the shape to the lowerArmLBONE, which
starts at the elbow.

8. Rename the shape to elbowLCTRL.

9. Slide the elbowLCTRL shape backwards a bit
behind the character.

10.Change the color of all the controls to some
shade of blue, or whatever color you prefer for
the controls.

To make the controls work, you’ll start by linking
the basic IK controls together. You’ll also link the
main hierarchy to the upper body as well. The
hand is a bit more complicated, so you’ll do that
afterwards.
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Link the basic IK controls together:

1. Link clavLGOAL to shoulderLCTRL.

2. Link both shoulderLCTRL and
armLStartHELP to spineLinkHELP, the helper
you made when you finished the spine.

3. Select the handLGOAL IK goal.

4. In the Motion panel, click the Pick Target: None
button and then click elbowLCTRL to make
that object the swivel target control.

This will cause the elbow to always point in the
direction of elbowLCTRL.

5. Link handLGOAL to handLCTRL.

6. Link elbowLCTRL to spineLinkHELP.

7. Zero out all the control shapes except for the
hand, using the techniques discussed earlier.
The hand will be taken care of later.

8. Set all the control shapes to Set As Skin Pose .

You can now move the shoulder control to
make the character shrug or reach. The elbow
control can move around as well to let the
animator adjust the position of the elbow. The
file char_rigging03.2.max shows the file with
the controls in place.

For the hand control, we made the IK Goal a child
of the hand. However, as mentioned earlier, we’d

like the hand to be able to be either locked to the
placementCTRL of the character, which usually
doesn’t move and is therefore “locked” to the
world, or to have the hand automatically move
with the spine, so that even though it is IK, it will
still function a bit like FK. As a result, the animator
won’t have to constantly move the hand around
when the character walks or moves away from its
default position.

This means we need the hand control to switch
between “local”, (relative to the spline) or “world”
(locked down to the placement). To accomplish
this, you’ll create two target helpers. One will
be linked to the upper spine link helper, so that
when the body/spine of the character moves, this
will move locally as well. The other helper will
be linked to the placement, so that it remains
locked. Finally you’ll create a third helper that will
blend between the two via a simple Position and
Orientation constraint.

You’ll also create an attribute called localWorld
on the hand control that will drive the constraint
weights, so that as the weights for the “local”
constraints go up, the other goes down, and vice
versa, letting us blend that third helper smoothly
between relative or locked motion. Finally, you’ll
link the hand control to that helper so that the
hand will automatically inherit local or world
motion.

Create local and world hand controls:

1. Select the handLCTRL.

2. Add the Attribute Holder modifier.

3. Add a custom float attribute called localWorld
that goes from 0 to 100, to the object’s current
modifier.

4. Create three Point helper objects, each with
a different size of 10, 15, and 20. Align the
helpers with handLGoal.
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5. Rename the helpers to localLHELP,
worldLHELP, and tweenLHELP.

6. Link localLHELP to spineLinkHELP, the
top spine helper.

7. Link worldLHELP to placementCTRL.

This links the local and world helpers together.

Constrain the tween:

Next, you’ll constrain the tween helper between
the two helpers.

1. Select the tweenLHELP object.

2. Use a Position Constraint to constrain
tweenLHELP to both the local helper,
localLHELP, and the world helper,
worldLHELP. Do so in that order, so that the
local helper is the first constraint target.

3. Use Orient Constraint to constrain
tweenLHELP to both the localLHELP and
worldLHELP. Do so in that order, so that the
local helper is the first constraint target.

Now tweenHELP defaults to a 50/50 split
between the two position and orientation
targets. Next you’ll wire up the attribute you
made to drive from “local” to “world” as the
attribute goes from 0-100.

Wire attribute to drive from local to world:

1. Select handLCTRL.

2. Right-click to bring up the quad menu and
choose Wire Parameters.

3. Select the custom attribute you added. Click
the tweenLHELP helper with the rubber band.

4. Choose the object’s Transform > Position >
Position Constraint > Position Weight 0. For
each constraint, the constraints were added in
the order 0, 1, 2, and so on; “local” was added
first with a weight of 0.

5. Choose a one-way connection by clicking the
right arrow.

6. The default expression is localWorld. However,
you want “local” to be 0 and “world” to be 100.
Since you are driving the local constraint right
now, you want to reverse this value, so that
when the attribute is at 0, the constraint weight
is at 100. To do this, change the expression to
100 – localWorld and press Connect.

7. While the dialog is up, you can also wire in the
“world” position constraint. On the right-side
list, click Position Weight 1 to wire the second
constraint weight.

8. Choose a right arrow again for a one-way
connection.

9. This time leave the expression as localWorld,
since you will want the attribute’s 0-100 value
to exactly drive the 0-100 weight increase for
the world target.

10.Click Connect.

Now repeat this process, except choose the
Orientation Constraint instead of the Position
one. You can either close the wire dialog and
repeat what you did, or just scroll down in the
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right-side list to add the 100 – localWorld
for the Orientation Constraint 0 weight and
the localWorld script for the Orientation
Constraint 1.

To see the constraint work, you adjust the spine
and see what the helpers do.

Adjust the spline:

1. Do an Unhide By Name and unhide the
spineTopCTRL.

2. Rotate the spineHelper a bit from left to right.
As you do, the localLHELP target goes along,
while the worldLHELP helper stays locked.
In addition, the tween helper also moves,
since it currently driven by the attribute which
defaulted to 0 for local.

3. Select the handLCTRL and adjust the
localWorld attribute. As you do, you can see
that the tween helper smoothly blends between
the “locked” location and the “local” position
relative to the spine.

4. After seeing that this works, undo all these
changes to reset the rotations back to the
rigging pose.

Now you’ll parent the hand control to the tween
dummy.

5. Link handLCTRL to tweenLHELP.

6. Zero out handLCTRL with the technique
explained earlier.

Now you test this with the arm working.

7. Select spineTopCTRL and rotate it. As you do,
the arm goes with it, since it is in “local” mode
(localWorld equals 0).

8. Leaving the spine rotated, adjust the localWorld
attribute. As you do, the hand will smoothly
blend back to a “locked” state. This will be
wherever the world helper is.

9. Leaving localWorld at a 100 value (“locked”
state), adjust spineTopCTRL. The hand stays
locked even though the spine is moving.

10.Adjusting placementCTRL still moves the
entire character, which is good.

11.Undo any move changes to go back to the basic
rigging pose, and save your work. The file
char_rigging03.3.max has the basic controls for
the IK setup.

Set up the wrist twist bones:

Before you move onto the hands, you’ll set up the
extra “wrist twist” bones that you created earlier.
The wrist twist bones will be controlled by another
custom attribute. Using this control, the animator
can rotate the twist bones so that they smoothly
ramp more and more rotation down the chain
towards the hand. This way, if the hand is twisted,
the arm can smoothly blend to it after skinning.

1. Select handLCTRL.

2. To the object’s current modifier, add a custom
float attribute called wristTwist that goes from
–360 to +360.

3. Using Wire Parameters, wire the wristTwist
attribute to the X Rotation of the first wrist twist
bone, wristTwistL1BONE. Choose a one-way
connection.

4. As you learned earlier, you’ll want to change
the attribute value that represents degrees into
radians. You’ll also want it to rotate only a
percentage of the entire value. You”ll use a 25%,
50%, and finally 75% for each bone down the
chain, For the first bone, enter the following
script expression: degToRad wristTwist*0.25.

5. Click Connect.

Repeat this process for each bone, changing
the value to 0.50 for the second bone, and then
0.75 for the third wrist twist bone. The file
char_rigging03.4.max shows the file with the
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twist bone wired together and the basic arm
working.

Repeat this arm process for the right arm.

As an option, you can rotate the right arm
control so that the local rotations of each arm
are similar for the animator. If you do this, you
might need to set both the “hand” and “clav”
IK Goal options to Parent Space: Start Joint to
prevent the arm chain from flipping. Rotate the
arm start dummy by 180 in the same direction
to account for this.

The file char_rigging03.5.max shows the final
arm chain for the left and right arms.

Connect the hands to the arms:

If you try moving and rotating a hand control,
you’ll see that you can move the control away from
the end of the arm. The arm then tries to “reach
out” to get to the control. While the rotation of
the hand control should eventually control the
rotation of the hand itself, you cannot parent the

hand directly to the control. If you did, the hand
and end of the arm would separate when you
moved the control too far away.

Rather than forcing the animator to make sure the
hand control never gets too far away from the arm,
you can use constraints to avoid the problem. In
this lesson, you use Point Constraint to constrain
the hand to the last arm tip bone, and then use
Orientation Constraint to constrain it to the actual
control. The hand will then stick to the end of
the arm, but rotate as needed based on the hand
control.

1. Hide the helper objects so it is easier to see the
hands and arms.

2. Select handLBONE.

3. Choose Animation menu > Constraints >
Position Constraint to constrain handLBONE
to the last arm-tip bone, wristLBONE.

4. On the Motion panel, click Keep Initial Offset
in the Position Constraint rollout.

5. Choose Animation menu > Constraints
> Orientation Constraint to constrain
handLBONE to the handLCTRL.
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6. On the Motion panel, click Keep Initial Offset
in the Orientation Constraint rollout.

By using the Keep Initial Offset options, you get
the proper position and orientation you want,
but retain the initial bone position and rotation
for the hand, which you don’t want to adjust.

At this point, the handLCTRL can now move
the IK arm around, and the hand follows. If you
rotate handLCTRL, it also rotates the hand, as
intended. If you pull the handLCTRL too far
out, the hand still maintains the rotation you’ve
set, but the point constraint keeps it properly
tacked onto the end of the arm.

7. Repeat this process with the right hand. The
file char_rigging04.1.max shows the completed
rigging.

In a more complex rig, you might also drive the
finger bones with some custom attributes. You
can do this with wiring, just as you did with
the toe rotations and wrist twist bones. In the

sample files, you’ll find a more complete rig.
However, this tutorial leaves the finger bones
as controls that the animator would have to
animate directly, instead of creating attributes
or controls for them.

Rigging the Head and Neck

For the head, neck, and hair, it’s usually easier to
animate them using a simple FK approach. To do
this, you’ll create some basic curve controls, parent
them together, and then parent the bones to the
controls.

Set up the lesson:

• Open char_rigging05.0.max from \tutorials\
character_animation\character_rigging folder.

Create basic curve controls:

1. Hide everything except the top spineLinkHELP
and the spineTopCTRL.

2. Create an NGon with a radius of 10.

3. Align the shape to the first neck bone,
neck1BONE.

4. If the aligned shape is vertical, you might want
to rotate it 90 degrees to make it flat. It is easiest
to do this in the Local rotation coordinate
system.
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5. Rename the NGon to neck1CTRL.

6. Create a second NGon a little larger and aligned
to the neck2BONE. Rotate it as needed to make
it flat. Rename it neck2CTRL.

7. Create another larger control and call it
headCTRL. Align it to the head bone and make
it flat.

8. Repeat this process for each of the four hair
bones, naming your controls hair1CTRL,
hair2CTRL, and so on. You do not need one for
the last tip bone.

The file char_rigging05.1.max shows all the
controls created in these steps.

Now you’ll link everything together to make the
animation work. To do this, each bone will be
parented to the control above it that has the similar
name and position. Then each control will be
parented back to the previous one.

Link bones to controls:

1. Link the neck1CTRL to the spineLinkHELP
dummy. This will attach the first neck control
to the spine motion.

2. Link the neck1BONE to the neck1CTRL. Link
the neck2CTRL to the neck1CTRL.

3. Link the neck2BONE to the neck2CTRL. Link
the headCTRL to the neck2CTRL.

4. Link the headBONE to the headCTRL. Link the
hair1CTRL to the headCTRL.

5. Link hair1BONE to hair1CTRL. Link
hair2CTRL to hair1CTRL.

6. Link hair2BONE to the hair2CTRL. Link
hair3CTRL to hair2CTRL.

7. Link hair3BONE to hair3CTRL. Link
hair4CTRL to hair3CTRL.

8. Link hair4BONE to hair4CTRL. Zero out all the
controls, and Set their states as the Skin Pose.

The file char_rigging05.2.max shows the all
controls and bones linked together.

At this point, if you rotate the neck or head
bones, everything below rotates as well. If you
rotate the spine, it rotates everything above.
However, you usually want the neck and head
to be “independent.” That is, even if you rotate
the upper body/spine, you don’t want the neck to
rotate. To keep the rotations separate, you turn off
rotation inheritance.
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Turn off rotation inheritance:

1. Select the neck1CTRL.

2. Go the Hierarchy panel and click Link Info.

3. Turn off Inherit for Rotate X, Y, and Z.

Any basic adjustment or tilt of the spine will
now leave the head facing straight ahead, which
is useful most of the time, especially when
animating walks. As a consequence, however,
you will always have to animate the neck or
head to make it rotate as the character turns
around.

If you wish, you can also make the headCTRL
independent, allowing the neck to rotate while the
head maintains its orientation.

The file char_rigging05.3.max shows the final
head and neck rig.

Rigging the Eyes

At this point, the character’s body rig is nearly
done. Next you’ll add some controls to handle the
eyes.

Set up for this lesson:

1. Open char_rigging06.0.max from the
\tutorials\character_animation\character_
rigging folder.

2. Unhide the head and neck controls and bones,
the placement control, and the body and eye
meshes so you can inspect the eyes. You also
might want to freeze the body mesh to make
your work easier.



380 Chapter 7: Bones & IK

Right now, each eye mesh is perfectly round. The
eyelids are also round and are located exactly at
the eyeball location. Because of this, you can easily
rotate the eyeball mesh or the eyelid, and things
stick together perfectly. The pupil is simply linked
to the eye. However, the eye socket itself is taller
than it is round.

This means the eyes need to be deformed to fit
the socket, while still being able to rotate without
intersecting. If you simply scale up the eyes, it
won’t work; you’ll simply have changed the model.
What you want is for everything to rotate first, and
then be deformed after the rotations have taken
place.

Fortunately, an easy and extendable way to do
this is with the FFD space warp. Space warps are
deformers that occur after all mesh and transform
operations have taken place.

Before flattening the eyes, you’ll set up a basic
look-at system. This will give you a control an
animator can use to make the eyes look this way
and that.

Set up the look-at system:

1. In the Left or Right viewport, create a Donut
spline shape. Radius settings of 5 and 10 work
well. Rename the shape to eyesCTRL.

2. On the Modify panel in the modifier stack,
right-click the Donut listing and convert the
donut to an Editable Spline object.

If you like, you can use the Vertex sub-object
level to work with the corner points and make
the control look more like an eye.

3. Position the eyesCTRL shape well in front of
the head.

4. Link the eyesCTRL to the placementCTRL.

5. In the Front viewport, create two text shapes,
an L and an R, both with a Size of about 10.

6. Rename the shapes to eyeLCTRL and
eyeRCTRL.

7. Link both the eyeLCTRL and eyeRCTRL to
the larger eyesCTRL.

8. Align the eyeLCTRL to the left eyeBallL mesh.
Align the eyeRCTRL to the right eyeBallR
mesh.

9. Now slide forward both the eyeLCTRL and the
eyeRCTRL so that they are centered in a Left or
Right view on the eyesCTRL.

10. Zero out the controls and assign the Skin Pose
for them.

You now have two eye targets that are directly in
front of each eye. You also have a master control
that will easily move both of them around. The
file char_rigging06.1.max shows the created
controls.
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Next, you’ll create helpers at the eye positions that
will “look at” the targets. You’ll add a Look-At
controller/constraint to each helper so they aim at
the target controls. And then, you’ll link the eyes
to the helpers so the eyes rotate.

Create look-at targets:

1. Create two point helpers.

2. Rename them to eyeLAimHELP and
eyeRAimHELP.

3. Align each to the respective eye ball mesh.

4. Select eyeLAimHELP. Choose Animation
menu > Constraints > LookAt Constraint.
With the rubber-band connector, click the left
eyeLCTRL as the target.

5. Repeat this process by selecting eyeRAimHELP
and having it look at eyeRCTRL.

6. Now link the eyeBallL mesh to eyeLAimHELP.

7. Link the eyeBallR mesh to eyeRAimHELP.

At this time, both helpers are looking at their
respective targets. By moving the master
control eyesCTRL, you can get both eye
helpers to track at once. By moving each L or
R eye target control independently, you can
get the eyes to cross or go walleyed. Having
independent controls also helps if the character
looks extremely far to one side, and you need
to shift one of the pupils back so that it doesn’t
intersect the face.

The file char_rigging06.2.max shows the basic
eye targets completed.

Next, on the eyesCTRL shape that moves both
eyes, you’ll create two custom attributes to control
the rotation of the lids. Then you’ll wire these
controls into the eyelid rotations.

Wire the eye controls:

1. Select eyesCTRL.

2. Add the Attribute Holder modifier, if you
desire.

3. Add an attribute called eyeLidL that goes from
–360 to +360 to the object’s current modifier.

4. Repeat this and call the second attribute
eyeLidR.

5. Right-click and choose Wire Parameters from
the menu.

6. Wire the eyeLidL attribute into the X Rotation
parameter of eyeLidL.

7. In the Wire dialog, click the right arrow for a
one-way connection.

8. Change the expression to degToRad eyeLidL
and click Connect.

9. Repeat this process to wire the eyeLidR attribute
into the X Rotation parameter of the eyeLidR.

The file char_rigging06.3.max has the
eyesCTRL with the two custom lid attributes
created and wired into the eyelids.
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At this stage, everything is good, except the eyes
don’t move with the head, and they don’t fit the
eye socket well.

Configure the eyes:

1. Choose Create panel > Space Warps. From
the drop-down menu, choose Geometric
Deformable. Click FFD Box.

2. Draw an FFD box in a viewport.

3. Align the FFD box to the left eyeBallL mesh.

4. Set the Length, Width and Height of the FFD
to the 25, 25, 25.

5. Rename the FFD box to eyeLFFD.

Repeat this process for the right eye.

Aligning the FFD to the eye ensures that the
FFD is centered around the eye meshes. The
25x25x25 size fits the eye mesh with a little
room, so you can be sure the entire eyeball and
lid will deform inside of it.

The file char_rigging06.4.max shows the
completed FFDs.

Next you’ll assign the eye meshes to the FFD,
link the FFDs and eye geometry to the head, and
deform the FFDs so the eyes fit the body mesh
better.

Bind eyes to FFD:

1. Select all the eye meshes for the left eye,
eyeLidL, eyeballL, and pupilL.

2. Click Bind To Spacewarp on the Main toolbar.
Click and drag from the selected meshes to the
eyeLFFD space warp.

This will bind the meshes to the space warp
FFD. You can verify this by selecting one mesh.
On the Modify panel, you will see the FFD
binding at the top of the modifier stack.

3. Repeat this process for the right eye.

Now you need to link the FFDs and the topmost
eye geometry to the head. The eyeballs are already
parented to the aim helpers. So you will link the
aim helpers, the lids, and the FFDs to the head.
You’ll use an in-between helper to ensure the lids
and FFDs don’t rotate oddly when linked.

Link the FFD to the eye:

1. Create a point helper and align it to the eyeLidL
mesh.

2. Rename it to eyeParentLHELP.
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3. Select the eyeLAimHELP, the eyeBallL
mesh, and eyeLFFD. Link them to the
eyeParentLHELP helper.

4. Link the eyeParentLHELP to headCTRL.

5. Repeat this process for the right eye.

The file char_rigging06.5.max shows all the
eye components linked properly to the head
control, with the look-at targets working.

For the final step, use the FFD sub-object level to
move and adjust the FFD points so the eyeball is
elongated vertically, and better fits the eye socket.
You might want to apply a MeshSmooth modifier
to the body mesh with iterations set to 1; this will
help you see how to fit the eyes into the socket. The
file char_rigging06.6.max shows the eyes properly
linked and set up.

For a more advanced rig, you could duplicate the
eye FFD space warps and create morph targets.
Then you could apply the Morpher modifier to the
original FFD and use the copies as targets to get
different eye shapes. You could also apply Morpher
on the body mesh to get eyebrow deformations,
then wire the two morphers together so that when
the brows move, the eyes do as well.

Rigging Wrist Twist

Currently, if you want to twist the forearm bones,
you have to manually animate the wristTwist
custom attribute on the handLCTRL object. To
make the wrist twist occur automatically, you can
set up a function to cause the wrist twist bones to
rotate when the hand control is rotated around
the X axis.

This task will requires some advanced mathematics
and scripting. You will learn about these tools in
this lesson.
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Create a custom attribute to control automatic
twisting:

You already have a manual twist variable on each
hand control. To make the wrist rig completely
versatile, you will set up a new custom attribute
called autoTwist. When autoTwist is set to its
maximum value of 100, the wrist bones will
respond 100% to the rotation of the hand control.
In other words, the wrist twist will be 100%
automatic. When autoTwist is 0, the wrist twist
bones will not respond to the hand control at
all. Intermediate values will cause the wrist twist
bones to respond to a greater or lesser degree.

1. Open the file char_rigging07.0.max.

This file contains the rig from previous lessons.

2. Select handLCTRL, the shape around the wrist.

3. Go to the Modify panel.

4. Choose Animation menu > Parameter Editor.

5. In the Parameter Editor dialog > Attribute
rollout > UI Type group, name the custom
attribute autoTwist.

6. On the Atttribute rollout, in the Add To Type
group, choose Selected Object’s Current
Modifier from the drop-down list, then in the
Add/Edit/Delete group, click Add.

The new autoTwist attribute appears on the
Modify panel’s Custom Attributes rollout.

Note: The Add button is not available with
Selected Object’s Current Modifier unless the
Modify panel is active.

Later, you will use this custom attribute to
determine whether automatic twisting should
take place.

Next, you will set up the automatic twist
function. At first glance, setting up automatic
twisting would seem to be a simple matter of
wiring the hand control’s X rotation to the wrist
twist bones’ X rotation. However, this will not
give the desired result.

The hand control is not linked to any objects
in the scene, and therefore any rotation on the
control is calculated in world space. This means
all rotation is recorded relative to the World
coordinate system. The wrist twist bones are
linked to the lower arm bone, so their rotation
is calculated in local space, relative to the lower
arm bone.

If you move and rotate the hand control so the
character’s hand is posed near its waist, the
rotation axes will be oriented differently than
they are when the character’s hand is straight
out from the body. The hand control’s local X
axis will be in a completely different orientation
than the wrist twist bones’ X axis, so any X
rotation passed from the hand control to the
wrist bones will be in the wrong orientation.

What you want to pass from the hand control to
the wrist bones is the hand control’s X rotation
in relationship to the lower arm, wherever it
is at the time you rotate the hand. To do this,
you must use a different method of calculating
rotation.

To understand the method you will use, you
must first understand Euler rotation, the
method you are currently using.



Rigging Wrist Twist 385

Understanding Euler Rotations

The rotations used in the rig so far are Euler
rotations. By default, the result of Euler rotations
is calculated by 3ds Max in XYZ order. That is,
when 3ds Max calculates rotation to play back the
animation, it performs the recorded X rotation,
then the Y, then the Z. If you were to perform these
rotations in reverse order, the result would not be
the same. For example, the object could rotate 90
degrees on X, then 30 degrees on Y, and finally 5
degrees on Z. This would be recorded internally
by 3ds Max as [90,30,5].

The most accurate way to see what an Euler
rotation is actually doing is to use the Gimbal
coordinate system for the Select and Rotate
transform. This will show you how the local
rotation axes are reacting to the current settings.

With the Gimbal coordinate system, you can see
that the use of Euler rotations can sometimes
produce a situation where the object will not rotate
around a particular axis. For example, suppose
you rotate an object by 85 degrees around its Y
axis. If you do this, and look at the axes with the
Gimbal coordinate system, you will find that the
X and Z axes are nearly on top of one another. At
this point, rotating around either X or Z would
produce nearly identical results. This condition is
called gimbal lock.

Gimbal rotated so X and Z axes are nearly coincident

Usually you don’t have to concern yourself with the
problem of gimbal lock, since 3ds Max can display
the rotation gizmo in a variety of coordinate
systems that let you rotate around an arbitrary
axis. However, it does illustrate the fact that many
different Euler [X,Y,Z] value sets can give you the
same result. This is also true when you rotate an
object by more than 360 degrees around one axis;
a rotation of 0 degrees yields the same result as 360
or 720. In addition, when playing back animation
keys Euler rotation will go for the shortest distance
between two results, so the object might not rotate
the way you expect.

When you use a system other than Gimbal, you
are actually rotating on more than one axis at a
time, and 3ds Max is translating the rotation from
the coordinate system you are using to the Euler
[X,Y,Z] values. If you are using the world or local
coordinate system to rotate an object around a
single axis, the rotation values in Track View might
change on more than one axis track. For example,
if you rotate around the Y and Z axes, you might
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find that the X rotation value has changed in Track
View even though you never rotated around X.

Visually speaking, Euler rotation is sufficient for
most types of character animation. However,
when you need to know an object’s X rotation in
relationship to another object, these values will not
provide accurate information.

Understanding Quaternion Rotations

In 3D computer graphics, rotations are stored
internally as a set of four values called quaternions.
This method uses an axis pointing in a specified
direction in 3D space, plus a value specifies an
angle about that axis. Just like Euler has X , Y and Z
components, quaternions have 4 components: X, Y
and Z values for the axis, and then a W component
that specifies the angle about that axis. The main
difference then is that Euler rotations around the
X, Y and Z axes are added up in a specified order.
Quaternions are simply one rotation about any
axis specified, even if it is not lined up with a major
axis.

The Euler [90,30,5] rotation could be likened to
a quaternion [1,0,0,90] followed by a quaternion
[0,1,0,30] and then a quaternion [0,0,1,5].
However, these values are typically stored as one
quaternion that would be the result of combining
them into one axis that when rotated by the proper
amount, would give the same end result. This way
the object rotation is defined with one x,y,z and w
quaternion value at any time.

3ds Max stores quaternion values using the cosine
and other methods such as radians. Therefore,
while you might think the Euler rotation [0,0,90]
would be the same as quaternion [0,0,1,90]
3ds Max would actually store this quaternion
as [0,0,0.707,0.707]. See the MAXScript
documentation for more information describing
how 3ds Max stores quaternions internally.

The main reason for using quaternion rotation
is that it provides a more stable method for

calculating rotations than the Euler method.
With the Euler method, you can get to the same
result with many different values, and you can
sometimes encounter gimbal lock. Quaternions
do not suffer from these limitations. However,
quaternions are not as intuitive as Euler rotations.

Understanding Transforms and Matrices

In any 3D package, the program must store
basic information about an object’s position,
rotation, and scale. This data can be stored in a
mathematical structure called a matrix. A matrix
is a collection of numbers stored in a grid, or row
and column type of layout. For example, a 2x2
matrix has 2 rows and 2 columns, with a total of 4
numerical values stored.

Example of a matrix

In 3D software, all the data denoting an object’s
position, rotation and scale is stored in a 3x3 or
a 4x4 matrix, with 9 or 16 values respectively. In
3ds Max, a quaternion value is a series of four
values in the matrix.

A matrix has its own mathematical properties.
You do not have to understand everything there is
to know about matrices to use them, but you will
need the basic information provided here to use
the transform matrix in character rigging.

To understand how matrix mathematics works
in practice, consider an object placed at the XYZ

maxscript.chm::/quat_values.htm
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position [20,30,10]. If you wanted to place the
object back at the origin of [0,0,0], you could
simply add to it the XYZ values of [-20,-30-10]. In
this sense, the set of values [-20,-30-10] provide
the inverse of [20,30,10].

If you wanted to find out how much an object was
offset from the origin, you could simply find out
its inverse. In addition, if you wanted to find out
how far away one object was from another, you
could add one object’s inverse to the other. This
concept is simple and obvious when working with
positions, but rotations are another matter.

In matrix mathematics, the inverse is a set of values
that sets the values back to the origin when it is
multiplied by the original set. With rotation, this
means you can multiply the inverse by the rotation
values to orient the object to world space.

An object’s rotation values in the matrix are always
stored relative to the world, even if the object is
linked to another object in the scene. As with the
position inverse example, you can find out one
object’s rotation relative to another by multiplying
the first object’s inverse by the second object’s
rotation matrix values. 3ds Max uses this method
to determine the linked object’s rotation offset
from its parent. The offset is the value displayed
in Track View. You can use the same technique
to find out the hand control’s relationship to the
lower arm bone, even though they are not linked
together.

Matrix multiplication follows a different set of
rules, so the inverse of rotation values is not
immediately obvious from the rotation you
would see in Track View, or from the quaternions
themselves. Fortunately, there is an inverse
function you can use in scripting to find this value.

Scripting Rotations

To set up an automatic wrist twist function, you
will need to apply a script controller to the first
wrist twist bone. Here, we will go over the parts

of the script you will enter for the controller. Do
not enter any script lines until the procedure later
in this section.

First, you must use scripting to extract the lower
arm bone’s transform relative to world space.
Then you will find its inverse, and multiply that by
the hand control’s transform to find its transform
relative to the arm bone.

This line puts the inverse of the lower arm bone’s
transform in the variable matParent:

The next line puts the hand control’s transform in
the variable matHand.

And lastly, you multiply the two together to get the
value that tells you how much the hand control
has transformed in relationship to the lower arm
bone’s local space. The result is stored in the
variable matResult.

Now you can get the rotation value for this matrix
value, and put it in the variable rot.

This will return the quaternion values for the hand
control rotation relative to the lower arm.

Finally, you need to find out the rotation on the
X axis.

The previous line returns the Euler rotation with
an XYZ extract order. In some cases, you will want
to evaluate the rotation in a different axis order.
There will usually be one that will work well until
the arm crosses more than 90 degrees on another
axis. One will work regardless of how much the
arm is rotated. In this case, YZX ordering will give
you the most stable results.

In order to control the order in which the
rotation values are evaluated, you need to use
the quatToEuler function instead. This lets you
specify the rotation order. You pass in the order
as a number. 1 represents, XYZ, 2: XZY, 3: YZX,
4:YXZ, 5: ZXY and 6:ZYX. (See the MAXScript
documentation for a full list).
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To use quatToEuler to evaluate rotation with YZX
order:

This will return the Euler results in the order
[Y,Z,X]. However, the three values are still referred
to as x, y, and z, in that order. So, to get the X
rotation value, you will ask for the third value, the
z.

In addition, the autoTwist attribute drives how
much the automatic twisting works. By default it
is at 100 percent, but as it drops to zero, the auto
twist falls off.

twist = twist * autoTwist / 100.0;

Finally, the wristTwist attribute can also be used to
add manual animation of the wrist twist over and
above the automatic twisting.

twist = twist + wristTwist ;

Then twist will have the final X rotation. However,
the value will be returned in degrees, while the
controller works with radians. In the Introduction
to Character Rigging (page 2–299) tutorial, you
learned how to convert values from degrees to
radians:

These lines comprise all the functions you will
need to create a script to set up automatic wrist
twist.

You have now worked through each step, and
you’re ready to apply what you’ve learned to the
wrist twist rig.

Assign the script to the first wrist bone:

1. Select wristTwistL3BONE, the wrist twist bone
closest to the hand.

2. In the Motion Panel, expand the Assign
Controller rollout. Then expand the Rotation
controller for rotation, and highlight X
Rotation.

3. Click the Assign Controller button, and choose
Float Script from the dialog that appears.

4. In the Script Controller dialog, create a variable
named lowerArmLBone.

5. Click Assign Node and, in the Track View
dialog, expand the clavLBONE node
hierarchy until you locate and highlight the
lowerArmLBONE node.

6. Create a second variable named handLCTRL
and assign it the handLCTRL node using the
same steps as before.

7. Create a third variable named autoTwist.

8. Click Assign Track and, in the Track View
dialog, expand the handLCTRL node hierarchy
until you locate and highlight the autoTwist
attribute (under the Attribute Holder node).

9. Create a fourth variable named wristTwist and
assign it the wristTwist custom attribute node
using the same steps as before.

10.Enter the following script in the Expression
window.

The last value calculated, the one stored in the
twist variable, will be taken by the script and
applied to the wrist bone’s X rotation.

11.Click Evaluate.

If you have entered the script correctly, the
value 0.0 will appear in the Result field.

If there is a problem with the script, an error
message appears in the white, Scripter line of
the MAXScript Mini Listener on the status bar.

12.Click Close.



Rigging Wrist Twist 389

Test the script:

1. Select handLCTRL. In the Modify panel, set
autoTwist to 100.

2. Rotate handLCTRL around its local X axis.

The wrist twist bone closest to the hand should
rotate with it.

If you need to change the script, you can
right-click the X Rotation track in the Assign
Controller rollout and choose Properties from
the pop-up list.

Wire the remaining wrist twist bones:

Now you will wire the remaining wrist twist bones
to wristTwistL3BONE so they will rotate by a
fraction of its rotation.

1. Select wristTwistL3BONE.

2. Right-click the object, and choose Wire
Parameters from the quad menu. Wire
wristTwistL3BONE’s X rotation to
wristTwistL2BONE’s X rotation. On the right
side of the Parameter Wiring dialog, enter the
expression X_Rotation * 0.5, then click the
right arrow and Connect.

This will cause wristTwistL2BONE to rotate by
half of wristTwistL3BONE’s X rotation.

3. Wire wristTwistL3BONE’s X rotation to
wristTwistL1BONE’s X rotation, using the
expression X_Rotation * 0.25.

The wrist twist rig is now complete.

The result of rigging both wrist twists can be
found in the file char_rigging07.1.max. A short
animation has been applied to the character’s
arm to demonstrate the automatic twisting
action.

The file char_rigging_advanced.max contains
a shoulder pad rig that uses quaternions and
a script controller to automatically move
a shoulder pad up and down according to
the arm’s movements. To see the script that
controls the shoulder pad, select PadLBone
or PadRBone. On the Motion panel > Assign
Controller rollout, highlight Y Rotation, and
right-click to choose Properties from the
pop-up menu.
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Cleaning Up

At this time the basic rig and control structure is
complete. Feel free to add more features such as
finger controls and such based on the techniques
you have learned.

However, before passing this off to an animator, it
would be good to clean up the file and make named
selection sets for various parts of the character.

Create selection sets:

1. Open char_rigging08.0.max from the\tutorials\
character_animation\character_rigging folder.

As you can see, there are many objects in the
scene. Helpers, IK goals, space warps, the
meshes, bones and the controls for the rig.
You’ll create selection sets for each object and
hide everything that needs to be hidden.

2. Choose Tools menu > Selection Floater.

This floating selection window allows you to
see and select multiple objects at once.

3. In the List Types group, click None to turn off
all the types, and then turn on Helpers and
Space Warps.

All the helper and space warp objects now
appear in the list.

4. In the bottom left of the dialog, click All to
select all objects displayed in the list. Click the
Select button to select them.

5. Create a selection set called internalJunk. Hide
all the selected items.

6. In the Selection floater, turn off Helpers and
Space Warps, and turn Geometry. Select all
the objects listed, and created a selection set
calledgeometry.

7. In the Selection floater, use the Shapes option
to select all shapes, and create a selection set
called controls.

8. Change the filter to only show Bone Objects.
Select all the bones. Create a selection set called
bones.

You or the animator can now easily select all of
the controls, mesh or bones for the character to
hide or show them, or freeze them.

To clean it up even more, you can also hide the
body geometry but leave the eyes.

A cleaned-up version of the character can be found
in the file char_rigging08.1.max.
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You can use placementCTRL to move the entire
character into position for a shot. Normally this is
not animated, except to pop into a start position
from one shot to another. If you rotate it, you’ll
have to rotate the head and neck also since they
are rotation independent.

During normal animation, you would block
in animation with hipCTRL. Then you would
animate footLCTRL and footRCTRL as well as
the knee controls to make the legs follow. If the
character was on a swing or if you needed to
quickly adjust both feet together, you could use
groundCTRL.

For the spine, you can both move and rotate
spineTopCTRL and animate its stretchiness. If
you need to offset just the bottom of the hips for
something resembling a hula-hoop motion, you
can use spineBotCTRL to move and rotate only
the bottom of the spine and hips.

The handLCTRL and handRCTRL controls let you
position and rotate the hands and arms. By default
they will move along with the spine, but if you
want locked-down IK, you can set them to World

mode. There is also a wristTwist attribute to help
with skin issues near the hand. The elbow controls
set where the elbow of the arm is pointing. The
shoulder controls can be moved to let the character
shrug or reach.

The neck, head and hair are all FK controls, and
can simply be rotated. The eyes have a master
object, eyeCTRL that allows you to make the
character look in a specific direction, as well as
independent L and R eye controls to allow the
character to go cross-eyed.

Rigging a Shoulder

When animating a rigged character, many
subtleties of movement are possible. To make the
animation as natural and realistic as possible, it
is necessary to animate the character’s shoulder
when its arm moves. Otherwise, the character will
appear stiff while going through its motions.

In this lesson, you will set up an advanced rig for
a character’s shoulder. When you move the arm
with the wrist control, the shoulder will respond
by rotating slightly to accommodate the arm’s
movement. With this type of rig, your character’s
arm and shoulder movements will look natural
and realistic without your having to animate every
shoulder movement individually.

The shoulder is one of the more complex areas
of human anatomy. It involves several bones and
muscles that move and slide in complex ways, that
vary on the arm position.

While this is a simplification of how the true
anatomy works, it yields a very good result, with
minimal work. In addition, the rig will give you the
ability to manually adjust the shoulder if necessary.

You will also learn how to set up a shoulder pad
that rotates vertically when the arm reaches a
specified rotation. You can use the pad to provide
additional control over the shoulder skin. This
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technique is particularly useful for characters that
have large shoulders, or for those wearing armor
or padded clothing.

Before doing this lesson, you should be familiar
with intermediate character rigging tools, such as
those covered in the lessons Rigging the Legs and
Feet (page 2–349) and Rigging the Arms (page
2–371).

Prepare the scene:

To create the shoulder rig, you will start with a
scene that contains arm bones and two control
objects.

1. Open the file tut_shoulder_rig01.max.

2. Press the H key to display the Select by Name
dialog and see the list of object names.

The bones are named ClavLfBone,
UpperArmLfBone, LowerArmLfBone and
WristLfBone respectively. The two control
objects are HandLfCTRL and ElbowLfCTRL.

3. In the Select by Name dialog, turn on Display
Subtree.

The indented listing shows you that the arm
bones are linked in sequence from the clavicle
(shoulder bone) to the wrist, as is usual with a
set of standard bones. No custom linking or
controls have been assigned to the bones at this
point.

4. Close the Select by Name dialog.

Set up the basic controls:

Now you will set up the basic IK chains and linked
controls for the arm.

1. Select ClavLFBone.

2. Choose Animation menu > IK Solvers > HI
Solver, and click UpperArmLfBone to create an
IK chain from the clavicle to the upper arm.

3. Name the IK chain IKChainClav.

4. Create another HI solver from the
UpperArmLfBone to the WristLfBone. Name
this chain IKChainArm.

5. Link IKChainArm to HandLfCTRL, the
shape at the wrist.

Moving the control shape will now animate the
arm.

6. Select IKChainArm, and go to the Motion
panel.

7. In the IK Solver Properties rollout, click
the button under Pick Target, and pick
ElbowLfCTRL, the point helper behind the
arm.

This will cause the elbow to always point in the
direction of ElbowLfCTRL.

Duplicate the arm chain:

Next, you will duplicate the bones in the arm
chain. To understand why you are doing this, you
need to know how the shoulder rig will operate.

Our goal is to make the clavicle bone will rotate
automatically based on the arm rotation. To
accomplish this, you will need to cause the clavicle
bone to continually point at a location in the
middle of the upper arm bone as the arm rotates.

Your first response to this challenge would
probably be to use a Look-At constraint to
aim ClavLfBone at some location on the
UpperArm. However, because UpperArmLfBone
is linked to ClavLfBone, you cannot do this.
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UpperArmLfBone is a child of the ClavLfBone, so
its rotation is dependent on the clavicle. If you then
made the clavicle rotate based on the upper arm,
you would create a dependency loop. 3ds Max will
not allow you to create such a loop.

To get around this limitation, you’ll create a
duplicate chain of arm bones without an IK chain
on the clavicle. Then you will put a Look-At
constraint on the clavicle to cause it to look at
the middle of the upper arm. Then you will use
a series of controls to make the original clavicle
follow the new clavicle.

This setup will get around the dependency loop
while still giving you complete control over the
shoulder. The setup is somewhat complex, but
once you go through it once, you’ll have a better
understanding of how it operates.

1. Select all the bones in the arm.

Tip: You can quickly select all the bones in
the chain by double-clicking the root bone
ClavLfBone.

2. Hold down the SHIFT key and move the bones
on the Z axis to make a duplicate chain above
the existing one. In the Clone Options dialog,
choose Copy and click OK.

3. Name the bones as follows:

• ClavLfBone2

• UpperArmLfBone2

• LowerArmLfBone2

• WristLfBone2

In the final rig, these bones will occupy the
same locations as the original bones. You have
moved the bones away from the original bones
simply to make it easier to set up this part of
the rig.

To make it easier to tell which chain is which,
you will change the color and size of the new
bones.

4. Choose Character menu > Bone Tools, and use
the Bone Tools dialog to change the color of the
new bones to red.

5. In the Bone Tools dialog, turn off the fins, and
lower the Width and Height settings to 5.

To prevent the dependency loop from occurring
on this set of bones, you will not create an IK
solver from the clavicle to the upper arm. The
only IK solver in this chain will be from the
upper arm to the wrist.

6. Create a HI solver from UpperArmLfBone2
to WristLfBone2. Name the new IK chain
IKChainArm2.

7. On the Motion panel, set the target for the
swivel to ElbowLfCTRL.

Note: Because ElbowLfCTRL is currently below
the chain, this will cause the arm to bend down
slightly as the elbow points at the helper.

Now you can move the new chain back to the
original position.

8. Align ClavLfBone2 with ClavLfBone.

9. Align IKChainArm2 with IKChainArm.

10. Link IKChainArm2 to HandLfCTRL.

At this point, you have two working arm
chains, the original with an IK chain for the
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shoulder, the other without an IK chain.
Moving HandLfCTRL will move both arm
chains identically.

11.Save your work as my_shoulder_rig02.max.

The file tut_shoulder_rig02.max shows the
results so far.

Create the look-at targets:

When animating the rig, you want to be able
to blend between aiming the clavicle straight,
and aiming the clavicle at the spot on the upper
arm. To achieve this, you will set up a Look-At
constraint for the new clavicle, and create two
targets for it. One target will sit at the end of the
clavicle’s original location, and will not move. The
other will sit halfway down the upper arm.

Here, you will create and position the look-at
targets. Later, you will set up further controls to
use with the constraint.

1. In the Top Viewport create a Point helper. Turn
on the Box and Axis Tripod options for the
helper.

The box and axis tripod will enable you to see
the effects of rotating the point helper later on.

2. Name this helper ClavLfAimer.

3. Align ClavLfAimer with ClavLfBone.

This helper will aim the clavicle by looking at
one of two look-at targets, or a blend of the two
targets.

4. Copy and move the helper on the X axis.
Position this second helper near the ends of the
clavicle bones.

5. Name the helper ClavLfAimTgtStable.

This helper will become the look-at target for
aiming the clavicle in its original orientation.

6. On the Modify panel, turn off the Axis Tripod
for the helper, and make it a little smaller.

7. Copy the helper on the X axis again, and name
it ClavLfAimTgtMoving. Position the helper
near the middle of the upper arm.

This helper will become the look-at target for
pointing the clavicle at the middle of the upper
arm bone.

You should now have three helpers, all aligned
on the X axis.

Set up the Look-At constraint:

1. Select ClavLfAimer, the first helper you created.

2. Choose Animation menu > Constraints
> LookAt Constraint. Click the
ClavLfAimTgtStable helper.

This sets up the stable target at the end of the
clavicle as the first look-at target.

3. Choose Animation menu > Constraints >
LookAt Constraint again, but this time pick
ClavLfAimTgtMoving as the target.

This adds the target in the middle of the arm as
the second Look-At constraint.

4. On the Motion panel, click the Rotation button
at the bottom of the PRS Parameters rollout.

5. In the Rotation List rollout, double-click the
LookAt Constraint listing to make it active.

In the LookAt Constraint rollout, you can
see that the two targets are listed, each with a
Weight of 50.
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Note: If you accidentally pick a wrong target,
you can delete it by highlighting the target on
the list and clicking Delete Look-At Target.
Then you can add the correct target by clicking
Add LookAt Target and clicking the correct
target. If you do this, be sure to turn off Add
LookAt Target when you have finished.

6. Change the viewport display to wireframe
mode by right-clicking the viewport label and
choosing Wireframe from the pop-up menu.

In wireframe mode, you can see the connecting
line between ClavLfAimer and the targets,
indicating that the target at the start of the
clavicle is set to look at the two targets.

7. In the Look-At Constraint rollout, turn off
Viewline Length Absolute.

This makes the connecting line the same length
as the distance between the constrained object
and the target, rather than the length specified
by the Viewline Length parameter. This will
make it easier to see what is happening with the
constraint.

Link the look-at targets:

1. Select ClavLfAimTgtMoving, and link it to
UpperArmLfBone2. Make sure you link it to
the second upper arm bone you created (the red
one), and not to the original upper arm bone.

This will cause the moving helper to move
when the upper arm moves.

Note: You were instructed to switch to wireframe
mode because it is easier to select the second set
of bones in this mode. You can switch between
Wireframe and Smooth & Highlights modes at
any time during this lesson, as you prefer.

2. Link ClavLfAimTgtStable to
ClavLfBone2.

Since ClavLfBone2 will not move during the
animation, this will keep this target from
moving.

You can now test the aim by moving the
HandLfCTRL object. You will see the aim
helper aiming between the two targets. Undo
any movements before continuing.

3. Save your work as my_shoulder_rig03.max.

The file tut_shoulder_rig03.max shows the
result of this setup.

Set up the clavicle rotation:

The next step is to make the original clavicle’s IK
chain rotate with the aimer helper. This will cause
the clavicle to rotate about half as much as the
upper arm.

You could link the clavicle’s IK chain directly to the
aimer helper, but you will have more control over
the rig if you link a control shape to the helper,
then link the IK chain to the control shape.

1. In the Left viewport, create a NGon shape
with a Radius of about 20. Name the object
ShoulderLfCTRL.

2. Align this control with IKChainClav.

3. Link ShoulderLfCTRL to ClavLfAimer.

This will cause the shoulder control to move
with the aimer helper.
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4. Link IKChainClav to ShoulderLfCTRL.

Now the IK chain is a child of the control shape,
which is a child of the aimer helper. When the
aimer helper looks in different directions, the
IK chain will rotate, in turn rotating the clavicle.

Next, you need an overall control for the entire
arm. This is the control you would link to
the spine if the arm were part of a complete
character rig.

5. Create a helper object that is larger than the
aimer helper, and name it ArmLfStart. Align it
with the pivot point of either one of the clavicle
bones.

6. Link ClavLfBone, ClavLfBone2 and
ClavLfAimer to ArmLfStart.

7. Save your work as my_shoulder_rig04.max
before continuing.

The file tut_shoulder_rig04.max shows the
result of this setup.

8. Test the rig by moving HandLfCTRL. As you move the hand control, both the red
and gray bone structures follow it. The aimer
helper points between the helper linked to the
red upper arm, and the helper at the end of
the red clavicle. The gray clavicle points in the
same direction as the aimer helper.

Note: When apply the Skin modifier to a
double-bone rig such as this, you would use the
gray bones, but not the red ones. The red bones
are there simply to provide assistance with the
rig, and are not intended for skinning.

9. With the arm bent, move ShoulderLfCTRL.

Because the IK chain is linked to this control,
you can move the shoulder manually by moving
this control.

10.Undo any changes you have made since saving
the file, or reload my_shoulder_rig04.max or
tut_shoulder_rig04.max.
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Control the weight of each look-at target:

The shoulder rig in its current form would provide
enough control over the shoulder for many
different types of animation. However, you can
take it a step further and create a custom attribute
that allows you to aim the clavicle more at one
look-at target than the other.

To do this, you will create a custom attribute on
the shoulder control, and wire it to the weights of
the look-at targets.

1. Select ShoulderLfCTRL.

Note: If you have previously copied the
Modifier-Attribute Holder.ms script to your
StdPlugs\Stdscripts folder, you can apply the
Attribute Holder modifier to the object. If you
do this, you will be able to add the custom
attribute to this modifier rather than the
object’s base level.

2. Choose Animation menu > Parameter Editor.
In the Parameter Editor dialog, name the
parameter autoAim, and leave the range set to
the default values of 0 to 100.

Note: If you have applied the Attribute Holder
modifier, you can also choose Selected Object’s
Current Modifier from the Attribute rollout >
Add to Type drop-down menu.

3. Click Add to add the custom attribute to
ShoulderLfCTRL.

The autoAim custom attribute will control the
weights of the targets. When one target is set to
100 and the other is 0, the target with the weight
of 100 will be in full force.

4. Right-click ShoulderLfCTRL, choose Wire
Parameters from the quad menu. From
the pop-up menu, choose Object (Ngon) >
Custom_Attributes > autoAim.

5. Click ClavLfAimer, and choose Transform >
Rotation > LookAt Constraint > LookAtWeight
0 from the pop-up menu.

6. In the Parameter Wiring dialog, enter 100 –
autoAim in the expression area at the lower
right of the dialog.

LookAtWeight 0 refers to the first target you
picked when setting up the Look-At constraint.
This is the stable target at the end of the
clavicle. Because the custom attribute is named
autoAim, you want it to set a weight on this
target of 0 when autoAim is 100, and a weight
of 100 when autoAim is 0. For this reason, you
must enter 100 – autoAim to get the right effect.

7. Click the arrow that points to the right, and
click Connect.

8. Repeat the process to wire autoAim to
ClavLfAimer’s LookAt Weight 1. This time,
leave the expression as autoAim.

LookAt Weight 1 refers to the moving target.
You want the weight of this target to be in full
force when autoAim is set to 100, so you want
this value to match autoAim.

9. Select ShoulderLfCTRL, and set autoAim to
60.0.

A value of 60 works well for arm actions within
the normal range of motion.

10.Save the scene as my_shoulder_rig05.max.

The file tut_shoulder_rig05.max has the final
version of the look-at shoulder.

The shoulder rig is complete. These controls
allow you to do the following with this rig:

• Move HandLfCTRL to bend the elbow and
cause the clavicle to rotate slightly to follow
the arm.
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• Animate the autoAim value to cause the
shoulder to follow the upper arm to a greater
or lesser degree.

• Move ShoulderLfCTRL to manually position
the clavicle.

You can attach this arm rig to any full-body
character rig by linking ArmLfStart to the
character’s spine bones or controls.

Rigging Finger Curls

You can rig a character’s hand in a variety of ways.
This tutorial will show you how to rig a hand so
you can curl the fingers individually, and create
believable animation on the hand.

A hand can achieve many complex movements,
and care must be taken to set up a hand rig that will
accommodate all ranges of motion. This tutorial
uses a script that provides additional options for
creating and animating custom attributes beyond
the built-in tools.

This tutorial also uses a modifier script so the
custom attributes can be held in a modifier rather



Rigging Finger Curls 399

than at the object’s base level. It allows you to store
presets for custom attributes, making it easy to
reuse hand poses at any time during the animation
process.

Although it is possible to rig a hand without
the aid of scripts, the script used in this tutorial
makes it easier and faster to get the end result.
Using MAXScript tools for character rigging can
give you additional options and make for a more
user-friendly character for animators to use.

Install the custom modifier:

You will begin by installing the custom modifier.

1. Copy the file PEN_Attribute_Holder_2.ms to
the 3dsmax8\scripts\startup folder.

The PEN Attribute Holder 2 scripted modifier
is designed as a holder for custom attributes
that provides an extended tool set for the
animator. It is useful for hands because it allows
you to store presets for the custom attributes
and share them with other PEN Attribute
Holder 2 modifiers via a save, load and merge
function. The modifier also allows you to place
custom attributes on the modifier, rather than
at the object’s base level. You will learn how to
use this modifier in this lesson.

2. If 3ds Max is running, exit the program.

3. Start 3ds Max.

Because the script is in the startup folder, it is
loaded automatically when you start 3ds Max.
Next, you will check that the script has been
properly installed.

4. Create a sphere in any viewport.

5. On the Modify panel, look in the modifier list
for the modifier PEN_Attribute_Holder_2.

If the modifier doesn’t appear on the list, check
that the script is in the correct folder, and
restart 3ds Max.

Add the modifier to the control object:

1. Open the file tut_handrig_start.max from the
\tutorials\character_animation\character_
rigging folder.

This file contains a character called Gonzo. He
is already fully rigged, except for the hands.
Gonzo has just two fingers and a thumb. The
technique you will use for this type of hand can
be extended for use with hands with more than
two fingers.

2. Hide all objects except the right hand bones
and the control object for the right hand. The
control object is a shape containing the word
Hand.
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3. Select the right hand control object, named
Gonzo_CNT_Rhand.

4. Apply the modifier PEN_Attribute_Holder_2
to the control object.

For the purpose of rigging, the fingers on the
character’s hand are called the index finger,
baby finger and thumb. Aside from the fewer
number of fingers, the hand will work much
like a human hand. To best understand how the
rig will work, you can compare the rotational
limits to your own hand, looking at your index
finger, pinky finger, and thumb.

The index finger has three joints. The base joint
has two axes of rotation, up and down and side
to side. The middle and end joints only have
one axis of rotation. The pinky (baby) finger
is much the same, but its base joint begins its
rotation farther inside the hand.

The thumb has the most complex set of possible
movements. Its base joint has three axes of
rotation that give it a greater range of motion
than the other fingers. The other two joints of
the thumb have just one axis of rotation.

To create an interface that can accommodate
most of the ranges of motion for the hand, you
will need two spinners for the index finger’s
rotation, three for the baby finger’s rotation,

one for splaying the index and baby fingers
apart, and three for the thumb’s movements.

Run a script to create an interface:

1. Select Gonzo_CNT_Rhand, the control object.

2. Choose MAXScript menu > Open Script, and
open handDef.ms.

3. On the MAXScript window, choose File menu
> Save As, and save the file as my_handDef.ms.

4. On the MAXScript window, choose File menu
> Evaluate All.

This adds a custom attribute to the
PEN_Attribute_Holder_2 modifier called
Index 01.

You will need to edit this script to add eight
more custom attributes to the modifier.
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Edit the script:

1. In the MAXScript window, look through the
script.

The first function, fn getDefFn, doesn’t need to
be edited. It is there to get the custom attribute
once you have added it and want to update it.
This function only returns a definition with the
name "Hand Controls" on the first modifier of
any selected object.

The second section of the script is the attribute
definition that you will be editing and adding
to the object.

2. Look for the following lines in the script:

The parameters section adds a variable that
can be used on the rollout. The rollout section
creates the rollout with the parameter called
Index 01. To add more spinners, you will
edit this part of the script. For each spinner,
you will add a line under parameters mainP
rollout:mainR and rollout mainR "Hand
Controls".

3. Copy the line Index01 type:#float ui:index01,
and paste it to the next line.

4. Change Index01 to Index02, and ui:index01
to ui:index02.

5. Copy the line spinner index01 “Index 01:”
range:[-30,100,0] fieldWidth:50, and paste it
to the next line.

6. Change index01 to index02, and Index 01 to
Index 02.

7. Remove the two hyphens from the start of the
line --redefine:handDef. This removes the
comment markings and allows this line to
evaluate. This line should be commented the
first time you run the script, then it should be
run each time you run the script again.

8. Choose File Menu > Evaluate All.

The Modify panel now contains two spinners,
Index 01 and Index 02.

Add the remaining custom attributes:

1. Copy the line Index02 type:#float ui:index02,
and paste it seven more times.

2. For each of the custom attributes listed below,
change Index 02 to the custom attribute name.
When entering a new variable name, use the
same capitalization and spacing as the variable
you are replacing. For example, for the first
variable listed, replace index02 with baby01,
Index02 with Baby01, and Index 02 with Baby
01.

• Baby 01

• Baby 02

• Thumb 01

• Thumb 02

• Thumb Roll
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• Cup

• Splay

3. Copy the line spinner index02 “Index 02:”
range:[-30,100,0] fieldWidth:50, and paste it
seven more times.

4. For each of the custom attributes listed above,
change Index 02 to the custom attribute name,
matching spacing and capitalization.

This portion of the script should look like the
following code:

5. On the MAXScript window, choose File menu
> Evaluate All.

The nine attributes appear on the Modify panel.

6. If you have difficulty getting the script to work,
you can load the script handDefFinal.ms and
run the script.

Tip: With this script, all the custom attributes
have been given the same range of values, -30
to 100. This range is suitable for finger curls,
but too large for other actions such as Splay,
which spreads the fingers apart. Instead of
spending the time to figure out each custom
attribute’s exact range, you will use expressions
to limit rotation for some of the bones’ axes.
For example, when wiring the attributes, you

can multiply a custom attribute by 0.5 or 0.4
to reduce the value passed on to the bone’s
rotation axis. This approach gives you more
flexibility, as you can easily experiment with
different expressions to get the right wiring for
your character’s hand. You will see how this
works when you wire the custom attributes
later in this lesson.

7. On the MAXScript window, choose File
menu > Save As, and save the script as
my_handDefFinal.ms.

This script can be altered for use with other
projects. The first time the script is run, be sure
to comment out the line redefine:handDef by
placing two hyphens in front of it.

When you use a script to create custom
attributes, you can use any MAXScript
command and interface item. This allows far
more flexibility in setting up complex controls
for a character then you can achieve with the
built-in Parameter Editor tool.

8. Close the MAXScript window.

9. Save the scene as my_handrig_02.max.

You can find a version of this scene in the file
tut_handrig_02.max.

Zero out the bones’ rotation:

List controllers are a way of layering transforms. A
list controller adds up all the controllers in the list
to create the final transform for the object.

When a list controller is applied to an object, the
first controller on the list stores the initial values
for the transform. Then a subsequent controller
can be used to add to the value of the transform.

For example, the first controller applied to the
rotation transform holds the object’s original
rotation values, such as any rotation applied to
pose the object. The second controller starts off
with a value of [0,0,0]. This is the controller that
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will hold any animation that differs from the
original pose.

When a list controller is applied to a bone, the
second controller gives you a set of values to which
you can wire parameters without affecting the
current pose. To learn more about list controllers,
do the lesson Using List Controllers (page 2–321)
in the Introduction to Character Rigging (page
2–299) tutorial.

You can add a list controller manually to each bone
with commands on the Motion panel, but you can
perform this task more quickly with a script.

1. Select all the bones in the hand.

2. Choose MAXScript menu > MAXScript
Listener to open the listener.

The results from the previously run script
appear in the window. Next, you will enter
three lines of script to set up the Rotation List
controller on each selected bone.

3. Enter the following line in the listener, and
press ENTER.

This line applies the Rotation List controller to
the Rotation transform for all selected objects.
If the line executes correctly, the word OK
appears on the next line.

4. Enter the following line in the listener, and
press ENTER.

This line changes the resulting Available
controller to a Euler XYZ controller for all
selected objects.

5. Enter the following line in the listener, and
press ENTER.

This line makes the second Euler XYZ
controller the active controller for all selected
objects. This means that any animation rotation
of the object will be added to that controller.

6. Close the listener window.

If you want to check how the script lines have
affected the bones, select one bone and go to the
Motion panel. In the Assign Controller rollout,
you can see that the Rotation List controller
has been added to the bone, and there are
two controllers below it, both Euler XYZ
controllers. The second Euler XYZ controller is
currently active.
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7. Save the scene as my_handrig_03.max.

You can find a version of this scene in the file
tut_handrig_03.max.

Wire the finger curls:

Now you will wire the bones’ rotation values to
custom attributes. Wiring connects two parameter
in the scene so you can control the value of one
with the other.

Note: If you are not familiar with the process
or parameter wiring, do the Wiring a Custom
Attribute (page 2–317) lesson in the Introduction
to Character Rigging (page 2–299) tutorial.

When rigging a character, you would ordinarily
take a few moments to work out the best rotation
axes for each custom attribute. To do this, you can
change the Reference Coordinate System to Local,
then rotate each finger bone to determine the axes
affected by each hand pose.

With the Gonzo character, the fingers curl toward
the palm when rotated around the Y axis, and
splay apart when rotated around the Z axis.

Note: There is no need to perform these tests
on the Gonzo character; the rotation wiring is
provided for you in this lesson. However, you can
do so if you wish. If you rotate any of the bones
to check the rotation axes, make sure you undo
any rotations you created before continuing with
this lesson, or reload my_handrig_03.max or
tut_handrig_03.max.

You will start by wiring the index finger bones’
rotation. You will use three spinners to control
the index finger: Index 01, Index 02, and Splay.
In each case, you will wire one axis of the bone’s
second Euler XYZ controller to one of the custom
attributes on the hand control.

1. Select Gonzo_Bone_RIndex02, the base bone
on the index finger.

2. Right-click the bone and choose Wire
Parameters from the quad menu. From the
pop-up menu, choose Transform > Rotation
> Euler_XYZ (the second one listed) >
Y_Rotation.

3. Click Gonzo_CNT_Rhand (the control
object), and choose Modified Object >
Pen_Attribute_Holder 2 > Hand Controls >
Index01.

The Parameter Wiring dialog appears with the
bone’s Y rotation on the left, and the custom
attribute on the right.

4. On the Parameter Wiring dialog, replace
Index01 on the left with degtorad(Index01).

This expression converts Index01 from degrees
to radians, which is the angle unit used by
objects to calculate rotation. For information
on the usage of the degtorad function, see the
lessonWiring a Custom Attribute (page 2–317)
in the Introduction to Character Rigging (page
2–299) tutorial.
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5. Click the left arrow at the center of the dialog to
make the custom attribute control the bone’s
Y rotation, and click Connect. Close the
Parameter Wiring dialog.

6. To test the connection, select Gonzo_CNT_
Rhand and go to the Modify panel. Change the
value of spinner Index 01.

The base bone on the index finger should rotate
as you change the spinner value.

Now you will wire the rest of the index finger
and pinky bones for the curling motion. For
all steps that instruct you to wire parameters,
be sure to wire from the bone > Transform >
Rotation > Euler_XYZ (the second one listed)
> specified rotation, to Gonzo_CNT_Rhand >
Modified Object > Pen_Attribute_Holder 2 >
Hand Controls > specified custom attribute.
In each case, add the degtorad function to the
expression on the left side of the Parameter
Wiring dialog, then click the left arrow and
click Connect.

7. Wire Gonzo_Bone_RIndex03’s Y Rotation to
Index02.

8. Wire Gonzo_Bone_RIndex04’s Y Rotation to
Index02.

The spinner Index02 now controls the rotation
of the last two joints on the index finger. You
could create two spinners to control the last
two joints of the finger, but this is often not
necessary.

9. Repeat these steps on the baby finger
bones, wiring Gonzo_Bone_RBaby02’s
Y Rotation to the custom attribute
Baby01, and Gonzo_Bone_RBaby03 and
Gonzo_Bone_RBaby04’s Y Rotation to Baby02.

Test the wiring by selecting Gonzo_CNT_
Rhand and changing the spinner values for
Index 01, Index 02, Baby 01, and Baby 02. Reset
all spinners to 0 before continuing.

10.Save the scene as my_handrig_04.max.

You can find a version of this scene in the file
tut_handrig_04.max.

Wire the finger splay:

1. Wire Gonzo_Bone_RIndex02’s Z Rotation to
the Splay parameter. Change the expression to
degToRad(Splay * 0.5).

This will reduce the rotation from the Splay
parameter by half before it is passed to the
pinky base bone. Using an expression to reduce
the value passed to the bone is similar to
reducing its range to -15 to 50, rather than -30
to 100. Using expressions to reduce the value
passed to the bone is a more flexible approach
than setting the range explicitly, as you can
easily change the multiplier 0.5 to another value
if you find you need the fingers to splay to a
greater or larger degree.

2. Wire Gonzo_Bone_RBaby02’s Z Rotation to
the Splay parameter. Change the expression to
-degToRad(Splay * 0.5).

Placing a negative sign in front of the expression
will cause the baby finger to rotate in the
direction opposite the index finger.

3. Test the wiring by selecting Gonzo_CNT_
Rhand and changing the Splay value. The index
and baby fingers should rotate away from one
another when Splay is increased.
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4. Reset the spinner to 0 before continuing.

Wire the baby finger cupping action:

When you cup your hand to grasp an object, the
thumb rotates into the palm, and the bone inside
your hand below the pinky finger rotates slightly
to form the palm into a cup. In this procedure,
you will wire the pinky finger’s hand bone to the
Cup spinner, so this part of the hand can achieve
a cupping action when the Cup parameter is
increased.

1. Select Gonzo_Bone_RBaby01, the hand bone
below the pinky finger.

2. Wire Gonzo_Bone_RBaby01’s X Rotation
to Cup, and change the expression to
degToRad(Cup * 0.2).

Tip: If you leave the Parameter Wiring dialog
open, you can do the next step by highlighting
the Y Rotation listing on the left, rather than
going through the wiring pop-up menus.

3. Wire Gonzo_Bone_RBaby01’s Y Rotation
to Cup, and change the expression to
degToRad(Cup * 0.4).

4. Test the wiring by selecting Gonzo_CNT_
Rhand and changing the Cup value. The baby

finger should rotate slightly inward toward the
palm when Cup is increased.

5. Reset the spinner to 0 before continuing.

6. Save the scene as my_handrig_05.max.

You can find a version of this scene in the file
tut_handrig_05.max.

Wire the Thumb controls:

The thumb bone inside the palm has the most
range of motion, and is the most complex in the
way it moves. This joint extends nearly to the
wrist, and has the ability to rotate around all three
axes of rotation. For this reason, the thumb is able
to rotate toward the palm to grasp objects, or move
out of the way so the hand can be completely flat.

To achieve this range of motion, you will wire the
thumb bone inside the palm in such a way that it
can rotate on all three axes. The remaining thumb
bones can rotate only around the Y axis.

In all, you will use three different custom attributes
for wiring the thumb: Thumb 01, Thumb 02, and
ThumbRoll. Thumb 01 will hold the Y rotation for
the thumb bone inside the hand, while Thumb 02
will hold the Y rotation for the last two bones. The
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ThumbRoll custom attribute will hold the X and Z
rotation for the thumb bone inside the hand.

1. Wire Gonzo_Bone_ RThumb03’s Y
Rotation to Thumb02 with the expression
degtorad(Thumb02).

2. Wire Gonzo_Bone_ RThumb04’s Y
Rotation to Thumb02, using the expression
degtorad(Thumb02).

3. Select Gonzo_Bone_ RThumb01, the thumb
bone that is part of the palm.

4. Wire the Gonzo_Bone_ RThumb01’s Y
Rotation to Thumb01. Make sure you change
the expression in the lower left entry area to
degToRad(Thumb01) before connecting the
wiring.

You can leave the Parameter Wiring dialog open
to wire the remaining axes on Gonzo_Bone_
RThumb01, as they are all displayed on the
Parameter Wiring dialog at this time.

5. Wire Gonzo_Bone_ RThumb01’s X Rotation
to ThumbRoll, and use the expression
-degToRad(ThumbRoll).

The negative sign in front of the expression will
invert the X rotation to the opposite direction.

6. Wire Gonzo_Bone_ RThumb01’s Z Rotation
to ThumbRoll, using the expression
degtorad(ThumbRoll).

Gonzo_Bone_ RThumb02 does not need any
rotation of its own, so it is not wired to any
custom attribute. It simply follows the rotation
of Gonzo_Bone_RThumb01.

7. Test the wiring by selecting Gonzo_CNT_
Rhand and changing the ThumbRoll value. The
thumb should rotate about its X and Z axes.

8. Reset the spinners to 0 before continuing.

9. Save the scene as my_handrig_06.max.

You can find a version of this scene in the file
tut_handrig_06.max.

Change the thumb’s rotation calculation order:

If you increase both ThumbRoll and Thumb01,
you will find that the rotation starts to behave
unnaturally as these two values increase past 30
or 40.

With the Euler XYZ controller, the rotation around
the X axis is calculated first. Then the Y and Z
rotation are added to it, in that order. The rotation
on the base thumb joint would work better if the Y
rotation were calculated first. This would ensure
that the base thumb joint always curls into the
palm a predictable way.

The ThumbRoll parameter affects only the Z and
X rotation. This parameter would work more
naturally if the X rotation, which swings the thumb
down away from the hand, were evaluated before
the Z.

You can change the order in which the Euler XYZ
controller evaluates the axes’ rotations by changing
a parameter on the Motion panel. In this case, you
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will cause the base thumb joint’s Y rotation to be
calculated first, then the Z and X respectively.

1. Select Gonzo_Bone_ RThumb01.

2. Go to the Motion panel.

3. On the PRS Parameters rollout, click the
Rotation button at the bottom of the rollout.

4. In the Euler Parameters rollout, change the Axis
Order to YZX.

5. Test the new axis evaluation order by selecting
Gonzo_CNT_Rhand and increasing the
ThumbRoll and Thumb01 values. The thumb
should rotate more naturally.

6. Reset the spinners to 0 before continuing.

7. Save the scene as my_handrig_07.max.

You can find a version of this scene in the file
tut_handrig_07.max.

Create a pointing pose:

The current rig allows you to create a number of
poses for the hand, such a pointing, grabbing, and
making a fist.

Rather than having to animate individual custom
attributes each time you want to animate the
hand, you can set up a custom attribute for each

common hand pose. When you choose a preset
pose, the appropriate custom attributes change
automatically.

First, you will set up a pointing pose.

1. Select Gonzo_CNT_Rhand.

2. On the Modify panel, in the Hand Controls
rollout, set the custom attributes to the
following values:

• Index 01: -17

• Index 02: -26

• Baby 01: 68

• Baby 02: 60

• Thumb 01: 29

• Thumb 02: 1

• ThumbRoll: 35

• Cup: 54

• Splay: 15

The hand takes on a pointing pose.

3. In the Presets rollout, in the Name field, enter
Point.

4. Click the Add button.

The name Point now shows up in the Presets
drop-down list.
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To test how the presets work, you will reset the
spinners to zero, then apply the Point preset.

5. Click the Reset All button.

This resets all the spinners to a value of 0.

6. On the Presets drop-down list, choose Point.

The values on the rollout change, and the hand
snaps to the preset pose.

Create a fist pose:

1. Create a fist pose with these values:

• Index 01: 79

• Index 02: 59

• Baby 01: 67

• Baby 02: 57

• Thumb 01: -18

• Thumb 02: 12

• ThumbRoll: 55

• Cup: 54

• Splay: 15

2. In the Presets rollout, in the Name field, enter
Fist.

There are now two presets in the Presets
drop-down list. These presets are stored with
the MAX file.

3. Click Reset All.

4. Save the scene as my_handrig_08.max.

You can find a version of this scene in the file
tut_handrig_08.max.

Animate the hand:

1. Unhide all the objects in the scene.

This displays Gonzo’s skin, so you can see how
the skin on the hand is affected by the bones.

2. Go to frame 10.

3. Turn on Auto Key.

4. Select Gonzo_CNT_Rhand, the right hand
control object.

5. Choose Fist from the Presets drop-down menu.

6. Go to frame 20.

7. Choose Point from the Presets drop-down
menu.

8. Scrub the time slider back and forth.
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The hand animates, going from the neutral
pose to a fist, then to a pointing pose.

9. Turn off Auto Key.

10.Save the scene as my_handrig_09.max.

You can find a version of this scene in the file
tut_handrig_09.max.

Rig the left hand:

If you like, you can rig the left hand in the same
way.

1. If you want to rig the existing bones, you can
copy the PEN_Attribute_Holder 2 modifier
from the right-hand control to the left-hand
control to save time in creating the custom
attributes. Then you can rig each parameter
separately.

2. You can also save the presets by clicking Save
on the Presets rollout. You can save presets to
a CPS file, and then select the left hand control
and use the Load button to load the presets
onto the left hand.

Another option is to copy and mirror the right
finger bones and the right hand control object
to the other side of the body. This will save
you from having to rewire all the parameters,
since the custom attributes and their wiring
are copied as well. However, you will have to
rename the bones to match the other bones on

the left side of the body, and add these bones to
Gonzo’s Skin modifier.

You can find a scene with both hands rigged in
the file tut_handrig_10.max.

Summary

In this tutorial, you learned numerous techniques
for creating a character rig that could be used for a
professional production. Now you can adapt these
tools to your own characters and create custom
rigs.

Using Schematic View

Using Schematic View

Schematic View provides the professional user
with a graphical representation of the logic of
a scene that makes complex hierarchies easier
to navigate and manipulate. In addition to it
being a powerful interactive tool for refining
your animation, Schematic View functionality
is accessible to scripting, making it extensible
through the MAXScript programming language.

Skill Level: Intermediate

Time to complete: 40 minutes

Features Covered in This Tutorial

• Exploring a Scene

• Controlling Schematic View Display

• Using Bookmarks

• Adding Background Maps

• Saving Schematic View Layouts

• Creating Hierarchies with Schematic View

• Copying Modifiers in Schematic View



Exploring a Scene 411

• Wiring parameters

• Scripted Tools for Schematic View

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\schematic_view folder. Before doing the
tutorials, copy the \tutorials directory from the CD
to your \3dsmax8 local installation.

Exploring a Scene
Set up the lesson:

• Open tut_schematic_explore.max.

Note: Files for this tutorial are located
on the Tutorial Files CD in the
\tutorials\schematic_view folder.

Explore an unknown file:

It’s quite common to receive an animation scene
file that you haven’t worked on yourself. Here
are the steps you might use when exploring an
unknown file.

1. View the model in the viewport. Use Arc
Rotate to navigate around the object.

Only a mesh object is visible in the viewport.

2. Play the animation in the viewport.

The character hops on its single foot.

3. Move to frame 0, right-click the active viewport
and choose Unhide All from the quad menu.

Now you can also see some of the bones and
control objects in the viewport.
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4. In the viewport, click the mesh of the character
to select it.

The name of the mesh object appears in the
name field on the command panel.

5. In the active viewport, right-click the mesh
object and choose Properties. In the Display
Properties group, turn on See-Through. Click
OK to close the dialog.

The character turns semi-transparent, so you
can see the bones within.
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The bones are difficult to see. Next, you’ll
change the color of the bones, to make them
more visible.

6. On the toolbar, click the drop-down arrow on
the Selection Filter list. Choose Bone, then drag
around all the bones.

All the Bones are selected in the viewport.

Tip: You can also select all the bones using the
keyboard shortcut CTRL+A.

7. Near the top of the Modify panel, click the color
swatch next to Multiple Selected.

The Object Color dialog appears.

8. Change the color of the bones to a medium red.

You can see all the visible components now, but
you can’t see the relationships between them. For
that, you need to use Schematic View.

Open Schematic View:

• On the toolbar, click the Schematic View
button.

The Schematic View appears across the top two
viewports.

Tip: It’s a good idea to run 3ds Max full screen
when using Schematic View. If you have dual
monitors, you can move the Schematic View
window to the second monitor.

The Schematic View shows all the objects in the
scene, whether or not they are hidden in the
viewports. Every component of your scene is
displayed as a node, a box with text. The nodes
are connected by wires which can represent the
hierarchy or other types of relationships such as
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parameter wiring, expressions, controllers, and
constraints.

You can display a great deal of information for each
node including controllers, constraints, materials,
maps. If you display too much information at once
the result will be information overload, so it’s a
good idea to learn to control the display.

Information overload

Tip: Use List Views when the Schematic View
window is exceedingly complex.

Control the Schematic View display:

In addition to the Schematic View window, there
is a separate Display floater. You can use this to
determine which relationships and entities are
visible in the Schematic View window.

Note: In order to perform certain operations, you
must have the correct display choices selected. For
example, if you copy modifiers, you need to have
Modifiers turned on in the Relationships group,
and Modifier Stack turned on in the Entities group.

1. Press and drag the Display Floater and position
it so it’s visible on the right side of the Schematic
View window.

Note: The Select button on the Schematic View
toolbar is used to select and move nodes in the
Schematic View window.

2. On the Display floater in the Relationship group
turn on Controllers.

Note: There is a Controller button in both
groups: make sure you click on the button in
the upper group.

In the Schematic View window, you can see
salmon-colored wires now connecting three
green IK nodes on the left with blue Bone nodes
on the right .



Exploring a Scene 415

3. Turn off Controllers and turn on Param Wires.

Purple lines connect the three green IK nodes
to the light blue CtrLFoot node above it.

4. On the Display Floater, turn on all the
Relationships.

The display is cluttered with lines.

5. On the Display Floater, turn off all the
Relationships except Modifiers.

6. In the Entities group, turn on Modifier Stack.

The Modifiers in the scene appear as ochre
colored boxes beneath the objects. Lines
connect the Skin modifier with the Bones in
the scene.

Note: There are no materials or lights in this
scene so choosing those options will have no
effect.

7. On the Display Floater, turn off everything,
then turn on Controllers in both the
Relationship group and the Entities group.

8. Use the Zoom button on the Navigation
controls at the lower-right of the Schematic
View window to zoom the viewport back.

Notice that the text attempts to remain visible
for as long as possible, but eventually it becomes
too small to read.

9. Use the Zoom Extents button on the
Navigation controls at the lower-right of the
Schematic View window to zoom the viewport
so all the nodes are visible.

10.Turn off all the buttons in the Display floater
before continuing.

Always Arrange Mode:

There are various buttons on the Schematic
View toolbar used to arrange the nodes. Always
Arrange is a mode that continually updates the
arrangement of the nodes according to certain
settings. You can use Always Arrange to recover a
nicely arranged schematic view.

1. On the Schematic View main toolbar,
click the Select button. Press and drag the node
labeled CtrlFoot to the left of the darkened grid
pattern.
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2. Select the node labeled CtrlSpine and drag it to
the left, off the darker grid as well.

The node and its children all move off the grid.
If you drag far enough left, the viewport will
pan dynamically to make room for the node.

3. Now click Always Arrange.

The nodes shift position back onto the darker
grid.

4. Now try to pick up the node marked CtrlFoot
and move it off the grid.

You can’t. Always Arrange is maintaining
the arrangement, so you can’t shift anything
around.

5. Turn off Always Arrange.

Use the Free and Arrange tools:

When Always Arrange is off, you have access to
four tools for arrangement.

Free All and Free Selected let you reposition nodes
and their children anyway you like. Arrange
Children and Arrange Selected clean up and
automatically rearrange node position based on
preference choices.

1. Click the CtrlFoot node to select it.

2. Double click it to select all its children.

3. Click Free Selected.

4. Move the children so they are above, below,
right, and left of the node.

Tip: You can click outside the nodes to deselect,
then click the nodes to move them individually.

5. Turn off Move Children and move the
CtrlFoot node.

It moves independently.

6. Click the Move Children button and again
move the CtrlFoot node.

The children move with the parent even when
they are not selected.

7. Click Arrange Children.

The three green nodes neatly stack between the
CtrlFoot object.

While you’re working, you might need to collapse
or expand the selected nodes and their children.
You do that using Expand and Collapse Selected.

Use Expand and Collapse Selected tools:

1. Click again to select the CtrlFoot node.

2. On the toolbar, choose Collapse Selected.

The three green nodes disappear, and there is a
down-pointing arrow below the CtrlFoot node.
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3. Zoom in so the CtrlFoot node is large and easily
visible. Then click the down-pointing arrow.

The node expands, and the IK Toe node
appears.

4. Click the down arrow again to expand the IK
Ball node, and again to display the IK Ankle
node.

Note: The character rig here uses a reverse foot
setup, so the hierarchy is reversed (the toe is
the parent of the ankle).

Next, you’ll learn to use Bookmarks.

Use Bookmarks:

You can place bookmarks at different locations in
the Schematic View, and then easily jump from
one location to the next.

1. On the Display Floater, turn on Controllers in
both the Relationship and Entities group.

2. Click Always Arrange.

The nodes reposition themselves when Always
Arrange is clicked.

3. Turn Always Arrange off.

4. Click Zoom Extents so you can see the all the
nodes in the window.

5. Now use Region Zoom and draw a zoom
rectangle around the lower-right corner of the
displayed nodes.

You should see a node named BoneToeNub.

6. Press the B key on the keyboard. Bookmark01
appears in the Bookmark Name field.

7. On the Schematic View toolbar, in the
Bookmark Name field, highlight Bookmark01
and enter BoneToeNub.

You’ve just created a bookmark.

8. Click Zoom Extents to zoom back out.

9. Again use Region Zoom, this time dragging a
selection rectangle around the lowest nodes on
the left.

You should see a node named IK Ankle.

10.Press B on the keyboard, then on the Schematic
View toolbar in the Bookmark Name field,
enter IK Ankle.

You’ve created a second bookmark.

11.Once more use Region Zoom, this time
selecting the lowest nodes in the middle area.

You should find a node named BoneHead.

12.Again press B, then on the Schematic View
toolbar in the Bookmark Name field, enter
BoneHead.

A third bookmark has just been created.

13.Click Zoom Extents so the entire Schematic
View window is visible.

14. On the toolbar, click Go To Bookmark.

The viewport zooms in to the bookmark
displayed in the bookmark field.

15.Press the right arrow key on the keyboard.

The viewport jumps to the next bookmark.

16.Press the right arrow key again.

You can cycle through all the bookmarks in this
way.

Add a background:

You can add a background image to the Schematic
View window and then arrange the components
over the image to create a visual navigation aid.
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1. Create a bitmap image from your Front
viewport.

There is already a bitmap image created for you.

Use this image as a background map

Note: The steps to create this image are quite
simple. Set up your viewport to display as
you like, then press the Print Screen button to
capture the desktop. Use a paint program to
crop the image to just the viewport that you
need.

2. Once the image has been created, choose
Options > Preferences on the Schematic View
menu bar.

3. In the Background Group, click the
blank File name button. Navigate to the
\tutorials\schematic_view folder and choose
pluggo_seethru.bmp.

4. Turn on Show Image, then close the Preferences
dialog.

The image is displayed in the Schematic View
window.

5. To manually move the components over
the image, click Free All, then move the nodes
one at a time over the image in the window.

Use Shrink Selected:

For convenience, you can eliminate the clutter
in your Schematic View by using the Shrink
commands.

1. Select all the nodes in the Schematic View,
except for the BoneHead node.

2. Right-click and choose Shrink > Shrink
Selected.

The Schematic View window nodes all shrink
into dots, except for the BoneHead node.
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Shrink Selected used to remove clutter.

Save and Retrieve the layout:

To save your Schematic View, you give it a name.

1. On the Schematic View toolbar, just right of
the Preferences button, enter a name for your
SV in the Schematic View name field. Name
this Node Map.

2. Once you have entered a name, you close the
Schematic View window by clicking the X
button in the upper right corner of the window.

3. To retrieve your layout, on the 3ds Max menu
bar, choose Graph Editors > Saved Schematic
Views > Node Map.

The saved layout reappears.

Creating Relationships in
Schematic View

Schematic View gives you an alternative workspace
for creating relationships in your scene. Instead
of performing operations in the viewport, you
can do the work in the Schematic View window.
This is particularly useful when you have complex
scenes with multiple characters, large quantities of
lights, or materials with numerous maps. While
not all operations can be accomplished within the
Schematic View window, you’ll find that using this
editor will speed up your workflow.

The Connect tool is used to create hierarchies, and
also instance controllers, modifiers and materials
between nodes. It is similar to the Select And
Link tool in 3ds Max except its functionality is
expanded within Schematic View.

Setup the Lesson:

• Open tutorials\schematic_view\tut_schematic_
view_fix_anim.max.

This is a very simple animated scene with a
bone structure and some controls.

Find the problems:

• Play the animation in each of the viewports.
Activate the viewport, then press the Play
button in the Animation playback controls.

In the Front viewport, notice that one of the
tail links is not swinging back and forth with
the rest of the tail.
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Problem with tail bone animation

Also, from the Left viewport, you can see that
the tail is not dropping with the rest of the
skeleton

Tail does not follow Pelvis dummy.

It looks like there might be a problem with the
hierarchy.

Create hierarchies using Connect:

1. On the toolbar, click the Schematic View
button.

Schematic View displays across the top two
viewports.

2. On the Schematic View toolbar, turn on
Always Arrange.

Answer Yes to the warning.

3. On the Schematic View toolbar, click
Hierarchy Mode.

The nodes rearrange themselves into indented
lists. This makes it much easier to understand
the structure of the hierarchy.

You can now see that the Bone tail hierarchy
chain is not linked to the Pelvis dummy.

4. On the Schematic View toolbar, click
Connect.

5. Drag from the Bonetail1 node to the Pelvis
dummy node and then click.
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Because Always Arrange is on, the Bonetail
chain moves in the Schematic diagram so it is
under the Pelvis dummy.

Wiring Parameters:

You can wire parameters directly inside Schematic
View using the quad menu.

1. On the Display floater, turn on Param Wires.

2. In the Schematic View window, right-click
the Pelvis dummy node, then choose Wire
Parameters from the edit quad on the lower
right.

3. Choose Transform > Rotation > X Rotation.

4. Drag to the CTRL-pelvis rotation node and
click.

5. Again choose Transform > Rotation > X
Rotation.

The Parameter Wiring dialog appears.

6. Now you must assign the control direction
so that the CTRL- pelvis rotation object will
control the Pelvis dummy rotation. Choose the
left pointing arrow, then click Connect.

7. Repeat the process for the Y Rotation and Z
Rotation.

The parameter wiring is displayed as purple
lines between the nodes.

8. Double click any of the purple lines.

The Parameter wiring dialog reappears. You
can edit parameter wiring in this way.

9. In the viewport, select the CTRL– pelvis
rotation object and rotate it.

Observe that the bones are now affected by the
shape object.

Controls wired used Schematic View

Notice that in the left viewport, the tail now moves
downwards with the rest of the hierarchy. One
problem has been solved.
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The tail animation is still incorrect, however.
It appears that this problem is not related to
hierarchy. You will use the List Viewer to uncover
what is wrong here.

Using List View:

1. On the List Views menu, choose All Instances.

The Instance list view dialog appears.

2. If you click the Object header you’ll see the list
rearrange by object name.

3. Click the Entity header so the list is rearranged
by Instanced relationship.

Notice there are four instances of a Bend
modifier. Although there are five bone objects

in the tail, only four of them have the instanced
Bend modifier. Bonetail2 is not in the list.

4. Close the List Viewer.

Copying the modifier:

1. In Schematic View on the Display Floater, turn
on Modifiers in the Relationships group, and
Modifier Stack in the Entities group.

The modifiers appear as mustard-colored
nodes beneath the Bone nodes.

2. Zoom in so you can see the Bone tail nodes.

3. On the Schematic View toolbar, click the
Connect tool.

4. Drag from the Bend node (beneath the Bonetail
1 node Modified Object) to the Bonetail2 node.

The Attach Modifier dialog displays.

5. In the Attach Modifier dialog, choose Copy,
and click OK.

6. The Bend modifier is now copied to the
Bonetail2 node.

7. Play the animation in the front viewport.

The tail link now is animated, but it’s still not
correct. The gizmo needs to be repositioned
and rotated to match the other nodes.

8. In the Left viewport, select the Bonetail2 object,
then on the Modifier stack highlight the gizmo.
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9. In the Left viewport, reposition the gizmo so it
is lined up with the tail (see the illustration).

Now the gizmo matches the position of the
modifier on the other objects.

10.Play the animation again. Now the tail swing
is correct.

11.Save your file as mytut_schematic_view_
fixed_anim.max.

The same method of using the Connect tool can
be applied to copying or instancing Materials,
constraints, and controllers. For new controllers.
you can use Assign on the quad menu.

Note: While you can copy materials and modifiers,
you can not assign new materials and modifiers to
objects using Schematic View.

Tip: Apply a material or modifier using the
standard techniques to a “throwaway” object in the
scene in order to get access to these in Schematic
View.

Using Scripted Tools in Schematic
View

Schematic View is now accessible to scripting.
We’ve included several unique scripted tools to
demonstrate the power of this functionality. Here
you’ll learn the process of adding scripted tools
to the Schematic View quad menu, and you’ll try
out the use of these tools.

Note: These scripts are simply samples; they are
not intended to be complete tools. They are
unsupported (unofficial tools).

Set up the Lesson:

1. Using Windows Explorer (or My Computer),
navigate to \3dsmax8\scripts\MAXScriptTools.

If, for some reason, the scripts do not
appear in that folder, they are also
available on the Tutorials Files CD, in the
\tutorials\tutorial_scripts directory.

2. Copy Macro_SchematicViewTools.mcr to the
\3dsmax8\UI\MacroScripts folder.

3. Close Windows Explorer (or My Computer).

4. Open tut_schematic_view_script_tools.max.

Files for this tutorial can be found in the
\tutorials\schematic_view folder.

5. On the MAXScript menu, choose Run Script.
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6. Navigate to and highlight Macro_
SchematicViewTools.mcr, then click
Open.

This runs the script, so it is now available to be
put into the interface.

Next, you will add the scripted tools to the
Schematic View quad menu.

Add the script tools to the quad menu:

1. On the Customize menu, choose Customize
User Interface.

2. Click the Quads tab.

3. Click the drop-down arrow at the upper-right
and choose Schematic View Quad.

4. Click each of the yellow quads to view which
tools are located on each quad. Then highlight
the edit quad, which is the lower-right
quadrant.

Now you will locate the tool in the Action table.

5. Leave the Group set to Main UI, then click
the drop-down arrow on the Category field.
Choose Schematic View Tools from the
Category list.

A list of Schematic View tools is now visible in
the Action window.

6. Locate Animate Project Into Schematic View,
then drag it to the edit quadrant, directly below
Wire Parameters.

7. Locate Project Into Schematic View in the
Action window. Drag it to the edit quadrant.

8. Locate Schematic Spacing Tool in the list, and
drag it also onto the edit quadrant.

9. Click Save, and save a .mnu file. You can accept
the default name, or create a new one of your
own.

10.Close the dialog using the X button at the top
right.

The three scripted tools are now ready to be used.
You will access them through the Schematic View
quad menu.

Use the scripts:

1. Activate the Front viewport.

2. On the toolbar, click the Schematic View
button.

Schematic View displays across the top two
viewports.

3. Drag a selection rectangle around all the objects
in the Schematic View window, then right-click.

The nodes are selected and the quad menu
appears.

4. On the Schematic View toolbar, click
Hierarchy Mode.

5. Click on Pelvis Dummy to select it, and then
double-click it to select all the objects below it
in the hierarchy.

6. Right-click on the selected objects. On the edit
quad, choose Project Into Schematic View.
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A second Schematic View window appears. In
this window, the nodes are arranged to match
their placement in the Front viewport.

Some of the nodes are too close together.

7. Right-click in the second Schematic View
window and choose Schematic Spacing Tool.

8. Drag the slider and watch the nodes move apart.

9. Close the Spacing tool.

10.Select all the objects in the Schematic View
window and right-click.

11.Choose Animate Into Schematic View from the
edit menu.

12.Click the play button on the Animation
playback controls. Watch the Schematic View

window. The node diagram animates to match
the animation in the viewport.

Note: You may notice that the tail isn’t swinging
in the animated Schematic view projection.
This sample script was written to use the
transform information in the nodes, and
doesn’t read the animated modifiers.

Summary

This tutorial has covered how you can use
Schematic View to explore the contents of a scene,
display scene information in various ways, and
wire object parameters.

Skinning

Using the Skin and Flex Modifiers

The Skin modifier associates a skeleton with
a mesh, allowing you to animate the mesh by
animating the skeleton. The Skin modifier works
on simple animated structures as well as character
meshes. You can use the modifier to control
creasing and muscle bulging.
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Skill Level: Intermediate

Time to complete: 2 hours

Features Covered in This Tutorial

• Applying the Skin modifier

• Using envelopes to adjust the effects of the Skin
modifier

• Using a Joint Angle deformer to improve skin
deformation

• Using a Bulge Angle deformer to simulate a
flexing muscle

• Using the Flex modifier to add secondary
motion to animation

Tutorial Files

You can find the files for this tutorial in the
tutorials\character_animation\skin_flex folder
on the Tutorial Files CD that ships with 3ds Max.
Before starting the tutorials, copy the \tutorials
folder from the CD to your \3dsmax8 local
installation.

Applying Skin to the Alien

In this lesson, you will apply the Skin modifier
to the alien model. You will adjust envelopes
and vertex weights for the model’s left side, then
mirror the settings to the right side. In doing so,
you’ll learn the following techniques:

• Changing the envelope start or end point

• Copying and pasting multiple envelopes

• Painting vertex weights

• Using the weight table

• Mirroring vertex weights

Alien model with skin controlled by bones

Time to Complete: 1 hour

Note: If you have never used the Skin modifier
before, you should do the Skinning (page 2–325)
lesson in the Introduction to Character Rigging
(page 2–299) tutorial before doing this lesson.

Set up for this lesson:

• Load the file tut_skinalien_start.max.



Applying Skin to the Alien 427

This is the character that was set up in the
tutorial Creating Complex Character Rigs
(page 2–349). The rig is in the scene, but it is
currently hidden because it isn’t needed for the
skinning process.

Reference pose in user view, with visible bones

Apply the Skin modifier:

1. Select MeshBody.

2. On the Modify panel, apply the Skin modifier
to MeshBody.

Note: In this case, you applied the Skin modifier
to just one object. You can also apply it to
multiple objects at the same time.

3. On the Parameters rollout, click Add, and select
all the objects on the list.

There are other bones in this scene, but the ones
not being used for skinning have been hidden.

4. Choose Edit > Select Invert.

This selects everything except MeshBody: that
is, all the bones in the scene.

5. Hide the bones by right-clicking a viewport and
choosing Hide Selection from the quad menu.

Display and adjust the shoulder envelope:

1. Select MeshBody.

2. In the Front viewport, zoom in on the shoulder
area of the model.

3. On the Parameters rollout, click Edit Envelopes
to turn it on.

Selectable bones, with handles on each end

Each envelope selector displays over its
corresponding bone as a dark gray line with
circular handles on each end.

Tip: While Edit Envelopes is active, the Select
button is disabled. If you have a mouse with a
wheel, you can zoom and pan without trouble.
If you don’t have a wheel mouse, after you zoom
and pan, toggle Edit Envelopes off and then on
again, so you can select envelopes once more.

4. Click the left shoulder envelope line to display
the corresponding envelope.
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Left shoulder envelope selected

Note: In this lesson the “left shoulder” means
the character’s left side, not your own left.

Each envelope consists of an inner envelope
(bright red) and an outer envelope (dark red).

The vertices inside the inner envelope receive
the most influence from the bone, while vertices
between the inner and outer envelopes receive
less influence. The farther the vertex is from
the inner envelope, the less it is influenced by
the bone.

For a smooth skin, outer envelopes for adjacent
bones should overlap slightly. This will cause
the skin in a joint area (knee, shoulder, elbow,
hip) to be influenced partially by each bone,
making a smooth skin transition at joints.

As you adjust an envelope, the vertices inside
the envelopes change color to show the degree
of influence from the envelope. Red vertices
receive the most influence, while blue vertices
receive the least.

5. Move one of the outer envelope handles to
decrease the size of the envelope.

Adjusting the outer envelope

Change the envelope’s length and direction:

The shoulder envelope sits a little too far into the
arm. You can change the length and direction of
an envelope by moving one of its end handles.

1. In the Front viewport, notice the two handles
within the inner envelope. These control the
envelope length. Select the right handle. When
selected, it turns purple.

2. Move the handle to the left to shorten the
envelope.

Shortening the envelope

3. Make adjustments to the inner and outer
envelopes and the envelope length until it looks
like the following image.
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Size and shape of the shoulder envelope corrected

4. In the Front viewport, adjust the arm envelopes
to look like the pictures below.

Envelope for the upper arm

Envelope for the lower arm

Paste to multiple hand envelopes:

1. In the Top viewport, zoom in on the left hand.

2. Select one finger bone, and adjust its envelope
so it just encompasses the finger mesh, and
overlaps the next bone a little bit.

Finger joint envelope adjusted

3. In the Envelope Properties group, click
Copy.

4. From the Paste flyout, choose Paste to
multiple bones. This is the last button on the
flyout.

5. In the Paste Dialog, choose all bones that
contain the word “finger”, “thumb” and
“hand”. Click OK to paste the envelope settings
to these bones.

6. Check the envelopes at the fingertips and
make sure they cover the entire mesh fingertip.
Adjust if necessary.

7. Adjust the main left hand envelope as shown
in the following image.
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Main hand envelope adjusted

8. In the Envelope Properties group, click
Copy.

9. Choose Paste to multiple bones. Paste
the selected envelope onto the HandRBONE
envelope.

Later in this lesson, you will learn how to mirror
envelopes and vertex weights from one side of
the character to another.

Adjust the body envelopes:

1. In the Front viewport, adjust the top chest/spine
envelope (spine05BONE) so the outer envelope
is not huge (as it is by default), but make sure
each envelope encompasses the torso from side
to side.

Spine envelope adjusted

2. Repeat the previous step for the other spine
bones: spine04BONE through spine01BONE.
The envelopes for all the spine bones should
be similar. You can alos use the copy/paste to
multiple bones combination to that effect.

Adjust the head envelopes:

1. In the Left viewport, adjust the neck envelopes
so they encompass the mesh and overlap
slightly.

Neck envelopes adjusted

2. Adjust the main head bone’s envelope so it
encloses the head, but is not too much larger.
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Main head envelope adjusted

3. The bone just above the main head bone
(hair1BONE) appears to be a single dot because
it is aligned perpendicular to the left view.
Leave it to its default settings and move to the
next bone in the chain.

4. Adjust the envelopes for the alien’s “topknot”
so they follow the contours of the mesh.

Adjusted topknot envelopes for the alien

Adjust the legs:

• In the Front viewport, adjust the envelopes for
the character’s left leg. You will have to move
the thigh’s top handle downward. Leave the left
foot for the next procedure.

Adjusted leg envelopes

Adjust foot envelopes:

1. In the modify panel, select the footLBONE. You
can also select that envelope in the User view
where it is easier to locate.

2. In the Left viewport, zoom in on the foot.

3. Adjust the character’s upper foot envelope so
the outer envelope is just outside the foot. You
will need to move the handles to make the foot
envelope parallel to the foot.

Upper foot envelope aligned and adjusted

4. Adjust the left toe envelope so it is similar to
the upper one.

Adjusted toe envelope
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You can find a scene with the envelopes adjusted
in the file tut_skinalien_envadjust.max.

View envelope influence:

1. Select the left toe envelope, and zoom in on the
left foot in the User viewport.

Shaded user view of the toe envelope

In a shaded viewport, the model is shaded in
red, yellow and blue to show the influence of
inner and outer envelopes, with red indicating
the strongest influence and blue a weak
influence or no influence at all.

The toe is mostly red, fading to yellow, then blue
where the toe meets the foot. This indicates
that the toe is influenced strongly by its bone.
These envelopes will work well with the bone
structure and mesh.

2. Select the top chest envelope (spine04BONE),
and look at the colors.

Shaded view of chest envelope

The colors on the chest area indicate that the
chest is barely influenced by the bone. This
presents a problem. The envelope is too small
to include the chest vertices. But if you increase
the size of the envelopes, they will encompass
the arms and neck.

You can solve this problem by painting weights.

Set painting options:

Envelopes assign weights to each vertex to define
how strongly the envelope influences the vertex. A
vertex weight can range from 0 to 1. A weight of
0 means the bone doesn’t affect the vertex at all.
At 0.5, the vertex is 50% affected by the bone, and
50% affected by one or more other bones. At a
weight of 1, the vertex is 100% influenced by that
bone alone.

Each vertex can have weights from several different
bones, but all the weights must add up to 1.

In an envelope, red vertices have a weight closer
to a value of 1, while blue vertices have a weight
closer to a value of 0.

The Skin modifier allows you to “paint” weights
onto vertices with the cursor, so vertices outside
an envelope can still be influenced by the bone.

1. In the User viewport, select the spine04BONE
chest envelopes and zoom in on the area.
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2. In the Parameters rollout > Weight Properties
group, click Paint Weights.

3. In the User viewport, move the cursor over the
chest area. Don’t click or drag just yet.

The default paint gizmo is too large for this model.

A large paint gizmo appears. As you move the
gizmo over each polygon, the line pointing out
from the gizmo shows the polygon’s normal
direction.

This gizmo is too big for painting this character.

4. Click the Painter Options button next
to Paint Weights.

5. On the Painter Options dialog, change Max
Size to 6 and press Enter. Leave the dialog open.

6. Move the cursor over the chest again. Now the
gizmo is a more manageable size.

Paint vertex weights:

1. In the Front viewport, click and drag over the
chest area.

As you drag over areas, the vertices in the area
turn red. In the User view, you can see that the
mesh in these areas is also red.

Painting chest envelope weights

2. Change the User view to a Perspective view, and
then use Arc Rotate to rotate the view so you
can see the back of the model.

While you’ve been painting the front of the
model, the back hasn’t been getting painted.

3. In the Painter Options dialog, turn on Mirror,
and set the axis to Y.

4. Click Paint Weights again. In the Front
viewport, click and drag the cursor over the
chest again.

In the Perspective viewport, you can see two
gizmos moving simultaneously, one on the
front of the mesh and the other on the back.
The Mirror option on the Paint Options dialog
causes the paint strokes on one side the mesh to
be duplicated on the other side.

Mirroring the paint tool to affect both the front and
back of the model
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5. Select another spine envelope from the list
of bones on the Parameters rollout, and
paint weights for it. Perform this step for
each of the spine bones (1 through 5) except
spine06BONE.

6. Close the Painter Options dialog, and turn off
Paint Weights.

7. Exit Edit Envelopes mode.

Test the skin setup:

After adjusting envelopes and vertex weights for
the left side, test the setup before you mirror it.

1. Continue working on your file or open
tut_skinalien_vertex_weighting.max

2. Unhide footLCTRL.

3. Turn on Auto Key.

4. Go to frame 10, and then move footLCTRL in
front of the character to lift the left foot into the
air as if to take a step.

Note: It is common practice, and generally a
good idea, to reserve frame 0 for the reference
pose of the character.

Some problems with deforming or “wandering” vertices

You might see some deforming as the foot
moves, especially at the joint between the thigh
and the hips. The steps that follow show ways to
correct these problems. These steps show what
to do if any part of the body mesh is deforming
too much as it follows the bones, or is following
a bone that it shouldn’t.

Note: In versions of 3ds Max prior to version 8,
vertices could wind up unassigned, and stay
in position when the nearest bone is moved.
That problem has been fixed: in version 8,
each vertex is assigned to a bone; however, the
envelope shapes and vertex weighting may still
need adjustment.

5. Turn off Auto Key.

Adjust vertex weights using the Weight Tool:

The Weight Tool is handy for quickly adjusting
weights for several vertices. For example, take a
look at the joint between the thigh and the hips.
The area is crumpled, and the skin isn’t stretching
correctly with the leg. Fixing this problem with
envelopes alone would be extremely difficult, if
not impossible.

1. In the User viewport, zoom in on the hip area.
Press F4 to turn Edge Faces Mode on.

2. On the Modify panel > Parameters rollout,
turn on Edit Envelopes, and then, in the Select
group, turn on Vertices. Make sure the Backface
Cull Vertices option is off.

3. Scrub the animation to see the problem with the
weighting. The vertices are behaving erratically
around the joint.
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Problems with vertices around the joint area.

4. Go back to frame 0. From the main tool
bar choose the Lasso Selection tool.

5. In the Web Properties group, click
Weight Tool to turn it on.

The Weight Tool dialog appears.

The Weight Tool is a new tool that was
introduced in 3ds Max 8. It provides some
convenient ways to select vertices and adjust
weights.

6. Zoom in on the hips in the Front viewport.
Select a couple of vertices right below the joint.

Two vertices selected around the thigh ring.

7. In the Weight Tool window, click the Loop
button to select the vertices connecting the loop
around the thigh.

Vertices selected around the thigh.

Notice that the selected vertices are shown as
100% weighted (1.000) to the upperLegLBONE
in the Weight Tool window.

8. Using the lasso tool, select the ring of vertices
surrounding the joint.
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Notice how these vertices are currently assigned
to the upperLegLBONE at full value (100%).
Some of the strength applied to these vertices
should be assigned to the lower spine envelope.

9. With the vertices still selected, select the lower
envelope (spine01BONE) in the User viewport.
You can also select that envelope from the
envelope list in the Modify panel.

10.In the Weight Tool dialog, click the .25 button.
This changes the selected vertices weighting
so that they are 75% weighted to the bone and
25% weighted to the lower spine.

11.Scrub the animation. The vertices starting from
the joint and running down the leg are now
reacting nicely, but the vertices above the joint
line still need some work.

Problem with vertices above the thigh.

12.Select another ring of vertices above the joint
line. Use a combination of different viewports
to make your selection. It would also help to arc
rotate around the user viewport to help with
the selection.

Vertices selected above the joint line.

13.With the vertices and the lower spine envelope
still selected, click the .5 button on the weight
Tool window.

14.Adjust the weights in the Weight Tool window
by selecting an envelope in the list and clicking
a weight button. Set the weights so that the
spine has about 50% control, the left leg about
40%, and the right leg about 10%.
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15.Select a few vertices situated above the previous
selection.

Vertices selected on one side of the belly area.

16.Adjust the weights so that the spine is 75%
active and the left leg 25% active. Set the right
leg to 0% strength for these vertices.

17.Scrub the animation. the joint area is getting
better but you still need to fine-tune the
weighting of some vertices.

Individual vertices need adjustments.

18.Alternate between frames 0 and 10 to identify
the problem areas. select vertices individually
or as a group and adjust their weighting in
the Weight Tool window. If you want to use a
percentage value other than the preset buttons,
you can use the Set Weight button after entering
the appropriate value.

Using Set Weight to apply custom weight values

19.Adjust the vertices so that the mesh deforms
nicely around the joint.
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Appropriate deformation around the joint area.

20.Close the Weight Tool window and exit Edit
Envelope mode when done.

At this point, the envelopes and vertex weights on
the left side of the mesh are as they should be. The
next and final step is to apply them to the right side
of the mesh, as well.

Mirror the vertex weights:

In 3ds Max, you can mirror the vertex weights
from one side of the character to the other. This
process mirrors all envelope settings as well as
manual vertex settings.

1. Continue working on your file or open
tut_skinalien_mirror.max

2. Make sure the alien mesh is selected and that
Edit Envelopes is on.

3. In the Mirror Parameters rollout, turn on
Mirror Mode.

Note: Mirror Mode is available only when Edit
Envelopes is turned on.

The character’s vertices turn red. In the Front
and User or Perspective viewports, you can
see the mirror plane down the center of the
character.

Vertices in mirror mode, with mirror plane through the
model’s center

4. Increase the Mirror Threshold value until the
character’s vertices turn blue and green. A
value of 6 should be sufficient; you might want
to choose a greater Threshold value.

Mirror Threshold value increased

The Mirror Threshold value changes the
distance from the mirror plane that Mirror
mode will look for left and right vertices. Blue
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vertices indicate the left side if the mirror plane,
while green vertices indicate the right.

5. Adjust the Mirror Offset value until the mirror
plane sits at the center of the character mesh. If
necessary, zoom into the Front viewport to help
you accomplish this. A Mirror Offset value of
1 should be adequate.

6. In the Front viewport, check the character
carefully to make sure all the vertices on the
character’s left side are colored blue, and those
on its right are colored green.

7. Click Paste Blue To Green Bones.

This pastes the envelope lengths and sizes from
the left side to the right.

8. Click Paste Blue To Green Verts.

This pastes vertex weights from the left side to
the right.

9. Turn off Mirror mode.

The envelope and vertex weight settings on the
right now match the settings on the left.

You might have to make some additional
adjustments to vertex weights around areas that
are affected by both sides of the body, such as
the back of the hips.

Adjusting the Skin settings is as much an art
as a science. Because a working skin setup
is essential to the animation process, it’s not
uncommon for an animator to spend hours or
days testing simple motions and adjusting the
skin settings accordingly. Gaining skill with the
Skin modifier takes practice, but the results are
well worth it.

To see a working skin setup for this character,
open the file tut_skinalien_finished.max.

Working with the Angle Deformers

The Skin modifier’s angle deformers control
creases and wrinkles, as well as add muscle bulges
and deformations. There are three kinds of angle
deformers: Joint, Bulge, and Morph.

Angle deformers work by telling vertices how to
behave when a certain angle is achieved between
two adjacent bones. For example, you could use a
bulge angle deformer to tell vertices in the upper
arm to bulge when the elbow is bent greater than
90 degrees.

After the Skin modifier is applied, it is
not uncommon for some joints to crease
unrealistically when the character is animated.
Angle deformers can correct these problems.

Set up the lesson:

1. Open tut_skinarm_start.max.

2. Scrub the time slider to play the animation.

Around frame 15, the inside of the elbow is
compressed.

The arm flexes.

This unrealistic deformation can be corrected
with a joint angle deformer. You’ll also use a
bulge angle deformer to add a slight bulge to
the upper arm when the elbow is bent.

3. Select the Arm mesh object.

4. On the Modify panel, expand the Skin listing
on the stack, and select Envelope.
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5. In the Envelope list, click Bone ForeArm to
choose that bone.

This bone’s rotation will control the deformer.

Add a joint angle deformer:

The process to add an angle deformer consists of
two steps. First, you select the bone envelope, and
then select the vertices to be deformed. Once that
is accomplished, you can add the gizmo for the
deformer.

1. Go to frame 0.

2. In the Parameters rollout > Select group, turn
on Vertices.

3. Drag a selection window around the vertices
above and below the elbow.

Lower-arm vertices selected

With the bone and vertices selected, now you
can add an angle deformer gizmo.

4. On the Gizmos rollout, make sure Joint
Angle Deformer is selected, then click Add
Gizmo.

The new gizmo appears in the viewport. This
gizmo, called a lattice, is used to control the
selected vertices.

Deformation lattice displayed around selected vertices

Set the joint angle deformer:

1. Move the time slider to frame 13.

Flexed arm with deformation lattice

Angle deformers use the angle between bones
to determine when the deformation will take
place. Regular keyframes are not part of the
deformation setup, so there is no reason to turn
on Auto Key.

2. In the Gizmo Parameters rollout, click Edit
Lattice.
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3. Move the lattice’s control points to pull
out the creased vertices on the inside of the
elbow.

Note: Editing the gizmo works similarly to
editing an FFD lattice, where manipulating the
control points affects underlying vertices.

Elbow crease corrected

Tip: You can hide the bones and deselect the
vertices to concentrate on the lattice.

4. Move the time slider from frame 0 to 13 and
back again, watching the movement of the
lattice.

5. Move the time slider to frame 24. Edit the
Lattice Points again.

Outstretched arm with elbow corrected

6. Click Edit Angle Keys Curve to display the Joint
Graph. This is not a graph of time; rather, it is
based on angle. It goes from 0 to 360 degrees
of rotation.

7. Move the time slider back and forth, while
watching the joint graph.

You can use this joint-angle graph to remove
or change lattice edits. You can also adjust the
easing by using the Bezier handles on the graph
points, much as you do for key timing in the
Curve Editor.

8. Close the Joint Graph.

Next, you’ll add a Bulge Deformer to make the
biped grow as the arm bends

Add a bulge angle deformer:

1. Turn off Edit Lattice, and move the time slider
to frame 0.

2. With Bone ForeArm still selected, drag a
horizontal selection rectangle to select a few
vertices in the middle of the upper arm.
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Initial vertex selection

3. Click Loop to highlight a loop of vertices
around the arm, and then click Grow a few
times until all of the upper arm’s vertices are
selected.

Loop button changes selection to loop around the arm.

The Loop and Grow buttons, along with Ring
and Shrink, are vertex selection tools have been
introduced to the Skin modifier in 3ds Max 8.
Ring is like Loop, but selects along the opposite
UV axis. Shrink is the complement of Grow: it
reduces the size of the selection.
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Grow used to select all upper-arm vertices

4. Once you have the correct vertices
selected, choose Bulge Angle Deformer from
the list on the Gizmos rollout, and click Add
Gizmo.

The new gizmo is displayed in the viewport.

Bulge Angle lattice displayed over upper arm

5. Move the time slider to frame 15, where the
arm is bent.

6. On the Deformer Parameters rollout, click Edit
Lattice.

7. Select the gizmo control points near the bicep.

8. Move the lattice points to create a bulging bicep.
Move points on the front and then on the back
of the arm.
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Bulge Angle lattice used to create a bulging bicep

9. Move the time slider back and forth to see the
bulge angle deformer create a bicep with the
bending of the arm.

Adding Realism with Secondary
Motion

One of the principles of traditional animation is the
use of secondary motion. The illusion of weight
and realistic movement is greatly improved by
having the extremities of a moving object continue
moving after the object stops. For example, a car
slams on the brakes, comes to an abrupt stop, and
the car antenna continues to wiggle.

In this lesson, using the Flex modifier, you’ll
animate secondary motion with the antennae on a
beetle’s head.

Set up the animation:

1. Open tut_beetle_noflex.max.

First, you’ll animate the beetle’s head so he
looks in one direction and then another.

2. Turn on Auto Key.

3. Move the Time Slider to frame 23.

4. Rotate the beetle’s head to the left.

If you want to be precise, press F12 to open the
Transform Type-In, and rotate 70 degrees
around the Z-axis.

5. Move the time slider to frame 29.

6. Rotate the head in the opposite direction, about
30 degrees around the Z-axis.

7. Turn off Auto Key.

Next, you’ll adjust the interpolation on the last
rotation key for a more abrupt motion.

Adjust the motion:

1. Right-click the key at frame 29 in the track bar,
and choose the Head: Rotation key at the top
of the menu.

2. In the dialog, set Tension and Continuity to 0.0,
and Bias to 50.0. Close the dialog.

3. Play the animation.

The head should whip around to the right.

Select the vertices to be affected by flex:

1. Go to the Modify panel.

2. In the stack display, directly beneath the
MeshSmooth modifier, choose Mesh Select.

The Mesh Select modifier lets you use a soft
selection for the Flex modifier, so the effect
of the modifier on the mesh will taper off
gradually.



Adding Realism with Secondary Motion 445

3. Choose Vertex selection mode.

4. Select only the vertices at the end of the
antennae.

End vertices chosen

5. Scroll down and open the Soft Selection rollout.

6. In the Soft Selection rollout, turn on Use Soft
Selection.

7. Increase the Falloff value while watching the
viewport.

The vertices change color showing the area of
influence to be used by the Flex modifier.

8. Adjust Falloff to include the eyebrows (about
30.0).

Eyebrows added with Soft Selection

Apply the Flex modifier:

1. On the Modifiers menu, choose Animation
modifiers > Flex.

This adds a Flex modifier only to the selection
of vertices, rather than to the whole head.

2. In the stack display, expand Flex and choose
the Center sub-object level.

3. If you don’t see the Transform gizmo, open
the Views menu and turn on Show Transform
Gizmo.

4. Move the center of the of the Flex modifier up
to the beetle’s forehead, using the Transform
gizmo to restrict the movement to the Z-axis.
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Center of Flex moved up to the forehead

5. Play the animation.

The antennae have their own movement now.
Watch the free secondary animation you’ve got
in the last 70 frames of the animation. Imagine
how much work that would be to keyframe by
hand.

Experiment with the Flex modifier:

1. While the animation is playing, change the
values for the different parameters of the Flex
modifier.

2. Change the parameters one at a time to see
what they do.

Different combinations of the three parameters
can create different wiggles and wobbles. Also
try lowering the Center sub-object of the Flex
modifier.

The antennae wobbled with Flex modifier

A scene with the Flex modifier applied can be
found in the file tut_beetle_flex.max

Summary

In these lessons, you have learned how to apply
and adjust the Skin modifier to a character, and
how to add secondary motion quickly and easily
with the Flex modifier. You can use these tools
with the character rigs and setups that you create
for your own characters.

Animating a Character
The goal of setting up bones and a character rig
is to make the animation process easier. In these
lessons, you’ll learn several methods for animating
a character.
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Skill Level: Intermediate

Time to complete: 2 hours

Features Covered in This Tutorial:

• Working with both simple and complete
character rigs

• Animating with Set Key mode

• Creating a character assembly

• Using IK and FK in the same animation

• Merging with XRefs

Tutorial Files

You can find the files for this tutorial in the
tutorials\character_animation\character_
animation folder on the Tutorial Files CD that
ships with 3ds Max. Before starting the tutorials,
copy the \tutorials folder from the CD to your
\3dsmax8 local installation.

Animating a Dance on a Simple Rig

Even a simple character rig gives you lots of
versatility in the animation process. Here you’ll
explore some of the ways a simple rig can be
effectively animated.

Set up the lesson:

• Load the file tut_chefdance_start.max from
the tutorials\character_animation\character_
animation folder.

This file contains a low-poly chef character.
This character rig was created using the
techniques described in the Introduction to
Character Rigging tutorial (page 2–299). The
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arms, legs, and spine are all created with bones,
and controlled by HI IK chains. The IK chains
are in turn linked or constrained to dummy
objects at the joints.

The bones and IK chains have been hidden, and
the geometry has been frozen. You will animate
only the dummies to animate the character.

Prepare for the dance:

Before animating the first dance step, you’ll set
keys for the dummy objects at frames 0 and 10.
The key at frame 0 will ensure the character stays
in its skin pose at frame 0. Some objects will need
to stay still until frame 10, and the key at this frame
will keep them from moving.

1. Select all the dummy objects.

2. Right-click the time slider. On the Create
key dialog, enter a Source Time of 0 and a
Destination Time of 0. Click OK.

This method of setting keys does not require
Auto Key to be turned on.

3. Right-click the time slider again, and this time
use a Source Time of 0 and a Destination time
of 10.

Now you will pose the character to start the
dance at frame 10.

4. Turn on Auto Key.

5. Move the dummy objects at the chef ’s wrists
and fingers so his hands sit comfortably in front
of him, with palms down.

Tip: Move and rotate the wrist dummies first,
then adjust the finger dummies if necessary.

Animate the first dance step:

1. Move the time slider to frame 25.

2. In the Front viewport, move the pelvis dummy
downward to bend the character’s knees.

3. Move the left heel dummy to the character’s left
make the foot step to the left.
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4. Move the hands up to face the chef ’s right, and
rotate his hips and shoulders to face a little
toward the right. Start with the hips, and then
rotate the shoulders, then the head.

Now you want the chef to step back to his pose
at frame 10. Rather than animate this by hand,
you can copy keys again.

5. Select all the dummy objects.

6. Right-click the time slider. On the Create Key
dialog, enter 10 as the Source Time and 40 as
the Destination Time.

When you drag the time slider, you will see the
chef take one step with his left foot, then step
back, along the upper-body cyclical motion.

Next, you’ll continue the animation on the
other foot.

Animate the second step:

1. Move the time slider to frame 55. Move the
pelvis down, move the right heel dummy to
make the foot step to the right, and animate the
hands, hips and shoulders to face the left.
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2. Select all the dummy objects and right-click
the time slider. Set Source Time to 40 and
Destination Time to 70.

The chef now steps once with each foot.

Refine the animation:

You can add touches of realism to the dance by
lifting the chef ’s feet between steps, and shifting
his weight.

1. Move the time slider to frame 18.

This frame is halfway into the chef ’s first step.

2. Lift the left foot slightly for the step.

3. Move the hip dummy slightly to the chef ’s right
to shift his weight over his standing leg.

4. Go to frame 33. This frame is halfway into the
step back to the middle position.

5. Select the pelvis and left foot dummy, and
right-click the time slider to copy the hip and
foot keys to frame 33.

6. Repeat these steps for the step to the right side,
adjusting the pelvis and right foot on frames
48 and 63. These frames are the midway point
for the step to the right.

7. Save the animation as my_chefdance.max.

You can find a finished version of this dance
step in the file tut_chefdance_finished.max.

Create and prepare a character assembly:

A character assembly is designed to hold all the
elements of a character rig: bones, IK chains,
helpers, and any other objects required to control
the character. The assembly can be saved and
inserted into scenes, and its animation can be
saved separately and merged into other characters
or itself.

Here you will use the character assembly to append
the chef ’s animation to itself, thus looping the
animation.

1. Continue with the same file, or load the file
tut_chefdance_finished.max from the tutorials\
character_animation\character_animation
folder.

2. Unhide all objects in the scene, and go to frame
0.

3. Select all the bones, IK chains, and dummy
objects in the character. These are all the
objects in the scene except Chef_Mesh,
Chef_Mesh_Head and Chef_Hat_Top.

4. Choose Character menu > Create Character.

This creates a character assembly comprising
all the selected objects. The character assembly
is denoted by a node (icon) placed between the
character’s feet.
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Character assembly node icon

The node, which is placed between the
character’s feet, is created as a group-type
object named Character01. The objects in the
assembly are called members.

5. On the Modify panel, change the name of the
character node to Char_Chef.

The skin pose is the pose used by the Skin
modifier, and as a reference by the character
assembly tools. You purposely did not animate
the character on frame 0 so you could preserve
and set the skin pose.

6. Make sure you are still on frame 0. On the
Character Assembly rollout, click Set As Skin
Pose. When asked if you really want to set the
skin pose, click Yes.

7. On the Modify panel, in the Animation group,
click Save Animation. Save the animation as
my_chefdance.anm. Take note of the folder in
which you save this file.

An .anm file saves the animation on each
member of the character assembly along with a
reference to the member name.

Extend the animation:

Next, you’ll append the chef animation to the
current scene to repeat the animation.

1. Note the frame where the animation ends,
frame 70. You will append the ..anm file to the
last frame of your current animation.

2. Select the character node. In the Animation
group, click Insert Animation, and choose
my_chefdance.anm. If you prefer, you can
choose tut_chefdance.anm from the tutorials\
character_animation\character_animation
folder.

The Merge Animation dialog appears.

3. Expand the Object Mapping rollout. This
rollout shows the source and destination objects
for the merge operation. The merge operation
will merge animation from each object in the
Current Nodes column to the corresponding
object in the Merge Nodes column.

Because the .anm file was saved with this
character, all the object names are the same and
the Merge Nodes column has been filled in.
Animated objects are listed in red text.
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Many of the mapped objects aren’t animated,
but that’s not a problem. Merging animation
from non-animated objects has no effect on the
character.

4. In the Source Time Range group, choose Paste
To Existing Animation.

5. For the Start Time and End Time settings, enter
10 and 70, the beginning and ending frames of
the .anm file you saved earlier.

6. In the Insert Animation To Frame field, enter
the last frame of the current animation, 70.

7. Click Merge Animation.

After a few moments, the animation is merged.

8. Play the animation.

Note: To see the entire animation, you’ll need to
increase the animation length.

9. If the merge operation was unsatisfactory, click
Undo Last Merge and try again with different
time values.

10.When the animation is successfully merged,
close the Merge Animation dialog.

11.Save the scene as my_chefdance_
appended.max.

To see the merged chef animation, you can open
the file tut_chefdance_appended.max from
the tutorials\character_animation\character_
animation folder.

You can also animate a walk cycle on
a simple rig. To see examples of this,
open the files walk_cycle_arms.max and
dynamic_walk.max. In order to change the
sliders in dynamic_walk.max, you will have to
click Select and Manipulate first.

Animating a Walk Cycle on a
Complete Rig

One of the most common actions for a character is
a walk cycle. In this lesson, you’ll use the Set Key
tool to animate a basic walk cycle.

Set Key works by setting a key for more than one
parameter for selected objects. This feature will be
handy for setting both the position and rotation
of objects simultaneously during the animation
process.

Because the rig has already been set up, animating
a walk cycle is fairly straightforward. You will need
to animate only the feet and hips.

Set up the animation:

1. Open the file tut_charwalk_start.max.

This file contains the alien character for which
bones, rigging, and skinning have been set up in
previous tutorials. Only the legs are visible, and
only the hip and foot controls can be selected.

2. Click the Key Filters button, located to the right
of the Set Key button. On the Set Key Filters
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floater, turn on Position, Rotation, Custom
Attributes, and Modifiers, and then turn off all
other selections. Close the floater.

When Set Key mode is used, the chosen
settings will cause a key to be created for these
parameter types on selected objects .

3. Turn on Set Key mode by pressing the
Set Key button

The Set Key Mode toggle, the time
slider background, and the active viewport
outline turn red to indicate that Set Key mode
is on.

Animate the extreme poses:

The animation starts on frame 40, where the
character’s right leg is in the passing position. You
will use 8 poses total to animate the walk, which
will require 4 extreme poses.

Note: When the term “forward” is used in these
steps, it means forward from the character’s point
of view.

1. Go to frame 50.

2. In the Left viewport, move the hip control
forward and down, and move the right leg to
step completely on the ground. The back leg
should be completely straight. It’s fine if the
back heel comes up a little.

3. Select both foot controls and the hip
control, and click the Set Keys button.

The button turns red for a moment,
and a key appears at frame 50 on the track bar.

Clicking the Set Keys button creates a key
for each selected object, for each selected
parameter type, at the current frame.

4. Go to frame 60. Move the hip control up and
forward, and move the left leg to the passing
position. Select the hip and foot controls, and
click Set Key.



454 Chapter 7: Bones & IK

5. Go to frame 70. Move the hip control down and
forward, and move the left leg to step on the
ground. The back leg should be straight, and
the back heel might come up a little. Select the
hip and foot controls, and click Set Key.

6. Go to frame 80. Move the hip control up and
forward, and move the right leg into the passing
position. Select the hip and foot controls, and
click Set Key.

7. Scrub the time slider to see the alien’s legs move
through the extreme poses.

A rough walk cycle is in place, but it’s a
little stiff. You’ll add more fluid motion with
in-between poses.

Animate the poses in between:

1. Select the right foot control. Copy the key from
frame 50 to 45. To do this, select the frame 50
key on the track bar, hold down SHIFT, and
move the key to frame 45 on the track bar.

Note: It is not necessary to click Set Key after
copying a key.

2. Go to frame 45. On the Modify panel, change
the Roll attribute to -100.0. Click Set Key.

This causes the foot to roll back, placing the
heel down first.

3. Select the left foot control, and copy the key on
frame 50 to frame 55.

4. Go to frame 55. On the Modify panel, increase
the Roll attribute to make the heel come up off
the ground. The example in the illustration
uses a value of 75.0, but the best value for your
rig might vary depending on how far apart
the foot controls have been placed. Watch the
Front viewport while changing the value, and
roll the foot enough to come off the ground,
but not enough to make the character’s knee
bend inward.
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Click Set Key after you’ve set the Roll attribute.

5. Copy the key at frame 70 to frame 65.

6. Go to frame 65 and change the Roll attribute to
–100.0. Click Set Key.

7. Select the right foot control, and copy the key at
frame 70 to frame 75.

8. Go to frame 75. Increase the Roll attribute and
click Set Key.

Shift the weight:

Now that the bulk of the animation is done, you
can use the Set Key method without Set Key Mode
being turned on. This will set a key for the current
transform only.

1. Turn off Set Key Mode.

2. Go to frame 40. In the Front viewport, move
the hips to the right to compensate for the
weight being on one leg only. Click Set Key.
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3. On frames 60 and 80, move the hips over the
standing leg. Click Set Key after setting each
pose.

Add finishing touches:

1. Go to frame 40. In the Front viewport, rotate
the right foot to make it “flick” outward. Click
Set Key.

2. On frame 60, rotate the left foot outward in the
same fashion, and click Set Key.

3. Do the same for the right foot on frame 80.

The basic walk cycle is now complete. A
finished version of this scene can be found in
the file tut_charwalk_finished.max.

If you like, you can unhide the hidden bones
and controllers and animate the arms. Make
sure you animate the arm opposite the leg. For
example, when the right leg comes forward on
frame 50, the left arm should come forward.

You can also animate a walk cycle on
a simple rig. To see examples of this,
open the files walk_cycle_arms.max and
dynamic_walk.max. In order to change the
sliders in dynamic_walk.max, you will have to
click Select and Manipulate first.

Character Rigging Tools

Character Rigging Tools

Prior to 3ds Max 8, transferring motion from one
character rig to another was not an easy task. With
the new rigging tools that have been implemented
in 3ds Max 8, you can load and save animation
clips and share them between characters and have
full control as to how motion is transferred. You
can use the new retargeting tools to go from any
kind of rig to another, and you can use the Motion
Mixer, once compatible only with biped objects, to
layout and create transitions between motion clips
effortlessly.

This tutorial explains how you can use these
tools using simple examples. Keep in mind that
retargeting, as a concept, is an advanced topic
by its very nature and is usually handled by
specialized individuals such as Technical Directors
inside a production pipeline.

Skill Level: Advanced

Time to complete: 2 hours
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Features Covered in This Tutorial

• Loading and Saving Animation Clips

• Re-Mapping the Structure of a Character to
Another

• Using Retargeting to Correct Motion Between
Two Characters With Different Anatomy

Tutorial Files

All the necessary files for this tutorial can
be found on the Tutorial Files CD in the
\tutorials\character_animation\bones_retargeting
directory. Before starting the tutorials, copy
the \tutorials folder to your local \3dsmax8
installation.

In This Tutorial

Saving & Loading Animations (page 2–457)

Mapping FK to FK (page 2–459)

Mapping FK to IK (page 2–462)

Saving & Loading Animations

In this lesson, you learn to save an animation to
a file based on an XML format. You will then
reload that file onto another character. In this
example, the file you save and the character you
ultimately load it unto share a structure that is
nearly identical, making the process very easy. In
subsequent lessons, you will tackle some situations
that are more complex.

Save an Animation

1. Open the file simple_saveload.max found
under \tutorials\character_animation\bones_
retargeting.

2. Play the animation. The character on the left,
displayed as a yellow skeleton is animated using
a Motion Capture file and is simply walking

forward, while the character on the right is
static and currently in a T-Stance position.

Note: The animation on the yellow skeleton is
based on Forward Kinematics and therefore is
relying on Position and Rotation keyframes.
You will transfer this animation to the pilot
character, who also has a bone structure that is
purely FK. No Inverse Kinematics solvers has
been applied to the pilot’s rig.

3. From the Selection Set drop-down on the Main
toolbar, choose skeleton_bones. This selects all
of the bones that define the yellow character to
the left of the viewport. Notice that the walk
cycle is animated between frames 0 and 36.

4. From the File menu, choose Save Animation.
A dialog appears.

5. Navigate to a folder where you wish to save your
file and name it my_walk.xaf. This type of file is
based on an XML format and allows you to save
additional information such as date of creation
or user name in the lower part of the dialog.
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6. To the Right of the dialog, turn on the
Segment option, and then click the Objects
Time Range button to set the range from frame
0 to 36.

Note: The Objects Time Range button
automatically picks up the start and end time of
an animation and assigns it as a segment value.

7. Click the Save Motion button to save the clip
and exit the dialog.

Load an Animation

1. Continue working on your file. From the
Selection Set drop-down menu, choose
pilot_bones. The pilot’s skeletal hierarchy is
now selected.

2. From the File menu, choose Load Animation.
A dialog appears.

3. Navigate to the folder where you saved
the my_walk.xaf clip earlier and select it.

Alternatively, you can use the file named
walk.xaf sound under \tutorials\character_
animation\bones_retargeting.

4. Make sure Default is listed under Motion
Mapping/Retargeting and then click on Load
Motion

5. A warning dialog appears. This is the
application’s way of telling you it needs help
understanding the structure of the characters
in use. Click the Yes button to access the Map
Animation dialog to create a Map file.

Note: As you will see in the next steps, this
example will be easy to complete because the
two characters were designed with a similar
hierarchy and naming convention. Later, you
will learn more about manually mapping
character structures.

6. In the Map Track to Track rollout of the Map
Animation dialog, right click the list on the
left and choose Select All form the cursor
menu. Repeat the procedure using the list on
the right. The complete skeletal structures of
the Incoming character (the yellow skeleton)
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and the Current character (the pilot) are now
selected.

7. In the Motion Mapping Parameters rollout,
in the Map Nodes group on the left, click the
Closest Name button.

Note: This option attempts to automatically
map bones based on the similarity of their
names. Be aware that this option may not
always work perfectly and that you may still
need to fine-tune the mapping manually.

8. In the Retargeting rollout at the bottom of the
screen, notice that the Load Motion button is
grayed out. You will need to save your mapping
first. In order to do that, click the Save Mapping
button.

9. Name the Mapping file my_pilot.xmm and
click the Save Mapping button. The Load
Motion button is accessible now.

10.Click the Load Motion button. The Map dialog
disappears and the motion clip is loaded on the
pilot.

11.Play the animation to see the pilot walking.

Note: Since the motion clip you loaded on the
pilot is purely FK, you can easily reposition him
in space by taking its top parent (the pilot’s
hips) and relocate this node using the Move
command.

Next

Mapping FK to FK (page 2–459)

Mapping FK to FK

In the previous lesson, you loaded a Forward
Kinematics-driven animation onto a character
and the process was faily simple, mostly because
the hierarchy, anatomy and general scale values
between the current and incoming characters were
similar.

In this lesson, you learn to map an FK animation
between two characters that have different
structures and sizes.

Map the Character:

1. Open the file FK_to_FK.max found under
\tutorials\character_animation\bones_
retargeting. The file shows a stripped-down
version of the walk cycle you worked on in
the last exercise, minus some limbs (such as
the fingers) that were removed to make this
lesson easier to follow. Also in the scene,
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is a character called Gonzo. Gonzo has a
hierachical structure of bones and you notice
that he is also noticeably shorter that the yellow
skeleton. By its vary nature, this fact alone will
have you work a little more than you did in the
last lesson, in order for the incoming animation
to be scaled appropriately.

2. From the Selection Set drop-down menu,
choose gonzo_bones. This selects the bone
skeleton assigned to gonzo.

3. From the File menu choose Load Animation.

Note: Since you have already saved the yellow
skeleton walk cycle to disk, you will not need
to do it again.

4. Browse to the folder where you saved the
my_walk.xaf file earlier and select it. You can
also use the file walk.xaf from the \tutorials\
character_animation\bones_retargeting folder.

5. Make sure Default is listed under Motion
Mapping/Retargeting and then click on Load
Motion. Again, 3ds Max prompts you to
create a Map file, click Yes to access the Map
Animation dialog.

6. In the Filters group, turn off Position and Scale.
Leave Rotation on but turn off X, Y and Z.

By mapping the top level rotation tracks, you
will be doing so on all axes and this will make
the mapping list a little easier to read.

7. You will start with the hips. Select the
Transform track on the Hips node of the
Current character (Gonzo) and the Transform
track on the Hips node of the Incoming

character (Skeleton). Click the left-pointing
arrow to map these tracks to each other.

In a Forward Kinematics scenario, you typically
want to map the transforms (position/rotation)
of the top nodes (typically the center of mass) of
the current and incoming characters together.
For the rest of the limbs, you only need to map
the rotation tracks.

8. Next, select a rotation track on a limb of the
Current character, and then map it to the
rotation track of the corresponding limb of the
Incoming character. For example the rotation
track of Spine1 of gonzo to the rotation track of
Spine1 of the skeleton.

Note: As you might have guessed, it helps to have
defined a naming convention in your skeleton
rigs as part of your production pipeline. The
selection of limbs is so much easier when the
names are similar.

9. Continue mapping rotation tracks for all limbs
of the Current (gonzo) character to match those
of the incoming (Skeleton) character. Now that
you have already mapped the position track
for the hips, you can filter that out as you don’t
need it for the rest of the limbs and this will
make the list even easier to read.

10.10. Once you are done mapping the Rotation
tracks, click the Save Mapping button and name
your file: my_FK_to_FK.xmm.
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11.Next to the Load Motion button, ensure the
Insert and Relative options are chosen and
then click the Load Motion button to see what
happens. Gonzo is now walking seemingly the
same walk as the skeleton.

12.Play or scrub the animation.

The movement is not bad but if you look closely,
you will definitely notice some sliding of the
feet. This is happening because at this time,
the animation on Gonzo’s center of mass is a
relative one-to-one reproduction of the yellow
skeleton’s center of mass motion. However,
Gonzo is shorter and therefore, his center of
mass should move forward less. You can correct
that and other scale issues with Retargeting.

Edit the Mapping and Adjust Retargeting Values:

1. Continue working on your file. From the
Selection Set drop-down, choose Gonzo_Bones
again.

2. From the File menu, choose Load Animation.

3. The Walk clip from earlier should alrady be
selected but you need to edit the mapping you

created. Click the Get Mapping button to locate
and load the mapping file you saved earlier as
my_FK_to_FK.xmm.

4. Click Edit Mapping to go back to your map
definition of both characters.

5. Place your cursor right below the mapping
arrows until you see a panning hand and then
drag the dialog all the way up to reveal the
Retargeting rollout.

You will use the retargeting rollout to establish
a scale value converting the animation of the
incoming file to one appropriate the the current
character.

6. In the list of mapped nodes, select the first
entry representing the Hips. Notice at this time
how the scale values are mapped based on a
one-to-one absolute value.

7. In the Scale Origin group, select the
Skeleton:Hips node as an origin base for the
Incoming file and Gonzo_Hips as an origin for
the Current file.
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8. In the Derive Scale Between Chains
group, set the Incoming Chain Start as
Skeleton:LeftUpLeg and the Incoming Chain
End as Skeleton:LeftFoot. Set also the Current
Chain Start as Gonzo_LeftUpLeg and the
Current Chain End as Gonzo_LeftFoot. Notice
how the Resulting Scale Factor is automatically
calculated as 0.569.

Note: By specifying a refernce to compare
between the two characters, you can easily
establish a scaling factor based on the distance
between nodes. You can use any limb you want
although a leg is typically a good candidate to
find a resulting scale factor. In this case you
used the left leg but you could easily have used
the right leg.

9. To the right of the dialog, click the Set button
to accept the changes.

10.At the bottom right of the dialog, set to Replace
the animation in Relative mode to replace the
old animation, and then click Save Mapping
and then Load Motion to view the results.

11.Play or scrub the animation and notice in the
left view that Gonzo’s motion forward is smaller
than that of the skeleton’s and that his feet aren’t
slipping anymore.

Note: In this example, we only established
scaling reference for the hips and legs. In other

situation where the anatomy differs greatly,
you can also establish scale references for other
limbs, for example the arms on a bone structure
when mapping a gorilla to a human being or
vice-versa.

Next

Mapping FK to IK (page 2–462)

Mapping FK to IK

In the previous lesson, you retargeted Forward
Kinematics animation from one character to
another. You mostly dealt with Rotation tracks
as is usually required with FK. Retargeting is
slightly different when you go from FK to IK.
An example of this would be to retarget Motion
Capture animation (usually FK-based) to an IK
rig that you still need to manipulate after loading
the animation.

In this lesson, you learn to map an FK animation
to an IK rig, giving special attention to the IK goals
receiving the motion data.

Map the Character:

1. Open the file FK_to_IK.max found under
\tutorials\character_animation\bones_
retargeting. The file is very similar to the one
you used in the last lesson but the skeleton
inside Gonzo has been rigged with a simple IK
solution to control the arms and legs.
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2. From the Selection Set drop-down menu,
choose gonzo_bones_and_goals. This selects
the bone skeleton assigned to gonzo and the
four IK goals assigned to the hands and feet.

3. From the File menu, choose Load Animation.

4. Browse to the folder where you saved the
my_walk.xaf file earlier and select it. You can
also use the file walk.xaf from the \tutorials\
character_animation\bones_retargeting folder.

5. Make sure Default is listed under Motion
Mapping/Retargeting since you want to create
a new map for this particular rig. Click on
Load Motion. Again, 3ds Max prompts you to
create a Map file, click Yes to access the Map
Animation dialog.

6. In the Filters group, turn off Position and Scale.
Leave Rotation on but turn off X, Y and Z. This
is the same setting you used earlier to make the
node controllers lists easier to read.

7. You will start with the hips. The Hips node
is the top parent in the gonzo hierarchy and
requires mapping for both position and
rotation. Scroll the Current node list until you
see the entry marked as Gonzo_Hips. Make
sure you can see the Hips node in the Incoming
node list as well.

8. Select the Transform tracks on both the Current
and the Incoming hips nodes and then click the
left pointing arrow to map these nodes together.

9. Map the Rotation tracks for all Spine nodes on
both current and incoming characters.

10.Repeat the procedure to map the rotation tracks
on the Neck and Head nodes.

Note: Since the IK rig is only set up to control
arms and legs, you still need to map the spine,
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neck and head nodes using an FK to FK
approach as you did in the last lesson. In the
next step, you will map the four ik goals to
control the arms and legs.

11.Scroll to locate and select the Transform nodes
of the RightShoulder entry. Map them together
between Current and Incoming files.

12.Repeat the procedure to map the Transform
nodes of the LeftShoulder object.

13.Scroll the Current node list until you see the IK
Goals displayed. Start by selecting the IK Chain
RightHand \ Exposed World Transform in the
Current node list.

Note: Exposed World Transforms represent
Transform data as it relates to the World
Coordinate System. Think of it as baked
animation data in World-Space. Regular
Transforms work in Parent-Space.

14.Map the selected node to the Exposed World
Transforms of the right hand of the Incoming
character.

15.Repeat the procedure to map the Exposed
World Transforms of the remaining IK goals to
their corresponding limb.

IK goal (left hand) => skeleton left hand

IK goal (left foot) => skeleton left foot

IK goal (right foot) => skeleton right foot

Note: You do not need to map the individual
bones that make the arms and legs as their
animation will be derived by the Exposed
World Transforms applied to the IK goals.

16.At the bottom of the dialog, click Save Mapping
As and name the file my_FK_to_IK.xmm. Do
not load the motion yet.

Adjust Retargeting Values:

1. Scroll up the node lists to access the Retargeting
rollout. You will need to adjust scaling for
nodes receiving position data, namely the Hips
and the IK goals.

2. In the Retargetable Nodes list, select
Gonzo_Hips => Skeleton:Hips.

3. In the Scale Origin group, select the
Skeleton:Hips node as an origin base for the
Incoming file and Gonzo_Hips as an origin for
the Current file.
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4. In the Derive Scale Between Chains
group, set the Incoming Chain Start as
Skeleton:LeftUpLeg and the Incoming Chain
End as Skeleton:LeftFoot. Set also the Current
Chain Start as Gonzo_LeftUpLeg and the
Current Chain End as Gonzo_LeftFoot. Notice
how the Resulting Scale Factor is automatically
calculated as 0.569.

5. To the right of the dialog, click the Set button
to accept the changes.

This is essentially a carbon copy of the
procedure used in the last lesson to establish a
scaling reference for the hips.

6. Play or scrub the animation.

Notice the problem in the viewport: The
motion scaling for the hips worked well but
unlike the previous lesson, it is not enough to

adjust motion scaling on the hips only. You
need to also adjsut scaling on the ik goals.

7. From the File menu, choose Load Animation.

8. From the dialog that appears, click Get
Mapping and load the file my_FK_to_IK.xmm
you saved earlier.

9. Click the Edit Mapping button to go back to the
Map Animation dialog.

10.Scroll to the Retargeting rollout to view the list
of Retargetable nodes.

11.Select the first IK chain entry named IK
Chain_RightHand => Skeleton:RightHand

12.In the Scale Origin group, select
Skeleton:RightArm as an Incoming
origin and Gonzo_RightArm as a Current
Origin. These nodes represent the joint
between the upper arms and shoulders and
make a good origin to scale the end effectors.

13.In the Derive Scale Between Chains group, set
the Incoming chain to start at the skeleton’s
right arm and end at its right hand. Similarly,
set the Current to start at Gonzo’s right arm
and end at his right hand. Notice the resulting
scale factor of 0.618.
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14.Click the Set button to accept the changes.

15.Repeat the procedure to rtarget the left hand
IK goal, choosing the proper scale origins (left
arm objects on both characters) and the proper
Derive Scale chains, going from the left arms
to the lef hands.

Note: Notice how the scale factor may differ
between one similar chain and the next, this
happens when the skeletal structure is not
exactly identical from one half of the body to
the other.

16.Click Set to accept the changes for the left hand
IK node.

17.Select the IK node for the right foot and retarget
it accordingly.

18.Repeat the procedure for the left foot IK node.

Note: Remember to click the Set button every
time you make a change to the retargeting
values.

19.At the bottom of the dialog, click the Save
Mapping button to update your map file and
then click Load Motion to reload the animation
file.

20.Play or scrub the animation. Gonzo is properly
following the animation coming from the
yellow skeleton. Scaling has worked properly as
no sliding is noticed at the feet level.

Note: The current IK rig on Gonzo is overly
simplified to make this lesson easier to follow.
In a more complex rig, IK solvers could have
been found in other places such as elbows and
knees, and these additional IK nodes could
have been mapped for an even better solution.
However, you can make easy adjustments on
this scene by enabling the Select and Manipulate

button on the main toolbar, and adjust the
handles that control the swivel angles on the
IK chains.
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Summary

In this tutorial, you have learned the basic
concepts of retargeting. The process involves
saving animation files to disk to create a library
of motions, and then load those files on different
characters. You have learned to create map files
to ensure motion files work well between one
character and the next, which is especially useful
where models have different scales and anatomy.
Finally, you have learned how to map motion
between Forward and Inverse Kinematic solutions.

Introduction to the Reaction
Manager
Having the animation of one object drive the
animation of another is a common problem in
3D animation, and one that tends to make the
fine-tuning process complex and time-consuming.

The Reaction Manager serves as the primary user
interface for the Reaction controllers. It allows
you to easily set up interactions between any
parameters within a 3ds Max scene. As you define
the interactions, the Reaction Manager displays
the associations and values in an intuitive interface
that allows you to find and adjust the reaction you

need. If your goal is to create realistic motion in
your animations, you owe it to yourself to learn
about the Reaction Manager.

In this tutorial, you will learn the capabilities of
this new animation tool by working through a
common instance where reactions are important:
the motion of the fingers and thumb on a human
hand. You’ll see how to set up and edit reactions
quickly, and explore the UI that has been designed
to speed your navigation through complex
reactions and scenes.

Skill Level: Intermediate

Time to complete: 1 hour

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\reaction_manager folder. Before
starting any tutorials, copy the \tutorials folder
from the CD to your \3dsmax8 local installation.

Creating Reactions in a Hand

In this lesson, you will use the Reaction Manager
dialog to establish a master-slave relationship
between some custom dialog elements and the
fingers on a hand. The dialog elements (sliders, in
this case) will be the masters, and the fingers in the
hand will be the slaves.

Set up the lesson:

• Files for this lesson are in the
\tutorials\reaction_manager folder. In
3ds Max, open hand_reactions01.max.

The scene contains a simple arm and hand rig.
An IK chain has already been set up on the arm.
The chain is controlled by moving the yellow
spline object CNT_HAND. Drag CNT_HAND
around a bit to confirm that the IK is working,
and right-click before your release the left
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mouse button, in order to return the effector
to its original position.

With CNT_HAND still selected, go to the
Modify panel. The editable spline object has
an Attribute Holder modifier assigned to it,
which in turn contains six custom attributes
sliders on the Custom Attributes rollout. The
sliders don’t do anything yet: you will use
Reaction controllers so that these sliders drive
the movement of the fingers.

Note: It’s helpful to know how the sliders are set
up. Each of the first five sliders, which control
the individual fingers, ranges in value from
–25.0 to 100.0, and is currently at the default
value of 0.0. The default value specifies the
neutral position for the finger: its current state.
For this exercise, a value of –25.0 means the
finger should be bent backward slightly, and a
value of 100.0 means it should be fully curled,
as in making a fist. The Hand Splay value
ranges from –100.0 to 100.0, and is currently
set to the default of 0.0.

You can examine the setup by highlighting
the Attribute Holder entry in the modifier
stack, choosing Animation > Parameter
Editor, and then clicking the Parameter Editor
> Edit/Delete button. This opens the Edit
Attributes/Parameters dialog. Click each
attribute in turn to see its settings on the
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Parameter Editor dialog. Then close both
dialogs.

Set up the reactions:

1. From the Animation menu, choose Reaction
Manager to display the Reaction Manager
dialog.

Tip: You can also open this dialog by
ALT+right-clicking an active viewport, and
choosing Reaction Manager from the quad
menu.

2. Click the Add Master button.

3. Select the CNT_HAND object in the viewport.

4. A pop-up menu appears, which lets you choose
the animation track that will serve as the master
in the reaction being defined. You could choose
a transform applied to CNT_HAND, but for
this lesson you will use the custom attributes
that have been built for you.

From the pop-up menu, choose Modified
Object > Attribute Holder > Custom_Attributes
> Pointer.

A new entry, CNT_HAND / Pointer, appears
in the Reactions list of the Reaction Manager
dialog, indicating that the Pointer attribute
of the CNT_HAND object is the new master
for the Reaction controller that you’ll set up.
Technically, the controller is actually applied to
the slave objects that you’ll specify in the next
few steps.

Next you’ll use Reaction Manager to specify the
slave tracks that this master drives.

5. Select the bones of the pointer (index)
finger: BN_Pointer01, BN_Pointer02, and
BN_Pointer03.

6. In the Reaction Manager dialog, with the
pointer finger bones still selected, click the Add
Selected Button.

7. You are presented with another pop-up menu,
which lets you choose the animation track
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of the slave objects that should be driven by
the Reaction controller. Choose Transform >
Rotation > Y Rotation.

This applies a Reaction controller to each of
the slave objects. The slave objects and the
parameters that will be driven by the Reaction
controllers appear in the Reaction Manager
dialog. The States list shows the initial values
for the Y rotation of the bone objects.

Note: You could also designate slave
objects by clicking the Add Slave button and
then selecting the individual objects, but in this
case it is faster to use the Add Selection button,
especially since you wish to affect the same
parameter (Y rotation) of each of the selected
objects.

Now that you’ve defined the relationship
between a master object, a Reaction controller,
and the slave objects’ parameter, the next step
is to tie specific master values to the specific
parameter values you want to see in response.

Adding reaction states:

1. Make sure CNT_HAND / Pointer is still
highlighted in the Reactions list.

2. Click the Create Mode
button to turn it on.

The button is highlighted, indicating that
you can now create new Reaction states
interactively.

3. If the CNT_HAND custom attributes
aren’t visible, select CNT_HAND again, and
go to the Modify panel.

4. On the Custom Attributes rollout, drag the
Pointer slider all the way to the right.

Remember, at this value the finger will be fully
curled.

5. On the Main toolbar, click
the Select And Rotate button to turn it on. Then
set the Reference Coordinate System to Local.

6. Select BN_Point01 in the viewport, and
rotate it along the Y axis approximately -90
degrees. Repeat this step for BN_Point02 and
BN_Point03 so that the pointer finger is fully
curled inward.
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Tip: You can save time by selecting each object
and then entering -90.0 in the Y box of the
Coordinate Display, below the time slider.

7. On the Reaction Manager dialog, click the
Create State button.

The newly created Reaction state is displayed
in the States list as a new entry. Now create
another state:

8. Select CNT_HAND again in the Perspective
viewport.

9. On the Modifier panel > Attribute Holder
modifier > Custom Attributes rollout, drag the

Pointer slider from the extreme right to the
extreme left position.

10.Rotate each of the pointer finger bones so that
the hand is wide open, with the fingers bent
back slightly beyond the plane of the palm.

Tip: If you are using the Coordinate Display to
type in the Y rotation, and you used -90 degrees
to curl the fingers inward, uncurl each finger
joint by 100 degrees.

11. On the Reaction Manager dialog, click
Create State again.

A third Reaction state appears as a new entry
in the States list.

12. Click Create Mode to turn
it off.

The button turns gray to indicate that you have
exited Create mode.

13.Save your file as my_hand_reaction.max.

You have now successfully defined the reactions
for a single finger. To test them out, select
CNT_HAND, and then, on the Modify panel,
drag the Pointer slider right and left to see the
finger curl and uncurl.

Your scene should now be similar to
hand_reactions02.max, which has the reactions
created for the pointer finger according to the
previous steps.
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Complete the hand setup:

1. Repeat the previous procedure for the thumb
and other fingers, attaching the reactions to the
appropriate sliders in the Custom Attributes
rollout. You might need Y rotation values
other than –90.0 for fully curled and 100.0
for extended backward; use angles that look
natural. For example, the first bone of the
thumb will bend very little in either direction.

When you have completed these steps, the
Reactions list should look something like this:

For each master in the Reactions list, the
States list should contain three states that look
something like this:

2. Save your work as my_hand_reaction01.max

Refining the Reactions

Now that you have defined the basic reactions
that uniformly curl and uncurl the fingers and
thumb, you can use Reaction Manager to add
some subtlety to the finger movement.

Set up the lesson:

• Open the file hand_reactions03.max from
your \tutorials\reaction_manager directory, or
continue from the previous lesson.

If the Reaction Manager dialog is not open,
choose Animation menu > Reaction Manager
to display it.

Adjust the finger curling:

Real finger joints don’t rotate uniformly; to
simulate that movement you will adjust the
reaction curves on a bone-by-bone basis.

1. On the Reaction Manager dialog, choose
BN_Pointer01 / Y Rotation in the Reactions list.

A single curve appears in the graph section of
the Reaction Manager dialog, representing the
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reaction states for this Reaction controller. You
will edit this curve to add some variety to the
movement of the differerent joints.

2. Click one endpoint of the curve to select it, and
then CTRL+click the other endpoint so that
both are selected. Right-click either endpoint
and then choose Bezier-Corner from the menu.

3. Adjust the handles of the curves, so that the
curve eases into the endpoints, as shown in the
following illustration.

4. Right-click the middle point, which
represents the original state, and then choose
Bezier-Smooth from the menu. Adjust the
handles so that the curve flows smoothly
through the point, as shown in the following
illustration.

Tip: You can also drag the point within the
graph to further refine the curve.

Next, you ’ll adjust the other fingers.

5. In Reaction Manager > Reactions list,
click BN_pointer02 / Y Rotation and then
CTRL+click BN_pointer03 / Y Rotation so that

both are highlighted. Adjust the curves in the
graph so that each has its own distinctive shape.

6. In the Perspective viewport, select the
CNT_HAND object and move the Pointer
slider back and forth. Compare the way the
bones curl when moving the Pointer slider to
the way the bones curl when moving the Middle
slider. This slight variation in speed between
fingers adds a subtle bit of realism that keeps
your animation from looking too mechanical.

Repeat the steps in this procedure for the
remaining fingers.

Tip: To select multiple endpoints or midpoints,
drag a region over all of them in the graph.

Set up the splay:

In this procedure, you’ll define one more reaction
controller: the Splay attribute.
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1. Open the file hand_reactions04.max from
your \tutorials\reaction_manager directory, or
continue from the previous section.

2. On the Reaction Manager dialog, click
the Add Master button. Select the CNT_HAND
object in the viewport, and choose Modified
Object > Attribute Holder > Custom_Attributes
> Hand Splay from the menu.

3. Press H to display the Select Objects dialog.
Highlight BN_Thumb01, BN_Pointer01,
BN_Middle01, BN_Ring01, and BN_Pinky01
in the dialog, and then click Select to select
them as a group.

4. On the Reaction Manager dialog,
with the bones still selected, click the Add
Selected button. Navigate the menus to choose
Transform > Rotation > Z Rotation.

5. Click the Create Mode
button to turn it on.

6. Select CNT_HAND in the viewport. On the
Modify panel > Attribute Holder modifier >
Custom Attributes rollout, drag the Hand Splay
slider all the way to the right.

7. Rotate each finger’s base joint around its local Z
axis so that the fingers are spread out, as shown
in the following illustration.

Warning: Make sure the Reference

Coordinate System is set to Local.

8. On the Reaction Manager dialog, click the
Create State button.

9. Select CNT_HAND in the viewport, and drag
the Hand Splay slider all the way to the left.

10.Rotate each finger’s base joint around its local Z
axis so that the fingers are close together.
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11. On the Reaction Manager dialog, click the
Create State button.

12. Click the Create Mode
button to turn it off.

You’ve now captured the movement of individual
digits on the hand, making it easy to animate the
motion of the fingers and thumb. Try selecting
CNT_HAND and sliding each of the sliders to see
their effect, and how they work with each other.
Compare your results to those in the finished file
hand_reactions05.max.

Experiment with keyframing the locations of the
sliders to create different finger animations.

Summary

In this tutorial, you have learned how to use
Reaction Manager to establish master-slave
relationships between controllers and parameters,
how to define reaction states, and how to fine-tune
reaction states to simulate realistic movement.

Lip-Sync Animation

Producing Lip-Sync Animation

In this tutorial, you will learn two methods for
producing lip sync animation. In the first lesson,
you will use modifiers to animate the mouth for
speech. In the second lesson, you will create a
morph target of your own and animate it with the
Morpher modifier.

Skill Level: Intermediate

Time to complete: 90 minutes

Features Covered in This Tutorial

• Applying a series of Mesh Select modifiers on
different parts of the mesh

• Following each selection of vertices with an
XForm Modifier

• Animating the transform modifiers to create
rotations for the chin, positions for the lips, and
raised eyebrows

• Using a MeshSelect modifier with a Bend
modifier to lift the cheeks for a smile

• Understanding speech and expression target
requirements for your own character

• Creating a facial expression target and assigning
it as a target in the Morpher modifier

• Setting lip sync keys by listening to the
character’s voice and looking at the audio
waveform in Track View
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Tutorial Files

Files for this tutorial are in the tutorials\character_
animation\character_animation folder.

Animating Lip Sync with the FFD
Modifier

As a character animator in 3ds Max, you have a
number of different options for creating facial
animation. You can use morph targets. You can use
wire deformers. You can animate NURBS Splines
or CVs. You could combine different techniques.
The goal is to make your character’s face and
mouth talk, to create the sound-synchronized
mouth positions and expressions that bring it to
life.

Traditional animators use a system called track
reading in which the animation is carefully
analyzed for mouth positions laid out against a
time sheet. The animator’s true skill is knowing
how to condense speech into as few positions as
needed to create the illusion of speech. Using too
many mouth positions will not read as well as just
a few key positions. The method in this tutorial
uses transform modifiers to create deformations
of the mesh.

Add a sound track:

1. Reset 3ds Max.

2. From the File menu, choose View Image
File. Play byebye.avi. A beetle gets up off a
strawberry and says “Thanks for watching; bye,
bye now.”

In this exercise, you’ll animate the beetle saying
“bye, bye now.” They are only three little words,
but it will teach you how lip sync is done
without taking too much time.

If the playback of the AVI is slow, don’t play
it from the CD ROM. Copy it to your hard
drive before playing. You can also resize it to a
smaller size to improve playback.

3. Open beetle_talk_nosound.max. This file can
be found in the \tutorials\character_animation\
character_animation folder.

4. Play the animation.

The beetle is already mouthing the words, but
there is no sound. You’ll add the sound track
and match it to the existing animation.

5. Click the beetle’s head in the viewport.

The track bar displays keys for the animation.

6. Right-click the beetle’s head in the viewport,
then choose Curve Editor from the transform
quad.

The Track View window appears.

7. Move your cursor over the Controller window,
then press and drag downwards to reveal the
hierarchy.

You can see the World icon at the head of
the hierarchy list.

8. Click the Sound item label on the list.

It turns yellow to show it’s active when you’ve
selected it.

9. Right-click the Sound label and choose
Properties from the controller quad.
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The Sound Options dialog displays. This is how
you add sound to an animation.

10.In the Sound Options dialog, click Choose
Sound.

On this dialog, you can add any WAV file as a
track, or you can select sound from an AVI file.

11.Navigate to the tutorials\character_animation\
character_animation directory and choose
byebye.avi and play the preview. Click OK to
select the sound from the AVI file.

Preview window

12.Close the Sound Options dialog.

13. Expand the Sound window by clicking the
plus in the circle to the left of the Sound icon.

In the hierarchy list, click the item label for
Waveform — Byebye.avi.

The waveform is displayed in the Track View
window:

Sound track to byebye.avi

14.Drag the time ruler up from the bottom of the
Key window, and place it close to the sound
track.

15. Use the Zoom icon to navigate the
viewport so the entire sound track is visible.

Adjust the sound track:

1. On the Track View menu, choose Modes >
Dope Sheet.

The Curve Editor window is replaced with the
Dope Sheet editor.

2. On the Dope Sheet toolbar, click Edit
Ranges.

Range bars are now displayed.

3. Click the Waveform item label to display the
waveform in the Dope Sheet editor.

Note the horizontal range bars above the
waveform. Use either of these to drag the sound
track, sliding the waveform to the left so that
the second half of it moves completely into the
light gray area, the active time segment.

Wave form for “well thanks for watching; bye, bye now”

4. Click Play in the time controls.

The sound file now plays. You hear the voice of
the beetle saying, “Well, thanks for watching;
(pause) bye, bye now.”

5. If the sound does not play, you need to
click Time Configuration and change playback
to Real Time. Sound will not play if Real Time
has been turned off.

6. Identify the waveform for “bye, bye now.” It
looks like this:

Waveform for “bye, bye now”
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Sync audio to existing mouth movement:

1. Select the beetle’s head in the viewport.

The track bar under the viewport displays keys.
You can now see where animation has been
created to move the lips.

2. Right-click the track bar and choose Configure
> Show Sound Track.

The sound track is now visible beneath the keys
in the track bar.

Sound track displays beneath track bar

3. In Track View, right-click the Controller
window and choose Manual Navigation. This
will allow the keys to stay visible while you
select the sound track.

4. Starting at frame 0, click the > button on the
time slider to advance a frame at a time from
0 to 12.

You should see that the movement for the first
“buh” sound takes place from frames 0 to 12.

Tip: If you prefer, you can use the > key on the
keyboard to move ahead one frame at a time.

5. Turn on Key Mode.

6. Click Next Key to advance through the
animation from one key to the next.

You see the chin move down at frame 12, up
at frame 14, down at 18, up at 19, down at 24,
and up at 28.

7. On the Dope sheet, slide the Sound track range
bar to the left so the waveform for "bye, bye
now" is close to the beginning of the active
segment.

8. Press S on the keyboard to turn off Snap Frames

9. In Track View, zoom up close around frames
11 14.

Zoom in so you can see the sound up close

10.In the Track View Edit window, drag the sound
track so the waveform spike lands on frame 12.

11.Play the animation.

The beetle talks.

12.Slide the sound track around a bit.

See what happens when the sound is positioned
slightly after the animation. The sound seems
to lag the mouth animation.

13.You can also try selecting sets of keys in track
bar and shifting them slightly to experiment.

You don’t want any animation occurring when
the sound stops, or it’ll look like a badly dubbed
movie.

14.Save the scene as my_beetletalk.max.
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Perform facial animation with modifiers:

This step explores how the preceding animation
was produced.

1. Open beetlesound_notalk.max.

This is a file with the sound track already in
place. If you’ve moved the MAX file, but not
the sound-track file (byebye.avi), you’ll get an
error message. Copy byebye.avi into the same
directory as the MAX file and you’ll be on your
way.

2. Select the beetle’s head

3. Open the modifier stack display.

This file has the mesh prepared for animation.
You see a series of sub-object selections using
MeshSelect modifiers. The XForm modifiers in
the stack have been renamed to chin gizmo, bot
lip gizmo, and top lip gizmo for the modifiers
that animate the mouth, and rt eyebrow gizmo
and lft eyebrow gizmo for the modifiers that
animate the eyebrows. There is also a Bend
modifier renamed smile gizmo, for animating
the cheeks into a smile.

4. Click the plus to expand each gizmo entry in
the stack. Click the gizmo sub-object entry and
see the gizmos in the viewports.

Chin gizmo

Bottom lip gizmo

Top lip gizmo

If you look at the waveform in Track View, you
can get an idea of which frame is associated
with which sound. The mouth movement for
the first “bye” starts around frame 10 and is
over by frame 14. The movement for the second
“bye” is over by frame 19, and “now” is over
by frame 28. These transitions are somewhat
subjective, and you might not choose exactly
the same frames.

You’ll animate the chin gizmo first.

5. Select the head. In the modifier stack. Expand
chin gizmo and select the sub-object gizmo.

The gizmo for the chin appears in yellow in the
viewport.
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6. Move the time slider to frame 12, or type 12 in
the Go To Frame field.

7. Turn on the Auto Key button.

8. At frame 12, rotate the chin gizmo down
approximately 15 degrees around the X axis.

This is the mouth open for the first “bye”.

9. Move to frame 7, then rotate the chin gizmo
back up but not all the way.

10.At frame 14, rotate the chin gizmo back up.

11.At frame 18, rotate the chin gizmo down again.

This is the mouth open for the second “bye”.

12.At frame 19, rotate the chin gizmo back up.

13.At frame 24, rotate the chin gizmo down again.
Here’s the mouth opening for "now."

14.At frame 28, rotate the chin gizmo back up.

15.Drag the time slider and watch the chin
movement with the sound track.

You’ve just animated the jaw movement for two
“buh” sounds. To add the “ee” sounds, you’ll
move the cheeks between frames 0, 18, and 24.

16.In the modifier stack display, expand smile
gizmo and select the gizmo.

This is actually a renamed Bend modifier.

17. With Auto Key mode still on, do the
following in the Modify panel > Parameters
rollout:

• At frame 18, increase the Angle setting to
about 7.

• Change the Direction setting to about 17.
Watch the results in the viewport.

• At frame 24, set Angle and Direction back
to 0.

18.Play the animation.

Complete the facial animation:

Now you’ll add eyebrow movements by animating
the gizmos for Rt eyebrow and Lft eyebrow.

1. With Auto Key mode still on, move
these gizmos up at frame 12, down at frame 0
and again down at frame 24.

2. You can make the lips purse a little by animating
the bot lip gizmo and top lip gizmo. Try moving
the bottom lip down to make an “oo” position
at frame 26 and back up at frame 28. You can
enhance the “buh” mouth positions by pushing
these gizmos together at frames 5 and 16.

3. Turn off Auto Key mode.

Adjust rotation curves over the sound file:

1. In the Curve Editor, click Filters and
choose Animated Tracks. Close the Filters
dialog

2. Expand the Controller window until you find
the Rotation track of the chin gizmo. Select that
track in the hierarchy list.

3. On the Controllers menu, choose Assign
Controller.

4. On the Assign Rotation Controller dialog,
choose Euler XYZ, then click OK.

An Euler Rotation Controller is now assigned
to the chin gizmo.

Note: Euler is the default rotation controller
type assigned to objects created in 3ds Max.
Since this scene was created in an earlier release,
it has a different controller already applied.
So the Euler controller has to be applied as a
step. When you make new files, it is applied
automatically.

5. Expand the X Rotation track of the chin gizmo.

Curves display for the chin gizmo rotation.
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6. Hold down the CTRL key and scroll to the
Wave form. Click the waveform to see both the
sound track and the rotation curves.

7. Play the animation and then adjust the keys on
the curves to vary and finesse the animation.
Select the keys at the top of the curves and
shift them to the left so they happen earlier.
Experiment.

Waveform and rotation curve displayed.

Another easy way to adjust this animation is by
using the track bar Selection Range.

8. Right-click the track bar and choose Configure
> Show Selection Range. Drag a selection
window around all the keys to display the
selection range.

9. Slide the keys by clicking and dragging the
middle of the range bar. Scale the animation by
clicking and dragging either end of the range to
condense the animation.

Selection range in track bar

10.Render the scene to an AVI file. Select a range
of about 40 frames. Play the finished file.

The animation plays back with the beetle saying
“bye, bye now.”

Summary

In this tutorial you have learned to create lip-sync
animation using the FFD modifier. You have
learned to add a sound track to your animation
using Track View, and to synchronize the sound
with the animation using the Curve Editor
function curves and the sound display in the track
bar.

Synchronizing Lip Movement
and Facial Expression with the
Morpher Modifier

The Morpher modifier can be used to synchronize
lip movement and facial expression. You learn the
basic requirements for lip sync that apply to any
character model. You also create a new expression
for the prebuilt head of Commander Lake, a
military action figure, and lip sync a few words.

This lesson expects that you are familiar with using
3ds Max and can navigate the viewports, animate
objects, and get around its user interface. It also
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assumes you know how to navigate the Curve
Editor windows.

Lip Sync Workflow

These are the general steps to follow in your own
work:

• Using mesh, patch, or other tools, model a
character’s head in a relaxed pose, with the lips
closed or nearly closed, and the eyes open. This
is the base model.

• Copy the base model a number of times.

• Modify each copy to create morph targets for
lip sync and facial expression.

Making copies of the original head ensures
there are the same number of vertices and
control points in the morph targets as there are
in the base model. This is a requirement of the
Morpher modifier.

• Apply a Morpher modifier to the original head
(base model).

• In the Morpher modifier, assign each target to
a channel.

The Morpher modifier has 100 channels. Each
one can contain a particular target. You can
also target a material for morphing using the
Morpher material, designed for this purpose.
For example, at the same time the Brows
Up channel in the Morpher modifier sets an
expression target, it can morph a bump map
material to crease the character’s brow.

• Animate the character’s face by animating from
one channel (target) to another. Turn on the
Auto Key button; position the time slider; use
the channel spinners in the Morpher modifier
to set appropriate values.

Target Requirements

For your own characters, you need a minimum of
nine phoneme or speech targets. Phonemes are

mouth shapes for speech, and nine is the usual
number for mimicking normal speech patterns.
You also need a blink target and a brows-up target.

The nine speech targets that cover standard speech
each require a particular configuration of the
mouth geometry. The modeling tips that follow
are specific to the geometry of patch models. Use
appropriate tools if your character is an editable
mesh, editable poly, or NURBS model.

When you create mouth targets, include cheek,
chin-and-jaw, and nostril movement. Teeth can be
part of the model or animated separately. In this
tutorial, the teeth are a separate object with one
morph target, teeth-closed.

Beyond these basic requirements, you can add
any number of targets for fear, happiness, pain,
cunning, and other emotions or expressions.
Targets for nostril flare and jaw-muscle bunching
can add subtle accents.

Tip: Expression targets are often created on the fly,
as the scene dictates. For example, if your scene
has the character shouting to be heard over the din
of a storm, you’ll need to create additional targets
with more extreme mouth shapes.

Tips on Modeling Mouth Shapes for
Speech

A letter can create different sounds depending on
the word it is in. The phrases in parentheses are to
clarify what sound is created by the letter.

A, I (“a” as in “Adam”, and “i” as in “Image”)
Move patch vertices at the mouth corners back,
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around the teeth, and up slightly. Pull out the
tangent handles on patch vertices in the middle of
the lips to stretch the lips around the teeth. Move
the cheeks back and up. Move the chin down.

Create the nine mouth shapes for speech:

E (“e” as in “we”) Modeling is similar to the A,
I target.

F, V (as in “fever”) Rotate and move patch vertices
in the middle of the lower lip to tuck the lip
under the upper teeth and flatten the chin slightly.
Slightly curl the upper lip in. Move nostrils up
slightly.

C, D, G, J, K, N, S, T, Y, Z Lower the chin and lower
lip. Indent the cheeks slightly.

B, M, P Place the lips together, move the cheeks
out slightly. The jaw and chin are “at rest”.

O (“o” as in “other”) Pull the corners of the
mouth in, indent the cheeks, move the upper lip
up slightly. Move the lower lip and the chin and
jaw down.

T, L (“t” as in “tea”, “l” as in “light”) Part the
mouth slightly. Pull the corners of the mouth back
slightly.
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U (“u” as in “burn”) Pull the corners of the mouth
in. Move the lower lip and the chin and jaw down.
Indent the cheeks; move them down and slightly
forward. Move the nostrils in very slightly.

W, O, Q (“w” as in “we”, “o” as in “who”, "q" as
in "quick") The modeling is similar to the “U”
target.

Tips for Modeling Facial Expression
Morph Targets

Blink

Brows-Up Brows-Down is the Brows-Up target
with negative values.

Pain The expression is created as a blend of the
Pain, Brows, and Blink targets.

Creating and Animating Your Own Facial
Expression

In this lesson, you will create a new expression
target (anger) for Commander Lake from a copy
of another target (pain). The teeth are also copied,
but the teeth are only there as a guide to the
modeling process. All the modeling is done in an
Editable Patch modifier.

Creating good expression targets takes some
trial and error. Try to keep the character’s
physiognomy consistent through the various
targets. For instance, when the corners of the
mouth move back, the cheeks should bulge slightly.
It’s very easy to create a target where the character
appears to suddenly lose weight, if you don’t make
a conscious effort to maintain volume.

Set up the lesson:

1. To get an idea of the scene you’ll be working
on, choose File > View File, and then choose
commander_lake.avi.

Note: A sound card and speakers or headphones
are required to hear the audio in this AVI file
and to complete this tutorial.

2. Open commander_lake_tut1.max.

For this lesson, a patch model (created using
surface tools) has been prepared with nine
phoneme targets and four facial expression
targets. An audio WAV file is included for the
character’s speech. These are the targets:
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In the previous image, the top row shows facial
expression targets; the two middle rows show
speech (phoneme) targets. The model at the
bottom of the image is the base model with a
Morpher modifier applied. The teeth-closed
target is visible at the far left; the teeth-open
base model, with a Morpher modifier applied,
is inside the base head. Organizing the targets
by type will help when you need to locate and
edit targets or create new ones.

When using the Morpher modifier, remember
that negative values and values over 100 percent
are possible. For example, negative values on
a smile target turn the corners of the mouth
down.

Hide unneeded objects:

1. Right-click the Front viewport to activate it,
then press ALT+W to maximize the viewport.

Two targets at the upper right are enclosed in
brackets.

2. Region-select the bracketed target on the left.
This is the CL (pain) target.

The selection includes the teeth.

3. Right-click and choose Move from the
transform quad menu, then hold down SHIFT

and drag to make a copy on the right side of
the viewport.

4. Select Copy in the dialog. Name the copy CL
(anger) and click OK .

The copy includes a set of teeth.

5. Right-click, and on the display quad menu,
click Hide Unselected.

6. In the viewport controls, click Zoom
Extents .

Create a named selection:

Named selections of vertices speed the modeling
process. This selection is for the four vertices that
form the corners of the mouth.

1. Select the head.

2. In the Modify panel > Selection
rollout for Editable Patch, click Vertex.

3. Expand the modifier stack display. Vertex
sub-object level is already turned on

4. Turn on Arc Rotate Selected, found on the
Arc Rotate Flyout. Rotate the viewport for a
good look at the four vertices that make up the
corners of the mouth.

5. In the viewport, CTRL+click the four vertices
at the corners of the mouth.

The interior mouth-corner vertices may take
a little work to select. Switch to a wireframe
display if necessary.
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Arrows show mouth corner vertices on wireframe

6. On the toolbar, in the Named Selection Sets
field, enter mouth corners and press ENTER.

This named selection makes it easy to select
these vertices later.

Shape the mouth by moving vertices:

1. Right-click one of the selected vertices on the
mouth and choose Move.

2. Place the cursor over the Z axis of the transform
gizmo (the axis highlights) and click+drag
down, to pull the mouth corners down.

You’ve formed a new shape for the mouth.

Move mouth corners down

3. Select the cheek vertices and move them down,
to line them up to the corners of the mouth.

Tip: You might want to use the Left viewport for
this. Make sure you drag the vertices, not their
tangent handles.

Move cheek vertices down even with mouth corners

Shape the mouth with vertex tangent handles:

The vertex tangent handles are an excellent way
to shape the model.

1. Tangent handles are often hidden in a shaded
viewport. As you work, switch back to shaded
view as needed to see the results. Use F3 to
toggle between wireframe and shaded display.
Do the following

• Right-click the viewport label and choose
Wireframe.

2. Select one outside corner vertex on the mouth.

3. Right-click the blank area of the toolbar to the
right of the tools. On the right-click menu,
choose Axis Constraints.

4. On the Axis Constraints toolbar, click Restrict
To Z.

5. Find the tangent handle that controls the curve
of the upper lip and move the handle up. Repeat
the procedure on the other side of the mouth.

This illustration is in shaded view.
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Subtle changes in the curvature, thinness, and position
of the lips greatly affect the emotion conveyed (at ease,
in pain, angry, and so on.)

Tip: If the Transform gizmo gets in the way, press X to
turn it off.

6. For anger, the nostrils and cheeks move up and
the center of the brows move down. Select and
move vertices and tangent handles to change
the expression to anger. Use the images here
as a guide.

One helpful technique is to select a vertex and
its mirror opposite and scale them from a
common center so the vertices move in and out.

For example, select the two
vertices at the corners of the mouth. On the
Main toolbar, turn on Scale and then choose
Selection Center from the Use Pivot Point
Center flyout. Drag in the viewports to make
the mouth narrower or wider.

Narrow the mouth, raise the nostrils, and lower the
center of the brow to create anger.

Tip: After editing the expression in one view,
arc-rotate the model around to see how the
change looks from other angles.

7. When you finish modeling, select the entire
head.

8. In the Morpher modifier, you can name a
channel anything you like, but it’s a good idea
to give the target a logical name. At the top of
the Modify panel, in the name field, type CL
(anger).

The anger target is complete. Next you assign
it as a target to the base head.

The completed CL (anger) target in shaded view

Assign the anger target:

This procedure assigns the anger target to the base
head.

1. Press ALT+W to minimize the viewport.
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2. On the Display panel, click Unhide All.

3. In the viewport controls, click Zoom
Extents All.

4. In the Camera viewport, click the head.

This is the base head. Notice the name
Commander Lake at the top of the Modify
panel.

5. In the Modify panel > Channel List rollout for
the Morpher modifier, scroll down to an empty
channel. Use the scroll bar to the left of the
channel list.

6. Right-click an empty channel button. Choose
Pick From Scene, and then click the CL (anger)
target in a viewport.

Test the new target:

You can test the new target at frame 0.

1. Move the time slider to frame 0.

2. On the Channel List rollout, click Zero Active
Channels Values.

All the active morph channels now have a key at
frame 0 with a value of 0. This lets you test the
target without influence from other channels.

3. Turn the channel value up for CL (anger). Use
the spinner at the right of the channel, or type
in a value.

The face morphs to anger.

4. Save your work to a new file.

Note: If you want to compare the anger target
you created with the one used for Commander
Lake, open commander_lake_tut2.max.

Update the Morpher modifier:

After modifying a target, you need to update the
Morpher modifier to use the revised target.

1. Select the base model.

2. In the Morpher modifier, right-click the
appropriate morph channel.

3. Choose Reload Target on the right-click menu.

Prepare to add keys:

1. Open the file commander_lake_tut1.max.

In this file, lip sync keys are preset for much of
the sound. In these steps, you add keys for the
last few words, “...Final transmission, 01 20 04.”

You will set up two views in Track View. By
dragging the time slider, you can locate sounds
and set keys in one view, and in the other view
use the audio waveform to help pinpoint the
position of a sound.

2. In the Camera viewport, move your cursor
over the geometry. When the tooltip says
“Commander Lake,” click to select the head.

The name Commander Lake appears in the
Name And Color rollout on the command
panel. If it doesn’t, you have selected something
else instead of the head.

3. Open the Modify panel.

The Morpher modifier is displayed. The first
nine channels display the targets for lip sync.

This file already has the sound track added, and
the lip sync started.

4. Turn on the Auto Key button.

5. On the menu bar, choose Graph Editors >
Track View - Dope Sheet.

The Dope Sheet editor is displayed across the
top two viewports. The controller window on
the left has the tracks for Commander Lake
scrolled to the top. The key window at the
right displays the keys for Commander Lake’s
animation.
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Dope Sheet displays Morph target keys

You need to split the Track View window
into two panes. You’ll set up the top pane for
morph keys and the bottom pane for the audio
waveform.

6. Drag the Track View splitter at the far right of
the Track View pane, just above the vertical
scroll bar, downward to split the pane.

7. In the top pane of Track View, click the plus
sign (+) in the Track View hierarchy panel to
the left of the item label Modified Object. Click
the plus sign again to the left of Morpher.

The Morph targets are highlighted in yellow in
the controller window.

8. Use the scroll bar at the right to move the keys
up in the top most pane, so that the Morpher
entry is at the top.

Next you’ll find the sound track wave form.

9. In the lower pane of Track View, pan left to find
the Sound track. Expand the sound track by
clicking the plus sign to the left of the sound
icon.

Scroll the view until the audio waveform is
visible. Adjust the height of the Track View
window if necessary.

You might have to scroll the top view again if
the controller window jumps.

Sound track and Keys displayed using split panes.

10. At the lower right of the Track View
window, press the Zoom flyout and choose
Zoom Time. Shift the focus to the latter part of
the animation, from frame 320 and on.

11.Maximize the Camera viewport.

Your screen should resemble the image here.
The mouth is visible, and the Morpher modifier
channel list is visible. Track View is set up, and
the Auto Key button is on.

Lip sync the first word:

1. Drag the time slider back and forth from frame
344 to frame 350.

You can hear that the word starting at frame 345
is “final.” The “F” mouth shape should precede
the sound.

2. Move the time slider to frame 344.

Tip: You can move quickly to a precise frame
by entering the frame number in the Current
Frame Indicator below the VCR controls.
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3. In the Channel List rollout for the Morpher
modifier, click Zero Active Channel Values.

In Track View, a key is displayed on all the
active morpher channels. Any interpolation
from previously set keys is canceled.

4. On the Channel List rollout, set the value of the
CL (F) channel to 70.

The lips form the “F” shape.

5. Move the time slider to frame 347, to the “i”
sound in the word “final.”

6. In the Channel list, right-click over the spinner
arrows of the CL (F) channel.

A key with a 0 value is set for CL (F). F needs to
be set to 0 so that it will not interfere with the
I shape.

7. Set CL (A) to 100 for the “i” sound. The CL (A)
and CL (I) targets are the same.

8. Go to frame 351 and set CL (A) to 0 and CL
(T) to 100.

This frame is the “L” in “final.” Because CL (T)
is interpolating through the CL (I) target, CL
(T) must be set to 0 at frame 347.

9. Move back to frame 347 and set CL (T) to 0.

Preview the result:

1. On the menu bar, choose Animation > Make
Preview.

2. On the Preview dialog, turn on Custom Range.
Set the range from 330 to 360.

3. Click Create to render the preview.

Previews with sound help you troubleshoot lip
sync. The preview looks reasonable, but keys
for the word “transmission” need to be set.

Lip sync the second word:

1. Scrub the time slider to locate the following
sounds and set the following keys:

• Scrub to frame 357, to the “a” sound in
“transmission.” Set CL (A) to 75 and CL (T)
to 0.

• Scrub to frame 362, to the “n” sound in
“transmission”. Set CL (A) to 0 and CL (G)
to 100.CL (G) now needs to be set to zero
at frame 357.

• Scrub to frame 357. Set CL (G) to 0.

• Scrub to frame 365, to the “m” sound in
“transmission.” Set CL (G) to 0 and CL (M)
to 100.CL (M) now needs to be set to zero
at frame 362.

• Scrub to frame 362. Set CL (M) to 0.

• Scrub to frame 367, to the “i” sound in
“transmission.” Set CL (M) to 0 and CL (A)
to 32.CL (A) now needs to be set to zero at
frame 365.

• Scrub to frame 365. Set CL (A) to 0.

• Scrub to frame 373, to the last “n” sound in
“transmission.” Set CL (A) to 0 and CL (G)
to 50.

2. Create a preview from frames 330 to 375.

In the preview, the “m” target in “transmission”
is too late; it needs to be earlier.

Make final adjustments:

1. Move the time slider to frame 365. At this
frame, CL (M) is at 100; CL (A) and CL (G)
both have keys set to a value of 0.

2. In the top pane of Track View, at frame 365,
select all three keys, CL (M), CL (A), and CL
(G) and move them to frame 362.

The keys are pasted over the CL (G) key you
set previously. Now CL (M) needs to be set to
zero at frame 357.

3. Scrub to frame 357 and set CL (M) to 0.

4. Render a preview between frames 330 and 375.
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The result is looking better, but the word “final”
looks exaggerated.

5. To adjust the word “final,” set CL (F) to 33 at
frame 344, and set CL (A) to 36 at frame 347.

Render a preview. The mouth movement on
the word “final” is improved.

Summary

If no one notices the lip sync on your character,
you’ve done a good job! If lip sync keys are set to
extreme values, the character’s face looks rubbery
and unreal. The trick is to match the shape of the
mouth to the sound. Rendering previews is the
best way to judge this.

For practice, set keys for the rest of the words in
this animation, “O one, two zero, O four.”

Important: Remember to set keys with zero values

before and after a key with a high value; otherwise a key

can influence the entire animation. For example, if the

CL (A) target is set to 100 and never brought back down

to 0, the influence of A target remains in effect for all the

following keys on other channels.

You can set keys for blink, brows, facial expression,
eyes, teeth, and head motion after finishing the lip
sync keys.
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Biped Retargeting

Biped Retargeting

In Biped, it is very easy to transfer animation from
one character to another by saving and loading
animation files or loading them into the motion
mixer. This solution may not always be perfect
however, especially if the two characters do not
have the same anatomy. When you load an existing

animation file, the character’s feet may sink below
ground level or the hand may not reach an object
the character is interacting with.

This tutorial explains how you can fix some of
these issues using Retargeting. You will retarget
one character onto another and ensure that some
of the limbs accurately match the position and
rotation in space of the original character. Lastly,
you will edit the animation using layers to fix any
artifacts that may have occurred in the process.

Features Covered in This Tutorial

• Retargeting one biped to another.

• Using layers to fine-tune the animation.

• Retargeting hands & feet.

Skill Level: Intermediate

Time to complete: 1 hour

You can find the files for this tutorial in the
\tutorials\character_animation\biped_retargeting
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

In This Tutorial

Retargeting a Biped (page 2–494)

Biped



494 Chapter 8: Biped

Adjusting the Animation Using Layers (page
2–495)

Retargeting a Biped

In this lesson, you retarget one biped onto another
so that both follow the same pattern. You will also
retarget limbs like hands and feet so that their
position and rotation match those of the original
character.

Retarget a Biped:

1. Open the file retargeting_start.max found
under \tutorials\character_animation\biped_
retargeting.

2. Play the animation. The character on the left
(Dr.X) is animated to open a door and go
through the opening. You will use retargeting
to apply the same motion to the character on
the right.

3. Select any biped object on the Gonzo character
such as its head (shown in green).

4. Go to the Motion panel and expand the
Layers rollout.

5. In the retargeting group, click the Select
Reference Biped button.

6. Click any biped element on Dr.X. Gonzo is now
relocated to where the Dr.X character is placed
in the scene. The Layer rollout now shows that
the Dr.X biped is being used as a reference.

7. In the Retargeting group of the Layer rollout,
ensure the hands and feet buttons are turned
off, and then click Update. This will ensure a
relative displacement of the hands and feet of
the Gonzo character, if compared to the Dr.X
character.

Note: Notice how Gonzo’s feet are slightly lower
than Dr. X’s. This can be a problem when
characters are walking on a hard surface.

8. Turn on the Retarget Left Foot and the Retarget
Right Foot buttons and click on Update.
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Gonzo’s feet are retargeted to explicitly follow those of
Dr.X.

9. From the Selection set drop-down menu on the
main toolbar, choose DrX_All.

10.Right-click in the viewport and choose Hide
Selection from the Quad menu.

11.Play the animation. The Gonzo character is
properly following the motion, but he hardly
ever stands up straight. In the next lesson, you
will use layers to adjust his demeanor.

Next

Adjusting the Animation Using Layers (page
2–495)

Adjusting the Animation Using
Layers
Adjust the Animation:

1. Continue working on your file.

2. Press Alt+W to minimize the perspective
viewport.

3. Zoom in on Gonzo’s upper body in the left
view.

4. Press H and select the object called Gonzo
Spine1 from the Select Objects dialog.

5.

In the Motion panel, expand the Bend Links
rollout and click the Bend Links button.

6. In the Layers rollout, click the Create Layer
button to create a new layer. Any adjustments
you make to the animation will go to that layer
to prevent you from altering the base animation
track.

7. On the Main toolbar, choose the Rotate tool
and set the Coordinate System to Local.

8. In the left view, rotate the spine object on the
blue axis (Z-Axis) to give the back a curved
stance. A rotation of about 10 degrees should
be enough.
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9. Expand the Key Info rollout and click on Create
Keyframe the spine.

10.If you wish, repeat the procedure to keyframe
the neck in a slightly more curved position. Try
to toggle Bend Links mode on and off to test
the results.

11.Play the animation. Notice the movement
of Gonzo compared to the stick figure
representing the base layer.

12.From the Selection Sets drop-down menu,
choose DrX_All. Click Yes to dismiss the
warning that appears and unhide the Dr.X
character.
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13.Go to frame 45. Notice how both characters
reach with their right hands to the door knob.
Since the animation was initially created using
the Dr.X character, chances are the position
of his right hand better corresponds to the
position of the door knob. Gonzo’s hand may
already be through the door at this point.

14.Select any biped part of the Gonzo character. In
the Motion panel, in the Layers rollout, turn on
Retarget Right Hand.

15.Press Update to retarget Gonzo’s right hand to
Dr.X’s right hand.

16.Play the animation to view the results. Notice
how Gonzo’s feet and right hand match their
counterparts on the Dr.X character.
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17. In the Layers rollout, press the Collapse
button to bake the adjustments you made to the
spine and neck onto the base layer.

18.Use the Selection Sets drop down to select and
then hide DrX_All and Gonzo_Biped. Only
Gonzo’s mesh remains visible.

19.Select the character’s mesh in the viewport and
go to the Modify panel.

20.Click the bulb next to TurboSmooth to turn this
modifier on. This will make the character in the
viewport much smoother and more detailed.

21.Play the animation. You can open a
finished version of this file by loading
retargeting_final.max.

Summary

In this tutorial, you learned how to retarget one
biped to another. This method ensures that some

of the limbs accurately match the position and
rotation in space of the original character. You also
learned how to edit the animation using layers to
fix problems that occur when the anatomy of the
two characters are not identical.

Twisty Bones

Using Twist Links

In 3ds Max, twist bones can be used on both biped
skeletons and max bones. In Biped, use the Twist
Links checkbox under Figure Mode > Structure
rollout to add the use of Twist bones. You can have
up to 10 twist links in the upper arm or forearm, or
in the thigh or calf. If you have an extra link in the
leg (Horse Link) you can add twist bones there as
well. You can adjust the bias of the twist along the
length of the chain by using the Twist Poses rollout.

Features covered in this tutorial

• Enabling Twist Links on a Biped.

• Adjusting Twist Links Values.
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• Adding Twist Links to the Skinning Process.

• Adjusting Twist Poses and Bias.

Skill level: Intermediate

Time to complete: 1 hour

You can find the files for this tutorial in the
\tutorials\character_animation\twist folder on the
Tutorial Files CD that ships with 3ds Max. Before
starting the tutorials, copy the \tutorials folder
from the CD to your \3dsmax8 local installation.

In This Tutorial

Twist Links (page 2–499)

Twist Links
Add twist links:

1. Open Jacket_no_twist_links.max.

This model was provided courtesy of Paul Neale and
Erin Nicholson. Some objects were hidden so you can
concentrate on the arms.

2. Play the animation.

The hand flips over to twist the lower arm.

3. Click on any part of the biped in the viewport
to select it, and then go to the Motion Panel.

4. On the Biped Rollout, click Figure Mode,
then expand the Structure rollout.

5. In the Twist Links group, turn on Twists.

6. Set the Upper Arm and Forearm Twist links to
10.

Twist Links group

7. In the Viewport you can see the extra links
created. By default, they are gray and frozen.

8. Right-click in the Viewport and choose
Unfreeze all.

9. Select the jacket and hide it. Press F3 to change
the viewport shading method to Wireframe
where you can see the multiple twist bones.

Upper Arm and Lower Arm twist bones set to 10.

10.Turn off Figure Mode and drag the timeslider
to scroll through the animation.
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You can see the twist bones changing in the lower arm.
In order for these to influence the mesh better, you
should add them to the Skin modifier.

11.In the viewport, right-click and choose Unhide
by Name, then unhide the Jacket object,
BromGirl_GEO_Jacket01.

12.Select the Jacket object and go to the Modify
Panel.

13.In the Parameters rollout, click the Add button
to add more bones.

14.From the list, add the ten Bip01 RUparmTwist
bones, and the ten Bip01 R ForeTwist bones.

15.To see the result clearly, hide everything then
unhide the jacket object only. Set the viewport
in shaded mode.
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Set twist poses:

1. Unhide the Bip01 R UpperArm link and then
select it.

Select the upper arm.

2. Expand the Twist Poses rollout. Click the Add
button. A newly named pose (Pose06) appears
in the Pose name Field.

3. Unhide the Bip01 RUparmTwist bones.

4. Hide the jacket and set the viewport display to
wireframe.

5. Adjust the Twist value to set the initial twist for
the start of the upper arm, then adjust the Bias
value to set the twist bias down the length of
the chain. Try a Twist value of -60 and a Bias
of 0.35.

6. Click Set to keep the value changes intact.

7. Rotate the upper arm object and observe the
affect on the chain of twist bones. Play with
different twist and bias setting to see the result.

Hide the other objects to see the bias affecting the chain.

8. Save your work as my_jacket_with_twist.max.

Summary

In this exercise, you have learned how to enable
and adjust twist link values on biped parts such as
upper arms and forearms. The same techniques
can be applied to leg limbs. You have also learned
how to set up twist poses with initial angle values
and bias control.
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Biped Euler Rotation and
Function Curves

Using Biped Euler Rotations and
Function Curves

Biped allows you to switch from Quaternion
rotations to Euler rotations for existing and new
animations. Both these rotation types display
function curves in Track View – Curve Editor.
Euler curves allow you to work with adjustable
tangent handles.

Features Covered in this Tutorial

• Changing Quaternion Curves to Euler.

• Changing Axis Order.

• Editing Euler Animation Curves.

• Editing Quaternion Function Curves.

Skill level: Intermediate

Time to complete: 1 hour

You can find the files for this tutorial in the
tutorials\character_animation\function_curves

folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

In this Tutorial

Biped Euler Rotations and Function Curves (page
2–502)

Biped Euler Rotations and
Function Curves

If you use function curve tangency to control
in-between key interpolation, you will find you
can use the same workflow in Biped animation.

Setting up the scene:

1. Open pitcher.max from the \tutorials\function_
curves folder.

2. Play the animation. The biped goes through the
motion of a baseball pitcher winding up and
then lobbing an imaginary ball. You will adjust
the animation of the windup using FCurve
editing of Euler rotations.

Changing Quaternions to Euler:

1. Select any part of the biped and then, in the
Motion panel, click the COM Rotation track
button.

2. In the active viewport, right-click, then choose
Curve Editor from the quad menu.
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3. The Track View appears, displaying the curves
for the COM. The Red, Green and Blue curves
represent X, Y and Z Rotations.

Note: If you cannot see the extents
of the curves, click the Zoom Horizontal
Extents and the Zoom Value Extents at the
bottom of the Curve Editor.

The curve is labeled: Quaternion Rotation of the Bip01.

4. In the Motion panel, expand the
Quaternion/Euler rollout.

5. Turn on the Euler option.

The track is now relabeled as “Tangent Euler Rotation of
the Bip01”.

Note: The Axis Order can be redefined to other
combinations, such as XZY, YZX, or ZYX.
When the axis order is changed on an existing
animation, the motion doesn’t change, only the
curves. Try it, if you like.

6. Change the Axis order to XZY.

7. Change the Axis order to ZXY.

Axis order reset to XZY

Axis order reset to ZXY

8. Reset the axis order back to XYZ.

Deconstruct the animation:

1. Turn on Key mode, and then use the
> keyboard key to move from keyframe to
keyframe. You can observe the way the COM
rotation plays in the total animation to rock the
pitcher back during the wind-up.
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Frames 0, 11 and 22.

2. Continue examining the next set of rotation
keys.

The pitcher swivels back at frame 22 and then rotates
forward at frame 60.

Edit the animation using Function Curves:

1. In the Track View Window, zoom in on the
Blue Rotation Curve. There seems to be a small
lump in the curve at frame 29.

2. Click on the key and move it downwards to
smooth out the curve. Handles appear on the
key.

Tip: It gets easy to recognize motion anomalies
by looking for sharp corners and/or small
bulges in the curves.

3. Pull the left handle out to the left, so that you
lengthen the handle.

4. Zoom back, so you can see both the red and
green curves. Pull out the handles on the left
side of the red and green keys at frame 29.

5. Go to frame 33, and zoom into the red and
green curves. Move the red and green keys
apart slightly by moving the red key upwards
and the green key downwards.

Tip: Watch in the viewport. When you release
the mouse the biped updates in the viewport.

6. Play the animation.



Biped Euler Rotations and Function Curves 505

The Biped now leans farther over. The pose is better than
before. If you play the animation, however there seems
to be a spot where the character snaps too quickly.

7. Go to frame 33, and raise the red and green
keys on the curve so the curve is smoother.

Smooth the curve by shifting keys vertically and
adjusting handles.

8. Do the same for the red and green curve keys
at frame 45.

9. Play the animation and move the keys in the
Trackview window while the animation plays,
until the adjustment of the keys has smoothed
the animation.

10.Drag the key in the Track View key window to
shift the rotation keys from frame 45 to frame
52.

11.Adjust the handles on keyframes 52 and 60 to
smooth the newly positioned key curves.

Play the animation again; it no longer snaps too quickly.

Edit Quaternion function curves:

In addition to the Center of Mass, the Pelvis has
rotations. The pelvis can be rotated on all 3 axes.
Rotating in X and Y will affect the hips, whereas
rotating the pelvis in Z will not affect the legs at all.

1. Select the Bip01 Pelvis.

The Pelvis displays Quaternion function curves.

2. Select the keys at frame 45 and move them to
frame 52.

You made this change to the COM, so this will
correct the hips at that frame. Notice that there
are no handles on the Quaternion keys. handles
are not displayed on Quaternion curves.

3. At frame 60 select the Left foot, and then,
in the Key Info rollout, set a planted key for it.

4. Play the animation. The motion of the pitch
is now smooth, with the new pose seamlessly
incorporated.

Summary

In this exercise, you have learned how to fine-tune
the rotation of the Center of Mass and the Pelvis
on a Biped. You have also learned how to display
function curves and how to edit tangents to
smooth out the animation on that section of a
biped. You also learned how to switch between
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Euler and Quaternion Curves to get the best curve
manipulation possible inside Track View.

Interacting with Objects

Interacting with Objects

This tutorial shows you how to animate a biped
interacting with other objects.

Wilson rides a skateboard.

In this tutorial, you will make a biped do the
following:

• Climb a ladder.

• Pick up a briefcase.

• Bounce a basketball.

• Work with props.

• Look at an animated object.

The movement of the biped’s hands can control
the movement of the second object, or the biped’s

hands can be constrained to or animated by that
other object. There are also lessons on creating the
illusion of weight, and using In Place mode.

Skill level: Intermediate

Time to complete: 3 hours

You can find the files for this tutorial in the
tutorials\character_animation\interacting_with_
objects folder on the Tutorial Files CD that ships
with 3ds Max. Before starting the tutorials, copy
the \tutorials folder from the CD to your \3dsmax8
local installation.

In This Tutorial

Making a Hand Follow an Object (page 2–506)

Making Feet Follow Objects (page 2–511)

Dribbling a Basketball (page 2–514)

Climbing a Ladder (page 2–522)

Picking Up an Object (page 2–530)

Creating the Illusion of Weight (page 2–534)

Using Props (page 2–539)

Making the Biped Look at Objects (page 2–544)

Using In Place Mode (page 2–546)

Making a Hand Follow an Object

In this lesson, you’ll make a biped’s hand follow
an animated object.
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When a biped’s hand must interact with an object,
there are two methods you can use to create the
animation:

• Animate the hand, then link the object to the
hand with Select And Link, or

• Animate the object, and use IK settings to make
the hand follow the object.

The second method has some practical advantages,
which are illustrated with this lesson.

Set up for this lesson:

1. Open the file ironing_start.max.

This file features a character named Wilson
standing in front of an ironing board.

2. Play the animation. The iron is animated to
move over the cloth on the ironing board.

This character already has a biped with
Physique applied to it. To work with the
character, you’ll hide the mesh and unhide the
biped.

3. Choose the named selection set Wilson Biped.
When the warning dialog appears, click Yes.

The biped appears in the scene.

4. Choose the named selection set Wilson Mesh.

5. On the Display panel, click Hide Selected.

This leaves the biped in the scene without the
character mesh.
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Pose the hands:

1. Go to the Motion panel.

2. Go to frame 0.

3. Turn on Auto Key.

4. Using Select And Move and Select
And Rotate, pose the right hand to hold the
iron handle. Look at the hand from different
angles to ensure it is gripping the handle. Don’t
be concerned if the fingers pass through the
handle slightly.

Tip: You can also right-click in a viewport and
choose Move or Rotate from the quad menu.

If you have difficulty with this step, open the
file ironing_handpose.max. This file contains
the biped already posed with its right hand on
the iron.

5. With Auto Key turned on, position the left
hand to hold down the fabric.

Link the right hand to the iron:

1. Select the right hand.

2. On the Motion panel > Key Info rollout, expand
the IK bar.

3. Click Select IK Object, and click the iron.
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The object name Steam Iron appears to the left
of the Select IK Object button.

4. Choose the Object option just above the Select
IK Object button.

5. Change IK Blend to 1.0.

6. Play the animation. The hand follows the iron.

You could have created a similar animation by
linking the iron to the hand with Select And
Link, then animating the hand. However, this
type of animation is limited. For example, if
you later bent the biped’s spine so he could get a
closer look at his ironing, the hand would move
with the spine and sink into the ironing board.
With IK linking, the hands will stay put when
you rotate the spine.

Right now, if you bent the spine, the right hand
would stay on the iron but the left hand would
move. You can keep the left hand from moving
by anchoring it to the ironing board.

Link the left hand to the ironing board:

1. Select the left hand.

2. Click Select IK Object, and click the ironing
board.

The object name Ironing Board appears to the
left of the Select IK Object button.

3. Choose the Object option just above the Select
IK Object button.

4. Change IK Blend to 1.0.

Bend the biped over:

1. Select all the biped’s spine links.

2. Make sure you’re at frame 0.

3. In the Key Info rollout, click Set Key.

4. Go to frame 40.

5. Make sure Auto Key is turned on.

6. Rotate the biped’s spine links so the biped
bends slightly forward.
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The biped’s hands stay in place when the biped
bends forward.

7. Go to frame 80, and rotate the spine links to
make the biped stand up straight again.

8. Animate the biped’s head every 30-40 frames
to make him look at the iron as he works.

Unhide the character:

1. From the Named Selection Sets list, choose
Wilson Mesh. When the warning dialog
appears, click Yes. The character mesh appears
in the scene.
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2. From the Named Selection Sets list, choose
Wilson Biped.

3. Go to the Display panel and click Hide Selected.

The biped is hidden, leaving only the character
mesh.

4. Play the animation. Wilson irons the cloth and
bends over to take a closer look.

5. Save your work in the file my_wilson_
ironing.max.

You can find a completed version of this
animation in the file ironing_complete.max.

Making Feet Follow Objects

In this lesson, you’ll make a character ride a
skateboard.
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In practice, you could accomplish this animation
by linking the skateboard to one of the biped’s
feet and animating the entire biped. However,
this would make it extremely difficult to animate
the biped’s upper body leaning and dipping as he
rides the skateboard. If you did so, every time
you moved the biped’s foot or leg, the skateboard
would skitter and slide unnaturally.

You can’t link the biped’s feet directly to the
skateboard with Select and Link. These body parts
are already linked to the legs, and linking them
to another object would cause them to become
disengaged from the legs and the rest of the body.

Instead, you’ll use IK linking to make the biped
feet and body follow an animated skateboard.
With this method, you can animate the upper
body leaning and turning without interfering with
the motion of the skateboard. This feature makes
it easy to animate a character doing any motion
where the feet need to stay stuck to the apparatus
while the body moves freely, such as pedaling a
bicycle or skiing down a slope.

Set up for this lesson:

1. Open the file skating_start.max.

This scene features Wilson on a skateboard.

2. Play the animation.

The skateboard follows a path, but Wilson
doesn’t go with it. You’ll work with Wilson’s
biped to make him ride the skateboard.

3. Choose the named selection set Wilson Mesh,
and hide the selected objects.

4. Choose the named selection set Wilson Biped,
and click Yes on the warning dialog to unhide
the biped.

Position the feet:

1. Go to the Motion panel.

2. Go to frame 0.

3. In the Front viewport, zoom in on the feet.

4. Turn on Auto Key.

5. Rotate each foot so it sits parallel to the top of
the skateboard.

Link the feet to the skateboard:

In order to link the feet to the skateboard, each
needs a key set at frame 0. You have already created
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keys for the feet by posing them on frame 0. If you
hadn’t, you could use the Set Key button on the
Key Info rollout to set keys for each foot/leg.

1. Select a foot or leg.

You can select any part of the leg or foot to link
it to the skateboard.

2. On the Motion panel > Key Info rollout, expand
the IK bar.

3. Click Select IK Object, and click the top
portion of the skateboard.

The object name Skateboard Top appears to the
left of the Select IK Object button.

4. Choose the Object option just above the Select
IK Object button.

5. Change IK Blend to 1.0.

6. Select any part of the other foot or leg, and
repeat these steps to link it to the skateboard.

7. Play the animation.

The biped tries to follow the skateboard, but
he’s not very successful. The legs extend as
much as they can, but the skateboard moves
away and the biped’s center of mass stays in the
same place.

To make the entire body go along with the
skateboard, you’ll link the center of mass to it.

Link the COM to the skateboard:

The center of mass object (COM) is the only object
in the biped that isn’t linked to other objects in the
biped. It can be linked to any object with Select
And Link to make the entire body follow along
with the object.

1. Select the center of mass object, named Wilson
Biped.

2. On the Main toolbar, click Select And
Link.

3. Link the center of mass to the skateboard.

4. Play the animation.

The entire biped moves with the skateboard.

Animate the upper body:

The linking method you’ve used allows you to
animate the upper body freely without interfering
with the skateboard motion.

1. Go to frame 0.

2. Make sure Auto Key is turned on.

3. Pose the biped in a crouch, as if ready to turn
a corner on the skateboard. Move the center
of mass downward to bend the biped’s knees,
and move it horizontally to shift the biped’s
weight. Rotate the spine to make the biped lean
forward, and pose the head and arms.
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Tip: To rotate the legs outward, rotate the calf
and not the thigh. This will rotate the legs while
keeping the feet in place.

4. Go to frame 60 and change the pose slightly.
You can move the center of mass to shift the
biped’s weight, turn his head, or move his arms
to different positions.

5. On frame 120, change the pose again.

6. Play the animation.

The biped rides the skateboard, leaning and
dipping to keep his balance.

See the animation on the character mesh:

1. Select the named selection set Wilson Mesh,
and click Yes to unhide the mesh.

2. Select the named selection set Wilson Biped,
and hide the selection.

3. Play the animation. Cowabunga!

You can see a finished version of this animation
in the file skating_complete.max.

Dribbling a Basketball

This lesson animates a biped’s hand and a
basketball to simulate the biped bouncing the ball.
The ball is animated on its own, bouncing up and
down. When the ball is at the height of its bounce,
it controls the hand through inverse kinematic
blending. When the ball strikes the ground, the
ball and the hand are not connected, and the hand
is animated independently. To create this effect,
you’ll animate IK Blend on and off.

Set up for this lesson:

1. Open basketball_bounce_start.max.
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2. Play the animation to see what happens.

The biped bounces the ball five times while
walking forward.

Biped bounces ball and walks.

Understand the keyframing:

Use Key mode to understand the structure of the
animation.

1. Select the ball.

Keys appear in the track bar.

2. Turn on Key Mode Toggle.

3. Move to each key using Next Key in the
time controls, or by clicking the arrows on the
time slider.

The ball strikes the ground at frames 15, 39, 58,
78, and 101.

The ball is at the top height of its bounce at
frames 0, 30, 48, 67, 89, and 111.

4. Select the biped’s right hand (the object named
Walk01 R Hand).

Keys appear in the track bar.
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5. On the Motion panel, open the Key Info rollout,
and then expand the IK expansion bar, so you
can see the IK Blend field. Play the animation.

The fields in the rollout blink rapidly because
IK Blend is animated.

6. Move to each key, looking at the IK Blend field.

IK Blend fluctuates between 1 and 0.

Observe the pattern of the keys in the track bar.
There are groups of three or more keys followed
by a single key.

The groups have IK Blend set to 1, but the
single keys have IK Blend set to 0. The groups
also have Object space selected. Sphere01
(the basketball) has been designated as the IK
Object.

Note: Only one IK Object can be defined for the
hand. You cannot change from one IK Object
to another during the animation.

Adjust the basketball’s animation:

1. Turn on Auto Key mode.

2. Select the ball in the viewport.

3. At frame 30, right-click and choose Move.
Using the Transform gizmo, raise the ball up
and closer to the biped’s body.

The hand follows the position of the ball
because the hand is locked into the object space
of the ball.

Tip: If the hand does not move with the ball,
select the hand and verify that Object space is
turned on in the Key Info rollout > IK group.

Hand follows ball.

4. At frame 0, move the basketball down.

The hand moves with the ball because IK Blend
is set to 1 and the ball is the designated Object.

Note: If you move the ball too far it leaves the
hand behind.
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Ball leaves hand.

5. Move the basketball up so it is in contact with
the hand.

Start with ball in contact with hand.

6. Rotate the spine so the biped crouches over.
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Rotate biped spine object.

7. Move the basketball down so the dribble is low.

8. To bend the biped’s knees, click the Body
Vertical button in the Track Selection rollout,
and move the COM object down somewhat.

Because the feet have planted keys, they act
as an IK anchor, and therefore the legs bend
accordingly.

Lower center-of-mass object to bend knees.

Moving the basketball repositions the hand
when the IK Blend is set to 1 and the basketball
to Object.

If you move the basketball while IK Blend is set
to 0, the ball will not affect the hand.

9. With the right hand selected at frame 14,
click the Set Free Key button on the Key Info
rollout.

This sets IK Blend to 0.

10.At frame 16, again set IK Blend to 0.

11.At frame 15, move the basketball.

Nothing happens to the hand, because IK Blend
is 0.
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Ball movement doesn’t affect hand.

Animate the dribble:

The basketball bounces one time more than the
biped dribbles it. You’ll set up the last dribble to
see how this works.

1. With Auto Key still turned on, go to frame 111.

2. Select the right hand.

Select green hand.

3. Move the hand up out of the way. You’ll be
moving it again, so it doesn’t matter where you
move it.
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Hand moved away temporarily

4. Select the basketball.

5. Move the ball in front of the biped, just above
waist height.

Position the ball.

6. Zoom in the Perspective, Left, and Front
viewports so you can see the biped’s hand from
different views.

7. Rotate and move the biped’s hand so it is in
contact with the ball. Rotate the fingers so the
hand cups the ball.

Tip: Rotate the fingers individually. Use Arc
Rotate Selected to orbit the viewport around
the selected finger as you work.
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Rotate fingers.

8. In the Key Info rollout, change IK Blend to 1
and turn on Object.

Sphere01 is already designated as the IK Object,
so you don’t need to select it.

9. Raise the ball.

The hand moves with it.

If you move the time slider back and forth,
you’ll see there’s still more work to do.

10.At frame 109, move the hand down so it is just
above the basketball. Then change IK Blend to
1, and turn on Object. Rotate the hand so the
fingers don’t penetrate the ball.
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11.At frame 113, move the hand down so it’s just
above the basketball. Change IK Blend to 1,
and turn on Object if it isn’t already selected.
Again rotate the hand as needed.

12.Move to frame 117.

You need to set IK Blend back to 0, or the
movement of the ball will continue to influence
the hand. But the fields are not available
because there is no key set.

13. In the Key Info rollout, click Set Key.

This sets IK Blend to 0 and turns on Body space.

Move the time slider to see the movement.

For extra credit, have the biped pass the ball
between his legs and dribble with the opposite
hand. While the hand can only have one IK
Object, both hands can share the basketball as
that object.

14.Save your work as mybasketball.max, or open
basketball_bounce_final for comparison.

Climbing a Ladder

It takes a lot of steps to create a freeform animation
because you’re animating the feet and hands
without any automation. Once you learn a
technique, you repeat the same sequences over and
over for each limb to create the keyframes.

In this lesson, you’ll load a file that is partially
animated, and you’ll create the animation for just
one of the arms. Normally, you would then repeat
the steps for the other limbs.

Set up for this lesson:

1. Open climb_ladder_start.max.

2. Play the animation.

Let the animation loop while you watch the
movement of the green hand. It grabs the
ladder to support the biped as he steps up on
the green foot.

You’ll make the left hand grab the rung, and
then slide up the rail as the biped climbs.
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Create the first poses:

1. Turn on Auto Key mode.

2. Select Bip01 L Hand.

At frame 0, the arms are at rest. The first pose is
at frame 19.

3. At frame 19, move the hand forward and
slightly up, as if the biped’s about to shake
hands.

The arm at frame 19

4. At frame 30, move the hand so the left fingers
just touch the ladder.

5. Rotate the hand about the Y-axis so the hand
is perpendicular to the ladder rung. View the
hand from several perspectives so you can place
the hand correctly.

The arm at frame 30
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Make the hand grab the ladder:

In this procedure, the fingers are rotated to grab
the ladder. The hand is set to an IK Blend of 1, and
put in the Object space of the ladder rail.

1. At frame 36, select the hand.

2. Move the hand so the palm is flush with the
ladder rail, near the third rung.

3. In the Top viewport, move the hand to the right
of the ladder rail.

4. Rotate the hand so the palm is flush with the
ladder rail.

Watch the Top and Perspective viewports as you
move the hand, or use Arc Rotate Selected to
orbit the viewport around the selected object.

5. To select all the fingers, double-click the hand
to select the hand and all the fingers, then hold
down the ALT key and click the hand.

Now all the fingers are selected.

6. In the Top viewport, rotate the fingers about
the Z-axis so they curl to grab the ladder.

You can also adjust each finger individually.

The arm at frame 36

7. Deselect the fingers and select the hand again.

8. On the Motion panel, in the Key Info rollout,
change IK Blend to 1.

9. Change from Body to Object space.

The IK Object, Box06, is now active.

10.Move the time slider to see the animation.

The biped appears to grab the rail.

Slide the hand up the ladder:

The hand is locked to the ladder rung at frame 36,
so it stays in place as the rest of the biped moves in
the frames that follow. To slide the hand up the
ladder, you’ll use a trick. You’ll move the hand in
the Reference Coordinate System of the ladder.

1. Make sure Bip01 L Hand is selected. On the
Main toolbar, choose Select And Move.

2. On the Main toolbar, in the Reference
Coordinate System selector, choose Pick.
Then select Box06, the rail of the ladder in the
viewport.

The Transform gizmo changes. You can now
move the hand so it remains aligned to the
ladder rail.

3. At frame 45, move the hand up so it is farther
up the rail.

The hand now immediately starts to slide up
the rail from frame 36 to frame 45. It should
grip the ladder for stability for a few frames
before the slide begins.

4. Hold down the SHIFT key and move the key on
the track bar from frame 36 to frame 39.

This clones the key from frame 36 to 39.

5. On the Motion panel, in Key Info rollout,
expand the TCB expansion bar. Set the Tension
and Continuity to 0 at frames 36 and 39.

6. Move the time slider to play the animation.

The hand grips the rail starting at frame 36,
then begins the slide from frames 39 to 45.
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7. At frame 49, move and rotate the hand so
the gripping fingers stay wrapped around the
ladder.

The movement takes place in the Reference
Coordinate System of the ladder rail (Box06),
but the rotation does not. Each transform can
use a different coordinate system. Selecting one
system for position doesn’t affect the system
for rotation.

Open and close the grip:

At frame 61, the green foot is planted on second
rung. Here you’ll have the hand release its grip on
the rail.

1. At frame 61, select all the fingers.

2. Rotate the fingers so they loosen their grip.

3. Move the hand out so it comes off the rail a
little.

Next at frame 80, the blue toes touch the top
rung, and the fingers grip again.

4. At frame 80, select all the fingers.

5. Rotate the fingers back into a grip.

6. Move and rotate the hand so it grips the ladder
at the top of the rail.

The arm at frame 80

The green foot is planted on top of the box at
frame 115. This is the last frame in which the
hands grip the rungs.

7. At frame 115, rotate the hand about the Y-axis,
so the hand pivots on the top of the rung.

The arm at frame 115
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8. Hold down the SHIFT key and move the key on
the track bar from frame 115 to frame 122.

This clones the key from frame 115 to 122.

9. In the Key Info rollout, set Continuity and
Tension to 0 for keyframes 115 and 122.

This locks the hand in place until frame 122.

Release the grip:

1. At frame 126, select the hand again. In
the Key Info rollout, set a free key with the Set
Free Key button.

Setting a free key sets IK Blend to 0 and turns
on Body space (as it turns off Object space).

2. Move the hand off the ladder.

The hand is not affected by the ladder any more.

3. Select the fingers and rotate them to relax the
grip.

Rotate the hand about the Y-axis so the hand is
pointing more toward the ground.

The arm at frame 126

4. At frame 154, rotate and move the hand so it is
loosely outstretched.

The biped steps onto the blue foot.

The arm at frame 154

5. At frame 169, select the entire right arm.
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6. On the Motion panel, in the Copy/Paste rollout,
make sure Posture is turned on.

7. Click Copy Posture, then Paste
Posture Opposite.

8. Play the animation.

The biped stops, rests his hands on hips, and
preens.

9. Save your work as myladder1.max, or open
climb_ladder_final.max to compare your work
to the correct animation.

Link the center of mass to an object:

You’ll begin by looking at a scene from the
production “Pool Tools”. A biped climbs a ladder,
but when the ladder swings from side to side, the
biped hangs in midair.

In these procedures, you’ll make the biped grab
onto the ladder. Then you’ll use the Select And
Link tool to make the movement of the ladder
affect the entire biped.

1. Open ladder_swing_start.max.

2. Play the animation.

The animation of the pool guy climbing the
ladder has already been done. The ladder
has also been animated, but there is no link
between the two.
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The pool guy climbs the ladder. The ladder swings, but the pool guy stays put.

In the next procedure, you’ll lock the hand
down, and then link the biped’s center of mass
to the ladder.

Make the hand grab the rung:

1. Go to frame 431. Turn on Auto Key
mode.

2. Select the left hand and move it close to the
ladder rung.

3. Select Bip01 L Finger0.

4. Right-click and choose Rotate.

5. Rotate the finger about the Z-axis, making it
grasp the ladder.
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6. On the Motion panel, in Key Info rollout,
set a sliding key.

This sets IK Blend to 1, which locks the hand
in Object space.

7. Play the animation.

The ladder still swings, leaving the biped
behind in the air. In the next procedure, you’ll
use the Select And Link tool to change this.

Make the biped swing with ladder:

1. Press H on the keyboard to select the biped’s
center of mass, Bip01.

2. On the Main toolbar, click Select And
Link.

3. Press H again and highlight ladder dummy01,
then click Link.

The biped’s center of mass is now linked as a
child to the ladder as its parent.

4. Play the animation.

The biped now follows the motion of the ladder.

Linked center of mass moves biped with ladder.

5. At frame 451, select and move the center of
mass.

The hand is locked, but the rest of the biped
can be changed.

Note: If you move the center of mass far
enough, the hand leaves the ladder. When you
override the IK limits, forward kinematics take
precedence.

6. Rotate the center of mass about the X-axis, so
the biped swings a little bit.

Move and rotate the center of mass until the
biped is in position.
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Hand locked, the rest of the biped moves.

7. Repeat the process at frame 482, moving and
rotating the center of mass, so the hand remains
on the ladder and the body swings in the
opposite direction.

The biped swings with the ladder.

To finish the animation, you’d have to
repeat this process to match all the keys as
the ladder continues to wobble back and
forth. You can do that for practice if you
like. To watch the finished animation, open
ladder_swing_final.max.

Picking Up an Object

When a biped needs to pick something up, carry
something, or put something down, you can use
a Link Controller to animate the biped, then let
the biped’s hand animation control the movement
of the object.

In this lesson, a character picks up, carries, and
puts down a briefcase.
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Note: This file uses the Classic biped figure, rather
than the skeleton found in the previous exercises.

Set up for this lesson:

1. Open pickup_briefcase_start.max.

2. Play the animation.

The biped picks up, carries, and sets down a
heavy invisible object with a handle.

3. Select Bip01 R Hand.

4. Turn on Key mode and move through the keys.

There is a key at frame 56, where the biped
picks up the briefcase. The biped carries the
briefcase until frame 228.

You’ll use these frames for the changes of
linkage.

Assign the Link controller:

1. At frame 56, open the Motion panel.

2. In the Perspective viewport, select handle.

Tip: Check the name at the top of the command
panel to confirm your selection.

3. In the Assign Controller rollout, click
Transform: Position/Rotation/Scale.

4. Click Assign Controller.

5. In the Assign Transform Controller dialog,
choose Link Constraint and click OK.

This assigns a Link Controller to the object the
biped is going to pick up.
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6. Zoom into the viewport to see the handle, the
dummy, and the biped’s hand.

7. In the Link Parameters rollout, click Add Link.

You’ll link to two different objects. The biped
hand will animate the briefcase. The handle will
link to a dummy when you want the briefcase
to remain stationary.

8. Select the blue dummy object near the briefcase
handle.

The name stay put dummy appears in the Link
Controller list.

9. Change the Start Time to 0.

Now you’ll add Bip01 R Finger0 as the second
link. You don’t need to click Add Link again,
as it is still active.

10.Select Bip01 R Finger0 (the large yellow box at
the end of the biped’s hand).

Bip01 R Finger0 appears in the Link Controller
list, with a Start time of 56.

11.Move the time slider to frame 228 and select
the dummy again.

The stay put dummy object appears in the list a
second time, with a Start time of 228.

12.Play the animation.

The biped picks up the briefcase, carries it, then
sets it down.
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In this case, there was no need to rotate the
fingers to create a grasp, since this biped has
only one giant finger. For bipeds that do have
more fingers, you would link to the Bip01
Hand objects, rather than the finger objects.
This would let you rotate the fingers, together
or individually, to create the grasp without
affecting the briefcase.

Note: Do not make changes to the biped’s hand
after creating the links. If you need to correct
the animation of the hand, delete the links, and
then create them again after the animation is
correct.

Tip: If the biped carries the object the entire
time, you do not need to use the Link
Controller. Instead, attach the object to the
biped hand using Select And Link.
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Creating the Illusion of Weight

There are two techniques for giving the illusion
of weight to a biped object in an animation. Both
affect the biped center of mass.

The first technique uses Balance Factor, which
moves the center of mass. Balance Factor is
available on the Body Horizontal track. This
technique creates the illusion of lifting a heavy
object. It lets you keyframe the center of mass
moving in and out of the body.

The second technique uses Figure mode to turn on
Rubber Band; you then move the center of mass in
front of or behind the body. This technique creates
the illusion of the biped pushing or dragging a
heavy object. You can’t keyframe the center of
mass with this technique; instead, you set it for the
entire animation.

Lifting Heavy Objects

Set up for this part of the lesson:

1. Open balancefactor_start.max.

Two bipeds have planted keys set on their feet,
with the pivot points set at their toes.

2. Select any part of the biped on the left, and then
open the Motion panel.

Use Balance Factor:

1. On the Track Selection rollout, click the
Body Horizontal button.

2. In the Key Info rollout, expand the Body
expansion bar so you can see the Body
parameters. Then set Balance Factor to 0.

The Balance Factor is available because this file
contains a keyframe on the Body Horizontal
track at frame 0.

Tip: Many parameter settings will not be
available unless you have a key set on a
particular track. If a parameter is unavailable,
click Set Key in Key Info rollout and see if it
becomes available.

3. Move to frame 15, then turn on Auto
Key mode.

4. Select Bip01 Spine object (the first, or lowest,
spine object).

5. Use Arc Rotate to orbit the viewport so you can
see the biped from the side.

6. Rotate the spine about the Z-axis.

Notice that the upper body rotates, while the
legs stay firmly planted.
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Only the upper body rotates.

Animate the Balance Factor:

1. Select any part of the other biped.

2. In the Track Selection rollout, select Body
Horizontal.

3. In Key Info rollout, click Set Key.

Now Balance Factor is available.

4. Change Balance Factor to 2.

5. Select Bip02 Spine. Rotate this spine.

This time the hips move back as the torso
rotates forward. If you rotate the torso enough,
the feet move off the floor.

Notice also that the center of mass is now in
front of the body.

Hips move back, torso rotates forward.

6. Move to frame 0, and select Body Vertical in
the Track Selection rollout. In the viewport,
use the Transform gizmo to move the center of
mass down, so the knees are bent.

7. At frame 15, also move the center of mass down
so that the knees stay bent.

8. Use the time slider to view the motion. Notice
that you no longer have the original standing
poses at frame 0.

9. Go to frame 0. Rotate Bip02 Spine so the
standing pose is re-established. Adjust the
COM so the knees are not bent.
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10.At frame 23, move the COM way down so the
chest goes right through the leg (this will look
wrong, but don’t worry). Then rotate the Bip02
Spine so the knees almost touch the chest.

Tip: There’s nothing that prevents biped body
parts from intersecting. Check your animation
for these intersections visually and correct by
adjusting keyframes.

11.At frame 30, move the center of mass so the
biped starts to lift the imaginary object using its
legs, rather than its back.

12.At frame 38, in the Track Selection rollout, click
the Body Horizontal button.

13.On the Key Info rollout, click Set Key.

14.Change the Balance Factor to 1.

The center of mass moves back closer to the
biped.

15.Select and rotate the spine.
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16.At frame 45, rotate the spine more.

17.Move the center of mass so the biped stands up
straight. Now the center of mass is back inside
the body.

18.Move the time slider back and forth to view the
animation.

Watch how the center of mass moves outside
the biped, then back again.

The biped appears to be lifting something
heavy because of the positioning of the knees
and spine.

19.For extra credit, finish the animation
of the other biped. Save your work as
my_balancefactor_final.max, or open
balancefactor_final.max for comparison.

Pushing Heavy Objects

Set up for this part of the lesson:

1. Open pushbox_start.max.

2. Play the animation.

The biped is pushing a box along the floor.
Notice that the center of mass is behind the
biped.

Adjust the center of mass with Rubber Band:

1. Select any part of the biped.

2. In the Motion panel, in the Biped rollout, turn
on Figure mode.

The biped moves so his hands are no longer
touching the box. Notice that, for this figure,
the spine objects are rotated so the biped has
a rounded back.
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3. In Track Selection rollout , click Body
Horizontal.

4. Expand the expansion bar in the Biped
Rollout. In the Modes group, turn on Rubber
Band Mode. Then move the biped’s center of
mass so it’s back inside the body.

5. Turn off Figure mode and play the animation.

The upper torso moves back over the feet. The
illusion of weight is diminished.

6. Turn on Figure mode. Move the center of mass
far behind the body, and then turn off Figure
mode.

The biped leans into the box, as though the box
were quite heavy.

7. Play the animation.
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Using Props

Props are objects that a biped might be carrying or
swinging, such as a sword, spear, or “lightsaber”.
They are parametric objects that are included
as part of the biped skeleton, so that if you have
motion capture data with prop information, there
is a place for that information to reside. You can
have up to three props saved with the biped.

Props have two parameters for Position Space and
Rotation Space that can be keyframed. This makes
it easy to have the prop follow the biped’s hand, or
to switch the prop from one hand to another.

Add a prop to an animated biped:

This procedure starts with a biped sawing a board.
You’ll create a prop to take the place of the saw.

1. Open saw_wood_start.max.

2. Play the animation. The biped rests one knee
on the invisible board, and saws it with an
invisible saw.

3. Select any part of the biped and open the
Motion panel.

4. On the Biped rollout, click Figure
Mode.

In the Perspective viewport, the biped shifts to
a different position.

5. To create a prop, open the Structure Rollout
and turn on Props 1.

The prop appears at the biped’s right hand.
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To align and position the prop to the hand,
you’ll leave Figure mode and set a key for the
prop.

6. Turn off Figure Mode, and then select the prop
in the viewport.

7. Move the time slider to frame 0.

8. In the Perspective viewport, rotate the prop
approximately 152 degrees around the Y-axis.

The rotation is displayed in yellow in the
viewport, and in the Coordinate Display below
the viewport.

9. On the Key Info rollout, click Set Key.

10.Expand the Prop divider bar. In the Rotation
Space drop-down list, choose Right Hand.

This puts the prop in right-hand rotation space.
As the right hand rotates, the prop will follow.
Notice that you can’t make changes here unless
you have set a key.

11.On the Main toolbar, click Select And Move,
and then change the Reference Coordinate
system to Local.

12.In the Perspective viewport, move the prop
along the Z-axis so it is slightly in front of the

hand, then click Set Key again to keyframe the
position of the prop.

13.Play the animation. The prop follows the
movement of the hand nicely.

14.To make the prop more closely resemble a saw,
turn on Figure mode and scale the prop so its
proportions match those of a hand saw. Then
turn off Figure mode and play the animation.
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If you like it, save your work to
mysawingwood.max.

Animate props switching hands:

This procedure starts with a file of an animated
biped. You’ll add a prop, and then keyframe it to
switch hands to follow the motion.

1. Open samurai_start.max.

2. Play the animation.

The biped brings his two hands together and
then separates them.

To create a prop you will go into Figure mode.

3. In the viewport, select any part of the biped.

4. Open the Motion panel, and on the
Biped rollout, turn on Figure Mode.

5. Open the Structure rollout and turn on Props 1.

The prop appears in the viewport beside the
biped’s right hand.

6. Turn off Figure mode and play the animation.

The prop follows the movement of the pivot
point of the right-hand wrist. To adjust the size
of the prop, you can use the Scale transform.

7. Turn on Figure mode and select the prop.

8. On the Main toolbar, choose either Scale or
Non-Uniform scale to change the size and
proportions of the prop. Turn off Figure mode
when you are through.

9. Turn on Auto Key mode. Rotate the prop so
that it’s perpendicular to the hand.

Rotate and move the prop near the palm of the hand.

10.On the Main toolbar, click Select and Move.
Then in the Reference Coordinate drop-down
list, choose Local. Move the prop on its local X
and Y-axes so the prop is in contact with the
palm of the hand.

11.Make sure the prop is still selected, and then
open the Key Info rollout.

12.Expand the Props bar, and click Set Key so the
Position Space and Rotation Space fields are
accessible in the Props group.

13.Using the drop-down list, change both Position
Space and Rotation Space to Right Hand.

14.Play the animation.

The prop follows the movement of the right
hand throughout the whole animation.
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Prop follows the right hand.

Prop follows right hand for the entire animation.

To make the biped switch hands, you can
keyframe the Position and Rotation Space.

15.Move to frame 40. The prop should still
selected. In the Key Info rollout, click Set Key.

This sets a key

16.Move to frame 41, and click Set Key.

This activates the Position and Rotation Space
fields.

17.Change Position Space and Rotation Space to
Left Hand. Now play the animation.

The prop follows the movement of the right
hand until frame 41. It follows the movement
of the left hand from 41 to the end of the
animation.

Something is not quite right, however. The
prop appears to be attached to the wrist of the
left hand.

18.On the Main toolbar, choose Select And Move,
and then change the Reference Coordinate
system to World.

19.Move to frame 45. Reposition the prop so it’s in
contact with the palm of the left hand. You can
rotate it slightly as well to match the angle of the
left hand. Click Set Key when you are happy
with the position and rotation of the prop.
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Adjust the placement of the prop.

20. Play the animation.

The prop follows the movement of the hands
correctly. The prop follows the right hand until
frame 41, then switches and follows the left
hand until the end of the animation.

Prop follows the other hand.

21.Depending on the length of the prop, you may
find that it passes through the head or other
body part. If this happens, you can keyframe
the rotation of the hand so the prop avoids this
intersection. You can also keyframe the prop
independently of the hand, if needed.
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The prop may intersect the head.

Rotate the hand or the prop to correct.

22.Save you work as mysamurai.max.

Making the Biped Look at Objects

You can easily have a biped’s head look at another
object in the scene. In this lesson, you’ll animate a
biped watching a table tennis match.

Set up this lesson:

1. Open lookat_tabletennis_start.max.

2. Play the animation in the Perspective viewport.

The ball bounces back and forth over the net
four times, then the ball bounces up and done
in place four times.

Ball bounces, but biped isn’t watching.

Make the biped look at a target:

Suppose you want to animate the biped watching
the ball going over the net, but not follow the
bounce in place. By animating Target Blend, you
can create this effect.

1. In the Perspective viewport, select the head of
the biped. Open the Motion panel.

2. Open the Key Info rollout and expand the Head
bar. On the Key Info rollout, click Set Key.

The Target Blend field becomes available.
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3. Click the Select Look At Target arrow, below
the Target Blend spinner, then click the table
tennis ball in the viewport.

The name pingpongball appears in the field.

4. Change Target Blend to 1.

The biped is now looking at the ball.

The biped looks at the ball automatically.

5. Play the animation.

The biped watches the bouncing ball intently.

The biped’s head follows the movement of the ball.

Make the biped look around:

In this procedure, you make the biped look around
as the ball bounces in place.

1. Move the time slider to frame 200.

At frame 200, the period begins where the ball
bounces in place.

2. On the Key Info rollout, click Set Key and set
the Target Blend to 0.

3. Move to frame 199. On the Key Info rollout,
click Set Key and set the Target Blend to 1.

Between frames 0 and 199, the Target Blend
parameter is set to 1; at frame 200, it changes
to 0. Setting these keys this way is a way to
control interpolation. You could also change
the interpolation for the key at frame 200 to
a step value coming in, and then not bother
setting the other key.

4. Move the time slider to frame 210. Rotate the
head so it’s looking away from the bouncing
ball.

5. Add more rotation keys to the biped’s head
until frame 300.
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Rotate the biped head freely when Target Blend is zero.

6. Play the animation.

The biped looks at the ball bouncing over the
net, but then switches focus to something else.

Note: You can’t select multiple objects within
a single animation. If you need to do that, try
using a List Controller with several LookAt
constraints, then animate the weights of the
list items.

7. Save your work as mylookat_tabletennis.max,
or open lookat_tabletennis_final.max for
comparison.

Using In Place Mode

When you’re animating a character that’s moving
through space, it’s hard to evaluate the motion
when the character moves out of your view. You
can use In Place mode to keep the viewport
centered on the moving character.

Use In Place mode:

1. Open In_place_start.max.

2. Play the animation.

This is an animation of a biped running. You
can see the entire animation, but you’re too far
away to really see what’s going on.

3. At frame 0, select the entire biped with a
selection rectangle.

4. Choose Zoom Extents Selected from the
flyout.

The viewport zooms to frame the biped, and
you can see the pose clearly.

5. Open the Motion panel.
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6. In the Biped rollout, click the plus to
expand the expansion bar. In the Modes group,
turn on In Place mode.

7. Play the animation in the Perspective viewport.

8. While the animation is playing, click Arc Rotate
in the viewport navigation controls.

This puts you into Arc Rotate mode. You can
now rotate the viewport while the animation
plays.

9. Rotate the viewport around while the biped is
running, so you can see the animation from all
sides.

Since you are using In Place mode, the biped
remains in view and never leaves the frame.

Tip: If you click In Place mode and the biped
disappears, navigate the viewport to the center
of the home grid. In Place mode plays the biped
animation at this location.

You can use In Place mode when you need to
view and adjust the animation of a biped that
moves beyond the confines of the viewport.

In Place mode, doesn’t actually create an
“in place” animation, it is just a viewing
mechanism. To actually change the animation
so the biped really stays in the same space,
create a dummy object and link the COM to the
dummy. Then keyframe the dummy so that the
biped stays in the same place as the animation
progresses.

To see an example of this, open the file
in_place_dummy_final.max.

Mixing Animation
This tutorial shows you how to use the Motion
Mixer. The Motion Mixer can combine motion
clips (BIP files) in a variety of ways.
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In this tutorial, you will learn how to:

• Load motion clips into the Mixer.

• Separate motions to affect only certain parts
of the biped.

• Create transitions between clips in the Mixer.

• Change motion clip length or timing in the
Mixer.

• Combine multiple clips at once with weight
curves.

• Warp a clip’s time, so portions of it play slowly
while other parts play faster.

• Use the Motion Mixer to combine foot-based
motion.

• Export animation from the Mixer to the biped.

Skill level: Intermediate

Time to complete: 3 hours

You can find the files for this tutorial in the
tutorials\character_animation\motion_mixer
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

Setting Up Clips for the Motion
Mixer

In the next few lessons, you’ll work with a scene
involving a fiddle player. The biped will move
around as a musician does, moving the bow across
the strings, tapping his feet, and performing other
motions.

In preparation for these lessons, several motion
clips (BIP files) have been created:

• toetap.bip—Right foot taps to the beat, left leg
bounces slightly to the rhythm

• headshake.bip—Head shakes slowly as the
player feels the music

Three spine motions will be used. You will
create transitions between these motions to
keep the player’s upper body moving.

• spinebentright.bip—Spine bends to the right
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• spinebentleft.bip—Spine bends to the left

• spinesitup.bip—Spine straightens out to make
the biped sit up straight

Four arm motions will be used for the bowing
motion. The fiddler moves the bow up and
down to get the sound from the fiddle, and
also moves his right elbow up and down to
reach the various strings. The bow reaches the
high-pitched strings when the elbow is down,
and the low-pitched strings when the elbow
is up. Transitions between these motions will
cause the player to play the song.

• dnarmdnbow.bip—Right elbow down, bow
moves down (moving the bow hand away from
the fiddle)

• dnarmupbow.bip—Right elbow down, bow
moves up (moving the bow hand toward the
fiddle)

• uparmdnbow.bip—Right elbow up, bow moves
down

• uparmupbow.bip—Right elbow up, bow moves
up

These motions will be sufficient to keep the entire
biped moving throughout the animation.

Each BIP file was created by animating keyframes
manually in 3ds Max. Each motion is very simple,
using just a few keyframes. The motions range in
length from 20 to 90 frames.

Tip: You can create your own BIP files by
animating the biped with keyframes and clicking
Save File on the Biped rollout. The option for
saving a specific segment of animation is useful for
creating clips for the Mixer.

These motion clips will be used to animate a
short sequence and illustrate the Motion Mixer’s
features. However, the power of the Motion Mixer
is much more evident with longer sequences. With
all these clips already created, you could easily

set up a much longer animation with much less
work than it would take to animate it manually.
In addition, changes to the animation are much
easier to make in the Motion Mixer than with
individual keyframes.

Inspect a motion file:

The Motion Mixer allows you to load several
clips and create transitions between them. In
practice, some BIP files work better than others for
transitions. Before using the Motion Mixer, you’ll
load one of the motion files that will be used with
transitions to inspect its keys and motion.

1. On the Create panel, click Systems, and click
Biped. Drag in any viewport to create a biped.

2. Open the Motion panel.

3. In the Biped rollout, click Load File to
open the file dnarmdnbow.bip.

4. Select any part of the biped’s right arm or hand.

The arm has three keys.

5. Scrub the time slider through the first 30 frames
of the animation.

The arm doesn’t move a great deal during
the animation, but there is some motion
throughout.

If motions used with transitions were static
(no change throughout the motion), the biped
would stop cold after each transition was
complete. The resulting motion would look
machine-like rather than natural.

When preparing clips for transitions in the
Motion Mixer, make sure each one has some
degree of motion throughout the entire clip.
This will keep the biped from going unnaturally
still before and after transitions.

6. If you like, load each BIP file onto the biped to
see the motion contained in the clip.
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Prepare to animate:

As with all animation, some preparation is
required. This animation will be timed to music,
so some time spent listening for musical cues
will help you determine where to place specific
motions.

1. Copy the file fiddleshort.wav from the
tutorials\character_animation\motion_mixer
folder to the sounds folder in your
\3dsmax8 local installation. If you have
not copied this file to your hard disk, you
can find it on the Tutorial Files CD, in the
tutorials\character_animation\motion_mixer
folder.

2. Choose Graph Editors menu > Track View -
Dope Sheet.

3. At the top of the hierarchy display, click the plus
sign (+) next to Sound to expand the listing.

4. Highlight either Sound or Metronome.
Right-click the highlight and choose Properties
from the quad menu.

5. In the Sound Options dialog, click Choose
Sound.

6. Choose the file fiddleshort.wav from your
/3dsmax/sounds folder.

The waveform for the music appears in Track
View.

Music courtesy of Joyce Andersen, www.joyscream.com

7. Click Play Animation. A short clip of
fiddle music plays.

When listening to the music, you can hear seven
notes played on the fiddle. For each note, the
biped will make one stroke with the bow. This

will be accomplished by creating transitions
between the various BIP files that animate the
right arm.

8. Scrub the time slider and listen for the start
frame for each bow stroke.

Notes begin approximately on frames 0, 7, 17,
24, 34, 51, and 74. These will be the starting
frames for bow movement clips in the Mixer.

Tip: When setting up animation to be performed
to a soundtrack, note the start frames for clips
on a piece of paper before you begin using the
Motion Mixer. These notes will help you work
faster.

Combining Clips

This lesson will show you how to mix clips in the
Motion Mixer. You’ll animate a character playing a
fiddle by combining several prepared BIP files in
the Mixer.
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You can view the file fiddler_playing.avi to see
(and hear) the result of this lesson.

Several files from the CD are required for this
tutorial. See Mixing Animation (page 2–547) to
find out where to find the files.

The BIP files used in this lesson are described
in Setting Up Clips for the Motion Mixer (page
2–548).

Set up for this lesson:

1. Open the file fiddler_start.max.

2. On the main toolbar, click Curve Editor
(Open).

The Track View Curve Editor appears.

3. In the Track View controller window, click to
highlight the Sound track, then right-click and
choose Properties.

The Sound Options dialog appears.

4. On the Sound Options dialog, Choose
Sound. On the Open Sound dialog, highlight
fiddleshort.wav, and then click Open. Click OK
to close the Sound Options dialog.

Note: The files fiddler_start.max and
fiddleshort.wav are in the same folder,
\tutorials\character_animation\motion_mixer\
.

If you now expand the Sound track
and highlight the track Waveform –
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FiddleShort.wav, the sound waves appear in the
curve window.

You also can click Play Animation to hear
the music.

5. The fiddle is linked to a dummy object which
is linked to the biped’s left hand. A LookAt
controller makes the fiddle point to the biped’s
neck at all times.

The bow is linked to a dummy object, which
is in turn linked to the biped’s right hand. A
LookAt controller is used to force the bow to
point to a dummy object just above the fiddle,
where the strings would be.

To better understand how this setup works,
move the biped’s right hand. The bow stays on
the string area as long as the hand isn’t moved
too far away from the fiddle.

Open the Motion Mixer:

1. Select any part of the biped.

2. Open the Motion panel.

3. In the Biped Apps rollout, click Mixer.

The Motion Mixer window appears
with the biped automatically added to it, and
Mixer mode is turned on.

Tip: If you can’t see all the Motion Mixer toolbar
buttons, expand the window by dragging its
lower-right corner.

Two empty tracks for the biped appear in the
Mixer. The topmost track is a clip track, which
can hold clips to animate the biped. The lower
track is a balance track, used for controlling the
biped’s balance during foot-based animation.
Because the biped is sitting down in this
animation, you won’t need the balance track.

4. In the Motion Mixer toolbar, click
Preferences. On the Mixer Preferences dialog,
in the Other group, turn off Balance Curves
and click OK.

The balance track disappears from the Motion
Mixer window.
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Add trackgroups to the Mixer:

In the Motion Mixer, tracks are grouped according
to which body parts they affect. For example,
you’ll need different tracks for the head, spine,
right arm, and legs. Each set of tracks that will
affect a set of body parts is called a trackgroup. A
trackgroup can contain several individual tracks.

When you add a biped to the Motion Mixer, a
single trackgroup with one track is automatically
created. The first trackgroup is named All because,
by default, it affects all parts of the biped. You’ll
need a total of four trackgroups for this animation,
so you’ll need to add three more.

1. Click the trackgroup name All to select it.

2. On the Motion Mixer menu bar, choose
Trackgroup menu > Add Trackgroup Below.

3. Choose this menu option twice more to create a
total of four trackgroups.

Filter the first trackgroup:

The trackgroups in the Mixer will be used to hold
animation for the head, spine, right arm, and legs.
You’ll start by setting up the first trackgroup to
hold the head animation.

1. Select the first trackgroup by clicking the All
label.

2. Right-click the label and choose Filter from the
pop-up menu. The Trackgroup Filter dialog
appears.

This dialog contains a diagram of biped parts.
You’ll use the diagram to select the biped parts
that will be affected by the clips on the track.
This process is called filtering, because it filters
out the parts you don’t want and leaves the ones
you do. By default, all available biped parts are
selected.

3. On the Trackgroup Filter dialog, click None to
select none of the biped parts.

4. Click the Head box in the diagram to select the
head.

You can also use the Trackgroup Filter dialog
to change the trackgroup name displayed in
the Mixer.

5. At the bottom-left of the dialog, change the
trackgroup name to Head.
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6. Click OK to close the dialog.

The new trackgroup name, Head, appears at
the upper-left of the trackgroup in the Mixer.

Filter the remaining trackgroups:

1. Right-click the label All at the upper left of the
second trackgroup, and choose Filter from the
pop-up menu.

2. Change the trackgroup name to Spine, and
select only the Spine box in the diagram. Click
OK.

3. Use the same technique to change the name of
the third trackgroup name to Bow Arm, and
select the right arm and hand.

4. Change the fourth trackgroup’s name to
Legs, and select both legs, both feet, and the
Body Vertical track in the Trackgroup Filter
dialog.

The Body Vertical track will keep the fiddler
seated.

Tip: Here you have arranged the trackgroups so
they roughly follow the shape of the body, with
the head at the top and the legs at the bottom.
You can arrange the trackgroups in any way
you like, but this arrangement makes it easy to
locate a particular trackgroup when working
with the Mixer.

5. Save your work as my_fiddler_tracks.max.

Place the leg motion in the Mixer:

The motion file toetap.bip contains 32 frames of
animation with the right foot tapping and the left
leg bouncing slightly to the rhythm. You’ll open
this clip in the Legs trackgroup and repeat it to
make it last throughout the entire animation.

1. Right-click the Legs track and choose New
Clips > From Files from the pop-up menu.

2. In the Open dialog, choose the motion file
toetap.bip and click Open.

The motion clip appears on the track.

3. Scrub the time slider. The biped taps his right
foot twice to the music, but the animation stops
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before the music ends. The clip will need to be
repeated to the end of the animation. You could
clone the clip manually with the SHIFT key, but
there’s a quicker way to repeat the motion.

Tile the leg motion:

1. Click the clip to select it.

2. Right-click the clip and choose Tile Range from
the pop-up menu.

The Tile Range option tiles the clip as many
times as possible between its current time and
the end of the active time segment. In this case,
the active time segment is 100 frames long. The
clip has been repeated twice, reaching frame 96
at the end of the third clip.

3. Click Play Animation to see the animation.

The biped taps his foot all the way through to
frame 98.

Trim the last leg clip:

The music stops around frame 85, but the foot taps
one last time after that. You’ll need to trim the last
clip to keep the foot from tapping after the music
stops.

1. On the Motion Mixer toolbar, click Trim
Clips.

2. Drag the rightmost end of the last toetap clip
until the end frame is 85.

The start and end frame numbers appear at
each end of the clip, so you can see when

the clip has been trimmed to frame 85. The
trimmed area of the clip appears as a gray bar
on the track.

3. Turn off Trim Clips.

The gray bar that indicates the trimmed area is
no longer visible.

4. Play the animation. The biped’s foot stops
tapping at frame 85.

5. Save your work as my_fiddler_legs.max.

Place the spine motions on a transition track:

Two motions have been prepared for the biped’s
spine, one leaning to the left and the other to the
right. You will use a transition track to blend
between the two motions, causing the biped to
lean one way and the other as he plays the fiddle.

1. In the Motion Mixer, right-click the Spine track
and choose Convert To Transition Track from
the pop-up menu.

The track becomes larger, with room for two
rows of clips. If necessary, expand the height of
the Mixer by dragging on its lower edge.
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2. Right click the new transition track and choose
New Clips > From Files from the pop-up
menu. Choose the clips spinebentright.bip and
spinebentleft.bip. Click Open.

The clips appear on the track with a transition
area between them.

Note: Your clips might load in the order opposite
the order shown in the figure. This is fine;
you’re working for a random motion, so the
sequence of the clips doesn’t matter in this case.

3. Scrub the time slider. The biped makes a
transition from leaning one way to the other.

The transition is a bit sudden. To look more
natural, this transition should take place over a
much longer time.

Adjust the spine transition:

1. On the transition track, drag the top clip to the
left so it overlaps about half the bottom clip.

The transition now appears with hatching.
Hatching on a clip or transition indicates that it
is invalid. In this case, the transition has turned
“inside-out” and is no longer valid.
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In this case, you want the ends of the transition
to align with the ends of the clips. The Snap
Clips option will help you accomplish this.

2. In the Motion Mixer toolbar, turn on
Snap Clips.

3. Drag the left end of the transition to the right
until it aligns with the right edge of the bottom
clip.

This turns the transition right-side out, so it
appears as a solid color rather than hatched.

4. Drag the new left end of the transition to the left
until it aligns with the left edge of the top clip.

If you play the animation, you can see that the
transition is still a bit abrupt. You can make
it smoother by stretching out the clips to last
longer.

Stretch the spine clips:

When you drag the end of a clip, the motion is
scaled rather than trimmed, meaning the biped
will perform the same motion but over a shorter or
longer time. Compare with dragging the clip edge
with Trim Clips turned on, which cuts motion off
either end of the clip but keeps the same timing.

1. Make sure Trim Clips is turned off.

2. Drag the rightmost edge of the top clip so it
ends at frame 100.

The new clip scale appears on the clip. Before
the clip was stretched, the scale was 1.0. Now

the scale will display as 2.63 or a similar
number.

Note: If the scale doesn’t appear on the clip,
click Preferences on the Motion Mixer toolbar.
In the Clips group, turn on Scales and click OK.

3. Move the left edge of the top clip to the right so
the clip starts at frame 30.

4. Drag the right edge of the top clip to the right
so the clip ends at frame 80.

5. Adjust the transition so it spans from frames
30 to 80.

6. In the Motion Mixer toolbar, turn off
Snap Clips.

7. Play the animation. The transition between one
bending motion and another is smoother. The
shift from left to right coincides with a change
in the music, which is a natural motion for a
musician.

Open the first bowing clip:

Four BIP files contain the right arm motions used
in this animation. In Setting Up Clips for the
Motion Mixer (page 2–548), you played the music
and noted the frames where the bowing begins.
You will use these frame numbers to place the clips
and the transitions between them.

1. Right-click the Bow Arm track, and choose
Convert to Transition Track from the pop-up
menu.

Note: All options on this menu are also available
on the Tracks menu.
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2. On the Motion Mixer toolbar, click Zoom
Region and drag on the Bow Arm track area
from frames 0 to 35. This zooms into the frames
on the Motion Mixer.

3. Right-click the Bow Arm transition track, and
choose New Clips > From Files. Open the clip
uparmdnbow.bip.

The clip appears with hatch marks to indicate
that it doesn’t have any transitions yet. You’ll
give this clip a transition in a moment, but first
you’ll adjust its length.

4. On the Motion Mixer toolbar, click Move
Clips. This turns off Zoom Region and allows
you to work with the track and clips.

5. Drag the right end of the clip until it ends at
frame 15.

6. Move the leftmost transition bracket to frame 0.
This gives you some room to place the second
bracket.

Place the transition with brackets:

The brackets in the transition area indicate where
the default transition will be placed when another
clip is opened. You’re about to open the next clip
for this track, and from your planning, you know
that you want the transition between the first and
second clips to start at frame 2. You can make this
happen automatically by placing the transition
bracket near the end of the first clip at frame 2.

1. Make sure Snap Clips is turned off.

2. Move the rightmost transition bracket to frame
2. Watch the Frame number on the Motion
Mixer toolbar to determine when you’ve
reached frame 2.

3. Open the clip uparmupbow.bip.

The clip is placed to start at frame 2, and the
transition spans the overlapping area between
the two clips. The first clip turns a solid color,
indicating it’s now a valid clip with a transition.

You are going to scale the second clip in
the next few steps. Recall that on the spine
transition track, when you scaled a clip, the
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transition changed. The transition between the
two arm clips is currently the right length for
this sequence, so you don’t want it to change
when you scale the second clip. To keep the
transition the same length, you’ll turn on Lock
Transitions.

4. On the Motion Mixer toolbar, turn on
Lock Transitions.

5. Shorten the right end of uparmupbow until it
ends at frame 22.

The transition doesn’t change as you shorten
the clip.

Clone one of the arm clips:

The third clip in this sequence, uparmdnbow, is
the same as the first clip. Rather than open the clip
again, you can simply clone the existing clip.

1. Hold down the SHIFT key and drag the
uparmdnbow clip so the new clip starts at
frame 17.

Because of the locations of the transition
brackets, an invalid transition is created. The
transition is the right length, but the beginning
and end are reversed, turning it inside-out.

The left bracket in the middle of the transition is
going to make it difficult to turn the transition
inside out, so you’ll move it out of the way.

2. Move the bracket at the center of the transition
to frame 24.

3. Drag each end of the transition until the
transition turns right-side out and becomes
valid.

Open the remaining bow arm clips:

You can quickly place the remaining bow arm clips
with planned placement of transition brackets.

On the Motion Mixer toolbar, make sure
Lock Transitions is turned on.

1. On the Motion Mixer toolbar, click Zoom
Extents so you can see the entire active time
range.

2. In the Bow Arm track, open the clip
dnarmupbow.bip. Scale the clip to end at frame
49, and move the last transition bracket to
frame 34.
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3. Open the clip dnarmdnbow.bip. Scale the
end of the clip to frame 72, and move the last
transition bracket to frame 51.

4. Open the clip uparmupbow.bip. Scale the
end of the clip to frame 83, and move the last
transition bracket to frame 74.

5. Open the clip uparmdnbow.bip. Scale the end
of the clip to frame 95.

6. Scrub the time slider to see the motion.

Trim the last arm clip:

Recall that the bow motions always end with a
subtle motion of moving back toward the fiddle.
During the last clip, the fiddler completes the
stroke required to play the last note, then moves
the bow a little bit toward the fiddle. You want to
remove this motion to make the fiddler stop his
bow when the music stops, around frame 85.

If you simply shorten the clip to end at frame 85,
the fiddler will still perform this unnecessary
motion at the end. To get rid of the extra motion,
you’ll trim the clip.

1. Turn on Trim Clips, and trim the last clip
to end at frame 85.

2. Scrub the time slider to see the motion, and
make sure the bow stops moving across the
fiddle by the time the music stops. If necessary,
trim the clip further.

3. Turn off Trim Clips.

4. Save the scene as my_fiddler_arms.max.

Open the head clip:

The animation looks pretty good, but the biped’s
head looks stiff. He stares at the fiddle with
intense concentration, which isn’t appropriate for
a lighthearted fiddle piece. Next you’ll open a clip
that will make the biped move his head gently, as if
he’s enjoying the music he plays.

1. Right-click the head track, and open the file
headshake.bip.

2. Stretch the clip so it goes to the end of the
animation, at frame 100.

3. Scrub the time slider to see the motion. The
biped gently shakes his head as he fiddles.
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Test the timing:

1. Click Play Animation.

As the animation plays, you can see that the
motion timing is roughly correct, but the
motion sometimes seem to lag behind the
music. This happens because animation
playback in viewports often slows down when a
music file plays with it. You’ll need to create a
preview to accurately judge whether the timing
is right.

2. Activate the User viewport.

3. From the 3ds Max menu bar, choose Animation
> Make Preview. Create a preview of the User
viewport.

4. When the preview has finished, watch it a few
times and look for mistimed motions.

The tapping foot is a little late throughout the
animation. You can easily adjust this by sliding
all the Leg clips.

Adjust the foot motion:

1. On the Motion Mixer toolbar, click Slide
Clips.

When Slide Clips is clicked, moving one clip
will push all the others on the track. Sliding
clips is similar to selecting all the clips on a
track and moving them at the same time.

2. Click the last clip on the Legs track and slide it
to the left. As you slide, watch the left edge of
the first clip on the Legs track, and slide until
the first clip starts at frame –4.

3. Click Move Clips. This will prevent you
from accidentally sliding clips when you mean
to move or trim them.

4. Turn on Trim Clips, and trim the first clip
so it starts at frame 0.

5. Create another preview and check the motion
again. Make any changes as necessary.

6. Save your work in the file my_fiddler_
playing.max.

A final version of this scene can be found in the
file fiddler_complete.max. You can also see the
animation in the file fiddler_playing.avi.
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Editing Weight

In this lesson, you’ll learn to use the weight tools in
the Motion Mixer to create a complex animation
from just a few clips.

The weight curve on each track can be used to
transition between one track and another. Weight
curves give you the freedom to shift motion
between tracks without having to place or adjust
transitions.

Set up for this lesson:

1. Open the file weight_curves_start.max.

This file contains a fiddle player ready to play.

2. Select any part of the biped.

3. Open the Motion panel.

4. On the Biped Apps rollout, click Mixer to open
the Motion Mixer.

Several trackgroups have been created for the
fiddle player: Head, Spine, Bow Arm, and Legs.
You will edit the weight curves in the Spine
trackgroup to animate the biped.

The trackgroups have been filtered for each set
of body parts. To learn to filter trackgroups, see
Combining Clips (page 2–550).

Note: In this lesson, you’ll work with only the
spine to illustrate the use of weight curves. In
practice, you would add many more motions
to the Mixer to animate the biped. To learn to
make a more complete animation of the fiddle
player, see Combining Clips (page 2–550). You
can use the techniques in this lesson to augment
the animation in that lesson.

Add clips and transitions to the spine track:

1. In the Motion Mixer, right-click the Spine track
and choose Convert To Transition Track.

This gives you room for two rows of clips so you
can create transitions between them.

2. Right-click the track and choose New Clips >
From Files from the pop-up menu.

3. In the Open dialog, turn off Set lowest starting
foot height to Z=0.

This setting affects only foot-based animation.
Since you’re working with the spine only, you
don’t need it turned on.

4. Open the clips spinebendleft.bip and
spinebendright.bip.

The clips appear on the Spine transition track
in the Mixer.
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Note: The clips might appear in reverse order in
your Motion Mixer. The order of the clips is not
important in this lesson.

5. Select both clips in the Mixer by holding down
CTRL and clicking each one.

6. Hold down SHIFT and clone the clips to the
empty area on the right side of the track.

7. Adjust the clip lengths and transitions to make
smooth, gradual motion between clips, as
shown in the image below.

Tip: Adjust the clip lengths first, then turn
on Snap Clips to assist you in snapping the ends
of transitions to the ends of clips.

8. On the Biped rollout, turn on Mixer
Mode.

9. Play the animation.

The biped moves from side to side, and the
animation looks good for this short animation.
However, if you were animating this character
over a long sequence, the side-to-side motion
would be repetitive after a while.

You could fix this problem by making more
spine motions to use in the Mixer, but there’s
an easier way. Instead, you’ll randomize the
motion by using only one additional clip, and
editing a weight curve.

Add a second track to the spine trackgroup:

1. Right-click a blank area of the spine track,
and choose Add Layer Track Below from the
pop-up menu.

This adds a second track below the first. Both
tracks are part of the Spine trackgroup.

2. In the new track, open the clip spinesitup.bip.
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3. Stretch the new clip to end at frame 100.

4. Play the animation.

The animation hasn’t changed. Even though
you have two tracks for the spine, only the top
track is applied to the biped. This is because the
weight curve on the top track is set to 1.0 (the
default value).

When a trackgroup has more than one track,
the Motion Mixer evaluates the motion from
the top down. If the top track has a full weight
of 1.0, any subsequent tracks are not taken into
consideration.

You can make the Mixer use the motion from
the second track by reducing the weight of the
first track to a value lower than 1.0.

Adjust the first track ’s weight curve:

1. Click the Weight Mode button at the right
end of the transition track.

The red weight curve appears at the top of the
track.

Note: If you don’t see the curve, click
Preferences on the Motion Mixer toolbar and
turn on Weight Curves.

2. Move the cursor over the leftmost end of the
weight curve (near frame 0) until you see the

arrow cursor. Click near frame 0 to set a weight
node.

3. At the right end of the transition track, reduce
the weight spinner to approximately 0.5.

The weight curve moves to the center of the
transition track.

4. Play the animation.

The biped’s spine animation blends the upper
and lower tracks equally.

Refine the weight curve:

1. Create two additional weight nodes, one around
frame 50 and another at frame 100.

2. Move the cursor over the weight node at frame
50, and click to select it.
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3. Drag the weight node downward until the
weight spinner value reads 0.0.

4. Move the weight nodes at frames 0 and 100 to
the top of the track. Their weights should read
1.0 on the weight spinner.

Tip: If you have difficulty selecting and moving a
node, draw a selection region around the node
and change its value on the weight spinner.

5. Play the animation.

The animation varies to use the top track at
first, then gradually use the bottom track, then
use the top track again.

You could vary the weight curve in a variety of
ways to randomize the animation and make it
look more natural.

Note: Weighting works across tracks in the
same trackgroup, but not across different
trackgroups. If you want to use weight curves,
you should create only one trackgroup for each
set of body parts, and create two or more tracks
within that trackgroup.

6. Save your work in the file my_weight_
curves.max.

You can find a finished version of this lesson in
the file weight_curves_complete.max.

Adding Time Warps

In this lesson, you’ll use the time warp feature
in the Motion Mixer to create a “bullet-time”
animation, where the action slows down as the
camera continues to orbit the scene.

You’ll start with a motion clip of a biped slipping
and falling. When the biped flies into the air after
the slip, you’ll turn the action into slow motion.

Set up for this lesson:

1. Load the file time_warps_start.max.

This file contains a biped and a camera. The
camera moves on an arc around the biped.
There is no animation on the biped.

2. Select the biped and open the Motion
panel.
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3. On the Biped Apps rollout, click Mixer to open
the Motion Mixer.

Load the motion clip:

1. On the Motion Mixer toolbar, click Add
Bipeds and choose the biped Bip01.

2. Right-click the new track and choose New Clips
> From Files from the pop-up menu. Open the
clip banana.bip.

3. On the Biped rollout, click Mixer
Mode.

4. Play the animation.

The biped walks, slips, and falls.

Add a time warp:

1. In the Motion Mixer, stretch the clip to extend
to frame 120. This will give you some time to
slow down the motion when the biped flies into
the air.

2. Scrub the time slider. Watch the animation and
note the frames at which the biped begins to fly
in the air, and when he begins to land. These
are the frames you’ll use to start and end the
slow-motion action.

For this lesson, you’ll use frame 35 as the start
and frame 50 as the end of the slow-motion
action.

3. On the Motion Mixer, right-click the clip and
choose Add Time Warp from the pop-up menu.

A time warp has been added to the clip, but the
appearance of the clip does not change.

4. On the Motion Mixer toolbar, click
Editable Time Warps.

A series of dashed lines appear on the clip to
indicate that a time warp has been applied to it,
and the time warp can be edited.

Edit the time warp:

1. Move the cursor over the clip until the arrow
cursor appears. Click near frame 35 to set a
time warp bar, and click again at frame 50 to
set another.
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Each bar is actually split into a top and bottom.
The bottom bar sets the original time, while the
top sets the warped time.

2. Select and move the first bar’s bottom half to
frame 35. Watch the Frame value on the Motion
Mixer toolbar to see the frame number as you
move the bar.

3. Move the second bar’s bottom half to frame 50.

Next you’ll set the warped time.

4. Move the first bar’s top half to frame 20.

The dashed lines to the left of frame 20 become
shorter to indicate the motion during that time
will play faster. The longer dashed lines after
frame 20 indicate slower motion playback.

5. Move the second bar’s top half to frame 80.

By looking at the lengths of the dashed lines,
you can see that the motion slows down a great
deal in the middle of the animation.

6. Turn off Editable Time Warps.

7. Play the animation.

As the biped flies into the air, the motion slows
down as the camera moves around him, then
he crashes to the ground.

8. Save your work in the file my_time_warp.max.

You can see a finished version of this scene by
loading the file time_warps_complete.max.

Using the Motion Mixer with
Locomotion

In Combining Clips (page 2–550), you learned
how to place clips in the Motion Mixer and
combine them to make a new animation. But in
that lesson, the biped was sitting down the entire
time, so you didn’t have to concern yourself with
transitions between planted foot motions.

When you create a transition between foot-based
motions (motion clips with IK constraints on
the feet), you’ll often need to make adjustments
to ensure the biped’s feet don’t slide during the
transition. In addition, differences in upper and
lower body motion can result in unnatural weight
shifts, which you can adjust with Motion Mixer
tools.

Note: This lesson uses techniques from the lesson
Combining Clips (page 2–550). If you haven’t done
this lesson yet, please do so before continuing.

Set up for this lesson:

1. Reset 3ds Max.
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2. On the Create panel, click Systems, and click
Biped. Create a biped of any size.

3. Create a second biped about the same size next
to the first one.

Look at the motions:

Before working with motions in the Mixer, it’s a
good idea to load each clip individually on the
biped and watch the entire motion from start to
finish. This will help you work more effectively
with the clips in the Mixer.

1. Select any part of the first biped.

2. Open the Motion panel.

3. On the Biped rollout, click Load File to open
the file frantic.bip.

4. Select the second biped.

5. On the Biped rollout, click Load File to open
the file sneak.bip.

6. Scrub the time slider to view the animation.

One biped moves around frantically, while the
other carefully sneaks along.

In this lesson, you’ll create a smooth transition
between these two motions in the Mixer. To
make your work with the transition as quick
and easy as possible, you’ll study these two
motions to find good starting points for the
transition on each clip.

Find transition start frames:

Suppose you want the biped to move frantically
for about 100 frames, then begin to sneak away.
This means you should look for a good place to
begin the transition sometime after frame 100 on
the frantic motion.

1. Watch the frantic biped and scrub the time
slider to view the animation around frame 100.

At frame 106, the frantic biped has his right foot
planted and his left in the air. This is a good
place for the transition to begin for this clip,
providing you can find a similar configuration
in the sneaking motion.
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2. While watching the sneaking biped, scrub the
time slider between frames 0 and 30.

Around frame 25, the sneaking biped’s left foot
is in the air while his right is on the ground.
This is a good place for the transition to begin
for this clip.

Create the transition in the Mixer:

1. Reset 3ds Max.

2. Create a new biped.

3. Select any part of the biped and open the
Motion panel.

4. On the Biped Apps rollout, click Mixer to open
the Motion Mixer.

5. Right-click the topmost track and choose
Convert To Transition Track from the pop-up
menu.

6. Right-click the track and choose New Clips
> From Files from the menu. Open the clip
frantic.bip.

7. Use the same method to open the clip sneak.bip.

The two clips are loaded onto the track with a
transition between them.

Adjust the transition:

1. Drag the left edge of the transition so it begins
at frame 106.

2. Move the sneak.bip clip until it starts at frame
81.



570 Chapter 8: Biped

This will cause the transition on sneak.bip to
begin 25 frames into the clip, at frame 106.

3. Drag the right end of the transition so it ends
at frame 121. As you drag, watch the Frames
value on the Motion Mixer toolbar to see the
current frame number.

The transition is now set up to start at the
frames you chose in the previous procedure.
The transition is 15 frames long, extending
from frame 106 to 121.

4. On the Motion Mixer toolbar, click Zoom
Extents.

You can see on the Mixer that the animation
extends to frame 273.

5. On the 3ds Max status bar, click Time
Configuration. In the Animation group of the
dialog, set the animation’s Length to 275.

6. Play the animation.

The biped moves around frantically until frame
106, then transitions to the sneaking motion.

Inspect the transition:

1. Move the time slider to frame 106. This is the
frame where the transition begins.

2. In the Perspective viewport, zoom in on the
biped’s feet.

3. Scrub the time slider back and forth between
frames 106 and 121 to see the right-foot motion
during the transition.

You can see that the right foot slides slightly
during the transition.

4. In the Motion Mixer, right-click the transition
and choose Edit from the pop-up menu.

A transition editor appears. By default, the
Transition Focus is set to Auto (Right Foot).
The transition focus determines the focal point
around which the transition takes place. The
Mixer has detected that the right foot is planted
throughout this transition, and has set the
transition focus accordingly.

In addition, red and yellow stick figures appear
in viewports to show each clip’s motion at the
transition point. You can try changing the
transition focus to see the effect it has on the
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transition between the red and yellow stick
figures.

Tip: The stick figures appear only if the current
frame is during a transition, and only if the
transition editor is open. If you can’t see the
figures, try scrubbing the time slider by a few
frames.

5. Scrub through the transition while watching
the stick figures.

When the stick figures are displayed, it’s easier
to see where the sliding occurs.

6. Check the values on the transition editor to
ensure the Start Frame is set to 106 for the
source clip and 25 for the second clip. Also
check the transition Length to make sure it’s
15. Change these values if necessary.

Fix the transition with a mixdown:

A mixdown can eliminate sliding during
planted-foot transitions. A mixdown pins a
planted foot to its current location at the start
of the transition and releases it only when the
transition is complete.

You can leave the transition editor open while you
perform this procedure. The stick figures will help
you see the effect the mixdown has on the planted
foot.

1. On the Motion Mixer toolbar, click
Preferences.

The Mixer Preferences dialog appears.

2. In the Mixdown Options group, make sure
“Prompt for options at each Mixdown” is
turned on. Click OK to close the dialog.

3. Right-click the name of the biped at the
upper left of the Mixer, and choose Compute
Mixdown from the pop-up menu.

4. On the Mixdown Options dialog, turn on
Enforce IK Constraints, and click OK.

A new mixdown track appears in the Mixer.
The mixdown animation is now affecting the
biped, and the transition track has no effect.

5. Scrub the time slider between frames 106 and
121 to see the transition.
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The right foot no longer slides during the
transition because the mixdown has enforced
IK constraints to keep the foot in place. You can
see this clearly by watching the stick figures as
you scrub the time slider. The red and yellow
stick figures’ right feet are in the same place
over the transition period, rather than slightly
separated.

6. Save your work in the file my_mixdown.max.

A finished version of this scene can be found in
the file locomotion_mixdown.max.

Create a BIP file from the motion:

1. Right-click the biped’s name at the upper left of
the Motion Mixer window, and choose Copy
Mixdown To Biped.

2. On the Biped rollout, turn off Mixer Mode.

3. Scrub the time slider to view the animation.

The biped does the animation even though
Mixer mode is off. The animation from the
mixdown has been copied to the biped and can
now be saved as a BIP file.

4. On the Biped rollout, click Save File. Save the
motion with the file name scared.bip.

Replace the transition track with the new clip:

Next, you will combine the new BIP file with
another motion clip. The motion file you just
created will be used to animate the biped’s legs,
while the upper body will be affected by the
motion in the file dynamic_3.bip. You’ll need the
balance track for this part of the lesson.

1. In the Motion Mixer toolbar, click
Preferences. On the Mixer Preferences dialog,
in the Other group, turn on Balance Curves
and click OK.

2. Right-click a blank area of the transition track
and choose Delete from the pop-up menu.

The transition track is deleted.

3. Right-click the biped’s name at the upper left of
the Mixer and choose Delete Mixdown.

The mixdown track is deleted.

4. Right-click the biped’s name and choose Add
Trackgroup.

5. Do this again to create a second trackgroup.

6. Right-click the top track and choose the file
dynamic_3.bip.

7. Play the animation. The biped moves around
wildly.
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The upper body motion will be used for this
animation.

8. Right-click the bottom track and choose the
file scared.bip.

The motion in this file will be used on the lower
body.

Filter the motion:

Next you’ll filter the trackgroups so each affects
only part of the biped’s body. For details on this
procedure, see Combining Clips (page 2–550).

1. Right-click the top trackgroup name All, and
choose Filter from the pop-up menu.

The Trackgroup Filter dialog appears.

2. Click None, then click Arms. Click the Spine
and Head links to select them. Change the
trackgroup name to Upper Body and click OK.

3. Right-click the lower trackgroup name All and
choose Filter from the pop-up menu.

4. Click None, then click Center and Legs.
Click the Spine link to deselect it. Name the
trackgroup Lower Body and click OK.

Each trackgroup is now named and filtered to
affect only specific parts of the biped.

Tip: To see the entire trackgroup names in the
Mixer window, slide the bar that separates the
trackgroup names from the clips.

5. Scrub the time slider to see the animation.
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The biped swings his arms wildly as he creeps
along.

Make a comparison biped:

By default, the Mixer provides a degree of balance
compensation when the motion on the upper and
lower body differ. The easiest way to see the effects
of balance compensation is to load the same mix
onto another biped, set balance compensation
parameters differently for the two bipeds, and
observe the differences in their motion.

1. Right-click the biped’s name in the Mixer,
and choose Save Mix File from the pop-up
menu. Save the mix with the file name
my_locomotion.mix.

2. Create a new biped in the scene about the same
height as the first biped.

3. On the Motion Mixer toolbar, click Add Bipeds,
and add the new biped to the Mixer.

4. Right-click the new biped name, and choose
Load Mix File from the pop-up menu. Open
the file my_locomotion.mix.

After a few moments, the mix appears in the
Mixer under the new biped’s name.

5. If necessary, turn on Mixer Mode for
the second biped.

6. If the biped jumps to the same place as
the first biped, click Move All Mode in the
Biped rollout and move the selected biped to
one side to separate the two bipeds. Turn off
Move All Mode.

Compare balance compensation:

Next you will disable balance compensation by
working with the weight curve on the biped’s
balance track.

1. Click the Balance Weight Mode button at
the right end of the second biped’s balance
curve.
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The curve turns red to indicate it can be edited.

2. Click the left end of the curve to create a weight
node at that point.

3. Use the weight spinner to change the value of
the entire curve to 0.0.

The biped now has no balance compensation
between the upper and lower body. The
first biped still has full automatic balance
compensation.

4. Play the animation.

The difference in the way the two bipeds
move shows you how balance compensation
affects the animation. Balance compensation is
effective only when different motions are used
for the upper and lower body.

5. In the Mixer, increase the balance curve’s weight
back to 1.0 to restore balance compensation.

6. Turn off Balance Weight Mode.

Fine-tune the spine balance compensation:

You can also fine-tune the balance compensation
on the spine and pelvis with balance parameters.

1. Right-click the second biped’s name and
choose Balance Parameters.

The Balance Parameters dialog appears.

Lateral Ratio affects the direction of motion
in the hips, while Propagation affects the
curvature of the spine. These values are set
separately for each biped in the Motion Mixer.

2. Change Propagation to 1.0 and click OK to exit
the dialog.

3. Play the animation.

The Propagation value of 1.0 on the second
biped forces all the spine links except the
topmost one to use the spine rotation on the



576 Chapter 8: Biped

lower body motion clip to some degree. A
Propagation value of 0.0, as on the first biped,
prevents the COM and pelvis rotation from
affecting the spine rotation on the upper body
in any way.

4. Save your work in the file my_balance.max.

A version of this completed lesson can be found
in the file locomotion_balance.max.

Animating a Multi-legged
Character

Animating a Multilegged Creature

In this tutorial, you’ll use a biped to animate a
quadruped (four-legged creature). You’ll use IK
Blend on the hands and feet to create a freeform
animation with changing pivot points.

Beetle bucking like a bronco, with motion blur

In this tutorial, you’ll learn how to do the following:

• Animate a leaping quadruped with freeform
animation.

• Use IK Blends and pivot points on the hands
and feet.

• Use Bones to create extra limbs.

Skill level: Intermediate to Advanced

Time to complete: 1.5 to 2 hours

You can find the files for this tutorial in the
tutorials\character_animation\quadruped folder
on the Tutorial Files CD that ships with 3ds Max.
Before starting the tutorials, copy the \tutorials
folder from the CD to your \3dsmax8 local
installation.

View the Video for This Tutorial

The images in the illustrations above are from
a short video called “Lunchtime” that can be
found on the Tutorial Files CD that ships with
3ds Max. In this part of the animation, one
beetle hops on the back of the other, and rides
him like a bucking bronco. Choose File > View
Image File and browse the Tutorial and Sample
Files CD to find \tutorials\character_animation\
character_animation\bugsnfrij.mov. You’ll need
QuickTime® installed to play this movie.

In This Tutorial

Animating a Quadruped (page 2–576)

Adding Extra Limbs (page 2–600)

Animating a Quadruped

In this lesson, you’ll animate a four-legged
character, a beetle, that leaps on all fours, but
can also walk upright on two legs. You’ll lock the
hands and feet at certain keys so you can adjust
the biped’s center of mass and spine to create the
basic poses.

Note: If you’re not familiar with the concept of
locking hands and feet, do the lesson Animating
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a Freeform Walk Cycle (page 1–359) before
continuing.

Set up the lesson:

• Open cs4_tut_quad01.max.

This is the biped used for the beetle.

The beetle and its biped

The beetle walks upright through most of the
animation, but in this shot, he’ll move on all
fours. Because he’s a two-legged character
pretending to move like a horse, you won’t
change him to a horse pose in Figure mode.
Instead, you’ll use freeform animation to put
him into his initial riding pose at frame 0.

Save a FIG file:

1. Select any part of the biped, then open
the Motion panel.

2. Turn on Figure Mode.

3. Use Save File to save a FIG file of the biped as
mybeetle1.fig.

This preserves the beetle’s original pose.

4. Turn off Figure Mode.

The pose does not change, since the beetle isn’t
animated in this file.
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Rotate the legs to put the beetle on all fours:

1. Turn on Auto Key.

You’ll use Auto Key instead of Set Key for the
first pose.

2. On the Track Selection rollout, turn on
Body Rotation.

This selects the center of mass (COM) and
activates Rotate.

3. Watch the Left viewport, and rotate the center
of mass approximately 80 degrees, so the biped
is nearly horizontal.

The COM (Bip01) rotated

The next steps rotate the arms and legs into
position.

4. In the Left viewport, draw a small selection box
through the middle of the thighs.

This selects both thighs in a single move.

5. Rotate the thighs approximately 120 degrees
about the Z-axis.

Watch the Z Coordinate Display in the status
bar.

6. Press PAGE DOWN to move down the IK
chains.

This selects the calves.

7. Rotate the calves so they are nearly horizontal,
and the feet are behind the biped (about –125
degrees around the Z-axis).
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Next, you’ll add a couple of rotations to the
arms.

Rotate the arms to put the beetle on all fours:

1. In the Top viewport, select Bip01 R
Clavicle. Then, in the Track Selection rollout,
click the Symmetrical button to select Bip01
L Clavicle.

Both clavicles are selected.

2. In the Top viewport, rotate the clavicles
about the Y-axis, approximately 40 degrees.

Note: Do not use the Body Rotation button in
the Track Selection rollout, because that button
turns on Rotate and also selects Bip01.

3. Press PAGE DOWN to select both upper arms.

4. Rotate the arms approximately –90
degrees about the X-axis, so the palms are
parallel to the ground.

5. Rotate the arms approximately 90
degrees about the Z-axis, so the arms stretch
out in front of the biped.

6. Rotate the arms about the Y-axis until they
hang down.
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Left viewport view of arms rotated down

7. In the Front viewport, rotate the arms
approximately 20 degrees about the Z-axis so
they move away from the body a bit more.

Arms moved away from the body

8. Press PAGE DOWN twice to select the hands.

9. In the Left viewport, rotate the hands about the
Z-axis so they are parallel to the ground (about
90 degrees).

10.Rotate the head up, so the biped is looking
straight ahead instead of downward.

Head rotated up

11.Rotate the toes so they are flat on the ground.
If necessary, rotate the feet, then the toes, so
the feet and toes point forward. Watch the
Perspective viewport as you rotate.

Make any additional adjustments to the legs,
arms, spine, and so on, until your model
resembles the one illustrated in the four views
that follow.

Tip: Look at the beetle from several views, and
rotate around it in the Perspective viewport to
help when making the arm and leg rotations.
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Four views of the beetle’s final pose on all fours

If the beetle’s posture is incorrect, open
cs4_tut_quad02.max to compare.

Change Dynamic Blend and Balance Factor:

For a beetle traveling on all fours, or before
you begin any freeform animation, you need to
turn off Balance Factor and Dynamics Blend.
These settings add secondary motion to footstep
animation, which assumes the biped is walking
upright.

1. Open cs4_tut_quad02.max.
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2. Select any part of the biped, and open
the Motion panel.

3. In the Track Selection rollout, turn on the
Body Horizontal button.

This automatically selects the center of mass,
and activates Move.

4. On the Key Info rollout, expand the Body bar.
Change the Balance Factor from 0 to 1.

In the Left viewport, the center of mass jumps
from the pelvis to the area under the chest.

5. Change the Balance Factor to 2.

The center of mass jumps to the area under the
throat.

Balance Factor=2.0

6. Change the Balance Factor back to 0. (In this
file, the Balance Factor was already set to 0.)

This ensures that the hips and spine balance
around the pelvis area.

Balance Factor=0

7. In the Track Selection rollout, turn on
Body Vertical.

8. Set Dynamics Blend to 0.
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Tip: You can also access Balance Factor and
Dynamic Blend from track bar keys for Body
Horizontal and Body Vertical. To do this,
right-click the key and choose Controller
Properties > Horizontal or Vertical. You’ll
find Balance Factor at the bottom of the Body
Horizontal key dialog, and Dynamics Blend at
the bottom of the Body Vertical dialog.

For another tutorial that teaches about Balance
Factor, see Creating the Illusion of Weight (page
2–534).

Add a ground plane:

In the lesson Animating a Freeform Walk Cycle
(page 1–359), you set keys that locked the feet
to the ground. Those keys locked the feet to the
world, rather than to an object.

In this lesson, you’ll create a box, and then lock
the beetle’s feet to the object, instead of locking
them to the world.

1. In the Top viewport, zoom out so the
biped is smaller.

2. In the Create panel, choose Box.

3. Create a box beneath the beetle. In the Top
viewport, start at the top left and drag down

to the lower right. After you click, continue to
drag down to create a negative height for the
box.

Change the size of the box to 500 units in
length, 150 units in width, and –10 in height.

4. Move the box so the biped is at the top
end of the box.

Biped at the end of the box

At this point, don’t worry about the biped
floating above the box. You’ll remedy that next.

5. In the Left viewport, select any part of the
biped.

6. On the Motion panel, in the Track
Selection rollout, turn on Body Vertical.

7. Press ALT+W to maximize the Left viewport.

8. Move the biped down so its hands and feet
are in contact with the box. Zoom in to see
the effect. Adjust the bipeds hands and feet if
they’re uneven.
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Biped positioned on box

9. Save the scene as MyQuad01.max.

Lock down the hands and feet:

1. Open cs4_tut_quad03.max.

This file is like the one you’ve been working on,
but the feet have been rotated so the heels are
flat on the ground.

2. Turn on Auto Key.

3. Change the Perspective viewport to
Wireframe. Zoom in so you can see the hands
and feet.

4. Press the H key and select Bip01 R Foot.

5. In the Key Info rollout, click Set Key.

The pivot point is on the ball of the foot. You
can leave it there.

6. In the Key Info rollout, expand the IK bar.
Click the Select IK Object arrow button, and
then click the box in the viewport.

The name Box01 is displayed in the field next to
the arrow button.

7. In the Key Info rollout, click Set Sliding
Key.

8. In the Track Selection rollout, click the
Opposite button.

The Bip01 L Foot is selected.

9. In the Key Info rollout, click Set Key.

This sets a key for the left foot.

10. Click the Select IK Object arrow, and click
the box again.

11. Click Set Sliding Key again.

The feet are now locked to the box.
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Warning: You must set the Object Space Object

before you set an IK Key. Otherwise, the IK key

parameters will be reset to IK Blend of zero and Body

Space on. Also note that you can define only one

Object Space Object. You cannot keyframe from one

Object Space Object to another.

12.Repeat the steps you used to lock the feet with
the left and right hands.

The hands and feet act the same. Both are
locked and do not pass through the box.

13. Turn off Auto Key.

14. Check the finished result. In the Track
Selection rollout, click Body Vertical, and move
the center of mass up and down.

The knees and elbows bend with the movement.
The feet and hands don’t go through the box as
the biped is moved down.

Knees and elbows bend without going through the box.

Add anticipation:

Before a character jumps, you need to prepare for
the jump. To show anticipation, a character moves
in the opposite direction from the jump, and holds
the pose, as if to tell the audience that something
is about to happen.

1. Turn on Auto Key. Move the time
slider to frame 10.

2. In the Track Selection rollout, click Body
Rotation.

3. In the Left viewport, rotate the center of mass
so the chin is almost touching the ground
(about 20 degrees around the Y-axis).
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4. Click Body Horizontal. Move the center
of mass back so the elbows lower almost to the
ground.

5. Select the head. Rotate the head so it’s
looking up.

6. Add extra rotations to the Spine objects so the
spine arches.

7. Raise the center of mass if the elbows pass
through the box.

Pose at frame 10

8. Move the time slider back and forth between
frames 0 to 10, and observe the motion.

9. Save your work as MyQuad02.max.

Continue the motion:

You’ll continue the motion at frame 20. You’ll
adjust the timing after you get all the poses in place.

1. Move the time slider to frame 20.

2. In the Track Selection rollout, click Body
Vertical.

3. Lower the center of mass so the beetle crouches
down.

Don’t worry about the elbows moving through
the box. You’ll fix that in the next few steps.

4. Press the H key and select the four biped spine
elements (Bip01 Spine through Bip01 Spine03).
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5. Rotate the spine links about 15 degrees
around the Z-axis.

6. Continue individually rotating each spine link
until they match the following illustration.

Pose at frame 20

7. Save the scene as MyQuad03.max.

Next, you’ll animate the pivot points and rotate
the feet so they roll from the heel to the toe. You’ll
rotate the hands so they rock from wrist to palm to
fingertips.

Rotate the feet to prepare to leap:

1. With Auto Key still on, move the time slider to
frame 23.

2. Select Bip01 R Foot.

The foot is selected, and the pivot (large red
dot) is displayed at the ball of the foot.

3. In the Key Info rollout, click Set Sliding
Key.

4. Rotate the foot, so the heel is raised
(about 25 degrees around the Z-axis.

5. Go to frame 0.

6. In the Key Info rollout, expand the IK
bar. Set Ankle Tension to 1, and then click Set
Planted Key.



588 Chapter 8: Biped

7. Go to frame 27.

8. Click Set Planted Key again.

9. In the IK expansion bar, click Select Pivot, and
then select the pivot at the front and center of
the toes. You may have to zoom in to see it.

Selecting the pivot automatically sets a key for
it. You don’t have to choose Set Planted Key
again.

10.Turn off Select Pivot.

11.Move the time slider to frame 30 and rotate the
foot.

The foot now rotates off the toe.

12. In the Track Selection rollout, click the
Opposite button. Repeat the previous steps for
the left foot.

Rotate the hands to prepare to leap:

1. Move the time slider to frame 23.

2. Select Bip01 R Hand, and click Set Planted
Key.

The right hand is selected, and the pivot is
displayed and locked at frame 23.

3. Rotate the hand approximately 40
degrees about the Z-axis so the heel of the palm
is raised.

Unlike the toes. the fingers rotate downward.
You’ll have to rotate the fingers to correct this.

4. Press H and select Bip01 R Finger1, then rotate
it upward about 45 degrees on the Z-axis, so it
doesn’t go through the surface of the box.

Since Auto Key is still on, you don’t have to set
keys for the fingers after you rotate them.

5. Press PAGE UP to select the right hand
again. Move the time slider to frame 27, and
click Set Sliding Key.

6. Turn on Select Pivot.
Select the pivot in the front and center of the
fingers.
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7. Turn off Select Pivot.

8. Rotate the hand approximately 40
degrees about the Z-axis.

The hand rolls up, with only the fingertips
touching the ground.

Tip: If the hand doesn’t rotate around the new
pivot, reassign Box01 as Object Space Object
and rotate again. Then it will work properly.

9. In the Track Selection rollout, click the
Opposite button. Repeat the previous steps for
the left hand.

Move the body to prepare to leap:

After both feet and hands are adjusted, the body
needs to be moved in preparation for the leap.

1. Move the time slider to frame 30.

2. In the Track Selection rollout, click Body
Vertical.

3. Move the biped up.

4. In the Track Selection rollout, click Body
Horizontal.

5. Move the biped forward.
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6. Continue using Body Vertical and Body
Horizontal until your biped matches the
following illustration.

Pushing-off pose

7. Save your work as MyQuad04.max.

Position the legs for flight:

When the beetle sails through the air, you’ll use
free keys on the hands and feet. No IK Blend is
needed.

1. Make sure Auto Key is turned on. Move the
time slider to frame 40.

2. With Move or Rotate active in the
Main toolbar, select a hand or foot.

3. From the Key Info rollout, click Set Free
Key. Repeat these steps to set a free key for each
remaining foot and hand.

If you open the IK expansion bar, you’ll see
that the IK Blend is set to 0 at frame 40 for the
extremities.

4. In the Left viewport, use Body
Horizontal and Body Vertical to move the
center of mass up and to the right.

The hands and feet are now off the box and the
biped is in the air.

5. Select Bip01 R Foot, and move it so the legs
extend fully.

6. Click the Opposite button. and extend the
left leg in the same way.

The knees are no longer bent.
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7. With the left foot still selected, click the
Symmetrical button to select both feet, then
rotate them downward and backward.

8. Press PAGE DOWN to select the toes and rotate
them as well.

The legs and feet are fully extended.

Position the arms and torso for flight:

Now that the legs are positioned, you’ll work on
the arms.

1. Select both of the hands, and rotate them
downward and backward.

2. Press H and select Bip01 R Finger1 and
Bip01 L Finger1. Rotate them down and back.

3. Select and rotate Bip01 Spine (the first spine
object) so the biped straightens up.

4. This step removes the swayback appearance.
Rotate each spine link individually. Go up
through the spine, rotating each link, then
rotate the first spine link again, if necessary.

5. Rotate the head so the beetle looks ahead.

Final pose of the biped springing into the air

6. Save the scene as MyQuad05.max.

Pose the upper body to reach the apex:

The character is airborne. As he reaches the apex
of his jump, you’ll rotate the spine to hunch him
over, tuck his elbows back, and bend his knees.

1. Make sure Auto Key is on. Move the time slider
to frame 56.

2. Open the Motion panel if it’s not already
open.

3. In the Track Selection rollout, use
Body Horizontal and Body Vertical to move the
biped up and over to the height of his jump.
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Zoom out in the Left viewport so you can see
the entire box. This will let you gauge how high
the biped should go so it has room to land.

Center of mass moved to apex of the jump

4. Select Bip01 Spine and rotate it so the
biped bends forward.

5. Continue selecting and rotating the spine links
so the back forms an arch.

6. Rotate the head forward so the biped
looks like he’s spotting where he will land.

You might also want to rotate the neck links
to create a more fluid bend between the spine
and head.

7. Select the right upper arm, Bip01 R
UpperArm. Click the Symmetrical button so
both upper arms are selected.

8. Rotate the arms back so they are closer
to the biped’s chest (approximately 40 degrees
about the Z-axis).

9. Press PAGE DOWN to select both biped lower
arms. Rotate them forward so the fingers
are near the biped’s chin (about 150 degrees
around the Z-axis).

10.Save the scene as MyQuad06.max.

Pose the lower body to reach the apex:

Now that the upper body is set, continue to the
lower body.

1. Select the right calf, Bip01 R Calf. Click
the Symmetrical button so both calves are
selected.
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2. Rotate the calves so the feet kick back.

3. If you like, press PAGE DOWN to move the
selection through the feet and toes; rotate them
so they tuck under the tail a little.

Final pose of the biped at its maximum height

4. Save the scene as MyQuad07.max.

Note: When doing character animation, you can
never save too often.

Pose the upper body for the descent:

You’ll continue by choreographing the biped’s
descent to the ground.

1. Make sure Auto Key is still on. Move the time
slider to frame 72.

2. In the Track Selection rollout, use
Body Horizontal and Body Vertical to move the
biped down and further to the right.

3. Click Body Rotation. Rotate the biped
downward until the biped‘s shoulders are
pointing at the ground.

4. Select only Bip01 Spine2 and rotate about
the Z-axis until the biped’s back straightens.

5. Select both hands and move them so they are
outstretched and ready to break the fall.

You can position the limbs using forward
rotations, or with inverse kinematics moves (as
you just did with the hands).
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Arms extended to touch the ground

Pose the lower body for the descent:

In preparation for landing, the legs should curl
down to meet the ground after the hands make
initial contact.

1. Select Bip01 R Thigh. Then click the
Symmetrical button so both thighs are selected.

2. Rotate the thighs approximately 90
degrees about the Z-axis.

3. Press PAGE DOWN to select the two calves of
the biped.

4. Rotate the calves in toward the thighs
(about –25 degrees around the Z-axis).

5. Press PAGE DOWN again to select the biped’s
feet.

6. Rotate the feet in toward the calves
(about –115 degrees around the Z-axis).
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7. If you want to fine tune the character,
rotate the toes, tail, neck, and head to match
the illustration.

8. Save the scene as MyQuad08.max.

Create the landing pose:

The beetle will land at frame 75. You’ll lock down
the hands and adjust the center of mass.

1. Continue from the previous procedure. Move
the time slider to frame 75. Once again, make
sure Auto Key is on.

2. In the Track Selection rollout, use
Body Horizontal and Body Vertical to move the
center of mass so the hands move through the
box.

3. Select the right hand, and click the
Symmetrical button so both hands are selected.

4. Rotate the hands forward so the hands
are visible and flat against the ground.
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5. Select the right hand, and set a sliding key
from the Key Info rollout.

Now you can set a key to lock the pivot.

6. Open the IK expansion bar, click Select Pivot,
and then click the pivot (the large red dot) at
the wrist.

Tip: You might want to Region Zoom around
the hands in the Top viewport for selecting the
pivot.

7. Click the Opposite button to select
the left hand, and set another sliding key.

8. Click Select Pivot again, and click the pivot for
the left wrist.

Now both hands are locked to the ground at
frame 75.

9. Select both feet. Move them outward
and up so the legs extend behind and above
the biped.

10. Rotate the feet so the toes point skyward.

The biped prepares for impact; the landing pose
completed.

11.Move the time slider back and forth and watch
the motion.

You’ve created a little kick with the legs.

12.Save the scene as MyQuad09.max.

Adjust the arms to create the landing:

Next you’ll bend the arms so the impact is
absorbed as the beetle lands.

1. Continue from the previous lesson. Move the
time slider to frame 83.

2. In the Left viewport, move the center of mass
down and right so the elbows are close to the
ground.

The hands are locked to the box and the elbows
should bend in response to the movement.
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3. Move left hand slightly behind the right hand.

This makes it look like the hands are hitting the
ground independently.

The hands don’t land together

4. Rotate the left hand up so it’s parallel to
the ground.

Adjust the legs to create the landing:

1. Select both thighs. Rotate them so the
legs are under the biped.

2. Press PAGE DOWN to select both calves, then
rotate them so the feet prepare to contact the
ground.

3. Press PAGE DOWN and rotate the feet so the
balls contact the ground.
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4. Press PAGE DOWN and rotate both toes until
they are nearly horizontal.

5. Select the right foot and move it back and
slightly up.

When an animal lands, its feet don’t hit the
ground at the same time.

6. Rotate Bip01 Spine1 to raise the elbows and
upper body slightly.

Hitting-the-ground pose

7. In the Front viewport, select both calves and
rotate them about 45 degrees around the X-axis.

8. Select each foot and move it in to match the
illustration.
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9. Select both feet. Move the time slider to frame
80.

10. Move the feet so the beetle compresses
as he lands.

The feet should be tucked under the tail.

Create the last pose:

1. Move the time slider to frame 86.

2. Select the right hand, and click Set Planted
Key.

3. Click the Opposite button. Click Set
Planted Key for the left hand.

4. Select the left foot, and set a planted key.

The left foot is already on the ground.

5. Click the Select Pivot button, and set the pivot
to the ball of the foot.

6. In the Track Selection rollout, use Body
Vertical to move the biped so the right foot
touches the ground.

7. Select the right foot, and set a planted key.

8. Click the Select Pivot button, and set the pivot
to the ball of the foot.

9. Make minor adjustments to the legs, spine,
neck, and head to match the illustration.
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Last pose

10.Save your work to MyQuad10.max.

Adjust the timing:

The take off and landing is too slow. Use the keys
in the track bar to improve the timing.

1. Continue from the previous lesson, and select
the entire biped.

The keys displayed in the track bar are the keys
for the entire animation.

There is too much time between frames 30 and
40.

2. Turn off Auto Key. Select the keys from 72
through 100 by dragging a selection rectangle
around them in the track bar.

3. Slide the selected keys so the key that was at
frame 72 is now at frame 60.

Note the readout on the status bar showing you
information about how the frames are being
shifted.

4. Now select the keys from frame 40 through the
end of the animation.

5. Slide these keys so the key that was at frame 40
is now around frame 33.

6. Move the time slider back and forth.

The take off and landing is much quicker.

7. Save your work as MyQuad11.max.

Adding Extra Limbs

In this lesson, you’ll add bones as appendages to
the biped, creating a pair of wings, and learn to
animate them.

Note that the extra limbs become 3ds Max objects,
and must be animated with rotations. They will
not respond to Biped Figure mode or inverse
kinematics.

Set up the lesson:

1. Reset 3ds Max.

2. Open cs4_tut_wallystart.max.
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This file shows Wally in See-Through mode. He
has wings, but no means of moving them. You’ll
remedy that in the next few procedures.

Add the wing bones:

1. In the Left viewport, use Region Zoom to
focus on the area around the wings .

The view after zooming

2. Open the Create panel, and click
the Systems button.

3. In the Object Type rollout, turn
on Bones. In the Bone Parameters rollout >
Bone Objects group, set the Width and Height
values to 3.0.

In this case, the Width and Height defaults of
10.0 would produce clumsy-looking bones.

4. In the IK Chain Assignment rollout, make sure
Assign To Children is turned off before making
bones. Off is the default.
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5. Add a set of four bones along the leading edge
of the wing. See the following illustration.
Create the three long bones, so the last bone is
at the tip of the wing, then right-click to finish.
The fourth bone will appear as a little knob at
the end.

Bones along the leading edge of the wing

6. Turn on Rotate. In the Front viewport,
select Bone01 and rotate it about –35 degrees
around the Z-axis.

7. Working between the
Front and Left viewports, use Move, Rotate,
and Scale to adjust the bones so they match the
following illustrations.

8. Save the scene as MyWally01.max.

Mirror the bones:

Now that one wing is created, you’ll mirror the
wing and set the proper IK solution.
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1. In the Front viewport, drag a selection window
around the wing bones you just created.

2. On the Main toolbar, click the Mirror
Selected Objects button to display the Mirror
dialog.

3. In the Mirror dialog, in the Clone Selection
group, choose Copy. In the Mirror Axis group,
set Offset to –35.5 on the X-axis. Click OK.

This creates four matching bones on the other
side, named Bone05 through Bone08.

4. Select Bone01. This is the base bone on the
right wing.

5. From the Animation menu, choose IK Solvers
> HI Solver, and click the end bone, Bone04.

6. Select Bone05. This is the base bone on the left
wing.

7. Apply the HI Solver to this bone and click the
end bone on the left wing, Bone08.
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Both wings have IK solutions.

Note: It’s a good idea to test the bend by moving
the end effectors. It might be necessary to
adjust the Swivel Angle from the Motion panel
in the IK Solver Properties rollout.

8. Save the scene as MyWally02.max.

Add dummies to control the wings:

You’ll now add two dummy objects to act as
control handles for the wings.

1. Open the Create panel, and click
the Helpers button.

2. Click Dummy. In the Top viewport, drag to
create a small dummy object near the tip of the
right wing.

3. In the Front viewport, move the dummy
object up to the wing tip.

4. Hold down the SHIFT key and move a copy of
the dummy over to the tip of the left wing.

The dummies will be used as control handles
instead of the end effectors.

5. Select both dummy objects, Bone01,
and Bone08. On the Main toolbar, turn on
Select And Link, and then drag a link to Wally
Biped Spine2.
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If you move the biped, the wing bones and
dummies will move along with the rest of the
model.

Note: After linking, you may notice the bones
rotate out of alignment with the mesh. This is
fixed by adjusting the Swivel Angle.

6. Select IK Chain01 and link it to
Dummy01. Repeat this step by selecting IK
Chain02 and linking it to Dummy02.

7. Select IK Chain01 and open the Motion
panel.

8. In the IK Solver Properties rollout, enter –51 in
the Swivel Angle field.

9. Select IK Chain02 and set its Swivel Angle to
296.

10.Save the scene as MyWally03.max.

Animate the wings:

1. Move the time slider to frame 5, and
turn on Auto Key.

2. From the Front viewport, select
Dummy01. Move it down and to the right a
little.

3. Move the time slider to frame 10, and move
Dummy01 down and a little to the left.

4. On the time bar, select the key at frame 5. Hold
down the SHIFT key and drag a copy to frame
15. Repeat this step with the key at frame 0, and
drag it to frame 20.

5. Repeat the previous steps with Dummy02.

When you’re done, you’ve animated Wally
flapping his wings.

6. To see a finished product, open
cs4_tut_wallyfinal.max, or view wallyshow.avi.
It shows a version of Wally that flaps his wings
and lifts off.
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To summarize the design process: After building
the character model, a biped was added and
adjusted to fit properly. Next, extra bones to
control the wings were added. The Physique
modifier was applied to Wally, and envelopes were
adjusted to enclose the mesh. Finally, the character
was animated.

Working with Motion Flow
Motion Flow mode lets you combine clips (.bip
files) to create longer character animations. The
BIP files are joined using velocity-interpolated or
minimum foot sliding transitions for a seamless
transition between the source and destination clip.
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Skill level: Intermediate

Time to complete: 1.5 to 2 hours

Files For This Tutorial

You can find the files for this tutorial in the
tutorials\character_animation\motion_flow
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

Features Covered in This Tutorial

In this tutorial you will learn to:

• Combine two motion capture BIP files and
unify the result.

• Create a Shared Motion Flow so you can use
one motion flow graph to animate multiple
bipeds.

• Use Create Random Motion to create random
scripts for multiple bipeds, so you can animate
a crowd.

• Use Create Random Motion to create a random
script for one biped.

Set Up The Tutorial:

To do this tutorial, you need to add a line to your
biped.ini file so the .bip files can be found when
you load sample scenes.

Biped.ini is in the \plugcfg folder under your
main 3ds Max folder. Use a text editor to add the
following line to the biped.ini file.

MoFlowDir=<maxdir>\tutorials\motion_flow

Replace <maxdir> with the drive letter and folder
of your copy of 3ds Max. For example, if 3ds Max
is in your d:\3dsmax8 folder, the line would be:

MoFlowDir=d:\3dsmax8\tutorials\motion_
flow

After making this change, you need to restart
3ds Max so the change applies to the current
session.

Note: You can have multiple occurrences of the
MoFlowDir= line in the biped.ini file.

Adding Clips to the Motion Flow
Graph

In this tutorial, you’ll become familiar with the
Motion Flow Graph and how to add clips, .bip
files, that will control your bipeds.

Set up the lesson:

1. Before starting this tutorial, follow the
instructions in Using Motion Flow (page
2–606) for editing your biped.ini file. After
changing the file, exit and restart 3ds Max to
apply the change.

2. If you have already changed your biped.ini file,
reset 3ds Max. You do not need to exit the
program.

Create a biped:

1. On the Create panel, click Systems.

2. On the Object Type rollout, click Biped.

The Biped button turns gold.

3. In the Perspective Viewport, click and drag up,
starting at approximately 0,0,0.

A biped appears in the viewports.



608 Chapter 8: Biped

Default biped

4. Right-click in the viewport to turn off the Biped
button.

Add clips to the Motion Flow graph:

1. Select any part of the biped and open
the Motion panel.

A biped must be selected for Biped controls to
display on the Motion panel.

2. On the Biped rollout, turn on Motion
Flow Mode.

The Motion Flow rollout displays.

3. On the Motion Flow rollout, click Show
Graph.

Motion Flow Graph

4. On the Motion Flow Graph toolbar, click
Create Multiple Clips.

The Open dialog displays so you can specify the
location of your motion files.

5. Hold down the CTRL key and click both
axekick.bip and backkick.bip.

6. Click Open.

The two motion files appear in the Motion Flow
Graph window.

7. Save the scene as MyMoFlow01.max.

Creating and Using Motion Flow
Scripts

The Motion Flow Graph stores .bip files, referred
to as clips. To create a script, you select clips that
you have added to the Motion Flow Graph.
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Set up the lesson:

1. Continue from the previous lesson or load
cs4_tut_moflow01.max.

Tutorial files are in the tutorials\character_
animation\motion_flow folder.

2. If using the tutorial file, select any part
of the biped and open the Motion panel.

3. Click Show Graph to make sure the
Motion Flow Graph is displayed.

Create a script:

1. On the Motion Flow rollout, in the Scripts
group, click Define Script.

2. On the Motion Flow Graph, click the Axekick
icon first, and then the Backkick icon.

The clip names appear in the list in the Scripts
group. The name script1 displays in the text
field above the list. In the Motion Flow Graph,
a red transition line joins the two clips, showing
that they are included in the current script. By
default, Biped uses “Minimum Motion Loss”
to find a likely starting frame for the transition
between the source and destination clips. You
have created a script called script1.

3. Close the Motion Flow Graph window
and click Play.

Use Arc Rotate Selected to rotate the Perspective
view for a better look at the motion.

As the animation plays, a three-star icon next
to the clip names (in the Scripts list) changes to
show which clip is playing. The numbers on the
left are the frame numbers where the animation
starts.

The default Minimum Motion Loss search
method did not choose ideal starting frames in
this case: the biped spins unnaturally during
the transition. You’ll first edit the transition
manually, then you’ll try an optimized
transition, which uses minimum foot sliding.

Use the Transition Editor:

When you edit transitions manually, you can
discard unwanted motion and adjust the duration
of transitions. You can also change the direction of
the destination clip in the Transition Editor.

1. Click Axekick in the Scripts list.

Controls in the Scripts group are activated.

2. Click Edit Transition.

The Transition Editor dialog displays; the
source and destination clip names appear in
the title of the dialog. Position the dialog so the
Perspective Viewport is visible.
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3. Click Go To Start Frame near the upper
right of the Transition Editor.

The time slider is positioned at the first frame
of the transition. By default, the duration of the
transition is 25 frames. This is displayed in the
Length field on the upper left of the Transition
Editor.

Red and yellow stick figures (called ghosts) in
the viewports help to establish a starting frame
for both clips. Both stick figures display during
the period of transition. Red represents the
destination clip motion. The biped interpolates
between the yellow and red ghosts over the
course of the transition.

4. In the dialog, set Angle to -50.

The destination ghost changes orientation.

5. In the Destination Clip group, set the Start
Frame to 0.

You can choose the destination starting frame
by viewing all of the clip’s motion.

6. Drag the time slider back and forth over the
transition.

In order to create a smooth transition, you’ll
look for areas in the source and destination
clips where foot and body movements will
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flow together cleanly. Frame 80, where the
character’s right foot is in the air, looks like a
reasonable starting frame for the source clip.
Body weight is in the process of shifting to the
right foot.

7. In the Source Clip group, set the Start Frame
to 80.

8. Move the Frame spinner in the Destination
Clip Ghost group and watch the red stick figure
representing the destination clip. At frame 20,
the character is starting to push backward with
its right foot. The character’s weight will be on
the right foot in both clips if this frame is used
as the Destination Start Frame.

9. Click Set Start Frame in the Destination
Clip Ghost group. The Frame value (20) is
copied to the Destination Set Start Frame field;
Biped recalculates and positions the destination
clip.

10.Set Length to 6 frames.

11.Play the animation.

The weight shifts to the right foot in both clips
during the transition. The transition looks
natural. Next you’ll try an optimized transition.

Tip: You can open the Extras toolbar, turn on
the Keyboard Shortcut Override Toggle and
press ALT+R to change the Active Time to the
animation length.

12. In the Transition Editor dialog, click
Optimize Transition.

The Transition Optimization dialog displays.

13.On the Transition Optimization dialog, turn on
Search Near Existing Transition. Click OK.

14.Play the animation.

The transition calculated by the automatic
optimization also looks good. Optimized
transitions are a time saver if there are many
clips and transitions that need to be processed.

Tip: You can select multiple transitions in the
Motion Flow Graph window and use Optimize
Selected Transitions in the Motion Flow
Graph toolbar to optimize all the transitions
at once. Optimized transitions can take time
to compute, but the results are worth the extra
processing time.

Make the animation available outside of Motion
Flow mode:

To make the animation available in your scene
outside Motion Flow mode, use the Create Unified
Motion command.

1. Click OK to close the Transition Editor dialog.

2. Click the Define Script button on the
Motion Flow rollout, in the Scripts group, to
turn off scripting mode.

3. On the Motion Flow rollout, in the Scripts
group, click Create Unified Motion.

The Unify Options dialog is displayed.
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4. Click OK to accept the default settings on the
Unify Options dialog.

5. On the Biped rollout, turn off the Motion Flow
Mode button.

The motion is available as a freeform animation
in your scene.

Open cs4_tut_moflow02.max to see the animation.
Note that a unified motion does not contain
footsteps.

Looping Animation in Motion Flow
Mode

By creating a script that repeatedly calls the same
motion clip, you can create a loop cycle that
lengthens the motion. This is a good way to
lengthen a walk or run cycle. You will use layers to
change the looped animation.

Set up the lesson:

1. Reset 3ds Max.

2. In the Perspective viewport, create a biped
starting at approximately 0,0,0.

3. Open the Motion panel.

4. Turn on Motion Flow Mode.

5. On the Motion Flow rollout, click Show
Graph.

The Motion Flow Graph displays.

6. On the Motion Flow Graph toolbar, click
Create Multiple Clips.

The Open dialog displays.

7. Open walk2loop.bip.

The motion clip appears in the Motion Flow
Graph window.

8. On the Motion Flow Graph toolbar, click
Create All Transitions. A Biped dialog asks if
you want to create transitions from each clip
to itself. Click Yes.

A transition is created pointing back at the
selected clip.

Note: When using Create All Transitions with
multiple clips, you must first select all the clips
for which you want transitions created.

9. On the Motion Flow Graph toolbar, turn
on Select Clip/Transition, if necessary.

10.Select the transition arrow in the Motion Flow
Graph window.

The arrow turns white.

11. On the Motion Flow Graph toolbar, click
Optimize Selected Transitions.

The Transition Optimization dialog displays.

12.If not already set, select Search Entire Clip and
click OK.

Create a script:

1. On the Motion Flow rollout, in the Scripts
group, turn on Define Script.

2. On the Motion Flow Graph dialog, click the
walk2loop clip five times.

You’ve created a script that calls for the clip to
transition to itself four times.

3. Click Play Animation.

The clip loops, extending the walk cycle.
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Walking biped with trajectory turned on.

Make the motion available in your scene outside of
Motion Flow mode:

1. Click the Define Script button on the
Motion Flow rollout, in the Scripts group, to
turn off scripting mode.

2. On the Motion Flow rollout, in the Scripts
group, click Create Unified Motion. Then, in
the Unify Options dialog, click OK to accept
the defaults.

3. On the Biped rollout, turn off Motion
Flow mode.

The walk cycle is available for editing outside
of Motion Flow mode.

Add a layer and modify the walk cycle:

1. On the Layers rollout, click Create Layer.

A new layer is created.

2. Turn on Auto Key.

3. At frame 0, in the Front viewport, rotate
both upper arms about the Y-axis to move the
arms away from the body.

4. Click Play.

The walk loop now has the character swinging
his arms farther from his body. The red stick
figure represents the original motion.

5. On the Layers rollout, click Collapse.

The layer showing the arms away from the body
is collapsed into the base animation.

6. Turn off Auto Key and click Play Animation
to watch the animation. You can also open
cs4_tut_moflow03.max to see the finished
animation.

Looping animations and layers lets you lengthen
and modify animations.

• To reduce keys and create footsteps, save the
BIP file, and then use Load Motion Capture File
in the Motion Capture rollout to reload the file.

• To reduce keys and extract footsteps, use
options in the Motion Capture Conversion
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Parameters dialog. The Convert command
on the Biped rollout will not extract footsteps
because the feet have no IK Constraints applied.

Using a Shared Motion Flow

By including multiple bipeds in a shared motion
flow, you can animate multiple bipeds using only
one motion flow graph. The Create Random
Motion command randomly picks clips to create a
unique script for each biped. Use this to create a
crowd that is loitering or cheering, for example.

Set up the lesson:

1. Reset 3ds Max.

2. In the Front viewport, create a biped at the far
left side that is about 150 units in height.

3. In the Create Biped rollout, turn on Drag
Position.

4. In the Front viewport, to the right of the
original biped, click to create five more bipeds
that are somewhat evenly spaced.

A total of six bipeds standing shoulder to shoulder

Create a shared motion flow:

1. Open the Motion panel.

2. If not already selected, select the biped
at the far right of the Front viewport and turn
on Motion Flow Mode.

Selecting any part of the biped will enable biped
controls in the Motion panel.

3. On the Motion Flow rollout, click Shared
Motion Flow.

The Shared Motion Flow dialog is displayed.
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4. On the Shared Motion Flow dialog, click New.

A new shared motion flow is created. A default
name appears in the Shared Motion Flows list.

5. On the Shared Motion Flow dialog, in the
Parameters group, click Add.

The Select dialog is displayed.

6. Click the All button at the lower left of the Select
dialog, then click Select.

The biped names are displayed in the Shared
Motion Flow dialog.

Note: You may receive a Biped warning
indicating that the scale of the legs of all the
biped must match. If you see this, click OK to
close the warning. Then, on the Shared Motion
Flow dialog, click Reset Wrong Scales: Just
Legs. (If you choose to Reset Wrong Scales:
Entire Figure, all the bipeds will occupy the
same space as the first biped. You don’t want
that.)

7. On the Shared Motion Flows dialog, click OK.

The Shared Motion Flow icon on the Motion
Flow rollout now has a white circle around it.
This means that the selected biped is part of a
shared motion flow.

Create a shared motion flow script:

1. On the Motion Flow rollout, click Show
Graph.

The Motion Flow Graph is displayed. The word
*Shared* appears in the graph name. This
Motion Flow Graph will be shared by the six
bipeds.
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2. On the Motion Flow Graph toolbar, click
Create Multiple Clips.

3. From the tutorials\character_animation\
motion_flow folder, add hatsoff.bip, laugh.bip,
shocked.bip, sneeze.bip, and wave.bip. Hold
down the CTRL key and click each file name to
add it to the selection. Click Open

The selected clips are added to the Motion Flow Graph.

4. On the Motion Flow Graph toolbar, click
Select Random Start Clip and drag a selection
window around all the clips.

The clips all turn purple and show a Random
Start Probability of 100, meaning that each clip
has an equal chance of being chosen first.

Tip: If you wanted all the bipeds to start their
movement using the same clip, you would
reduce the Random Start Probability values of
all but the clip you want all the bipeds to use
first. Right-click a clip to display its parameters
dialog.

5. Click the Select Clip/Transition
button, and turn off the Show Random
Percentages button. Then drag a selection
window around all the clips in the Motion Flow
Graph.

6. On the Motion Flow Graph toolbar, click
Create All Transitions. You are asked if you
want to create transitions from each selected
clip to itself. Click Yes.

Transitions appear between all the clips.

7. On the Motion Flow rollout, in the Scripts
group, click Create Random Motion.

The Create Random Motion dialog is displayed.

8. On the Create Random Motion dialog, set
Random Start Range from 0 to 30.
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Each biped has a random script based on the
clips in the Motion Flow Graph. If two bipeds
share a clip, the clip’s start frame is picked
randomly. This prevents identical motion.

9. On the Create Random Motion dialog, turn
on “Create motion for all bipeds sharing this
motion flow”, and then click Create.

The Unify Options dialog appears. It will
appear for each biped you’re creating a motion
for.

10.Click OK to accept the default settings on the
Unify Options dialog each time it pops up.

11.An alert asks if you want to put all the bipeds
into Motion Flow mode. Click Yes.

The bipeds appear with footsteps, ready to
begin their random motion routine.

Play and save the animation:

1. Activate the Perspective viewport. Use Arc
Rotate, Pan, and Field-of-View so you can see
all the bipeds.

2. Click Play Animation.

Each biped moves to its own script that is
compiled from the assortment of clips you
added to the Motion Flow Graph.

3. Save the scene as MyMoFlow02.max.

Creating Random Motion

This lesson illustrates how to use the Create
Random Motion feature with clips in the Motion
Flow Graph to create interesting scenarios quickly.
It uses an available set of .bip motion files.

You’ll add four figure-skating motions to
the Motion Flow Graph, create a network of
transitions, and generate a random script to
animate the biped.

Set up the lesson:

1. Reset 3ds Max.

2. In the Perspective viewport, create a biped
starting at approximately 0,0,0.

Add clips to the Motion Flow Graph:

1. Open the Motion panel.

2. On the Biped rollout, turn on Motion
Flow Mode.

3. On the Motion Flow rollout, click Show
Graph.

The Motion Flow Graph displays.

4. On the Motion Flow Graph toolbar, click
Create Multiple Clips.

5. From the tutorials\character_animation\
motion_flow folder, hold down CTRL
and select the following four motion files:
skateup.bip, skatestart.bip, skateloop.bip, and
skatespin.bip. Click Open.

The motion files load into the Motion Flow
Graph.

Arrange the clips:

1. On the Motion Flow Graph toolbar, turn
on Move Clip.
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2. Arrange the clips in a column with skateup
at the bottom, then skatestart, skateloop, and
skatespin.

Set and optimize transitions:

1. On the Motion Flow Graph toolbar, turn
on Create Transition From->To.

2. In the Motion Flow Graph window, click
and drag from one clip to the next to create
transitions between the clips. Start with skateup
and drag to skatestart, then skateloop and
finally skatespin.

Use the illustration as a guide to create the
transitions. To create a loop, click a clip twice.

3. Turn on Select Clip/Transition and
region-select all the clips. Then, on the Motion
Flow Graph toolbar, click Optimize Selected
Transitions.

The Transition Optimization dialog is
displayed.

4. Make sure Search Entire Clip is active and click
OK.

5. On the Motion Flow Graph toolbar, turn
on Show Random Percentages.
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A percentage number displays next to each
transition.

You’ll alter the percentages for the loop
transition and the transition between skateloop
and skatespin.

6. In the Motion Flow Graph window, right-click
the loop transition arrow on the skateloop clip
(not the box representing the clip).

The Transition Editor dialog displays, with the
name of the transition in the title bar.

7. On the upper left of the Transition Editor
dialog, enter 85 in the Probability field. Click
OK.

The random percentage next to the transition
arrow is updated.

8. In the Motion Flow Graph window, right-click
the transition from skateloop to skatespin. On
the Transition Editor dialog, enter 15 in the
Probability field. Click OK.

When a random script is generated, skateloop
will be chosen over skatespin 85 percent of
the time. The percentage numbers in the
Motion Flow Graph are normalized, so if two
transitions from a clip are set at 100, each one
has a even chance of being selected.

9. On the Motion Flow Graph toolbar,
turn on Select Random Start Clips, and click
skateup.

The skateup clip turns purple. It will always
be the first clip to play when a random script
is created.
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10.Close the Motion Flow Graph window.

11. On the Motion Flow rollout, in the Scripts
group, click Create Random Motion.

The Create Random Motion dialog is displayed.

12.In the Minimum Animation Length field, enter
2000 and click Create. On the Unify Options
dialog, click OK to accept the defaults.

A random script is generated.

Note: If the biped’s start position looks like it is
floating above the grid, set the Start Position
Z value to 0 on the Motion Flow rollout. This
will position the entire animation back on the
ground plane.

13.Click Play Animation to view the results.

The skater gets up off the ice and begins skating.
Once the script reaches the skateloop clip it
loops back to skateloop 85 percent of the time
and skatespin 15 percent of the time.

14. To get a bird’s eye view of the entire
motion, press H and select the biped center of
mass (Bip01). Open the expansion bar on the
Biped rollout. In the Display group, turn on
Trajectories, then restart the animation.

The trajectory of the scripted motion, as seen in the Top
viewport
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Note: Keep in mind that, since you’re using
Create Random Motion, your motion will not
necessarily look like the one above.

15.Save the scene as MyMoFlow03.max.

Summary

Upon completion of this tutorial, you’re now able
to assign motion clips to a biped and adjust the
transition between a clips or set up a looping
operation for a clip. You also know how to create
a random script for one biped or multiple bipeds.
Finally, you created a random script that always
start with a specific clip and some of the random
clips have a greater chance of being used than
others.

Motion Capture Data
Motion capture is the practice of getting motion
data from live actors performing various actions.
The motion data is captured (retrieved) via
sensors placed at the actors’ joints and extremities.

3ds Max does not perform motion capture,
but it accepts motion-capture data in the most
commonly used formats.

Three types of motion-capture data are included
with 3ds Max 8:

• In the tutorials\character_animation\motion_
capture directory, raw motion-capture files
have keys at every frame and do not contain
footsteps.

• In the tutorials\character_animation\footstep_
animation directory, the raw data has been
converted: it has footsteps and has been filtered
for key reduction.

• In the tutorials\character_animation\freeform_
animation directory, the raw data has been
filtered for key reduction, but it contains no
footsteps. It is freeform animation.

In this tutorial, you’ll do the following:

• Import motion-capture data.

• Filter and edit the data.

• Import prop data.

Skill level: Beginner

Time to complete: 1 hour

You can find the files for this tutorial in the
tutorials\character_animation\motion_capture
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

Importing Motion-Capture Data

You can import a file either in its raw state with
keys at every frame, or with key reduction filtering.
You can also edit raw motion-capture data by
moving footsteps in Footstep mode and adding
layers to keyframe the upper body. In this lesson,
you’ll import a raw motion-capture file and edit
footsteps.

Edit a raw motion-capture file:

1. Create a biped.

2. On the Motion panel, in the Motion
Capture rollout, click Load Motion Capture
File.

3. Open fashion1.csm.
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If this file does not appear in the Open dialog,
be sure the Files Of Type drop-down list is set
to .csm.

4. On the Motion Capture Conversion Parameters
dialog, choose On for Footstep Extraction and
choose No Key Reduction for Conversion.
Click OK.

The file loads with keys at every frame.

5. On the Biped rollout, turn on
Footstep Mode.

6. In the Front or Left viewport, select footsteps 2
and 3, and move them up .

7. Click Play Animation.

The biped with keys at every frame adapts
smoothly to the edited footsteps.

8. In the Top viewport, select footsteps 7 through
21.

9. On the Footstep Operations rollout, set Bend to
a negative value.

The footstep path bends out. The biped adapts
naturally to the footsteps.

10. Turn off Footstep Mode.

11.Drag the time slider to frame 250.

12. On the Biped rollout, open the expansion
bar. In the Modes group, turn on Bend Links
Mode.

13.Turn on the Auto Key button to begin
animation.

14. In the Layers rollout, click Create Layer.

15.Rotate the spine so the character stands up
straight, rather than leaning back during the
walk.

16.Click Play Animation to view the changes.

The character walks more upright.

17.In the Layers rollout, click Collapse.

This collapses the spine editing down to the
original animation, and will take some time.

Filter the data for key reduction:

1. On the Motion Capture rollout, click
Convert From Buffer.

2. On the Motion Capture Conversion Parameters
dialog, choose On for Footstep Extraction and
choose Use Key Reduction for Conversion.
Click OK.
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The raw data in the motion-capture buffer is
filtered with key reduction.

The motion-capture buffer contains the raw
data buffered when the file was first read
in. This data is used to either try new filter
settings quickly, or to paste a pose from the raw
information in the buffer onto a biped with
filtered data. If you plan on major editing of
motion-capture data, then key reduction is the
way to go.

Compare the raw and filtered data:

1. On the Motion Capture rollout, click
Show Buffer.

2. In the Biped rollout, open the
expansion bar. In the Display group, switch
from Objects to Bones on the flyout.

3. Click Play Animation.

The raw data represented by the red stick figure
closely matches the filtered data represented by
the other stick figure.

This motion does not contain any high
frequency data (fast motion), so it’s not
necessary to correct the filtered motion. Later
in the tutorial, you’ll filter a file with high
frequency information and add correction.

4. Save your work as MyMotionCapture01.max.

You’ll use this file as the start of the next lesson.

Comparing Trajectories

In this lesson, you’ll learn to use trajectories to
visualize and manipulate motion capture data.

Set up this lesson:

• Open the file MyMotionCapture01.max.

This file was saved at the end of the last lesson.

Display and compare trajectories:

1. Select any part of the biped.

2. On the Motion Capture rollout, click
Show Buffer Trajectory.

3. In the Biped rollout, open the expansion
bar. In the Display group, click Trajectories.

4. In the Display group, click Preferences.

The Display Preferences dialog appears.

5. In the Trajectories group, turn on Bone Base.
Click OK to close the dialog.

6. Select various parts of the biped to compare
filtered and raw trajectories for each biped
body part.
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7. On the Display group, click Preferences again.
On the Display Preferences dialog, turn off
Show Entire Trajectory. Click OK.

Now the trajectories display only 50 frames
before and after the current frame. Notice
that the trajectories between the buffered and
filtered data are very close.

8. On your hard disk, create your own directory
for data that you filter. You can save this
animation as a .bip file, using Save File on the
Biped rollout.

Tip: The default filter settings work well in many
cases, but information may be lost in motion
capture files that contain a lot of high-frequency
motion. There are a number of ways to work with
such files.

One is to filter the file normally, as you did in this
lesson, and then paste the missing information
using Paste From Buffer on the Motion Capture
rollout.

You can also change Tolerance and Key Spacing
parameters for less key reduction. Alternatively,
you can import a motion capture file with no key
reduction , and add a layer on the Layers rollout.
This is an easy way to make changes to a file that
contains keys at every frame.

Use Calibration Controls

Motion Capture calibration controls (the bottom
row of buttons on the Motion Capture rollout) are
active only if a raw motion capture file is imported
with no key reduction. They are used primarily to
calibrate marker (CSM) files, although they work
with all raw motion capture data.

Marker files represent raw marker position data
directly from a motion capture device, and
typically require more work than the BVH or BIP
motion capture files that ship with 3ds Max.

Use Marker Files

You can manage biped size and limb position
relative to the markers with the two main
calibration functions on the Motion Capture
rollout: Talent Figure Mode and Adjust Talent
Pose. The size and limb offsets are saved as FIG
and CAL files, respectively. These files, as well as a
marker name (MNM) file, can be loaded prior to
importing a motion capture file to apply the size
and limb offsets to marker files requiring the same
adjustment.

Using High-Frequency Data and
Looping

With high-frequency motion, such as sprinting,
you can lose the nuances of the motion if you use
the default filter settings. In this lesson, you will
minimize key reduction on the legs of a sprinter so
the legs follow the raw motion data more closely.
You’ll also learn to loop a motion file in the Motion
Capture Parameters dialog.

Set up for this lesson:

• Reset 3ds Max.

Load a CSM file:

1. In the Front viewport, create a biped.

2. On the Motion panel, in the Motion
Capture rollout, click Load Motion Capture
File. Choose .csm as the file type.

3. Open jez.sprint.csm.

The Motion Capture Conversion Parameters
dialog is displayed.

4. Choose On for Footstep Extraction, and Use
Key Reduction for Conversion. Click OK.

The clip loads but has no footsteps.
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5. In the Biped rollout, open the expansion
bar. In the Display group, switch from Objects
to Bones on the flyout.

6. In the Motion Capture rollout, turn on
Show Buffer.

The red stick figure represents the raw motion
capture data. The other stick figure represents
the filtered data. Note that you can’t use In
Place mode with Show Buffer.

Compare the data:

1. Use ALT+W to maximize the Left viewport.

2. Click Play Animation.

The filtered data lags behind the raw data in the
feet, making the sprint look more like a fast
shuffle. However, this is hard to see because of
fast playback and the key bracketing.

3. Right-click the Play Animation button. In the
Time Configuration dialog, in the Playback
group, turn on Real Time and 1/4x Speed to
slow down the motion. Turn off key bracketing
by choosing Customize > Preferences >
Animation > Key Bracket Display group >
None.

4. In the Motion Capture rollout, click
Convert From Buffer.

The motion capture buffer contains raw motion
capture data. You’ll enter parameters to correct
the lagging and to extract footsteps.

In the Motion Capture Conversion Parameters
dialog, choose On for Footstep Extraction and
Use Key Reduction for Conversion.

5. In the Footstep Extraction group, set Extraction
Tolerance to 1.23.

6. In the Key Reduction Settings group, change
the Minimum Key Spacing for both legs to 1.
Click OK.

The filtered legs match the raw legs during
the sprint. The legs have a key at almost
every frame, but the rest of the biped has key
reduction.

Loop a motion capture file:

1. In the Motion Capture rollout, click Load
Motion Capture File. Choose .csm as the file
type.

2. Open jez.sprint.csm.

The Motion Capture Conversion Parameters
dialog is displayed. All the settings on
this dialog should be the ones you entered
previously.

3. In the Load Frames group, turn on Loop and
enter 1 in the Loop field. Click OK.



626 Chapter 8: Biped

The sprinting motion is looped, creating a
longer sprinting period. You can also loop a
motion in the Motion Flow Graph with similar
results.

Importing Prop Data

If your motion capture file includes prop data,
3ds Max can read that data and apply it to a prop
object.

When you load a CSM file (character studio
marker file), the motion data is applied to the prop.
If the prop switches from one hand to another, the
program automatically determines the switch of
the prop’s coordinate spaces as the prop is moved
from one hand to the other.

Tip: The automatic behavior can be changed once
the data is in the scene. Go to the desired frame,
choose a new coordinate space, then set a key.

When loading a BIP file for retargeting onto other
characters, the props move with each of the hands.
The software ensures that the hands come together
at a precise position on the prop during transfers.

Bipeds with multiple props as swords

Load a CSM file:

1. Create a biped with a single prop.

The biped appears with a single prop displayed
as a box positioned near the biped’s right hand.

2. Open the Motion panel. In the Motion
Capture rollout, click Load Motion Capture
File.

3. Choose the file type .csm. Search for files in the
tutorials\character_animation\motion_capture
directory.

Tip: When loaded for the first time, .csm marker
files should be imported with no key reduction
and no footstep extraction. This enables the
calibration buttons in the Motion Capture
rollout. Marker files typically need some
calibration.

4. Select the prop01.csm file, and click Open.

The Motion Capture Conversion Parameters
dialog displays.

5. Select the default filter options. If Footstep
Extraction is turned on, footsteps will appear.
Click OK.

The biped adapts itself to the motion data.

Note: Props can be animated with 3ds Max
controllers, and that animation can then be
collapsed onto the prop’s transform controller for
editing with motion flow or the Motion Mixer.

Editing with Layers

In this lesson, you’ll import a file and use layers
to add changes. The motion file is a sprinting
motion. You’ll add a layer and rotate the center of
mass so the character is running on a wall.

Set up for this lesson:

• Reset 3ds Max.

Load the motion:

1. Create a biped.
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2. Open the Motion panel. In the Motion
Capture rollout, click Load Motion Capture
File.

3. Open jez.sprint.csm.

4. On the Motion Capture Conversion Parameters
dialog, the defaults include no footstep
extraction and no key reduction. Click OK to
accept the defaults.

The motion file loads with keys at every frame.

5. Click Play to see the running motion.

Add a layer:

The following steps illustrate the use of Snap Set
key to alter the runner’s original position.

1. On the Layers rollout, click Create Layer.

A layer is created.

2. Move the time slider to frame 8, where the
character’s left foot is just touching down.

3. Turn on Auto Key to begin animation.

4. In the Track Selection rollout, click Body
Rotation.

This selects the center of mass rotation track.

5. In a viewport, click and drag to rotate the center
of mass 90 degrees about the X-axis.

6. Click Play Animation.

The character is running on an invisible wall.

7. Move the time slider to frame 0.

8. In the Layers rollout, click Snap Set Key.

The character snaps to his original position.

9. Move the time slider to frame 16.

The right foot is just touching down.

10. On the Layers rollout, click Snap Set Key.

The character snaps to his original position.

11.Click Play Animation to view the result.

The character runs on the ground, then on the
wall, and back to the ground again.

To improve the effect, you can rotate the spine
objects and stretch the legs to make it appear
that the character is jumping on the wall.

Workbench
This tutorial shows you how to use the Workbench
to do key removal and add SubAnim controllers
to the biped tracks. You will also learn how to
identify motion errors and correct them using
workbench fixers and filters.
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The Workbench

In this tutorial, you will learn how to:

• Use Workbench filters to reduce keys and affect
rotations.

• Apply controllers to multiple biped objects
using the Workbench controller list.

• Analyze and fix errors using the Workbench.

Skill level: Intermediate

Time to complete: 1+ hours

You can find the files for this tutorial in the
tutorials\character_animation\workbench folder
on the Tutorial Files CD that ships with 3ds Max.
Before starting the tutorials, copy the \tutorials
folder from the CD to your \3dsmax8 local
installation.

Filtering Animation

The Workbench offers several different powerful
capabilities beyond what’s available in Track View
- Curve Editor. One of these is the ability to use
filters within the Workbench to make adjustments
to the animation. In this example, you’ll use filters
to reduce keys, and to smooth and boost rotation
tracks on a specified range of frames. You’ll adjust
multiple keys at the same time, making changes

that would be difficult to do if you worked with
individual keys.

Use the Key Reducer filter:

1. Open workbench_filters_start.max.

2. Play the animation.

The biped walks while shaking for several steps,
then waits without shaking until around frame
180, then walks off shaking again.

Biped walks, shaking, then pauses and looks around.

Biped walks shakily onward.
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3. In the viewport, select Bip01 Spine. This is the
first, or lowest, spine element.

4. Notice that the track bar is completely filled
with keys.

In this case, the keys are the result of the
procedural noise rotation which has been
applied as a SubAnim and then collapsed. The
period in which there is no shaking is the result
of the animation of the controller weights.

You’ll use the Key Reducer filter to remove the
keys during the period of no shaking.

5. In the Motion panel, on the Biped Apps rollout,
click the Workbench button.

The Workbench appears.

The rotation keys for the Bip01 Spine object
are displayed in the Curve View, and the object
name is highlighted on the Selection panel list.

6. Click Zoom Value Extents and
Zoom Horizontal Extents for a better view of
the curves.

The spikier curves indicate times when more
radical movement occurs, while the flatter part
of the curve indicates a time during which there
is little or no movement. During times of little
movement, a key on every frame isn’t required.
You will filter keys during this time to remove
the unnecessary keys. This time period spans
from frame 69 to 180.

Viewport with floating Workbench

7. Click the Filters panel at the upper left of the
Workbench window.

The other panels are used to analyze the
motion for errors, then selectively apply fixes to
those errors. In this case, it’s not necessary to
perform analysis and selective fixes, so you’ll
use the filters instead.

8. In the Time To Filter options, turn on From/To.
Set the From field to 69 and the To field to 180.

9. In the Filters drop-down list, choose Key
Reducer.

The Key Reducer has several parameters to
adjust the tolerance of the key reduction
process. In this case, the defaults will work just
fine.

10.Click the Filter button at the bottom of the
Filters panel to start the filtering process on the
specified time range.

Tip: If you don’t see the button, expand the
height of the workbench.

After a brief calculation, the keys are removed
in the track bar and curve view. The curve still
shows many keys before frame 69 and after 180,
but in between those frames, there are now no
extra keys.
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Keys removed

11.Play the animation. The animation appears
unchanged.

Next, you’ll use Rotation filters to adjust the
existing animation. You’ll lessen the shaking
at the period before the biped waits, and
exaggerate the shaking in the period when the
biped starts to walk again.

Adjust rotation keys:

1. Continue from the previous step.

2. From the Filters drop-down list, change the
filter to Rot Blurring.

Rot blurring is short for rotation blurring.
Rotation blurring smooths rotation keys
smooths severe changes between rotation keys.

3. In the Time To Filter options, change the From
field to 0 and the To field to 69.

4. Accept the default values for the Tolerance
parameters, then click the Filter button.

After a calculation period, the rotation curves
change.

Dotted lines indicate where curves have been blurred.

5. Play the animation in the viewport.

The biped shakes less than before.

Now you’ll use the Rotation Smoothing filter to
make more moderate changes to the selected
key range.

6. Change the filter to Rot Smoothing, and click
Filter again.

Curve after Rotation Smoothing filter applied

7. Play the animation.

The shaking has been significantly lessened in
the first 70 frames of the animation.

You can exaggerate the rotation in the last
70 frames of the animation by applying the
Rotation Boosting filter.
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8. In the Time To Filter options, change the From
field to 180 and the To field to250.

9. From the Filters drop-down list, choose Rot
Boosting. Rot Boosting is short for Rotation
Boosting. This increases the value of Rotation
keys to give more rotation.

10.Click the Filter button.

After a brief calculation period, the rotation
curves grow larger in the curve view, for the last
70 frames of the animation.

Curves before Rotation Boosting filter applied

Curves after Rotation Boosting filter applied

11.Play the animation and observe the effect.

The filters have made definite changes to
the animation. The changes were made to
periods that were filled with keyframes, which
would be difficult to adjust if you attempted to
manipulate the keys individually.

12.Save your file as my_shakybiped.max, or open
workbench_filters_final.max for comparison.

Adding Controllers to Multiple
Biped Objects

You can use the Workbench to apply instanced
controllers to multiple objects. In this animation,
a biped leaps from the ground and flies like a
superhero in the air. You’ll apply noise rotations
to the arms, legs, and spine to simulate the slight
movements as he soars in front of the camera.

Add controllers using the Workbench:

1. Open super_start.max.
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2. Play the animation. The biped leaps from the
ground and flies up into the air.

There is no animation after frame 70 or so.
You’ll add a noise controller to animate one of
the biped’s arms, beginning after frame 70.

3. In the viewport, select the Bip01 R UpperArm
object.

4. on the Motion panel, under the Biped Apps
rollout, click the Workbench button.

The Workbench appears, displaying the curves
for Bip01 R UpperArm.

5. Move the Workbench floater so it covers the top
half of the viewport. Adjust the viewport so
you have a clear view of the biped.

Now you can see both the biped and the
Workbench at the same time.

6. At the lower right of the
Workbench, on the Navigation: Track View
toolbar, click the Zoom Horizontal Extents and
Zoom Value Extents buttons.

Now the curves are clearly visible for your
examination.

Curves and biped both visible

To assign the noise controller, you’ll use the
Workbench Controller list.

7. At the top of the Workbench toolbar, click the
button labeled Controllers.

The Controller list is now visible between the
Selection panel and the Curve view.
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Controller list window appears between select panel
and curve view.

8. In the Controller List, under the Bip01 R
UpperArm entry, expand Biped SubAnim so
you can see the BipRotationList. Expand that
entry and highlight the Available label.

9. Right-click the Available entry, and choose
Assign Controller. In the dialog that appears,
choose Noise Rotation.

10.On the Noise Controller dialog, make the
following changes to the Noise Rotation
parameters:

• Turn off Fractal Noise.

• Frequency=0.11

• X, Y, and Z Strength=0.33

Play the animation. Notice that the arm now
has animation beyond frame 70.

You can copy this controller and paste it to
multiple biped objects in the Workbench. You’ll
do that next.

Copy controllers using the Workbench:

1. Close the Noise Rotation properties window.

2. Select the Noise Rotation entry in the Controller
List. Then press CTRL+C on the keyboard.

This copies the controller into a buffer.

3. In the Select panel, highlight Bip01 L
UpperArm.

The Controller list now navigates to the Bip01 L
UpperArm object.

4. Expand the entry and expand the
BipRotationList, then highlight Available.

5. Press CTRL+V on the keyboard to paste the
controller onto this object. Choose Instance
rather than Copy, and click OK.

Tip: If you don’t get the option to Instance the
controller, this means you didn’t click the Noise
Rotation in the Controller list before copying.

Play the animation in the viewport to verify that
both arms now are animated after frame 70.

6. In the Select panel of the Workbench, hold
down the CTRL key and select Bip01 L Thigh
and Bip01 R Thigh .
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7. Select the Available entry for Rotation for each
of these objects, and again press CTRL+V to
paste the controller onto these objects.

8. Repeat these steps for the Bip01 Head and the
Bip01Spine1 objects

If you want, you can also copy the controller
to the pelvis. If you do, be aware the pelvis is
locked on the Z-axis and can only rotate on the
X and Y-axes.

9. Play the animation and observe the effect.

10.Since all the controllers are instanced, you can
make changes to any one and alter all of them
at the same time. To do this, highlight one of
the Noise Rotation entries in the Controller list,
and then right-click and choose Properties.

Tip: If you want to make an instanced controller
unique, highlight it, and then press U on the
keyboard. Now you can make changes to that
controller without affecting the other ones.

11.Save your file as my_super_final.max, or open
super_final.max for comparison.

Analyzing and Fixing Animation
Errors

The Workbench lets you analyze motion tracks
to detect noise or spikes that can reveal motion
errors. Once the errors have been located, you can
correct them either selectively or all at one time. In
this lesson, you’ll learn the workflow for analyzing
and fixing motion errors using the Workbench.

Analyze motion errors:

1. Open fix_nightclub_start.max.

Biped dancing

2. Play the animation in the viewport.

The biped performs some dance steps. Notice
that on a number of different frames, the arms
rotate wildly for just a moment.

At frame 69, the arms rotate incorrectly.

You could try to locate these frames manually
by slowly going through the animation and
visually searching for the problems. The
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Workbench offers an automated method to
accomplish the same thing.

3. Select any biped body part and open the
Motion panel. In the Biped Apps rollout, click
the Workbench button.

The Workbench is displayed.

4. In the viewport, move the Workbench so it is
covering the top half of the viewport. Pan and
zoom so the biped animation is clearly visible
below the Workbench.

Perspective viewport and floating Workbench

5. In the Workbench, on the Select panel, hold
down the CTRL key and highlight Bip01 R
UpperArm, and Bip01 L Upperarm.

Select both UpperArm objects

if you can’t see the function curve
clearly, click Zoom Value Extents and Zoom
Horizontal Extents

Curve displayed for rotations of Bip01 R UpperArm

Note: The curve view doesn’t display the curves
for both body parts. The default behavior of
the curve view allows you to select as many
biped body parts as necessary, without forcing
the display of all the curves. If you want to see
the multiple curves together in the window,
turn on the Controllers list, and then select the
multiple tracks there.
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Multiple curves displayed using Controllers list selection

The motion errors are already fairly obvious in
the function curve display. Next you’ll use the
Analyze panel to select the affected part.

6. Open the Analyze panel. In the Parts To
Analyze options, turn on Selected Parts.

This will analyze all the selected parts
highlighted in the selection list, rather than just
the curve displayed at the right. It wouldn’t be
very difficult to select the keys and delete them
by hand at this point, but if there were many
keys it would be more work. Next, you’ll see
how to use the Workbench to automatically
find and select the errors.

7. In the Analyzers group, choose Spike Detector
from the drop-down list.

8. Leave the Standard Deviation set to 3.0.

Standard Deviation sets the degree to which the
animation can depart from its overall pattern.
The default setting will work fine for finding
the spikes in this animation.

9. Click the Analyze button at the bottom of the
Analyze panel. If you don’t see that button,
expand the height of the Workbench window
until you do.

Analyze panel shows number of errors for each biped
object.

The errors appear listed in the Error field at the
bottom of the Analyzer panel. The Analyzer
finds six errors for the left arm, and five for the
right arm. The errors are displayed as brown
lines in the curve view.

Error displayed as brown lines.
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Tip: If you know there are errors in your file, but
the Analyzer doesn’t find them, try lowering the
Standard Deviation value and analyzing again.

Fix motion errors:

Now you can use the Fix panel to automatically
correct the errors. Since these are rotation spikes,
you’ll use the Remove Keys fixer to delete the keys.

1. Open the Fix panel. The errors are listed
individually in the Analyze Results window.
Click on any error in the list for the Bip01 R
UpperArm.

The error will display as a yellow line in the
curve view.

2. Click on any other error in the list for the Bip01
R UpperArm.

Again, the error will display as a yellow line in
the curve View.

3. Turn on Sort By Part, so all the errors for the
Bip01 R UpperArm are displayed together.

4. Hold down the CTRL key and select all the
Bip01 R UpperArm errors.

All the errors display as yellow lines on the
graph.

5. In the Fixers group, choose Remove Keys from
the drop-down list.

6. Turn on Delete Keys. Set the Interval Width to
3, then click Fix Selected.

Interval Width sets the number of frames
around the error for the filter to look at when
deleting keys.

After a brief calculation, the keys are removed.
The curve shows the correction, with dotted
lines indicating the former curve positions.

7. Repeat for the remaining Bip01 L UpperArm
errors. You can click Fix All to fix all the errors
without selecting them in the list.

When the errors are fixed, they’re removed
from the Analyze Results window.

8. Play the animation and observe that the
rotations are now error-free.

Biped arms rotate correctly following fix.
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Animating Crowds

Animating Crowds

This tutorial covers a range of techniques used with
the 3ds Max crowd-animation features for creating
and animating crowds. Crowd animation starts
out with behaviors applied to delegates, which
serve as stand-ins for crowd members. Next, that
motion is applied to mesh objects or bipeds. These
objects might carry their own animation, which
can be combined with the delegate animation in a
variety of ways. In the final part of this tutorial,
you’ll learn how to use motion synthesis to apply
different parts of a mesh object’s animation to each
crowd member, based on its current behavior.

In this tutorial, you’ll learn how to do the following:

• Create the Crowd system building blocks: the
Crowd and Delegate helper objects.

• Apply behaviors to delegates so the Crowd
system can animate them.

• Use cognitive controllers to change delegate
behavior dynamically during the crowd
simulation.

• Apply crowd simulation to non-bipedal
characters. In the final lesson, you’ll animate
a flock of eagles flying around an arbitrary

shape, using motion synthesis and the Vector
Field space warp. They flap their wings as they
ascend, and glide as they descend or fly level.

Skill Level: Beginner to Intermediate

Time to complete: 2 hours

You can find the files for this tutorial in the
tutorials\character_animation\crowd_basics
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

In This Tutorial

Getting Started with Crowds (page 2–638)

Using Multiple Delegates and Behaviors (page
2–641)

Applying Avoidance (page 2–644)

Applying Logic to Crowd Behavior (page 2–646)

Using Crowd with Animated Non-Biped Objects
(page 2–649)

Getting Started with Crowds

The Crowd object lets you assign behaviors to
delegates. This lesson teaches you how to add the
Crowd and Delegate objects and make them work
together. You’ll add a behavior and assign it to the
smallest possible crowd: a single delegate.

Create a delegate:

1. On the Create panel, click Helpers.

2. In the Object Type rollout, click Delegate.

3. In the Top viewport, drag to add a Delegate
helper object.

By default, the tip of the pyramid-shaped
delegate object is its front; it helps to think of
it as an arrowhead pointing in the direction
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it wants to go. Adding a delegate in the Top
viewport points it forward, in terms of the
default world orientation.

Create a crowd object:

The Crowd helper object is also available from the
Helpers > Object Type rollout.

• In any viewport, add a Crowd object.

Delegate and Crowd helper objects in Top viewport

The size, position, and orientation of the Crowd
object are not important. Be sure to make it
easily accessible, because you’ll be selecting it
frequently as you work with crowd simulation.

Tip: Create a selection set containing the Crowd
object to be able to select it quickly without
using the viewports.

Add a behavior:

You’ll add a behavior and apply it to the delegate.
The easiest behavior to use is the Wander behavior.

1. Go to the Modify panel, which shows
rollouts for the Crowd object.

2. In the Setup rollout, click the New button.

3. In the Select Behavior Type dialog, choose the
Wander behavior and click OK.

The default name of the behavior, Wander,
appears in the list at the bottom of the Setup
rollout, and a new Wander Behavior rollout
appears in the Modify panel below the Setup
rollout. You can find a full explanation of its
parameters in the 3ds Max 8 User Reference, in
the Crowd Animation User Interface chapter.
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When you have multiple behaviors in a scene,
this rollout shows the type and parameters for
the current behavior, as indicated in the list.

4. Change the name of the Wander behavior by
clicking in the list box and typing a new name,
such as My Wander Behavior.

The name doesn’t change in the behavior’s
rollout title. The rollout title always displays the
name of the behavior type.

Tip: When a scene contains multiple behaviors
of the same type, give them distinguishing
names so you don’t confuse them.

Assign the behavior:

Next, you’ll apply the behavior to the delegate.

1. On the Setup rollout, click the Behavior
Assignments button.

This dialog lets you group delegates into teams
and assign behaviors and cognitive controllers
to delegates and teams. You’ll cover the more
advanced functionality in later lessons.

2. In the Behavior Assignments And Teams dialog
> Assignment Design group, click the two list
entries: Delegate01 and My Wander Behavior.

When you select both a delegate and a behavior,
the New Assignment button becomes available.
This vertical button, situated between the
Assignment Design and Behavior Assignments
group, displays a column of right-pointing
arrows.

The New Assignment button, outlined in red

3. Click the New Assignment button.

The assignment is added to the list in the
Behavior Assignments group. By default, it has
the highest available Weight value of 1.0 and
is active.

4. Close the dialog by clicking OK.

Solve the simulation:

You’re now ready to solve the simulation. During
the solution, the software generates animation keys
for delegates to which you’ve assigned behaviors.

1. On the Modify panel > Solve rollout, click the
Solve button.
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The software solves the simulation, while the
bar graph under the Solve button shows its
progress. As a result, the delegate wanders
randomly around on the world grid.

The wandering delegate’s trajectory

Tip: You can see the delegate’s trajectory by
selecting the delegate, then going to the Motion
panel and clicking Trajectories.

2. Play the animation.

You might need to change viewport settings to
see the delegate throughout the animation.

3. Experiment with the behavior and delegate
settings and continue to solve. Remember that
you must have the Crowd object selected to see
the various crowd parameters. Also, you must
have the delegate selected to see the trajectory.

Here are some things to try:

• In the Wander Behavior rollout, change
the Period setting to adjust how long the
delegate travels before it changes direction.

• Change Seed to vary the random path.

• Select the delegate, and in the Motion
Parameters rollout, turn off Constrain To XY
Plane. This lets the delegate wander in 3D
space. Note that, to solve after you do this,
you’ll have to select the Crowd object again.

Tip: To save time, turn on the Keyboard
Shortcut Override Toggle, and then press the S key
to run a solution when the Modify panel is active.

Now that you’ve learned the basic features of the
crowd system, you can work with real crowds that
contain more than a single delegate.

Using Multiple Delegates and
Behaviors

3ds Max has a number of special facilities for
working with multiple delegates and crowds, as
you’ll see in this lesson. You’ll also explore several
new behaviors.

This lesson builds on the knowledge gained in the
previous one. If you haven’t completed the Getting
Started with Crowds (page 2–638) lesson, please
complete it before undertaking this one.

Set up the lesson:

1. Run 3ds Max, or reset the program, and then
add a Delegate and Crowd object, as in the first
lesson.

2. Add a small box near the center of the
workspace, then add a large sphere surrounding
it. The two should be roughly concentric.
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You can open a MAX file that already has these
objects. Open crowd_basics01.max from the
tutorials\character_animation\crowd_basics
directory in your 3ds Max path.

Clone the delegate:

You’ll use the Scatter Objects tools to create several
clones of the delegate, position them about the
large sphere’s surface, and aim them at the box.

1. Select the Crowd object, then go to the Modify
panel.

2. In the Setup rollout, click the Scatter
button to open the Scatter Objects dialog.

3. On the Scatter Objects dialog > Clone panel,
click the Object To Clone button and select
Delegate01. Click Select to close the dialog.

4. Change the How Many setting to 9.

5. Click the Generate Clones button.

This creates nine copies of the delegate (10
delegates in all). You can’t see them yet because
they’re all coincident with the original delegate.

6. In the Scatter Objects dialog > Position panel
> Placement Relative To Object group, choose
On Surface.

7. In the same group, click the Grid/Box/Sphere/
Surface/Shape button, and select Sphere01.

Even though you’re using a sphere to distribute
the delegate clones, you’re not choosing Inside
Sphere. That’s because you’re going to position
the clones on the surface of the sphere, rather
than throughout its volume.

8. Near the bottom of the Position panel, click the
Generate Locations button.

The software distributes the delegate clones
randomly on the sphere surface.

Delegates are scattered about the sphere surface.

Reorient the delegates:

The delegate clones are positioned at random
locations across the large sphere’s surface. They’re
all pointing in the same direction. In the next
steps, you’ll reorient them so they’re all pointed at
the small box.

1. In the Scatter Objects dialog > Rotation panel >
Look At Target group, choose Selected Object.

This makes the button available.

2. In the same group, click the Selected Object
button, and select Box01.

3. Click the Generate Orientations button.

The delegate clones are all now pointing at the
box.

Delegates are pointed at the box.
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4. Click OK to close the Scatter Objects dialog.

5. Select the large sphere, and press the DELETE
key to remove it from the scene.

You’ll use this setup in the fourth lesson.

6. Save the file as crowd_basics03a.max.

Next you’ll use two behaviors, Seek and Repel,
to make half the delegates move toward the
small box and the other half move away from it.

Add behaviors:

1. Select the Crowd object. In the Setup Rollout,
click New and add a Seek Behavior.

2. On the Seek Behavior rollout, click the button
at the top (currently labeled “None”), and select
the box.

The box’s name appears on the button,
indicating that it’s the object that will be sought
by any delegate to which the behavior is applied.

3. On the Setup rollout, click Behavior
Assignments.

You could assign the Seek behavior one delegate
at a time, but that’s not necessary. Crowd lets
you group delegates into teams and assign a
behavior to the entire team.

4. In the Behavior Assignments And Teams dialog
> Teams group, click New Team, and then OK.

This adds a team with the default name Team0.
You can rename it by clicking its name at the
top of the group box.

5. Rename the team Seek Team.

Next, you’ll specify which delegates are to be
members of Seek Team.

6. Click the Add Members button. In the Select
Delegates dialog, click Delegate01, and then
hold down SHIFT and click Delegate05 to select
the first five delegates. Click OK to exit.

The delegate names appear on the Seek Team
roster.

7. In the Assignment Design group > Teams list,
click Seek Team, and in the Behaviors list, click
Seek.

8. Click the vertical New Assignment button to
create the assignment.

Create a behavior with the Behavior Assignments
And Teams dialog:

You’ll create a Repel behavior using the Behavior
Assignments and Teams dialog.

1. In the Behavior Assignments And Teams dialog
> Assignment Design group, click the New
Behavior button, and choose Repel Behavior.
Click OK.

The behavior is added to the Behaviors list. You
still need to use the command panel to modify
the behavior. The dialog stays open as you do
this.

2. On the Setup rollout, choose Repel from the list.

The Repel Behavior rollout replaces the Seek
Behavior rollout.

3. On the Repel Behavior rollout, specify Box01 as
the repel object, using the same method as with
the Seek behavior.

4. On the same rollout, in the Radius group, turn
off Use Radii.

This applies the Repel behavior at any distance,
not just within a specific radius.

5. Return to the Behavior Assignments And
Teams dialog. Create a new team containing
Delegate06 through Delegate10. Rename it
Repel Team.

6. Assign the Repel behavior to Repel Team and
close the dialog.

7. In the Solve rollout, click Solve to solve the
simulation.

Half the delegates move toward the box and the
other half move away, but they all stay on their
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own plane. You can make them move in three
dimensions.

If you tried the third suggestion at the end of the
previous lesson, you might have an idea of how
to fix this: Turn off the delegates’ Constrain To
XY Plane switches. But there’s no need to do so
one delegate at a time.

Move the delegates in three dimensions:

1. On the Setup rollout, click Multiple
Delegate Editing.

The Edit Multiple Delegates dialog appears.
You can use this dialog to apply changes to
several delegates simultaneously.

2. In the Edit Multiple Delegates dialog >
Delegates To Edit group, click the Add button.

3. In the Select dialog, click All and then click
Select.

This adds all delegates in the scene to the
Delegates To Edit list.

Note: You cannot work with teams in the
Edit Multiple Delegates dialog. However, the
Behavior Assignments dialog lets you create
named selection sets from teams, and the Select
dialog lets you specify selection sets.

4. In the General group, turn off Constrain To
XY Plane.

5. Turn on SET, the adjacent check box.

This ensures that the changed setting takes
effect when you exit the dialog.

6. Click the Apply Edit button.

This closes the dialog and applies your change
to all specified delegates.

7. Solve the simulation again.

This time, the delegates move in three
dimensions. Half of them move directly toward
the box, and the other half turn and move
directly away. The seeking delegates continue

to seek the box after they reach it, continually
circling it.

8. Save this file as crowd_basics02a.max for use
in the next lesson.

Applying Avoidance

In the previous lesson, you might have noticed
that the delegates penetrated each other when they
were close to the box. In this lesson, you’ll learn
to use the Avoid behavior to prevent delegates
from colliding. You’ll also learn to apply a second
"desired direction" behavior to the Seek team and
animate the behaviors’ influences.

Set up the lesson:

• Open the file you saved at the end of the
previous lesson. Or, if you like, open
the file crowd_basics02.max from the
tutorials\character_animation\crowd_basics
directory, in your 3ds Max path.

Add the Avoid behavior:

1. Select the Crowd object.

2. Add an Avoid Behavior.

Like Seek and Repel, the Avoid behavior has a
button for specifying a single object to avoid.
But in this case, you want to specify several
Avoid objects, so you use the Multiple Selection
button.

3. On the Avoid Behavior rollout, click
Multiple Selection.

4. Highlight all objects (the delegates and the
box), and click Select.

5. Use the Behavior Assignment dialog to apply
the Avoid behavior to the Seek team.
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When you click New Assignment, the Avoid
behavior appears in the assignments list above
the Seek behavior. That’s because the list is
sorted alphabetically, starting with the leftmost
column. By default, all behaviors are applied
simultaneously, so when you solve, both the
Seek and Avoid behaviors are applied to the
Seek team at each frame.

6. Solve the simulation.

For the most part, the delegates now stay far
away from each other and the target box.

Use visual cues:

You can get a better idea of how Avoid works by
turning on its various feedback options. These
give visual cues for distance-related settings and
activities.

1. On the Avoid Behavior rollout, turn on Display
Hard Radius and Display Repel Radius.

Wireframe spheres appear around the delegates,
showing the respective radii.

2. Turn off Display Hard Radius and Display Repel
Radius to avoid an overly complex display.

3. In the Avoid Behavior rollout > Display During
Solve group, turn on Potential Collisions, Repel
Activity, and Look Ahead Radius.

4. Solve again.

During the solution, white lines appear
indicating Potential Collisions detection;
colored lines indicate Repel Activity
calculations, and spheres indicate Look
Ahead radii. The latter are available only
during solution, because the distance must be

computed from the Look Ahead setting and the
delegate’s current velocity.

Adjust the behavior:

The delegates give each other a wide berth because
the Look Ahead setting, which tells delegates how
many frames to look ahead for potential collisions
before turning to avoid each other, is set to the
fairly large default value of 30. The delegates can
get closer to each other if you reduce this amount.

1. Set Look Ahead to 3.

2. Solve the simulation.

This time the Seek Team delegates don’t stay
quite so far apart. In fact, you might see some
interpenetration, because the small Look
Ahead setting doesn’t give them enough to time
to start turning to avoid each other. The best
settings for Avoid, as with most other behaviors
and Crowd settings, depend on the situation,
and finding them usually takes trial and error.

Change the behavior:

Next, you’ll make the delegates stop seeking the
box and start moving away when they reach it.
You can do this by assigning the existing Repel
behavior to the Seek team and activating it at the
proper frame while simultaneously deactivating
the Seek behavior.

First, examine the animation to determine when
to change the behaviors.

1. Move the time slider back and forth to find
frame where the delegates come closest to the
box.

Choose frame 70, or a frame near frame 70.

2. Move the time slider back to frame 0. Turn on
the Auto Key button.

3. Open the Behavior Assignments dialog, and
assign the Repel behavior to the Seek team.

4. In the Behavior Assignments list, click the Seek
Team Repel Behavior item.
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The corresponding items in the Assignment
Design group are highlighted, and the controls
at the bottom of the Behavior Assignments
group become available.

5. At the bottom of the Behavior Assignments
group, turn off Active.

The X next to the assignment in the list
disappears, indicating that the assignment is
inactive. This setting is animatable, so you can
directly control which assignments are active
on a frame-by-frame basis throughout the
animation.

6. Drag the time slider to frame 70.

7. Turn on Active for the Seek Team Repel
Behavior assignment. Then choose the Seek
Team Seek Behavior assignment, and turn off
Active.

8. Drag the time slider back and forth to either
side of frame 70 and watch the Behavior
Assignments list.

At the same time that the Repel behavior turns
on, the Seek behavior turns off.

9. Close the dialog, and turn off Auto Key.

10.Solve the simulation.

At frame 70, the delegates stop seeking the box,
turn abruptly, and begin to move away.

For a more gradual change, you can animate
the Weight setting. This controls the relative
influence of the behavior over the delegates,
and ranges from 0 to 1.0.

Applying Logic to Crowd Behavior

In the previous lesson, you learned how to switch
a team from one behavior to another by animating
the Active status. You did this by setting up and
solving the first part of the simulation, and then
using that feedback to set up the second part. This
isn’t a very flexible method, though. If you change

the target position, or the delegates’ speed, the
frame where the behaviors should switch would
change, and you’d have to move at least two keys.
With more complex simulations, such as those
with multiple or moving targets, or delegates that
travel different distances, modifications can be
difficult.

For complex situations, you can assign cognitive
controllers to delegates and teams instead of
behaviors. The cognitive controller has several
states. Each state can contain one or more
behaviors, each with a different weight. You set
the states up as a diagram and link them with
transitions. The transitions use MAXScript scripts
to determine when one state relinquishes control
to another.

In this lesson, you’ll use a cognitive controller to
change a team’s behavior from Seek to Repel when
the team members reach the box.

Set up the lesson:

• Open the file you saved in the middle of the
Using Multiple Delegates And Behaviors
lesson (crowd_basics03a.max). Or, if you
like, open crowd_basics03.max from the
tutorials\character_animation\crowd_basics
directory in your 3ds Max path.

This scene contains 10 delegates scattered in
a spherical pattern about a small, centrally
located box.

Set up the behaviors:

1. Select the Crowd object, and open the Modify
panel.

2. Use the Edit Multiple Delegates dialog
to turn off Constrain To XY plane for all the
delegates.

The method for doing this is covered in the
previous lesson, Applying Avoidance and
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Animating Behavior Assignments (page
2–644).

3. Add a Seek behavior and a Repel behavior, and
set the box as the target for both behaviors.

4. For the Repel behavior, turn off Use Radii.

Use the cognitive controller:

Instead of assigning these behaviors to the
delegates, you’ll use them to build a cognitive
controller and assign the controller to the
delegates.

1. On the Setup rollout, click Cognitive
Controllers.

2. In the Cognitive Controller Editor window,
click the New button on the right side of the
toolbar.

This creates a new cognitive controller with the
name Cognitive Controller and activates the
Create State tool (the button at the left end of
the toolbar).

3. Click twice in the editor window, in two
different locations.

This adds two state boxes to the controller. Each
state can contain any number of behaviors.

The cognitive controller editor with two states added

The first state you added is dark red, which
means it’s the Start state. It is executed first
when the cognitive controller begins working.
You can set any state to be the Start state.

To make the delegates seek the box first, you’ll
assign the Seek behavior to the first state. You’ll
also make the states’ names more descriptive,
and assign a behavior to the second state.

4. Right-click in the window to exit Create State
mode, and then right-click the red state box.

The State dialog opens. The name of this dialog
reflects the name of the state at the time you
open it. You can change the name, and the
new name is displayed the next time the screen
refreshes.

5. In the State dialog, click the name (“State”) in
the upper, one-line edit window and change
it to Seek.

6. Click the Add button. In the Select Behaviors
dialog, click Seek Behavior and click OK.

The Seek behavior is highlighted in the list. You
can change the weight, so that if a state contains
several behaviors, some can predominate over
others.

When you opened the Select Behaviors dialog,
the screen refreshed and the State dialog name
changed to Seek.

7. Close the Seek dialog by clicking the Close box
(X) in its upper-right corner.

8. Change the second state’s name to Repel and
assign it the Repel behavior.

Create a transition:

You’ll add a transition between the two states, and
create a short script to tell the cognitive controller
when to switch between them.

1. On the editor toolbar, click Create
Transition.

2. Drag a line from the Seek state to the Repel
state.
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An arrow points from the first state to the
second. This is the transition.

3. Right-click the transition arrow.

4. In the Transition ("Seek -> Repel") dialog,
change the Duration setting to 10.

This makes the transition take place over 10
frames instead of 25. A shorter transition
causes faster reactions.

Note the other settings. If you change the
priority, and a state has two or more outbound
transition conditions, all of which are true, the
one with the highest priority takes precedence.
You can also change the rates at which a
transition eases out of one state and into the
next.

5. Click the Edit MAXScript button.

6. In the MAXScript window, enter the following:

fn TestDist del t = (
get_dist=distance $box01.pos del.simpos
if get_dist < 120
then 1
else 0 )

Alternatively, you can load the
MAXScript file test_dist.ms from the
tutorials\character_animation\crowd_basics
directory in your 3ds Max path.

This script tests, at each frame, the distance
between each delegate and the box. If it is less
than 120 units, the delegate moves into the next
state, which uses the Repel behavior.

The name of the function, which is the second
word of the script (after "fn"), must appear in
the Transition dialog as well.

The script, which starts with "get_dist,"
calculates the distance between the position
([name].pos) of a specific object ($box01) and
the position of a generic delegate (del.simpos).
"Simpos" is a special position property used
to determine a delegate position during a
simulation solution.

The software executes the transition script
once per frame for each delegate that uses this
cognitive controller. Each time the script is
executed, the cognitive controller substitutes a
subsequent delegate for "del".

The first time the script is executed at a given
frame, it calculates the position the distance
between the objects box01 and delegate01.
The second time, it calculates the position
the distance between the objects box01 and
delegate02, and so on. To see each delegate’s
name as its position is tested, insert this line in
the script anywhere between the first line and
the last line:

print del.name

Be sure to have a Listener window open (press
F11) before you run the solution.

To learn more about how scripts work in
transitions, read the reference topics Cognitive
Controller Editor and State Transition
Dialog, where you’ll find more sample scripts
with descriptions of their components and
functions.

7. Double-click the name of the function
("TestDist") to highlight it, and then press
CTRL+C to copy it to the Windows clipboard.

8. Close the MAXScript dialog.

9. In the Transition dialog, highlight or delete the
contents of the Transition Condition text box,
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and then press CTRL+V to paste the name of
the function into the box.

10.Click OK to close the Transition dialog, and
then close the Cognitive Controller Editor.

Two more short steps remain before you can
test the transition.

11.Open the Behavior Assignments dialog, and
create a team from all the delegates.

12.Assign the cognitive controller (Cognitive
Controller) to the team, and close the dialog.

13.Solve the simulation.

The delegates move toward the box until they’re
fairly close, at which point they turn and move
directly away.

14.Try these variations:

• Add a second transition from the Repel state
to the Seek state that turns the delegates
back around after they get a certain distance
away. Hint: You need to change only three
items in the first script.

• Animate the position of the box so the
delegates have to chase it before they can
get close enough for the transition to begin.
Tip: You might have to increase the End
Solve setting.

• Use Edit Multiple Delegates to set random
speeds for the delegates, so they don’t all
reach the box and turn around at the same
time.

Using Crowd with Animated
Non-Biped Objects

The 3ds Max Crowd animation system has a
number of special features designed for applying
behaviors to non-biped objects. In this lesson,
you’ll learn how to create a flock of birds that
automatically flap their wings when they fly
upward, and glide without flapping when they fly

horizontally or downward. You’ll use the Crowd
system’s non-bipedal motion synthesis methods
to achieve this.

You’ll animate several delegates and link them
with clones of an animated global object. Next,
you’ll use clip controllers to define clips from the
global object’s animation. You’ll define states to
specify which animation clip the clones should
use, depending on their parent delegates’ speed,
acceleration, pitch, and so on. Crowd will blend
the clips and synthesize an animation based on the
clip and state information.

This scene uses a vector field, which is a special
type of 3ds Max space warp that enables crowd
members to move around complex objects.

Set up this lesson:

• Open the file crowd_basics04.max in the
tutorials\character_animation\crowd_basics
directory in your 3ds Max path.

This file contains the basic setup for the birds
scene. It contains a crowd object and a "flock"
of five delegates in V formation, as well as a
vector field surrounding a C-shaped "obstacle"
object.

Examine the vector field:

The vector field is already set up, so you needn’t
make any changes to it, but it’s useful to take a
quick look at it to see how it works.

1. Select the vector field object.

The vector field object is the gizmo shaped like
two double-headed arrows in an X formation,
near the C-shaped object. It’s probably easiest
to use the Top viewport to select this.

2. Go to the Modify panel. In the Obstacle
Parameters rollout > Display group, turn on
Show Lattice.

The lattice is a yellow, box-shaped,
three-dimensional grid surrounding the
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obstacle object. Its settings determine the
location, resolution, and maximum volume of
the vector field. This field uses a high-resolution
grid, so the display in the Perspective viewport
is almost solid yellow, but you can see the grid
clearly in the orthogonal viewports.

3. Turn off Show Lattice, and turn on Show Range.

The range is typically an expanded version of
the obstacle object, and is used by the vector
field to calculate vectors within the lattice.

4. Turn off Show Range, and turn on Show Vector
Field.

The blue lines represent forces used by the
Vector Field space warp to guide delegates
through this volume. As you can see, their
spacing is determined by the lattice resolution,
and the overall shape of the field is determined
by the range volume.

5. Turn off Show Vector Field.

Assign behaviors:

1. Select the Crowd object. On the Modify panel
> Setup rollout, add a Space Warp behavior.

2. On the Space Warp Behavior rollout, click the
button and select the vector field object.

Now, any delegates using the Space Warp
behavior will use the vector field to guide their
motion.

3. Add an Avoid behavior.

4. On the Avoid Behavior rollout, click the
Multiple Selection button.

5. In the Select dialog, select all of the delegates
and click Select.

This sets the delegates to avoid each other.

6. Open the Behavior Assignments dialog.

The delegates have already been grouped into
a team (Team0).

7. Assign both behaviors to the team and close
the dialog.

8. On the Solve rollout, click the Solve button.

You can stop the simulation at any time by
pressing ESC. As Crowd solves the simulation,
the delegates move around the obstacle object,
roughly following its contours while remaining
at their starting height. Some might fly away,
which you’ll remedy in the next procedure.

To allow the delegates to fly up and down, you
turn off the switch that constrains the delegates
to the XY plane.

Modify the delegates:

1. On the Setup rollout, click Multiple
Delegate Editing.

The delegates have already been added to
the Delegates To Edit list. You don’t need to
highlight them.

2. In the General group, turn off Constrain To
XY Plane.

3. Turn on SET for Constrain To XY Plane.

You can also vary the delegates’ speeds.

4. In the Speed group, to the right of Average
Speed, turn on both Random and SET.

Turning on Random gives you access to both
Average Speed settings.

5. Change the first Average Speed setting to 3.0.

Crowd will use random values between 3 and 5
units per frame for the delegates’ speeds.

6. Click the Apply Edit button to close the
dialog and apply your changes to all specified
delegates.

7. Solve the simulation again. This time, be sure
to let it finish.

The delegates move in three dimensions,
soaring and then descending.
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If any of the delegates still fly away, try changing
its starting position, or if you want to keep the
V formation, move all of them together.

Reveal the eagle:

You’ll assign an animated bird object to each
delegate.

1. Right-click in the active viewport, and from
the Display quadrant of the right-click menu,
choose Unhide All.

Only the Eagle object was hidden. If you haven’t
changed the Perspective view, you’ll see it in
that viewport. If you have, and the Eagle object
is not visible, use SHIFT+Z to undo viewport
changes.

2. Select the Eagle object and drag the time slider
to see its animation.

The bird flaps its wings from frames 0 to 186
and then remains still. The last key frame is 288.

The bird is animated in place, so you can
combine the delegates’ motion with the bird’s
animation to create a convincing animation.

There are quite a few interim keyframes, even
while the bird doesn’t move, because Motion
Clips uses interim frames to blend animation
clips when it synthesizes an object’s animation.

Assign animated objects to delegates:

1. Select the Crowd object and click Scatter
to open the Scatter Object dialog.

2. Specify Eagle as the object to clone

How Many is already set to 5.

3. Turn off Clone Controllers so the eagle’s
animation won’t be replicated in the clones.

If you don’t do this, the existing animation
mixes with the synthesized new keyframes,
which can create confusing and erroneous
results.

4. Click Generate Clones, and then click OK to
exit the dialog.

5. Drag the time slider to see the non-animated
clones superimposed over the original,
animated eagle.

Next, you’ll link the delegates with the eagle
clones, repositioning the clones at the same
time.

6. Click Objects/Delegate Associations to
open its dialog.

7. Click the Add button under the Objects list and
select the five eagle clones: Eagle01 through
Eagle05.

8. Click the Add button under the Delegates list
and select the five delegates.

The two lists appear in alphabetical order,
indicating the order in which each delegate and
eagle mesh are to be paired. You can change the
order by highlighting list items and clicking the
up and down arrows in between the two lists.
In this case, it’s not necessary.

9. Click Align Objects With Delegates.
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This moves each object to its respective
delegate’s position, and reorients the object as
necessary to align its local axis with that of the
delegate. In the viewports, the eagle clones line
up with the delegates. But they’re not linked yet.

10.Click the Link Objects To Delegates button, and
then click OK to close the dialog.

This creates a parent-child hierarchy for each
pair, with the delegate as the parent in each pair.

11.Drag the time slider to observe the eagle clones
moving with the delegates.

The eagle clones remain in their initial,
wings-raised animation position as they move.

Use Clip Controllers:

You’ll use Clip Controllers to apply the correct
animation clips from the original eagle object
to the clones. Three clip controller types are
available:

• Global Clip Controllers: the objects from which
the animation clips are derived, in this case, the
Eagle object.

• Master Clip Controllers: the block controllers
that are created in Track View. There is
one controller for each object to which the
synthesized animation is applied. For more
information, see the Block Controller topic in
the 3ds Max User Reference.

• Slave Clip Controllers: objects containing all
animation tracks in each Master Clip controller.
For more information, see the Slave Parameters
Dialog topic in the 3ds Max User Reference.

1. With the Crowd object selected, scroll down
to the Global Clip Controllers rollout at the
bottom of the Modify panel.

2. Click New and select the Eagle object.

This specifies the Eagle as the Global Object,
from which the eagle clones’ animation will be
derived.

3. In the Global Clip Controllers list, click the
Eagle entry, and then click the Edit button to
open the Synthesis dialog.

The dialog’s three tabbed panels let you set up
the clip controllers in a logical workflow.

4. Look at the five check boxes In the Motion
Clips panel > From Global Object group. They
should all be off, but if any are on, turn them off.

These are useful only when you’ve animated the
global object’s position and rotation and want
to incorporate this animation in the resulting
states.

5. In the same group, click New to add a new clip.
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The MotionClip Parameters dialog opens with
the default clip name Motion Clip.

The MotionClip Parameters dialog defines
animation clips from the global object. The
current end frame is automatically set to the
last key in the global object’s animation.

6. Change the name to Flap, and set End to 186,
the last frame of the flapping motion. Click OK.

7. Create a second clip called Glide, and set it to
use frames 187 through 288. Click OK.

The clips use different colors so you can
distinguish them in Track View.

Define states:

You’ll define two states to specify how a delegate
moves at any given time. You can specify values
or value ranges for one or more of these motion
categories: speed, acceleration, pitch, pitch
velocity, and heading velocity. You can also use
MAXScript to define a state. As you define states,
you assign clips to them. For example, if your
animated object uses different motions for turning
sideways or slowing down, you create a state for
each one and assign it the appropriate motion clip.

In this procedure, you’ll create one state for upward
motion that uses the Flap clip, and a second state
for downward motion that uses the Glide clip.

1. Click the State tab, and then click New State.
Change the name from ClipState to Flap.

2. Click Add Clip and choose the Flap clip.

3. Click Edit Properties.

You’ll use this dialog, which has the same name
as the state (in this case, “Flap”) to apply the
Flap state when the delegate moves upward.

4. Click the Pitch tab and turn on Use Pitch.

The Range settings become available. Use these
to specify the range of pitches to activate this
state.

5. Set Min to 1.

The bird will flap its wings whenever its pitch is
between 1 through 180 degrees (when it’s flying
upward).

6. Click Exit to close the Flap dialog.

7. Add a second state and call it Glide.

8. Assign it the Glide motion clip and use Edit
Properties to specify that the Glide state is to
use a pitch range of -180 to 0. Again, close the
dialog by clicking Exit.

The bird will stop flapping its wings whenever
it’s flying downward or level. You can also set
different flapping rates for different pitches by
creating more clips when you set up the global
object.

Specify master motion clips:

This is the final part of the motion clip setup
procedure. Here you specify the master motion
clips, that is, the objects to which the synthesis is to
be applied. You also blend the clips and synthesize
the animation.

1. Click the Synthesis tab.

2. Click the New Master Motion Clip button and
select the five eagle clones.

The Global Object doesn’t appear in the Select
Object To Copy dialog because you designated
it as the object from which the clips are derived.

3. In the Synthesis Blend Parameters group, click
Auto Blend All.
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Auto Blend creates natural-looking transitions
between the clips. To see an example of the
results of Auto Blend, set From Clip to Glide
and To Clip to Flap. The blend from gliding to
flapping begins on the 80th frame of the Glide
clip.

4. Click Synthesize All.

This generates the animations for the clones.
You don’t have to solve the crowd simulation
unless you change delegate or behavior settings.

5. Turn off real-time animation playback in the
Time Configuration dialog and play back the
animation. Maximize the Perspective viewport
and zoom in.

Although the birds should flap their wings only
when they fly upward, and then stop flapping
to glide downward, it isn’t quite working that
way. The problem is that the clips are too long
for their matched states. For instance, a bird
might fly upward for only 50 frames, but the
animation clip for the Flap state is 187 frames
long. You’ll need to modify the clips.

You might wonder why we didn’t start with
a Global Object whose animation was set
up expressly for use with motion synthesis.
In a production environment, you might be
working with models containing animation
originally created for other purposes; in this
lesson, we’re attempting to simulate such
a situation. The Synthesis dialog lets you
specify exactly which frame ranges to use when
synthesizing motion from a Global Object’s
animation.

Examine the Block and Slave controllers:

Before you modify the clips, take a look at the
"behind the scenes" results of the synthesis process;
that is, the creation of block and slave controllers.

1. From the Graph Editors menu, choose Track
View - Dope Sheet.

2. In the hierarchy pane on the left side, expand
Global Tracks, expand Block Control, and then
expand Global Motion Clip::Eagle.

3. Scroll down or expand the Track View window
vertically so you can see a few of the Master
Motion Clip items.

In the track hierarchy, the global motion clip
from the Eagle object’s animation is the parent
to the master motion clips for the eagle clones.
Each master motion clip is a different sequence
of blocks, created during the synthesis process.
The Flap and Glide blocks are each a different
color.

4. Expand a Master Motion Clip to see the Flap
and Glide slave tracks. Expand a slave track to
see its keys.

5. Close Track View.

Modify the clips:

Examine the Global Object’s animation to see how
to improve the synthesis.

1. Click the Eagle object and drag the time slider
slowly.

The wing-flapping animation repeats four
times. The clip needs only part of one cycle,
though, because the clip controller can blend
between the last frame of one cycle and the first
of the next. The flap cycle should start with the
wings all the way up and end with the wings
slightly up.

2. Move the time slider back to frame 0 and
turn on Key Mode Toggle.

3. Click Next Key repeatedly while watching
the eagle object. Stop at frame 48.

The wing-flapping animation returns to the
initial wings-up position at frame 48.

4. Click Previous Key once.



Using Crowd with Animated Non-Biped Objects 655

The last key before the end of the flap cycle is
42. The Flap clip should go from frame 0 to
frame 42.

The glide cycle is different. Because there’s
no actual animation, you must make the clip
long enough to avoid generating too many
keyframes (as the result of repeating a short clip
many times to fill the state), while keeping it
short enough to fit within the state length.

For this lesson, you’ll set a glide-cycle length of
10 frames. In your own animations, experiment
to find a good length for different clips. Even
with animation clips, such as the wing-flap
cycle, you may need to scale or adjust the
animation so the cycle doesn’t exceed the
shortest length of a state.

Clip controllers perform spline interpolation
over the intersection of each pair of blocks
using keys within the blocks. To avoid this
interpolation altering the motion within the
clip, insert additional keyframes near the ends
of the motion. This makes the interpolation
occur at the extremes of the clip, rather than
over its entire length.

So, for the glide clip, you’ll move some keys
immediately inside each endpoint. These keys
are of Bend modifiers applied to the wings, and
have already been set to use linear interpolation.

5. With the master eagle still selected, find the key
at frame 205 of the track bar (the mini Track
View below the viewports).

6. Drag the key from frame 205 to frame 211.

It helps to watch the status bar text while you
do this.

7. Drag the next key from frame 228 to frame 212.

The key icon will overlap the icon of the key at
frame 211.

8. Drag the next key from frame 253 to frame 219.

9. Drag the next key from frame 270 to frame 220.

Enlarged view of track bar, showing keys at frames 211,
212, 219, and 220.

In the above illustration, the track bar has
been "zoomed in" for illustrative purposes by
shortening the active time segment. You’ll see
more overlap on your screen.

Now you have keys at frames 211 and
220 that define the clip ends, and keys
immediately inside the ends that can be used
for interpolation.

To change the clip lengths used for synthesis,
edit the global clip controller.

10.In the Crowd Global Clip Controllers rollout,
click the Eagle list item, and then click the Edit
button.

11.In the Global Motion Clips group, choose the
Flap list item, and then, in the From Global
Object group, click Modify.

12.Set the End parameter to 42, then click OK.

13.Modify the Glide clip to extend from frame 211
to frame 220.

Redo the synthesis:

1. On the Synthesis tab, in the Synthesis Blend
Parameters group, click Auto Blend All.

From Clip and To Clip now reflect the changed
clip lengths. Also, after the Auto Blend, the
Blend Start items change.

2. Click Synthesize All to apply the new clip
lengths to the states.

3. Close the dialog and play the animation.

Hide the Global Object and the delegates:

At this point you can hide the Eagle object and
the delegates. This makes it easier to see the
synthesized motion of the eagle clones.
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1. Use Select By Name to select all the
delegates and the Eagle object.

2. Right-click in the active viewport and choose
Hide Selection from the right-click menu to
hide the delegates and global object.

In this lesson, you worked with a global object
that was animated in place. All transformational
animation was supplied by the Crowd system. You
can also derive delegate motion from the global
object’s transformational animation, if it exists.

The Global Object’s animation wasn’t ideal for the
crowd simulation. You learned how to adapt an
animation so it works better in a simulation.

Animating Biped Crowds

Animating Biped Crowds

With 3ds Max, you can create both simple and
complex crowd scenes with bipeds and characters.
In this tutorial, you’ll learn to set up both types of
biped crowd simulations.

The first lesson covers a basic crowd scene setup;
the remaining lessons will show you how to
create multiple characters and use them together
in a sophisticated scene. Starting with a single
panda character, you’ll create several pandas of
different sizes and colors. Then you’ll make the
pandas move through the scene, following specific
behaviors while avoiding collisions with one
another.

To create the crowd behavior, you’ll need a
motion flow graph with multiple motion clips and
transitions. As it solves the simulation, the crowd
system will choose the best clips to apply to each
biped in the context of the scene.

In this tutorial, you’ll learn how to:

• Create a simple biped crowd scene

• Create several characters from one character

• Associate bipeds with delegates

• Fine-tune behaviors and settings for a crowd

• Create multiple BIP files for use in a simulation

• Troubleshoot a crowd simulation

Skill level: Intermediate

Time to complete: 2 hours

You can find the files for this tutorial in the
tutorials\character_animation\biped_crowds
folder on the Tutorial Files CD that ships with
3ds Max. Before starting the tutorials, copy the
\tutorials folder from the CD to your \3dsmax8
local installation.

In This Tutorial

Creating a Crowd of Swimming Bipeds (page
2–657)

Creating Character Families (page 2–660)

Associating Bipeds with Delegates (page 2–664)

Setting Up Behaviors (page 2–670)

Creating Multiple BIP Files (page 2–675)

Troubleshooting the Simulation (page 2–678)
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Creating a Crowd of Swimming
Bipeds

In this lesson, you’ll use a Surface Follow behavior
to make a crowd of swimming bipeds stay afloat as
they swim on an animated ocean.

Set up for this lesson:

• Open the scene swimming.max in tutorials\
character_animation\biped_crowdsdirectory.

This file has a plane with animated noise to
simulate ocean swells. It also has a crowd, a
delegate, and a biped ready for you to select.

You begin by cloning the biped.

Clone to create multiple bipeds:

You can clone a gang of bipeds from a single one
with Shift-Move.

1. On the Main toolbar, select biped1 from the
Named Selection Sets field.

2. Right-click in the viewport, and choose Move
from the quad menu.

3. Hold down the SHIFT key and move the biped
with the mouse, using the Transform gizmo. It
doesn’t matter where you move the biped.

The Clone Options dialog appears.

4. Set the number of copies to 5 and click OK. You
don’t have to change the Name field.

Five bipeds appear next to the original one.

Tip: You can also clone bipeds one at a time
using Edit menu > Clone.

Set up the behaviors:

1. Select the Crowd object.

2. On the Modify panel > Setup rollout >
Behaviors group, click New. Choose Surface
Follow Behavior from the pop-up menu and
click OK.

3. In the Surface Follow Behavior rollout, click the
None button, and then select the Plane01 object
in the viewport.

This defines Plane01 as the surface to follow.

4. In the Behavior group, click New again and add
a Seek behavior.

5. In the Seek Behavior rollout, click None, and
then select the green pyramid (Buoy) in the
viewport.

Scatter the delegates:

In this procedure, you’ll use the Scatter facility in
Crowd to clone the delegate and distribute the
clones.

1. In the Setup rollout, choose Scatter.

Some of the Scatter parameters are already set
up for you.

2. In the Clone panel, confirm that Object To
Clone is set to Delegate01.

3. Change the How Many setting to 5.

4. In the Position panel > Placement Relative To
Object group, verify that "Plane01" appears on
the button.

5. In the Rotation panel > Look At Target group,
choose Selected Object, then click the None
button and select Buoy from the list.

You have not yet generated clones or locations,
so there is only one delegate in the scene.



658 Chapter 8: Biped

You’ll use the All Ops panel to perform all
scatter-related operations simultaneously.

6. In the All Ops panel > Operations group, in the
Compute column, turn on Clones, Positions,
and Rotations, and then click the Scatter button.

The six delegates are now scattered on the
surface. Next, you’ll redistribute them using
random seeds.

7. In the Operations group, in the Inc Seed
column, turn on Positions and click Scatter
again.

This increments the random seed value. As
a result, the six delegates move to different
locations.

8. Keep clicking Scatter until you find a random
placement you like. Then click OK to exit the
dialog.

Tip: You can use this dialog to select and scatter
other objects in the scene. Click the Select
Objects To Transform button and select the
other objects.

Assign behaviors:

1. In the Setup rollout, click the Behavior
Assignments button.

2. Group the delegates into a single team.

This method is covered in the Using Multiple
Delegates and Behaviors (page 2–641) lesson in
the Animating Crowds (page 2–638) tutorial.

3. Assign the Seek behavior to the team.

Assignments are displayed in the window on
the right.

4. Click OK to close the dialog.

5. In the Solve rollout, click the Solve button.

The delegates seek the buoy for 100 frames and
then stop.

Tip: To Solve, you can either click Solve in the
Solve rollout, or press S with Plug-in Keyboard
Shortcut Toggle turned on.

6. In the Setup rollout, click Behavior
Assignments.

7. Assign the Surface Follow behavior to the team.

8. Close the dialog and solve again.

Now the delegates seek the buoy, but also follow
the surface.

9. In the Solve rollout, change the End Solve frame
to 160.

Associate the bipeds and delegates:

1. In the Setup rollout, click Biped/Delegate
Associations.

The Associate Bipeds With Delegates dialog
appears.

2. Below the Bipeds list, click the Add button.

3. In the Select dialog, click the All button and
then click Select.

4. Below the Delegates list, click the Add button.

5. In the Select dialog, click the All button and
then click Select.

6. Click the Associate button to connect the
bipeds and the delegates.

The dialog disappears, but nothing changes in
the viewport yet. There is more to set up before
the bipeds move to the delegate positions.

Create a Motion Flow file:

1. Select any part of any biped and open the
Motion panel.

2. Turn on Motion Flow Mode.

3. In the Motion Flow rollout, open the
Motion Flow Graph by clicking the Show Graph
button.
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4. In the Motion Flow Graph toolbar, click
Create Clip, then click in the graph window to
make a clip.

5. Right-click in the window to stop creating clips,
and then right-click the clip.

6. In the clip1 dialog, click the Browse button, and
then choose rtswimforward.bip.

7. In this file, frames 0 through 80 comprise a
cycle. In the clip dialog, change the end frame
to 80, and then click OK to close the dialog.

Based on the swimmer in the Creating a Simple
Freeform Animation (page 1–344) lesson, the
rtswimforward.bip file has been modified so
there is forward motion for the swimmer. The
delegate will take its forward speed from the
movement of the center of mass in the .bip file.

Tip: You can use Layers to add forward motion
to a .bip file. Create a new layer, animate the
Body Horizontal track, and then click Collapse
Layers.

8. In the Motion Flow Graph toolbar, choose
Create Transition From -> To.

9. Click the clip to loop the animation.

This animation can now be repeated to fill the
160 frames of the crowd simulation.

10. In the Motion Flow rollout, click Save File.

11.Name the file myswimloop.mfe and click Save.

You’ve just saved a motion flow editor file that
loops rtswimforward.bip.

12.Close the Motion Flow Graph dialog.

Create a shared motion flow:

1. In the Motion Flow rollout, click Shared
Motion Flow.

The Shared Motion Flows dialog appears.

2. Click New to create a new Shared Motion Flow.

3. In the Parameters group, click the “Load .mfe”
button and open the myswimloop.mfe file you
saved earlier.

4. Click the Add button, click All, and then click
Select.

All of the bipeds appear in the Bipeds Sharing
This Motion Flow group.

Note: If you get a message saying that some
biped legs are scaled incorrectly for shared
motion flow, click the button labeled Reset
Wrong Scales: Just Legs.

5. Click the Put Multiple Bipeds In Motion
Flow button, and then click OK.

Next, you designate the random start clip so the
crowd simulation can solve.

6. In the Motion Flow rollout, open the
Motion Flow Graph by clicking the Show Graph
button.

7. In the *SHARED* Motion Flow Graph
dialog, click Select Random Start Clips, and
then click the rtswimforward clip in the graph.

The clip is now displayed in purple with a
probability value of 100.

Since there is only one clip in this graph, it is
100 percent probable that this clip will be used
to start the simulation.

Normally, you would have to tell the delegate to
use the random start clip that you set here, but
this has already been done for you. You’ll learn
how to do this in the next lesson.

8. Close the *SHARED* Motion Flow Graph
dialog.

9. Select the Crowd object in the viewport.

10.In the Modify panel > Solve rollout, click Solve.

After a pause, the bipeds snap into position
over the delegate objects.
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11.When the solution is finished, play the
animation.

The bipeds are all swimming above the surface
of the water. This is because Crowd always uses
the default distance between the delegate and
the biped’s center of mass as an offset between
the two, even if the biped’s orientation has
changed from its original standing position.
You can correct this, allowing the bipeds to
swim on the water surface, by changing the
Offset value of the Surface Follow behavior.

Adjust the biped positions:

1. Select the Crowd object. On the Modify panel,
go to the Surface Follow Behavior rollout.

2. In the Position On Surface group, change the
Offset setting to 50.

3. Solve again.

The delegates are correctly offset 50 units below
the surface. But during the solution, the bipeds
are still above the water. This is because, for
optimal efficiency, Crowd doesn’t apply the
offset to bipeds associated with delegates until
after it solves the simulation.

Also, when the bipeds reach the buoy, they
don’t turn around to try to seek it again, but
just keep swimming in the same direction. This
is because the motion flow network, with its
single motion clip, doesn’t provide any means
for the bipeds to change direction. You will
learn a method for allowing bipeds to change
direction in the lesson Setting Up Behaviors
(page 2–670).

4. Play the animation.

The bipeds are swimming in the water.

Vary the animation:

If you want the bipeds not to swim in unison, you
need to vary the frame of the animation at which
each biped starts. You can do this by letting the

software choose a different, random start frame
from the motion clip for each biped.

1. On the Setup rollout, click the Multiple
Delegate Editing button.

2. In the Delegates To Edit group, add all the
delegates.

3. In the Biped group, to the right of the Value 1
and Value 2 columns, turn on Random and SET
for Start Frame.

When you turn on Random, the Value 2
parameter becomes available.

4. Change the Value 2 setting to a different frame
number, such as 8.

This means the software will start the
rtswimforward motion clip at a different,
random frame for each biped. For example,
one biped might start swimming at frame 0,
while another might wait until frame 4 to start
moving.

5. Click the Apply Edit button to make the
changes and exit the dialog.

6. Solve again, and then play the animation.

The bipeds no longer swim in unison.

Creating Character Families

In the next five lessons, you’ll develop a crowd
scene containing two families of panda bears
roaming around their environment. In this
lesson, you’ll set up one biped for each member
of the Black and Brown families, and scale them
accordingly to create a father, mother, and a child
panda.
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When creating a biped crowd scene, you will
need a number of characters. You can easily
create a number of similar characters from one
character. The resulting crowd members can be
slightly smaller or larger than one another, or have
different clothing, skin or hair color.

In this lesson, you’ll save each character separately
in its own file with a different biped and mesh
name, and create families by merging each one
into a scene with other characters.

Set up the lesson:

1. Load the file tut_black_papa.max.

This file contains a lone black-and-white
panda. From this panda, you will create a series
of six pandas with different biped and skin
names. Some pandas will be black and white,
while others will be brown and white.

2. Press H on the keyboard to display the names
of objects in the scene.

The panda biped is named Black_Papa_Biped,
while the panda mesh is named
Black_Papa_Skin.

3. Close the Select by Name dialog.

4. Save the file as my_black_papa.max.

To create more characters for the crowd scene,
you will save different versions of the black
papa bear.

Scale to create a new character:

1. Select the mesh, and change its name to
Black_Mama_Skin.

2. Select any part of the biped and go to
the Motion panel.

3. Turn on Figure Mode.

4. In the Structure rollout, change the biped’s
Height value to 110.

The skin changes size along with the biped.
This creates a slightly smaller version of the
bear, to represent the mama bear.

Note: In some situations, changing the biped’s
Height won’t scale the character uniformly. If
you have exclusively used envelopes for vertex
adjustments, and haven’t made any custom
vertex assignments with the Vertex sub-object
level, the method described here will scale the
character correctly.

5. Turn off Figure Mode.

6. In the Biped rollout, if necessary, expand the
expansion bar to see the Name field, and enter
the name Black_Mama_Biped.

Reposition the scaled character:

Now you’ll need to move the mama bear away
from its original location to prevent the bears from
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coming in on top of one another when they are
merged later on.

1. In the Track Selection rollout, click Body
Horizontal.

2. Turn on Auto Key and make sure that
you’re at frame zero.

3. In the Front viewport, move the mama bear’s
COM to the right of its original location.

4. Turn off Auto Key.

5. Save the scene to the file my_black_
mama.max.

Change and save the baby bear:

1. Select any part of the biped and turn
on Figure Mode.

2. In the Biped rollout, change the Name to
Black_Baby_Biped.

3. In the Structure rollout, change the biped’s
Height value to 60.

4. Turn off Figure Mode.

5. Turn on Auto Key and click
Body Horizontal. While at frame zero, move
the baby bear to the right of its original location.
Turn off Auto Key.

6. Select the mesh, and change its name to
Black_Baby_Skin.

7. Save the scene to the file my_black_baby.max.

Merge the family members to one file:

1. Choose File menu > Merge, and choose the
file my_black_mama.max. If you didn’t create
this file, you can choose tut_black_mama.max.
Choose all objects in the merged scene, and
click OK to merge them. When you see the

message regarding the duplicate material name,
click Use Scene Material.

If the mama bear comes in on top of the baby
bear, use the method described in earlier
procedures to move them apart.

2. Merge the file my_black_papa.max or
tut_black_papa.max. Merge all objects in the
file. If necessary, move the bears apart by using
the above procedure to reposition the scaled
character.

You have just created a family of
black-and-white bears.
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3. Save the scene as my_black_family.max.

Create a family of brown bears:

1. Open the Material Editor.

The multi/sub-object material Black Panda has
two sub-materials, Black and White. You will
change the black material to a brown material
to create brown-and-white pandas.

2. In the material Black Panda, click the color
Black. On the sub-material Black, change the
Diffuse color to brown, and change the name of
the material to Brown.

Tip: To make the color brown, create a dark
red-orange color such as RGB:[95,79,38].

The color changes on all the pandas. Now you
have a family of brown-and-white pandas.

3. Click Go to Parent on the Material Editor
toolbar, and change the multi/sub-object
material name to Brown Panda.

4. Select the papa bear biped, and change its Name
in the Biped rollout to Brown_Papa_Biped.

5. Select the papa bear mesh, and change its object
name to Brown_Papa_Skin.

6. Change the mama bear biped name to
Brown_Mama_Biped, and the mesh name to
Brown_Mama_Skin.

7. Change the baby bear biped name to
Brown_Baby_Biped, and the mesh name to
Brown_Baby_Skin.

8. Turn on Auto Key. For each
biped, click Body Horizontal, and move the
bears forward from their original locations.
Turn off Auto Key.

This will prevent the black bears from merging
in on top of the brown bears in the next
procedure.

9. Save the scene as my_brown_family.max.

Merge all the bears:

1. Choose File menu > Merge, and merge the file
my_black_family.max or tut_black_family.max
into the current scene.

If necessary, move the bears apart.

These two families of bears will be used to set
up a biped crowd simulation in the lessons that
follow. The family will be easier to work with if
the meshes are hidden.

2. Select all six skins.

3. Right-click one of the skins, and choose Hide
Selection from the quad menu.
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4. Save the scene as my_families.max.

You can find a finished version of this lesson in
the file tut_families.max.

With this technique of creating character
families, the key is to name each biped, skin
and material differently. When you merge the
characters together in a scene, there will be
no difficulties with duplicate object names or
materials, and you’ll know the names of each
character’s biped and skin.

Associating Bipeds with Delegates

In this lesson, you’ll associate each biped in the
Brown and Black families with its corresponding
delegate. You’ll also set up a motion flow graph so
each character can choose from the same batch of
motions over the course of the simulation.

The behaviors in the crowd simulation are set up
to make the delegates wander around a camp,
seeking the center of the camp and other members
of their families.

This series of lessons assumes a basic knowledge of
the crowd and motion flow systems. If you haven’t
done the tutorials Animating Crowds (page 2–638)
and Using Motion Flow (page 2–606), do these
tutorials before proceeding.

Set up the lesson:

1. Load the file tut_biped_crowds01.max.

This file contains a crowd scene with six
delegates and a ground plane. The delegates
on one side represent the Black family, while
the others represent the Browns. At the center
of the ground plane is a box that represents the
center of the pandas’ camp.

2. Select the Crowd helper, and go to the Modify
panel.

3. On the Setup rollout, click Behavior
Assignments. The Behavior Assignments and
Teams dialog appears.

Behaviors have been set up to make the mama
and baby bears seek their respective fathers,
who wander from time to time. They all seek
the box in the center to a small degree, which
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keeps the delegates from wandering too far
away from the camp. An Avoid behavior
prevents collisions between all delegates.

4. Click OK to close the Behavior Assignments
and Teams dialog.

5. Play the animation.

Even though there are no bipeds in the scene
yet, the simulation has been solved with just the
delegates. The two sets of delegates alternately
mingle in the center and wander off as a family
group.

Tip: It’s a good practice to test the
simulation with delegates only, to ensure the
behaviors are all working correctly. A common
error is to test behaviors with delegates
moving at high speeds that do not accurately
approximate the speed of biped movement.
Test the behaviors with the delegates’ average
speed similar to speed the bipeds will use. You
can change all the delegates’ average speed by
selecting the Crowd helper, and clicking Modify
panel > Setup rollout > Multiple Delegate
Editing. In this simulation, the average delegate
speed is 2 units per frame.

Merge the characters:

• Choose File menu > Merge, and choose the
file my_families.max. If you didn’t create
this file in the previous lesson, merge the file
tut_families.max. Choose all objects in the
scene for merging.

The families of pandas have been merged into
the scene. The bipeds are visible, but the skins
have been merged as hidden objects.

Pair up bipeds and delegates:

1. Select the Crowd helper.

2. On the Modify panel, in the Setup rollout,
click the Biped/Delegate Associations button .

3. Beneath the Bipeds list, click the Add button.
Select all the bipeds in the scene.
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The selected bipeds display on the dialog in
alphabetical order. You want the papa biped to
be listed first for each family.

4. Highlight Black_Papa_Biped, and use the up
arrow button at the center of the dialog to move
that biped to the top of the list. Use the same
technique to move Brown_Papa_Biped to the
fourth position, above the two other Brown
family bipeds.

5. Beneath the Delegates list, click the Add button.
Select all the delegates.

6. Make sure the Make Specified Associations
option is selected.

This will associate each biped with the delegate
directly across from it on the list.

7. Make sure Set Delegates to Use Biped is turned
on.

This option will turn on the Use Biped option
for each delegate in the scene, which will make
it possible to create a biped crowd simulation.

8. Click the Associate button to associate the
bipeds with delegates.

9. Save the scene as my_biped_crowds02.max.

Although each biped is now associated with its
respective delegate, the bipeds are not aligned
with delegates. This will happen later once you
solve the simulation for the first time. Before
you can solve the simulation, however, you’ll
need to set up a motion flow graph.

Set up a motion flow graph:

You’ll set up a motion flow graph that they’ll all
share, also known as a shared motion flow. When
solving a simulation with delegate-controlled
bipeds, Crowd uses this graph to synthesize
motion flow scripts for the bipeds. The motion
is shared, but Crowd typically generates a unique
script for each biped, depending on the behaviors
influencing its delegate. This process is motion
synthesis.

Tip: Before creating the motion flow graph,
you might find it helpful to look at each of the
clips to see what they contain. To do this, reset
3ds Max, create a biped, and load each clip listed
in step 5 by clicking Load File on the Biped
rollout. Watch the motion contained in each
clip. When you have finished looking at the
motions, reload my_biped_crowds02.max or
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tut_biped_crowds02.max, and continue from this
point.

1. Select any part of one of the bipeds, and go to
the Motion panel.

2. Click the Motion Flow Mode button.

3. In the Motion Flow rollout, turn on the
Show Graph button.

This opens an empty motion flow graph. As
a first step in creating the motion flow graph,
you’ll add all the necessary clips.

Note: If you like, instead of creating the
motion flow graph from scratch, you can
click Load Motion Flow Graph and load the
file panda_crowd.mfe file included in the
tutorials\character_animation\biped_crowds
folder. If you do, the Reset Unfound Motion
Flow File dialog might appear to ask you
for the location of the first clip referenced
by the graph. If this occurs, navigate to the
tutorials\character_animation\biped_crowds
folder under your 3dsmax path, turn on Add
Directory to Search Path and Add Directory
to .ini File, and choose the first file requested.
The remaining clips will be located in the same
folder, and the graph will load. If you do this,
skip this procedure and the next, and continue
with the “Choose starting clips” procedure to
ensure starting clips are selected.

4. On the Motion Flow Graph dialog toolbar,
click the Create Multiple Clips button.

5. Navigate to the tutorials\character_animation\
biped_crowds directory in your 3ds Max path,
and open the following files.

Tip: You can select multiple files in the Open
dialog by using the SHIFT or CTRL keys.

• panda_walk.bip

• panda_walk_fast.bip

• panda_walk_slow.bip

• panda_walk_L45.bip

• panda_walk_R45.bip

• panda_walk_L90.bip

• panda_walk_R90.bip

• panda_walk_L135.bip

• panda_walk_R135.bip

• panda_walk_180.bip

• panda_loiter.bip

In the Motion Flow Graph, the software
creates a clip for each file.

Each clip’s file name describes its motion.
For example, panda_walk_L90 has the
biped make a right-angle turn to the left
while walking, and panda_walk_180 has the
biped turn around and walk in the opposite
direction.

Tip: Numerous clips are needed to give the
bipeds enough options to avoid one another
during the simulation. The more clips you
have, and the greater the variety of clips,
the more choices the bipeds will have. In
general, a minimum of eight clips is needed
for an effective biped crowd simulation.
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6. If you like, use the Move Clip tool to
rearrange the clips in the graph in a circular
arrangement.

Tip: The arrangement of clips in the graph
does not affect the simulation, but it can help
you see your graph more clearly. For this
graph, a roughly circular arrangement with
panda_walk.bip, panda_walk_fast.bip, and
panda_walk_slow.bip at the top will make it
easy to see all the clips and transitions, and to
choose starting clips.

Create a motion flow network:

A motion flow network is a series of connections
between clips. When the crowd simulation solves,
it will choose a series of clips for the biped to
follow. Transitions between clips tell the crowd
simulation that one clip can follow another in the
series.

1. On the Motion Flow Graph toolbar, click
Select Clip/Transition.

2. Draw a selection region around all the clips to
select all of them.

3. Click Create All Transitions. When you
are asked if you want to create transitions from
each clip to itself, click Yes.

Transitions are created between all clips, and
between each clip and itself.

The number 100 appears next to each transition
to indicate the probability of each transition
being chosen during the transition.

Tip: You can toggle the probability display
by clicking Show Random Percentages.

Next, you will optimize the new transitions.
This will change each default transition to the
best possible transition for each pair of clips.

4. Draw a selection region around all clips
and transitions to select them. Click Optimize
Transitions. Accept the default values and click
OK. Wait a few moments while transitions are
optimized.

Choose starting clips:

Next, you must designate the possible starting
clips for the simulation.

Note: If you loaded the motion flow graph
panda_crowd.mfe instead of creating the graph
from scratch, the starting clips might or might not
be selected depending on whether the system had
to look for clips upon opening the graph. In this
case, use this procedure to ensure the starting clips
are selected.
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1. In the toolbar at the top of the Motion
Flow Graph dialog, click the Select Random
Start Clips button. Hold down the CTRL key
and choose panda_walk, panda_walk_fast,
panda_walk_slow, and panda_loiter.

The selected clips are displayed in purple with
a probability value (100). This means there
is an equal probability that any one of these
clips will be selected as the starting clip for the
simulation.

The selection of panda_loiter as a possible
starting clip means a biped can start the
simulation by standing and waiting for other
bipeds to pass by before it starts moving.

Next, to share the motion flow network among
all the bipeds, you need to save it and then
reload it with the Shared Motion Flow dialog.

2. On the Motion panel, In the Motion Flow
rollout, click the Save File button. Save the
motion flow network as my_panda_crowd.mfe.

Next, you’ll set up a shared motion flow.

Set up a shared motion flow:

The motion flow graph must be “shared” among
all bipeds. For the best results, each biped sharing
the motion should be of the same scale. The black
and brown fathers are the same size, as are the

two mothers and two children. You’ll create three
separate motion flows, pairing up father, mother,
and child bipeds.

1. In the Motion Flow rollout, click the
Shared Motion Flow button.

2. In the Shared Motion Flow dialog, click the New
button to add a shared motion flow, and change
its name from SharedMoFlow0 to Fathers.

3. In the Shared Motion Flow dialog, click the
Add button, and use the Select dialog to add
Black_Papa_Biped and Brown_Papa_Biped to
the shared motion flow.
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4. In the Parameters group, click the Load .MFE
button, and open the my_panda_crowd.mfe
file you saved previously. Wait a few moments
while the graph loads.

5. Click Put Multiple Bipeds In Motion Flow.

This turns on Motion Flow mode for the bipeds
listed in the dialog. Bipeds must be in Motion
Flow mode in order to work with a crowd
simulation.

6. Click OK to close the dialog.

Set up the remaining shared motion flows:

1. Click Shared Motion Flow again.

2. Click New to create another shared motion
flow named Mothers, and apply it to
Black_Mama_Biped and Brown_Mama_Biped.
Put these bipeds in Motion Flow mode, and
click OK to close the dialog.

3. Click Shared Motion Flow again.
Create another shared motion flow named
Children, and apply it to Black_Baby_Biped
and Brown_Baby_Biped. Put these bipeds in
Motion Flow mode.

4. Click OK to exit the dialog.

The Shared Motion Flow button appears
with a white circle, indicating that the currently
selected biped is part of a shared motion flow
network.

5. Close the motion flow graph, if it is open.

6. Save your work as my_biped_crowds03.max

Setting Up Behaviors

In this lesson, you’ll work with biped settings and
behaviors to make the simulation solve correctly.

Set up this lesson:

• Open the file my_biped_crowds03.max that
you created in the previous lesson, or open
tut_biped_crowds03.max..
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This file contains the scene from the previously
completed lesson.

Set delegates to use random start clips:

You can specify that biped/delegates should
use either the first clip of the current script or a
random start clip setting. When you first solve this
simulation, none of the bipeds will have scripts, so
you must choose the second option.

1. Select the Crowd helper in the viewport.

2. In the Modify panel > Setup rollout, click
Multiple Delegate Editing.

3. In the Edit Multiple Delegates dialog >
Delegates To Edit group, click the Add button.

4. In the Select dialog, click All and then Select.
This selects all delegates for editing.

5. In the Biped group, choose Random Start Clip
and turn on its SET check box.

Turning on SET indicates that this new setting
should take effect when you click Apply Edit.

6. Click the Apply Edit button at the bottom of
the dialog.

Solve the simulation:

• In the Modify panel > Solve rollout, click the
Solve button.

After a few moments, each biped moves to its
respective delegate, and begins to walk through
the simulation.

Tip: You can speed up the solution process
significantly by increasing the Solve rollout
> Display During Solve group > Frequency
setting to a higher number such as 20 or 50.
This will update viewports less frequently
during the solution process. For even faster
solution calculation, you can turn off Update
Display, but you will not be able to see the
solution until it is complete.
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The bipeds move toward and away from the
center, as the delegates did earlier. However,
they tend to cluster at the center. The fathers
don’t wander very much from the center, and
the other bipeds follow them.

This is a common situation with biped crowds.
Often, the behavior settings for delegates alone
are not exactly right for a biped simulation. You
will change the behaviors slightly to suit the
bipeds.

There is an additional problem that the bipeds
pass through one another. You will solve this
problem after you get the behaviors working
correctly.

Tip: All the clips in this simulation contain
freeform animation, rather than footsteps.
Freeform and footstep clips work equally
well in a biped crowd simulation. However, a
simulation that uses footstep clips will display
all the footsteps used by each biped, which can
clutter viewports and make it difficult to see
what’s going on in the scene. For this reason,
freeform clips were used for this simulation.
The clips actually started out as footstep clips,
but were converted to freeform animation by
loading the clip on a biped and clicking Convert
on the Motion panel > Biped rollout.

Adjust the behaviors:

1. Select the Crowd helper.

2. On the Modify panel > Setup rollout >
Behaviors group, choose the Wander behavior.

In the Wander Behavior rollout, the Period
value sets the number of frames during which
the delegate or biped should wander. Then the
biped or delegate ceases wandering, and follows
other behaviors in the simulation.

When using the Wander behavior with biped
crowds, the Period should be set to slightly
longer than the average clip length. This gives
the simulation enough time to choose an entire
clip for the wandering period. Most clips in this
simulation are about 90 frames long.

3. In the Wander Behavior rollout, change the
Period value to 100.

To keep the father bipeds from clustering at the
center, you can also reduce the weight of the
behavior that causes them to seek the center
box.
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4. In the Setup rollout, click Behavior
Assignments.

5. In the Behavior Assignments area, highlight
the Seek Center Box behavior assigned to the
Fathers team, and change the Weight value at
the bottom of the dialog to 0.01. Click OK to
close the dialog.

This lower weight setting will make the father
bipeds less likely to seek the center box, and
more likely to wander.

6. In the Solve rollout, click Solve.

This time, the activity in the scene is more
varied. The bipeds approach the center, walk
away from the center, and come back, which
is similar to the original movement of the
delegates alone.

However, the bipeds don’t always avoid each
other successfully; at times, they pass through
one another. This happens because directional
changes indicated by the delegate behaviors can
be overridden by the motion clips guiding the
biped animation. To avoid collisions, the biped
motion must take precedence.

Set priorities:

To resolve the problem of biped collisions, you
can set priorities for bipeds. This approach causes
the crowd system to solve one biped’s motion at
a time. As each biped’s motion is determined,

subsequent bipeds can accurately predict the
location of bipeds solved earlier, and choose clips
in such a way that collisions will be avoided.

1. Go to frame 0.

The Browns, the three delegates at the top of the
Top viewport, will have priority over the Blacks.

2. Select the Crowd helper.

3. On the Modify panel, at the bottom of the
Priority rollout, turn on Display Priorities.

In the viewport, each delegate displays the
number 0. By default, the Priority value 0
is assigned to all delegates. You can change
Priority assignments manually, picking
delegates in the appropriate order.

Note: Delegates with lower Priority values take
precedence over those with higher values. Thus,
for example, a delegate with Priority 0 goes
before a delegate with Priority 1, and so on.

4. In the Priority rollout > Assign By Picking
group, click the Pick/Assign button.

When this mode is turned on, you can pick
only delegates in the scene.
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5. In the Top viewport, click the rightmost
delegate in the top group.

By default, you assign a Priority value of 0 to the
first delegate you pick, so the number doesn’t
change.

6. Pick the delegate to its left.

The Priority value 1 appears next to the
delegate.

7. Continue to pick delegates in a
counter-clockwise manner, ending with
the rightmost delegate at the bottom of the Top
viewport.

The Brown family members now have priorities
0, 1, and 2, while the Blacks have 3, 4, and 5.

8. Right-click in the viewport to turn off
Pick/Assign.

Tip: If the priority numbers are obscured by the
bipeds, you can check the priority assignments
by selecting each delegate and checking its
Priority value at the bottom of the Modify
panel. If you do so, select the Crowd helper
again before continuing.

To enable Crowd to use priorities, you must
turn the feature on.

9. In the Solve rollout > Bipeds group, turn
on Biped/Delegates Only, Use Priorities and
Backtracking.

Solve the simulation:

1. In the Modify panel > Solve rollout, turn on
Update Display if it’s turned off.

Note: If you are concerned about system
performance, you can turn off Update Display
for faster solution calculation.

2. Set Frequency to 20.

3. Click Solve to start the solution.

This time, because Use Priorities is on, the
solution proceeds one biped at a time. First, the
Brown father heads toward the center, and then
his child and wife join in, one at a time. During
each subsequent sub-solution, you can see the
previously solved delegates moving without
their bipeds. Next, the Black father takes his
turn, followed by the mother and child.

At certain points during the solution
calculation, you will see the time slider jump
back to an earlier frame. This occurs when the
system uses backtracking to avoid collisions.

When the crowd system can’t find a way to
avoid a collision, and returns to the previous
motion clip to try a different path through the
motion flow network. If the crowd system can’t
avoid a collision by jumping back one clip, it
jumps back again to look for a better path, and
so on. You can see the time slider jump back
during backtracking even when the Update
Display option is turned off.

Tip: In a crowd simulation with more bipeds,
you can also help prevent collisions by setting
different start frames for each delegate. For
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example, delegates closer to the center of the
scene can start moving before delegates farther
away. You can set start frames individually for
delegates by selecting a delegate and changing
the Start Frame value on the Modify panel, or
you can set them all at once by selecting the
Crowd helper and clicking Modify panel >
Priority rollout > Set Start Frames.

4. Save your work as my_tut_biped_
crowds04.max

Creating Multiple BIP Files

In this lesson, you’ll learn how to create a different
motion clip from an existing clip so you can use it
in a motion flow network. You’ll take an existing
motion clip and convert it from freeform to
footstep animation. Then you’ll alter the motion
somewhat, convert it back to freeform animation,
and insert it as a new clip into the shared motion
flow network.

Set up this lesson:

• Open the file my_biped_crowds04.max that
you created in the previous lesson, or open
tut_biped_crowds04.max.

In the previous lesson, you might have noticed
that some of the turns taken by the panda
characters seem too extreme. That’s because the
bipeds are limited to the motion clips available
to them in the motion flow network. For best
results in your biped-based crowd simulations,
provide as many different appropriate motion
clips as possible.

Examine an existing motion clip:

1. Load tut_black_papa.max.

The original black-and-white panda stands
motionless in the scene.

2. Select any part of the biped and go to
the Motion panel.

3. From the Biped rollout, click Load File
and load panda_walk.bip. Play the animation.

The panda takes several steps in a straight line.

This motion consists entirely of freeform
animation. In general, it is easier to use
freeform clips in a crowd simulation because
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they minimize clutter in the viewports.
However, for editing motion data, it is much
easier to work with the motion if you convert it
to footsteps first.

Convert freeform animation to footsteps:

1. In the Biped rollout, click Convert. The
Convert to Footsteps dialog opens.

Note: The state and name of this dialog varies
depending on whether the biped already
contains either freeform or footstep animation.

2. Make sure that Flatten Footsteps to Z=0 is
turned on, and Generate a Keyframe per Frame
is turned off. Click OK.

3. If footsteps don’t appear in viewports,
click the expansion bar on the Biped rollout to
unhide the Display Group, and click the Show
Footsteps.

The converted freeform animation now appears
as a simple series of editable footsteps.

Edit the footsteps:

1. In the Biped rollout, turn on Footstep
mode.

2. In the Top viewport, select all footsteps except
the first one, footstep 0.

3. In the Footstep Operations rollout, change the
Bend parameter to 10.0.

In the Top viewport, you can see the footsteps
bend subtly to the left. The biped updates to
reflect the edited footsteps.

Now, you’ll convert the edited footsteps back to
freeform animation and save the motion as a
separate motion clip.
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Convert footsteps to freeform animation:

1. Turn off Footstep mode.

2. Click Convert to open the Convert to
Freeform dialog.

3. Make sure that Generate a Keyframe per Frame
is turned on, and click OK.

The edited footstep motion is converted back
to freeform animation.

4. In the Biped rollout, click Save
File, and save the motion clip as
my_panda_walk_L10.bip.

Modify the motion flow network:

Next, you’ll modify the motion flow network by
adding the new moderate turn motion. You’ll then
create additional transitions between the new clips
and the existing clips.

1. Re-open the file my_biped_crowds04.max that
you created in the previous lesson, or open
tut_biped_crowds04.max.

2. Select any part of any biped.

3. Open the Motion panel. On the Biped
rollout, make sure that Motion Flow Mode is
turned on.

4. On the Motion Flow rollout, click Show
Graph.

5. On the Motion Flow Graph toolbar, click
Create Clip. Click in an empty place near the

bottom of the graph to place an empty clip.
Right-click an empty part of the graph to turn
off Create Clip mode.

6. Right-click the new clip in the graph. The Edit
Clip dialog opens.

7. In the Edit Clip dialog, click on Browse and
open the panda_walk_L10.bip motion file.
Click OK to close the Edit Clip dialog.

8. Draw a selection region around all clips
and transitions to select them, and click Create
All Transitions in the Motion Flow Graph
toolbar. Click Yes on the dialog that appears.

Transitions are created between the new clip
and all other existing clips.

9. In the Motion Flow rollout, click the Save
File button. Save the motion flow network as
my_panda_crowd_multiple.mfe. Close the
Motion Flow Graph
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10.Select the Crowd object, go into the Modify
panel, and solve the simulation again.

The new motion clip is intergrated into the
crowd motion.

Save your work as my_biped_crowds05.max

In your work with the panda crowd simulation,
you might have noticed that the baby pandas don’t
walk properly. This sometimes occurs when clips
made for a specific biped (such these clips, which
were made for the father panda) are used with a
different-sized biped.

You can solve this problem by loading each motion
clip onto the baby panda, and working with the
motion to make it work for that biped. You would
then create a new motion flow network with the
new clips, and apply it to the baby pandas in the
crowd scene.

When working with the motion clips, you might
have to deactivate footsteps and create new keys
for them. If you create new keys for the footsteps,
you will lose the arm motion currently in the
clip. To keep the arm motion, copy the biped arm
motion to a track before working with footsteps,
then paste the arm tracks back to the biped before
saving the BIP file.

To see another version of the crowd simulation
that uses different clips and a new motion
flow network for the baby pandas, load the file
tut_biped_crowds06.max.

Troubleshooting the Simulation

To see the results of the motion synthesis, you can
check each biped’s motion flow script.

Set up the lesson:

• Open the file my_biped_crowds05.max that
you created in the previous lesson, or open
tut_biped_crowds05.max.

This file contains the scene from the previously
completed lesson.

Check the results:

1. Press H on the keyboard. Select any available
part of a biped, and then go to the Motion
panel.

2. In the Motion Flow Script rollout, scroll
through the script.

Their scripts show the sequence of clips used for
a specific biped’s movement in the simulation.
The script is generated when the simulation is
solved.

3. Select another biped, and look at its script.

Each uses a different sequence of walking and
turning clips to move through the scene.

In addition to the techniques you learned in this
tutorial, there are many other ways to improve
a crowd simulation.

If the crowd simulation isn’t working at all:

• Try removing all behaviors but one (such as a
Seek behavior) and solving the simulation. If
the bipeds follow that one behavior just fine,
then the problem is with one or more of the
other behaviors; add the behaviors back one at
a time, and solve each time to determine which
behavior is causing the problem.
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• If the bipeds don’t follow that one behavior,
then the problem is with the clips. Try adding
more varied clips to the shared motion flow.
Bipeds can only follow the clips they have in the
graph. For example, if all clips move the bipeds
straight forward, they will not be able to turn to
avoid other bipeds or obstacles in the scene.

• To see exactly where a problem is occurring,
turn on Update Display in the Solve rollout, and
set Frequency to a low number such as 5. This
will update the display every 5 frames. Watch
the simulation as it solves, and look for problem
areas, such as places where bipeds collide or go
somewhere they shouldn’t. This will help you
spot which behavior is causing the problem.

If collisions occur at the start of the simulation:

• If delegates are placed too close together at the
start of the simulation, the simulation won’t
detect potential collisions at the start. This
happens because the Avoid behavior checks
to see if a collision between delegates is going
to occur; that is, if two bipeds’ hard radii will
intersect at some frame in the future, not if
it has already occurred. You can solve this
problem by moving delegates farther apart at
the start of the simulation so their hard radii
don’t intersect. Remember that if you move a
delegate, the biped won’t align with the delegate
until you solve again.

• Try adding additional random start clips to the
graph. This will give the crowd system more
choices when starting the simulation.

• Move delegates at frame 0 to allow more time
for transitions.

If collisions occur during the simulation:

• Increase the Avoid behavior’s Hard Radius to a
higher number, and solve again.

• You can also try changing the Priority and Start
Frame values for individual delegates to keep

bipeds from colliding. You can change these
values individually by selecting the delegate and
going to the Modify panel, or with the tools on
the Crowd helper > Modify panel > Priority
rollout.

If one or more bipeds can’t find a solution even with
backtracking:

• Decrease the Hard Radius value on the Avoid
behavior, and solve again. If the Hard Radius is
too high, bipeds will have nowhere they can go
without detecting a collision.

• Make motion clips as short as possible, so the
crowd system doesn’t have to back up too far
when backtracking.

• You can also change transition probabilities in
the motion flow graph to make some clips more
likely to be used than others.

General tips for working with biped crowds:

• Use freeform clips rather than footsteps to
prevent viewports from becoming cluttered
with footsteps.

• After the simulation is complete, you can select
a biped and scroll through its script on the
Motion Flow rollout. This will tell you if some
clips are being used more than others, and can
give you clues about which clips should be
added to give the bipeds more variety to choose
from.

• When creating a simulation for a large number
of bipeds, a common workflow is to place the
camera in such a way that some bipeds aren’t
visible at the very start or end of the simulation.
For example, if you have set the Start Frame
for some delegates to a frame later than the
simulation start, these delegates and bipeds
won’t move until their Start Frame comes up.
The delegates and camera should be placed in
such a way that these bipeds are "offscreen"
until they move into view.
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• You can use more than one motion flow graph
in a scene. For example, you could have one
graph with running motions, and another with
walking motions. In this way, some bipeds
could run around the scene while others walk.
Each biped can use only one graph.



Reactor

Introduction to Reactor

This tutorial will lead you through the process of
creating a physically based animation using the
reactor dynamics functionality built into 3ds Max.

There are many situations in animation where
hand animating and creating keyframes for
objects can be completely replaced; or at the very
least, augmented, by using keyframes created
automatically using physical techniques. For
instance, imagine trying to hand-animate a

thousand balls being poured out of a bucket; you
would need to make sure that no two objects
passed through each other during the simulation,
and that they behaved realistically when colliding
with each other and the environment. With
reactor, however, you can produce the same
animation by just creating a bucket and a thousand
spheres, providing each object with physical
properties such as mass. Once you have set up
the objects’ positions, the rest is calculated for you
automatically.

In this tutorial, you will use the reactor
functionality to create a toy with a low center of
gravity. You will then create copies of the toy, and
use the Preview Window to add them to a toy
box and update the objects’ positions in 3ds Max.
Next, you will hand-animate the box turning
over. The dynamics functionality will solve the
animation for the toys, taking into account the
hand-animated box; the toys will react to the box’s
motion and pour out onto the floor.

Skill Level: Intermediate

Time to Complete: 90 minutes

Features Covered in This Tutorial

In these lessons you will learn:

• Creating rigid body collections.

Dynamics
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• Creating simulations with reactor.

• Controlling simulation accuracy.

• Using hand animated objects with reactor.

• Creating fractures with reactor

Tutorial Files

You can find the files for this tutorial in the
tutorials\reactor\introduction folder on the
Tutorial Files CD that ships with 3ds Max. Before
starting the tutorials, copy the \tutorials folder
from the CD to your \3dsmax8 local installation.

Rigid Bodies Make the World Go
Round

The objects in a reactor physical simulation; in
this example, the toys, the toy box, and the floor,
are known as rigid bodies. These are the building
blocks of physical scenes, and can be made up
of one or more geometries. You can use any
geometry to create a rigid body.

In this section, you will create two simple primitive
objects that can be used as rigid bodies, and assign
them some physical properties.

Create a rigid body:

1. Start with a new scene in 3ds Max.

2. On the Create panel, click Sphere.

3. In the Perspective viewport, drag to create a
sphere. On the Create panel, set the radius to
25.0.

4. On the Create panel, click Box.

5. Drag in a viewport to create a box beneath the
sphere. On the Create panel, set the Length and
Width values to 200.0 and set Height to 5.0.

Note: Move the box down to make sure it is not
touching the sphere.

Now you need to give your sphere some
physical properties.

6. Select the sphere, and on the reactor
toolbar, click Open Property Editor.

As you have not assigned any physical
properties to the sphere yet, the dialog displays
the default values.

Note: If you don’t have an object selected in
the scene, or if you select an item that cannot
be used as a rigid body (such as a rigid body
collection), the parameters in the dialog will
be grayed out.

7. Look at the editor’s Physical Properties rollout.

The default value for Mass is 0.0, which means
that the rigid body is fixed in space during
the simulation. However, in this example, the
sphere is going to drop onto the box, which
will act as the floor in your simulation. For
this reason, you need to give the sphere a mass
value. Set the Mass to 50.0.



Getting Collective 683

8. If you do not specify any physical properties for
an object, it will automatically use the default
rigid body properties when simulated. Since
you don’t want the box to move in this example,
the default properties are sufficient for this
object. It uses the default Mass value of 0.0, and
will therefore be fixed in space.

You now have two objects with physical properties.
However, your scene is still not valid for
simulation. The objects must be explicitly added
to the simulation using Rigid Body Collections.

Getting Collective

If you have a valid rigid body and you want to
simulate it, you need to add it to a rigid body
collection. At the start of a simulation, the
scene is examined for all enabled rigid body
collections. The rigid bodies are then taken from
the collections and added to the simulation. In
this example, you will create a collection and add
the sphere and box to it in order to add them to
the simulation.

Note: You can continue using your file or
you can open reactor_intro_1.max from
\tutorials\reactor\introduction.

Create and add objects to a rigid body collection:

1. On the reactor toolbar, click Create Rigid
Body Collection.

Note: Rigid Body (RB) Collections are helper
objects, used to keep track of the rigid bodies
in your scene. They will not show up in
renderings, and their position has no effect on
your scene.

2. Click any viewport to add the collection to your
scene.

Note: The icon’s position has no effect on the
simulation.

3. On the Modify panel, in the RB Collection
Properties rollout, click Pick, and select the box
in the viewport.

This adds the box to the rigid body collection.

Note: You can also add objects to the collection
with the Add button, as in the following step.

4. Click Add. This opens a standard selection
dialog that contains a list of the remaining
available rigid bodies in the scene.

Note: If you want to remove a rigid body from
the collection, select it in the Rigid Bodies list
and click Delete.

5. From the list, choose the sphere, then click
Select to close the dialog and add the sphere
to the collection.

Tip: A useful shortcut for creating RB
Collections is to select the objects before you
create the collection. If you select several
objects and click Create Rigid Body Collection,
an RB Collection is created which already
contains the selected objects.

The Basics of Simulation

Now that you have a valid scene for simulation,
you can try simulating it. There are two methods
for simulating animation.

The first uses a preview window that displays
your simulation using OpenGL or DirectX. You
can examine your objects’ physical behavior in
the window, see how they interact, and even use
the mouse to interact with the scene. You can use
this window to update the rigid bodies’ states in
3ds Max at any time during simulation, which
means that it acts as an interactive scene modeler.

The second method is keyframe creation. You
define an animation range, and the physical
world is created and simulated across that range,
passing the rigid bodies’ states back to 3ds Max
as keyframes.
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Note: You can continue using your file or
you can open reactor_intro_2.max from
tutorials\reactor\introduction.

Examine your scene in the preview window:

1. On the reactor toolbar, click Preview
Animation.

This will open your scene in a preview window.
By default, your scene is initially displayed from
the Perspective view. You can use the left mouse
button to rotate the camera, the middle button
to pan, and the scroll wheel to zoom.

2. To start your simulation, choose Play/Pause
from the Simulation menu in the window, or
press P on your keyboard. Your simulation will
start and the sphere will fall onto the box.

You can use your right mouse button to drag
the sphere around the scene. However, you
cannot move the box, as it has no mass.

Note: You can press R to reset the simulation.

3. When you’re finished exploring your
simulation, close the preview window and
return to 3ds Max.

Create physically-based keyframes:

Next, you will create keyframes for the objects’
interaction. A sphere falling onto a level box isn’t
very engaging, so first you will tilt the box so the
sphere will roll along its surface.

1. In the Left viewport, select the box and
rotate it by 30 degrees clockwise, being careful
not to rotate the box into the sphere.

2. On the reactor toolbar, click Create
Animation. A Reactor dialog is displayed,
asking you to confirm the choice. Click OK to
continue.

This creates a simulation and runs it for the
length of time between the Start Frame and End
Frame values set on the track bar. The default
values for these are 0 and 100, respectively; you
will change these values later in the tutorial.

Keyframes are created for the positions and
orientations of your rigid bodies for each of
those 100 frames

3. Click Play Animation to watch the
animation in the viewport. You should see your
sphere falling onto the box and rolling down
over the edge of it.

4. With the sphere selected, region-select all of the
keys in the track bar and press Delete.

Geometry Types

Simulation Geometry is the second rollout in the
Rigid Body Properties dialog; it deals with how
objects are represented in the physical simulation.

In reactor, a convex object is one that has no holes
or dips in its surface. For instance, ping-pong
balls are convex, golf balls are concave. Convex
objects are much easier to simulate than concave
objects. For this reason, when you simulate an
object, it is treated as if it was convex by default,
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even if the 3ds Max object is concave. To do this,
reactor uses a special algorithm to create a convex
version of the object for simulation; however, the
object does not change in 3ds Max. This is called
creating a convex hull for the object’s mesh, and
is represented by the Mesh Convex Hull option
on the Simulation Geometry rollout of the Rigid
Body Properties dialog.

However, there are times where you will want to
simulate the exact mesh of an object, concavities
and all. You specify this using the Concave Mesh
option.

In this section of the tutorial, you will specify
that you want to simulate your sphere as an exact
sphere. This means that the sphere’s geometry is
not simulated; instead, a mathematical sphere is
used for simulation. This is not only faster, but
also more accurate (the object will roll perfectly
smoothly) and less memory-intensive than a
simulation based on a geometry-based sphere.

Note: You can continue using your file or
you can open reactor_intro_3.max from
\tutorials\reactor\introduction.

Change the simulation geometry for the sphere:

1. Select the sphere.

2. Open the Rigid Body Properties dialog.

3. In the Simulation Geometry rollout, choose
Bounding Sphere.

4. Click Create Animation to re-create the
keyframes for the simulation. The sphere will
roll more smoothly, though this may not be
immediately apparent if your sphere is highly
tessellated.

5. With the sphere selected, region-select all of the
keys in the track bar and press Delete.

Geometry Simulation

Now you will continue making your toy. The
sphere that you have already created acts as the
toy’s body. The next step is to create a cylinder
that will become the toy’s arms. You will also
create a duplicate of this cylinder and reduce its
tessellation. This simplified version, which is
easier and faster to simulate, will be used as the
simulation geometry for the first, more complex
cylinder. This technique is known as using proxy
geometry.

Note that if you were to make twenty copies of the
first cylinder and add them to your simulation,
they would all use the simplified, duplicate
cylinder as their simulation geometry. This would
mean that only one instance of the cylinder
geometry would need to be created for the physical
simulation, so memory usage would be reduced
and simulation speed would be increased.

Note: You can continue using your file or you can
open reactor_intro_4.max from \tutorials\reactor.

Create a simplified version of an object for
simulation:

1. Create a cylinder in the Left viewport, and
position it above your sphere.

Note: Make sure that the cylinder and sphere
don’t touch each other.

2. In the Modify panel, set the following values
for the cylinder: Radius=6.0, Height=70.0 and
Sides=18.0.
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3. With your cylinder still selected, choose Edit >
Clone. In the Clone Options dialog, make sure
Copy is selected and click OK.

This copy of your cylinder will be used as the
proxy geometry.

4. In the Modify panel, reduce the number of
sides of the new cylinder to 12, and move it
away from the other objects.

5. Select the original cylinder and open the
Rigid Body Properties dialog.

6. Set the cylinder’s Mass value to 10.0.

7. Set the cylinder’s Simulation Geometry
property to Proxy Convex Hull.

This means that the cylinder will use the convex
hull created from another object’s geometry as
its physical representation.

The Proxy button in the rollout is activated.

8. In the Simulation Geometry rollout, click
the Proxy button, and then select the cloned
cylinder in one of the viewports.

The button now displays the name of your
chosen proxy object.

Note: You can now hide your proxy cylinder
to keep it out of the way by selecting it,
right-clicking and choosing Hide Selection
from the display quadrant of the quad menu.

9. Select the RB Collection helper object in your
scene, and add the original cylinder to it.

10. On the reactor toolbar, click Preview
Animation and play the animation.

You will see that the cylinder does not roll as
smoothly as its display would suggest.

11.In the preview window, choose Display >
Sim Edges to display edges for the objects’
simulation geometries.

You will see that the cylinder’s simulation
geometry is coarser than its display body.

Building Up a Rigid Body

A rigid body can be made up of more than one
object, or primitive. A rigid body with more than
one primitive is known as a compound rigid body.

As stated previously, concave objects (objects with
holes or dips in the surface or geometry) are more
difficult to simulate than convex objects. For this
reason, a compound rigid body made up of several
convex objects can be simulated much faster than
a single concave object. A good example of this is a
picture frame, where simulating a concave picture
frame would be slow, but simulating a group of
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four convex boxes representing the frame sides
would not.

In this section, you will combine the two non-fixed
rigid bodies in your scene (the sphere and
cylinder) to create a single rigid body. In doing
so, you will see the differences between primitive
properties and rigid body properties. Each
primitive in a rigid body can have a separate mass
and simulation geometry, while friction, elasticity,
and display body properties are applied to the
entire rigid body.

To create your compound rigid body, you will
need to select the objects and group them using
the group functionality in 3ds Max. This group
can be added to the rigid body collection as a new
rigid body.

Note: You can continue using your file or
you can open reactor_intro_5.max from
\tutorials\reactor\introduction.

Create a compound rigid body:

1. Select the cylinder and move it down into the
sphere, so that it resembles a pair of arms.

Relocated cylinder as seen in the Front viewport.

2. Hold down CTRL and select the sphere, adding
it to your selection set.

Note: The cylinder and sphere should be the
only selected objects.

3. Choose Group menu > Group.

In the Group dialog, name your new group
toy_body. Click OK to continue.

4. Select the RB Collection helper object, and add
your new group to the collection.

5. Click Preview Animation to watch the
simulation.

You should get an error saying that the sphere
and cylinder can no longer be rigid bodies.
This is because they are being used as part of an
active compound rigid body, so you will need
to remove them as single objects from the rigid
body collection.

6. On the RB Collection Properties rollout of the
Modify panel, hold down CTRL and select the
sphere and the cylinder and click Delete.

7. Click Preview Animation and watch the
simulation.

Now you can see that the sphere and cylinder
act as parts of the same object.
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Making It Wobbly

The toy you are going to make will have a
non-uniform mass distribution which, in this
case, means that most of its mass will be centered
about its base. This will have the effect that the toy
will not roll or fall over, but will try to right itself,
and will wobble around. This behavior is possible
because the primitives in a compound rigid body
can have different masses. All you have to do is
add a small, heavy object inside the bottom of the
toy and most of its mass will reside there.

Note: You can continue using your file or you can
open reactor_intro_6.max from \tutorials\reactor.

Complete the toy:

1. First, finish adding the toy’s geometries. Create
a torus for its waistband, a sphere for the head,
two spheres for eyes and one for the nose.

Front view of completed toy geometry

2. Select the three spheres used for the eyes
and nose and open the Rigid Body Properties
dialog.

3. Set the simulation geometry to Bounding Box.

Since these spheres won’t play a large part in the
simulation, you can treat them as very simple
geometries to speed up the simulation.

4. Select the head of the toy and set its simulation
geometry to Bounding Sphere.

The torus’ simulation geometry can be left
as Mesh Convex Hull, though you could also
create a copy and simplify it as a proxy, as you
did with the cylinder.

5. Once you have finished creating and arranging
these objects, add them to the toy_body group.
For each object, select the object, choose Group
menu > Attach, and then click toy_body.

Change the mass distribution for a rigid body:

1. Select the toy_body group and choose Group
menu > Open.

This allows you to select the individual
primitives within the group to edit their rigid
body properties.

2. Change the mass of each object in the group
(except the body and arms, which already have
mass values) to 1.0.

Tip: You can do this quickly by selecting all of
the objects in the group, and setting the Mass to
1.0 in the Rigid Body Properties dialog.

You do this because you are going to add a heavy
object to the group, and it is this mass that you
really want to affect the object’s motion.

3. Click Preview Animation and you will
see that all of the new objects have been added
to the compound rigid body.

The toy should fall, though it won’t yet have
the correct behavior. If the object doesn’t fall
you may not have given a mass to all of the
objects in the rigid body and, as a result, one
of the primitives is fixed. To fix this, close the
preview window and check the mass of each of
the objects in the group.
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4. Add a small box (Height, Width, and
Length=3.0) inside the body sphere and near
the bottom of the object.

5. In the Rigid Body Properties dialog, give
the box a mass of 300.0.

6. Select a component of the group and choose
Group menu > Close to close the group.

7. Select the small box, choose Group menu >
Attach, and then click toy_body to add the box
to the group.

8. Click Preview Animation and examine
the behavior of the toy.

The toy slides down the box and tips over as
before, but it tilts backward as though to right
itself. The high mass in the box at the base of
the toy has lowered the group’s center of gravity.

Save your file as my_reactor_intro.max, and
experiment with flattening out the plane and
scaling it up.

Looking at Things Differently

reactor allows you to use display proxies
for objects; this means that a rigid body can
have a different display body for use in the
preview window. This increases the window’s
performance, especially when you are simulating
more than one object with the same display body.
If you have a lot of objects that all look the same,
then your display only needs to keep track of one
instance of the display body when display proxies
are used. As a bonus, simulation setup speed
is greatly improved, as only one instance of the
display body has to be created.

In this section you will create a display proxy for
the toy. This is done so that when you create copies
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of the toy later in the tutorial, your setup and
display speed should not be adversely affected.

Note: You can continue using your file or
you can open reactor_intro_7.max from
\tutorials\reactor\introduction.

Create a display proxy for a rigid body:

1. Create a copy of the toy by SHIFT+dragging
the group in the viewport.

Move the copy away from the other objects.

2. A display proxy must be a single mesh. To
create this, first ungroup the toy copy by
selecting the new group and choosing Group
menu > Ungroup. Then select the copy’s main
body sphere.

3. Right-click the sphere. In the Transform
quadrant of the quad menu, choose Convert To
> Convert To Editable Mesh.

4. In the Edit Geometry rollout of the Modify
panel, click Attach List.

5. In the Attach List dialog, select the rest of the
objects that were part of the group and click
Attach.

You now have a single mesh representing the
toy, which can be used as a display proxy.

Tip: It is a good idea to label models in your
scene clearly, especially when they look
similar to one another. In this tutorial, for
example, you could rename your proxy object
toy_body_proxy.

6. Select your original toy_body group and
choose Group menu > Open.

7. Select the group parent, which is the pink box
surrounding the grouped objects.

You need to select the group parent rather
than any of the toy’s constituent objects, as the
group parent represents the rigid body and
display proxies are applied to rigid bodies, not
primitives.

8. Open the Rigid Body Properties dialog,
and in the Display group of the Simulation
Geometry rollout, choose Use Display Proxy.

This activates the display proxy pick button.

9. Click the display proxy pick button and select
the single-mesh version of your toy in one of
the viewports.

The button displays the name of your proxy object, in
this case toy_body_proxy.

You have now assigned an alternative display
body to your compound rigid body.

10.With the mesh toy selected, right-click and
from the Display quadrant of the quad menu,
choose Hide Selection to hide your proxy
object.

This will keep it out of your way.

11. Select a component of the group, and
choose Group menu > Close, then click Preview
Animation.

Your toy will use the new mesh as its display
object. If you make changes to the editable
mesh, these will be displayed whenever you use
the preview window.
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Simulation Accuracy

If strange artifacts show up in the objects’ motions,
you probably need to increase the accuracy of your
physical simulation. This can be done in one of
two ways. You can change the accuracy externally,
which affects the accuracy for both keyframe
creation and the preview window, or you can
alter it from within the preview window. In both
cases, changing the accuracy requires altering a
simulation parameter called Substeps/Keyframe.
You can edit this in the reactor rollouts on the
Utilities panel or by using the Physics menu in the
preview window.

When the physics are being calculated, reactor
moves the objects forward in small steps. The
smaller the steps, the more accurate the simulation.
However, you should note that the simulation will
also become slower as it becomes more accurate.
The default accuracy value is 10 substeps per
keyframe, which means that reactor divides each
keyframe interval into 10, and steps the simulation
forward in intervals of this size. If you increase the
substeps per keyframe value to 25, then the size
of reactor ’s steps becomes one keyframe interval
divided by 25.

Note: You can continue using your file or
you can open reactor_intro_8.max from
\tutorials\reactor\introduction.

Change the accuracy of your simulation:

1. On the Utilities panel, click the reactor
button and expand the Preview & Animation
rollout.

2. Change the Substeps/Key value from 10 to 25.

3. Click Preview Animation.

The simulation may run more slowly but will be
less likely to be affected by sudden slowdowns.

Setting Up the Simulation

In this section you will create a toy box and 39
copies of your toy. Using the preview window,
you will drop the toy copies into your box, let
them settle, and then pass their positions back to
3ds Max. As you will see, the preview window acts
as an interactive modeling tool, allowing you to
rearrange objects physically and then use changes
made in the preview window to update 3ds Max.

Note: You can continue using your file or
you can open reactor_intro_9.max from
\tutorials\reactor\introduction.

Create the toy box:

1. In your scene (away from the other objects),
create five boxes with Length and Width=400.0,
and Height=25.0.

2. Arrange the boxes to form a larger, hollow box.
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3. In the Left viewport, rotate the sloping box
20 degrees counterclockwise to flatten it out
somewhat. With the sloping box selected,
increase both its Length and Width parameters
to 600, and move it downward 240 units.

4. Select and right-click the box used as the base of
the toy box, and in the Transform quadrant of
the quad menu, choose Convert To > Convert
To Editable Mesh.

5. In the Edit Geometry rollout of the Modify
panel, click Attach List.

6. In the Attach List dialog, select the other four
boxes, which make up the sides of the toy box,
and click Attach.

You now have a single mesh representing the
toy box.

7. Open the Rigid Body Properties dialog
and set the Simulation Geometry property to
Concave Mesh.

Update your scene from the preview window:

1. On the toolbar, click Select and Move.

2. Move the toy inside the box.

Note: Make sure that the toy is not touching the
box.

3. In a side viewport, SHIFT+Move the toy, and
position the first copy above the original.

Note: Make sure that the copy is not touching
the original toy.



Setting Up the Simulation 693

4. In the Clone Options dialog, set Number Of
Copies=39 and click OK.

5. Select the RB Collection helper object and in
the Modify panel > RB Collection Properties
rollout, click Add.

6. Select all of the new toy objects and the toy box
and click Select to add them to the rigid body
collection.

7. Click Preview Animation and let the toys
fall into the box and settle.

8. When the toys have settled in the box, from the
Preview Window menu bar choose MAX menu
> Update MAX.

9. Close the preview window and click in one of
the viewports to update the display. The toys
will have been updated so that they have the
positions and rotations you updated in the
preview window.
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Using Hand-Animated Rigid
Bodies

Something that you will often want to do is to
use hand-animated rigid bodies in a physical
simulation. These rigid bodies are referred to as
unyielding rigid bodies and have the Unyielding
property turned on in the Rigid Body Properties
dialog. They behave as their keyframes dictate
and other rigid bodies react to them. You do not
need to give them a mass. In this example, you will
hand-animate your toy box so that it tips over and
spills the toys out onto the floor.

Note: You can continue using your file or
you can open reactor_intro_10.max from
\tutorials\reactor\introduction.

Add hand-animated rigid bodies to a physical
simulation:

1. Select the toy box.

2. Open the Rigid Body Properties dialog.
On the Physical Properties rollout, turn on
Unyielding.

3. Turn on Auto Key and move the time
slider to frame 60. Rotate the box clockwise
by about 125 degrees so that the objects will
pour out when physically active. Turn off Auto
Key. Be careful to move your floor below the
final position of the toy box so that the two are
not interpenetrating. This would not generate
errors in simulation, but would look strange.

Note: Your toys may exhibit some strange
behavior when you are hand-animating the
box, but don’t be alarmed. This is because the
objects have not been keyframed yet. They
will, however, behave correctly in the preview
window.

4. Click Preview Animation.

Your box tips over and the toys pour out onto
the floor. You may want to increase the size of
your floor so that the toys don’t all wobble over
the edge.

5. At this stage, you may want to tweak the physical
properties of your objects. For instance, if your
objects are piling up as they fall out of the box,
you can reduce their friction and the friction
of the floor, so that they spread further after
colliding with the floor and the other toys.
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Note: Remember that to change the physical
properties, you must open the group and
change the properties of the group helper
object. You can change the properties of more
than one object at a time.

Preparing Output

Now that you have your simulation behaving
correctly, you need to create keyframes for the
objects’ motions. This can be done as before using
the Create Animation button on the Toolbox.

In this example, you will create keyframes for
the first 100 frames of the motion, and then
simulate from frame 100 on. This shows how the
reactor dynamics functionality can extract initial
velocities from the scene so that simulating from
frame 0 to 100 in one step is the same as simulating
from frames 0 to 20, then from 20 to 40, 40 to 60,
60 to 80, and finally 80 to 100.

Note: You can continue using your file or
you can open reactor_intro_11.max from
\tutorials\reactor\introduction.

Extract initial velocities for rigid bodies:

1. On the reactor toolbar, click Create
Animation.

Keyframes are created between frame 0 and 100
for your rigid bodies’ motions.

2. On the Utilities panel click reactor, then on
the Preview & Animation rollout, set Start
Frame=100 and End Frame=500.

3. Click Preview Animation.

You will see that the objects start simulation
with initial linear and angular velocities.

4. In the Time Controls, click Time
Configuration.

5. In the Time Configuration dialog, set End Time
to 500.

6. Click Create Animation again.

Keyframes will be created from frame 100 to
500. If you examine the keyframes behavior
in the viewport, you will see that the objects’
motion is smooth as it passes over frame
100, since the objects’ initial velocities were
extracted and used for simulation.

Reducing File Size

You now have keyframes for your objects’ motion
that can be used for creating animations or still
renderings. However, each object currently has a
keyframe for every frame. This means that your
file size is quite large; it will also be quite difficult
to tweak an object’s behavior after the simulation.

reactor provides access to a reduction process that
attempts to remove redundant keyframes for the
rigid bodies. You can provide a threshold value for
the algorithm that guarantees that the motion of
the objects after this reduction will be within that
factor of their original value. In this section, you
will reduce the keyframes for your rigid bodies.

Note: You can continue using your file or
you can open reactor_intro_12.max from
\tutorials\reactor\introduction.

Remove redundant keyframes after simulation:

1. On the Utilities panel > click reactor and
expand the Preview and Animation rollout.

2. In the Preview and Animation rollout, set Start
Frame to 0 and End Frame to 100.

3. On the Utilities panel, expand the Utils rollout.
In the Key Management group, click Reduce
Now.
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This reduces the keyframes for all active rigid
bodies in the simulation. For this example, use
the default threshold value of 0.5.

4. Look at the animation again. As you can see,
the behavior of the rigid bodies in your scene is
almost exactly the same as before the reduction
process, but the number of keyframes for each
toy is greatly reduced. The motion of the toys
is still quite complex, but the file size has been
reduced about 30%.

5. Save your scene as my_reactor_intro_final.max.
If you like, you can compare your results with
the saved file reactor_intro_final.max. About
midway through your animation, your scene
should look something like the following
illustration.

Summary

In this tutorial, you have learned the basics of
using reactor to create complex animations:

1. Using the Rigid Body Properties dialog to set
properties for objects in your animation.

2. Using an RB Collection object to control the
animation.

3. Previewing the animation, and converting the
animation into 3ds Max keyframes.

Fractures with Reactor

Simulating Fractures with reactor

Fracture simulates the breaking of a rigid body
into a number of smaller pieces as the result of an
impact. In this tutorial, you will create a wall and
then observe the result of firing a cannonball at
the wall.

Note: Before you work through this tutorial, you
should have already worked your way through
Introduction to reactor (page 2–681).

Build a wall:

1. Start 3ds Max or choose File menu > Reset if
you are already working in the software.

2. In the Top viewport, create a box with the
following parameters:

• Length: 200.0

• Width: 200.0

• Height: -5.0

3. In the Left viewport, create another box just
above the box from the previous step. Use the
following parameters:

• Length: 10.0

• Width: 20.0

• Height: 16.0

4. SHIFT+Move the smaller box directly
next to itself.
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Note: Make sure the box is as close as possible
to, but not touching or overlapping its original
position .

The Clone Options dialog appears.

5. In the Clone Options dialog, make sure Copy is
selected, set Number of Copies to 7, and click
OK.

Now you have the first row of bricks in your
wall.

6. In the Left viewport, select all of the small boxes
in the row of ’bricks’.

7. SHIFT+Move the entire row to create
another row directly above and slightly offset to
the original.

Note: Make sure the new row is not touching or
overlapping the original row.

The Clone Options dialog appears.

8. In the Clone Options dialog, make sure Copy is
selected, and that Number of Copies is 1, then
click OK.

9. Repeat the previous two steps until you have
seven rows of bricks in your wall.

Now you have a brick wall. Next, you will create
a Rigid Body Collection and set your wall on
the ground.

10.Choose File menu > Save and save your file as
myfracture.max.

Create a rigid body collection:

Note: If you would like to start from
here, open fracture_1.max from the
\tutorials\reactor\fracture directory.

1. Select all of the boxes in your scene
(including the ground). On the reactor toolbar,
click Create Rigid Body Collection

An RB Collection helper is created. It already
contains all of the objects in your scene as they
were selected when you created the collection
set.

Now you have a rigid body collection, but you
need to assign masses to the bricks in the wall
before you can run a simulation.
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2. Select the boxes that make up the wall
(not the ground). On the reactor toolbar, click
Open Property Editor.

The Rigid Body Properties dialog appears.

3. In the Rigid Body Properties dialog, set Mass to
10.0 and set Simulation Geometry to Bounding
Box, then close the dialog.

4. On the reactor toolbar, click Preview
Animation.

A real time preview window appears.

5. Press P to start the simulation in the preview
window.

The bricks will fall to the ground, but you may
notice that they also explode away from one
another. This is because the Collision Tolerance
is too high.

6. Close the Preview window.

7. On the Utilities panel, click reactor.

8. In the World rollout, set Col. Tolerance to 0.3.

The smaller the collision tolerance, the closer
objects can be without interacting. However,
this also increases computation time.

9. Click Preview Animation again and
press P to start the animation.

The bricks no longer explode, however you may
notice that once they fall onto the ground, they
start exhibiting strange behavior, such as falling
through each other and crumbling down.

To remedy this, you need to make the
simulation more accurate by increasing the
substeps.

10.In the Preview window, choose Performance
menu > 100 substeps.

This makes reactor calculate 100 steps between
each frame of animation, and will give you a
much more accurate dynamic simulation.

Note: Increasing substeps will also slow down
your calculation time.

11.Press R to reset, and P to start the simulation
again.

The bricks should fall into place and come to
rest.

Note: If you have trouble getting your objects
to settle correctly, try adjusting the positions
of the bricks, bringing them closer together
without overlapping.

12.In the Preview window, choose MAX menu >
Update MAX.

This sends the current state of all of the objects
in the simulation back to 3ds Max, updating
their position.
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13.Close the Preview window and activate a
viewport to see the bricks move into their new,
settled position.

14.Choose File menu > Save to save your file.

Create a projectile:

Note: If you would like to start from
here, open fracture_2.max from the
\tutorials\reactor\fracture directory.

1. In the Front viewport, create a sphere, setting
the radius to 5.0 and Segments to 16.

2. With the sphere still selected, open the
Property Editor, set the sphere’s mass to 10.0,
and the Simulation Geometry to Bounding
Sphere.

3. Select the RB Collection. On the Modify panel,
add the sphere to the collection.

Next, you will give the sphere some velocity.

4. Turn on Auto Key and move the time
slider to Frame 5.

5. Move the sphere to the other side of the wall
and turn off Auto Key.

reactor uses the initial velocity of an object as
a starting point for its dynamics simulation.
Since the sphere has no velocity at Frame 0, you
need to start the simulation from a different
frame.

6. On the Utilities panel, click reactor and expand
the Preview & Animation rollout.

7. In the Preview & Animation rollout, set Start
Frame to 2 and Substeps/Key to 100.

Note: Earlier, you changed the substeps in the
Preview window, however this only updated
the setting temporarily. Changing the value
in the Preview & Animation rollout updates
the default values used each time you open the
Preview window.

8. In the Preview & Animation rollout, click
Preview In Window.

Note: This is the same as clicking Preview
Animation on the reactor toolbar.

If the World Analysis dialog is displayed,
indicating interpenetrations between some of
the boxes, just click Continue.
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9. Press P to start the simulation.

The ball crashes through the wall sending bricks
flying everywhere. This is realistic if the bricks
are all sitting loosely on top of each other, but
not if they are cemented together, as in a real
brick wall. To simulate the behavior of a single
body breaking into pieces, you use Fracture.

10.Close the Preview window.

Create a Fracture:

Note: If you would like to start from
here, open fracture_3.max from the
\tutorials\reactor\fracture directory.

1. In the viewports, select all of the bricks that
make up the wall, making sure not to select the
floor or the sphere.

2. On the reactor toolbar, click Create
Fracture.

3. On the Utilities panel > reactor > Preview &
Animation rollout, change Substeps/Key to 25
and click Preview In Window.

Note: The Fracture collection is held together
automatically, so the dynamic simulation does
not have to be quite as accurate. Simulating
fractures also uses a significant amount of
processor power, so a highly accurate solution
can take a long time to Preview.

4. In the Preview window, press P to start the
simulation.

This time the projectile breaks through the
wall, but the bricks don’t explode. Instead, the
fracture is local to the impact of the sphere.

Summary

In reactor, the Fracture collection treats its
members as a single rigid body, so that in a
collision, the rigid body will fracture realistically.

Rag Doll

Rag Doll Tutorial

In this tutorial, you will add constraints to a
predesigned character model to create a fully
simulated rag doll using reactor. The tutorial uses
two different constraint types to achieve realistic
rag doll motion; hinge and rag doll constraints.
Each type is presented individually, with the
workflow and typical use case for each constraint.

The scene is a simplified room, containing a set
of stairs for your rag doll to fall down, and a floor
on which he’ll come to rest. The focus of this
tutorial is rag doll character creation, so we’ve
provided the completed scene with one catch - the
character lacks any physical properties, and, most
importantly, it has no constraints! Without these
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features the character has no physical presence in
the scene, and will not react with the other objects.

As you proceed through this tutorial you will learn
what constraints are, how to use them and how
to tweak their parameters to adjust the rag doll’s
reactions. After this it is up to you to decide how
to best use all those rag dolls - whether it be for
falling down staircases, tumbling over banisters or
simply being caught in explosions. It’s up to you!

Skill Level: Intermediate

Time to complete: 2–3 hours

Features Covered in this Tutorial

In these lessons you will learn:

• Setting physical properties for the bones.

• Viewing gravity and other simulation
parameters.

• Creating a rigid body collection.

• Previewing the animation.

• Using Constraints to hold the character
together.

• Using Hinge Constraints for knees, elbows and
wrists.

• Disabling collisions.

• Using Rag Doll constraints for hips and
shoulders, back and neck.

Tutorial Files

Note: You can find the files for this tutorial in the
tutorials\reactor\ragdoll folder on the Tutorial
Files CD that ships with 3ds Max. Before starting
the tutorials, copy the \tutorials folder from the
CD to your \3dsmax8 local installation.

Setting Up the Rag-Doll Scene

In this lesson, you set up the scene by opening a
3ds Max file.

Open the sample file:

• Choose File menu > Open and open
character.max from \tutorials\reactor\ragdoll.

You are presented with a simple scene
containing some stairs, a floor and a character
model.

At the moment none of the objects in this scene
have any physical properties associated with
them; this is what you’ll be adding over the
course of the tutorial. reactor essentially adds
physicality to scenes. To properly simulate
dynamics, objects must have real-world
properties such as mass and friction assigned.
By adding these things to your scene, you can
create a simulation that mirrors your everyday
experiences, or if you’d prefer, an alien world
with gravity pointing to the right!
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Making Objects Physical

The character model you are working with may be
thought of as 18 individual pieces: 17 which are
bones and an eighteenth, which is the skin that
envelopes them. As far as reactor is concerned,
the skin plays no part in the physical simulation
of the scene; it is simply an aesthetic feature in
that it presents a more realistic human look than
the underlying bones. Only the bones themselves
are simulated and they feedback new coordinate
information to the skin so that it may properly
deform to keep the bones wrapped up.

With this in mind the first thing you must do is
give each of the bones a value for its mass.

Set physical properties for the bones:

1. On the toolbar, click Select by Name, or
alternatively, press H.

You will now be presented with a complete list
of all the objects in the scene.

2. In the Select Objects dialog, turn on Display
Subtree.

As you can see, all of the bones are named so
that their position in the body is apparent;
LCalf, RFoot, Head, etc.

3. Select all the bones and click Select.

4. On the Utilities panel, click reactor and
open the Properties rollout.

5. Assign a value of 10.0 kilograms to the
selection, meaning that, in total, the character
weighs 170 kg. Although doing this yields a
nice final result, if you’d like to add greater
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realism to the simulation you should try to give
the different components a comparable value to
their real life equivalents, keeping the ratio of
masses relative - your forearm should not have
the same mass as your thigh, for example!

For this tutorial, accept the default values of 0.3
for Friction and Elasticity. However, feel free to
tweak their values and see the results. Elasticity
controls how ’bouncy’ the object appears to
be; a greater value leads to a more ’bouncy’
feel. Friction controls how easy it is to slide the
object across a given surface in the scene; larger
values lead to increased resistance.

Next, you will give the background objects a
physical presence in the scene, i.e. the steps of
the staircase and the floor.

6. Select the steps and the floor in your scene.

7. On the Utilities panel > Properties
rollout, set Mass to 0.0.

This seems like a strange mass for these
objects. However, reactor treats all objects
with a mass of zero as fixed in place; under
no circumstances are they allowed to move.
Since you don’t want the steps or the floor to
suddenly drop into the void under the influence
of gravity, you give them a mass of zero to tell
reactor that they are immovable.

As you may have noticed, the default mass
assigned by reactor to an object is zero (fixed),
so this last step can be ignored, in general.

View gravity and other simulation parameters:

1. On the Utilities panel, click reactor and
open the World rollout

The three values in the World rollout > Gravity
area control the gravity in your world (scene).
The X, Y and Z components together form the
direction vector that represents gravity. Since
gravity usually points downward, only the Z
component has a non-zero value, by default.
But where does the rather strange looking
value of -386.22 come from? The minus sign
simply indicates that the gravity should be
applied downwards, and the value is arrived at
as follows: In the real word, gravity accelerates
objects towards the earth at around 9.8 m/s
every second. If you look down at the next
value in the World rollout, you’ll see that 1m
is equal to 39.37 3ds Max units (inches), so
if you roughly convert gravity from meters to
3ds Max units, you get the 386.22 3ds Max units
you see above.

2. Choose Customize menu > Units Setup and
switch the Display Unit Scale to Metric.
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Notice that the values in the World rollout are
updated accordingly:

If you give values to the X and Y components
of Gravity, you can create bizarre scenes where
characters fly towards the walls or even the
ceiling! In this lesson, you will be simulating a
’normal’ environment, so there is no need to
change it.

The final step before you can simulate your scene
is to add your objects to a rigid body collection.

Add the objects to a rigid body collection:

1. In the Create panel, click Helpers and
select reactor from the dropdown list.

The Object Type rollout should now contain
reactor object types.

2. In the Create panel > Object Type rollout, click
RBCollection, then click in one of the viewports
to create a rigid body collection helper object.

The position of the helper object is of no
significance to the scene. You should see
something similar to the following image in the
viewport:
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At the moment, there are no objects in the
collection.

3. On the Modify panel > RB Collection
Properties rollout, click Add.

4. In the Select Rigid Bodies dialog, select all of
the scene objects except skin and click Select.

The RB Collection Properties list should now
look something like this:

You’re now ready to simulate the rag doll
scene. Before you do, save your work as
my_character01.max.

Preview the animation:

1. You can continue from your previous
scene, or choose File menu > Open
and open character01.max from the
\tutorials\reactor\ragdoll directory.

2. On the Utilities panel, click reactor and
expand the Preview & Animation rollout, then
click Preview in Window.

You are informed that several of the bodies
are interpenetrating, however you may
safely ignore this for the moment by clicking
Continue. The reactor preview window pops
up and you are be presented with the following
scene:
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3. Press P to start the simulation.

The bones are not yet connected, and thus,
fall apart when they hit the stairs. In the next
lesson, you will attach the limbs.

Attaching Limbs Together

In the previous lesson, the character literally fell to
pieces once he hit the stairs. In the current scene,
each bone is essentially an independent object and
is in no way linked with the other bones in the
body. There is nothing to stop the individual bones
from going their own way. In this lesson, you will
use Constraints to hold the character together.

Constraints are used to connect one object to
another. All constraints are represented in 3ds Max
by helper objects.

View all available reactor helpers:

• On the Create panel, click Helpers, and
select reactor from the dropdown list.

Among the reactor objects, you’ll see some
of the available constraint types; from Hinge
constraints to Prismatic constraints, there are
constraint types to reproduce pretty much any
behavior you would like to see in your scene.
In the next lesson, you will concentrate on the
Hinge and Rag Doll constraints, as these are
the two you will be using to piece together the
character.

Using Hinge Constraints

The first constraint you’ll be using is known as
a hinge constraint which, as you may guess from
the name, behaves like a hinge. A simple everyday
example of this kind of constraint is a door. A
door can only swing around the points at which it
is attached to the frame; you can think of this as
the axis around which the door may rotate. It can’t
rotate around the other two axes as the connection
points to the frame prevent it from doing so.
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In fact, the door is actually a special type of hinge
constraint in that it is a limited hinge constraint.
This means that although it can rotate around the
hinge axis, it can only do so until it bumps in the
wall of the car. In reality, it cannot swing a full 360
degrees; the constraint’s range of motion is limited
(to 120 degrees, for example).

Furthermore, the hinges that connect the door
to the frame can take only a measured amount
of stress before giving way (think of hitting the
door with a rather large sledge hammer). Since
you can break the constraint, you would call this
a breakable hinge constraint, or more precisely a
breakable limited hinge constraint. The good news
is that reactor can simulate all of these features
giving you free reign over the movement and the
stresses and strains that the constraints in you
scene can undergo.

Add a hinge constraint

1. On the Create panel, click Helpers, and
select reactor from the dropdown list.

2. On the Create panel > Object Type rollout,
click Hinge.

The Properties rollout displays.

As you can see, there are a vast number of
parameters available, however, for this tutorial,
the only ones that you will be concerned with
are the Parent, Child, and Limited values. The
Parent and Child buttons are used to select
which objects in your scene will serve as the two
components of the constraint, the upper arm
and forearm, for example. The Limited group
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contains parameters that allow you to control
the extents to which the hinge may move.

Setting Up Knees, Elbows, Ankles
and Wrists
Open the sample file:

• You can continue from where you left
off, or choose File menu > Open and
load the character01.max from the
\tutorials\reactor\ragdoll directory.

A similar concept to the Rigid Body Collections
is used when dealing with constraints; however,
this time you add a Constraint Solver to the scene.
Once you have done this, you can begin to add
various constraint types to your objects and then
add them to this solver. The solver, in essence,
figures out how best to keep all of your objects
happy under the conditions they’ve been given
(body A connected to body B, body B connected
to body C etc.).

Add a constraint solver to the scene:

1. In the Create panel, click Helpers and
choose reactor from the dropdown list.

2. On the Create panel > Object Type rollout,
click CSolver.

3. Click in one of the viewports to create a
Constraint Solver.

Note: The location of the helper object is not
important.

Constraint solvers only work if all the
constraints act upon rigid bodies that belong to
the same rigid body collection. Next, you will
specify which collection the constraint solver
will apply itself to.

4. With the solver selected, open the Modify
panel > Properties rollout, and click the button
labeled None, below RB Collection.

5. Press H and select RBCollection01 from
the Pick Object dialog.

Now you’re ready to start connecting bones
together, and soon you will have your rag doll
tumbling down the stairs. You will be using the
hinge constraint to connect the various bones in
the character; first joining the right foot and calf
bones to simulate an ankle.

Create hinge constraints for the ankles:

1. On the Create panel > Object Type rollout,
click Hinge.

2. Click anywhere in a viewport to create a hinge
constraint.
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Next, you will choose which objects you would
like to assign to this constraint.

3. In the Modify panel > Properties rollout, click
the button labeled None, next to Child.

4. Press H and choose RFoot in the Pick
Object dialog, then click Pick

The Child button should now read RFoot.

5. In the Modify panel > Properties rollout, turn
on the Parent checkbox.

This indicates that you want to constrain two
objects together (rather than one object to the
world).

6. Click the button labeled None, next to Parent.

7. Press H and choose RCalf from the Pick
Objects dialog, then click Pick

The button beside Parent should now read
RCalf and the scene should look like this:

8. In its current state, the character’s foot is free to
rotate 360 degrees around the hinge constraint,
which as you can imagine would be pretty
painful! You need to use the Limited property
for this hinge constraint.

9. In the Properties rollout, turn on Limited.

10.In the Limited group, set Min Angle to -20.0
and Max Angle to 30.0

11.Repeat this process for the left foot and calf
bones.

Create hinge constraints for the knees, elbows and
wrists:

• The process for setting up the hinge constraint
for each of the other bone pairs is identical with
only the constraint limits differing. With this in
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mind use this list set the constraint parameters
for each joint:

Once you have completed this, your scene
should now look like this:

The other bones will be simulated using Rag Doll
Constraints as their motion is more sophisticated.
The last thing you have to do is to add all of the
constraints to the constraint solver.

Add the hinge constraints to the constraint solver:

1. Press H, and in the Object Select dialog,
choose CSolver01 and click Select.

2. On the Modify panel > Properties rollout,
click Add.

3. In the dialog, choose all of the hinges and click
Select

The CSolver Properties rollout should now
look like this:

Constraint Name Child Parent Min Angle Max Angle

RAnkleJoint RFoot RCalf -20.0 30.0

LAnkleJoint LFoot LCalf -20.0 30.0

RKneeJoint RCalf RThigh -85.0 0.0

LKneeJoint LCalf LThigh -85.0 0.0

RWristJoint RHand RForeArm -35.0 35.0

LWristJoint LHand LForeArm -35.0 35.0

RElbowJoint RForeArm RUpperArm -85.0 0.0

LElbowJoint LForeArm LUpperArm -85.0 0.0
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Next, you will preview the scene again to see just
how these alterations have affected the character.

• On the Utility panel, click reactor, then
in the Preview & Animation rollout, click the
Preview in Window.

You may have noticed during the last preview that
reactor complained that some of the rigid bodies
in the scene were interpenetrating. Although you
ignored this warning on that occasion, it’s not a
good idea to do in general. Later in this tutorial,
you will take care of this issue, but for now click
Continue and view the preview.

The first thing that stands out is that the bones
connected with hinge constraints stay together.
This is exactly as planned, but notice that they
continue bouncing and dancing about once they
hit the floor. This is because reactor notices that
the bones are interpenetrating with one another
and tries to separate them. However, at the same
time, the constraint solver is trying to keep them
together. Since they are essentially battling with
one another over the position of the various bones
they continue to bounce about erratically. The
solution to this is to tell reactor not to worry about
interpenetrations between the bones that you’ve
connected.

Disable collisions between the limbs:

1. On the Utility panel > reactor >
Collisions rollout > Global Collisions group,
click Define Collision Pairs.

You are presented with the following dialog:

There are three columns; one for all the entities
(objects) in the scene, one for enabled collisions
and one for disabled collisions. By default, all
collisions are enabled between all objects so
you need to tell reactor to ignore the collisions
between the bones in your character. You only
want to ignore bone-to-bone collisions though.
If, for example, you chose to ignore the collision
between the character’s foot bone and the floor
object, the character’s foot would pass straight
through the floor unimpeded.
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2. Select all of (and only) the bone objects in the
first column.

This displays a list of enabled collisions in the
second column.

3. Click the >> button

All of the collision pairs between the selected
bodies move to the third column (disabled
collision pairs).

4. Click OK to accept the changes.

Note: Instead of disabling all collisions between
all limbs, you could instead disable collisions
between adjoining limbs. In order to do so, you
would start with all collisions enabled, select
each adjoining pair (LHand and LForeArm,
Spine3 and Head, etc..) and click ">>" to
disable just those pairs.

Preview the animation with collisions disabled:

1. On the Utilities panel > reactor >
Preview & Animation rollout, click Preview in
Window.

The Preview window should open this time
without any warnings and everything should
behave as expected (no bouncing limbs).

2. Save your work again, this time as
my_character02.max

Using Rag Doll Constraints

In the last lesson, you finished joining up the
simpler bones in the body. Now it’s time to think

about how you will simulate joints such as the
hips or shoulders. These joints are more complex
than the knees or elbow, as they need to allow for
rotation and they have a range of motion of greater
freedom than the hinge constraint provides. To
tackle these types of joints you will use Rag Doll
constraints.

These are fairly complex, so this lesson will serve
as a brief overview. The following is a picture of
two objects connected by a Rag Doll constraint:

A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

1. Parent Body

2. Child Body

In a Rag Doll constraint, there are 3 axes of
importance: the Twist Axis, the Plane Axis and the
Twist x Plane Axis. The twist axis is probably the
easiest to visualize and you can do so by simply
stretching out your arm and rotating it so that
your thumb changes from pointing upwards to
downwards. Your movement is just a series of
rotations along the twist axis of the shoulder and
elbow. In general, the twist axis should follow
the length of the child body in a joint. In reactor
you can specify how far on either side of neutral
the constraint can twist (which need not be
symmetric).
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A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

1. Twist Min.

2. Twist Max.

3. Twist Range

A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

1. Twist Range

The other two axes are interlinked and together
the control the allowed volume that the child body
can occupy. So first you’ll have a look at the cone
angles that allow you to specify the volume that the
child may move through:

A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

1. Cone Min.

2. Cone Max.
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A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

If you imagine the constraint representing your
shoulder, the green volume is the range of allowed
positions that your upper arm may occupy.
However, you can refine the allowed volume
further by using the plane axis to enforce plane
limits. These limits are used to generate two
further cones:

A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

1. Plane

2. Plane Min. Cone

3. Plane Max. Cone

4. Plane Min.

5. Plane Max.
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A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis (outward)

1. Plane

2. Plane Min. Cone

3. Plane Max. Cone

This allows you to create two different scenarios;
one where the cones generated by the plane limits
intersect with cone produced by the cone angles
and the one where they do not:

A. Twist Axis

C. Twist x Plane Axis

1. Plane Min. Cone

2. Plane Max. Cone

A. Twist Axis

C. Twist x Plane Axis

1. Plane Min. Cone

2. Plane Max. Cone
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If the volumes do not intersect, the plane limits do
not have any effect in the constraint; however, by
allowing the cones to intersect, and deeming the
overlapping volume as invalid body positions, you
can limit the allowed positions for the child body
further still.

A. Twist Axis

B. Plane Axis

C. Twist x Plane Axis

These are the parameters that you will be adjusting
in reactor to tweak the behavior of the character.
Hopefully this brief overview will help clarify Rag
Doll constraints a little for you.

Setting Up Hips, Back, Neck and
Shoulders
Open the sample file:

• You can either continue from where
you left off or you choose File menu >
Open and load character02.max from the
\tutorials\reactor\ragdoll directory.

You will approach this lesson in a similar manner
to the hinge constraint lesson in that you’ll go
through one of the joints in detail and then
use a table of parameters to construct the other
constraints. The setup for each Rag Doll constraint
is identical, so once you’ve mastered the first one
you should have no trouble setting up the rest of
the character. You start with the hips.

Create Rag Doll constraints for the hips:

1. On the Create panel, click Helpers and
choose reactor from the dropdown list.

2. On the Create panel > Object Type rollout,
click Ragdoll.

3. Click in a viewport to create a Ragdoll helper
object.

Next, you choose which objects to associate
with this constraint.

4. In the Modify panel > Properties rollout, click
the button labeled None, next to Child.

5. Press H and from the Object Select
dialog, choose RThigh and click Pick.

The button beside Child should now read
RThigh.

6. Turn on Parent.
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This tells reactor that you want to constrain
two bodies together.

7. Click the button labeled None, next to Parent.

8. Press H and from the Pick Object dialog,
choose Pelvis, then click Pick

The button beside Parent should now read
Pelvis and the scene should look like this:

Next, you need to adjust the Rag Doll constraint
limits so that it behaves like a real hip joint:

9. In the Modify panel > Properties rollout >
Limits group, set Twist Min to -5.0 and Twist
Max to 5.0.

10.Set Cone Min to -25.0 and Cone Max to 55.0.

11.Set Plane Min to -45.0 and Plane Max to 2.5.

You have completed your first Rag Doll
constraint. Once you have successfully finished
with that constraint, you can move on to
completing the rest in a similar fashion.

Create ragdoll constraints for the back, neck, and
shoulders:

• The table below gives a list of the constrained
bodies, the constraint name and the constraint
parameters. Use this table to set up the
remaining Rag Doll constraints in your scene.

Once you’ve created all of the above constraints
your Rag Doll constraints should look like this:

The only thing left to do is to add these new Rag
Doll constraints to your constraints solver.

Constraint Name Child Parent Twist Min Twist Max
Cone
Min

Cone
Max

Plane
Min

Plane
Max

RHipJoint RThigh Pelvis -5.0 5.0 -25.0 55.0 -45.0 2.5

LHipJoint LThigh Pelvis -5.0 5.0 -55.0 25.0 -45.0 2.5

BackJoint1 Spine1 Pelvis -1.0 1.0 -30.0 30.0 -50.0 5.0

BackJoint2 Spine2 Spine1 -1.0 1.0 -8.0 8.0 -6.0 3.0

BackJoint3 Spine3 Spine2 -1.0 1.0 -8.0 8.0 -6.0 3.0

RShoulderJoint RUpperArm Spine3 -5.0 5.0 -75.0 85.0 -5.0 65.0

LShoulderJoint LUpperArm Spine3 -5.0 5.0 -85.0 75.0 -5.0 65.0

NeckJoint Head Spine3 -5.0 5.0 -45.0 45.0 -15.0 15.0
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Add the Rag Doll constraints to the constraint solver:

1. Press H on the keyboard and select the
CSolver01 object.

2. On the Modify panel > Properties rollout,
click Add.

3. Select all the objects (Rag Doll constraints) and
click Select.

Now the constraint solver has all of the
constraints in it and the scene is ready to
preview once again. First, save your scene.

4. Choose File menu > Save As and save the file as
my_character03.max

Preview your character:

• On the Utility panel > reactor > Preview
& Animation rollout, click Preview in Window.

Now your character should tumble down the
stairs properly.

Creating the Animation

Now that the simulation is working correctly, it’s
time to create the animation. Since you don’t want
to see the bone objects and the constraints in your
animation, the first thing you’ll do is hide them.

Open the sample file:

• Continue from the previous lesson or choose
File menu > Open and choose character03.max
from the \tutorials\reactor\ragdoll directory.

Hide the bones of the character:

1. Press H and in the Select Objects dialog,
choose the skin, the floor and all 16 steps then
click Select.

2. On the Display panel > Hide rollout,
click Hide Unselected.

Now you should only be able to see the skin of
your rag doll.

Create and play the animation:

1. On the Utility panel > reactor > Preview
& Animation rollout, click Create Animation.

2. Once the animation calculations have
completed, click on the viewport of your choice
and click Play.

And that’s a wrap! It’s up to you now to tweak
the various parameters on the rag doll to alter his
behavior as he tumbles down the stairs. You may
find some joints are too loose or tight: reduce or
increase the limits accordingly. You can give both
halves of the rag doll’s body different settings to
encourage him to fall in a given direction. Try
changing his initial position and orientation or
add some obstacles on the stairs.

You can see the final result of this tutorial
by opening characterEnd.max from the
\tutorials\reactor\ragdoll directory.
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Summary

You can use the reactor constraints to hold a
character together, and control how it behaves
during falls, collisions, and other physical
encounters.

Deformable Bodies

Deformable Bodies Tutorial

There are two main classes of dynamics entities
in reactor. The first are rigid bodies, which have
their geometry fixed over simulation time. Rigid
bodies are a pretty good approximation of many
real-world objects such as tables, walls, guns, trees
and cars. However, such objects are clearly not
suitable for modeling other real-world objects
whose geometry may change over time, such as
clothing, hair, ropes, foam bricks and tentacles.
You can model such objects using the second
class of objects known as deformable Objects.
Deformable objects have a mesh geometry whose
vertices change over time.

In reactor, deformable bodies are very versatile
and can be used in conjunction with rigid bodies.
When used with rigid bodies, deformable objects
can be used for character secondary motion.
Examples of character secondary motion include
hair, clothing, tentacles, tassels, wobbling flesh,
wing membranes and tails. Secondary motion of
this nature can also be applied to non-character
objects, for example cartoon effects such as
deformable cars. In addition, deformable objects
are useful for environmental effects such as
swinging ropes and chains, curtains, and flags
with dynamic wind.

Skill Level: Intermediate

Time to complete: 1 hour

Features Covered in This Tutorial

In this tutorial, you setup a scene with the four
main types of deformable object:

• Soft body, a deforming three-dimensional
closed triangular mesh.

• Cloth, a deforming two-dimensional triangular
mesh.

• Rope, a deforming one-dimensional chain of
vertices.

• Deforming Mesh, a deformable mesh who’s
vertices have been keyframed (e.g., skin on a
character rig).

Tutorial Files

You can find the files for this tutorial in the
tutorials\reactor\deformable folder on the Tutorial
Files CD that ships with 3ds Max. Before starting
the tutorials, copy the \tutorials folder from the
CD to your \3dsmax8 local installation.

Creating Cloth

In this section, you will do some home decoration
in a haunted house by putting up some curtains.
The emphasis in this is section is on creating cloth
using the reactor cloth modifier, setting up cloth
constraints, and fine tuning the cloth to make it
curtain-like using the cloth properties available
to you.

Prepare your scene

1. Reset 3ds Max.

2. Choose File menu > Open, then navigate
to \tutorials\reactor\deformable and open
deformable_tutorial_cloth_start.max.
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3. If the reactor toolbar is not visible, right-click
a blank area of the main toolbar and choose
reactor in the pop-up menu.

Create the curtains:

1. Press H and on the Select Objects dialog,
choose Curtain01 and click Select.

2. On the reactor toolbar, click Apply Cloth
Modifier.

You should see the cloth modifier in the
modifier stack.

3. Repeat the previous two steps for Curtain02.

Tip: When creating cloth, you can use any 2D
geometry. In this case, it’s a tessellated NURBS
surface. In reactor, the underlying topology
of the cloth object can influence the cloth’s

behavior. For instance, cloth will tend to fold
along contiguous edges, so if the topology is
very regular this will impact the behavior of
the cloth. In this case, you’ll create an irregular
tessellation.

Next you need to create a cloth collection to
place your curtains in.

4. On the reactor toolbar, click Create Cloth
Collection.

Tip: If you are working with lots of cloth,
you may want to move the cloth collection
somewhere easily accessible from within a
viewport.

5. In the Modify panel > Properties rollout, click
Add. Then choose Curtain01 and Curtain02
click Select.

Note: If you created the collection with the
curtain(s) selected, they were automatically
added to the collection, and will not show up in
the Select Cloths dialog.

6. On the reactor toolbar, click Preview
Animation, and then, when the window opens,
press P to play the simulation.

The curtains fall gracefully to the floor.
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Hang the curtains:

Next, you need to hang the curtains. This can be
easily achieved by using cloth constraints. If you
look behind the curtain, you will find a curtain rail
and some curtain clips. In this case, the curtain
rail and curtain clips are reactor rigid bodies and
the curtain clips have been keyframed to open
each curtain. Now, you will attach the curtain to
the curtain clips.

1. Select Curtain01, open the Modify panel, and
expand the reactor Cloth modifier.

2. Click Vertex to access the Vertex sub-object
level.

The vertices of the curtain should be
highlighted blue (unselected).

3. Expand the Constraints rollout (you may want
to close the Properties rollout for now).
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There are four different types of constraints to
choose from. In this case, you’ll use Attach To
Rigid Body.

4.

C:\epicuser\3dsmax_t\graphics\bu
Unable to perform the specified s

Click Attach to Rigid
Body.

A new constraint named Attach To Rigid Body
appears in the constraints list box.

5. Click the constraint in the list.

Tip: You can rename a constraint by clicking its
name twice. This is useful if you’re setting up a
complex cloth rig with many individual cloth
constraints.

6. In the Left viewport, select the rightmost two
vertices at the top of the cloth.

These are the vertices you’ll constrain.
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Next, you’ll pick the rigid body (the curtain
clip) to constraint the vertices to.

7. In the Modify panel > Constraints rollout, click
the new constraint that you just created. A
new rollout will appear (Attach To RigidBody).
There, click the Rigid Body button (currently
labeled None) and select the rigid body you
wish to attach to, in this case CurtainClip02.

Tip: Use the Select Objects dialog (press H) if
you have trouble selecting the clip object.

8. Repeat this for each of the curtain clips: Add
an Attach To Rigid Body constraint, click the
constraint in the list, select the vertices that
will be constrained, click the button on the
Attach To RigidBody rollout, and then select
the constraining clip.
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Tip: When reviewing which cloth vertices
are constrained, reactor colors constrained
vertices yellow and those vertices constrained
for the selected constraint red.

At this point it, would be a good idea to check
what is constrained so far by previewing the
scene.

9. On the reactor toolbar, click Preview
Animation.

You should see one curtain attached to curtain
clips being opened as the underlying clips are
keyframed.

10.Now that the left curtain is set up, repeat the
three-point constraint process for the right
curtain, Curtain02.

11. When both curtains are set up, preview
the animation again

Bring the curtains to rest:

The first thing you can see from the preview is
that the cloth does not begin its animation from
a natural state. In the first frame, the triangles
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in the curtains are completely coplanar, which is
unnatural for a set of curtains.

To correct this, you can use the Update MAX
functionality of the Preview window. This lets you
simulate your scene, bring the curtains to a natural
rest state, and then update 3ds Max with the new
state.

First though, you must tell reactor not to use the
current animation for the curtain rails (so the
curtains have time to settle). You can do this by
turning off the unyielding option for each of the
curtain clips.

1. Select all six curtain clip rigid bodies and
on the reactor toolbar, click Open Property
Editor.

2. On the Property Editor > Physical Properties
rollout, turn off Unyielding.

3. Play the preview, let the curtains come
to a nice rest state, and then choose MAX >
Update MAX in the Preview window.
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4. Close the Preview window.

The cloth in 3ds Max updates to take on the rest
state it had in the preview.

5. Select the six curtain clips and turn their
Unyielding property back on so their animation
will be used next time.

Tune the behavior of the curtains:

At this stage, you have a functional pair of curtains.
Now you can make a couple of adjustments
to fine-tune the behavior of the curtains. This
generally involves altering the various cloth
parameters.

1. Select one of the two curtains and, on the
Modify panel, click the reactor Cloth modifier,
if necessary.
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Notice that there is one keyframe stored in the
modifier, as indicated near the bottom of the
Properties rollout. This keyframe is the stable
state you updated from the Preview window.

The default values for the reactor Cloth modifier
are usually sufficient to simulate basic cloth-like
behavior and you can leave the majority of
the parameters set to their defaults. In this
case, you will look at two parameters: Avoid
Self-intersections and Constrain Deformation.

Avoid Self-Intersections is very useful for
creating realistic looking cloth. It prevents the
cloth from passing through itself.

2. Turn on Avoid Self-Intersections.

Tip: Avoid Self-Intersections is quite
computationally intensive. If you are setting
up your cloth and performing many trial

animations, you probably want to keep Avoid
Self-intersections turned off.

3. Next, turn on Constrain Deformation and
make sure Max % is set to 10.

The Constrain Deformation parameter is useful
if you want to reduce the stretching effects of
cloth in certain areas without increasing the
stiffness parameter. For instance, if you have
a heavy cloth constrained along its top edge,
the edges between this top edge and the next
row of vertices may stretch considerably due to
the mass of the cloth. One solution to stop this
stretching is to increase the stiffness, but this
can have adverse side effects such as making the
cloth jittery.

The Constrain Deformation parameter applies
an extra pass to the simulation to try to keep the
overall stretching of the cloth to a percentage
equal or less than the value specified. For
example, with a 10% value, reactor tries to
make sure that the distance between vertices in
the cloth doesn’t increase by more than 10%
during the simulation.

4. Preview the animation.

Now the curtains should look realistic.

Create the animation:

• On the reactor toolbar, click Create
Animation.

Now the animation is "baked" into 3ds Max.
You can now modify it and render it; for
example, you will usually apply a MeshSmooth
modifier on top of the reactor modifier. This
smooths out the surface, but does not affect
reactor in any way; reactor still works on the
coarser mesh. You can add lights, effects, etc.,
and render the scene.
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Creating Rope

So far, the haunted house is looking a little
exorcized of any ghostly spirit. In order to spook
it up a little, you’ll set some ropes spinning. Okay,
so that’s not so scary, but at least you’ll be learning
how to create dynamic ropes in 3ds Max.

Before you try this lesson, you should have
completed the previous lesson on cloth, as you will
be reusing some of the techniques learned in that
section.

To make the ropes in this lesson, you will start
with one rope, set it up the way you like, and then
make a copy of it. You can create a rope from any
spline object in 3ds Max. As ropes generally hang
from things, the scene contains a spinning wheel
rigid body. The wheel was constructed using a
CarWheel Constraint and is set up to spin around
the Z axis.

Tutorial Files

The file for this section is deformable_tutorial_
rope_start.max

You can find a completed version of this section in
deformable_tutorial_rope_end.max.

Procedures

Create the first rope:

1. Open the file deformable_tutorial_rope_
start.max from the \tutorials\reactor\
deformable directory.

2. Select Rope01 and, on the reactor toolbar,
click Apply Rope Modifier.

Tip: As mentioned previously, you can use
any spline shape when creating a rope object.
As with cloth, the reactor Rope modifier
constructs the geometry for the rope simulation
from the underlying topology. If you have only
two vertices in your spline, the rope simulation
geometry will only have a single section or
spring and will behave in a particular way. In
this example, the line has eight sections, which
lets the rope bend easily and behave realistically.

At this point, you should see the reactor Rope
modifier in the modifier stack.

3. Next you need to create a rope collection
to place the rope in. On the reactor toolbar,
click Create Rope Collection.

4. As with cloth, you need to add the rope object
to the rope collection to animate it. If the
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rope (Rope01) was selected when you created
the collection, it was automatically added.
Otherwise, use the Add button in the Modify
panel > Properties rollout to add Rope01 to the
collection.

5. On the reactor toolbar, click Preview
Animation and then press P (for Play).

The rope falls away under gravity.

Attach the rope to the spinning wheel:

1. Select the rope object, expand the reactor Rope
modifier in the modifier stack, and click Vertex
to go to the Vertex sub-object level.

As when constraining the Curtains in the
previous lesson, you’ll create an Attach to Rigid
Body constraint and designate a vertex and
rigid body to be in the constraint.

2. select the top vertex of the rope, and then on
the Modify panel > Constraints rollout, click
Attach To Rigid Body.

3. On the Modify panel > Constraints rollout,
click the Attach to RigidBody constraint in the
list.

The Attach to RigidBody rollout appears.

4. On the Attach to RigidBody rollout, click the
button and select RopeWheel. as the rigid body
for the attachment.

5. On the Attach to RigidBody rollout, turn on Do
Not Affect Rigid Body and Ignore Collisions.

For the former, you don’t want the ropes to
slow down the rotation of the wheel, and for the
latter, you are not concerned with any collisions
between the ropes and the wheel.

6. Preview the animation to check the
progress so far.

The rope looks a bit stiff. Next, you will make
it behave a bit more naturally.

Adjust the rope:

First, you’ll make Rope01 a bit more stretchy.

1. Make sure Rope01 is selected, and in the
Modify panel > Properties rollout > Rope Type
group, set Stiffness to 0.1.
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2. You also want to make sure that the rope
collides with itself. To do so, turn on Avoid
Self-Intersections

3. Finally, you’ll make the rope heavier. Set Mass
to 5.0 kg.

C:\epicuser\3dsmax_t\graphics\del_rope_set_mass.png
Unable to perform the specified scaling

Create additional ropes:

Now that you have one rope set up with the desired
behavior, you can create many copies of it around
the spinning wheel.

1. With Rope01 still selected, open the Tools
menu and choose Spacing Tool.

2. On the Spacing Tool dialog, set Count to 20,
and in the Type of Object group, choose Copy.

3. Click Pick Path, then press H and select Circle01
on the Select Objects dialog. In the Spacing
Tool dialog, click Apply, and then click Close.

This actually leaves you with 21 ropes. The
original rope is duplicated as Rope21.

4. Delete Rope21.
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5. Select RPCollection01 and go to the Modify
panel. Click Add, highlight Rope02 through
Rope20, and click Select.

6. On the reactor toolbar, click Preview
Animation.

Phew, pretty scary! All that remains now is to
create the animation within 3ds Max.

Create the animation:

• On the reactor toolbar, click Create
Animation.

Now you are finished with the Rope tutorial.
At this point, you should be able to create all
manner of interesting rope simulations.

Creating Soft Bodies

It’s time to add some possessed spirits into the
room to liven things up a little. To start, you will
add a simple squashy ball that will be followed by
some lively bananas.

Note: Before you work through this lesson, you
should have already completed the previous
sections on Cloth and Rope.

As with the previous sections, the scene starts out
with a couple of inanimate objects that you will
breathe some life into. In this case, you start with a
simple GeoSphere and a single banana made from
an editable mesh. The plan is to make soft bodies
out of these, make a few copies and animate them
bouncing down the stairs.

Note: There are two types of Soft Body: Mesh
Based and FFD Based. The primary difference is
that a mesh-based soft body directly modifies the
underlying mesh. It is useful for simple geometries
like balls. An FFD based soft body modifies an
FFD lattice which, in turn, modifies the underlying
mesh. FFD based soft bodies are generally used
when trying to deform a more complex mesh. As
a general rule of thumb, if a mesh has more than
200 triangles, it is a good idea to use an FFD based
soft body.



732 Chapter 9: Dynamics

Tutorial Files

The file for this section is deformable_tutorial_
softbody_start.max

You can find a completed version of it in
deformable_tutorial_softbody_end.max.

Creating a Mesh-Based Soft Body

You will start by creating the animation of a
mesh-based soft body.

Create a mesh-based soft body:

1. Choose File menu > Open and open
deformable_tutorial_softbody_start.max from
the \tutorials\reactor\deformable directory.

2. Select SquidgyBall. On the reactor
toolbar, click Apply Soft Body Modifier.

The reactor SoftBody modifier appears in the
modifier stack for the SquidgyBall object.

Next you’ll create a soft body collection to place
the squishy ball in.

3. On the reactor toolbar, click Create Soft
Body Collection.

4. If SquidgyBall was not selected when you
created the soft body collection, use the Pick or
Add buttons in the Properties rollout to add it.

5. On the reactor toolbar, click Preview
Animation.

The soft body should bounce down the stairs.
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As with all deformable objects, it is possible to
constrain the soft object vertices to a point in
space, a rigid body, another deformable body
and to keyframe its vertices. In this case, you
just wanted to make an otherwise boring mesh
more interesting so you are going to leave the
ball to fall under gravity.

After examining the behavior of the ball in the
preview window, it is sliding across the floor of
the room a little too much. To correct this, you
can change the friction value. Friction specifies
how much energy (speed) is lost when the soft
body is in contact with other objects.

The ball slides a little too much for our liking.

Modify the soft-body parameters:

1. Select the SquidgyBall, and in the modifier
stack, select the reactor SoftBody modifier.

2. On the Properties rollout, set Friction to 0.6.

3. Now, when you preview the simulation
again, the ball behaves a little more naturally.
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The ball slides less when friction is increased

4. Now that you are happy with the soft
body behavior, create the animation by clicking
Create Animation on the reactor toolbar.

Creating FFD-Based Soft Bodies.

As discussed previously, an FFD-based soft body
is one which deforms an FFD lattice which, in

turn, deforms a mesh that is contained within the
FFD lattice. Hence, a two step process is involved
when creating an FFD-based soft body. The first
step is to create an FFD around the object and
the second is to apply a Soft Body modifier. After
you have applied the Soft Body modifier, you can
opt to use either the original mesh or an FFD, if
it is available on the modifier stack. This lesson
assumes that you are familiar with the process of
creating an FFD lattice.

Create an FFD-based banana:

1. In the Left viewport, select Banana00 and apply
an FFD (Box) modifier to it.

Set the number of points for the FFD to 10x3x3.

2. With Banana00 selected, click Apply Soft
Body Modifier on the reactor toolbar.

3. Since the default type of reactor soft body is
the mesh-based soft body, you need to tell
reactor to use an FFD-based soft body. With
the reactor SoftBody modifier highlighted in
the modifier stack, go to the Properties rollout
and choose FFD-based.
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4. Select your soft body collection
(SBCollection01), and add the Banana00 soft
body to it.

5. Preview the animation.

Note: You can see that the display for an FFD
soft body is the FFD lattice. This is because
reactor uses only the FFD lattice for the
simulation. When you create an animation,
reactor animates the FFD lattice which, in turn,
animates the mesh. And the mesh is all you see
when you render.

You have created an FFD soft body to animate
the banana. Next, you’ll make the banana a
little more lively by modifying some of the
parameters.

Modify the soft body parameters:

1. Select Banana00, and make sure the reactor
SoftBody modifier is highlighted in the
modifier stack.

2. On the Properties rollout, set Stiffness to 0.4
and Damping to 0.1, and make sure Friction is
set to 0.6

3. Preview the animation again.
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Now that the behavior of the banana is more
interesting, you will add more bananas.

Create additional bananas:

• As with the ropes, you can just select the banana
and use the Spacing Tool to copy it (again,
make sure you use copy and not instancing). In
this case, add another 4 bananas to the scene
and move them so that they all start out in a

line. Remember to add them to the soft body
collection.

Creating the Animation

Now the scene is all set up, it’s time to "bake" the
animation into 3ds Max.

Create the final animation:

• Finally you can create the animation in
3ds Max to see how the FFD-based soft body
really behaves.

On the reactor toolbar, click Create Animation.

Note: The simulation may take a while to
compute. If you want to keep track of the
progress of the animation, you can turn on
Update Viewports in the Utility panel > reactor
> Preview and Animation rollout.
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Creating a Deforming Mesh

In this final lesson on Deformable Bodies, you will
add a ghostly spirit to the room. To accomplish
this, you will be working with a deforming mesh.
A deforming mesh can be thought of as an object
completely driven by 3ds Max that still has the
ability to collide with other reactor objects. For
example, the skin of a skinned character could
be a deforming mesh in reactor; any object and
attachments, such as clothing, would collide with

it. Also, any other deformable object can be
attached to deforming meshes, such as hair (rope),
soft appendages (FFD soft bodies), and so on.

Note: This lesson assumes that you are have already
completed the previous sections on Cloth, Rope
and Soft Bodies.

As with the previous sections, the scene starts out
with an inanimate object: in this case, a ghost. The
ghost is contains four main sections: a deforming
mesh that is the body of the ghost; a nose that will
become an FFD soft body; a ghostly tail that will
also be an FFD soft body; and some hair made
from splines, which you’ll convert into rope. The
body of the ghost has already been animated
(using skinning and a path controller), but is up to
you to add animation for the rest of the bodies.
This section is a good example of how you can use
secondary motion to liven up a scene.

Tutorial Files

The file for this section is deformable_tutorial_
deforming_mesh_start.max.

You can find the completed version of this tutorial
in deformable_tutorial_final.max.

Creating the Deforming Mesh

You will start by adding the deforming mesh into
the scene.

To add a deforming mesh to the scene:

1. Open deformable_tutorial_deforming_
mesh_start.max from the \tutorials\reactor\
deformable directory.

Deforming meshes differ from other
deformable objects in reactor in that a modifier
does not need to be applied, because reactor
does not modify its vertices. In fact, it presumes
that the vertices will be modified by another
modifier such as a skin and bones system like
Physique, or by any other animation tool. The
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only step involved when creating a deforming
mesh is to place the mesh into a Deforming
Mesh Collection (DMCollection).

2. On the reactor toolbar, click Create
Deforming Mesh Collection. Click in any
viewport to create the collection.

3. On the Modify panel > Properties rollout, click
Add and select GhostMesh to add it to the
collection.

4. On the reactor toolbar, click Preview
Animation.

The ghostly spirit hovers in the center of the
room.

Adding Attachments to the Ghost

Next, you attach some more appendages to make
the ghost a little more lively.

Add an FFD nose:

1. Select the GhostNose object and apply an FFD
(box) modifier. Set the Number of Points of the
FFD box to 6x4x6.

This will result in a suitably wobbly nose

2. On the reactor toolbar, click Apply Soft
Body Modifier.

3. On the Modify panel > Properties rollout,
choose FFD-Based for the reactor SoftBody
modifier.
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To keep the nose firmly attached to the ghostly
head, you need to attach some vertices. To
do this, you can use the Attach to DefMesh
constraint.

4. On the Modify panel > Constraints rollout,
click Attach to DefMesh.

The Attach to DefMesh rollout appears.

5. On the Attach to DefMesh rollout, click the
button labeled None. Press H and select
GhostMesh in the Select Object dialog.

6. Go to the Vertex sub-object level for the reactor
SoftBody modifier.

7. Select the vertices of the FFD soft body that are
nearest to the GhostMesh object.

On the Modify panel > Attach to DefMesh
rollout, turn on Ignore Collisions, as you are
not concerned with collisions between those
vertices and the Ghost Mesh.

Next, you’ll create a soft body collection to put
the nose into.

8. On the reactor toolbar, click Create Soft Body
collection button, and add the GhostNose
object to it, if necessary.

9. Preview the animation.

10.Select GhostNose, and on the Modify panel >
Properties rollout, set Stiffness to 0.3.

Add an FFD tail:

• Repeat the above process for the GhostTail
object (attach it to the bottom of the ghost).
Use a 4x4x4 FFD for it.
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Note: You have finished setting up the two FFD
soft bodies. In the next section, you don’t need
them to be simulated during preview. Since
FFD soft bodies can be quite computationally
expensive, you may want to disable the soft body
collection containing the nose and tail until the
rest of the scene is set up and you actually create
the animation. You can do this by selecting the
soft body collection, going to the Modify panel >
Properties rollout, and turning on Disable.

Adding Some Dreads

Note: As in the Rope section of this tutorial, you
are going to create some reactor ropes to simulate
some dreadlocks on the ghost head. The workflow
for this section is quite similar to the rope section
so hopefully you have been through that already.

Create the dreads:

1. As before, the goal is to get one dread (rope)
working the way that you want and then copy
that one.

Select GhostHair01. On the reactor
toolbar, click Apply Rope Modifier.

2. Attach the rope to the GhostMesh object using
its closest vertex and an Attach to DefMesh
constraint.

3. With the reactor Rope modifier highlighted,
go to the Modify panel > Properties rollout, set
Thickness to 0.5 and make sure Rope Type is
set to Constraint.

4. Create a rope collection and add GhostHair01
to it.

5. Now that you’ve finished setting up the rope,
make a few copies and add them to the rope
collection. Make sure the rope ends don’t
penetrate the head.



Creating a Deforming Mesh 741

At the moment, the dreads on the ghost start
the animation in an unnatural position. As
with the curtains, you can simulate the rope in
the Preview window, allow the ropes to settle
under gravity, and then use MAX > Update
Max to update their position.

Let the dreads settle:

You will need to first "freeze" the ghost so it doesn’t
move while the ropes settle.

1. Select the Deforming Mesh collection, and on
the Modify panel > Advanced rollout, turn on
Freeze.

2. Preview the animation. Wait until the
hair settles and then choose MAX > Update
Max.
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3. Unfreeze the Deforming Mesh collection.

Creating the Animation

Now that you’ve set up the entire scene, it’s time to
see the final result.

Create the animation:

1. If you disabled the soft body collection after
setting up the nose and tail, you should now
re-enable it.

2. On the reactor toolbar, click Create
Animation.

Pulling It All Together

So far, you’ve been working on an isolated part of
the scene; the animations done in the previous
section have been hidden. By clicking Unhide All
in the Display panel, you can see the results from
each of the other sections. Notice how during each
section you’ve been simulating isolated subsets
of the scene; that way you can concentrate in a
particular part of the scene without re-simulating
those other parts you are already happy with,
minimizing the overall time spent creating
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animations. Notice, though, that you can do
this only when there are no interactions between
the different subsets. For example, you created
the animation for the curtains separate from the
ghost because you knew that those objects would
not interact. This was achieved by disabling the
collections of the objects that you didn’t wish to
simulate.

You can find a completed version of this tutorial in
deformable_tutorial_final.max.

Hair

Using Hair

The tutorials included in this section walk you
through a variety of methods for using Hair. For
best results, follow the tutorials in this order:

• Creating a Centurion Helmet (page 2–743)
(three parts)

• Grooming a Dog (page 2–749)

• Styling Hair with a Spline Emitter (page 2–752)

• Styling Hair with Recomb From Splines (page
2–757)

• Working with Instance Objects (page 2–759)

• Working with Surface Lock (page 2–760)

• Transplants, Wigs, and Toupees (page 2–762)

Tutorial Files

All the necessary files to do the tutorials can be
found in the \tutorials\hair\ folder.

Creating a Centurion Helmet

The concepts covered in this tutorial are:

• Adding the Hair and Fur modifier and defining
its general properties

• Modifying the material properties of the hair

• Adding lights and rendering the hair.

Add the Hair and Fur modifier to the helmet:

1. Open helmet_hair_start.max from your
\tutorials\hair folder. This scene contains two
mesh objects named Head and Helmet.

2. Select the Helmet object, and then go to the
Modify panel and apply the Hair and Fur
modifier (World Space Modifier).

Hair guides emanate from the entire helmet.

3. The hair should grow only on selected
portions of the helmet, so access the Hair and
Fur modifier Polygon sub-object level and
select the polygons on the helmet that will serve
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as emitters for the hair modifier. In this case,
they’re the polygons at the top of the helmet.

4. On the Selection rollout,
click Update Selection.

The hairs now emanate only from the selected
polygons.

Modify the Hair general parameters:

1. Scroll down to the General Parameters rollout
and change the hair count to 10000.

2. Reduce Hair Segments to 4. This is the number
of segments created along the length of each
hair. You’ll need more segments for longer hair,
and fewer for shorter hair. This also reduces the
amount of time it takes to render the scene.

3. Change the Rand(om) Scale value to 0.0.

For this example, the helmet hair is all the same
length, without any random scaling.

4. Set the Root Thick and Tip Thick values both
to 2.0 so that the hairs are the same thickness
along their entire length.

Next you’ll change the frizz and material
properties of the hair.
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Modify the Frizz and Material Properties of the
helmet crest:

1. On the Frizz Parameters rollout, set the Frizz
Root and Frizz Tip values to 10.0.

2. In the Material Parameters rollout, select a
bright, saturated red for the Tip Color and
black for the Root color.

3. Reduce both Hue Variation and Value Variation
to 5.0.

Because this is artificial hair, its color and
texture are more uniform than natural hair. We
want to add a bit of variety, but not much.

4. Leave the Mutant % value at 0.0.

Mutant hairs are randomly selected and receive
the color assigned. Mutant hairs are present in
natural hair; as we age, we have more and more
mutant gray (or white) hairs. However, the foot
solder’s helmet plume will not age (they used
dyed horsehair), so you’ll leave the mutant hairs
out for now.

Render your scene to view the hair:

The Hair and Fur modifier requires at least one
spot light in the scene to render shadows.

1. From the right-click quad menu, unhide the
lights in the scene.
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Two omni lights for general lighting and one
spot light for the Hair and Fur modifier appear.
The spot light is set to render shadows.

A Hair and Fur render effect is necessary to
render hair, but this is added automatically
when you first apply the Hair and Fur modifier
to an object in the scene. Also, by default the
render effect is set to automatically use all spot
lights in the scene to illuminate the hair, so no
further action is needed on that front.

You can now render your scene.

2. With the Perspective viewport active, render
your scene (F9).

Note: You can render hair only in a Perspective
or Camera viewport.

Your centurion helmet should look something
like this:

Rendered image of the helmet.

Next

Recombing the Helmet Crest of Hair (page 2–746)

Recombing the Helmet Crest of
Hair

In this lesson you’ll learn how to style the hair
using the Recomb From Splines tool.

1. Continue from the previous lesson or open
recomb_helmet.max.

2. Before you begin to draw the splines, turn on
Snaps Toggle (press S) so that the start of the
splines begin at the roots of the hair. Also,
right-click the Snaps Toggle button to open the
Grid And Snaps Settings dialog, and on the
Snaps panel, turn off Grid Points and turn on
Face. Close the dialog with the X button in the
upper-right corner.

3. Starting at the front of the helmet, draw Line
splines away from the head as illustrated below.
Hair requires that all the splines are part of the
same object, so after you draw the first spline,
turn off the Start New Shape check box on the
Object Type rollout.
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1. Select the Helmet object, and click Tools rollout
> Recomb From Splines. In the Perspective
viewport, click the spline object.

The hair now follows the shape of the splines.

2. Render your scene to view the new hair.

Next

Adding Facial Hair to the Centurion (page 2–747)

Adding Facial Hair to the Centurion

Now that you have the helmet ready to go, you’ll
add hair to the centurion’s face.

1. Continue from the previous lesson, or open the
file recomb_helmet_splines.max.

2. Apply the Hair and Fur modifier to the head.
Go to the Polygon sub-object level, and select
the polygons at the base of the chin. Click
Update Selection.

3. In the Presets group of the Tools rollout, click
Load. Double-click the “clumpy-wet-brown”
preset to apply it to the polygons.
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4. Render the Perspective viewport.

You now have fine, spiky hair growing from
the chin. However, the model needs better
lighting. To better view the hair growth, you’ll
add another spot light to the scene.

5. In the Top viewport, zoom out, select the
existing spot light, and with the Shift key held
down, drag it to the front of the model. When
the Clone Options dialog appears, choose Copy.

Now the scene contains two spot lights.

6. Render the image again to preview the results.

Style the goatee:

1. Click the Tools rollout > Style Hair button to
open the Style dialog.

2. Press and hold the B key and then move the
mouse until the brush circle encompasses most
of the goatee hair. Click to set the size.

3. Click the Clump button and then drag
leftward to move the hairs together until they
are positioned as illustrated below.

4. Click the Translate button, and drag the
brush to straighten the hairs.

5. Click the Preview button to view how
the rendered hair will be positioned. To exit
Preview mode, press theESC key.

6. When you are happy with the results, click
Done and render the scene.

The hair still frizzes out a bit too much at the
tips.

7. Go back and change the Frizz Tip value to 0.0.
Render the scene again to view the changes.

8. Try experimenting with the colors and Mutant
% value on the Material Properties rollout to
age the centurion’s goatee. The example below
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shows what happens when you apply values of
25%, 50%, and 100%.

Grooming a Dog

In this tutorial you’ll use Hair to add fur to a dog
model, and then groom the fur. The tutorial also
covers preparing the model for automatically
growing fur of different lengths by adjusting
polygon sizes.

Set up the lesson:

• Load the file dog_groom_start.max. This is
located in the \tutorials\hair\ folder.

This scene contains a cartoon dog model.
The dog was created using the box-modeling
method, and was then mesh-smoothed. This
automatically creates smaller polygons where
the hair should be shorter, such as on the legs.

Apply Hair and Fur and choose a preset:

• From the Modifier List drop-down >
World-Space Modifiers category, choose Hair
and Fur (WSM).

The hairs appear as red lines emanating from
the dog model.

Groom the fur:

1. On the Tools rollout, click Style Hair.

The Style dialog opens. By default, all the
guides are standing perpendicular to the mesh
surface, and are all the same length. If you like,
rotate the view so it resembles the following
illustration.

At the start, all the guides stick straight out.

2. On the toolbar, click the Attenuate
button.

Attenuated guides

The hair length is now directly proportional to
the size of the underlying polygons, which is
handy because most animals have shorter hair
in areas with higher details, such as the head.

3. If you haven’t done so already, rotate the view
so you can see the dog from the side. Press and
hold the ALT key and MMB-drag (drag with
the middle mouse button held down), or press
and hold CTRL+R and move the mouse.
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The Style dialog starts you out in
Brush/Drag/Translate modes; you’ll use
these to begin grooming the dog.

4. Size the brush. Press and hold the B key and
then move the mouse until the brush is about a
third the size of the dog.

5. On the toolbar, click the Select by Hair
Ends button.

6. Stay in Brush mode and drag the fur in the
general directions it should flow; don’t worry
about the hair penetrating the dog.

The dog after partial brushing

Because this is a big soft brush, you can get a
fairly smooth transition from one direction to
another. As you continue to groom, make the
brush smaller for fine-tuning the fur.

7. After every drag or two, press the R key
(Recomb).

Recombing “tames” the guides.

The Recomb function snaps all the hair that
you’ve just brushed to the surface’s tangent,
while preserving direction and length.

8. Repeat the two previous steps until you’re
happy with the general flow of the fur.

The dog after further grooming and recombing

9. Click the Scale tool and go around
manually adjusting the guide lengths. You
might want to make the brush smaller and
smaller as your tweaks become more refined.
The hair on the ears should be a bit shorter, and
you might want to grow the hair on the snout
out a bit.
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Scale the guides in places where the fur should be
shorter.

10. Now go to Select Whole Strand
mode, and choose the Stand tool.

This brush pushes the hair away from the
skin. Natural fur usually stands out at about
60 degrees from the surface; you can also use
the Translate brush at a side angle to do this. In
this case, you’re making something more like
a stuffed animal, so you can stand it out a bit
more than normal.

11.Go around the model, puffing the guides out
away from the surface.

Use the Stand tool to make the guides stick out more.

12. Click Preview and check your work. If
the dog needs further grooming, you’ve got a
pretty good idea how to do it by now.

13.When you’re satisfied with the grooming, exit
the Style dialog by clicking Done. Be sure not
to click the close button [X] in the upper-right
corner, or you’ll lose your work.

Adjust settings and render the dog:

1. This is a toy dog, so you can use unreal coloring
to enhance the effect. On the Modify panel >
Material Parameters rollout, set Tip Color to a
medium green (R=95, G=157, B=45) and Root
Color to a slightly darker green (R=61, G=145,
B=45). Also set Occluded Amb to 96.4 and
Hue Variation to 40.0. The fur shouldn’t be too
shiny, so set Specular to 8.365 and Glossiness
to 71.28.

The scene already contains two spot lights,
both set to cast shadows in the form of shadow
maps. Because the Hair and Fur render effect
uses these by default, the spot lights will
automatically cast shadows from the hair.

2. On the General Parameters rollout, set Hair
Count to 329000, Hair Passes to 3, Root Thick
to 5.0, and Tip Thick to 1.0.

Note: These settings make the dog quite furry.
It will take a while to render, but the results are
worth the wait.

3. On the Frizz Parameters rollout, set Frizz Tip to
20.0, and Frizz X/Y/Z Freq (all three) to 64.0.

4. Activate the Perspective viewport, if necessary,
and then press F9 to render the scene.
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The dog appears in all its furry glory.

Styling Hair with a Spline Emitter

Some hairstyles, particularly longer ones, lend
themselves more naturally to spline interpolation
than surface growth. Spline-based hair basically
gives you explicit control inside 3ds Max over a
finite set of guide hairs. When you create hair
with a spline object as the growth source, Hair
creates a guide from each spline in the object.
It then uses these guides as cross-sections to
create hair growth. Essentially, you’re creating a
three-dimensional “sheet” of hair in the shape of
the spline cross-sections.

For success with spline-based hair, keep these
important requirements in mind:

• Hair growth is interpolated between each pair
of successively numbered splines. The best way
to ensure this is to create the splines that serve
as the hair outline as separate objects, and then
attach them all together in the correct order.

• Interpolation between pairs of splines is linear,
so use as many splines necessary to create a
rounded look for your hair.

• The first vertex in each spline serves as the hair
root, so when you create the splines, start at the
base of each hair.

In this tutorial, you’ll create two different spline
objects, both comprising a number of Line splines,
to create a woman’s hairdo. The hairdo will have
bangs in the front, with a flip on the sides and long,
straight hair in the back.

Set up the tutorial:

1. Open the file spline_emitter_start.max.

The scene consists of a simple head mesh and
three shadow-casting spot lights that are hidden
at this time. Instead of using the mesh as a hair
emitter, you’ll create a spline-based outline for
the hair.

2. Select the head in the scene and right-click on
it. From the Quad menu that appears, choose
Freeze Selection.

3. On the main toolbar, right-click the
Snaps Toggle button to open the Grid And Snap
Settings dialog.

4. The only snaps option that should be on is
Face. As necessary, turn off any other options
and turn on Face.

5. In the Grid And Snap Settings > Options panel,
turn on Snap To Frozen Objects.
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6. Click the close button in the upper-right corner
to exit the dialog, and then left-click the Snaps
Toggle button to turn on snapping to faces.

Create the spline cage for the hair:

In this section you’ll create the splines for the hair.
In that respect, you have to consider the design of
the hairdo and the parting of the hair. The red line
in the following illustration shows where the hair
part will be. You will use it as a base line for the
hair splines as they flow on either side of the head.

The hair part line

1. Go to the Create panel and choose Splines >
Line. Make sure Initial Type and Drag Type are
both set to Smooth.

2. In the Perspective viewport, position the mouse
at the front of the parting line seen above, and
then click to start the spline. Move the mouse
partway down the left side of the head and
click again. Move it farther down and slightly
back, click again, and then move it down and
closer to the front to create a nice flowing curve.
Right-click to end.

The four-vertex spline is not smooth enough to
follow the contours of the head. You will make
the necessary adjustments later but for now,
press F3 to view the scene in wireframe mode..

3. Continue adding splines. Start the next one
a little further back from the first. Likewise
for the third and fourth. Continue around the
back, always placing the spline base points
along the parting line of the hair. use the
following image as a reference.

Adjust the spline cage

1. Go to the Display panel. In the Hide
rollout, turn on Hide frozen Objects. This hides
the head object from the scene.
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2. Select the first spline you created: Line01,
and then go to the Modify panel.

3. From the Geometry rollout, click the Attach
button.

4. Attach the splines sequentially, moving
clockwise around the head. The sequential
numbering of splines in the spline cage is
very important for the hair modifier to work
properly.

5. Go back to the Display panel and turn off
Hide frozen Objects.

6. With the spline cage selected, go to the
Modify panel and rename the object Hair

7. Go to the Vertex sub-object level. Looking at
the top of the head, select all the first vertices
representing the hair roots.

8. Press CTRL+I to invert the selection.

9. From the main toolbar, choose the Scale
tool and set the scale pivot to Use Selection
Center

10.Scale the selection up so that the splines flow
more naturally around the head.
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11.Adjust the individual vertices so they fit the
shape of the head nicely, floating just above
the mesh. Make the necessary adjustments
to follow the design of the hairdo you have
set yourself to achieve. If necessary, refine the
splines to add vertex control to shape the spline
cage with more detail.

Apply the hair and settings:

1. Continue working on your file or open the file
spline_emitter_hair.max

2. With the Hair object selected, apply a Hair and
Fur (WSM) modifier.

Hair and Fur modifier applied to splines (Display Hairs >
Percentage increased to 10.0 for better visibility of hair)

3. Make the following parameter settings:

General Parameters rollout:

• Hair Count=600

• Hair Segments=25

• Hair Passes=4

• Root Thick=0.6

• Tip Thick=0.4

Note: These parameters control the number of
hairs, their curvature and size.

Material Parameters rollout:

• Occluded Amb=0.0

• Tip Color= Dark brownRGB [34,28,13]

• Tip Color= Dark brownRGB [29,24,11]

• Hue Variation=15

Note: These parameters control the material
properties of the hair, such as color and
specular values.

Frizz Parameters rollout:

• Frizz Root=80

Note: This parameter adds a certain amount
of noise to the root of the hair, making it look
denser and more natural.

Multi Strand Parameters rollout:
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• Count=5

• Root Splay=0.85

• Randomize=15

Note: These parameters add a certain amount of
clumping around the rendered hair.

Note: These parameter settings shown above
were determined through experimentation.
You might find other settings work better for
your hair; feel free to revise the suggested values
as you see fit.

4. Render the hair from various angles, and adjust
spline vertices and settings as necessary.

Note that adjusting the splines causes the
interpolation of the red display hairs in the
viewports to change in real time.

To see our final results, open the file
spline_emitter_final.max. Your results may
differ significantly; there are many variables in
projects like this.

The final results, rendered from the different viewpoints

Working with Presets

1. Continue working on your file or open the file
spline_emitter_final.max.

Note: Now that you have adjusted the hair
parameters, you will save a hair preset for later
recall.

2. With the Hair object selected, go to the
Modify panel and expand the Tools rollout.

3. In the Presets group, click the Save button.

4. In the dialog that appears, name the preset
Brown_Hair and then click OK.

5. Click the Load button to view a list of available
presets.

The preset you just saved is displayed in a
thumbnail called Brown_Hair.shp.

6. Double-click the platnumBlond.shp preset to
load it.

7. Render the scene to view the results. The
character now has light blond hair, but the
parameters need adjustment.

Tip: Instead of starting from scratch, it is
sometimes easier to start with a preset and
adjust its parameters to get the effect you are
aiming for.
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8. Adjust the parameters of the platinum blonde
preset to get better results. Feel free to
experiment with various values. If you wish,
you may use the following settings:

• Hair Count=2000

• Hair Segments=20

• Hair Passes=3

• Root Thick=0.7

• Tip Thick=0.4

• Frizz Root=50

• Frizz Tip=0

• Multi Strand Count=4

• Root Splay=0.2

9. Render the scene to test the results.

Styling Hair with Recomb From
Splines

While the Style dialogue has many powerful
sculpting features, it’s more like jazz; you work with
gestured movements. Some times it’s desirable to
start by laying down some composition first.

For doing this, you have the Recomb From Splines
command. You can create an arrangement of

splines, and then use Recomb From Splines to
apply the splines to the Hair and Fur modifier
guides. The splines don’t have to be right on the
mesh surface. They also needn’t be lined up in any
particular order, as with spline growths. Instead,
they’re used for controlling a mesh growth’s initial
state.

One useful workflow for styling haircuts, is to lay
down some splines directly on the head, keeping
in mind their lengths and shapes, with particular
attention to detail around the part and whorl. This
is where this tutorial will begin.

When working with Recomb From Splines, keep
the following points in mind:

• You don’t need many splines.

• You can generate the splines from another
object’s haircut with Tools rollout > Convert:
Guides -> Splines or Hair -> Splines.

• The order of creation of the splines is
unimportant, unlike spline growths, but the
root-to-tip vertex order is.

Set up the tutorial:

1. Open the file spline_recomb_tutorial_
start.max.

The scene contains a mesh object named
head plus a group of splines and some lights.
Examine the splines object, and, if you like, add
some splines to it.
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2. Apply the Hair and Fur modifier to the head
object.

3. Select a set of polygons and set some initial
parameters. For example, you might want to
turn down settings such as Frizz and Rand
Scale so the recombing results are clear.

4. On the Tools rollout, click Recomb From
Splines, and then select the splines object.

The hair now follows the splines, but is pretty
flat.

5. Go into the Style dialogue and give the guides
some volume. You could simply use the Stand
brush, or just move them around with Translate
brush. Then go around and fine-tune the
length with a Scale brush or a Cut brush [C].

6. Back in 3ds Max, you’re ready to go.
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7. Render the scene now, or load spline_recomb_
tutorial_finished.max and then render.

Working with Instance Objects

Many natural objects possess properties similar
to hair and present comparable challenges with
regard to modeling for CGI. Things like feathers,
leaves, flowers, and scales can all be described with
a system similar to hair, but in place of each hair,
we grow an object.

When working with instances, please keep the
following points in mind:

• You’re creating geometry, even if it is only at
render time, so memory is a limitation on hair
count. For this reason, start with a low polygon
count.

• The material applied to your growth is inherited
from the growth object, not the instance itself;
only UVs come from the instance.

• The root of the instance, where the 3ds Max
pivot is, will be at the root of where the hair
would otherwise be.

• The shape, including the size, bend, etc.
result directly from hair properties and other
influences on the hair.

• Despite the terminology, objects created with
Hair’s Instance Node function are not instances

of the original object, and do not automatically
reflect subsequent changes to the original.
To affect the resulting hairs, use the Instance
Node group > Replace button after editing the
original object.

Set up the tutorial:

1. 1. Open the file instancing_start.max.

The scene consists of a dog model with Hair
applied and a plane mapped with a leaf image.

Note that the dog model has already been
textured with the same material as the leaf.

2. Render the scene.

3. Select the leaf object.

Note also that the object’s pivot is at its base,
where it should connect with the dog’s skin. If
it weren’t, you’d need to go to the Hierarchy
panel > Adjust Pivot rollout, turn on Affect
Pivot Only, and then move the pivot to the
proper location.
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4. Select the dog object and open the Tools rollout.

5. In the Instance Node group, click the Pick
button, and then select the leaf object.

6. Render the scene.

Working with Surface Lock

One of the really useful tools Hair offers is the
ability to lock hairs to a surface. This feature allows
you to create features such as a braid as easily as
you can model one. In this tutorial you’ll use the
surface lock feature to create a twist of hair.

Set up the tutorial:

1. Open morph_braid_start.max.

This scene contains three cylinders combined
into a single object named Braid surface that
morphs into a braid. This braid geometry is not
renderable since its only purpose is to deform
the hair.

2. Select Braid surface and note the hair settings.

When locking hair to a surface, you are actually
locking the guides to the surface, so it’s a good
idea to keep parameters that spread hair away
from the guides low, such as Random Scale and
Frizz. For realistic hair you can set them a little
higher than 0, and it’s also good to use a higher
Hair Segments value to improve deformation.

3. At the Polygon sub-object level of the Hair
and Fur modifier, select the top polygons of
each cylinder as shown and then click Update
Selection.

You’ll grow hair from the tops of the cylinders
and then drape it down around the surface.

4. On the Tools rollout, click Recomb From
Splines and then pick the Spine Guides object.
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The hair aligns to the direction and length of
these splines.

You could easily create these splines from
edges of the geometry, drawing them by hand,
or styling them in the Style dialog and then
converting guides to splines. Or you could just
create the same hairstyle using the styling tools
and skip the splines altogether.

The next step is to lock the hair to the surface of
the cylinders, which you do in the Style dialog.

5. Click Tools rollout > Style Hair.

By default, all the guide vertices are selected, so
you don’t need to select any.

6. Click the Lock Selected Vertices button.

In other situations, it might be desirable to lock
only specific parts of the hair to a surface, for
instance, to wrap hair around curlers, or tuck
pieces behind the ears.

7. Click Done to exit the Style dialog.

Now the hair is locked to the Braid Surface.

8. To deform the hair, turn on the Morpher and
Path Deform modifiers in the stack. Go to
frame 20 to render the effect.

For animation, the braid mesh can be skinned
to a bone chain, instead of posed with Path
Deform.

9. To see the final result, open morph_braid_
finished.max.
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Note: This scene contains a few extra Hair and
Fur modifiers to create layered growth effects.

Transplants, Wigs, and Toupees

Once you’ve created hair, you can use any of a
variety of ways to move mesh growth hair from
one character or creature to another. Here we
discuss three of them.

Method 1 - The Toupee

This method is relatively simple. You start with
a file that contains a head with mesh-growth
hair. The idea is to get rid of any unnecessary
geometry in order to move this hair elsewhere.
Technically, you could just make the whole head

non-renderable, but instead you might just want
to create a library of custom hair setups, retaining
only the essential geometry; that is, only the
polygons from which the hair grows.

1. Open the file toupee_start.max.

2. Select the head mesh, and then, on the Tools
rollout, click Hairdo > Copy.

This caches the full hair description, both
guides and materials.

3. Go to the Editable Mesh stack level and access
the polygon selection you used to grow the hair.
If you’ve lost the selection, you can restore it
by copying it from the Selection rollout of the
Hair and Fur modifier, and then pasting it to
the mesh.

4. Invert the selection, and then delete it.

5. In the modifier stack, highlight the Hair and
Fur modifier.

Your selection has probably been scrambled a
bit.

6. Select all polygons, and on the Selection rollout
of the modifier, click Update Selection.

The hair now looks approximately like it did
originally, but not exactly.

7. On the Tools rollout, click Hairdo > Paste.
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You now have a hair toupee that you can plant
under the skin of your character(s). For best
results, make the surface non-renderable.

Method 2 - The Wig

1. Open the file wig_start.max.

2. If the Hair Count value is high, as it is in this
file (22,000), reduce it by a large factor (for
example, 1/20) and, if necessary, set Multi
Strand Parameters rollout > Count to 0.

3. On the Tools rollout of the Hair and Fur
modifier, click Convert > Hair -> Splines.

4. Delete the original mesh object.

5. Select the resulting spline object and then apply
a Hair and Fur modifier.

This creates a spline growth.

Because it’s a spline growth, not a mesh growth,
the interpolation is uneven. To resolve this,
you’ll disable interpolation.

6. On the General Parameters rollout, turn off
Interpolate.

This means that Hair won’t fill in between the
guides. In other words, you’ll have one hair per
spline, if Hair Count is set high enough.

7. Turn off displacements by setting values such as
Frizz, Kink, and Rand Scale to 0.0.
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The original values are already reflected in the
spline object you created.

8. On the Multi Strand Parameters rollout, set
count to 20 or so, and also set low values such
as 0.5 for Root Splay and Tip Splay.

9. Render the scene.

You now have a hair description that is
independent of any mesh, upon which you can
run dynamics if you like.

Method 3 - The Transplant

1. Open the file transplant_start.max.

You’ll transplant this growth onto a different
model. You can summarize this procedure by
clicking Tools > Hairdo > Copy, selecting a
target surface that’s positioned as closely as
possible to the source, adding a Hair and Fur

modifier, and then pasting the hairdo. Instead,
in the following steps you’ll use a lengthier
method in order to learn what goes on inside
Hair when you copy and paste hairdos.

2. On the Tools rollout, click Convert >
Guides->Splines.

This differs from the Wig lesson (above) in
that this time we’re interested in the guides
themselves.

3. Save the material by clicking Tools rollout
> Presets > Save. Name the preset
temp_hair_material.

4. The head is no longer necessary, so delete it.

5. Position the spline object created in step 1
around a new growth mesh. In this example,
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we used a Capsule primitive, but feel free to use
any type of object you like.

6. Apply a Hair and Fur modifier to the growth
mesh and then select the polygons from which
the hair should grow.

7. Recover the original settings by clicking
Tools rollout > Presets > Load and then
double-clicking the temp_hair_material preset.

8. Click Tools rollout > Recomb From Splines.
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Technically, you don’t need the spline object
anymore, but you might want to keep it around
for a future hairdo.

9. Render the scene.

Cloth

Cloth Tutorials

Laura by Georges Walser

The tutorials included in this section walk you
through a variety of methods for using Cloth. For
best results, follow the tutorials in this order:

Creating a Billowing Flag (page 2–766)

Designing a Shirt (page 2–771) (in three parts)

Tailoring and Fine-Tuning (page 2–786)

Using Cloth with Bipeds (page 2–789)

Creating Pleats (page 2–790)

Creating an Umbrella (page 2–793)

Creating a Billowing Flag

This quick-start tutorial will introduce you to
some of the basic concepts you’ll need when using
Cloth. It is meant simply to provide an overview
to the Cloth modifier. Do not be concerned if you
don’t understand the entire process, as the "why"
will be explained further in the later tutorials.

The concepts covered in this tutorial are:

• Quick use of Garment Maker for splines
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• Applying the Cloth modifier

• Locking points on the cloth to the flagpole

• Adding a space warp (for wind)

• Adding a collision object (for flagpole)

• Running the simulation

• Adjusting fabric properties

Create a cloth flag from a spline object:

1. Load quickstart.max from your \tutorials\cloth
folder.

This scene contains a rectangular spline object
named Flag and a cylinder named FlagPole.

2. Select the rectangle shape named Flag and
apply the Garment Maker modifier to it.

Modifier stack with Garment Maker modifier applied to
the Editable Spline object Flag
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The resulting Flag object is now a 3D mesh.

This turns the 2D spline into a 3D mesh that
you can use as cloth.

The corners of the new mesh get "rounded"
because the flag spline was not set up correctly.

3. Delete the Garment Maker modifier.

The spline object reverts to its original status.

4. Access the Vertex sub-object level and then
select all four vertices of the spline (press
CTRL+A).

5. On the Geometry rollout, click Break.

Flag with vertices broken

This causes the segments within the spline
to become independent, as shown above.
This preserves the corners when you apply
Garment Maker. Whenever you have a spline
that changes appearance after the application of
Garment Maker, check the vertices and break
the ones that cause this kind of issue.

6. Exit the sub-object level and then reapply the
Garment Maker modifier.

Flag with Garment Maker applied

Apply and set up the Cloth modifier:

1. With the Flag object still selected, apply the
Cloth modifier to it.

2. On the Object rollout, click the Object
Properties button.

This opens the Object Properties dialog.
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First, you’ll tell Cloth which objects should be
part of the cloth simulation. Currently only
Flag is present in the left-hand column of the
Object Properties dialog; the FlagPole object
should be part of the simulation as well.

3. On the Object Properties dialog click the Add
Objects button, select FlagPole, and then click
OK.

This adds the FlagPole object to the simulation.

Next you’ll set which Objects are to act as cloth
and which objects the cloth will interact or
collide with.

4. In the list on the left side of the Object
Properties dialog, click Flag, and then click the
Cloth radio button.

This tells the simulation that Flag is to be a cloth
object.

5. In the list on the left side of the Object
Properties dialog, click FlagPole, and then click
the Collision Object radio button.

This tells the simulation that FlagPole is a
collision object with which the cloth object can
interact.

6. Click OK to close the Object Properties dialog.

Run the simulation:

Before you simulate, it’s a good idea to check the
cloth scale to make sure you get the results you
might expect. To do this, you’ll measure the flag
as it relates to the cloth simulation. Cloth works
in real-world units to create its simulation, so it’s
important to make it a habit to check the size of
your objects.

1. Go to the Create panel and click the Helpers
button.

2. Click Tape, and then in the Front viewport drag
out a Tape helper to determine the width of the
flag.

You’ll find that it is approximately 165 3ds Max
units in width. Currently, Cloth is set (in
the Simulations Parameters rollout) to 2.54
cm/unit, which equals 1 inch per unit (2.54
cm=1 inch). So at 165 inches wide, the flag
is 13.75 feet wide, which is a big flag. That’s
not unrealistically large, but it is big, which is
something to keep in mind because it affects
the cloth behavior.

3. On the Cloth Object rollout, click Simulate. Let
the simulation calculate for a few frames. After
about 35 frames, press the ESC key to stop the
simulation.

The flag falls to the ground because it is not
attached to the flagpole in any way. To attach
the flag to the flagpole, you will need to access
the Cloth Group sub-object level and create a
group of vertices to attach to the flagpole.

Attach the flag to the pole:

1. Go to the Group sub-object level of the Cloth
modifier.
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The flag vertices become visible.

2. In the Front viewport, select the column of
vertices on the Flag object nearest the flagpole,
as shown below.

Vertex selection for FlagPole binding

3. On the Group rollout click the Make
Group button, and then name the group
FlagPoleSelection. Click OK to close the
dialog.

Now that you’ve made and named a group, you
need to assign it to the flagpole.

4. On the Group rollout click the SimNode button,
and then pick FlagPole by either selecting it in
the viewport or by pressing the H key and using
the Select Objects dialog.

Alternatively you could attach the flag to the
flagpole using the Surface constraint, but that
method locks each vertex to the triangle on the
chosen object whose center is closest to the
vertex. In the case of the flagpole, some of the
vertices would be pulled toward the cylinder
cap triangles to which they are closest, which
might create unexpected results.

5. Exit the Group sub-object level.

Run and refine the simulation:

1. On the Object rollout click Simulate.

The flag drapes down and is held up by the
flagpole, but it doesn’t seem to drape very

naturally. This is due to the size of the cloth.
Remember that you determined that the flag is
almost 14 feet wide, so you now need to edit the
cloth properties for the flag so that it behaves
more realistically.

2. Click the Object Properties button, and then
in the left-hand column of the floating dialog
click Flag.

3. Change the Shear value to 350.0.

4. Change the U Bend value to 50.0.

Altering these two parameters forces the cloth
to be less flexible, cause more realistic folds in
the cloth drapes.

5. Close the Object Properties dialog, and then
click Erase Simulation to remove the existing
simulation data.

6. Click Simulate again to see the flag drape.

Add a wind force:

To make the simulation more realistic, you’ll use
a Wind space warp to make the flag flap in the
breeze.

1. Go to Create panel > Space Warps > Forces
and then add a Wind space warp In the Left
viewport.

2. Rotate the space warp to point in the same
direction as the flag, as shown below.

Wind space warp placement in the scene



Designing a Shirt 771

3. With the Wind space warp selected, go to the
Modify panel and change the Strength value
to 10.0.

Next you’ll tell the Cloth simulation to take the
wind into account by adding it as a force.

4. Select the Flag object and then on the Object
rollout click the Cloth Forces button.

This opens the Forces dialog.

5. In the Forces In Scene column, click Wind01
and then click the right-arrow button in
the center to move it over to the Forces in
Simulation column. Click OK to exit the dialog.

6. Erase the simulation again and then click
Simulate and let the new simulation run to
completion.

Flag blowing after simulation is complete

You can see how easy it is to create a simple
cloth object with Cloth. Now that you’ve had
a taste of how the system works, you’ll use the

major Cloth features to build a realistic shirt
for a character model.

Next

Designing a Shirt (page 2–771)

Designing a Shirt

In this tutorial, you will go through the process of
building a shirt for a character from scratch.

The first lesson will lead you through several key
features of the Garment Maker modifier that let
you design the patterns that will be used to create
the garments.

The concepts covered in this lesson are as follows:

• Drawing splines for the pattern

• Applying Garment Maker to the pattern

• Working with MultiSegment splines

• Positioning the Garment Maker panels over the
character

• Creating seams

Create the shirt pattern:

1. Load tutorial_1.max from your \tutorials\cloth
folder.

This scene contains a character for which you
will make a shirt.

2. Select the character named Jester. In the Front
viewport, rotate it -90 degrees on the X axis.

The Jester character model should now be
facing upward in the Top viewport. Garment
Maker requires that you create patterns in
the Top viewport. Rotating the character will
allow you to use it temporarily for fitting while
creating the pattern. When you’ve finished
creating the patterns, you will rotate it back.
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Next you’ll start to make a pattern for a shirt.
First you’ll create the panels that will make up
the front and back of the shirt.

3. On the Create panel click Shapes > Line,
and create a spline in the Top viewport that
resembles the front of a shirt without sleeves.
This will look something like a vest, as shown
below.

Front of shirt in the Top viewport

Next you’ll make the sleeve for the shirt. The
sleeve is basically one long piece of fabric that
wraps around the arm, with a seam at the
bottom. The end of the sleeve that will attach
to the shirt should be curved to better fit the
shoulder area.

4. In the Top viewport, create a spline sleeve that
fits the arm’s length, and is about three to four
times the arm’s width.

Sleeve in the Top viewport

5. Copy the sleeve and front panel splines of the
shirt so that you have a front and back plus two
sleeves. Also, rotate the sleeve on the left so that
it is properly oriented, as shown below.

Pattern panels copied and arranged

Next you’ll combine all the pieces and set them
up to be sewn together.

6. Use the Attach function to combine all the
editable splines into one object and name it
Pattern.

In order for Garment Maker to work, all of the
panels that are created as part of a single piece
of clothing must be part of the same object.
That’s why you attached all the splines. Next
you’ll break off different segments of the pattern
so that these edges can be sewn together.
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7. At the Vertex sub-object level, select all four
corner vertices of both sleeves and then click
Break.

Vertices selected for breaking

This will give you four separate splines to select
and sew together instead of having only one
spline. When you work with Garment Maker,
you need to make sure that your shape contains
separated splines to use as the seam edges.

8. Select the eight corner vertices on both the
front and back pieces of the shirt, and click
Break again.

Vertices selected for breaking

Now that the pattern is ready, you’ll apply the
Garment Maker modifier to make this 2D
spline pattern into a 3D mesh.

9. With the Pattern spline selected, go to the
Modify panel and apply the Garment Maker
modifier.

When you apply Garment Maker to the
closed splines it fills them in with an irregular

triangular mesh that is designed for cloth
deformation.

Fit the shirt to the character model:

Now that you’re done with the preliminary
creation and sizing for the pattern, you’ll rotate the
Jester back into standing position.

1. In the Front viewport select the Jester object
and rotate it 90 degrees around the X axis.

The next step is to position the panels of the
pattern around the character.

2. Go to the Panels sub-object level of the Garment
Maker modifier and select the panel that makes
up the front of the shirt.

3. Move the panel into place in all four viewports
so it lines up well with the front of the character.
This panel will need to be rotated 90 degrees
around X and moved up and forward a bit to
line up with the character as shown below.

Positioning of the front shirt panel

4. Still at the Panels sub-object level, select the
panel that makes up the back of the shirt. Move
and rotate this panel into place. This panel will
need to be rotated 90 degrees around X as well
as 180 degrees around the Z axis so the mesh
is facing outward.

5. Move the sleeve panels into place above the
arms.
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Positioning of the back and arm shirt panels

You’ll adjust a few parameters of the panels
before adding the seams to the shirt’s panels.

6. At the Panels sub-object level select one of
the sleeve panels. In the Panels rollout’s
Deformation group choose the Curved radio
button option. Set the Curvature value to -3.0
and choose the Y-axis option.

This causes the sleeve panel to bend around the
arm.

7. Using the Move and Rotate tools, reposition the
panel to fit more closely around the arm.

If the sleeves are not wide enough to curve
around the arm, go back to the Editable Spline
level on the stack to make them a bit wider. To
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get Garment Maker to recognize this change,
tweak the Density spinner up and down in the
Garment Maker > Object rollout after editing
the splines.

8. Repeat these steps to curve the other sleeve
and position it to resemble the following
illustration.

Sleeve panels with curvature

Make the shirt seams:

All the panels are in place, so next you’ll make
some seams for sewing them together. You
can make seams at both the Curves and Seams
sub-object levels. The Curves level is a good place
to make seams quickly if you know exactly how
they need to connect. However, this method can
be a bit confusing at first. Therefore, you’ll use the
Seams level because it gives more visual feedback.

1. Go to the Seams sub-object level of the Garment
Maker modifier. Select the edge on the front
panel of the shirt above the left shoulder. It
turns red to indicate it is selected.

2. Press and hold the CTRL key, and then select
the corresponding edge on the back panel of the
shirt. On the Seams rollout click Create Seam.

If a dialog box comes up that reads, “Seamed
segments not within tolerance,” increase the
value for the Seam tolerance on the Seams
rollout. You might also get a twisted seam. If
this happens, click Reverse Seam on the Seams
rollout.

Left: Twisted seam

Right: Correctly aligned seam

Most of the seams for clothing can be made as
easily as this: Select two edges and then click
Make Seam.

The exception to this is creating the seam
between the sleeves and the arm holes. There
are three seams involved here instead of two:
the front half of the arm hole, the back half of
the arm hole, and the sleeve edge itself. You
must first make the arm holes on the front and
the back of the shirt into one segment. You will
do this by making a "MultiSegment" seam.

3. Select both segments for the arm hole on the
front and the back of the shirt. It is important
that you select the segments on the same side of
the body on which you just made a shoulder
seam. When both edges are selected, click
Make MultiSegment on the Seams rollout.
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Segments selected for making MultiSegment

Now, if you deselect and select either the
back or front segment, both will be selected
or deselected because Garment Maker now
considers them to be one segment.

4. Select the MultiSegment you just made, and
then select the sleeve edge. Click Create Seam
to attach the sleeve.

Seam attaching sleeve to body

5. Create the seams for the rest of the segments on
that side of the body. Don’t forget the underside
of the sleeve.

Seams for left side of body

6. Use the same method to create the seams for
the other side of the body.

Remember to create the shoulder seam first and
then make the MultiSegment seam. When dealing
with MultiSegment seams, the order of creation is
important. If you attempt to create seams in the
wrong order, you might get a “Seamline topology
is wrong” error, and the seams will not be created.
When dealing with MultiSegment seams, create
the minimum number of seams necessary to make
the MultiSegment seam match the topology of the
other piece to that you are going to connect. In
this case, you have an arm seam that is open at
the bottom, and a MultiSegment that is open at
both the top and the bottom. By closing the top
of this MultiSegment with a seam at the shoulder,
you’ve created proper topology to make the
MultiSegment seam.

To recap this first lesson, you created a pattern for
a shirt from standard splines, applied Garment
Maker, positioned them over the character and
then created the seams that will be used to sew the
panels together. In the next tutorial, you will see
how to make the flat panels look more like a shirt.
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Next

Designing a Shirt, Part 2 (page 2–777)

Designing a Shirt, Part 2

In this next tutorial, you’ll take the patterns you
built in the first tutorial, and you’ll apply Cloth to
begin the process of turning the panels into a shirt.

This lesson covers the following concepts:

• Assigning cloth and collision objects

• Bringing the seams together

• Assigning clothing properties

• Running the local simulation to fit a garment

1. Open tutorial_2.max from your \tutorials\cloth
folder.

This scene contains the Jester character and
the shirt pattern with seams in place from the
previous lesson. Now that all the seams are in
place on the pattern, you will add the Cloth
modifier to form the pieces into the shirt. The
first task is to decide on the scale of the scene.

If you use the Measure utility, you can see
that the Jester character is about 77 3ds Max
units tall. If we set one unit to one inch, what
would make him 77 inches (6 feet, 5 inches)
tall, including the hat, which seems reasonable.
Since we want to use 1 3ds Max unit=1 inch,
that means 1 unit=2.54cm, so the cm/unit
setting in Cloth will be set to 2.54; this is the
default.

2. Select the Shirt object, go to the Modify panel,
and apply the Cloth modifier to it.

Since we want cm/unit=2.54, there is no need to
change this value, but please keep in mind that
it is very important to set this value correctly
before attempting a simulation.

The Object Properties button on the Object
rollout opens the Object Properties dialog,

where you add objects to the simulation and
assign them different properties.

3. Click the Object Properties button. In the left
column of the Object Properties dialog, click
the Shirt entry and then choose the Cloth radio
button on the right.

This sets the shirt to be a cloth object in the
simulation.

Take note of all the Cloth Properties parameters
that can be adjusted when an object is set to be
cloth. You can use these parameters to get the
fabric type you want, or you can use a preset.

4. With the Shirt still highlighted in the left
column, choose Cotton from the Presets
drop-down list.

This sets all of Cloth Properties to simulate
cotton.

If you were to simulate now, the shirt would
simply fall to the floor because it’s the only
object in the simulation currently. You’ll add an
object for the cloth to collide and interact with.

5. On the Object Properties dialog, click the Add
Objects button.

This opens a list of objects in the scene.

6. Click the Jester and then click OK.
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When you add objects to the simulation, it is
the same thing as instancing the Cloth modifier
to those objects. Each object that is part of the
Cloth simulation will have a Cloth modifier
assigned to it. Be aware of this as you set up
your own simulations.

7. With Jester still highlighted in the left column,
click the Collision Object radio button on the
right near the bottom.

8. Set the Offset parameter to 0.25, which will
keep the cloth a quarter of a 3ds Max unit away
from the body (the default of 1.0 is a little large
for this scene).

9. Click OK to close the Object Properties dialog
and set the parameters.

At this point, you have set the shirt to react like
cloth, and the Jester’s body to collide with it.
You are now ready to convert the panels into a
shirt. You do this with a local simulation.

Before you simulate sewing the garment
together, you’ll turn gravity off.

10.Scroll down to the Simulation Parameters
rollout, and click the Gravity button so it is no
longer highlighted and active.

11.In the Perspective viewport, zoom in a bit to
get a closer look at the shirt, then still within
the Cloth modifier, go to the Object rollout,
and click then Simulate Local. When the seams
have pulled the shirt mostly together, press the
ESC key to stop the simulation.

As you can see in the image above, the panels
have pulled together and are draped over the
Jester character. However, the seams have not
come together to form a single garment and the
green sewing springs are still visible. In order
to get the seams to snap together completely,
you will need to perform one more operation.

12.On the Simulation Parameters rollout, turn off
Use Sewing Springs.

The green lines disappear.

13.Turn Gravity back on, and then back on the
Object rollout, click Simulate Local again.

14.Let the simulation run until you are satisfied
with the fit, and then press the ESC key to stop
it.
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Now the shirt is complete. Next, you can
animate the character and simulate the cloth
over the animation. But before you animate
your character, you’re going to give the shirt a
pocket to add some detail to it.

Add a pocket:

Now that the shirt is coming together, you’ll add a
pocket to it in order to give it some more detail.
This tutorial will introduce you to the idea of
attaching one cloth object to another as well.

The following concepts are covered in this lesson:

• Garment Maker creation

• Creating and using groups

• Assigning separate cloth properties

1. Load tutorial_3.max from your \tutorials\cloth
folder.

This scene contains the Jester character and
the shirt simulated from the previous lesson.
If the scene opens with the panels apart and
the garment looking stretched out, there’s an
easy fix. Occasionally you will see a scene file
with the panels not together and the triangles
distorted. To fix this, just turn on Use Sewing
Springs, click Reset State, and then use Simulate
Local to rebuild the shirt as it was at the end of
the previous tutorial.

Now that the shirt is in place, you will add a
pocket to it to make it look like a fancy T-shirt.

You’ll start by creating a pocket to add in the
same way you made the shirt pattern.

2. In the Top viewport, zoom into the front of the
Jester’s body, then draw out a pocket shape
with the line tool using Create panel > Shapes >
Line. Make the pocket an appropriate size for
the shirt and name the object Pocket. Be sure
to go to the Vertex sub-object level and break
all the vertices.

Spline pocket in the Top viewport

3. With the Pocket object selected, apply the
Garment Maker modifier to it.

4. Go to Panels sub-object level of the Garment
Maker modifier, and then move the pocket into
place just in front of the shirt. You might want
to rotate the pocket a bit to more closely align it
with the chest portion of the shirt. When you’re
done, exit the sub-object level.

Pocket positioned at the Panels sub-object level

Now that the pocket is in place, you will need to
add it to the simulation.

5. Select the shirt, and then click Object
Properties. On the Object Properties dialog,
click Add Objects to open a list of objects in the
scene. Click Pocket and then click OK. With
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Pocket still selected in the left column, click the
Cloth radio button on the right. Click OK to
close the Object Properties dialog.

Before attaching the pocket to the shirt, it’s
advisable to make the mesh densities of the two
objects similar. Right now, the mesh density of
the pocket is higher than the shirt, which can
cause crumpling at simulation time.

6. Select the Pocket object, and then access the
Garment Maker modifier in the stack. On the
Object rollout, change the Density value so
the mesh density of the pocket more closely
matches that of the shirt. A value of 3.0 should
work.

Next you’ll attach the pocket to the shirt. You
can do this at the Group sub-object level of the
Cloth modifier.

7. Select the Pocket object, and then go to the
Group sub-object level of its Cloth modifier.
This level lets you select vertices. Select the
vertices at all edges of the pocket except the top
edge, as shown below.

Pocket vertex selection

8. Click the Make Group button and name the
group PocketEdge.

You’ll see a new group in the Group rollout list
named “PocketEdge (unassigned).”

9. With this group still selected, click the Cloth
button and pick the shirt by selecting it in the
viewport or by pressing the H key and selecting
it by name.

Now the Group should be named “PocketEdge
(cloth to Shirt).” This lets you know that you
have attached the group of vertices to the shirt
object as a piece of cloth.

10.Return to the base level of the Cloth modifier,
so you are no longer in Group sub-object
mode. Make sure Gravity is not active on the
Simulation Parameters rollout.

11.Click Simulate Local to conform the pocket to
the shirt.

12.This should take only a few frames, and you
should also realize that this process will also
further refine the shirt’s fit itself, so don’t let the
simulation run too long.

Pocket conformed to the shirt

As you have seen, adding extra detail to a piece of
clothing is not a very difficult process. Attaching
one cloth object to another is simply a matter of
creating a group of vertices and choosing the other
cloth object to attach it to. In the next lesson you
will expand on this knowledge to create a collar
and cuffs for the shirt, as well as assign different
material properties to them.
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Next

Designing a Shirt, Part 3 (page 2–781)

Designing a Shirt, Part 3
Add a collar:

Now that you’ve had a taste of adding detail to
a garment, it’s time to look at some of the more
advanced attributes within Cloth. In this tutorial,
you’ll add a collar and cuffs to a simple shirt
design, and change their seams to create creases
within the garment.

The concepts that will be covered in this lesson are
as follows:

• Creating seams and positioning Garment
Maker panels

• Using the Seam Strength and Seam Angle
controls

• Simulating multiple times to get a garment into
position

1. Load tutorial_4.max from your \tutorials\cloth
folder.

This scene contains a character and the shirt
from the previous lesson. This shirt has some
additions to it as shown in the following
illustration. Two extra pieces have been added
for the collar, and one extra piece per arm for a
cuff. The cuff is a bit narrower than the sleeve.

Shirt layout with collar and cuffs added to the basic
pattern

2. Select the shirt, and on the Modify panel, turn
on the Garment Maker modifier so the panels
move into place.

The shirt is set up as in the previous lesson with
most of the seams created for the arms, back
and front of the shirt. You’ll adjust the curve of
the cuffs and collar and apply seams to them.

3. Go to Panels sub-object level of Garment
Maker, and select one of the cuffs. In the
Deformation group on the Panels rollout,
choose Curved, and set the curve to -5.0
around the Y-axis.

Now that the cuff is curved around the arm,
you can add its seams.

4. Go to the Seams sub-object level of Garment
Maker and create a seam between the sleeve
and the cuff. Then create the seams for under
the sleeve and under the cuff. Create your
seams in this order or you might get topology
dependency errors.

Seams for the underarm and cuff

Now that you have made the seams for the cuff,
you will edit the seam attaching it to the sleeve
to get a cuff-like result. Where the cuff meets
the sleeve, there should be a clear crease and a
bunching of the sleeve.

5. At the Seams sub-object level, select the seam
(the green sewing springs) that joins the cuff
and the sleeve. On the Seams rollout, set Crease
Angle to 90.0 and Crease Strength to 100.0.

This will make the seam try to maintain an
angle of 90 degrees.

6. Complete steps 3-5 for the other side of the
body.
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Now you’ll take a look at the collar. It would
probably be best to make the seams for
the collar first, and then change the curve
afterward.

7. At the Seams sub-object level, create a seam
between the back of the shirt and the bottom of
the closest collar piece.

Seam from the back of the shirt to the bottom of the
collar

8. Next, create a seam between the tops of the two
collar pieces. If necessary, click the Reverse
Seam button to straighten out the seam.

Next you’ll bend the collar panels and move
them into place.

9. At the Panels sub-object level select the base of
the collar and apply a curvature of -3.0 around
the X-axis. Select the other piece of the collar
and apply a curvature of -2.0 around the X-axis.

10.Select each of the collar places and move them
into place around the neck and above the
shoulders, as shown below.

Collar bent and positioned

Next you’ll edit the seam of the collar as you did
the cuffs. This will let the folded part of the
collar stand out a bit.

11.Select the seam between the top of the two collar
pieces in Seams sub-object mode. Set Crease
Angle to -75.0 and Crease Strength to 25.0.

Now you are ready to add the Cloth modifier
and simulate.

12.Apply the Cloth modifier to the shirt.

13.On the Object Properties dialog, set the shirt to
be cloth, and choose the Cotton preset from
the drop-down list.

14.Add the Jester to the simulation, and make
the Jester a collision object. Close the Object
Properties dialog by clicking OK.

15.Turn off Gravity, and then Simulate Local with
Use Sewing Springs on to bring the panels
together.

16.Stop the simulation and then, on the Simulation
Parameters rollout, turn off Use Sewing
Springs.

Turning off Use Sewing Springs tells Cloth to
compute the seam angles and strength for the
cuffs and collar.
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17.Turn Gravity back on, and then Simulate Local
again with Use Sewing Springs off to further
refine the garment’s position and fit.

If you don’t get the right result the first time,
you might want to turn Use Sewing Springs
back on and Reset State. This will allow you to
perform the local simulation again.

Simulated shirt with collar and cuffs

This lesson has provided you with additional
ways to control how your fabric behaves and is
joined together. In the next lesson you’ll look
at how you can further refine the look and
behavior of your clothing by assigning different
cloth properties to the panels of garments.

Apply various cloth settings to different parts of the
shirt:

In the last lesson you looked at different controls
that help define how your fabric behaves. In
this lesson you’ll apply different cloth settings
to various parts of the shirt to create a more
convincing look.

The concepts that will be covered in this tutorial
are as follows:

• Assigning separate Cloth properties for panels

• Assigning different materials for panels

• Assigning separate Cloth properties with a
material

1. Load tutorial_5.max from your \tutorials\cloth
folder.

This scene contains a character and the
shirt from the previous lesson. You’ll add
some different properties to the cloth panels
themselves.

2. Select the shirt and then, on the Cloth modifier
Object rollout, click Object Properties to open
the Object Properties dialog. Highlight the
Shirt entry in the left column and then turn
on Use Panel Properties. Click OK to exit the
dialog.

This will let you set the cloth properties for the
entire shirt on a panel-by-panel basis.

3. Go to the Panel sub-object level of Cloth and
select one of the cuffs. It will turn red it indicate
that it’s selected.

You can change all of the parameters for how
the fabric reacts here on the Panel rollout.

4. From the Presets drop-down list, choose
Generic Heavy.

This sets the cuff to deform like a heavy or stiff
piece of fabric.

5. Select the different panels of the collar and the
other cuff and set them to the Generic Heavy
preset. Be sure to choose the preset even if it is
already displayed in the list.

6. Select each of the other shirt panels, and set the
preset to Cotton.

This will make most of the shirt behave like
cotton except for the collar and cuffs, which
will be heavier and less flexible, as if they were
starched.

Now it’s time to rerun the simulation.

7. Exit the Panel sub-object level and go to the
Object rollout of the Cloth modifier. Be sure
Use Sewing Springs is on in the Simulation
Parameters rollout, and then click Reset State
from the Selected Object Manip group of the
Object rollout.
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This resets the state of the shirt so you can run
the local simulation again.

8. Run the local simulation again, first with Use
Sewing Springs on for a bit, and then run
the local simulation with Use Sewing Springs
turned off. You might also use Simulate Local
(damped), which adds a heavy damping to the
fabric as it simulates.

9. If you are not satisfied with the results, click
Erase Simulation and then rerun the simulation
until you like the positioning and drape of the
shirt.

Now that you have different fabric properties
for the cuffs and the collar, you’ll set up some
different materials and densities. If you take a
look at the end of the cuff, you will see it seems
a bit low-poly and chunky.

Slightly chunky-looking cuff

10.If necessary, select the shirt, and then go down
the modifier stack to the Garment Maker
modifier.

You’re going to change the density of different
parts of the shirt next. In order to do this so
you don’t have to re-simulate the garment
afterwards, you’ll first check to make sure that
you preserve the shirt’s position.

11.In the Garment Maker modifier, make sure the
Preserved Surface radio button is chosen.

12.Go to the Panels sub-object level and select
one of the cuffs. On the Panels rollout, change
Density to 3.0 and set the Mat ID to 2. Do this
for the other cuff as well.

This will let you apply a different material to
the cuffs only.

13.Select each panel of the collar and change its
Density to 2.0 and its Mat ID to 2.

14.Use the Material Editor to create a
Multi/Sub-Object material with two
sub-material slots. Change the two
sub-materials to any colors you like, apply the
material to the shirt, and then render.

Smooth cuffs with separate materials applied

You changed the cloth properties via the Panel
sub-object level; you’ll now learn about an
alternative method that can add some flexibility
to assigning cloth properties. You’ll use a
grayscale map to determine which parts of the
shirt are made of which types of fabric.

15.Go back up the stack to the Cloth modifier, and
open the Object Properties dialog by clicking
Object Properties on the Object rollout.

16.Highlight the Shirt entry on the left, and then
turn off Use Panel Properties.
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17.Choose the Cotton preset.

Now the entire shirt is set back to cotton.

18.In the upper-right corner of the Object
Properties dialog, click the Property 2 radio
button. Choose the Cotton Generic Heavy
preset.

19.Click OK to exit the dialog.

Now you have two different sets of cloth
properties you can modify and assign to the
shirt.

20.Open the Cloth modifier’s Material Params
rollout.

Note: This rollout is available only when a single
object is selected.

The Interpolate option is currently active. This
option lets you move the slider to interpolate
between the two properties you just set for the
cloth, and even animate between them if you
wish. But for now you’ll use the other option:
Texture Map. This lets you to use a grayscale
texture map to assign fabric properties. White
pixels will assign Property 1, black pixels will
assign Property 2, and values in between will
blend between the two sets of properties.

21.Open the Material Editor and create a new
material. As the Diffuse map type choose
Bitmap and choose the shirtprop.bmp from
your \maps folder.

22.Apply this material to the shirt.

23.Reset the initial state, making sure Use Sewing
Springs is on. Go to the Object rollout of the
Garment Maker modifier and choose the Flat
Panels option.

This lays out the panels in a manner that is
appropriate for UVW mapping.

24.Above the Garment Maker modifier apply a
UVW Map modifier. Keep the Planar default
mapping type and adjust the size to fit properly.
Make sure Show End Result toggle is off below

the modifier stack display so you can see the
panels.

UVW modifier in the Top viewport
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Modify panel with UVW Mapping modifier

25.Go back up to the Cloth modifier in the stack.

26.On the Material Params rollout, choose the
Texture Map option and then click the None
button to get the texture. On the Material Map
Browser dialog choose Browse From > Mtl
Editor, and then choose the Diffuse map you
just added to your shirt.

You’re now ready to simulate again.

27.Use Simulate Local as before to conform the
shirt to the character with the new settings.

Now the fabric parameters are defined by the
black-and-white map to make the cuffs and
collar a bit stiffer than the rest of the shirt. You
can now apply any material you want to the
shirt.

Simulation with cuffs and collar properties set by
material

As you can see, giving a single piece of clothing
multiple cloth properties is not difficult, and
can generate results that would be impossible
otherwise. Now that you can construct
garments and give them properties to make
them behave as you would like, you’ll start
looking into how you can refine the design of
the clothes you build so they fit the characters
better.

Next

Tailoring and Fine-Tuning (page 2–786)

Tailoring and Fine-Tuning

As you begin to create more complex clothing,
you’re most likely going to want to create the
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garments for your characters, then be able to go
back and refine them to make them fit better. In
essence, you’ll be acting like a virtual tailor. This
tutorial introduces you to the traditional sewing
concept of darts, and how they can help you build
better clothing.

The concepts that will be covered in this tutorial
are as follows:

• Using darts with Garment Maker

• Creating seams for darts

• Modifying darts after simulation to get a better
fit

Fit a dress with darts:

1. Load tutorial_6.max from \tutorials\cloth
folder.

This scene contains a character model and a
pattern for a sun dress. This sun dress has darts
in it to help it fit the character’s body closely
while still being a very simple pattern.

2. Select the SunDress object.

The darts in the pattern appear as thin
diamonds.

3. Go to the Modify panel and turn on the
Garment Maker modifier.

Most of the seams for the dress are already
made. The ones you’ll focus on are the darts.

Darts marked in red

4. Go to the Seams sub-object level of Garment
Maker. Select the two seams of one of the darts
and then click Create Seam.

Seam made for one dart (far right) and selected edges to
create a seam for the next dart

5. Proceed around the dress making seams for
each dart.

6. Apply the Cloth modifier to the dress.
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7. On the Object rollout click Object Properties.
Highlight the SunDress entry in the list on the
left, click the Cloth radio button, and then
choose the Cotton preset from the drop-down
list.

8. Click the Add Object button and then add the
Girl to the simulation. With the Girl entry
highlighted click the Collision Object option.
Click OK to exit the dialog.

9. On the Object rollout choose Simulate Local
(damped). Once your dress is partially formed
to the figure, stop the simulation, turn off Use
Sewing Springs in the Simulation rollout, and
then simulate locally again for a bit.

The shoulder straps are floating too high above
the shoulders, so you’ll decrease the offset a bit.

10.Open the Object Properties dialog again and
choose the Girl entry in the list at the left. In the
Collision Properties group reduce the Offset
value to 0.6. Click OK to close the dialog.

11.Click Simulate Local (damped) to tighten up
the dress.

The resulting dress has some bunching on
both sides under the chest. This bunching is
what the darts are designed to minimize or
eliminate. You should be able to get a better fit
by repositioning the darts and making them
a little larger.

Bunching on both sides of the dress

12.Go to the spline level at the bottom of the
modifier stack and then access the Vertex
sub-object level. In the Top viewport,
reposition the outside darts to be larger, and
position them more toward the top of the dress
as shown below.

Darts moved up and widened

13.Garment Maker doesn’t register changes in the
spline shape until the mesh is regenerated, so
now you need to click the Mesh It And Preserve
button, which lets you keep the dress in place
as it adjusts to the new dart positioning. If you
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clicked the Mesh It! button instead, the dress
would revert to the pre-sewn configuration.

14.Go up to the Cloth modifier, turn on Simulation
Rollout > Use Sewing Springs, and then click
Reset State.

15.Run the simulation locally again until you’re
satisfied.

You should get a much better fitting dress.

Results after manipulating the darts

Next

Using Cloth with Bipeds (page 2–789)

Using Cloth with Bipeds

Cloth is a complex system, so it makes sense to
learn how it functions in concert with another
character animation tool, namely the Biped
functionality in 3ds max.

The following concepts are covered in this tutorial:

• How to slow down the character’s initial pose
so the initial Cloth simulation can occur. The
idea here is that motion-capture data imported

into both products will position a character at
frame 0, which can cause problems for Cloth
because it wants to simulate over at least 30 to
90 frames before motion begins, generally in a
neutral pose.

• Truncating a simulation

• Capturing an initial state

Clothe an animated biped:

1. Load tutorial_7.max from your \tutorials\cloth
folder.

This scene has a biped standing in the “Da
Vinci” pose.

Biped in Da Vinci pose

2. Select all the biped parts and then go to the
Motion panel.

3. On the Copy/Paste rollout, click Copy Posture.

Now this posture is saved for you to get later.

4. On the Motion Capture rollout, click Load
Motion Capture File, and then load the file
backkick.bip from your \tutorials\cloth folder.
Click OK through the dialogs that follow,
accepting the default settings.

5. Open the Dope Sheet for Track View, and select
all of the Biped keys. Move the keys 30 frames
to the right.
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This will give you 30 frames to transition
between the copied pose and the first
motion-capture frame.

6. At frame 0, on the Motion Panel > Copy/Paste
rollout, click Paste Posture.

7. On the Key Info rollout click Set Key.

Now when you scrub the time slider your
animation should transition smoothly between
the Da Vinci pose and the first frame of the
motion capture.

8. Unhide the Shirt object.

9. Select the Shirt object and then go to the
Modify panel and click Cloth modifier > Object
rollout > Simulation group > Simulate to get
the shirt to deform. At frame 30, press ESC to
halt the simulation.

10.At frame 30, click Cloth modifier > Object
rollout > Selected Object Manip group > Set
Initial State.

This sets the initial state of the shirt to be in
sync with the first frame of the motion capture.
Because Cloth requires some pre-roll for the
simulation, it provides you with the tools
needed to copy the cloth at any stage back to
frame 0.

11.Next, go to frame 0 and click Truncate
Simulation.

This removes the simulation after frame 0.

12.Choose File > New, and on the New Scene
options dialog, choose Keep Objects And
Hierarchy.

This removes all animation from the scene.

13.Import the motion capture file again. The cloth
will be in sync with it at frame 0, and you can
simulate the rest of the animation at that point.

This tutorial gave you a method for "staging"
your Cloth simulation.

Next

Creating Pleats (page 2–790)

Creating Pleats

In this final tutorial, you will learn more about
creating specific pleats within a garment to make it
look as if it’s just been ironed and pressed.

The concepts that will be covered in this tutorial
are as follows:

• Using a pattern with pleats in Garment Maker

• Creating seams for pleats

Sew the skirt sections together:

1. Load tutorial_8.max from your \tutorials\cloth
folder.

This scene contains a mannequin figure and a
pattern for a pleated skirt. This skirt has been
broken into several sections for a pleated look
when it gets sewn together.

2. Select the Skirt object.

Skirt pattern

This pattern object contains five sections that
will have pleats between them. You’ll connect
the five sections to the five segments on the
bottom of the waistband portion of the dress.

3. Apply the Garment Maker modifier to the Skirt
object.
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Garment Maker applied to the skirt panels

Next you’ll position and rotate the pattern into
place at the Panels sub-object level of Garment
Maker.

4. Go to Panels sub-object level and then position
and rotate the waistband portion of the pattern
near the character’s waist.

5. In the Panels rollout > Deformation group
choose Curved. Enter a Curvature value of -1.7
around the X-axis.

This bends the waistband portion of the skirt
around the character’s waist.

6. Move and rotate the skirt panels so they encircle
the character, as shown below. Take your time
and rotate the view around the character to get
a better sense of where the panels are in relation
to one another.

Panels rotated and placed around the character

Once the panels are in place you can make
seams to attach each panel to the waistband.

7. At the Seams sub-object level of Garment
Maker, select a segment on the bottom edge on
the waistband and the corresponding edge on
the top of a skirt panel.

Edges selected to make a seam

8. On the Seams rollout click Create Seam.

9. Attach the remaining panels to the waistband
with additional seams.
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Seams created attaching the waist band to the panels

10.Create a seam for the back of the waistband to
close it off.

Each adjacent pair of skirt panels need a seam
between them to keep them together and define
a pleat.

11.Select the edges of the two back panels to create
a seam between them and then click Create
Seam.

Seam created between back panels of the skirt

12.With this seam still selected, go to the Seams
rollout and change Crease Angle to 90.0 and
Crease Strength to 25.0.

Setting Crease Angle to 90 makes the seam try
to achieve a 90–degree angle during simulation.
The Crease Strength setting defines how hard
the seam will try to reach the set crease angle.
All of this happens during simulation when Use
Sewing Springs is off.

13.Repeat steps 11 and 12 with each pair of
adjacent panels in the skirt.

14.Exit the sub-object level and apply the Cloth
modifier to the Skirt object.

15.On the Object rollout click Object Properties.

16.On the Object Properties dialog, highlight the
Skirt entry in the Objects In Simulation list and
choose the Cloth option to designate the skirt
as a cloth object.

17.From the Presets drop-down list choose Cotton.

18.Click the Add Objects button and add Manny
to the simulation. Choose the Collision Object
radio button to designate the mannequin as a
collision object. Click OK to exit the dialog.

Now it’s time to simulate and see how the dress
looks.

19.On the Simulation parameters Rollout turn
Gravity off and make sure Use Sewing Springs
is on. Click Simulate Local (damped) and let
the sewing springs pull the skirt together for
a few seconds. Press the ESC key to stop the
simulation.

20.Turn off Use Sewing Springs and turn on
Gravity.

21.Run the local simulation again to snap the
seams together and to define the pleats. After
a couple of frames, press the ESC key to halt
the simulation.
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Skirt after simulation is complete

Next

Creating an Umbrella (page 2–793)

Creating an Umbrella

In this tutorial you’ll use the Garment Maker and
Cloth modifiers to simulate the motion of umbrella
fabric as an umbrella closes and opens. These
modifiers allow you to create a realistic animation
faster than would be possible with simple vertex
animation.

Features covered in this tutorial

• After completing this tutorial you will be able
to:

• Use the Array tool to pattern the geometry.

• Apply the Garment Maker modifier.

• Define Seams between panels of a garment.

• Use Merge to bring in another 3ds Max file.

• Attach the cloth to an animated object.

• Perform a cloth simulation.

Tutorial Files

• All the necessary files for this tutorial can
be found on the Tutorial Files CD in the
\tutorials\cloth directory. Before starting the
tutorials, copy the \tutorials folder to your local
\3dsmax8 installation.

Array a 2D Shape:

You will start this exercise by arraying a simple
shape that represents a single umbrella panel.

1. Start or Reset 3ds Max. From the File
menu, choose open and open the file
Umbrella-start.max. It is a scene with a simple
triangle-shaped spline, representing one panel
of the umbrella.

2. Select the shape.

3. In the name and color rollout, rename it to
Umbrella Fabric.

4. Verify the shape is still selected.

5. Click and then right-click the move tool.

6. Enter -3 in the Y field in the Offset:World group.
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7. On the main toolbar, set the Coordinate System
to World.

8. Set the Coordinate center to Transform.

9. From the Tools menu select Array.

10.Enter 60 in the Rotation Incremental Z field.

11.Enter 6 in the 1D count field.

12.Select the Copy option.

13.Click Preview to verify settings are correct.

14.Click OK to apply the settings.

Combine into a single shape:

When the array was performed, six individual
shapes were created. The Garment Maker modifier

requires just one. In the following steps you’ll
combine all six shapes into one.

1. Press H to open the Select By Name Dialog.

2. Highlight Umbrella Fabric, and then click
Select.

3. Open the Modify Panel.

4. In the Geometry rollout, click Attach Mult.

5. Click All to select all the objects in the list.

6. Click Attach.

Adding the garment maker modifier:

Here you will apply the Garment Maker modifier
to the shapes. This modifier creates a mesh
defining the fabric and will let you define the
seams in the garment.

1. Select the UmbrellaFabric.
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2. From the Modify Panel, apply the Garment
Maker modifier.

Define the Seams:

The Garment Maker modifier supports multiple
panels of a garment. In this sequence you will
define the seams between the panels.

1. Press F4 to enable Edged Faces mode on. This
will make sub-object selection easier.

2. Expand the Garment Maker modifier, and then
select the Seams sub-object mode.

3. Select a pair of adjacent edges.

4. Click Create Seam.

5. Repeat these steps to define the other 5 seams.

6. When the seams are defined, exit the Seams
sub-object level.

Transform the Panels into Alignment:

In this section you’ll rotate the panels closer to
their assembled position. A point helper will be
used as a reference coordinate system.

1. From the Create Panel>Helpers category,
choose Point.

2. Click near the origin to create the Point Helper.

3. With the Point Helper selected, click and then
right click the Move tool.

4. Set the coordinates to X=0, Y=0, Z=0.
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5. In the Modify panel, enable the Box option on
the parameters of the point object.

6. Adjust the Perspective viewport so that the
positive X and Y axes are directed as shown.

7. Select the UmbrellaFabric, and then activate the
Panels sub-object level.

8. Select Panel 1.

9. Select the Rotate tool.

10.Set the World Coordinate System and
Transform Coordinate Center.

11.Right-click the rotate tool and enter 24 degrees
in the X field.

12.Select Panel 4.

13.Right-click the rotate tool and enter -24 degrees
in the X field.

14.Exit Panels sub-object mode. To rotate the
remaining panels you’ll need to use the point
helper you created.

15.Select the Point Helper.

16.Rotate the point helper by entering 30 degrees
in the Z field.
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17.The Point helper can now be used as the
reference coordinate system to rotate panels 3
and 6.

18.Select UmbrellaFabric, and then go to Panels
sub-object mode.

19.Select Panel 6.

20.From the coordinate system list choose Pick.

21.Press H to open the Select by Name dialog, and
then highlight Point01 in the list.

22.Click Select to close the dialog.

23.From the Coordinate System list, choose
Point01.

24.Set the Coordinate center to Transform.

25.Right-click the rotate tool and enter -24 degrees
in the Y field.

26.Select Panel 3.

27.Right-click the Rotate tool and enter 24 degrees
in the Y field.

28.Now the Point helper will have to be adjusted
for rotating the last two panels.

29.Exit Panels sub-object mode and select the
Point helper.
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30.Rotate the point helper by entering -30 in the
Z field.

31.Select UmbrellaFabric, and then go to Panels
sub-object mode.

32.Select Panel 2.

33.Right-click the Rotate tool and enter 24 degrees
in the Y field.

34.Select Panel 5.

35.Right-click the Rotate tool and enter -24 in the
Y field.

36.Exit the Panels sub-object level.

Add cloth modifier:

Here you will apply a Cloth modifier to the panels
defined by Garment Maker.

1. Select UmbrellaFabric.

2. Open the Modify Panel.

3. From the modifier list, select the Cloth
modifier.

Defining cloth properties:

The Cloth modifier supports many properties that
define and control the behavior of cloth. In this
sequence you will assign a preset group of cloth
properties and perform a local simulation to close
up the seams.

1. Select UmbrellaFabric.

2. From the Object rollout of the Modify panel,
select Object Properties.

3. Highlight UmbrellaFabric in the objects list,
and then set the Cloth option.

4. Open the Cloth Property Presets list and select
Cotton.
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5. Set the U Stretch parameter to 25. Note that
the U and V stretch parameters are locked by
default, so changing one changes the other.

6. Click Ok to close the Object Properties dialog.

7. In the Simulation Parameters rollout, turn off
gravity.

8. From the Object rollout, click Simulate Local
(damped). Click the button again to stop the
local simulation as soon as the seam gaps close
up.

Merge Umbrella frame:

In this section you will merge in another 3ds max
file that contains an umbrella frame. The frame
has already been animated.

1. From the File menu select Merge.

2. Select Umbrella.max.

3. Click All in the object list and then click OK to
close the dialog.

4. Select UmbrellaFabric.

5. Click and then right-click the Move tool.
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Add umbrella components as collision objects:

In this section you will add several of the umbrella
components to the cloth modifier as collision
objects. This will prevent the cloth from moving
through them when the simulation is performed.

1. Select UmbrellaFabric.

2. Click Object Properties from within the Object
rollout.

3. Click Add Objects.

4. Select Arm1 through Arm6, Strut1 through
Strut6, and the CenterPole.

5. Define the added geometry as Collision
Objects.

6. Press OK to exit the dialog.

Define Seam Groups:

In this section you’ll attach the cloth to each of the
arms of the umbrella frame. This will be done by
grouping the vertices along a seam and applying a
surface constraint to the appropriate arm.

1. On the keyboard, Press T to set the top
viewport.

2. Zoom in on the right half of the umbrella.
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3. Select the UmbrellaFabric.

4. Activate the Group sub-object level.

5. Press the Selection Tool.

6. Set the Fence Selection Region option.

7. Set the Window selection option.

8. Select the vertices directly over top of Arm1.

9. In the Modify Panel>Object
rollout, select Make Group.

10.Name the Group Seam1.

11.Note that Seam1 appears in the group window
and is currently unassigned.
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12. Press Surface.

13.Press “H” to open the Pick Object dialog.

14.Select Arm1 from the list and press Pick.

15.Note that Arm1 is now associated with Seam1.
As the arm moves the seam vertices will follow.

16.Repeat these steps to create seam groups for
each arm of the umbrella frame. The arms are
numbered sequentially in a counter clockwise
direction.

Note: When you are done, there will be six
groups defined and they will be associated with
the six arms.

17.Exit the Group sub-object level.

Performing the simulation:

Now you’re ready to simulate the umbrella fabric
closing and opening with the umbrella arms.

1. Press P to go back to a perspective view.

2. In the Simulation Parameters rollout,
turn on the Gravity option.

3. Still under Simulation Parameters, turn Self
collision on. Use a value of 1 for the iterations
parameter.
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4. Click Time Configuration.

5. Set the Length to 200 frames and press Ok to
close the dialog.

Note: The Umbrella Frame that was merged into
this file has already been animated over a 200
frame range. Changing the time configuration
allows you to simulate the cloth over that entire
range.

6. In the Simulation group,
click the Simulate button.

Note: The simulation evaluates the cloths shape
for each frame of the animation based on its
properties, the position of the arms and the
force of gravity.

7. When the simulation is complete scrub the time
slider to view the animation.

Note: To see the final animation, open the
umbrella.avifile in \tutorials\cloth.

Summary

This concludes the written tutorials for Cloth. At
this point, you should have a pretty good idea of
how to use this tool.
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Mental Ray

Using the Mental Ray
Renderer
The mental ray® renderer is an alternative to the
3ds Max default scanline renderer. Created by
mental images®, it is a general-purpose renderer
that can generate physically correct simulations of
lighting effects, including ray-traced reflections
and refractions, caustics, and global illumination.
The lessons that follow introduce you to the use
of this renderer, controlling rendering quality,
and using it for various effects, some of which
are not available with the scanline renderer. We
recommend that you go through the lessons
in order, as some of them expect you to know
information covered in earlier lessons.

In addition to the renderer interface, 3ds Max
8provides a variety of materials and shaders
intended for use with the mental ray renderer. The
following tutorial, Using mental ray Shaders and
Materials (page 2–846), introduces you to the use
of these.

Skill Level: Intermediate

Time to complete: 2 hours

Features Covered in This Tutorial

• Using the Sampling Quality controls to adjust
the quality of a rendering.

• Using Trace Depth to control reflections (this
lesson also demonstrates a few other reflection
controls).

• Simulating a camera by using the mental ray
renderer’s version of motion blur and depth of
field.

• Creating the indirect illumination effects of
caustics and global illumination.

• Using Final Gather to improve the quality of
indirect illumination.

• Using the mental ray area lights, which generate
soft-edged shadows.

Tutorial Files

Files for this tutorial can be found in the
\tutorials\mental_ray folders on the Tutorial Files
CD.

Note: Before doing the tutorials, copy the \tutorials
directory from the CD to your \3dsmax8 local
installation.

Rendering
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Using Sampling to Adjust
Rendering Quality

The antialiasing settings for the mental ray
renderer, found on the Render Scene dialog
> Renderer Panel > Sampling Quality rollout,
control the quality of the finished rendering.
The most important settings are Samples
Per Pixel > Minimum and Maximum, which
essentially determine the degree of antialiasing,
but also affect resolution. Values above 1 enforce
oversampling (also called supersampling), which
enables antialiasing, values less than 1 result in
infrasampling, or rendering at reduced resolution,
while values of 1 result in no oversampling: the
renderer uses exactly one sample per pixel. For
more information, see Sampling.

The Minimum and Maximum parameters are set
by default to 1/4 and 4, respectively. These default
settings enable full-resolution rendering of edges
and slightly reduced resolution elsewhere in the
image. By reducing these settings, you can render
at full size but reduced resolution; by increasing
them, you can employ increasing degrees of
sampling.

In the following steps, you’ll be looking mainly at
edges.

Set up the scene:

• Open the file adaptive_sampling.max from
the \tutorials\mental_ray directory in your
3ds Max directory.

This scene consists of an openwork mesh, like
an ornamental brick.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Open the Render Scene dialog, and click
Render.

3ds Max renders the Perspective viewport to
show the mesh against a yellow background.

Note: The scene has been set up to use the
mental ray renderer, and the Render Scene
dialog is locked to the perspective view.

Samples: 1/4 minimum to 1 maximum

The image quality is not bad, but you can see
where surface edges are somewhat jagged,
especially against the background.

The Samples Per Pixel settings used initially in
this scene are Minimum=1/4 and Maximum=1.
The Maximum value is lower than the default,
but these are values you might want to use to
render a quick draft of an image.

Increase the sampling quality:

1. Click Clone Rendered Frame Window to
make a copy of the rendering.

3dsmax.chm::/sampling_mental_ray_renderer_glossary.html
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Cloning a rendered frame makes it easy to
compare the results of changing renderer
settings.

2. On the Render Scene dialog, go to the Renderer
panel and open the Sampling Quality rollout.

3. Increase the value of Maximum to 4, and then
click Render.

The image quality is noticeably better.

Samples: 1/4 minimum to 4 maximum

These values, Minimum=1/4 and Maximum=4,
are the default sampling values.

Increase the sampling quality still further:

1. Click Clone Rendered Frame Window to
make a copy of the last rendering.

2. On the Sampling Quality rollout, in the Samples
Per Pixel group, increase the value of Minimum
to 1, and the value of Maximum to 16, then
click Render.

The new rendering is extremely smooth.

Samples: 1 minimum to 16 maximum

For most finished renderings, the Minimum
number of samples per pixel should be set to
at least 1.

Increasing the number of samples per pixel
improves rendering quality, but eventually it
runs into diminishing returns. For the size of
the image you are rendering here, 400 x 400
pixels, a Maximum of 16 samples per pixel
gives good results. Increasing Maximum to a
value greater than 16 would result in the same
image, only rendered more slowly. If you were
rendering a higher-resolution image, you might
want to use larger Maximum values to obtain
the best quality possible.

Note: If you set Minimum equal to Maximum,
regardless of the value, each pixel is sampled
an equal number of times. This loses the
advantage of adaptive sampling, and wastes
rendering time. If you render the diagnostic of
the sampling rate, as shown below, the image
appears completely white.

Zoom in to see the results of sampling settings:

To better see the results of the sampling values you
used, zoom in on the rendered frames.
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• Hold down the CTRL key and click the window
of each of the three renderings you created, in
roughly the same part of the image.

Tip: If you have a three-button pointing device,
you can also use the middle mouse button or
wheel to zoom the rendered frames.

Close-up of 1/4 to 1 sampling

Close-up of 1/4 to 4 sampling

Zoomed in, edges in the 1/4 to 1 rendering are
clearly jaggy, and the routed edges don’t fully
render. In the 1/4 to 4 rendering, the routed
edges render correctly, but some stepping is
still visible, especially against the background.
In the 1 to 16 rendering, hardly any stepping is
visible at all.

You can close the cloned renderings now, if you
want.

Test low sampling quality:

For fun, try seeing what happens with extremely
low sampling.

1. Zoom the main rendered frame window (not
the clones, if you have left these open) back
out to a full view by holding down CTRL and
right-clicking the window.

2. In the Samples Per Pixel group, set Minimum
to 1/16 and Maximum to 1/4, then click render.

The result, as you might expect, is extremely
jaggy. At these low rates, there is no guarantee
that all pixels are sampled.
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Samples: 1/16 minimum to 1/4 maximum

Use diagnostic rendering to view adaptive sampling:

You can view the way the mental ray renderer is
sampling your scene.

1. On the Render Scene dialog, go to the
Processing panel. Open the Diagnostics rollout,
and turn on Enabled. Make sure that Sampling
Rate is chosen, and then click Render.

This is a schematic rendering. The brighter the
pixel, the more samples were collected within

it and on its lower and left edges. The red grid
shows the borders of individual buckets.

This scheme shows a low sampling rate to be
rather dim (few samples) and diffuse.

2. Go back to the Renderer rollout, and in the
Samples Per Pixel group, increase Minimum to
1/4 and Maximum to 1, and then click Render.

Now the rendering shows that a better sampling
rate concentrates on edges where the renderer
detects contrast.

3. Increase Minimum to 1 and Maximum to 16,
and then click Render again.
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The higher sampling rate more accurately
concentrates on regions of contrast.

Save your work:

• Save the file as sampling_tests.max.

Summary

Sampling controls the quality of your rendering.
You can use low sampling rates for draft
renderings, and higher sampling rates for polished
renderings. The Samples Per Pixel diagnostic tool
lets you see an image of where adaptive sampling
is being done.

Setting Trace Depth (and Other
Reflection Controls)

Reflection is one of the most basic capabilities of
ray tracing. With mental ray, you can determine
the trace depth, the number of reflections the
renderer traces. In this lesson, you’ll look at the
parameters for ray-traced reflections.

Set up the scene:

• Open the file trace_depth.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

This scene contains two blue spheres inside a
box, plus a camera and a single omni light.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Click Quick Render (Production) to
render the Camera01 view using the mental
ray renderer.

Note: The scene has been set up to use the
mental ray renderer, and the Render Scene
dialog is locked to the Camera01 view.
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Rendering in buckets

No reflections appear in the scene because the
materials aren’t set to ray trace.

Instead of rendering from the top of the image
downward, as the scanline renderer does, the
mental ray renderer renders in rectangular
blocks, called buckets. By default, buckets
appear in a sequence that minimizes the
amount of data transferred.

Note: If you use multiple CPUs to render a scene
(either two CPUs within a single system, or by
using multiple systems on a network), each
CPU is assigned a bucket to render every time
the CPU becomes available, until the scene is
fully rendered.

When the mental ray renderer encounters a
ray-tracing map assigned to a material’s reflection
or refraction component, it ray traces reflections
or refractions (or both) for that material. However,
it uses its own raytracer, and ignores the map’s
parameters that appear in the Material Editor.

The mental ray ray-tracing parameters are found
on the Render Scene dialog > Renderer panel >
Rendering Algorithms rollout.

Add Raytrace maps:

1. Open the Material Editor and make sure
the first material, named Mirrors, is selected.

This material is assigned to the box walls, floor,
and ceiling.

2. Open the Maps rollout, and click the map
button for the Reflection component. (By
default, this button, like all the other map
buttons, is labeled “None.”)

This opens the Material/Map Browser.

3. In the Browser list, scroll down to the Raytrace
map, and double-click it.

This assigns the Raytrace map to be the
Reflection map for the Mirrors material.

The Raytrace map is assigned as the Mirrors material’s
Reflection map.

Click the Go To Parent button to return to
the top material level.

4. Click the Blue Ball material’s sample slot,
and assign a Raytrace map to this material’s
Reflection component, as well.

The Blue Ball material is applied to the two blue
spheres.

Render with reflections:

Before you render, note the current Max.
Reflections setting for the mental ray renderer.

3dsmax.chm::/rendering_algorithms_rollout_mental_ray_renderer.html


812 Chapter 10: Rendering

1. Open the Render Scene dialog. Go to
the Renderer panel, and open the Rendering
Algorithms rollout. Look at settings in the
Trace Depth group.

The Maximum Reflections parameter is set to 1.
This means that, for each surface, the ray tracer
will stop after reflecting its surroundings once.

Note: These are not the default values for Trace
Depth.

2. Click Render to render the scene.

Scene rendered with Max. Reflections set to 1

Each primary surface reflects one copy of its
surroundings. While an interesting effect, it
isn’t realistic because, since every object in the
scene is reflective, the reflections should repeat,
creating reflections of reflections of reflections,
and so on. Similarly, the reflections aren’t
accurate. For example, the spheres as reflected
in the upper-left corner of the rendered image
don’t contain any reflections, whereas the
originals do.

Try increasing the number of reflections controlled
by Trace Depth.

Increase the trace depth:

1. On the Rendering Algorithms rollout, increase
Max. Reflections to 2.

2. Render the scene.

Scene rendered with Max. Reflections set to 2

The rendered image depicts a second level of
reflection. For example, the right-hand sphere
shows its own reflection in its reflection of the
other sphere. And the spheres’ reflections in
the upper left appear as the original spheres did
in the previous rendering, with a single level of
reflection. Also, a third pair of reflected spheres
appears, with no reflections.

3. Increase the Max. Reflections value to 10, and
render the scene again.
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Scene rendered with Max. Reflections set to 10

Because of the nature of ray tracing, the reflections
of reflections in such highly reflective scenes won’t
contain as many reflections as the original objects.
However, after a while, the differences aren’t very
noticeable. For most scenes, you won’t need a
Max. Reflections setting higher than 8 or so.

Note: If you set Max. Reflections higher than
10, the rendered image is the same as with Max.
Reflections set to 10. This is because in this scene
the Max Depth setting (also found under Trace
Depth) is set to 10 (the default is 6). The Max
Depth value limits the total number of reflections
and refractions. It helps ensure that rendering
times don’t become prohibitively long. If you
need more reflections, be sure to increase the Max
Depth setting.

Adjust visibility settings:

Two settings in the Object Properties dialog let you
control whether the active renderer (either mental
ray or the scanline renderer) renders objects, their
reflections, or both. In this section, you’ll take a
brief look at the Visible To Camera and the Visible
To Reflection/Refraction options.

1. On the Rendering Algorithms rollout, set Max.
Reflections back to 2.

First you’ll take a look at the 3ds Max
Renderable option.

2. In the Camera01 viewport, select the
foreground sphere (Sphere01). Then right-click
the viewport, and choose Properties from the
Transform (lower-right) quadrant of the quad
menu.

This opens the Object Properties dialog.

3. In the Rendering Control group, turn off
Renderable.

This makes the object invisible to the renderer,
although it still appears in the viewports.

4. Note that Cast Shadows is turned on, and then
close the dialog by clicking OK.

5. Render the scene using the mental ray renderer.

Neither the sphere nor its shadow or reflections
appear.

Rendering turned off for Sphere01

6. Reopen Object Properties for the Sphere01
object. In the Rendering Control group, turn
Renderable back on, and then turn off Visible
To Camera. Click OK.

This turns off the object’s visibility to the
mental ray renderer, although it can still cast
shadows, and other objects can still "see" and
reflect it.

7. Render the scene.
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Visible To Camera turned off for Sphere01

The Sphere01 object is missing, but its shadow
appears, and you can see its reflection in the
other sphere as well as on the surrounding
surfaces. In fact, you can even see the visible
sphere’s reflection in its reflection of the
invisible sphere. We call this the "reverse
Dracula" effect.

8. For a true Dracula effect, go back into Object
Properties for Sphere01. Turn Visible To
Camera back on, and then turn off Visible To
Reflection/Refraction. Close the dialog and
render the scene.

Visible To Reflection/Refraction turned off for Sphere01

The sphere renders, but its reflection doesn’t
appear in any of the other objects. In fact, you
can see the reflection of the sphere’s shadow

in the wall behind it, but not the sphere’s
reflection.

Save your work:

• Save the file as sphere_reflections.max.

Summary

When the mental ray renderer encounters a
raytrace map (or material), it uses its own ray
tracer. The Maximum Trace Depth settings control
how many times a ray is reflected or refracted.
The Object Properties dialog contains controls for
object visibility.

Creating Refraction

Refraction in mental ray works much the same
as in the 3ds Max scanline renderer, with a few
exceptions. To render refractive objects in mental
ray, you must use materials containing a Raytrace
or Reflect/Refract map as the Refraction map, and
set an appropriate number of refractions in the
Render Scene dialog. In this tutorial, you’ll load a
scene with a martini glass and drink, which you’ll
set to be refractive.

Set up the scene:

• Open the file martini.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

The principal objects in the scene are a
reflective cocktail shaker, a martini glass and
drink (the liquid inside the glass), and a couple
of olives on toothpicks.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.
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Render the scene with the scanline renderer:

1. Open the Render Scene dialog, and click
Render.

Note: The scene has been set up to use the
default scanline renderer, and the Render Scene
dialog is locked to the Camera01 view.

Scanline rendering of the cocktail set

2. Click Clone Rendered Frame window to
save a copy of this rendering for comparison.

Render the scene with the mental ray renderer:

1. On the Render Scene dialog, go to the Common
panel. Open the Assign Renderer rollout, and
click the Browse (“...”) button associated with
Production.

A Choose Renderer dialog appears.

2. In the list on the Choose Renderer dialog,
double-click “mental ray Renderer.”

Click Render.

mental ray rendering of the cocktail set

The two renderings are nearly identical. The
only difference is that the mental ray ray-tracer
handles the reflections on the cocktail shaker a
bit differently than the scanline ray-tracer.

3. Close the cloned frame window.

Currently both the glass object and the drink
object (a cone inside the glass) are mapped with
identical, opaque materials, so they don’t look very
realistic. The first thing to do is edit the materials
to be refractive.

Although the two objects are basically the same
for rendering purposes, you’ll use two different
materials because the indices of refraction for glass
and the drink’s water/alcohol mixture are slightly
different. Also, note that the materials are set to
2-Sided; this option generally gives the best results
with refractive objects.

Add refraction maps:

1. Open the Material Editor and make sure
the Glass material’s sample slot is selected.

2. On the Extended Parameters rollout, make sure
that Index Of Refraction is set to 1.5.

This is the default value, which approximates
the index of refraction for glass.
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3. On the Maps rollout, assign a Raytrace map to
the Glass material’s Refraction component.

A Raytrace map is assigned as the Glass material’s
Refraction map.

When the mental ray renderer encounters
a ray-tracing map assigned to a material’s
reflection or refraction component, it ray traces
reflections or refractions (or both) for that
material. However, it uses its own raytracer,
and ignores the map parameters that appear
in the Material Editor.

4. Click Go To Parent to return to the top
(material) level of the Glass material.

5. Select the Drink material’s sample slot. On the
Extended Parameters rollout, set its Index Of
Refraction to 1.329. The index of refraction
(IOR) of alcohol is slightly less than that of
water, which has an IOR of 1.333.

6. On the Maps rollout, assign a Raytrace map to
the Drink material’s Refraction component.

7. Click Go To Parent to return to the Drink
material’s top (material) level.

Compare rendered refractions:

1. Use the Render Scene dialog > Common Panel
> Assign Renderer rollout to make the default

scanline renderer current again, and then click
Render.

Scanline rendering with refraction

2. Click Clone Rendered Frame window to
save a copy of this rendering for comparison.

3. Use the Render Scene dialog > Common Panel
> Assign Renderer rollout to make the mental
ray renderer current again, and then click
Render.

mental ray rendering with refraction

These two renderings are also similar. The
mental ray renderer shows subtler detail
where the liquid (Drink material) refracts its
surroundings.

4. Close the cloned frame window.
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To render this scene properly, mental ray must
trace at least six refractions:

• At the near outer glass surface (relative to the
camera viewpoint)

• At the near inner glass surface

• At the near drink surface

• At the far drink surface

• At the far inner glass surface

• At the far outer glass surface

By default, the Trace Depth for setting for
refractions (as for reflections) is 6. This is enough
to render the cocktail glass well. However, by
default the Max Depth value is also 6, which means
that not enough rays are cast to account for all
reflections. You fix this in the next procedure.

Increase the Max Depth for tracing to allow for better
reflection:

• On the Render Scene dialog > Renderer panel
> Rendering Algorithms rollout, in the Trace
Depth group, increase the Max Depth value to
8, and then click Render.

Max Depth=8 to improve reflections

The differences are subtle, but the reflection
of the glass on the cocktail shaker now shows
more detail.

Although the cocktail refracts well, there is a
problem with the shadows. The refraction maps
allow light to penetrate the glass and drink objects,
but the olive in the glass isn’t illuminated, and its
shadow doesn’t appear on the table. Also, the area
beneath the glass is too dark. The reason is that
the glass and drink materials aren’t transparent!
In the real world, transparency and refractivity
go hand in hand, but in the computer graphics
world (at least, for 3ds Max and the mental ray
renderer), they are independent settings. For
proper illumination and shadowing, you must
make the materials transparent.

Make the materials transparent:

1. On the Material editor, choose the Glass
material’s sample slot. Go to the Blinn Basic
Parameters rollout. Change the Opacity setting
to 10.

2. Do the same for the Drink material.

3. Render the scene.

Glass and drink materials with correct opacity of 10 per
cent

The olive is properly illuminated and the
shadows now look convincing.

The glass was created by lathing a Line object. The
default Output option Mesh was used, but the
mental ray renderer can render either of the other
two lathe output types as well.
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Improve quality by changing the lathed glass’s
output mode:

1. Select the glass, then go to the Modify
panel. On the Lathe modifier’s Parameters
rollout, find the Output group, and then change
the setting from Mesh to NURBS.

2. Render the scene.

The rendering can take a few seconds longer.
The differences are subtle, but the rim and the
base of the glass appear smoother, with less
aliasing.

Lathed glass changed to NURBS output

You can use Patch output as well. The appearance
of a Patch lathe is similar to NURBS output, but
rendering is noticeably slower. Unless there’s a
specific reason to use Patch output, the NURBS
output option for lathed objects is a good
compromise between quality and time.

Tip: for best results with either the scanline
renderer or the mental ray renderer, you should
make sure your meshes are "clean." That is, they
should have no coincident faces, edges or vertices.
With lathed objects, make sure the Weld Core
option is turned on, and unless you need them
to remain parametric collapse them into editable
meshes to speed up rendering.

Summary

To generate refraction, assign a raytrace map to a
material’s refraction component, and specify an
Index Of Refraction (IOR) that is other than 1.0.
Refraction controls are independent of opacity
controls, but for most purposes refractive objects
should also have a low opacity.

Using mental ray Motion Blur

Motion blur, a term that comes from photography
and cinematography, refers to the blurring that
occurs when objects move a significant distance
while the camera shutter is open. In effect, the
object is "wiped" across the film during the
exposure, creating a smeared appearance. This
can also cause the entire scene to be blurred if
the camera is moving fast during the exposure
(camera motion blur), or cause blurred shadows if
a light is moving fast (light motion blur).

With a real camera, motion blur is determined by
two factors: the shutter speed and the speed of the
moving objects, camera, or lights.

In your scenes and animations, you can use
motion blur to emphasize the speed of fast-moving
objects or give the impression that the scene is
created with a camera moving jerkily. The mental
ray renderer can simulate this phenomenon, with
a global shutter speed setting for all viewports.

In this tutorial, you’ll use a spinning and rolling
car wheel to compare 3ds Max’s two types of
motion blur with mental ray’s, and also look at
how to improve the render quality of mental ray’s
motion blur.

Set up the scene:

1. Open the file motion_blur.max from the
\tutorials\mental_ray directory in your
3ds Max directory.
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This scene consists of a car wheel inside a
box, several lights, and a camera. The wheel
is animated.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Warning: The wheel rim and lugs have a material

named Rim2 applied to them. The Material Editor

also contains a material named Rim, which uses a

Raytrace map. The Rim material can give good results

with image motion blur and mental ray motion blur,

but using it with the scanline renderer and object

motion blur will hang 3ds Max.

2. Drag the time slider to see the wheel animation.

The wheel rotates in place over the first part of
the animation, then at frame 24 it starts to roll
out of the scene.

You can find motion_blur.avi, the finished
animation from this scene, in the
\tutorials\mental_ray directory in your
3ds Max directory. If you like, take a look at it
before proceeding, to see the results of this tutorial.

Render image motion blur with the scanline
renderer:

To begin, try rendering scene motion blur with the
default scanline renderer as a basis for comparison.
First check the motion blur properties.

1. Click Select By Name. On the Select
Objects dialog, select the [Lugs] group and the
Rim and Tire objects in the list, and then click
Select.

2. Right-click the selected objects in the Camera01
viewport (which should be active), and choose
Properties from the Transform (lower-right)
quadrant of the quad menu.

The Object Properties dialog is displayed. On
the General panel, the name field in the Object
Information group should display “Multiple
Selected.”

3. In the Motion Blur group, make sure that
Enabled is turned on, that the motion blur type
is set to Image, and that the Multiplier is set to
1.0. Click OK to close the dialog.

4. Move the time slider to frame 20, at which point
the wheel is spinning at full speed.

5. Open the Render Scene dialog. Go to the
Renderer panel, and on the Default Scanline
Renderer rollout, find the Image Motion Blur
group. Increase the value of Duration (Frames)
to 1.0.

This will make it easier to see the motion blur
effect. The value of 1.0 specifies that the virtual
shutter is open for the entire duration between
one frame and the next.

6. Render the scene.

First the wheel renders sharply, and then
motion blur is applied.

Frame 20 rendered with the scanline renderer and
image motion blur
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Note: Though this is an animation, the Time
Output option is set to Single (in the Common
panel > Common Parameters rollout > Time
Output group), so you’re rendering only one
frame.

A rotating wheel with thick spokes is a great
object for testing motion blur, because as the
rotational speed increases from the wheel
center outward, so does the blur amount.
Notice that, although the wheel is blurred, its
shadow is perfectly sharp.

Render object motion blur with the scanline
renderer:

Also try the scanline renderer with object motion
blur.

Tip: To more easily compare the two types of
motion blur, click Clone Rendered Frame Buffer
to copy the rendered frame before you perform
the next steps.

1. Select the [Lugs] group and the Rim and Tire
objects again. On the Object Properties dialog,
change the Motion Blur type to Object.

2. On the Render Scene dialog, go to the Renderer
panel. On the Default Scanline Renderer
rollout, in the Object Motion Blur group, set
Duration (Frames) to 1.0.

3. Render the scene again.

Frame 20 rendered with the scanline renderer and
object motion blur

Unlike the two-pass Image Motion Blur
process, Object Motion Blur takes place in a
single rendering pass. The blur looks different,
but the shadow is still sharp.

Note: Did you know that motion blur in
the default scanline renderer depends on
antialiasing? If you turn off Antialiasing (on
the same rollout, in the Antialiasing group), no
motion blur appears in the rendering.

Now you’re ready to compare all this with the
mental ray renderer.

Use the mental ray renderer to generate motion blur:

Important: For the mental ray renderer to generate

motion blur, the motion blur type of the [Lugs] group

and the Rim and Tire objects must still be set to Object.

The mental ray renderer does not blur objects that are

set to use Image motion blur.

1. On the Render Scene dialog, go to the Common
panel. Open the Assign Renderer rollout, and
click the Browse (“...”) button associated with
Production.

A Choose Renderer dialog appears.

2. In the list on the Choose Renderer dialog,
double-click “mental ray Renderer.”
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3. Go to the Renderer panel. Open the Camera
Effects rollout, then in the Motion Blur group,
turn on Enable.

Also in the Motion Blur group, notice that
Shutter is set to 1.0, the default.

4. Render the scene.

Like the scanline renderer’s Object Motion
Blur, mental ray’s motion blur occurs in the
same pass as the actual rendering.

Frame 20 rendered with mental ray motion blur and
Shutter=1.0

One big difference is the motion blur in the
wheel’s shadow, which isn’t possible with the
scanline renderer.

Tip: When lights are set to cast shadows using
the mental ray Shadow Map, you can disable
shadow motion blur by turning off Motion
Blur in the Render Scene dialog > Renderer
panel > Shadows & Displacement rollout >
Shadow Maps group. This toggle doesn’t affect
ray-traced shadows.

5. Change the Shutter setting to 0.5, and render
again.

mental ray motion blur with Shutter=0.5

6. Change the Shutter setting to 5.0, and render
again.

mental ray motion blur with Shutter=5.0

Lowering the Shutter setting decreases the
blurring, and raising it increases the motion blur
amount. Thus, the setting is roughly analogous to a
camera’s shutter speed, in which longer exposures
result in greater blurring of moving objects.

Render a later frame:

1. Change Shutter back to 1.0.

2. Drag the time slider to frame 25, and render
again.
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Motion blur while the tire is rolling forward

Here, although the Shutter setting is 1.0, the
blur looks “busier” than it did before. This is
because two kinds of blurring are going on: the
rotational blur that was also visible at frame 20,
and a translational blur that occurs because the
wheel is rolling forward.

Summary

To generate motion blur with the mental ray
renderer, you need to specify Object Motion Blur
for the objects to blur, and then enable motion
blur on the Render Scene dialog > Renderer panel
> Camera Effects rollout.

Using mental ray Depth of Field

Depth of field, a term that comes from
photography, refers to the region in which objects
in front of the camera are clearly focused. At
the camera’s focus plane (its target distance),
objects are in focus. The farther objects are from
this plane, the more blurred they become. With
a narrow depth of field, objects soon become
blurred. With a broad depth of field, objects must
be some distance from the focus plane before they
become blurred.

In a real camera, depth of field is partly determined
by the aperture size, or f-stop setting. A wider

aperture, indicated by a low f-stop setting, reduces
the depth of field; conversely, a smaller aperture,
indicated by a high f-stop setting, increases it.

In your scenes, you can use depth of field to direct
the viewer’s attention to a particular object or area
by causing the surrounding parts of the scene to go
out of focus. The mental ray renderer can simulate
this phenomenon, with separate f-stop and focus
plane settings for cameras and for the Perspective
view.

Set up the scene:

1. Load the file depth_of_field.max from the
\tutorials\mental_ray directory in your 3ds Max
directory.

This scene consists of three apples inside a
wooden box, plus a camera, spotlight, and an
omni light. The camera target is animated to
move from the front apple to the rearmost over
30 frames.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera01 view.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

2. Render the scene.
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Scene rendered with depth of field turned off

The three apples are all in focus, because Depth
Of Field is currently turned off.

Note: Though this is an animation, the Time
Output option is set to Single (in the Common
panel > Common Parameters rollout > Time
Output group), so you’re rendering only one
frame.

Add depth of field to the scene:

1. In the Top viewport, select the camera, and
then right-click in the Camera01 viewport to
reactivate that view.

The mental ray Depth of Field option lets you
control depth of field for each camera when
rendering with mental ray. It has no effect with
other renderers.

2. Go to the Modify panel. On the
Parameters rollout, find the Multi-Pass Effect
group. Turn on Enable, then choose “Depth Of
Field (mental ray)” from the drop-down list.

Although the mental ray depth-of-field
feature is not really a multi-pass effect, you
choose it here because the scanline renderer’s
depth-of-field feature for cameras is also on
this list.

A Depth Of Field Parameters rollout is
displayed on the Modify panel below the
generic Parameters rollout for cameras.

3. Change the f-Stop value to 1.0.

It is hard to detect a change in depth of field at
the default f-Stop setting of 2.0.

4. Render the scene.

Scene rendered with depth of field turned on, f-Stop=1.0

The front apple is still in focus, the one behind
it is slightly blurred, and the rearmost apple is
fuzzier still. This progression occurs because
the camera is focused on the front apple, as
determined by its target’s position.

Incidentally, the mental ray f-Stop values don’t
have a direct correlation to f-stop values for
real-world cameras. The control is labeled
"f-Stop" primarily as a mnemonic device.
As with a real camera, increasing the value
broadens the depth of field, while decreasing it
value narrows the depth of field.

Use the f-Stop setting to narrow the depth of field:

You can reduce the depth-of-field, thus enhancing
the effect, by lowering the f-Stop setting.
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• On the Depth Of Field Parameters rollout, set
f-Stop to 0.3, then render the scene again.

Scene rendered with f-Stop=0.3

The front apple remains in focus. However, the
middle apple is noticeably blurrier than before,
and the rearmost apple even more so.

Note that the unfocused edges are quite grainy,
due to the low sampling settings. You can
improve their appearance by increasing the
number of samples mental ray uses.

Increase the sampling rate to improve quality:

1. On the Render Scene dialog > Renderer panel,
open the Sampling Quality rollout. In the
Samples Per Pixel group, change Minimum to 1
and Maximum to 4 respectively.

2. Render the scene.

Scene rendered with f-Stop=0.3, Samples Min=1,
Samples Max=4

Although rendering now takes longer, the
graininess is much reduced. Use low Samples
settings to test effects, and then set them higher
for final renderings.

Render different frames of the animation:

To change the area of focus, simply move the
camera target, which 3ds Max automatically
translates to mental ray’s Focus Plane setting (see
the final section of this tutorial). In this scene, the
target is animated so that it moves from the front
apple to the rearmost between frames 1 and 30.

Note: For a free camera, you set the target distance
using a spinner at the bottom of the camera’s
Parameters rollout.

1. Set f-stop to 0.4 and drag the time slider to
frame 30.

In the Top viewport, you can see that the
camera target is now positioned near the
rearmost apple.

2. Render the scene.
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Camera focused on the rearmost apple

This time, the rearmost apple is in focus, while
the blurriness increases towards the front of
the scene.

3. Drag the time slider to frame 10.

In the Top viewport, you can see that the
camera target is now at the center apple.

4. Render the scene.

Camera focused on the middle apple

If you render all the frames as an animation,
you can see the focus move from the front to
the back, like adjusting the manual focus on a
camcorder as you’re videotaping. (In filmmaking,
this is often called “pulling focus.”) You can find
depth_of_field.avi, a rendered animation of this
scene, in the \tutorials\mental_ray directory in
your 3ds Max directory.

Tip: To animate a camera orbiting another object,
you might normally use its target as the center of
the orbit. But this might not be the same location
you want to use to control depth of field. If so,
change the way you animate the camera. Create
a dummy object to replace the camera target for
animation purposes, and assign the camera a Look
At controller that has the dummy as its target.

Set depth of field for a Perspective viewport:

The mental ray renderer also has separate
depth-of-field controls for perspective viewports.
These are found on the Render Scene dialog >
Renderer panel > Camera Effects rollout. (With
the mental ray renderer, depth of field is not
available for axonometric views such as Front, Top,
User, and so on.)

1. Go to frame 1.

2. At the bottom of the Render Scene dialog,
click to unlock the Camera01 viewport.

3. Right-click the Perspective viewport (lower
right) to activate it.

4. On the Renderer panel > Camera Effects
rollout, find the Depth Of Field (Perspective
Views Only) group, and turn on Enable.

5. Click Render.

Because Focus Plane is set to its default of 100,
which is closer than the front apple, the entire
scene renders out of focus.

For perspective viewports, the Focus Plane
value sets the distance where the scene is in
focus. To find a reasonable value for it, look at
the comparable target distance for the camera.

6. Select the camera. On the Modify panel, look at
the Target Distance readout near the bottom of
the Parameters rollout for the camera.

The distance between the camera and the front
apple should be about 175. If it’s a different
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number, remember that number for the next
step.

7. In the Render Scene dialog > Renderer panel
> Camera Effects rollout > Depth Of Field
(Perspective Views Only) group, set Focus
Plane to 175, or the Target Distance reading
you found in the previous step, and render the
Perspective viewport again.

The view is slightly shifted, but the depth of
field is similar to the result you obtained with
the camera.

The Depth Of Field controls on the Camera
Effects rollout apply only when rendering
perspective viewports. For camera viewports,
always use the “Depth Of Field (mental ray)”
rollout on the camera’s Modify panel.

Note: For perspective views, the Camera Effects
rollout also lets you control depth of field
by specifying the near and far limits of the
in-focus area. Choose In Focus Limits from the
drop-down list, and then set the Near and Far
parameters to the desired values. There is no
direct relationship between the f-Stop setting
and the Near and Far limits; that is, changing
one doesn’t change the other.

You can’t animate the Focus Plane setting. On
the other hand, you can animate the f-Stop
setting for either a Camera or a Perspective
view. In general, using a target camera gives you

the most flexibility when you want to animate
the mental ray depth-of-field effect.

Summary

To use mental ray depth of field with a camera,
choose “Depth Of Field (mental ray)” on the
camera’s Modify panel > Parameters rollout >
Multi-Pass Effect group. The camera’s target
distance sets the focus plane, and the f-Stop value
controls the width of the depth-of-field effect.

To use mental ray depth of field with a Perspective
viewport, use the similar controls on the Render
Scene dialog > Renderer panel > Camera Effects
rollout.

Creating Reflective Caustics

Caustics are the effects of light cast onto an object
after the light has been reflected off or refracted
through another object. A common example of
reflective caustics is the effect of sunlight reflecting
off the water surface in a swimming pool, casting
uneven, shimmering light patterns onto nearby
walls. In this tutorial, you’ll re-create this effect
with mental ray’s caustics.

Mental ray simulates reflective caustics by
generating "photons" from a light source,
bouncing the photons off a surface, and then
drawing the resultant light patterns on surfaces
onto which the light is reflected. This effect
falls under the general category of indirect
illumination, which also includes refractive
caustics (page 2–831) and global illumination
(page 2–835) (radiosity-type lighting).

To render reflective caustics in mental ray, you
must use at least one material containing a
Raytrace, Flat Mirror, or Reflect/Refract map
in the Reflection map slot, and set the reflective
object to generate caustics. In this tutorial, you’ll
load a scene with a swimming pool, whose surface
you’ll set to be reflective.
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Set up the scene:

• Open the file swim_pool.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

The principal objects in the scene are the
swimming pool enclosure, the wall behind it,
the ladder, and a box that serves as the water
surface. Light is cast onto the pool surface by a
spotlight.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Click Quick Render.

In this scene, the renderer is locked to the
Camera01 view and set to use the mental ray
renderer.

Swimming pool rendered without reflections

The water material doesn’t contain a reflection
map, so it doesn’t look very realistic.

Add a reflection map:

1. Open the Material Editor and make sure
the Ground_Water material (in the first sample
slot) is selected.

2. Open the Maps rollout. Assign a Raytrace map
to be the Reflection map.

Note: When the mental ray renderer encounters
a ray-tracing map assigned to a material’s
reflection or refraction component, it ray
traces reflections or refractions (or both)
for that material. However, it uses its own
raytracer, and ignores most of the map’s
parameters in the Material Editor. The mental
ray ray-tracing parameters are found on the
Render Scene dialog > Renderer panel >
Rendering Algorithms rollout.

3. Click Quick Render again.

Swimming pool rendered in mental ray with reflections

This is a little better. The water reflects its
surroundings, and the bump map on the water
material breaks up the reflection. But an actual
swimming pool would bounce light onto the
walls, as well. This is what reflective caustics do.

4. Close the Material Editor.
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Set the water to generate caustics:

1. In a viewport, select the box object named
Water, and then right-click it.

2. On the Transform (lower-right) quadrant of the
quad menu, choose Properties.

The Object Properties dialog is displayed.

3. On the Object Properties dialog, go to the
“mental ray” panel. Click to turn on Generate
Caustics, and then click OK.

Objects receive caustics by default, but don’t
generate them. To generate caustics, an object
must have a reflective or a refractive material
applied to it, as the Water does.

Note: In addition, all light sources are set to
produce photons. Thus, in most cases you need
only explicitly specify the objects that are to
generate caustics. In some cases, though, you
might want to turn off Receive Caustics for
objects that you don’t want to be illuminated
by reflected photons.

Turn up the light energy:

1. Click Select By Name. On the Select
Objects dialog, choose Spot01.

2. Go to the Modify panel.

3. Open the “mental ray Indirect Illumination”
rollout. Leave Automatically Calculate Energy
And Photons turned on, but change the value
of the Energy multiplier to 30.

Note: By turning off Automatically Calculate
Energy And Photons, you can create a local,
unique behavior for the light when calculating
indirect illumination. For most situations,
however, this isn’t necessary. If you need to
adjust a light’s behavior, use the three multiplier
controls.

The default energy level for generating caustics
isn’t always sufficient to have a visible result.

When this is the case, increase the Energy,
either for an individual light or for the scene
overall. As with radiosity for the default
scanline renderer, the required energy level
depends on the dimensions of the scene. Unlike
radiosity, unfortunately, with the mental ray
renderer there is no fixed rule for determining
the energy level that works. You need to find a
workable value by trial and error, as we have
done for this scene.

Enable caustics:

1. Click Render Scene. On the Render
Scene dialog, go to the Indirect Illumination
panel. On the Caustics And Global Illumination
rollout, in the Caustics group, turn on Enable.

2. Click Render.

Swimming pool rendered with caustics

Now the wall shows the caustic effects of light
bounced off the surface of the water. The water,
in turn, reflects the caustics, making the whole
scene brighter overall.

Adjust the radius of photons:

The caustics in the previous rendering are
extremely diffuse. This is because the default size
of rendered photons is based on scene extents: one
photon is 1/100 the maximum radius of the scene.
(The default radius of caustic photons is smaller
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than the default radius of global-illumination
photons.) Sometimes this gives good results,
but sometimes smaller photons help you achieve
greater detail.

1. On the Caustics And Global Illumination
rollout, in the Caustics group, turn on
Maximum Sampling Radius and make sure it’s
set to the default value of 1.0.

Turning on Maximum Sampling Radius lets
you control the size of the photons used to
create caustics.

2. Click Render.

Swimming pool rendered with caustics, and Radius=1.0

This time, instead of irregular light patterns,
the image contains a lot of small white dots
scattered throughout the scene. These are the
photons; or rather, their reflections after being
bounced off the water surface onto the ladder
and nearby walls. Each photon’s position is
determined by the angle of the photon emitter
(the light source) with the part of the water
surface that it hits, taking into the account the
surface irregularity caused by the bump map or
any other modification.

Photons this small don’t look realistic, but they
show how the mental ray renderer is generating
caustics, and they can be a useful preview tool.

The mental ray renderer blends caustic photons
only where they overlap. So for this scene,

reducing the Radius value would only make the
photons look even spottier. You need larger
photons for more realistic results.

3. Set the Maximum Sampling Radius value to 5.0.

4. Click Render.

Swimming pool rendered with caustics, Radius increased
to 5.0

This image is closer to the one that used the
default (calculated) radius, but the caustics
patterns are more clearly defined.

Note: When the photon reflections overlap,
mental ray uses sampling to smooth them into
the uneven patterns you’ve been seeing. You
can adjust the effect of smoothing by changing
the setting Maximum Number Of Photons Per
Sample.

Change the filter option:

The caustics in the previous rendering are slightly
noisy. That’s because you’ve been using the default
Box filter. Switching to the Cone filter can smooth
the caustics and make them look more normal.

1. On the Caustics And Global Illumination
rollout, in the Caustics group, use the Filter
drop-down list to change the filter type to Cone.

2. Click Render.
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Photon radius of 5.0, with Cone filter

Now the caustics are blended more smoothly.

You can vary the appearance of Caustics a great
deal by adjusting the indirect illumination
parameters, both on the Render Scene dialog and
on the light’s “mental ray Indirect Illumination”
rollout. Other variables include scene elements
and materials; so in general, you’ll need to
experiment to find appropriate settings for your
scenes and animations.

Note: In this scene, the offsets for the Noise map are
animated, which leads to changing patterns on the
water surface, and hence changing caustics as well.
View reflective_caustics.avi for a brief (but rather
too rapid) demonstration of animated caustics.
This movie file is in the \tutorials\mental_ray
directory in your 3ds Max directory.

Save a photon map file:

You can save photon maps to a file for re-use,
which can speed the rendering of caustics in an
animation. These steps show how to do so.

1. Scroll to the bottom of the Caustics And Global
Illumination rollout. In the Light Properties
group, set Average Caustic Photons Per Light
to 1000.

Reducing the number of photons makes it easier
to see individual photons when you render.

2. On the Caustics And Global Illumination
rollout, in the Photon Map group, click the
Browse button (labeled “...”) next to Use File.

A Save As dialog is displayed.

3. On the Save As dialog, enter pool.pmap as the
file name, and then click Save to exit the dialog.

Use File is now active. This tells the mental ray
renderer to save the photon map (the pattern of
photons and reflections) to a file. If lighting and
reflection conditions don’t change, the renderer
can reuse this file repeatedly when rendering an
animation, instead of regenerating it for each
frame. This can save a significant amount of
rendering time.

4. Render the scene again.

Now comparatively few photons appear,
reflecting the reduced photon count you set in
step 1 (of this procedure). Also, the mental ray
renderer has generated and saved the photon
map file you specified in the previous step.

Next, set mental ray to use 10 times as many
photons, so it’ll be easy to tell whether it’s
generating a new photon map in the subsequent
rendering.

5. In the Light Properties group, set the number of
Average Caustic Photons per Light back to the
default value of 10000.

6. Make sure Use File is on, and then render the
scene again. (You can cancel this rendering
before it’s done.)

The image is the same as in the previous render.
Although you increased the number of photons
in step 5, the mental ray renderer is now using
the photon map you saved during the previous
render, so it ignores the new setting. To see the
effect of any altered conditions, you need to tell
mental ray to recalculate the photon map.

7. Turn off Use File, turn on Rebuild, and
re-render the scene. (You can cancel this
rendering before it’s done.)
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This time, the rendered image reflects the
increased number of photons.

In general, render a new photon map when
any condition that affects the photon pattern
changes from frame to frame. For example, in
this swimming pool scene, the bump map that
produces the uneven water surface is animated
to create moving caustics. But the caustics would
remain stationary throughout the animation if you
didn’t choose Render. If the conditions for caustics
don’t change from frame to frame, render once to
save a photon map, then use the Load option when
you render the remaining frames in the animation.

Summary

To create reflective caustics, use the reflective
objects’ Object Properties dialog > mental ray
rollout to have the object generate caustics. Adjust
caustic settings on the Render Scene dialog >
Indirect Illumination panel > Caustics And Global
Illumination rollout.

Creating Refractive Caustics

Caustics are the effects of light cast onto an object
after the light has been reflected off another
object or refracted through another object. A
common example of refractive caustics is the
effect of sunlight transmitted through a glass of
liquid, casting uneven, shimmering light patterns
onto nearby surfaces, as shown in the following
photograph. In this tutorial, you’ll re-create this
effect with the mental ray renderer.

Actual photograph of real-world caustics

The mental ray renderer simulates refractive
caustics by emitting "photons" from a light
source, refracting the photons through one or
more objects, and then drawing the resultant
light patterns on surfaces onto which the light is
transmitted. This effect falls under the general
category of indirect illumination, which also
includes reflective caustics and global illumination
(radiosity-type lighting).

To render reflective caustics, you must use at least
one object with a material that contains a refractive
map (such as Raytrace) in the Refraction map slot.
You must also set the refractive object to generate
caustics. In this tutorial, you’ll load a scene with
a goblet and the liquid inside it, which you’ll set
to be refractive. You’ll then turn on the mental
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ray Caustics feature, and experiment with various
settings related to refractive caustics.

Note: This tutorial builds on the knowledge gained
from two previous tutorials: Creating Refraction
(page 2–814) and Creating Reflective Caustics
(page 2–826). To get the most from this tutorial,
we recommend that you first complete those
tutorials.

Set up the scene:

• Open refractive_caustics.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

This scene already fulfills several of the
requirements for refractive caustics. The Glass
and Liquid objects both contain refractive
materials, a light source is set to emit photons,
and all objects are set, by default, to receive
caustics. Also, the surface the glass stands on
has a material applied, which is necessary for it
to be able to receive caustics.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Click Quick Render.

In this scene, the renderer is locked to the
Camera01 view and set to use the mental ray
renderer.

No caustics appear in the scene. That’s because
the most basic requirement, turning on caustics
in the renderer, hasn’t been met.

Scene rendered without caustics

If, at this point, you were to turn on caustics and
try to render, you would see this error message:

When Caustics is turned on but no caustic
generators or receivers exist in the scene, rendering
can slow down significantly, so the renderer
doesn’t allow this situation to occur.

If you click OK, the renderer disables caustics
to avoid unnecessary calculations, and then
continues to render. If you click Cancel, you can
set objects to generate caustics before you render
again.

Set the glass and its liquid to generate caustics:

1. Select the Glass object, right-click to display the
quad menu, and choose Properties from the
Transform (lower-right) quadrant.

The Object Properties dialog is displayed.

2. On the Object Properties dialog, go to the
“mental ray” panel. Click to turn on Generate
Caustics.
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3. Repeat step 1 and 2 for the Liquid object, which
is a lathed shape inside the Glass object.

Tip: You might find it easiest to select this
object by using Select By Name.

4. Open Object Properties for Walls2, the object
that the glass is standing on.

Tip: The easiest way to select this object is by
clicking the Camera01 viewport away from the
other objects.

Note that Receive Caustics is on for the Walls2
object. All objects are set to receive caustics by
default.

5. Close the Object Properties dialog.

Turn on caustics:

• Scroll to the top of the Caustics And Global
Illumination rollout. In the Caustics group,
turn on Enable.

Increase the light energy:

In the reflective caustics lesson, you used the
spotlight’s multiplier to increase the light energy
used to generate indirect lighting, including
caustics. For the scene with the cocktail shaker,
you will also increase the energy value, but using
the controls for caustics and global illumination.
As the scene contains two lights, this approach
makes more sense.

1. Click Render Scene. On the Render
Scene dialog, go to the Indirect Illumination
panel.

2. Scroll to the bottom of the Caustics And Global
Illumination rollout. In the Light Properties
group, increase the value of Global Energy
Multiplier to 175.0.

3. Click Render.

Caustics rendered with default radius

The caustic photons use the default radius of
1/100 the maximum radius of the scene. With
the swimming pool model, the default radius
yielded mediocre results. With the cocktail
shaker scene, the result is similarly fuzzy. As
before, the next step is to look more closely at
photon distribution.

Render with smaller photons:

1. In the Caustics group, turn on Maximum
Sampling Radius.

The default value of an explicitly specified
caustic photon radius is 1.0.

2. Click Render.

Caustics rendered with Maximum Sampling Radius = 1.0
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The smaller photons show that the caustic
distribution of photons is more complex than
the default radius shows. We want to keep much
of that detail. As with the swimming pool, a
radius of 1.0 is too small for photons to blend
well. Again, you will try a larger photon size;
but since the scene is smaller, the photons don’t
have to be as large as they did for the swimming
pool.

Increase the photon size:

1. In the Caustics group, change the Maximum
Sampling Radius value to 2.5.

2. Click Render.

Caustics rendered with Maximum Sampling Radius = 2.5

Now the photons blend somewhat better, but
the effect is rather fuzzy. With the swimming
pool model, the Cone filter provided better
blending, so give that a try.

Change the filter option:

1. In the Caustics group, change the Filter type
from Box to Cone.

2. Click Render.

The photons are blended better and appear a
bit brighter as a result.

In effect, this is where you left off work on the
swimming pool model. But the refractive caustics
in this model benefit from increasing the number
of photons.

Increase the photon count:

1. Scroll to the bottom of the Caustics And Global
Illumination rollout. In the Light Properties
group, increase the value of Average Caustic
Photons Per Light to 50000 (fifty thousand).

2. Click Render.

The scene takes longer to render, but the
quality of the caustics is dramatically improved.
Reflective caustics scatter photons, so
increasing the photon count often muddies
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the effect, rather than improving it. Refractive
caustics focus most photons, so increasing the
count often improves the effect.

Summary

To create refractive caustics, use the refractive
objects’ Object Properties dialog > mental ray
rollout to have the object generate caustics. Adjust
caustic settings on the Render Scene dialog >
Indirect Illumination panel > Caustics And Global
Illumination rollout. Setting an explicit Maximum
Sampling Radius value can help improve quality,
as can increasing the number of caustic photons.

Using Global Illumination

In the real world, light energy bounces from one
surface to another. This tends to alleviate harsh
shadows, and makes illumination more even than
it would be otherwise. In 3D graphics, however,
light does not bounce by default. You must instruct
your program to generate a model of bounced
lighting. There are a number of methods for
doing so. The method provided by the mental ray
renderer is known as global illumination. Global
illumination employs the same photons used to
render caustics. In fact, both global illumination
and caustics fall into the same overall category,
called indirect illumination.

In your scenes, you can use global illumination
to create smooth, natural-looking lighting
with relatively few light sources and relatively
little added cost in rendering time. This lesson
demonstrates some of the settings associated with
global illumination.

Note: Another widespread method for simulating
bounced lighting is radiosity, which computes
the exchange of radiant energy between surfaces.
In 3ds Max, radiosity is available for use with the
default scanline renderer, but not with the mental
ray renderer.

Set up the scene:

• Open loft_and_spotlight.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

The scene shows an imaginary loft space. It is lit
by a single spotlight. The scene has been set up
to use the mental ray renderer, and the Render
Scene dialog is locked to the Camera01 view.
It is also set up to render at the 1:85 (“cine”)
aspect ratio.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Click Quick Render (Production).

Loft lit by a single spotlight

With only the single spotlight and no bouncing
of light, the scene is very shadowy.

Add global illumination:

1. Click Render Scene to open the Render
Scene dialog. Go to the Indirect Illumination
panel. On the Caustics And Global Illumination
rollout, in the Global Illumination group, click
to turn on Enable.

2. Click Render.
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Global illumination added to the rendering

Now the scene is better lit, but the walls have a
“blobby” look. You are in fact looking at the
photons that the mental ray renderer has cast
from surfaces that bounce light. These photons
are large. As with caustics, by default they are
1/10 the maximum radius of the scene. Large
photons help speed rendering, but they can
leave artifacts.

With caustics, you adjusted the effect
by adjusting photon size. With global
illumination, you can use an additional method
called final gathering. A final gather pass adds
additional samples to the calculation of global
illumination. It adds to the rendering time,
but it eliminates most artifacts from dim or
overlapping photons.

Add final gathering:

1. Scroll down to the Final Gather rollout. In the
Final Gather group, click to turn on Enable.

2. Click Render.

Loft rendered with both global illumination and final
gathering

Now the loft is evenly lit, though it is still a bit
dim.

Try final gathering only:

The final gather step is independent from the
global illumination pass. You can use final gather
without global illumination, as these steps show.

1. On the Caustics And Global Illumination
rollout, in the Global Illumination group, click
Enable to turn it off again.

2. Click Render.

Loft rendered with final gathering only

The result is dimmer than when you combined the
two methods. The photon artifacts aren’t visible,
but the corners of the room are too dark, and
appear patchy.

In general, to obtain a polished rendering, it is
a good idea to use global illumination and final
gathering together.

Increase the light energy in the scene:

The combination of global illumination and final
gathering gave an evenly lit scene, but it could
benefit from a bit more light.

1. On the Caustics And Global Illumination
rollout, in the Global Illumination group, click
Enable to turn it back on.

2. On the Caustics And Global Illumination
rollout, scroll down to the Light Properties
group.

3. Increase the value of Global Energy Multiplier
to 1.5.
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4. Click Render.

Loft rendered with more light energy

Light Properties > Global Energy Multiplier = 1.5

Now the scene is better lit. Unfortunately, the
better lighting makes some patchiness more
apparent, especially in the corners, and where
the walls meet the ceiling. This is a situation
that you can improve by increasing the level of
final gathering.

Increase the number of final gather samples:

1. On the Final Gather rollout, in the Final Gather
group, increase the value of Samples to 50.

2. Click Render.

Loft rendered with smoother light

Final Gather > Samples=50

Increasing the number of final gather samples
noticeably increases render time, but now the
lighting in the loft is convincingly even.

Save your work:

• Save the scene as illuminated_loft.max

One effect of light bouncing, is that surfaces
can take on the color of nearby objects. This
phenomenon is often called “color bleeding.” It
tends to be more apparent in photographs than in
daily life, because our eyes and brain compensate
for it. When you use global illumination, color
bleeding can add a touch of photorealism to your
renderings.

Set up a scene to look at color bleeding:

1. Open loft_with_art.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

This scene is a corner of the loft, with the same
indirect illumination settings as in the previous
rendering. The aspect ratio is 1.333.

2. Click Render.

A corner of the loft model

3. Right-click the Camera02 viewport, and choose
Unhide All from the Display (upper right)
quadrant of the quad menu.

An object, Box01, that represents a red painting
is now visible in the scene.

4. Click Render.
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The corner with a red painting

Some bounced color is visible on the floor, and
more is visible on the ceiling above the painting.
The effect is a subtle one. It can benefit from a
higher light level, and also from more global
illumination photons.

5. On the Caustics And Global Illumination
rollout, scroll down to the Light Properties
group.

6. In the Light Properties group, increase the value
of Global Energy Multiplier to 15.

7. Also in the Light Properties group, increase
the value of Average GI Photons Per Light to
100000 (one hundred thousand).

8. Click Render.

The corner and painting with more light and more
photons

Light Properties > Global Energy Multiplier = 15

Light Properties > Average GI Photons per Light =
100,000

The effect is still subtle, but it is more apparent
with the increase in the light level and the
number of photons used to calculate global
illumination.

Save your work:

• Save the scene as color_bleed.max.

Summary

Rendering global illumination increases the light
level of a scene in a realistic way. Adding final
gather can improve the rendering quality. The
controls for these are on the Render Scene dialog
> Indirect Illumination panel > Caustics & Global
Illumination rollout.

Using mental ray Area Lights

Area lights are lights that emit photons from a
geometric area, as opposed to a point (“omni”)
light source or a focused spotlight (or the even,
parallel rays of a directional or sun light).
Real-world examples of area lights are windows,
skylights, fluorescent and neon tubes, and so on.
Typically, the shadows generated by area light
sources are more diffuse than shadows from point
or spot light sources, and have soft edges.

The default scanline renderer provides two means
of generating area light, depending on whether you
are using standard lights or photometric lights.
With standard lights, Area Shadows give the effect
of area lights. With photometric lights, the Linear
and Area light types provide area lighting. The
mental ray renderer has area lights of its own.

Warning: The mental ray renderer does not recognize

either area shadows for standard lights, or the geometric

dimensions of photometric linear and area lights. If you

want to use area lights in mental ray renderings, you

have to use the mental ray Area Omni or mental ray Area

Spot light types.
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The mental ray area light types (Area Omni
and Area Spot) are implemented with a built-in
MAXScript script. You can either create area lights
as new light objects (mental ray area lights are
standard lights), or use the MAXScript “Convert
To mental ray Area Lights” utility to convert
existing omni or spot lights to area lights. This
tutorial shows you how to do so.

Set up the scene:

• Open the file area_light_spot.max from
the \tutorials\mental_ray directory in your
3ds Max directory. (Don’t confuse this with
area_light_omni.max, which is in the same
directory and looks similar, but behaves
differently.)

This scene consists of a cylinder resting on
a plane, and some boxes to the left floating
in front of another plane. The planes have a
matte/shadow material applied, which lets
them display shadows without any other visual
detail, rather the way seamless paper is used in
a photographic studio. The background of the
rendered scene is provided by a gradient map.

The scene contains a target spotlight as its
principal (key) light, and a single omni light
to provide fill. At the right of the scene is a
yellow box outlined in black. This object is a
placeholder that lets you see the location of the
spotlight.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene with the scanline renderer and
ray-traced shadows:

1. Select the spotlight (Spot01), and
then go to the Modify panel. On the Modify
panel, the spotlight’s General Parameters

rollout shows that the light is on, that it casts
shadows, and that the shadow type is Ray
Traced Shadows.

2. Click Quick Render (Production) to
render the scene.

Scanline rendering with ray-traced shadows

The rendering shows the hard-edged shadows
typical of ray-tracing.

Render the scene with the mental ray renderer:

1. On the Render Scene dialog, go to the Common
panel. Open the Assign Renderer rollout, and
click the Browse (“...”) button associated with
Production.

A Choose Renderer dialog appears.

2. In the list on the Choose Renderer dialog,
double-click “mental ray Renderer.”

3. Render the scene.

The rendering with the mental ray renderer’s
ray-traced shadows is almost identical to the
scanline version.

Convert the spotlight to a mental ray Area Spot:

1. Make sure the spotlight is still selected.
Go to the Utility panel. On the Utilities rollout,
click to turn on MAXScript.
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The MAXScript rollout is displayed.

2. Near the bottom of the MAXScript, click the
drop-down list labeled Utilities, and choose
“Convert To mr Area Lights.”

The “Convert To mr Area Lights” rollout is
displayed.

Note: Even if “Convert To mr Area Lights” is
visible in the Utilities list (by default, it is the
only choice), you still have to choose it by hand
to see the conversion utility’s rollout.

3. On the “Convert To mr Area Lights” rollout,
click Convert Selected Lights.

An alert asks you Delete Old Lights?

4. Click No.

When you click Yes, the original light is deleted
from the scene. When you click No, the original
light remains in the scene, but it is turned off
while the new mental ray area light is turned
on. Clicking No is the safer choice while you
are still creating a scene, and might want to
recover some of your earlier steps. When the
scene is finished, you can always delete the
original light.

Warning: Although the old light is turned off and

the new light is on, so that renderings will look the

way you expect, the original light remains selected. If

you want to adjust the properties of the new mental

ray area light, you need to select it explicitly. Select

By Name is the easiest way to do this.

5. Render the scene

mental ray rendering with a 2D area light

The shadows are now diffuse and soft-edged,
as if created by unfocused light. By default, a
mental ray area spot is a 2D rectangular area
that is 20.0 units square.

Render the area spotlight’s icon:

1. Click Select By Name. Choose mr Area
Spot01 from the list, and then click Select.

2. Go to the Modify panel. Open the Area Light
Parameters rollout, and turn on Show Icon In
Renderer.

Rendering with area light icon

The area light renders as a white square that has
the same location as the yellow box.

Rendering the area light’s icon can be a help
when you want to visualize how shadows will
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appear in a final rendering, and how you might
want to adjust them. For most scenes, probably
you will want to turn off the icon before you
create a production-quality rendering.

Adjust the size of the area spotlight

1. On the Area Light Parameters rollout, change
both the Height and Width of the area light to
10.

These are the same dimensions as the faces of
the yellow cube.

2. Render the scene.

Rendering with size of area light matched to size of box

The icon is no longer visible, as it’s the same
size as the cube. The shadows themselves are
not too different from the ray-traced versions,
except that they are softer.

If you have an object in the scene that is a
“practical” light (that is, that is meant to look as
if it were emitting light, using self-illumination,
appropriate shadows, and so on), then setting
the area to the same dimensions as the object
can help you achieve this effect.

3. On the Area Light Parameters rollout, change
both the Height and Width of the area to 100.

4. Render the scene.

Large area light generating diffuse shadows

With such a large area, like a skylight or picture
window, the shadows are very diffuse.

Tip: The cylinder is outside the spotlight’s cone,
so even when you increase the area of the light,
the cylinder doesn’t cast shadows.

Tip: When shadows are as diffuse as this,
improving sampling can help improve sample
quality.

Improving shadow quality by adjusting sampling

Sampling rate increased to range from 1 to 16.

For the purposes of this tutorial, leave global
sampling set to the default values (1/4 to 4).
The renderings go faster.
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Adjust local sampling for the area light:

In the Samples group on the Area Light Parameters
rollout, you can adjust shadow quality locally for
the area light. This is another way to speed up
render time for draft renderings.

1. Set Height and Width back to 20.

2. In the Samples group, set both U and V to 1.

U and V are the dimensions local to the 2D area
of the light. Their values should be equal except
in special circumstances.

3. Click Render.

Local UV sampling reduced to 1 x 1

As you might expect, the shadows are pretty
sketchy.

4. Increase U and V to 2.

5. Click Render.

Local UV sampling increased to 2 x 2

Surprisingly, increasing the local sampling
rate to 2 x 2 results in shadows that are nearly
as good as those with the default shadow
sampling rate of 5 x 5 (as shown above). The
more focused the shadows, the less sampling
is required to get a good result. More diffuse
shadows benefit from higher sampling rates.

Tip: If shadows from an area light appear
grainy, and only a few area lights are in use, try
increasing the lights’ local sampling rate before
you increase the rate for the scene as a whole.
Often, increasing the sampling rate for area
shadows only can take less time to render than
increasing the global rate.

6. Set both U and V back to their default value of
5.

Change the 2D light area from a rectangle to a disc:

The alternative area for a 2D mental ray Area Spot
light, is to emit from a disc, like a porthole.

1. On the Area Light Parameters rollout, use the
Type drop-down list to change the area from
Rectangle to Disc.

The Height and Width values are disabled, and
the Radius value becomes enabled.

2. Change the Radius value to 75.

3. Render the Scene.
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With a large disc, shadows also appear very
diffuse.

Save your work:

• Save the scene as my_area_spotlight.max.

Open a scene for 3D area lighting:

The mental ray Area Spot light emits light from
a two-dimensional area. The other option,
a mental ray Area Omni light, emits from a
three-dimensional surface.

• Open the file area_light_omni.max from
the \tutorials\mental_ray directory in your
3ds Max directory. (Don’t confuse this with
area_light_spot.max, which you just worked
with.)

This scene is similar, but the key light is a
standard omni light, located closer to the
geometry.

Render the scene with the scanline renderer:

• Click Quick Render (Production) to render the
scene.

Scanline rendering with ray-traced shadows and an
omni light

Like the previous scene, this one initially
renders with the default scanline renderer and
ray-traced shadows. The result is similar, but
the omni light also causes the cylinder to cast
a shadow.

Convert the Omni light to a mental ray Area Omni
light:

1. Select the omni light that is located inside the
box. (In the top viewport, it is located above
Plane01 where the cylinder rests.)

2. Go to the Utility panel. On the Utilities rollout,
click to turn on MAXScript.

The MAXScript rollout is displayed.

3. Near the bottom of the MAXScript, click the
drop-down list labeled Utilities, and choose
“Convert To mr Area Lights.”

The “Convert To mr Area Lights” rollout is
displayed.

Note: Even if “Convert To mr Area Lights” is
visible in the Utilities list (by default, it is the
only choice), you still have to choose it by hand
to see the conversion utility’s rollout.

4. On the “Convert To mr Area Lights” rollout,
click Convert Selected Lights.

An alert asks you Delete Old Lights?



844 Chapter 10: Rendering

5. Click No.

Note: Remember that you can also create mental
ray area lights from the create panel. For the
purposes of this tutorial, converting the light
is an easy way to make sure the light is in the
correct location.

Render the scene again:

1. Open the Render Scene dialog. On the
Common panel > Assign Renderer rollout,
click Choose Renderer (the button labeled “...”)
for the Production renderer. On the Choose
Renderer dialog, choose “mental ray Renderer”
from the list, and then click OK.

The mental ray renderer is now active.

2. Click Render.

Shadows from area omni light with default radius of 20.0

The area shadows are very diffuse, and the
cylinder casts shadows in two directions.

Adjust the radius of the light-emitting sphere:

1. Click Select By Name. Choose mr Area Omni01
from the list, and then click Select.

2. Go to the Modify panel. Open the Area Light
Parameters rollout, and change the radius of
the light to 5.

3. Click Quick Render (Production).

Shadows from area omni light with radius of 5.0

With a smaller area, shadows are more
concentrated, though the cylinder’s shadow has
diffuse edges.

Change the light-emitting area from a sphere to a
cylinder:

The alternative geometries for an area omni light
are Sphere and Cylinder. The Cylinder option can
model light sources such as fluorescent tubes.

1. On the Area Light Parameters rollout, use the
Type drop-down list to change the type to
Cylinder.

2. Drag the spinners to set the Radius to 3 and the
Height to 32.

While you drag the spinners, the shape of
the area light is displayed as a wireframe in
viewports. The display goes away when you
release the spinner. Unfortunately, the shape is
not displayed when you just type in the Radius
and Height values.



Using mental ray Area Lights 845

Wireframe of the area light’s shape is displayed in
viewports while you drag a dimension spinner.

3. On the Area Light Parameters rollout, turn on
Show Icon In Renderer.

4. Click Quick Render (Production).

Shadows from cylindrical area light

The shadows are diffuse, and correspond to the
shape of the cylinder.

Change the cylinder’s orientation:

The orientation of a spherical area light doesn’t
make a difference in rendering, but the orientation
of a cylinder does.

1. Right-click the Left viewport to activate it.

2. Turn on Select And Rotate.

3. In the Left viewport, rotate the area omni light
–90 degrees in the Z axis.

Using the Left viewport to rotate the cylindrical area
light

4. Click Quick Render (Production).

Note: The renderer is locked to render the
Camera01 viewport.

Cylindrical area light rotated 90 degrees

The difference is fairly dramatic. The shadows
have changed their orientation to match that
of the light.

Save your work:

• Save the scene as my_area_omni_light.max.
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Summary

Area lights provide a way to create realistic
soft-edged shadows when using the mental ray
renderer.

Using Mental Ray Shaders
and Materials
With the mental ray renderer, you can use a variety
of shaders and materials. A shader in mental
ray rendering is comparable to a map in basic
3ds Max materials, but shaders are more general
purpose, and have other uses as well. The shaders
and materials provided for use with the mental
ray renderer don’t work with the default scanline
renderer: if you attempt to render them with the
scanline renderer, usually they appear totally
black.

Most of the shaders provided with 3ds Max come
from libraries written by the creators of mental
ray, mental images, or by a company named lume.
A variety of shaders are available, depending
on the type of component to which you are
assigning a shader. Because of the great number of
mental-ray-specific shaders, and the great number
of settings they have, this tutorial can only scratch
the surface of this feature set. Consider it an
introduction to some of the possibilities.

Before you do these lessons, you should already be
familiar with the material covered by the previous
tutorial, Using the mental ray Renderer (page
2–805).

Skill Level: Intermediate

Time to complete: 2 hours.

Features Covered in This Tutorial

• Using a mental ray shader in place of a 3ds Max
map.

• Using the mental ray Connection rollout to
enhance a material.

• Using some camera shaders.

• Using some special-purpose shaders and
materials, including contour shading and the
Glass material.

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\mental_ray folder. Before doing the
tutorials, copy the \tutorials directory from the CD
to your \3dsmax8 local installation.

Using a mental ray Shader as a
Map

When mental ray extensions are enabled (this is a
preference in the Preferences dialog), then when
you click the Material Editor’s Type button for a
material or map, the Material/Map Browser’s list
shows the materials or maps that are intended for
use only with the mental ray renderer. If the mental
ray renderer is active, the mental ray materials or
maps are distinguished by a yellow icon instead
of a green one. If the default scanline renderer is
active, the mental ray materials or maps are not
visible unless you turn on Show > Incompatible,
in which case they are displayed in gray.



Using a mental ray Shader as a Map 847

mental ray shaders appear in the browser list with yellow
icons.

This lesson shows how to use a mental ray shader
the way you would a map.

Set up the scene:

• Load the file mirrors.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera01 view.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Click Quick Render.

The scene is simply the mirrored balls enclosed
by a mirrored box, which you used in the
tutorial Setting Trace Depth (and Other
Reflection Controls) (page 2–810). The trace
depth for reflections is set to 2.

Reflective balls in a reflective box

Maximum Trace Depth > Reflections=2

Replace the Raytrace map with a Reflect shader:

1. Open the Material Editor.

2. If it is not already active, highlight the Mirrors
material in the first sample slot.

3. Open the Maps rollout. Click the button for the
Reflection map (it should contain the text “Map
#4 ( Raytrace ).”

The Raytrace map’s parameters are displayed.

4. Click the Type button for the Raytrace map (it
contains the text “Raytrace”).

The Material/Map Browser is displayed.

5. From the list in the Browser, click to highlight
the shader named Reflect (base), then click OK.

The Replace Map dialog is displayed. Choose
Discard Old Map, and then click OK.

The Reflection component for the Mirrors
material (applied to the box object) now uses
the mental ray Reflect shader. This shader is
found in the base library from mental images.

6. Click Quick Render again.

The Mirrors material reflects the balls, but the
reflections appear different.
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Reflections that use the mental images reflect shader

The mental ray Reflect shader takes into
account the geometry to which its applied, so
the reflections on the walls of the box appear
flatter than they did with the 3ds Max Raytrace
map.

Increase the number of reflections:

1. Click Render Scene. On the Render
Scene dialog, go to the Renderer panel. Open
the Rendering Algorithms rollout, and in the
Maximum Trace Depth group, change the value
of Reflections to 10.

2. Click Render.

Reflect shader with the number of reflections increased
to 10

As with the 3ds Max Raytrace map, increasing
the number of reflections increases the overall
brightness of the scene. The only significant
difference when you use the Reflect shader is
that the shape of reflections is influenced by
geometry, an effect that is visible on the walls
of the box, and also in the box’s reflections as
reflected by the spheres.

Save your work.

• Save the scene as mi_reflect_shader.max.

When a mental ray shader appears in the Browser
list, you can use it for the component you are
assigning, as we used the Reflect shader for
the Reflection component in the preceding
steps. Some shaders are more appropriate than
others. Assigning a shader that does not generate
reflections to the Reflection component is not very
useful, though 3ds Max might allow you to do so.

Finding More Information

When in doubt, or if you need information about
a specific mental images library shader, you can
look at the mental images documentation for it..

Tip: When you follow a link to the documentation
for mental images library shaders, scroll up a bit
in your browser. The links tend to go directly to
the shader’s declaration code, and often there are
some introductory paragraphs directly above the
code.

You can find links to all the descriptions of the
mental images library shaders provided with
3ds Max in the help topic mental images Shader
Libraries. The help topic Shaders in the LumeTools
Collection has links to the descriptions of the lume
library shaders. Finally, the topic Custom Shaders
for 3ds Max has links to a set of shaders that are
provided specifically for use with this product.

3dsmax.chm::/mental_images_shader_libraries.html
3dsmax.chm::/shaders_in_the_lumetools_collection.html
3dsmax.chm::/custom_shaders_for_3ds_max.html
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Summary

You can assign mental ray shaders to material
components just as you do 3ds Max maps.

Camera Shaders

Camera shaders are an example of mental
ray shaders that do somewhat more than the
traditional notion of a shader coloring an object
surface. When you apply a shader to a camera,
it affects everything within the camera’s field of
view. The 3ds Max interface supports three kinds
of camera shaders:

• Lens shaders

• Output shaders

• Volume shaders

You assign camera shaders using the Render Scene
dialog. This tutorial demonstrates how to add a
volume shader, then shows the use of a few lens
shaders.

Note: Although there is a button for Output
shaders, no camera output shaders are provided
with 3ds Max. This option is provided for users
who have access to camera output shaders via
other shader libraries or custom shader code.

Adding a WrapAround Shader

The WrapAround shader generates a panorama.
It is a lume shader. That is, it is provided with
the LumeTools library, one of the shader libraries
that accompany 3ds Max 8. (The other three are
standard libraries from mental images.)

Set up the scene:

• Load the file throne_room.max.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Render the scene:

• Click Quick Render (Production).

Throne room model

The scene is of a throne room that is fully
enclosed.

Add the camera shader:

1. Click Render Scene to open the Render
Scene dialog. Go to the Renderer panel.

2. Scroll to the Camera Effects rollout. In the
Camera Shaders group, click the Lens button.

The Material/Map Browser is displayed.

3. Choose “WrapAround (lume)” from the
Browser list, and then click OK.

Note: The WrapAround shader has no
parameters, so you don’t need to use the
Material Editor to adjust it.

4. Turn on the Lens toggle.

Render the scene:

• Click Render.

Now when the scene renders, it renders
a 360-degree panorama of the camera’s
surroundings.
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Wraparound rendering of the throne room

Tip: You can use the Panorama Exporter
utility’s Viewer component to view renderings
generated by the WrapAround shader. If you
do use the Viewer, usually you will want to
generate a rendering with higher resolution
than we used in this exercise.

Save your work:

• Save the scene as throneroom_360.max.

Applying a Volume Shader

Volume shaders shade volumes rather than
surfaces; that is, they fill a space with some effect.
In this exercise, you assign the Mist shader. Like
the Wraparound shader, it is a lume shader from
the LumeTools library. The Mist shader has the
effect of mist or fog.

Set up the scene:

• Load the file gargoyle.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Note: Most of the files necessary to do the
tutorials can be found on the Tutorial Files CD
that ships with 3ds Max 8. Before doing the
tutorials, copy the \tutorials directory from the
CD to your \3dsmax8 local installation. Some
additional and updated files are zipped with the

updated tutorial text. These are noted where
they occur.

Render the scene:

• Click Quick Render.

Rendering of the gargoyle

Warning: This scene uses a single skylight. The

skylight and IES sky light require Final Gather to

be enabled (on the Indirect Illumination panel

and rollout) when you render with the mental ray

renderer. If you turn off final gathering, rendering

will show only a profile of the model.

When final gathering is disabled, objects lit by a sky light
render as black.

mr_reference.chm::/lume/Mist.html
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Add a camera volume shader:

1. Click Render Scene to open the Render
Scene dialog.

2. Go to the Renderer panel, and open the Camera
Effects rollout.

3. On the Camera Effects rollout, find the Camera
Shaders group, then click the button for Volume
shading.

The Material/Map Browser is displayed. By
default, half a dozen volume shaders are
available.

4. Choose “Mist (lume)” from the Browser list,
and then click OK.

5. Click Render.

Mist used as a camera volume shader, with default
settings

The scene is indeed misted, but it looks as if
the gargoyle is in front of the mist, not in the
middle of it.

Adjust the Mist settings:

To adjust the Mist shader, you have to use the
Material Editor.

1. Open the Material Editor.

2. Drag the Volume shader button to an unused
sample slot in the Material Editor.

An Instance (Copy) Map dialog is displayed.
Be sure to choose Instance, and then click OK.

If you don’t choose Instance, changes you make
to the shader settings in the Material Editor
won’t have any effect on the Render Scene
dialog.

Tip: If you forgot to choose Instance, change the
shader settings as you choose, and then drag
the shader’s sample slot or its Type button back
to the button in the Render Scene dialog, to
update the Render Scene dialog’s copy of the
shader.

Now the Material Editor displays the Mist
shader controls.

3. Change Transparency to 0.0.

4. Click the Solid Color color swatch to display the
Color Selector. In the Color Selector, change
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Value (in the Hue/Saturation/Value group of
sliders and spinners) to 0.7.

5. Close the Color Selector.

6. Click Render

Mist with adjusted settings

Now the mist looks a bit more convincing.

Save your work:

• Save the scene as gargoyle_in_the_mist.max.

Adding a Night Shader

A Night shader adjusts the brightness of dimly lit
scenes. Like Mist and WrapAraound, it is a lume
shader.

Set up the scene:

• Load the file streetlight.max.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Render the scene:

• Click Quick Render (Production).

Nighttime scene

The scene is of an ice cream parlor at night. A
streetlight in front of it illuminates a dog.

Add a Night camera shader:

1. Open the Render Scene dialog. Go to
the Renderer panel, and open or scroll to the
Camera Effects rollout.

2. In the Camera Shaders group, click the button
for the Lens shader.

The Material/Map Browser is displayed.

3. Choose “Night (lume)” from the Browser list,
and then click OK.

This assigns the Night shader to the camera’s
output.

4. Make sure the Lens toggle is turned on.

5. Click Render.
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Scene rendered with the night shader

The rendered scene is now lighter. The Night
shader simulates the way a human eye perceives
colors in dim lighting conditions. The result
does not necessarily look like what a camera
would photograph.

Adjust the Night shader settings:

To adjust the Night shader, you have to use the
Material Editor.

1. Open the Material Editor.

2. Drag the Lens shader button to an unused
sample slot on the Material Editor. (You might
have to scroll the sample slots to find an unused
one.)

An Instance (Copy) Map dialog is displayed.
Be sure to choose Instance, and then click OK.

If you don’t choose Instance, changes you make
to the shader settings in the Material Editor
won’t have any effect on the Render Scene
dialog.

Tip: If you forgot to choose Instance, change the
shader settings as you choose, and then drag
the shader’s sample slot or its Type button back
to the button in the Render Scene dialog, to
update the Render Scene dialog’s copy of the
shader.

Now the Material Editor displays the Night
shader controls.

The Night shader has two parameters:
Multiplier and Cutoff. (The second rollout lets
you assign shaders to these parameters.)

3. Change the Multiplier value to 2.0.

4. Click Render.

Night shader multiplier set to 2.0

The resulting scene is brighter still.

Day for night is a common film technique.
With the Night shader, you can render night
for day, although the resulting effect is rather
surreal. The Night shader is most effective
when the Multiplier is set between zero and 1.0.

5. Change the Multiplier value to 0.4.

6. Click Render.
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Night shader multiplier set to 0.4

The result is how the scene might appear if
there were diffuse light from a cloudy sky.

Save your work:

• Save the scene as nighttime.max.

Using a Distortion Shader

Distortion is also a lume shader. it applies a
physically accurate camera lens distortion to the
rendered scene.

Set up the scene:

• Load the file shop_daylight.max.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Render the scene:

• Click Quick Render (Production).

Daylight scene

Here is the ice cream parlor again, this time in
daylight.

Assign a Distortion shader and choose the Barrel
distortion type:

1. Open the Render Scene dialog. Go to
the Renderer panel, and open or scroll to the
Camera Effects rollout.

2. In the Camera Shaders group, click the button
for the Lens shader.

The Material/Map Browser is displayed.

3. Choose “Distortion (lume)” from the Browser
list, and then click OK.

This assigns the Night shader to the camera’s
output.

4. Make sure the Lens toggle is turned on.

Before you render the Distortion shader, adjust
its settings.

Choose the Barrel distortion type:

1. Open the Material Editor.

2. Drag the Lens shader button to an unused
sample slot on the Material Editor. (You might
have to scroll the sample slots to find an unused
one.)
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An Instance (Copy) Map dialog is displayed.
Be sure to choose Instance, and then click OK.

Now the Material Editor displays the Distortion
shader controls.

This shader provides two kinds of distortion:
Barrel and Pincushion. There is also an
Amount setting, which controls the strength of
the effect

(The second rollout lets you assign shaders to
the main parameters.)

You will inspect Barrel distortion first, as
this is the kind more often encountered in
photographs.

3. Turn off Pin Cushion and turn on Barrel. Leave
Amount set to its default value of 10.0.

4. Click Render.

Barrel distortion with an Amount of 10.0

Barrel distortion is the kind generated by a
wide-angle lens. In this case, the lens appears
to be very wide angle indeed. Lenses this wide
are sometimes called “fish-eye” lenses.

Reduce the distortion amount:

1. On the Distortion (lume) Parameters rollout,
change the Amount to 2.0.

2. Click Render.

Barrel distortion with an Amount of 2.0

Now the distortion effect is subtler, more like
what you might encounter in a photograph.

Change the distortion type to Pincushion:

With Pincushion distortion, the image is pinched
inward, rather than stretched outward.

1. On the Distortion (lume) Parameters rollout,
turn off Barrel and turn on Pincushion.

2. Change the Amount back to the default value
of 10.0.

3. Click Render.

Pincushion distortion with an Amount of 10.0
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At the default Amount of 10.0, the Pincushion
effect appears even more extravagant than the
Barrel effect.

Reduce the distortion amount:

1. On the Distortion (lume) Parameters rollout,
change the Amount to 3.0.

2. Click Render.

Pincushion distortion with an Amount of 3.0

The effect is still pronounced, but less
psychedelic than before.

Summary

Assigning a camera shader modifies what the
camera object perceives, and alters the entire
visible scene. Controls for camera shaders are
on the Render Scene dialog > Renderer panel >
Camera Effects rollout. A camera volume shader
applies a volume effect to the camera’s field of
view. One example is the Mist shader, which
shrouds the scene in mist. A camera lens shader
alters the shape or quality of the lens. Examples
are the WrapAround shader, which generates a
360-degree panorama; the Night shader, which
raises the lighting level of dimly lit scenes; and the
Distortion shader, which simulates the distortion
of a camera lens.

If a camera shader has settings that you want to
adjust, use an unused sample slot in the Material
Editor to adjust an instance of the shader.

Using the mental ray Connection
Rollout

From the point of view of the mental ray renderer,
a material is simply a collection of shaders.
Most important of these is the Surface shader,
which corresponds to the Diffuse component of
a standard 3ds Max material. When you use a
standard material with the mental ray renderer,
it is translated into a mental ray material that has
(in most cases) the same properties it would have
when rendered with the default scanline renderer.

In addition, the mental ray Connection rollout
appears for materials when mental ray extensions
are enabled by using the mental ray panel of
the Preferences dialog. This rollout lets you add
mental ray shading to a standard material.

The components are as follows:

• Surface
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The Surface shader corresponds to a standard
material’s Diffuse component.

• Shadow

A Shadow shader can change the appearance of
shadows.

• Photon

A Photon shader, if present, controls how the
material’s surface behaves when calculating
indirect illumination (caustics and global
illumination).

• Photon Volume

A Photon Volume shader, if present, controls
how the volume of objects with this material
behaves when calculating indirect illumination
(caustics and global illumination).

• Displacement

A Displacement shader displaces the rendered
mesh, similar to the way the Displace modifier
displaces 3ds Max geometry.

• Volume

A Volume shader shades a volume rather than a
surface. That is, it fills the space enclosed by the
object with some effect.

• Environment

An Environment shader provides reflections or
refractions that are local to material, overriding
the scene’s actual environment.

• Contour

A Contour shader adds contours to the
material, rather like the Ink component of the
Ink ’n Paint material.

• Light Map

A Light Map shader saves the rendered material
as a map, rather like the scanline renderer’s
Render To Texture feature.

Note: No Light Map shaders are provided with
3ds Max.

All of these shader types work only with the mental
ray renderer, and have no effect when you render
using the default scanline renderer.

Each kind of component has a different set of
shaders that can be assigned to it. You assign a
shader by clicking the component’s button and
then choosing the shader from the Material/Map
Browser, just as you assign a map when using
standard material controls.

Four of the components, Surface, Shadow,
Photon, and Displacement, are typically provided
from the material’s standard controls. Because of
this, they are accompanied by a lock button. You
can assign a shader to these components only if
you first turn off the lock button.

Warning: When you assign a shader to the Surface

component, you can create a material whose appearance

in renderings is completely different from its appearance

in its sample slot and in shaded viewports.

In this lesson, you use the mental ray Connection
rollout to assign a Contour shader that generates
a “cartoon” image of the gargoyle, and then you
apply a special Environment shader effect.

The mental ray Connection Rollout and
the mental ray Material

In addition to the mental ray Connection rollout,
3ds Max includes a material named the mental
ray material. This material lets you create a
mental ray material “from scratch.” It has slots
for all 10 shaders that can make up a material
from the mental ray renderer’s point of view.
(The tenth component is a Bump shader, which
the Connection rollout doesn’t provide.) Until
you are familiar with mental ray rendering, we
recommend that you use the Connection rollout
rather than the mental ray material. When you use
the Connection rollout, typically the material’s
surface, shadow, and photon behavior are all
calculated by 3ds Max, whereas with the mental
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ray material you must explicitly specify these
behaviors along with the more special-purpose
shader components. The lesson that follows,
Special mental ray Materials (page 2–862), shows
one use of the mental ray material.

Using a Contour Shader

Note: This lesson shows how to use mental ray
shaders to generate contours. The mental ray
renderer also supports the Ink ’n Paint material.

Set up the scene:

• Load the file gargoyle.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Note: Most of the files necessary to do the
tutorials can be found on the Tutorial Files CD
that ships with 3ds Max 8. Before doing the
tutorials, copy the \tutorials directory from the
CD to your \3dsmax8 local installation. Some
additional and updated files are zipped with the
updated tutorial text. These are noted where
they occur.

Assign the contour shader:

1. Open the Material Editor, and then open
the mental ray Connection rollout.

2. On the mental ray Connection rollout, in the
Advanced Shaders group, click the button for a
Contour shader.

The Material/Map Browser is displayed.

3. Choose “Simple (contour)” from the Browser
list, and then click OK.

The Simple (contour) Parameters rollout is
displayed on the Material Editor.

Enable contours:

Although you have assigned a contour shader, you
also need to enable contours.

1. Open the Render Scene dialog. Go to the
Renderer panel, and open the Camera Effects
rollout. In the Contours group, click to turn
on Enable.

Note: You can’t use contour shading with
distributed bucket rendering.

2. Click Render.

First the gargoyle renders, and then the
contours appear.

Gargoyle with contours

Width=1.0

At the default width of 1.0, the contours are too
coarse. You can adjust their width.

Adjust the contour shader:

1. On the Material Editor, on the Simple (contour)
Parameters rollout, change the value of Width
to 0.25.

2. On the Render Scene dialog, click Render.
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Contour width reduced to 0.25

This is a more pleasing effect, one that you
might want to use in renderings.

The mental ray renderer also provides a way to
render only the contours. We will do so in the
procedure that follows.

Render only the contours:

1. On the Render Scene dialog > Renderer panel >
Camera Effects rollout > Contour group, click
the button for Contour Output.

The Material/Map Browser is displayed.

2. Choose “Contour Only (contour)” from the
Browser list, and then click OK.

The three components in the Contours group,
Contour Contrast, Contour Store, and Contour
Output, assign shaders as well, which are
applied at the camera level.

• The Contour Contrast component has a
single available shader, Contour Contrast
Function Levels. You can adjust this shader’s
settings to fine-tune the way contours are
generated.

• The Contour Store component also has
a single shader available, Contour Store
Function. This shader has no controls. Just
leave this shader assigned as it is by default.

• The Contour Output component has
three options: Contour Composite, which
overlays contours on the original rendering,
as you’ve just seen; Contour Only, which
renders only the contours; and Contour
PS (PostScript), which saves contours to a
PostScript file.

3. If you need to, arrange the open dialogs so you
can see the Material Editor and the Render
Scene dialog at the same time.

4. Drag the Contour Output button (labeled
something like “Map 4 ( Contour Only
(contour) )”) from the Render Scene dialog to
an unused sample slot in the Material Editor.

As in the previous lesson, be sure to choose
Instance on the Instance (Copy) Map dialog,
and then click OK.

The Contour Only (contour) Parameters
rollout is displayed on the Material Editor.

5. Click the Background Only color swatch, and
then use the Color Selector to change the
background color to white. Click Close to close
the Color Selector.

6. On the Render Scene dialog, click Render.

Again, first the shaded gargoyle renders,
and then the contours alone are saved as the
rendering.

Rendering of contours only

mr_reference.chm::/shaders/node24.html##contourcontrastfunctionlevels
mr_reference.chm::/shaders/node23.html##contourstorefunction
mr_reference.chm::/shaders/node26.html##contourcomposite
mr_reference.chm::/shaders/node26.html##contouronly
mr_reference.chm::/shaders/node26.html##contourps
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Save your work:

• Save the scene as gargoyle_outline.max.

Using an Environment Shader

An environment shader is a special effect
of the mental ray renderer. Reflective and
refractive materials can reflect or refract the scene
environment, if one is present. When you assign
an environment shader, you substitute a local map
for the global scene environment. The material
reflects or refracts this map instead, letting you
create “fake” reflections or refractions.

Set up the scene:

• Load the file gargoyle_environment.max.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view. A bitmap provides the
background for the rendered scene.

Render the scene:

• Click Quick Render (Production).

Gargoyle with a background environment

This is the gargoyle with an urban background
behind it.

Incidentally, this model uses the default
3ds Max lighting instead of a Skylight.

Make the gargoyle refractive:

1. Open the Material Editor. Click the
first sample slot, with the Gargoyle material,
to make it active.

2. Open the Gargoyle material’s Maps rollout.
Click the button for the Refraction component.

The Material/Map Browser is displayed.

3. Choose Raytrace from the Browser list, and
then click OK.

The Raytrace map’s parameters are displayed.

4. Click Go To Parent to return to the
top-level Gargoyle material controls.

5. On the Maps rollout, reduce the Refraction
Amount to 80.

For reflection and refraction, leaving the
Amount at 100 per cent can make an object
nearly invisible.

6. Click Quick Render.

Gargoyle refracting the background

The gargoyle now appears to be made of glass,
and refracts the scene behind it, including the
bitmapped environment.
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Add an environment shader:

1. On the Material Editor, open the Gargoyle
material’s mental ray Connection rollout. Click
the button for the Environment shader.

The Material/Map Browser is displayed.

2. Choose “Environment (3dsmax)” from the
Browser list, and then click OK.

Note: Only one environment shader ships with
3ds Max. Of the other two shaders in the list,
Material To Shader is for using a standard
3ds Max material as a shader, and Shader List is
for combining multiple shaders.

The Environment shader’s parameters are
displayed.

3. On the Parameters rollout, click the Map
button.

The Material/Map Browser is displayed again.

4. Choose Bitmap from the Browser list, and then
click OK.

A Select Bitmap Image File dialog is displayed.

5. Choose sunset.jpg, and then click Open.

The Environment shader now uses sunset.jpg
as its bitmap.

6. Click Quick Render.

Gargoyle using an environment map

Now the gargoyle refracts colors from
sunset.jpg, rather than the bitmap assigned
on the Environment And Effects dialog. Only
those portions that refracted the environment
map are affected: portions of the gargoyle that
refracted the base it’s sitting on render the
same.

Also, because of the distortions caused by
refraction, the environment map doesn’t
appear in full detail.

Increase the refraction amount:

As an environment shader is an artificial effect
anyway, sometimes you might want to emphasize
it. You can do so by increasing the Refraction
Amount. The environment map differs from the
actual environment, so there is less risk of the
object “blending in” as it can when it reflects or
refracts the scene background.

1. To return to the top level of the Gargoyle
material, click Go To Parent twice. (The first
click goes from the Bitmap controls to the
Environment shader controls.)

2. Scroll to the Maps rollout. Increase the
Refraction Amount to 100.

3. Click Quick Render (Production).

Environment map amount increased to 100
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The effect of the environment map is more
pronounced.

Save your work:

• Save the scene as my_environment.max.

Summary

The mental ray Connection rollout lets you add
mental ray shading to 3ds Max materials. One such
effect is contour shading. Another is environment
shading.

Special mental ray Materials

3ds Max provides a few materials meant for use
with the mental ray renderer. These materials
don’t work with the default scanline renderer,
which renders them as black. The materials are
the mental ray material, described in the previous
lesson, Using the mental ray Connection Rollout
(page 2–856); the DGS material; and the Glass
material.

This lesson shows one way you can use the Glass
material, and then demonstrates using the mental
ray material in conjunction with the DGS Material
shader.

Using the Glass Material

Set up the scene:

• Load the file caustics_two_lights.max from
the \tutorials\mental_ray directory in your
3ds Max directory.

This is the same scene you used in the lesson
Creating Refractive Caustics (page 2–831),
except that now both lights are generating
caustic patterns.

The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Note: Most of the files necessary to do the
tutorials can be found on the Tutorial Files CD
that ships with 3ds Max 8. Before doing the
tutorials, copy the \tutorials directory from the
CD to your \3dsmax8 local installation. Some
additional and updated files are zipped with the
updated tutorial text. These are noted where
they occur.

Render the scene:

• Click Quick Render (Production).

Refractive caustics with two spot light sources

Change the glass to use a Glass material

1. Open the Material Editor.

2. Click an unused sample slot to make it active.

You might have to scroll down, or right-click
a sample slot and choose a larger number of
Sample Windows to find an unused sample slot.
Don’t click one that has triangular brackets in
the corners: this is a material that is already
used in the scene.

3. Click the material Type button.

The Material/Map Browser is displayed.

4. Choose Glass (physics_phen) from the Browser
list, and then click OK.
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The Glass (physics_phen) Parameters is
displayed on the Material Editor. Notice that
Index Of Refraction is set by default to 1.5,
which for glass is the correct value.

The Glass material provides a physically
accurate model of glass. It is a phenomenon,
which in mental ray terminology means it is a
scripted tree of shaders.

5. Use Select By Name to select the Glass
object.

6. On the Material Editor, click Assign
Material To Selection.

7. Click Quick Render (Production) once again.

Refractive caustics with the Glass material

The caustics are now brighter. In particular,
they show the hotspot at the base of the stem
that was also apparent in the real-world photo
of caustics.

Actual photograph of real-world caustics

Comparing the rendering to the photo, the
caustics you generated with the Glass material
might be a little too bright. You can adjust this
by decreasing the value of the Global Energy
Multiplier for lights (in the Light Properties
group on the Caustics And Global Illumination
rollout). Try this if you want to.

Using the DGS Material Shader

The DGS material provides physically accurate
qualities, as the Architectural material does.
(The DGS stands for Diffuse, Glossy, Specular.)
However, the DGS material does not provide
a bump mapping component. An alternative
solution is to use the mental ray material in
combination with the DGS Material shader. The
DGS Material shader has the same controls as the
DGS material, while the mental ray material lets
you add other kinds of shaders, including bump
mapping, to the DGS Material shader surface.

Note: An additional disadvantage of the top-level
DGS material is that by itself, it does not support
caustics or global illumination.

Set up the scene:

• Load the file swim_pool_dgs.max.
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The scene has been set up to use the mental ray
renderer, and the Render Scene dialog is locked
to the Camera02 view.

Render the scene:

• Click Quick Render (Production).

This scene is the one created in the tutorial
”Creating Reflective Caustics.”

Reflective caustics using a raytrace-mapped material

Add a mental ray material:

1. Open the Material Editor, and click an
unused sample slot to make it active.

2. Click the material Type button.

(The Type button is to the right of the material
name field, and is labeled “Standard” by
default.)

The Material/Map Browser is displayed.

3. Choose “mental ray” from the Browser list, and
then click OK.

The sample slot turns black.

A mental ray material is really just a container
for shaders: it has no renderable properties
until you assign it a surface shader. You can add
additional shaders for additional effects, as the
procedures that follow will demonstrate.

Add a DGS material shader as the surface shader:

1. On the Material Shaders rollout, in the Basic
Shaders group, click the Surface shader button.

The Material/Map Browser is displayed.

2. Choose DGS Material (3dsmax) from the
Browser list, and then click OK.

The DGS Material (3dsmax) Parameters rollout
is displayed on the Material Editor.

Note: The Lights parameters on this rollout
don’t have a counterpart in the DGS material.
When the Lights toggle is turned on, the
material is illuminated only by those lights
specified in the list. When Lights is turned off,
all lights in the scene affect the material. As
the swimming pool scene has only a single
spotlight, you don’t need to use these controls
in this lesson.

Adjust the DGS material shader settings:

The default DGS settings aren’t quite appropriate
for water.

1. Click the Diffuse color swatch.

The Color Selector is displayed.
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2. Set the material’s diffuse color to be aqua, a
reflection of the walls of the room. Set Red to
0.3, Green to 0.4, and Blue to 0.45.

3. With the Color Selector still open, click
the Glossy Highlights color swatch. Set the
highlights to be white (set the HSV Value to
1.0).

4. Drag the Glossy Highlights color swatch to the
Specular color swatch.

The Copy Or Swap Colors dialog is displayed.
Click Copy.

Now both the highlight and specular colors are
white.

5. Close the Color Selector.

6. On the DGS Material (3dsmax) Parameters
rollout, change the value of Transparency to 0.9.

The effective range of Transparency is from 0.0
to 1.0. At 0.0 the material is fully opaque. At 1.0
it is fully transparent.

Warning: You can set the value of Transparency

to be greater than 1.0, but this has no effect. An

anomaly of the user interface for shaders in the

mental ray and lume libraries, is that spinner values

are not “clamped” to lie within their effective ranges,

as they are for controls in 3ds Max.

Add bump mapping to the material:

1. Click Go To Parent to return to the top
level of the mental ray material.

2. On the Material Shaders rollout, in the
Extended Shaders group, click the button for
the Bump shader.

The Material/Map Browser is displayed.

3. Choose Bump (3dsmax) from the Browser list,
and then click OK.

The Bump (3dsmax) Parameters rollout is
displayed on the Material Editor.

4. Click the Map button.

The Material/Map Browser is displayed.

5. Choose Noise from the Browser list, and then
click OK.

Now the Material Editor displays rollouts for
the Noise map.

6. On the Noise Parameters rollout, change the
Size value to 6. Leave the other settings at their
defaults.

Copy the DGS material shader to be a photon shader:

If you were to apply the material in its present state
to the Water object and try to render caustics, the
mental ray renderer would display a series of error
and warning messages telling you that it is unable
to store photons. This is because the material has
no photon shader. For the mental ray material, a
photon shader is required to tell the renderer how
to handle caustics.

The shader you use for the surface component is
usually a good starting place.

1. Click Go To Parent twice, to return to the
top-level mental ray material.

2. Drag the button for the Surface shader to the
button for the Photon shader. The Photon
shader button is in the Caustics And GI group.

A Copy (Instance) Map dialog is displayed.

3. Make sure that Copy is chosen, and then click
OK.

You need a copy of the shader, not an instance,
because you don’t want exactly the same
settings for the photon shader.

At this point, if you were to apply the material
and render caustics, they would appear very
faint. This is because the material is set to be
highly transparent. However, you don’t want
the caustic photons to simply go through the
water: you want them to pass through the water
and to bounce off of it.
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Caustics rendered with DGS material shaders

The photon shader still has high opacity.

4. In the Caustics And GI group, click the Photon
shader button.

The DGS Material (3dsmax) Parameters rollout
is displayed on the Material Editor.

5. Change the value of Transparency to 0.5.

Assign the material to the water object:

1. Click Select By Name.

The Select Objects dialog is displayed.

2. Choose the Water object in the list, and then
click Select.

3. On the Material Editor, click Assign
Material To Selection.

Adjust caustic settings, and render the scene:

1. Click Render Scene.

The Render Scene dialog is displayed.

2. Go to the Indirect Illumination panel. In the
Caustics group of the Caustics And Global
Illumination rollout, make sure Enable is
turned on. Change the number of Maximum
Number Of Photons Per Sample to 50, and turn
off the Maximum Sampling Radius toggle.

Tip: Reducing the value of Maximum Number
Of Photons Per Sample can help improve the
appearance of caustics. For many scenes, the
default of 100 can cause too much blending of
photons, especially when you are also using the
default photon radius of 1/100 the scene radius.

3. In the Light Properties group at the bottom
of the Caustics & Global Illumination rollout,
increase the number of Average Caustic
Photons Per Light to 100000 (one hundred
thousand).

4. Click Render.

Reducing the photon shader’s opacity scatters photons
both above and below the water surface.

Caustic lighting appears on both the walls of
the room, and at the bottom of the pool.

Save your work:

• Save the scene as physical_caustics.max.

Summary

The mental ray materials provide additional ways
to assign mental ray shaders. The Glass material
is a physically accurate model of glass. The DGS
Material shader provides physical settings for a
material. You can use it for both the Surface and
Photon components of a mental ray material. The
mental ray material also lets you add other shaders,
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such as a Bump shader, for additional qualities
and details.

Using the Dielectric Material
Shader

The purpose of the Dielectric Material shader is
to create transparent materials that are physically
accurate. Specifically, the Dielectric Material
shader can model accurately situations where
objects of different refractivity are adjacent to each
other. Refractivity is measured in the real world,
and specified in the Dielectric Material shader, by
an index of refraction (IOR).

The scene you use in this lesson shows a glass
containing water. There are three kinds of
transparent materials in the scene:

• Air

Air refracts very little, and unless the scene
involves very great distances has an effective
IOR of 1.0.

(Air is implicit, and isn’t modeled by any
3ds Max geometry.)

• Glass

Glass has an IOR of 1.5.

• Water

Water has an IOR of 1.333.

You apply the Dielectric Material shader to the
geometry that represents both glass and water. But
instead of considering just the two materials in and
of themselves, you take into account the interfaces
between transparent materials:

• Water and air

• Glass and air

• Water and glass

Set up the scene:

• Open the file water_glass_start.max from
the \tutorials\mental_ray directory in your
3ds Max directory.

The scene shows a water glass resting inside a
box (to provide background surfaces), and with
a chamfered cylinder standing in the glass. It
has been set up to use the mental ray renderer,
and the Render Scene dialog is locked to the
Camera01 view.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

Render the scene:

• Click Quick Render.

A material has been applied to the box and the
cylinder, but not to the glass or the water in it,
so these render as solid colors.

Scene without transparent materials

You are going to create transparent materials
and apply them to the water and the glass.
First, you will inspect the glass and water
objects, because these have been set up with the
Dielectric Material shader in mind.
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Inspect the glass and water components:

1. On the main toolbar, click Select By
Name.

A Select Objects dialog appears.

Three objects are named glass-air, water-air,
and water-glass. These are the transparent
objects in the scene.

2. Highlight glass-air, and then click Select.

The water glass is highlighted in the viewports.
These three objects are named for their
interface with other transparent objects: most
of the glass is in contact with air.

3. Click Select By Name again. Highlight
water-glass, and then click Select.

The water in the glass is highlighted.

4. Click Select By Name again. Highlight
water-air, and then click Select.

The surface of the water is highlighted. Because
water, glass, and air each have different IORs,
the scene uses three different objects. You will
create materials based on the interfaces between
different IORs.

Transparent objects in the scene

1. water-glass (selected)

2. glass-air

3. water-air

Create a material for the water glass:

1. Open the Material Editor.

2. Click an unused sample slot to make it active.
In the name field, change the material’s name
to glass-air.

Having the name of materials match the name
of objects makes the scene easy to manage.

3. Click the Material Type button. (This is the
button to the right of the name field. By default,
its label is “Standard.”)

The Material/Map Browser appears.

4. Choose “mental ray” from the list, and then
click OK.

The mental ray material is basically just a
holder for shaders. You must assign a shader
to the Surface component for the material to
be visible in renderings. Assigning shaders to
other components is optional.

5. Click the Surface shader button.

The Material/Map Browser appears again, this
time displaying maps and shaders instead of
materials.

6. Choose “Dielectric Material (3dsmax)” from
the list, and then click OK.

The shader’s Parameters rollout is displayed in
the Material Editor.

Note: Despite the name, this is a shader and
not a top-level material. The corresponding
material is named Glass (see “The Glass
Material,” below).

Tip: You can confirm that the material is
now transparent by turning on Background in
the Material Editor.

7. On the Parameters rollout, change the
Persistence Distance to 10.0. Leave the other
values left at their defaults (1.5 is the IOR of
glass).
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8. Click Go To Parent to return to the top
level of the mental ray material.

9. Drag the Surface button to the Photon button.

A Copy (Instance) Map dialog appears. Choose
Instance, and then click OK.

While the Surface shader controls how the
surface of objects with this material appear,
the Photon shader controls how they behave
“physically”: that is, when calculating caustics
and global illumination. For this scene, we
want Surface and Photon characteristics to be
identical.

Assign the new material:

1. On the main toolbar, click Select By
Name. In the Select Objects dialog, highlight
the glass-air object, and then click Select.

2. In the Material Editor, make sure the new
glass-air sample slot is still active, and then
click Assign Material To Selection.

Create a material for the water surface:

1. In the Material Editor, drag the glass-air sample
slot to another sample slot.

This creates a copy of the glass-air material.

2. In the Name field, change the name of the
material to water-air.

3. Click the Surface shader button to view the
Parameters rollout for the Dielectric Material
shader.

4. Change the Index Of Refraction value to 1.333
for water.

Note: Because the shader is instanced, this value
changes in the Photon component as well.

Assign the new material:

1. On the main toolbar, click Select By
Name. In the Select Objects dialog, highlight
the water-air object, and then click Select.

2. In the Material Editor, make sure the new
water-air sample slot is still active, and then
click Assign Material To Selection.

Create a material for the water that touches the glass:

1. In the Material Editor, drag the water-air
sample slot to another sample slot.

2. In the Name field, change the name of the
material to water-glass.

3. Click the Surface shader button to view the
Parameters rollout for the Dielectric Material
shader.

4. Change the Index Of Refraction (Out) value to
1.5, for glass. (The first Index Of Refraction
value should still be 1.333.)

5. Click the Outside Light Persistence color
swatch.

A Color Selector appears.

6. Change the Outside Light Persistence color
from black to white.

This helps ensure that light will be transmitted
through the water in the glass. It is a change
you need to make only when both transparent
objects are “physical” 3ds Max objects.
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Forgetting to change Outside Light Persistence to white
when two transparent objects are adjacent

Assign the new material:

1. On the main toolbar, click Select By
Name. In the Select Objects dialog, highlight
the water-glass object, and then click Select.

2. In the Material Editor, make sure the new
water-glass sample slot is still active, and then
click Assign Material To Selection.

Render the scene:

1. Click Render Scene to open the Render
Scene dialog.

2. Go to the Indirect Illumination panel. On the
Caustics And Global Illumination rollout, in
the Caustics group, turn on Enable to enable
caustics.

3. Click Render.

The water glass renders with physically correct
refraction and caustic light effects.

Rendering with transparent dielectric materials and
caustics

Save your work:

• Save your scene as clear_glass.max.

Note: A final version of this scene is in
water_glass_final.max

The Glass Material

The Glass material is a top-level container for
a Dielectric Material shader assigned to both
the Surface and Photon components. It has no
other controls. If you were to replace the mental
ray materials created in this lesson with Glass
materials that had the same settings, the rendering
of the water glass would appear identical.

Summary

These are the main points of this lesson:

• The Dielectric Material shader is a transparent
shader that has physically correct refraction.

It is especially useful when two transparent
materials are adjacent to each other: for
example, water and glass.

• Typically, you apply Dielectric Material to both
the Surface and Photon components of a mental
ray material. The shader can be instanced, as
usually the settings should be the same.
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The Glass material is a shortcut way to assign
Dielectric Material values to both the Surface
and Photon components.

• The Index Of Refraction value is the IOR of the
object to which you apply the material.

• The Index Of Refraction (Out) value is the IOR
of the transparent object that adjoins the object
to which you apply the material.

• If a transparent object adjoins two different
transparent materials, create different objects
for different adjoining materials (glass and air,
for example), and apply different Dielectric
Material shaders that have the correct
combination of IORs, in each case.

• If the two transparent objects are both 3ds Max
objects, remember to change Outside Light
Persistence to white.

Using lume Shaders for Other
Water Effects

The LumeTools collection is a small library of
mental ray shaders that is provided in addition
to the standard mental ray shaders supported by
3ds Max. These shaders can create a variety of
naturalistic effects. In the Material/Map Browser,
the name of these shaders is followed by “(lume).”
This lesson demonstrates using some of the lume
shaders to create water effects.

Using the Ocean Shader

The Ocean shader creates waves that you can
animate. It can be used as a bump shader, a
displacement shader, or both.

Set up the scene:

1. Open the file ocean_start.max from the
\tutorials\mental_ray directory in your
3ds Max directory.

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD that ships
with 3ds Max 8. Before doing the tutorials,
copy the \tutorials directory from the CD to
your \3dsmax8 local installation.

2. A warning might appear, pointing out that
the scene’s units are different from the default
3ds Max units. Choose Adopt The File’s Unit
Scale, and then click OK.

The scene is simply a curving surface, with a
shiny Architectural material applied to it.

Ocean surface with no bump mapping

Add an ocean shader:

1. Open the Material Editor.

2. Make sure the first sample slot is active. This
material is named ocean.

3. On the Special Effects rollout, click the Bump
button.

The Material/Map Browser appears.

4. Choose “Ocean (lume),” and then click OK.

3ds Max assigns an Ocean shader to the Bump
component.
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Note: You can also use the Ocean shader for
displacement mapping, although this takes
more processing time. If you assign Ocean to
the Displacement component, remember to
turn off the shader’s Bump toggle; otherwise,
it will have no effect.

5. Click Quick Render.

The surface shows bumps from the Ocean
shader.

Surface with the Ocean shader

Note: The plane in this scene is large:
approximately 2,000 units square. The default
values for the Ocean shader work well with
objects about this size. For smaller objects, you
might want to adjust the values of Largest and
Smallest to get waves and ripples that appear
the way you want.

Animate the ocean shader:

1. With the Parameters rollout for the
Ocean shader still visible, click Auto Key to
turn it on.

2. At frame 0, change the value of Wave Speed to
0.0.

Tip: A quick way to do this is to simply
right-click the spinner arrows.

3. Go to the last frame (frame 50).

4. At frame 50, change the value of Wave Speed
to 0.5.

Now, if you render the entire animation, the
ocean pattern changes from frame to frame.
If you don’t want to take the time to render
the animation, you can view a version of it by
choosing File > View Image File and opening
ocean_animated.avi.

Note: The Wave Speed setting is sensitive,
and even small values or changes can cause
extremely rapid wave movement.

Save your work:

• Save the file as ocean_waves.max.

Creating a Water Material

In addition to Ocean, there are some other
lume shaders that provide water effects. You can
combine them to obtain a water material, as this
section shows.

Set up the scene:

• Open the file water_material_start.max from
the \tutorials\mental_ray directory in your
3ds Max directory.

In this scene, a ball and a piece of wood are
floating in water, while a pipe emerges from
the water. The “water” in the scene is simply a
plane object.

Create a material for the plane:

1. Select the Plane01 object.

2. Open the Material Editor.
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3. Click an unused sample slot to make
it active, and then click Assign Material To
Selection.

4. Click the Material Type button to the right of
the material name field. (By default, this button
is labeled Standard.)

The Material/Map Browser appears.

5. Choose “mental ray” from the list, and then
click OK.

The rollouts for the mental ray material now
appear in the Material Editor.

Add a water surface shader:

When you use the mental ray material, the first
shader to assign is always the Surface shader;
otherwise, the material won’t render.

1. On the Material Shaders rollout, in the Basic
Shaders group, click the Surface button.

The Material/Map Browser appears.

2. Scroll down in the list until you see “Water
Surface (lume).” Click to highlight it, and then
click OK.

Water Surface is now the surface shader for the
plane.

Water surface shader assigned to plane

If you render, you see that the water now looks
gray, and that its surface is semitransparent.
However, not much else is going on, here.

Add a submerge shader:

1. Click Go To Parent to return to the top
level of the mental ray material.

2. On the Material Shaders rollout, in the
Extended Shaders group, click the Volume
button.

The Material/Map Browser appears. (Fewer
shaders are available for the Volume component
than there were for the surface.)

3. Choose “Submerge (lume)” from the list, and
then click OK.

Submerge shader added to the material

Not much has changed, except that the
Submerge shader’s color looks a little more
water-like, and tints the portions of objects that
are submerged. However, this water is very still.

Add an ocean shader to the bump component:

1. Click Go To Parent to return to the top
level of the mental ray material.

2. In the Extended Shaders group, click the Bump
button.

The Material/Map Browser appears.
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3. Choose “Ocean (lume)” from the list, and then
click OK.

4. Click Quick Render.

Surface perturbed with the ocean shader

That looks a lot more watery.

In all these steps, you have used only the default
shader settings, which work pretty well when
you combine the shaders with a single material.
One thing to try adjusting is the Ocean shader’s
Largest setting: you can get dramatically
different results by changing this value.

Save your work:

• Save the scene as flotsam.max.

You can find a version of the final scene in
water_material_final.max.

Summary

These are the main points of this lesson:

• A number of lume shaders are available to
simulate water effects.

• The Ocean shader models the surface of a body
of water; it is most efficient to use it for bump
mapping.

• You can animate the Ocean shader by animating
its Wave Speed setting.

• You can use the mental ray material to combine
different water effects. In the lesson, a water
material was obtained by using Water Surface
for the Surface component, Submerge as the
Volume component, and Ocean as a Bump map.

Using the SSS fast Skin
Shader

Traditionally it has been a challenge to create the
proper look for human skin using the default tools
in 3ds Max. While there are many ways to create
materials that look somewhat like skin, there has
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always been one critical element missing. Human
skin is not an opaque material, like metal or solid
plastic. It has depth: skin scatters the light that
hits it and allows sub-surface elements like bones
and veins to affect its color. At the same time,
skin allows light from behind to shine through,
revealing the variation in color and density of the
part of the body covered by the skin.

The distinctive lighting effects seen in human skin
are due to sub-surface scattering of light within
the skin. New in 3ds Max 8is a powerful new
mental ray shader that allows you to reproduce
and fine-tune these effects to take your digital art
to a whole new level.

Sub-Surface Scattering (SSS) in mental ray comes
in two methods: Fast and Physical. Fast uses
a non-physically correct method to simulate a
material that has soft, translucent feel, like human
skin or candle wax. The SSS physical material
simulates the effects of light being reflected from
varying depths within an object using a physically
correct rendering method. While the physical
method is technically accurate, it comes at the cost
of increased render time.

In this tutorial, you will learn how to use the
mental ray SSS Fast Skin Material and apply it to
a model.

Skill Level: Intermediate

Time to Complete: 1 hour

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\sss_fast_skin folder. Before starting any
tutorials, copy the \tutorials folder from the CD to
your \3dsmax8 local installation.

Creating Realistic Skin

In this lesson, you will use the mental ray SSS Fast
Skin material on a model of a simple human head.
You will then build up the material with maps and
parameter adjustments to make it more realistic

Set up the lesson:

• From your tutorials/sss_fast_skin directory,
open maki1_01.max.

The scene consists of a model of a human head,
with no material assigned to it.

Assign the mental ray renderer:

1. Open the Render Scene dialog.

2. On the Common panel, open the Assign
Renderer rollout.

3. Click the Choose Renderer (“...”) button for the
Production renderer option, and then choose
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the “mental ray Renderer” from the Choose
Renderer dialog.

Assign the material:

Now that mental ray has been selected as the
current renderer, you have access to the mental ray
materials. You will select the SSS Fast Skin material
and apply it to the Maki1 head object.

1. Continue working with the scene, or else open
maki1_02.max.

2. In the Front viewport, click to select the Maki1
object.

3. Open the Material Editor, and select the
first unused material slot.

4. Click Get Material to select a new material.
This displays the Material/Map Browser.

5. In the Material/Map Browser, double-click SSS
Fast Skin Material (mi).

6. Close the Material/Map Browser.

7. In the Material Editor, rename the material
Maki Face.
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8. In the Material Editor, click Assign Material
To Selection.

9. Right-click the Camera01 viewport to activate
it.

10. On the main toolbar, click Quick Render.

The rendered image already has a soft, skin-like
appearance.

Build the material:

Now that you have the base material assigned to the
head, it’s time to begin adding maps and adjusting
the various parameters. The SSS Fast Skin Material
is a complex material with parameters for each

aspect of human skin’s various layers, as well as
many more standard surface parameters.

1. On the Material Editor > Maki Face material >
SSS Fast Skin Material (mi) Parameters rollout,
set the number of samples to 128.

2. Click the Bump Shader map button. On the
Bump (3dsmax) Parameters rollout, set the
Multiplier value to 0.4.

3. Click the Map button on the Bump (3dsmax)
Parameters rollout. On the Material/Map
Browser, select the Bitmap map type, and then
click OK.
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4. On the Select Bitmap Image File dialog, select
the face_bump.png image from the file list,
then click Open.

5. Quick render the Camera01 view.

Now there is a bump texture for the eyebrows
and a very subtle bumpy noise on the surface
of the skin.
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Refining the Skin Material

This lesson explores more advanced settings for
the SSS Fast Skin shader.

Set up the lesson:

• Open the file maki1_04.max from your
tutorials/sss_fast_skin directory, or continue
from the previous lesson.

Set up subsurface scattering:

1. On the Material Editor > Maki Face material >
3-Layer Diffuse Subsurface Scattering rollout,
click the Overall Diffuse Coloration shader
button.

The Material/Map Browser appears.

2. On the Material/Map Browser, double-click
Bitmap. From the Select Bitmap Image File
dialog, open the file face_color.png.

3. Click Go To Parent.

4. Quick Render the Camera01 viewport.

The new diffuse colors from the bitmap give
color to the skin, lips, and eyebrows.

5. Click the Unscattered Diffuse Color color
swatch.

A Color Selector appears.

6. On the Color Selector, set the color to R=255,
G=246, B=242, then close the dialog.

7. Continue with the following adjustments in the
3–Layer Diffuse Subsurface Scattering rollout:

Set the Unscattered Diffuse Weight to 0.15.

Set the Epidermal (Top) Layer Scatter Color to
R=255, G=217, B=185.

Set the Epidermal (Top) Layer Scatter Weight
to 0.8.

Set the Epidermal (Top) Layer Scatter Radius
to 0.18.

Set the Subdermal Layer Scatter Color to
R=255, G=176, B=145.

Set the Subdermal Layer Scatter Weight to 0.8.

Set the Subdermal Layer Scatter Radius to 2.25.

Set the Back Surface (Through) Scatter Color
to R=212, G=67, B=67.

Set the Back surface (through) scatter weight
to 0.8.

Set the Back surface (through) scatter radius
to 5.0.
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Set the Back surface (through) scatter depth to
5.0.

8. Quick Render the Camera01 viewport.

The skin tone has changed, and light is filtered
through the thin tissue of the ear.

Set up specularity and reflection for the skin surface:

The following steps demonstrate the settings of the
2-Layer Specularity And Reflection rollout. This
rollout provides the parameters you use to set up
the surface properties of the skin.

1. Open maki1_05.max or continue from the
previous section.

2. On the Material Editor > Maki Face material
> 2-Layer Specularity And Reflection rollout,
click the Overall Specular Weight shader
button.

The Material/Map Browser appears.

3. On the Material/Map Browser, double-click
Bitmap. From the Select Bitmap Image File
dialog, open the file face_spec.png.

4. Click Go To Parent.

5. Continue with the following adjustments on
the 2-Layer Specularity And Reflection rollout:

Set the Edge narrowness to 6.0.

Set the Specular Color #1 to R=255, G=254,
B=252.

Set the Specular Weight #1 to 0.4.

Set the Specular Edge Weight #1 to 0.2.

Set the Shininess #1 to 4.0.

Set the Specular Color #2 to R=255, G=246,
B=253.

Set the Specular Weight #2 to 0.4.

Set the Specular Edge Weight #2 to 0.0.

Set the Shininess #2 to 20.0.

Set the Reflection Weight to 0.0.

Set the Reflection Edge Weight to 0.0.

Set the Reflection Glossiness to 2.0.

Keep Only Reflect Environment turned off.
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6. Quick Render the Camera01 viewport.

Now the rendering shows some variation in the
way the skin surface reflects light. The eyebrows
are softer, the skin is less shiny, and the lips have
an additional glossy sheen.

Change advanced options:

These steps take you through setting the advanced
options of the SSS Fast Skin material. The

Advanced Parameters rollout contains parameters
that affect the material’s overall look.

1. Open maki1_06.max or continue from the
previous section.

2. On the Material Editor > Maki Face material >
Advanced Options rollout, make the following
adjustments:

Set the Lightmap Gamma Curve to 0.8.

Turn on Scatter Indirect Illumination.

Set the Scale Conversion Factor to 0.18.

Adjust the Scatter Bias to 0.1.

Set the Falloff Strength to 2.25.

Keep ‘Screen’ (Soft) Compositing Of Layers
turned on.

3. Quick Render the Camera01 viewport.

With the adjustments to scattering you made
on the Advanced Options rollout, shadows are
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softer, especially around the semitransparent
nose and ear. By adjusting the advanced
parameters, you can adjust the subsurface
scattering effect to the size of the model and the
visual effect you want to obtain.

Summary

The SSS Fast Skin shader provides you with a fast
and flexible tool for creating realistic skin effects
when you render with the mental ray renderer.

Network Rendering

Network Rendering

Included with 3ds Max is functionality that lets
you render an animation or a high-resolution
image over a computer network, using multiple
computers simultaneously. Each computer on the
network, if properly set up, can render different
frames of the animation or different sections of the
image, greatly reducing overall rendering time.

This lesson provides a brief overview of the
process of rendering an animation over a local
area network. For detailed information, see the
section on network rendering in the 3ds Max
8User Reference, beginning with Introduction to
Network Rendering. Also see Down on the Farm,
an informative online white paper in PDF format
by Gary M. Davis.

Note: Down on the Farm is a fairly large document;
it might take a little while to download after you
click the link.

Set up the rendering network:

1. Create a local area network or use an existing
one. Each machine, or Server, that you plan to

use for rendering should meet or exceed the
minimum requirements for running 3ds Max.

2. On each Server, install 3ds Max using the
Compact installation option. No authorization
is required for this option.

3. At least one machine on the network should
contain a full, licensed version of 3ds Max for
creating scenes to be rendered.

4. Determine which machine on the network
will act as Manager. Typically, this machine is
different from the machine on which scenes
are created, but it can be any machine on the
network. On the Manager machine, run the
Manager program as an application or service.
You can also use the Manager machine as a
Server. Do this only if you won’t be using
3ds Max at the same time to create or modify
scenes.

5. On each Server machine, run the Server
program as an application or a service. The
Manager assigns tasks to the Server program.

Set up for network rendering:

1. Create a scene containing animation that you
want to render on the network, and specify
where the output image files should go. When
specifying directories for maps and output
files, be sure to use the Universal Naming
Convention (UNC) so that all machines on the
network will be able to find the directories.
Also, the directories should be shared.

Tip: The easiest way to specify a UNC path is
to start with Save In > My Network Places,
and then navigate through the network to the
machine and directory.

For further information, see Setting Up
Directories.

2. Open the Render Scene dialog (press F10),
and in the Render Output group, turn on Net
Render.

3dsmax.chm::/introduction_to_network_rendering.html
http://www.visualz.com/free/down_on_the_farm.pdf
3dsmax.chm::/Setting_Up_Directories.html
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3. Click Render.

The Network Job Assignment dialog opens.

4. Specify a job name and, optionally, a
description of the job.

5. Set a priority and options for the job. All of
these are explained in the topic Network Job
Assignment Dialog.

6. Click the Connect button to find and register
with the Manager. Optionally, if you want to
connect to a specific manager, first turn off
Automatic Search and enter the name of the
Manager machine or its IP address.

After you connect, the Network Job Assignment
dialog displays a list of servers and current jobs.

Submit and monitor the job:

1. To use all available servers, make sure Options
> Use All Servers is on, and click Submit.
Alternatively, turn off Use All Servers, highlight
the servers you wish to use, and click Submit.

Your rendering job enters the queue, and will
be undertaken as soon as the designated servers
are available, depending on the presence of any
existing jobs and their relative priorities.

At this point, you can use the backburner
Queue Monitor program to check the progress
of your job. For detailed information on
the Queue Monitor, see The Queue Monitor
Application.

2. Click the Connect button, and then use
the Connect To Manager dialog to specify
the same manager you connected to from the
Network Job Assignment dialog.

3. In the Job list, find your job and click it to
highlight it.

A job summary appears in the list to the right.

4. Use the Queue Monitor tools to edit the job,
stop or start it, delete it, and so on.

When the job is finished, you’ll find all the
rendered frames in the directory you specified
with the Render Scene dialog. You can convert
these to a movie file using any of several
different methods, such as with the 3ds Max
RAM Player utility.

Summary

If you have access to multiple networked
computers, you can save enormous amounts
of time rendering both animations and
high-resolution still images on the network. All it
takes is a bit of setup and administration, and the
payoff makes it well worthwhile.

3dsmax.chm::/network_job_assignment_dialog.html
3dsmax.chm::/the_queue_monitor_application.html
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Particle Flow
In these tutorials, you’ll learn how to use the
Particle Flow particle system in 3ds Max to create
special effects such as water splashing, mist
blowing, the explosive impact of an asteroid into a
planet surface, guided missiles trailing smoke and
blowing up targets, and more.

Features Covered in This Section

Among the 3ds Max features covered in these
tutorials are the following:

• Spawning particles upon collision with a
deflector.

• Changing particle type based on test results.

• Applying forces such as gravity and drag to
particles.

• Using scripting with an event-driven particle
system.

• Using materials with particles.

Files for This Section

Files for this tutorial can be found on the Tutorial
Files CD in the \tutorials\particle_effects folder.

Note: All the necessary files to do the tutorials can
be found on the Tutorial Files CD that ships with

3ds Max 8. Before doing the tutorials, copy the
\tutorials directory from the CD to your \3dsmax8
local installation.

Tutorials in this Section

Crashing an Asteroid into a Planet Surface (page
2–885)

Creating Guided Missiles (page 2–904)

In this tutorial, you’ll start with a relatively large
asteroid crashing into a planet surface. Actually,
by that time it’s more properly called a meteor,
but we’ll stick with “asteroid” for the sake of
consistency. The collision creates massive after
effects, including a shock wave with more rocks
jumping up from the leading edge, all trailing fiery
particles.

F/X
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Important: We recommend that you not attempt to

render this scene as described here. The main purpose

of this tutorial is to show how to set up a relatively

complex particle system. Before being able to render

this scene, you would need to define particle shapes and

materials for a number of events. This is not covered in

the tutorial, but rather left as an elective exercise.

Note: This is an intermediate-level tutorial. You
should be familiar with basic Particle Flow and
3ds Max functionality such as aligning objects.

Skill level: Intermediate

Time to complete: 2–4 hours

Features Covered in This Tutorial

• Particle system setup and customization

• Flexible emitter setup

• Using an animated reference object to create
different-shaped particles

• Applying forces to particles

• Spawning new particles from existing ones

• Spawning particles on collision with a deflector

• Moving particles across a surface

Tutorial Files

Note: All the necessary files to do the tutorials
can be found on the Tutorial Files CD, in the
\tutorials\particle_effects\ directory. Before doing
the tutorials, copy the \tutorials directory from the
CD to your \3dsmax8 local installation.

Creating the Collision

Particle Flow’s event-driven particle system allows
you to create very flexible particle animation.
It’s flexible in the sense that you don’t have to
define the particle properties and actions based on
explicit keyframes, as in earlier particle systems. In
Particle Flow, you can create a sequence of events

that are triggered by conditions. As the conditions
change or are updated, so too does the particle
system. This makes it easy to adjust the motion
and properties without having to “hard code”
the system. For example, if you create a series of
events that a single particle collision triggers, what
if you add more particles? With an event-driven
system, it doesn’t matter how many times an event
is triggered.

One way to think of an event-driven particle
system is as a Rube Goldberg device, or as a row
of dominoes on end: One event triggers the next,
and so on. Similarly, in this tutorial, you’ll use a
single event to trigger a series of complex events.
In this case, an asteroid object smashes onto a
planetary surface. When an asteroid collides
with the surface, events are generated that create
a fireball, fragments with smoking trails, a shock
wave, secondary impacts, and so on.

Open the scene file:

• Open asteroid_impact_start.max.

In addition to the planet and asteroid objects,
the scene contains two space warps: Drag
and Gravity. There’s also a spherical deflector
(SOmniFlect01).

Create the particle system:

To begin, you need to create the start of the flow:
the asteroid that will be drawn toward the planet
surface.

1. In the Left viewport, create a spherical PF
Source with a diameter of 1000 units. Turn off
Show: Logo.
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2. Use the Align tool to center the emitter
on the Planet object

This will give the particles some distance from
the surface.

The default system contains some operators you
don’t need, so you’ll get them out of the way.

3. Open Particle View. You can do this by going
to the Modifier tab for the PF Source object,
or by pressing 6.

4. In Particle View, click the Render operator in
the global event (PF Source 01), and set Type
to None.

This scene won’t be suitable for rendering;
it’s only for demonstrating how to set up the
particle system. Before rendering, you’d need
to define different shapes and materials for a
number of events, which is outside the scope of
this tutorial.

5. Delete the Speed, Rotation, and Shape
operators in the birth event: Event 01.

By default, the birth event includes a Position
Icon operator, which is where you will emit the
asteroid particles.

6. Highlight the Position Icon operator, and set its
location method to Edges.

This will emit particles at the outer limits of the
icon, not within its volume.

7. In the Uniqueness group, set Seed to 12517.
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This positions the initial particle so that it will
strike the planet in the desired location, near
the light target.

The animation is relatively long (1000 frames,
to be exact), so you’ll want to adjust the Birth
operator’s parameters.

8. In the Birth operator, set Emit Stop to 700 and
Amount to 1.

This will cause one particle to be born between
frame 0 and 700; specifically, at frame 0. During
the remaining frames, the initial particle will
give birth to other particles.

Next, you’ll determine what the asteroid
geometry will be. In the scene you’ll find the

Asteroid object, a simple mesh with a Noise
modifier. The modifier is animated to assume
a new shape in every frame. This procedural
mesh generation can be useful when you want
to use several unique asteroids without having
to create a separate meshes for each.

9. Add a Shape Instance operator below the
Position Icon operator, and set Asteroid to be
the reference object.

Tip: Because the Asteroid object is outside the
viewports when you open the scene, you’ll
probably find it easier to use the Pick Object
dialog: After clicking the Particle Geometry
Object button in the Shape Instance operator,
press H and then double-click Asteroid in the
list.

10.(Optional step) Take a look at the Shape
Instance parameters; first, Scale %. Instead of
having to add a separate Scale operator, you can
set the relative scale of the instanced geometry,
as well as a variation to randomize the scale
with each successive particle. Feel free to adjust
either parameter accordingly. Also, if you
were to use several asteroids, but left Acquire
Current Shape off, the instanced geometry
would always look the same. By turning this
parameter on, the Shape Instance operator will
use the current state of the geometry when
assigning it to a newly born particle. This keeps
you from having to create a unique object
for each particle. But for this tutorial, you’re
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emitting only one original particle, so you can
leave it off.

By the way, it’s easier to visualize what’s
happening if you can actually see the shape of
the object.

11.Highlight the Display operator and set Type to
Geometry.

Use gravity to send the asteroid toward the planet:

At this point, the particle doesn’t really do
anything. To make it fall toward the planet object,
all you need to do is define a Gravity space warp
as a force applied to the particle. In the scene
you’ll find a spherical Gravity aligned to the planet
object to create this effect.

1. Add a Force operator below the Shape Instance
operator and assign Gravity01 as the Force
Space Warp. Also, set Influence % to 100.0.

If you play the animation, you’ll see the mesh
falling toward the planet object. It should be
hitting the planet surface near the location of
the light target (Direct01.Target) visible in the
Perspective viewport.

The asteroid mesh strikes the planet surface near the
light target (Perspective viewport).

To look more natural, the asteroid should fall
with a tumbling motion. You can achieve this
with the Spin operator. The Spin operator is
similar to the Rotation operator, but instead
of controlling orientation explicitly, it instead
applies angular velocity to the particle. For
this reason, you will sometimes want to use a
Spin operator in conjunction with a Rotation
operator, but not in this case.

2. Continuing down the event, add a Spin operator
below the Force operator.

Its parameters let you control the angular
velocity on different axes. But in this scene, all
you really need to do is just give it a nudge in a
random direction.

3. Make sure Spin Axis is set to Random 3D, and
then set Spin Rate to 90 with a Variation value
of 30.

This causes the particle to rotate 90 degrees,
plus or minus 30 degrees, every second.

4. Right-click the Event 01 title and rename it
CreateAsteroids.
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This event currently just births asteroid
particles and causes them to be drawn toward
the planet object. The quantity of particles is up
to you, but, for simplicity’s sake, in this tutorial
we recommend using a single particle.

Create a collision:

The next step is to cause the asteroid particle to
collide with the planet surface, at which point it
breaks up and causes a shock wave.

This scene includes a spherical deflector that
roughly matches the surface of the planet
object. The reason for using this instead of
a mesh-based deflector is one of speed and
simplicity. Mesh-based deflectors like UDeflector
have to test polygons for intersection, which is
slower than testing a bounding sphere. Since the
planet object is a sphere, all that’s necessary for
faster collision calculations is aligning their pivots
and matching the scale. Of course, that’s already
done for you in this scene.

1. Add a Collision test at the bottom of the
CreateAsteroids event.

Because the collision will cause particles to
spawn, you could use a Collision Spawn test,
but you’ll use Collision instead so you can get a
look at its added flexibility.

2. Click the test to highlight it, and in its
parameters assign SOmniFlect01 as the
deflector.

You’ll leave the remaining Collision controls
at their default values, but note that there’s
quite a bit of functionality in this test. Particles
don’t have to test True only when they collide.
In fact, you can have particles test True when
they’re about to collide with a deflector, or only
if they’ve slowed down or sped up after the
collision.

Next, you’ll need a new event to pass colliding
particles to. This event will do several different
things. First, it will spawn particles, generating
a cluster of particles from the single asteroid.
Then it will split the particle stream, with
some becoming fragments that fly off into the
atmosphere and others forming a shock wave
that hugs the surface of the planet.

3. Create a new Spawn test outside of the
CreateAsteroids event.
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This automatically creates a new Display
operator as well.

4. Rename the new event RocksShockwave, and
wire it to the Collision test, as it will create rocks
and the shock wave.

5. In the Spawn test’s parameters, set Offspring #
to 200 with a Variation % setting of 15.

6. In the Speed group, change Variation % to 30
and the Divergence angle to 60.

Thus, the collision of the asteroid with the
planet will generate about 200 new particles,
each of whose speed is between 70 percent and
130 percent of that of the original, and with an
angular spread of 60 degrees.

Note: Although Spawn is nominally a test, in
this case you’re using it strictly as an operator,
to define the results of the collision. Later on,
you’ll use two additional tests in this event,
including a second Spawn, to send the particles
to other events.

7. Change the Display operator’s type and color.
Try orange ticks, for example.
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8. Play the animation.

The asteroid creates a blast of particles on
impact.

Creating the Shock Wave
Set up the lesson:

• Continue from the previous lesson, or open the
file asteroid_impact_part2.max.

Create the shock wave:

To cause the spawned particles to emit radially and
hug the surface of the planet geometry, you’ll use
the Speed By Surface operator. This can sometimes
be slow, especially with dense objects, but in the
case of this sphere it should be fine.

1. Below the Spawn test, add a Speed By Surface
operator, and then click the operator to display
its parameters.

This powerful operator provides quite a few
controls.

By default, the surface of the object affects the
particle motion for one frame only. But if the
particles are to stay on the surface, it’s best to
choose the other setting.

2. Choose Control Speed Continuously from the
first drop-down list.

3. Next, set Speed to 30 with a variation of 5, so
as not to break up the shape of the shock wave
too much.

The Speed By Surface operator allows you to
reference multiple objects, even objects whose
shape is animated, as well as define the speed
values along the surface based on a material.

4. In the Surface Geometry group, click Add and
select the Planet object .

5. Set Direction to Parallel To Surface.
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This forces the particles to move along the
surface of the object. You also have the option
of moving along the normals, but in this case
that would cause the particles to move away
from the planet’s surface.

The Continuous Speed Control group contains
some important controls. Accel Limit lets you
limit how quickly the particles can change
speed and direction. If this is too high, the
particles can get a bit out of control.

6. Set Accel Limit to 10.

Next are the Range and Falloff Zone controls,
which let you limit the extent of the effect.
Range specifies the distance within which the
operator will affect the particles; Falloff Zone is
the attenuation between the starting point and
ending point. But in this example these controls
don’t matter, because the particles should
always be affected by the surface. Otherwise
they’d slide off the surface unrealistically once
they reached the range limit. So you can just
leave the Unlimited Range option turned on.

7. Play the animation.

The Asteroid creates a ring of particles, like
a shock wave, that moves outward along the
surface. It can sometimes be slow to process
this event, so you might consider adding a
Cache operator when this event is completed.
The Cache operator “bakes” the particle
motion into the computer memory for faster
playback. It’s sort of like preprocessing the
animation, so the computer has to think only
about displaying the particles, not figuring out
where they should be.

A realistic shock wave within an atmosphere
will slow down over time; the Drag space warp
is well suited for this type of effect.

8. Add a Force operator below the Speed By
Surface and assign the Drag01 space warp to it.
Set Influence % to 500.

9. Play the animation again.

The shock wave slows down over time, affected
by drag realistically.

You’ll do more with the shock wave effect,
shortly, but first you’ll complete this event.
You’ll split the particle stream so that some
become the shock wave and others become
rocky fragments. This is done with a test called
Split Amount.

Create rocky fragments:

Split tests are very useful in Particle Flow because
they allow you to divide particles within an event
and send them to new events. Instead of having to
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create two separate streams, you can split a stream
at any time and reference those streams together
or separately. In this scene, a certain number of
particles are spawned when the asteroid strikes
the planet. You split these into two groups: one
to become shock-wave particles and the other to
become the fragmentary rocks tossed into the
atmosphere.

1. In the RocksShockwave event, add a Split
Amount test below the Spawn test.

Split Amount lets you subdivide the particle
stream by percentage, every Nth particle, or all
particles above or below a certain amount. This
gives you quite a lot of control over splitting
the stream, so we’re only going to scratch the
surface with this one.

Positioning the test immediately below the
Spawn test lets it split off the particles before
they have a chance to be affected by any
operators in the event.

2. Using the default Fraction Of Particles option,
set Ratio % to 20.

Because Split Amount is a test, the particles
that are split are sent to the next event while the
others remain. In a little while, you’ll set it up
so that the 20 percent that are split become rock
fragments.

If you don’t connect the output of the Split
Amount test to any other events, Particle Flow
essentially ignores it. You can check this by
setting Particle View > Options menu > Track
Update to Particle Count. This adds a tab to
each event, showing how many particles it
contains.

The Particle Count option adds a tab to each event that
shows its current particle count.

Flesh out the shock wave:

You could move on to the rocky fragments, but
it’s usually a good idea to flesh out one stream of
events at a time. In this case, there are a few more
things to do with the shock wave. Currently it’s
just a bunch of particles moving outward along
the surface. The next two things to do are to add
particles trailing behind the shock wave, plus other
particles leaping upward from the leading edge.
The production theory of this is that the shock
wave particles will likely need to be rendered as
a glowing hot shape with fiery facing particle
trails and sparks. You’ll want independent control
over each of these, something Particle Flow is
specifically designed for.

1. Add a Spawn test to the bottom of the
RocksShockwave event.
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You’ll set this up so that particles within this
event emit more particles as they move.

2. Click the new Spawn test, and in the Spawn Rate
And Amount group, choose By Travel Distance.

As in the Boat Splashes tutorial, this method
is useful because it controls the number of
particles spawned based on the distance the
parent particles travel. So fast-moving particles
spawn more than slower moving particles.

3. With the By Travel Distance option, the
spawning rate is controlled by the Step Size
value, which you should set to 0.5.

The default Offspring # value of 1 is sufficient,
because you already have many shock wave
particles to emit from. But you can always
increase this if necessary.

4. In the Speed group, set Inherited % to 15 with
a Variation value of 5.

This is important because with the default
value of 100, all of the spawned particles will
retain the full velocity of the parent particles.
By reducing this to 15%, they will trail behind
substantially.

Next, you’ll create an event that defines how
these spawned particles will behave and appear.

5. Add a new Force operator outside the
RocksShockwave event. Add Drag01 to its
Space Warps list, and set Influence % to 100.
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6. Rename the new event ShockwaveTrails, and
set its Display operator to Dots and change the
color to dark red, or any other color that will
help distinguish the spawned particles from the
parents.

7. Wire the output of the new Spawn test in the
RocksShockwave event to the input of this new
event.

Now, when you play the animation, the Drag
force slows down the trailing fragments.

However, what’s missing is that these spawned
particles have no lifetime: they will never die. If
they are to represent fiery trails, you’ll probably
want to use materials that are driven by the age
of the particles; perhaps a Gradient material.

8. Add a Delete operator to the ShockwaveTrails
event, just below the Force operator. In the
operator’s parameters, choose By Particle Age
and keep the default Life Span value of 48 with
a Variation of 8.

Now you’ll start to see the trail particles dying
after they’ve been around for two seconds (this
scene uses the film frame rate of 24 fps). This
should be sufficient, but you can always adjust
accordingly.

At this point, your particle diagram should
resemble the following illustration.
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Generating Secondary Events
Set up the lesson:

• Continue from the previous lesson, or open the
file asteroid_impact_part3.max.

Create particles shooting up from the shock wave:

To create new particles that are spawned upward
from the leading edge of the shock wave, you
could do a few different things. In this case, you’re
already spawning particles from them, so why not
split the particles and have some become these
new particles? You’ll use a method similar to the
one in the RocksShockwave event.

1. At the top of the ShockwaveTrails event, add a
Split Amount test, and keep the default setting:
Fraction of Particles > Ratio %=50.

Now every other particle spawned will be a
trail particle and the rest will be these newer
particles.

2. Create a new event in Particle View by cloning
the Force operator in the CreateAsteroids
event as an instance. To do this, press and
hold the SHIFT key, and then drag the Force
operator from the CreateAsteroids event to
an empty area of the Event Display, below the
ShockwaveTrails event.
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A dialog asks how to clone the operator. Choose
Instance, and click OK.

The new operator appears in italics, denoting
that it’s now instanced from another operator.
This is a useful way of reusing operators and
propagating changes over them.

3. Rename the new event ShockwaveBurning,
and change the new event’s Display operator to
something unique like yellow lines.

The Lines display type is particularly useful for
moving particles because, unlike the others, it
shows not only distance but also direction and
velocity. Each line points in the direction of
the particle’s motion, and the length of the line
indicates its relative speed.

These particles will be shooting up away from
the surface of the planet. You’ll use the Gravity
space warp in the Force operator to slow them
down gradually and have them fall back to the
surface, if they live that long.

Other than being affected by gravity, the new
ShockwaveBurning particles don’t do anything
unique at the moment. You’ll make them move
upward away from the surface with another
Speed By Surface operator. But this time,
instead of hugging the surface of the planet,
these particles will shoot away from the surface.

4. At the top of the ShockwaveBurning event, add
a Speed By Surface operator. In its parameters,
keep the default choice of Set Speed Once, and
set Speed to 5 and Variation to 1.

This will give a single nudge to particles that
enter this event.

5. For the Surface Geometry, assign the Planet
object, and keep the default Direction choice of
Surface Normals.

This will push the particles away perpendicular
to the object’s surface. When you have a wildly
undulating surface (not the case here), this can
make for some interesting particle motion.

As in the previous event, you need to set a
lifetime for the particles.

6. At the bottom of the ShockwaveBurning event,
add a Delete operator. Choose By Particle Age,
and set Life Span to 20, and Variation to 1.
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This will make these particles disappear quickly,
mimicking the motion of licking flames.

The last thing you need to do to finish the shock
wave portion of this tutorial is to wire up the
new event.

7. (Optional step) If you created the
ShockwaveBurning event away from the
ShockwaveTrails event before, you might want
to move it closer before going on to the next
step.

8. Connect the output of the Split Amount
test in the ShockwaveTrails event to the new
ShockwaveBurning event.

If you play the animation now, you should have
a radial shock wave moving outward, leaving a
trail of particles behind while emitting bits of
particles upward into the atmosphere.

Create rocky fragments:

With the shock wave complete, you can get
back to the rock fragments you left earlier.

Remember that when creating the shock wave
in the RocksShockwave event, you added a Split
Amount operator to split the particles spawned
in that event. Twenty percent will become
rocky fragments that explode outward into the
atmosphere while the rest form the shock wave.
You haven’t wired the Split Amount output into
a new event, so until now it has been essentially
ignored. Now it’s time to create an event that
defines the rock fragments.

1. To the left of the RocksShockwave event, create
a new event by copying the Force operator from
the CreateAsteroids event and then pasting
it as an instance. Rename this new event
EmitFragments.

2. Change the resulting Display operator type to
orange dots.

3. Wire the output of the Split Amount operator
in the RocksShockwave event into the new
event’s input.

At this point, it’s still a bit premature to start
testing the animation. In fact, because the
shock wave is now complete and can be rather
CPU-intensive to play back, it’s a good idea to
disable a few operators to keep things running
smoothly for the time being.

You can disable events and operators with a
click of a button. Test operators don’t really
get turned off, but instead you can set them
to always return true or false, bypassing the
conditional portion of the test. To toggle an
event, you click the light bulb-shaped button to
the right of the event name.
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Operators don’t have this, but instead, if you
click an operator icon it will alternate between
being enabled and disabled. When disabled,
the operator is grayed out.

When you place the mouse cursor over a Test
operator’s icon, you’ll notice it changes to a
diamond cage. If you position it over the left
side of the icon, the cage displays an arrow
pointing to the left, indicating “all particles
return True.” Conversely, on the right side of
the icon the cage remains closed, indicating
that all particles automatically test False. To
make sure that all particles test True or False,
click the appropriate side of the icon. After you
click the icon, it changes to display a green light
for True or a red light for False.

4. To speed up interactivity while building the
rock fragments, go to the RocksShockwave
event, disable the Speed By Surface operator,
and then set the Spawn operator at the bottom,
which feeds into the ShockwaveTrails event, to
False.

The following illustration shows both places to
click, and the end result.

That should speed things up significantly for
the time being. But don’t forget to reset these
changes when you’re finished with the scene.

If you play the animation now, you should see
the original particle that starts the shock wave,
as well as new particles being shot up into the
atmosphere and falling back to the planet.

Create trails for the rock fragments:

Next, you’ll create fire and smoke trails for these
rock fragments. These trails can be mapped
dynamically with a gradient over particle lifetime
to look like fire and smoke. You’ll also create
new secondary shock waves from when the rock
fragments collide with the planet surface upon
reentry.

1. At the bottom of the EmitFragments event,
add a Spawn test. Set the mode to By Travel
Distance with a Step Size of 0.2. In the Speed
group, keep the default Inherited % choice, and
set the value to 10 with a Variation % of 10 and
Divergence of 30 degrees.
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This will cause the trailing particles to lag
behind a bit and spread outward in more of a
conical trail.

At this point, the Spawn test in the
EmitFragments event will spawn particles.
However, the new particles will behave the
same as the existing particles, being affected
identically by the operators in the event. If you
play the animation, you’ll notice the particles
look the same and are all equally affected by
gravity.

To control the new particles differently, you’ll
define a separate event for the trails.

2. Below the EmitFragments event, add a new
Delete operator. Rename the resulting new
event FragmentTrails and set the Display
operator to red dots, or anything else unique.

3. Set the Delete operator to By Particle Age, and
then wire the output of the Spawn test in the
EmitFragments event to the new event.

When you play the animation, things start to
fall into place. The fragments trail red dots
behind. The only problem is that they die
too quickly. By default, the Delete operator is
set to 48 frames, which is not enough in this
case. The Delete operator is important for
this event because, otherwise, the trails would
exist for the entire length of the scene and,
more importantly, wouldn’t be able to receive
age-based material effects like gradients.

4. In the Delete operator’s parameters, set Life
Span to 80, and Variation to 24.
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Create secondary flames:

One last minor problem with this effect is that the
rock fragments fall back to the planet and pass
through the surface. It would look much better
if they caused new impacts and shock waves, like
secondary explosions. You can accomplish this
easily with a Collision test and new event.

1. You can reuse the Collision test from the
CreateAsteroids event: Click it to highlight it,
and then right-click it and choose Copy from
the menu. Then position the cursor just below
the Spawn operator in the EmitFragments
event, right-click, and choose Paste Instanced
from the menu. Alternatively, you can just
SHIFT+drag it to the new location, and then
choose Instanced from the Clone Options
dialog.

You’ve defined a collision test to determine
when the rock fragments fall back toward the
planet surface. Without an output wire from
the Collision test, the particles will just bounce
on impact. To create secondary flames on
impact you need to create a new event to define
just that.

2. Add a new Spawn test outside the
EmitFragments event. Rename the new event
SecondaryFlames and change the Display type
to yellow Ticks.

This will make it easy to see when the secondary
flames are happening.

3. Connect the output of the Collision test in the
EmitFragments event to the new Spawn event.

4. In the Spawn test’s parameters, keep the default
Spawn Rate of Once, and turn on Delete Parent.

This is important because you don’t want the
rock fragments to continue bouncing around;
instead, they should spawn the new particles
and then die.

5. Set Offspring # to 50 with a Variation % value
of 30.
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This lets each rock fragment spawn between 35
and 65 new particles.

6. In the Speed group, set Inherited % to 50 with a
Variation % value of 30 and Divergence value
of 90.

This will cause the spawned particles to travel
outward at about half of the impact speed in
a widespread pattern.

Currently the SecondaryFlames event doesn’t
really do anything other than spawn new
particles. To create secondary flames, you’ll add
some operators so that the particles will create
a radial shock wave pattern, hug the surface,
slow down over time, and eventually die after a
few seconds.

7. Add a Speed By Surface operator to the
SecondaryFlames event below the Spawn test.

This will cause the particles to follow the
surface of the planet object.

8. Set the Speed By Surface operator to Control
Speed Continuously with a Speed of 30 and
Variation of 10.

This will push the particles away at a speed of
30 units a second.

9. Choose the Planet object as the Surface
Geometry and set Direction to Parallel To
Surface.

This will force the particles to hug the surface
of the planet as they move outward.

10.Lastly, set Accel Limit to 5.

11.Next, copy the Force operator from the
RocksShockwave event and paste it as an
instance it into the SecondaryFlames event.
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This is the same operator that affects the
particles with 500 percent Drag.

12.Add a new Delete operator at the bottom of the
SecondaryFlames event, and set it to By Particle
Age, keeping the default settings: Life Span=48
and Variation=8.

This will cause the new particles to die after
roughly two seconds.

13.In the RocksShockwave event, turn the disabled
operator and test back on.

That’s it! You can compare your results with
ours in the file asteroid_impact_final.max.

Summary

This Particle Flow setup is complete for now. As
it stands, because there are no Shape or Material
operators beyond the initial Shape Instance, all
particles will render as the Asteroid shape. Instead,
the other events should use other shapes and
Shape Facing operators. However, that is beyond
the scope of this tutorial, and is left up to you.
Myriad possibilities are available to you.

Some suggestions would be to create the rock
fragments with animated instanced geometry
created with the same method used to create the
asteroids. You could do the trailing effects with
Shape Facing and Material Dynamic operators, in
order to create gradient-mapped effects over the
life of the particle.

Goals are a common feature in modern particle
systems, defining a point in space that particles
are attracted to or seek. This may seem simple,

but good goal tools are quite complicated and
require several capabilities to make them useful
in production. These capabilities include:
weighting among multiple goals, acceleration and
deceleration to and from goals, as well as events
upon goal completion. All this is handled by
Particle Flow using the Find Target test. You can
think of the Find Target test as a guidance system
for particles, which makes it perfect for creating
guided missile animation.

In this tutorial there is a funky biplane that’s trying
to shoot down some rebel teapots. This biplane
has been modified with missile pods on each wing
that will emit particles. Each missile pod will emit
one particle. Each particle will use instanced
geometry of a missile and seek a teapot at random,
trailing smoke particles along the way. When a
missile particle reaches its target, it will trigger an
explosion event.

In the past, using the default particles, this could
not have been done procedurally. First, you
couldn’t make particles seek a target, let alone a
random target from within a group. And while
you could spawn particles on collision with an
object, the spawned particles had to share the
same properties. This meant the explosion would
have to have been done with a separate particle
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system timed by hand. That defeats the purpose
of a procedural system.

Skill level: Intermediate

Time to complete: 2–3 hours

Features Covered in This Tutorial

• Creating missiles using particles emitted from
selected faces

• Using Find Target tests

• Creating smoke trails using Shape Facing
operators and dynamic materials

• Creating explosions using animated Scale
operators

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial Files CD, in the
\tutorials\particle_effects\ directory. Before doing
the tutorials, copy the \tutorials directory from the
CD to your \3dsmax8 local installation.

Creating the Missiles Using
Particles
Open the scene file:

• Open guided_missile_start.max.

This scene contains a biplane, three teapots,
and a hidden missile. The biplane has four
instanced objects on the wings; named
MissileRack01 through MissileRack04. Each
has forward-facing polygons already selected
at the sub-object level, to specify the location
from which its missile will be fired. When you
specify them as particle emitters, you can tell
Particle Flow to emit the particles only at these
selected polygons.

Create the particle system:

You’ll create a particle emitter in the viewport.

1. On the Create panel, click the drop-down list
and choose Particle Systems.

2. On the Object Type rollout, click PF Source,
and then in the Top viewport drag out an
emitter icon near the biplane. Make the icon
about half the size of the wings.

Emitter icon in Top viewport

The emitter icon has two components, the logo
and the icon. The logo has directional arrows
to help you visualize the particle generation.

3. On the Create panel, find the Emission rollout
> Quantity Multiplier group, and set Viewport
% to 100.0.

Align the emitter:

Next, you’ll rotate and position the emitter so it’s
aligned with the biplane. You’ll use the icon to
control the speed vector/direction of the missiles.
The emitter will be linked to the biplane, so that
the missiles will be shot heading in the same
direction as the plane flies.

1. With the PF Source emitter icon selected
in the viewport, click the Align button on
the toolbar, and then click the biplane object,
which is named Fuselage.
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2. In the dialog that appears (Align Selection:
Fuselage), in both the Align Position and
Align Orientation groups, turn on X/Y/Z
Position/Axis. This will align both the position
and orientation of the emitter with the biplane
fuselage. Click OK to confirm the alignment.

Note: There’s no need to align the scale here.

Emitter aligned with biplane

Next you’ll rotate the emitter 90 degrees, so it’s
pointing toward the front of the plane.

3. On the toolbar, click the Rotate button,
and then choose Local reference coordinate
system.

4. In the Perspective viewport, rotate the particle
flow emitter icon 90 degrees about the Y axis,
so the arrow of the emitter is pointing in the
same direction as the biplane is flying.

Tip: Press the equal sign key (=) to increase
the size of the Transform gizmo, then select
the green horizontal circle to rotate about the
Y axis.

Rotate the emitter locally.

5. Use Arc Rotate Selected to orbit the
Perspective viewport around the emitter icon
and verify that the direction of the particle flow
is correct.

Then press SHIFT+Z to undo the viewport
changes.

6. On the main toolbar click the Move
button, then choose Local from the Reference
Coordinate System drop-down list.

Use the Transform gizmo to move the emitter
above the top of the biplane. Then go to the
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Modify panel, and on the Emission rollout’s
Emitter Icon group, turn off Show: Logo.

The size of the icon isn’t important because it
won’t be used as an emitter, but it should be
big enough that you can select it easily in the
viewport.

7. Rename the emitter Guided Missile.

8. Use the Select And Link tool to link the
emitter to the biplane fuselage object as a child
(drag from the emitter to the biplane).

Now the movement of the biplane will drive the
movement of the emitter.

9. Open Particle View by pressing 6 on the
keyboard.

You can see the Guided Missile name for the
global event.

Create the particles using selected faces:

Next, you will create the conditions for the missile
launch. You’ll create four particles, emitting one
from each of the selected faces of the missile tubes.

1. Rename Event 01: right-click its title bar,
choose Rename, and enter Launch Missiles.

2. Click the Birth operator and set Emit Start to 30
and Emit Stop to 100. Also, set Amount to 4.

With these settings, the system will emit four
particles (missiles) between frames 30 and 100.

The Amount value determines how many
particles will be emitted uniformly between the
specified frames. You often use particle systems
to create a large number of duplicates, but here
only four particles will be used, creating the
four missiles.

3. Next, click the Display operator and set its Type
to Geometry.

You’ll want to be able to see the missiles to make
sure they’re oriented properly.

4. Replace the Position Icon operator with a
Position Object operator. From the depot, drag
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the Position Object operator onto the Position
Icon in the Launch Missiles event. When you
see a red line, release the mouse button.

5. Click the Position Object operator to display
its parameters, and turn on Inherit Emitter
Movement.

This is important because you want the speed
of emission to be relative to the motion of the
emitter; in this case, the biplane.

6. In the Emitter Objects group, click By List and
add all four MissileRack objects.

7. In the Location drop-down list, choose Selected
Faces.

Without this being set, particles will be emitted
from all polygons on the objects. In this file,
the faces in the front of the missile racks have
been selected already.

8. Scroll down to the bottom of the rollout. In the
Uniqueness group, set the Seed to 10527.

The Uniqueness Seed provided limitless choices
for different quantifiers. Changing this value
produces an individual effect.

Set the speed of the missiles:

Next, you’ll set the speed of the particles.

1. In the Launch Missiles event, click the Speed
operator.
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2. On the Speed 01 rollout set Speed to 1200.

3. Set Variation to 24.0.

Keep Direction set to Along Icon Arrow. This
uses the orientation of the PF Source emitter
icon to determine the direction in which the
particles are emitted.

Instance the missile geometry:

You’ll use the Shape Instance operator next. This
replaces the simple shapes in the Shape operator
with a reference of geometry in your scene. In this
case, the four particles will be replaced with four
missiles.

1. Replace the Shape 01 (Tetra) operator with
a Shape Instance operator. Drag the Shape
Instance operator from the depot on top of the
existing Shape operator.

The red line means the operator will be replaced

The Shape Instance operator will let you choose
an object to use in place of the particles. First
you’ll need to unhide the missile geometry in
the viewport.

2. Right-click the active viewport, and choose
Unhide By Name. Choose Missile01 from the
list, then click Unhide.

You can see the unhidden missile appear in
front of the biplane in the Top viewport.

Missile geometry

3. In the Launch Missiles event, click the Shape
Instance 01 operator. On the Shape Instance 01
rollout, in the Particle Geometry Object group,
click the button labeled None, and then click
the missile in the viewport, or press H on the
keyboard and select the Missile01 object from
the list and click OK.

Note: You can actually use multiple objects and
cycle through them as particles are emitted, but
that isn’t necessary in this case.

A handy set of parameters in Shape Instance
is the built-in scaling controls. Use these
parameters for simple size adjustments. If you
were doing a flock of birds, it would make sense
to randomize their scale slightly, but all missiles
should be exactly the same size. Leave Scale %
at 100.0.

4. Make sure that Acquire Mapping and Acquire
Material are both turned on.

This is important unless you want to override
the existing mapping and materials on the
instanced geometry.

5. Select the Missile01 object in the Top viewport,
then right-click and choose Hide Selection.
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With the missile instanced by the particles, you
don’t need the original visible in the scene any
more.

6. Move the time slider to frame 32, and pan
the Top viewport until you have a clear view
of the biplane.

Missile pointing the wrong way

While the missiles are emitting in the correct
direction, the instanced geometry isn’t aligned
to the direction of travel. This becomes
important as they twist and turn to acquire
their targets, so to set the orientation you need
to adjust the Rotation operator.

7. Click the Rotation 01 operator, then set
Orientation Matrix to Speed Space Follow.
Change Y to 90.0 degrees.

This rotates the instanced geometry internally
90 degrees about Y and orients it to the
direction of travel. Now if you scrub the
animation, things should be fixed.

Missile direction corrected

Save your work:

• Save your work as myguided_missile_
part1.max.

Animating the Missiles Seeking
Targets

Right now, the missiles are flying straight without
any sort of guidance. How do you make the
missiles seek those rebel teapots? The Find Target
test is the key.
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The Find Target test creates targets or goals for
particles within the event. Particles will seek the
targets in the list based on speed or time to target,
with a variety of parameters to control how they
arrive at their target. This is a very powerful action
that can be used for quite a few unique effects. For
example, when set to No Control, Find Target acts
as a proximity test by sending particles to new
events based on their distance from the target
objects. So in some ways it’s not just a goal tool
but also a location test.

Set up:

• Continue from the previous lesson or open
guided_missile_target_start.max.

This is a snapshot file from the end of the last
lesson. If you do open this file, you’ll need to
press 6 to open Particle View .

Add and adjust a Find Target test:

1. Add a yellow Find Target test to the bottom of
the Launch Missiles event. Highlight the Find
Target label after adding it.

At this point, your particle diagram should
resemble the following illustration.

2. In the Find Target 01 rollout, confirm that the
control method is set to Control By Speed.

3. In the Control By Speed group, set Speed to
1200 with a Variation of 24 units.

This defines the general speed the particles will
travel to the target. Missiles travel fast.

4. Also in the Control By Speed group, set Accel
Limit to 7200.

This increases how quickly the missiles can
change speed and direction to reach their
targets.

Now you’ll define the target. By default, Find
Target uses its own icon; for this tutorial you’ll
change it to seek the teapot objects.

Define the target:

1. In the Target group, choose Mesh Objects, and
then click By List. In the Select Target Objects
dialog, highlight all three teapot objects, then
click Select.

The names of the teapot objects appear in the
Target list.

2. Next turn on Follow Target Animation, so that
the particles will constantly seek the moving
targets. Otherwise the particles will seek the
location in space where the target was when the
particle was emitted.

3. Make sure Lock On Target is on as well, so that
particles will choose a target and stick with it,
no matter what happens.

4. Confirm that the Point and Object fields are
set to Random, so that each particle will seek a
random point on a random target.
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This creates the ultimate in chaotic
non-uniformity. You can, however, adjust it so
that the particles approach different areas of the
targets, but since the teapots are small and far
away, it’s not necessary now.

5. Confirm that the Docking Direction is set to
None Specified.

This is important because other settings will
alter how the particles approach the targets.
This option is more useful when doing simple
crowd simulation.

6. In the Uniqueness group, change the Seed to
10739.

7. If you play the animation now, you should see
the missiles shoot out and seek the teapots.

Particle seeking target

Missile finds teapot

Save your work:

• On the File menu choose Save As. Save your file
as myguided_missile_target.max.

Two major steps remain.

First, you probably noticed that it’s hard to follow
the trajectory of the missiles. Adding smoke trails
will add realism and make it easy to follow the
flight of the missiles.

Next, because Find Target is a test, it has an output.
So what happens when the missiles hit their
targets? You can create a new event that causes an
explosion or whatever you want. In the two lessons
that follow, you’ll add smoke trails, and then create
the explosion.

Adding Smoke Trails

Adding smoke trailing from the missiles in this
tutorial is relatively simple in that it’s just a matter
of spawning particles from the particles that define
the missiles.

Using Spawned Particles

One of the great advantages in Particle Flow over
the legacy particle systems is that the spawned
particles are totally independent of the parent
particles (other than emission). For this reason,
they can be of different shapes, be affected by
different space warps, as well as use completely
different test operators.
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Set up the lesson:

• Continue from the previous lesson, or open
guided_missile_trails_start.max.

Note: If you do open the provided file, press 6
to open Particle View.

Add a Spawn test:

To create spawned particles from the Missile
particles, you first need to create a Spawn test in
the Launch Missiles event.

1. Drag a Spawn test from the depot to the bottom
of the Launch Missiles event.

Drag Spawn test to the bottom of the event.

2. Highlight the Spawn 01 test in the event, and in
the Spawn Rate And Amount group, choose By
Travel Distance. Set Step Size to 3.0 units.

This is a useful method for spawning
trailing-type of effects because the rate at
which new particles are spawned is based on
the distanced traveled and not a set amount
per second. This effectively makes it spawn
based on speed, so to avoid gaps created by
fast-moving particles or bunched-up particles
from slow-moving ones.

3. Make sure Offspring # is set to 1.

This means that only one particle will be
spawned per spawn. By increasing this value,
you can make spawns in puffs or clumps of
multiple particles.
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4. In the Speed group, choose In Units and set the
value to 50.

This sets an explicit emission velocity constant
that is not based on inherited velocity from the
parent particles. The main reason for doing this
is one of subject matter: missiles will burn at a
constant rate, so the smoke trail emission will
be constant. Of course you could adjust this
anyway, with smaller values causing spawned
particles to remain tightly together and larger
values pushing them away from the source
more.

5. As with all things in nature, adding some
randomness is important, so set Variation % to
10 and Divergence to 10 as well.

Variation will add randomness to the speed of
emission and Divergence to the direction.

6. In the Uniqueness group set the Seed to 9227.

An important point to keep in mind when
using the Spawn test is that it can create many
particles very rapidly. In this case, all of the
new particles are the same as the missile
particles, that is, instanced geometry. So if you
played the animation now, the sheer mass of
new geometry would severely impact system
performance before long. For that reason, it’s
recommended that you temporarily turn off
the particle system before proceeding. Later
on in this lesson you’ll simplify the geometry
of the spawned particles, after which you’ll be
able to play the animation without suffering a
performance hit.

7. Press the semicolon key (;) or click the light
bulb icon in the title bar of the global event
(Guided Missile).

This toggles the active status of the particle
system.

Create a Force operator:

The Spawn test output isn’t connected to a new
event yet, so, as mentioned, the spawned particles
are exactly the same as the missile particles. To
change them, you’ll use a new event.

1. Drag a Force operator from the Depot to the
event display.

This creates a new event containing the new
Force operator as well as a new Display operator.

2. Rename this new event Missile Smoke Trails.

3. Click the Force operator in the Missile Smoke
Trails event to display its parameters. In the
Force Space Warps group, click By List, and add
both the Drag01 and Wind01 space warps.

While the missile particles aren’t affected by
space warps, the motion of the smoke trails
will be influenced by drag and turbulence,
independent of the parent particles.



Adding Smoke Trails 915

Give the particles a unique look:

The next thing you need to do is give the particles
a unique look.

1. In the Missile Smoke Trails event, click the
Display operator.

2. On the Display rollout, change the Type to
Dots.

3. Change the color to dark blue (or whatever you
want).

Add a Delete operator:

The smoke particles should form trails then slowly
disappear. You’ll use a Delete operator to produce
the latter effect.

1. Add a Delete operator to the bottom of the
Missile Smoke Trails event. Click it in the event,
to display its parameters.

2. On the Delete 01 rollout, in the Remove group,
choose By Particle Age. Set Life Span to 120
frames, and set Variation to 8.

This will cause the smoke trails to last long
enough to form the trails, but not hang around
forever.

3. In the Uniqueness group, change the Seed to
28692.

Define geometry and materials:

One last series of steps you need to do to finish
this effect is define geometry and materials for
the particles. For the smoke trails, it’s useful to
employ the Shape Facing operator, which creates
polygons that constantly orient themselves toward
the camera. These are then mapped with radial
gradients and noise to create a smoke-like look.

1. To start, add a Shape Facing operator below
the Force operator in the Missile Smoke Trails
event. Highlight the Shape Facing operator,
after adding it.

This operator is simple, with only a few
parameters.

2. On the Shape Facing 01 rollout, in the Look At
Camera/Object group, click the button labeled
“None,” and then press H on the keyboard.
Choose Camera01 from the list.

This makes the particles face Camera01
throughout the animation.

3. In the Size/Width group, keep the default
choice of In World Space and set Units to 5.
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The World Space option lets you specify
an absolute value. The other choices work
differently. In Local Space works from existing
scale. In Screen Space makes a constant value
based on a percentage of screen width, so the
particles are always the same size regardless of
their distance from the camera.

4. In the Uniqueness group, set the Seed to 235.

5. In the Missile Smoke Trails event, highlight the
Display 02 operator.

6. On the Display 02 rollout, change the Type to
Geometry.

One problem exists, though: The particles are all
the same size. Ideally, you’d want the particles
to scale up over time. In Particle Flow, you have
very explicit control over animating parameters.
They can be animated over absolute time, event
time, or particle age. In this case, you’ll want to
animate the particles scaling up over the life of the
particle. This is done with a Scale operator with an
animated scale channel.

Add a Scale operator:

1. Add a Scale operator just below the Shape
Facing operator, then click it to display the
rollout.

2. On the Scale 01 rollout, change Type to Relative
First.

The operator lets you specify a different
scaling value for each of the three axes, so
you can animate them individually to create a

non-uniform scale. In this case, though, you’ll
animate scaling on all three axes together, so
make sure Constrain Proportions is on.

3. In the Uniqueness group, set Seed to 16948.

Next, you’ll animate the Scale Factor. Since the
smoke trail particles live for approximately 120
frames, you’ll set a key at frame 120.

4. Go to frame 120.

Animate the scaling:

1. At frame 120, click the Auto Key
button to turn it on.

2. On the Scale 01 rollout, in the Scale Factor
group, change the X% value to 200.

This will automatically set a key for each axis
channel at both frame 0 and the current frame.

Tip: Another way to do this is to right-click
the parameter field and choose Show In Track
View. This opens the Curve Editor with this
track isolated. There, you can set keys and do
whatever you want with them.

You’ll explore this technique in a few minutes;
you needn’t experiment with it now.

3. Turn off Auto Key.

Adjust the scale parameters:

Next, you will adjust the variation of the scale and
the animation offset keying.
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1. On the Scale 01 rollout, in the Scale Variation
group, change the Scale Variation X % value
to 10.

Because the proportions of three Scale Variation
settings are constrained, Y % and Z % change
as well.

2. In the Animation Offset Keying group, set Sync
By to Particle Age.

This is important because it controls how
keyframed parameters are passed to the particle
system.

Note: If you used Absolute Time, the particles
would all start at 100 percent at frame zero, and
scale to 200 percent at frame 120, regardless of
when they were emitted. Particles emitted after
frame 120 would always be scaled 200 percent.
In this case, however, you want these keys to
be relative to the life of the particle. So you use
Sync By Particle Age, and the scale starts at 100
percent and increases to 200 percent by the
time the particles die.

Wire the smoke trails to the missiles:

Since this event isn’t connected to any other events,
it isn’t doing anything yet. You’ll connect the trails
and the missiles.

1. In the event display, drag from the output of the
Spawn 01 test to the input of the Missile Smoke
Trails event.

This wires the missiles to the trails, so the
missiles will spawn the smoke trail particles.

2. Turn the particle system back on: Press the
semicolon key (;) or click the light bulb icon
in the title bar of the global event (Guided
Missile).

Now, if you play the animation in the Camera
viewport, you’ll see the quad polygons emitted
and aligned constantly.
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Adjust the key interpolation:

There’s a problem in that the keys for the scaling
are interpolated linearly, in a constant fashion.
To look realistic, the scaling animation should
decelerate as the scaling increases.

A simple way to do this is in the Curve Editor, with
the Key Info dialog. If you set the key interpolation
to Fast, the software will create a curve that
gradually tapers off as it approaches the frame 120
key.

1. In Particle view, right-click the Scale Factor X
% parameter field on the Scale 01 rollout, and
choose Show In Track View.

The Curve Editor appears, displaying the curve
for the scaling track.

Tip: If necessary, use Zoom Value Extents to see
the curve.

2. Click the key at frame 120, then right-click to
display the Key Info dialog.

3. Change the In interpolation to Fast.

4. Use the right-pointing arrow between the
In and Out interpolations to copy the Fast
interpolation to the Out value as well.

5. Click the right-pointing arrow to the right of
the Out box to copy the Fast interpolation to
the In value of key # 1. Click the left-pointing
arrow to the left of the In box to copy the Fast
interpolation to key # 1’s Out value, as well.

6. Repeat this process for the Y Scale Factor track,
and again for the Z Scale Factor track.

7. Close Track View.

Apply a material:

When you created the missile particles, they
inherited mapping and materials from the
geometry because you used instanced geometry.
This is not the case with the Smoke Trail particles.
You’ll have to assign a Material operator to this
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event. There are three choices: Static, Dynamic,
and Frequency. Because the material is animated,
you’ll need to use Dynamic.

1. Add a Material Dynamic operator just below
the Scale Operator in the Missile Smoke Trails
event.

2. On the Material Dynamic 01 rollout, confirm
that Assign Material is on, then click the button
labeled “None.”

3. In the Material/Map Browser, change Browse
From to Mtl Editor.

Now you can see all the materials that are in the
Material Editor.

4. Choose the smoke material, and click OK.

5. Make sure Assign Material ID is on.

The reason for using Dynamic instead of Static
is primarily because the material is going to
be animated over the age of the particle. The
material itself isn’t animated, but it uses a
Particle Age map as a mask for the opacity.
When used in a Material Dynamic operator,
it will apply this map over the life span of
the particle, creating a gradual shifting of
the opacity from white to black (opaque to
transparent).

Save your work:

• Save your work to myguided_missile_
trails.max.

Now if you scrub the animation, the missiles will
be trailing particles behind as they fly to their
targets.

There’s still a problem, however: The missiles
travel right through the teapots.

To activate a new event when they reach their
target, you will need to wire the output of the
Find Target operator to something. This could be
anything, even something as obscure as a Script
operator that turns on lights or increases the scale
of the teapots every time there’s a collision. In the
next lesson, you’ll add another spawning event
that creates an explosion of particles.

Creating an Explosion on Impact

When the missile particles reach their target, you’ll
need a new event for an explosion. In this lesson
you’ll create this event using a Spawn operator.
You’ll repeat the same techniques you used to
create the smoke trails here, with some slight
variations.
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Set up the lesson:

1. Continue from the previous lesson, or open
guided_missile_explosion_start.max.

2. If you do open the provided file, select the
particle emitter in the viewport, then press 6 on
the keyboard to display Particle View.

Create a Spawn operator:

1. Drag a Spawn test from the depot into the event
display.

This creates a new event.

2. Rename the resulting new event Explode.

Set the parameters for the explosion:

1. On the Display 03 rollout, change the Type to
Circles, and change the color to orange.

This spawn operation will be a bit different
than the one used to create the smoke trails,
primarily in that it’ll kill the original missile
particle and create a single burst of particles.

2. Click the Spawn test in the Explode event and
turn on Delete Parent.

3. Set Offspring # to 50 with a Variation % of 10.

This will cause from 45 to 55 particles to be
spawned whenever a particle (missile) is passed
to this event.

Next, you’ll set the speed, variation, and
divergence.

4. In the Speed group, set the Inherited % value
to 20.

5. Set Variation % to 30 and Divergence to 60
degrees.

This will cause the speed of the exploding
particles to be directly related to the speed of the
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incoming particle that causes the spawn. The
Divergence angle is used to create a widespread
pattern, not just a stream of particles.

Add forces:

Next, you’ll add a drag force to the explosion.

1. From the depot, drag a Force operator to
bottom of the Explode event. Highlight the
Force operator to display its rollout.

2. Click the By List button and then choose the
Drag01 space warp, then click Select.

The Drag01 space warp appears in the list.

Add a Delete operator:

Finally you will add a Delete operator with a short
life span. This will cause the explosion particles
to die in roughly two seconds, rather than linger
forever.

1. Add a Delete operator to the bottom of the
event, and then highlight it to display the
rollout.

2. In the Remove group, choose By Particle Age,
set Life Span to 48 and Variation to 8.

3. In the Uniqueness group, set the Seed to 31886.

Like the Smoke Trail particles, these explosion
particles can be represented geometrically by

facing shapes. You’ll use a Shape Facing operator
to accomplish this.

Add a Shape Facing operator:

1. Add a new Shape Facing operator just below
the Force operator. As before, highlight the
operator after creating it, to display its rollout.

2. In the Look At Camera/Object group, set
Camera01 to be the selected object.

3. In the Size/Width group, keep the default In
World Space choice, and set Units to a value of
300.

4. Set Orientation to Align To Speed Follow.

This will cause the shape alignment to be based
on the direction of travel, which works well
for explosive and bursting effects. You can see
the difference if you set the display type in this
event to Geometry. The shapes still face the
camera, but they are oriented to the direction
of travel and not the World Z axis.

5. In the Uniqueness group, set Seed to 235.

Wire the explosion to the Find Target test:

1. In the event display, locate the Find Target
output in the Launch Missiles event.
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2. Drag from the Find Target 01 test output to
the input of the Explode event to wire the two
together.

When a missile finds its teapot target, it spawns an
explosion.

As before with the smoke trails, you’ll need to scale
these particles up over the age of the particles so
they don’t appear instantly.

Add and animate a Scale operator:

1. Add a Scale operator to the Explode event, just
below the Shape Facing operator.

2. Set its Type to Relative First.

Just like the smoke trails, you’ll want to animate
the facing particles. In this case, however, you
want to scale from 10 to 100 percent, so setting
the keys is a little trickier than before.

3. Because the explosion particles die after about
48 frames, move the time slider to frame 48.

4. Now turn on the Auto Key button.

5. On the Scale 02 rollout, in the Scale Factor
group, SHIFT+right-click the spinner arrows
for the X % field.

This automatically sets a key for all three
channels at frame 0 and frame 48.

6. Now, with the Auto Key button still activated,
go to frame 0 and change the value to 10
percent.

You now have uniformly scaling animation
from frame 0 to 48.

7. Turn off the Auto Key button, so you
don’t key any more parameters.

8. Set Scale Variation % to 10 and the Sync By
method to Particle Age.
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9. Lastly, as before, right-click the X % Scale field
and choose Show In Track View.

10.Click the scale key on the left side of the curve.
A handle becomes visible to the right of the
key. Move the handle so the curve resembles
the illustration.

11.Repeat the previous step for the Y Scale Factor
and X Scale Factor tracks.

12.Close Track View.

The final steps are to add another Material
operator and assign a material to the particles.

Add a Material Dynamic operator:

1. In the Explode event, add a new Material
Dynamic operator below the Scale operator.
Highlight the operator to view its parameters.

At this point, your particle diagram should
resemble the following illustration.

2. On the Material Dynamic rollout, click the
button currently labeled “None.”

The Material/Map Browser appears.

3. In the Browse From group, choose Mtl Editor
if necessary.

4. Assign the Flames material, and confirm that
Assign Material ID is turned on.

Flames material

This material is similar to the smoke material
in that it’s a face-mapped material that uses
gradient and opacity driven by particle age.
When mapped to particles with a relatively
short life, it creates an explosive fire-type effect
that fades off quickly like an explosion.
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5. In the Material Editor, turn on Show Map
In Viewport.

6. In the Uniqueness group, set Seed to 14505.

Save and render:

1. Save your file to myguided_missile_
complete.max. If you prefer, you can load the
provided file, guided_missiles_render.max for
comparison.

2. Now you can render your file to see the results.
Choose Rendering > Render.

3. On the Common Parameters rollout, choose
Active Time Segment, if it isn’t already turned
on.

4. Render the animation to a file and format of
your choosing.

5. When the rendering is finished, choose File >
View Image File to play your animation. Or
you can load guided_missile.mov and play it
to compare.

Note: Your results might not be precisely the
same as this: It will depend on how you adjust
the key interpolation parameters, and the size
and placement of the emitter.

Summary

A single particle system in Particle Flow can
comprise a number of entirely disparate particle
types, such as missiles, their smoke trails, and the
explosions when they hit their targets, and you
can assign different behaviors and looks to each
element of the event-driven system.



Controlling Foliage with
MAXScript

Using Scripts for Effects
MAXScript is the powerful scripting language
included with 3ds Max. You can use MAXScript to
create custom commands, along with dialogs and
buttons to execute the commands. If you find that
you execute the same sequence of commands over
and over again during your work process, you can
use MAXScript to create a custom dialog or button
that will execute the sequence for you.

You can write a custom MAXScript with a
minimum of programming knowledge. Many
tools are available to help you create scripts, such
as templates and existing scripts that come with
3ds Max.

Features Covered in This Tutorial

This tutorial shows you how to use MAXScript to
create and edit scripts to speed up your workflow.
No prior experience with MAXScript is necessary
to do this tutorial.

Note: To learn more about creating scripts with
MAXScript, see the tutorial , or see Learning
MAXScript in the MAXScript Reference.

Files for This Tutorial

The files for this tutorial are on the Tutorial
Files CD that ships with 3ds Max 8in the
\tutorials\scripting_fx folder. Before doing the
tutorials, copy the \tutorials directory from the CD
to your \3dsmax8 local installation.

Skill Level: Advanced

Time to complete: 1 hour

Creating a Camera Manager

In this lesson, you will create a dynamic dialog with
a button for each camera in the scene. Clicking a
button will set the active viewport to show the view
from the corresponding camera. You will then
modify the script to make it select the camera and
open the Modify panel in addition to changing the
active view. You will also add a button to update
the dialog. Finally, you will convert the script to a
toolbar button for easy access.

The files for this lesson can be found in the
\tutorials\scripting_fx folder.

MAXScript

maxscript.chm::/learning_maxscript.htm
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Prepare the scene:

At the end of this lesson, you will create a custom
button for the script. To prepare for this, you will
need to copy the custom icon files to your UI/Icons
folder.

1. Copy the following files to your
3dsmax8/UI/icons folder:

• Camera_Manager_24a.bmp

• Camera_Manager_24i.bmp

• Camera_Manager_16a.bmp

• Camera_Manager_16i.bmp

2. Restart 3ds Max.

You must restart 3ds Max at this point in order
to make the custom icons show up in the
program later on.

3. Open the file tut_camera_manager_start.max.

This is a scene with a teapot, two target cameras,
and one free camera.

Run the initial script:

Now you will open and run a standard MAXScript
called tut_camera_manager.ms.

1. Go to the Utility panel.

2. Click the MAXScript button.

3. In the MAXScript rollout, click the Run Script
button.

4. Choose the script tut_camera_manager.ms.

A dialog appears with three buttons labeled
Camera01, Camera02, and Camera03.

5. Activate the Top viewport.

6. In the Camera Manager dialog, click the
Camera01 button.

The active viewport displays the Camera01
view.

Inspect the script:

1. Choose MAXScript menu > Open Script.

2. Open the file tut_camera_manager.ms.

A color-coded, MAXScript Editor window
appears. Comments are green, reserved
words are blue, and string literals are red.
Color-coding makes the code much easier to
read.

Tip: To update the color-coding, click CTRL+D.
Updating the color-coding is necessary if you
copy and paste text into the script, or if you add
text within a comment block. A comment block
begins with /* and ends with */. Everything
in between is treated as a comment, and is
not executed by the script. Also, any line
beginning with a double hyphen (--) is treated
as a comment.

The script creates a dialog dynamically (based
on circumstances in the current scene). This
is done by searching the scene objects for
cameras, and building a string that is a script in
itself. This new string is then executed to create
the dialog.
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This approach is necessary when the script
must run on conditions not known beforehand.
This is the case here, since the initial script
must search the scene for cameras before it
can generate the dialog. In addition, a new
script must be generated if cameras are added,
deleted, or renamed.

3. Look at the script in the listener and identify
these components:

• Header - The script begins with a header,
containing information about the script
such as its name, author, date, and purpose.

• Fn genScriptStr - The script contains one
function called genScriptStr. This function
searches the scene for cameras and generates
the script that displays the dialog.

• The script ends with a call to the function.

The function is commented to help you
understand the operation of the code.
Comments appear in green.

4. Read through the function comments to get an
idea of the sequence of events in the function.

The following comments will help you identify
the parts of the function:

• Build an array of cameras in the scene.

• Calculate the dialog height based on the
number of cameras detected.

• Initialize the dialog definition string.

• Loop through the camera array, building the
buttons and events.

• Increment Counter

• Add buttons & events to the existing string

• Close the dialog definition.

• Close the dialog, if it is already open, then
open the dialog.

• Return the string.

5. On the MAXScript window, choose File
menu > Save As, and save the script as
my_camera_manager.ms.

Modify the script:

Now you will modify the script to not only put the
camera view in the active viewport, but to also
select the camera and open the Modify panel. This
will allow you to quickly access a camera so you
can change its parameters.

1. In the MAXScript window, locate the following
line:

2. After this line, starting on a new line, add the
following two lines:

Note: If you copy and paste from the help file
to the script, you will have to add the carriage
return between the lines manually before
continuing. The difference between the fonts
in the existing and pasted text will not cause a
difficulty in the script.

3. On the MAXScript window, choose File menu
> Save As, and save the modified script as
my_camera_manager_mod.ms.

You can also find the modified script in the file
tut_camera_manager_mod.ms.

Test the modified script:

1. With the MAXScript Editor open, press
CTRL+E.

This evaluates (runs) the script. If there are no
errors, the script runs and the Camera Manager
dialog appears. There are three buttons labeled
Camera01, Camera02, and Camera03.

2. On the Camera Manager dialog, click the
Camera01 button.

The active viewport is set to show the Camera01
view, Camera01 is selected, and the Modify
panel is accessed.

If the script encounters an error while running,
the cursor will be positioned on the line of code
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where the error might have occurred. You can
also look at the Listener for information on the
error. If the Camera Manager dialog does not
appear, scroll through the script and look for
the line where the error occurred. Repair the
error, then run the script again with CTRL+E.

3. Close the Camera Manager dialog.

Modify the script to update the dialog:

Next, you will modifying the script again, this
time to add a new button to the dialog called
Update. When clicked, this button will search
the scene again and generate the camera buttons
based on the current scene status. Updating will
be necessary if cameras are added, deleted, or
renamed.

First, you will expand the size of the dialog to
accommodate the new button.

1. Locate the following line:

2. Change this line to:

Now you will add the button itself to the dialog.
After the button definition, you will add the
code that specifies what will happen when
the button is pressed. The script will close
the Camera Manager dialog if it is open, then
call the genScriptStr function to create a new
script.

3. Find the following lines:

4. Add the following lines after the open
parenthesis:

5. On the MAXScript window, choose File menu
> Save As, and save the modified script as
my_camera_manager_update.ms.

You can also find the modified script in the file
tut_camera_manager_update.ms.

Run the modified script:

1. With the MAXScript window active, press
CTRL+E to evaluate and run the script.

The Camera Manager dialog appears. There
are now four buttons, the three camera buttons
and an Update button.

2. Click Camera01 to select this camera.

3. Delete Camera01.

4. Click the Update button.

The Camera Manager dialog is updated.
Camera01 no longer appears in the dialog, and
the dialog has been resized accordingly.

5. Close the Camera Manager dialog.

Inspect the script string:

The technique of writing a script that generates
and runs another script is very powerful and
versatile. You can use it to run a script on an
unknown number of objects.

Now you will inspect the string generated by the
script. To do this, you must use the MAXScript
Listener. This window allows you to run a single
line of code by entering the code and pressing
SHIFT+ENTER. It also shows you the result of
executing the line.

1. Choose MAXScript menu > MAXScript
Listener.

A MAXScript Listener window appears with
the results of the script. If you encountered
errors, the reports of those errors appear.
Otherwise, a series of OKs and a few other
commands appear in the Listener.
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2. Enter the following line in the MAXScript
Listener window:

Press SHIFT+ENTER after entering the line.

A new MAXScript window opens, displaying
the contents of the string generated by the
genScriptStr function.

3. Inspect the script.

In the script, you can see the commands that
create the rollout. If you like, you can compare
this script to the original code, and associate
the commands in the original script with the
new script.

4. Close the Listener and the MAXScript window
that contains the generated script, but leave the
MAXScript window with the original script
open.

Turn the script into a toolbar button:

Next, you will turn the script into a toolbar button.
This will provide quick access to the camera
manager script.

1. Locate the Render Scene button on the
Main Toolbar.

2. In the MAXScript window, select all the text of
tut_camera_manager_update.ms.

3. Drag and drop this text onto the Toolbar
next to the Render Scene button.

A button appears with the icon of a page
of text. This is the default macro button.

4. Run the script by clicking the button.

Change the icon on the button:

At the beginning of this lesson, you copied four
BMP files to your UI/Icons folder. These image
files hold a custom icon for use on the Camera
Manager button.

First, you will open one of the images to see what it
looks like.

1. Choose File menu > View Image file. Browse
to the UI/Icons folder and open the file
Camera_Manager_24i.bmp.

This file contains an image created in a paint
program from existing camera buttons. It
features two cameras, one behind the other,
and red and yellow accents to set it apart from
other camera buttons.

The four files you copied earlier hold just this
one icon image represented in several ways.
To make a custom image or set of images, you
need a series of four files, each beginning with
the same prefix which designates the icon name
or group. For the camera manager script, there
are four files, each beginning with the prefix
Camera_Manager:

• A 24x24 image for use when large icons are
displayed. Suffix: _24i.bmp.

• A 24x24 grayscale image showing the
transparency of the 24x24 image, with
black pixels indicating see-through areas
where the gray button background will show
through. Suffix: _24a.bmp.

• A 16x15 image for use when small icons are
displayed. Suffix: _16i.bmp.

• A 16x15 grayscale image showing
transparency of the 16x16 image. Suffix:
_16a.bmp

To create a custom button icon or icon set, you
can create these images in any paint program.

Next, you will replace the default macro button
image with the custom icon.
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2. On the Main Toolbar, right-click the
default macro button, and choose Edit Button
Appearance from the pop-up menu.

The Edit Macro Button dialog appears.

3. Choose the Image Button radio button.

4. From the Group list, choose Camera Manager.

The icon represented in the Camera_Manager
file series appears. Upon startup, 3ds Max looks
in the UI/Icons folder for sets of files with the
same prefix, and creates an icon group for each
set. This makes the custom icon available on
the Edit Macro Button dialog.

By creating BMP file sets and copying them to
the UI/Icons folder before starting 3ds Max,
you can assign custom icons to any button in
the scene.

5. For Tooltip, enter Camera Manager.

6. Click OK.

The button on the toolbar now shows the
custom icon.

When you make an independent MAXScript
into a toolbar button, the script is automatically
changed to make it into a macroscript. A
macroscript is a script that functions as a
macro, or an executable series of steps. The
macroscript is very similar to the independent
MAXScript, but has a few extra commands to
make it possible for the script to execute when
the button is pressed.

7. Right-click the new toolbar button, and
choose Edit Macro Script from the pop-up
menu.

The macro script is opened in a MAXScript
Editor window. The drag and drop process has
automatically created a macroscript named
DragAndDrop-Macro##.mcr, where ## is
the next sequential number for macroscripts
created with the drag-and-drop method.

The original script text now appears in
between opening and closing parentheses.
The macro script definition starts with
two optional keyword parameters:
Category:”DragAndDrop”, and Tooltip:””.

Save a custom UI scheme:

To cause the Camera Manager button to appear
the next time you run 3ds Max, you must save the
current user interface to a UI file.

1. Choose Customize menu > Save Custom UI
Scheme.

2. Save the UI as CamMgr.ui.

You can load this UI anytime to display the
Camera Manager button.

Enhancing the Unhide Command

When working with large scenes in 3ds Max, you
will often have the need to hide and unhide objects
to keep viewports uncluttered and facilitate your
workflow. In this lesson, you will learn how to
create a script that enhances the unhide tool. The
script will allow you to unhide objects, select them,
and zoom to the selected objects with one mouse
click.

When you need a custom script, you can often
find a similar script from various sources on the
Internet. However, you will often want to change
the user interface, or pull out parts of a larger
script to make a custom script. This lesson will
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show you how to take an existing function and
build a custom user interface for it.

First, you will create a utility script that performs
the unhide, select, and zoom functions. Then you
will convert this utility to a dialog.

Prepare the scene:

First, you will run an existing version of the script
on a test scene to see how it works.

1. Open the file tut_unhide_plus.max from the
tutorials\scripting_fx folder.

This is a simple scene with a 5x5 array of
spheres, and with additional spheres hidden.

Next, you will run the script. This script is
designed to be run on the Utilities panel.

2. On the Utilities Panel, click MAXScript.

3. Click Run Script, and choose UnhidePLUS-
Utility.ms.

4. Choose UnhidePLUS from the MAXScript
rollout > Utilities drop-down list.

Two rollouts appear in the Utility panel, both
named UnhidePLUS.

Try out the script:

Now you will try out the utility to see how it works.

1. In the UnhidePLUS Tools rollout, click Unhide.

The Unhide Objects dialog appears.

2. Double-click Sphere06 to unhide it.

Sphere06 is unhidden and selected.

3. In the UnhidePLUS Tools rollout, turn on Add
to Current Selection.

4. Click the Unhide button, and double-click
Sphere07.

Sphere07 is unhidden and selected, and added
to the current selection containing Sphere06.

5. Under Zoom Selected to Viewport, choose the
Active option.

6. If the Top viewport is not the active viewport,
right-click the viewport to make it active
without losing the current selection.

7. Click Unhide, and double-click Sphere08.

Sphere08 is unhidden and selected, and added
to the current selection. The active viewport is
zoomed to the selected objects.

8. Under Zoom Selected To Viewport, choose All.

9. Click Unhide, and double-click Sphere09.
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Sphere09 is unhidden and selected, and added
to the current selection. All viewports are
zoomed to the selected objects.

Inspect the script:

Now you will open the script and inspect its
contents.

1. On the Utilities panel > MAXScript
rollout, click Open Script. Open the file
UnhidePLUS-Utility.ms.

The script contents appear in a MAXScript
window.

2. Look through the script and read the comments
to get an idea of the script’s operation.

In addition to commands, the script contains
numerous comments (explanatory text that is
not interpreted by MAXScript). Comments
appear on lines between the symbols /* and */,
or are preceded by two hyphens (--).

3. Scroll through the script, and use the comments
to locate the following elements:

• Header – Basic information such as the
script name, author’s name, the date the
script was created, and its purpose.

• The unhidePLUS function - This function is
the heart of the script. It performs the work
of unhiding the objects, selecting them, and
zooming the viewport.

The utility/rollout section contains several
parts:

• Rollout definition – The rollout definition
contains three sections: variables, UI control
items, and rollout events. There are two
check boxes, one radio button, and one
button UI control item. There is one rollout
event which is for the Unhide button.

• Utility events – Within the rollout definition
are two utility events. One adds the rollout

when the utility is opened, and the second
closes the rollout when the utility is closed.

When you create a utility script, it automatically
creates a rollout with a Close button. The
rollout definition in the script pertains to
the UnhidePLUS Tools rollout, which is
placed on the Utilities panel below the default
UnhidePLUS rollout when the script is run.

4. Look more closely at the unhidePLUS function.
Using the comments as a guide, locate the
sections that unhide the objects, select them,
and zoom to the selected objects.

Load the template:

Now you will recreate the script using a template.
The template has placeholders for all the elements
needed to create a script.

1. Reset 3ds Max.

2. In the Utilities panel, click Open Script, and
open the file Template-Utility.ms.

3. Look over the code and locate the parts of the
template.

• Header

• Functions

• Utility definition

• Rollout definition: variables, UI Control
Items, rollout events

• Utility events

The template saves time when you’re creating a
new script. Writing the script is simply a matter
of filling in each of the placeholders.

4. Save the script as my_unhide_utility.ms.

Saving the script now will prevent you from
accidentally overwriting the template.

Fill in the header:

The template’s header provides a basic layout for
a header, with entries for filename, version, and
other details.
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1. In the MAXScript window, replace FILENAME
with the text my_unhide_utility.ms.

2. Replace ## with 01.

3. Replace AUTHOR_NAME with your name.

4. Replace MM.DD.YY with the current date.

5. Replace INSERT_PURPOSE with a brief
description of the script’s purpose, in your own
words.

Add an existing function to the template:

1. On the MAXScript window, click File
menu > Open Script, and open the file
UnhidePLUS-fn.ms.

This file contains the code that unhides the
objects, selects them, and zooms the viewport.

2. Select all the text from -- FUNCTION
(unhidePlus) to the line after redrawViews()
(include the last lone close parenthesis in your
selection).

3. Copy the text to the clipboard using CTRL+C.

4. In UnhidePLUS-Utility.ms, select the text --
INSERT_FUNCTION. Replace this text with
the copied text by pressing CTRL+V.

The function is in place, but there is no user
interface to call it. You will build the user
interface yourself from scratch.

Fill in the utility and rollout declarations:

The utility and rollout declarations set the name of
the utility, and the rollout name that will appear on
the Utilities panel.

1. Replace UTILITY_TITLE with UnhidePLUS.

The utility title sets the name that appears in
the Utilities panel drop-down list, and also the
name of the automatic rollout that contains the
Close button.

The variable utl_UNAME is used to refer to
the utility within the script. You will replace

this placeholder with the internal name utl_up,
where up stands for Unhide Plus.

2. Replace all occurrences of utl_UNAME with
utl_up.

Tip: To automate this process, press CTRL+H
to access the Replace dialog.

3. Replace ROLL_TITLE with UnhidePLUS
Tools.

The rollout title sets the title of the custom
rollout that contains the buttons and controls
created by the script.

4. Replace all occurrences of rol_RNAME with
rol_up.

The variable rol_up is the internal pointer to
the rollout.

This function doesn’t require any variables, so
you will not add any code to the VARIABLES
section.

Fill in the rollout information:

Next you will define the UI (user interface) items
for the rollout. The items appear on the rollout in
the order in which they are defined.

When defining UI items, each line of code contains
the following parts:

• The type of UI item being defined, such as
button, check box, or radio button series.

• The label for the UI item as it appears on the
rollout.

Additional defining parameters can be added to
the line to define the item’s status, its size, and
other aspects of the UI item.

1. Under -- UI CONTROL ITEMS, add the
following line:

This adds a check box with the internal name
cbx_sel. It will appear on the rollout with the
label Select on Unhide, and it will be checked
by default when the script is loaded.
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2. After the line you just entered, add the following
lines:

The radiobuttons command requires more
information than the checkboxes command.
The labels parameter sets the radio button
names, while the columns parameter places the
radio buttons in three columns to make them
appear on the same line. Only one variable is
needed to hold the item’s status.

The button command simply adds a button
and defines its label and size. You will define
what the button does in the EVENTS section.

3. After -- ROLLOUT EVENTS, add:

These lines of code declare the event. When the
Unhide button is pressed, the code between the
parentheses will be executed. This is the only
event in the rollout.

4. After the first parenthesis, add:

This line calls the unhidePlus function. The
UI control items are passed as arguments. The
function uses these values to determine which
options to perform.

5. Save the script as my_unhide_utility.ms.

Test the Script:

1. In any viewport, create several objects of any
kind.

2. Hide at least three of the objects.

3. On the MAXScript window, press CTRL+E to
evaluate (run) the script.

4. Choose UnhidePLUS from the MAXScript
rollout > Utilities drop-down list.

If the script is working correctly, the
UnhidePLUS and UnhidePLUS Tools rollouts
will appear on the Utilities panel.

If the script does not function as expected, this
means an error has occurred. In the MAXScript
window, the cursor will be positioned on or
near the line where the error occurs. Check the

script against this lesson, or compare it with
UnhidePLUS-Utility.ms.

5. When the script is running correctly, test the
options by unhiding objects with various
settings.

Convert the utility to a dialog:

Now you will modify the script to run from a
dialog rather than the Utilities panel.

1. Continue with the script you have been editing,
or load the file UnhidePLUS-Utility.ms.

2. After the comment marker /*, change the first
two lines of the header to the following:

Now you will replace the utility declarations
with those for a dialog.

3. Delete the following:

• Utility utl_up "UnhidePLUS"

• The open parenthesis on the next line

• --UTILITY EVENTS through -- Note: A
Utility is 180 pixels wide.

To create the dialog, you will make use of the
information you have already set up for the
rollout rol_up.

4. Add the following after the line )--end rol_up:

This will cause all the information that
previously appeared on the UnhidePLUS Tools
rollout to appear on the dialog.

Now you will add error handling to remove any
existing dialog before creating a new dialog.
This ensures that multiple instances of the
dialog are not created.

5. Just before the line — end functions., add:

6. Save the script as my_unhide_dialog.ms.

7. To test the script, press CTRL+E to run the
script. The UnhidePLUS Tools dialog should
appear, with all the tools that were available on
the Utilities panel.
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If the script does not function as expected, this
means an error has occurred. In the MAXScript
window, the cursor will be positioned on or
near the line where the error occurs. Check the
script against this lesson, or compare it with
UnhidePLUS-Dialog.ms.

With the techniques you have learned here, you
can create your own custom scripts based on
existing functions.

Summary

You can use scripting to create custom tools that
suit your own workflow. You can start off with
existing templates and functions, and customize
the scripts to access frequently-used tools and
commands.

If you want to try out another MAXScript tutorial,
see .
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Asset Tracking

Using Asset Tracking

Asset management can be accomplished directly
from 3ds Max using two features:

• Open from Vault

• Asset Tracking

These features provide direct access to Asset
Tracking Systems (ATS). ATS are programs such
as:

• Autodesk Vault

• Perforce

• SourceSafe

These ATS applications provide a variety of
features such as version control and tools
for backing up project assets. Typically, ATS
applications are employed in a networked team
environment where assets are shared amongst
members.

The Asset Tracking feature in 3ds Max can be
used independently of external ATS applications.
For example, it can be used to modify paths for
bitmaps and xrefs. If you do have an external ATS
setup on the network, then the Asset Tracking

Feature can also be used to directly access these
applications. 3ds Max includes Autodesk Vault.
The Asset Tracking Feature of 3ds Max can be used
to access items from Autodesk Vault directly.

Skill Level: Advanced

Time to complete: 2 hours

Features Covered in this Tutorial

• Revising Asset Paths

• Creating a new vault

• Logging into the vault using 3ds Max

• Setting a Working folder

• Adding files to the vault

• Checking files in and out of the vault

• Checking version history

• Checking files out of the vault

Tutorial Files

All the necessary files to do the tutorials can
be found on the Tutorial And Sample Files CD,
in the \tutorials\asset_management\ folder,
unless otherwise specified. Before beginning the
tutorials, copy the \tutorials directory from the CD
to your \3dsmax8 local installation.

Project Management
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In this Tutorial

Using Asset Tracking to Revise Asset Paths (page
2–938)

Creating a New Vault (page 2–940)

Logging into the Vault Server from 3ds Max (page
2–941)

Setting the Working Folder (page 2–942)

Adding Files to the Vault (page 2–942)

Changing the File (page 2–944)

Checking the File back into the Vault (page 2–944)

Checking Version History (page 2–945)

Checking Files Out of the Vault (page 2–945)

Using Asset Tracking to Revise
Asset Paths

Although the majority of the Asset tracking
features are designed to work in conjunction with
Autodesk Vault, (or another ATS system) you can
modify asset paths independently of any external
applications. This can be a very helpful feature.

1. Create a new folder called Exercise at the root
level of a drive.

2. Copy the six files from the Tutorial Exercise
Folder to your new Exercise folder, that is, Full
House.max and the five *.JPG files.

3. Open Full House.max.

4. The file contains five playing cards, each of
which has a material that references one of the
five bitmaps.

In this section, you are going to rearrange
the files into folders and then use the Asset
Tracking feature to indicate the new paths for
the bitmaps.

5. Exit 3ds Max.

6. Open Windows explorer and navigate to your
Exercise folder.

7. Create two new folders. Bitmaps and Scene.

8. Move the .jpg files into the Bitmaps folder and
Full House.max into the Scene folder.

9. Start 3ds Max.

10.Open Full House.max from the Scene folder.

11.You receive a message indicating that the
bitmap files were not located.



Using Asset Tracking to Revise Asset Paths 939

12.Click Continue.

13.From the file menu, select Asset tracking.

14.The Asset Tracking dialog shows the external
files used by Full House.max and indicates they
are missing.

15.Highlight AC.jpg in the list.

16.From the Paths menu, select Set Path.

17. In the Specify Asset Path dialog, press the
ellipsis button.

18.Navigate to the \Exercise\Bitmaps folder and
click Use Path.

19.The new path appears in the dialog.

20.Click OK to close the Specify Asset Path dialog.

21.Press ~ to refresh your scene. The bitmap
appears in the viewport.

22.Close the Asset Tracking dialog.

23.Press M to open the Material Editor.

24. Click Get Material.

25.Select Scene in the Browse from Group.
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26.Double click the Ace of Clubs material.

27. Click the diffuse
map button in the Maps rollout.

28.The Bitmap button in the Bitmap
Parameters rollout indicates the correct new

path.

Note: The root drive may be different on your
system.

29.Close the Material Editor and Material Map
Navigator.

30.From the File menu, select Asset Tracking.

31.Press and hold the CTRL key and click on the
remaining .JPG files.

32.From the Paths menu, select Set Path.

33.Indicate the new bitmap location.

34.The remaining images appear.

35.Close the Asset Tracking dialog.

36.Exit 3ds Max without saving.

Next

Creating a New Vault (page 2–940)

Creating a New Vault

In this section you will use Autodesk Vault
Manager to create a new Vault. A vault is a location
where files shared by a project team will be located.

Note: This section assumes you have Autodesk
Vault installed on your system. Refer to the
3ds Max installation disk to learn how to install
Autodesk Vault.

1. From Windows Start menu navigate to the
Autodesk program group and open Autodesk
Vault Manager.

2. At the Log In dialog enter your User Name
and Password. By default the user name is
Administrator and the password is blank.
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3. Highlight the Master Vault, (named Vaults).

4. Click Actions > Create Vault.

5. Enter FullHouse as the name for the new vault.

6. The Default File Store Location is where
Autodesk Vault maintains the project files. The
location may be different than that shown.

7. The file store can be located in a default
location, or a new location can be specified.

Click OK to create the new vault with the default
file store location or click Select File Store
Location to specify a new location. Click OK.

The file store is where the vault database stores
the master files that will be shared by all team
members. The location will typically be on a
remote server.

Next

Logging into the Vault Server from 3ds Max (page
2–941)

Logging into the Vault Server from
3ds Max

1. From the File menu, select Asset Tracking.

2. From the Server menu select Log in.

3. Click the ellipsis button adjacent to the
Database dropdown list.

4. Highlight the FullHouse database and click OK.
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5. Click OK to close the Vault Log In dialog.

6. Close the Asset Tracking dialog.

Next

Setting the Working Folder (page 2–942)

Setting the Working Folder

The working folder is the location on your local
drive where the files you check out from the vault
will be placed. In this case, you’ll use the Exercise
folder you created earlier.

1. Create a new folder on your local drive called
Exercise2.

2. Copy the files from the /asset_management/
Exercise2 tutorial folder into your new
Exercise2 folder.

3. The Scene folder contains the Full House.max
file similar to the one you used earlier. The
exception is that the five cards are externally
referenced into Full House.max. Each
individual card .max files is contained in the
Xrefs folder. The Bitmaps folder contains the
image files for each card.

4. From the File menu, select Asset Tracking.

5. From the Server menu, select Options.

6. Click Browse from the Vault Options dialog.

7. Navigate to the Exercise2 folder.

8. Click Ok to close the dialog.

9. Close the Asset Tracking dialog.

Next

Adding Files to the Vault (page 2–942)

Adding Files to the Vault

1. From the Exercise2/Scene folder open Full
House.max.

2. From the File menu select Asset Tracking.

3. The dialog displays both the max file and its
dependents. A question mark appears next to
the file because the files are uncontrolled, i.e.,
not associated with Autodesk Vault.
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4. Highlight the Full House.max file in Asset
Tracker.

5. From the File Menu select Add Files.

6. Select the Keep checked out option.

7. Enter a comment for this version of the file.
Since there have not yet been any changes made,
a comment like Base Version is appropriate.

8. Click OK to add the file.

9. From the File menu select Add Files.

10.Enter Base Version in the comment section,
and click OK.

Note: The files now have a circle next to them
to indicate that the vault version is identical to
the local version. A check mark appears in the
circle adjacent to Full House.max because it is
checked out of the Vault.

Next

Changing the File (page 2–944)
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Changing the File

In this step, you’ll make a change to the Full
House.max file that you have checked out.

1. From the Shapes category of the
Create Panel, click Text.

2. Within the Parameters rollout, enter 2 in the
Size field.

3. Enter Full House in the text window.

4. Click in the Perspective viewport to create the
text.

5. Click, and then right-click, the move tool.

Next

Checking the File back into the Vault (page 2–944)

Checking the File back into the
Vault
Check the file into the Vault:

1. Open the Asset Tracking dialog.

2. Highlight the file you have open, i.e., Full
House.max.

3. From the File menu, select Checkin.

4. A warning appears indicating that the scene has
been modified and needs to be saved. Click Yes.

5. Enter Text Added in the comment window for
this version.

Note: The Keep checked out option is not
selected this time.

6. Click OK to close the dialog.
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7. The check mark that appeared next to the Full
House file is removed, indicating it is no longer
checked out.

8. Close the Asset Tracking dialog.

Next

Checking Version History (page 2–945)

Checking Version History
Check version history:

1. From the File menu, select the Asset tracking
dialog.

2. Highlight Full House.max.

3. From the File menu select History.

4. A dialog appears indicating that Full House.max
is on its second version. The Comments field
helps indicate the changes that were made.

5. Close the History dialog.

6. Close the Asset Tracking dialog.

7. From the File menu, select Reset.

8. At the prompt, click Yes.

9. A warning appears indicating that you are
trying to save the file when it’s not checked out.

10.Click No.

11.An IO Error dialog indicates that you cannot
overwrite your local version of the file because
it is read-only.

12.Version control helps ensure the Vault files are
kept synchronized with any local versions.

13.Click Ok to close the IO Error dialog.

14.From the File menu, select Reset.

15.This time click No at the prompt to save
changes.

16.Close 3ds Max.

Next

Checking Files Out of the Vault (page 2–945)

Checking Files Out of the Vault
Opening a file from the Vault:

1. Start 3ds Max.

2. From the File menu, select Open from Vault.

3. The Vault Log In dialog appears.
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4. Enter a User Name, Password, and the Server
containing the database.

Note: By default, the User name is Administrator
and the Password is blank.

5. Select the Database and click OK.

6. The Open File dialog appears. Note that the
folder structure of your local working folder
has been replicated on the vault. This was done
when you added the files earlier.

7. Open the scene folder and select Full
House.max.

8. Click Open.

9. A dialog appears asking if you want to check
the file out before making edits. Click Yes.

10.You are now working with the latest version of
this file (Version 2).

11.From the File menu, select Exit.

The application closes without any prompts
because you have not made any changes.

Summary

In this tutorial, you learned how to revise asset
paths, specifically bitmaps associated with scene
materials. Autodesk Vault Manager was used to
create a new vault. The asset tracking feature was
used to define a working folder for local versions
of vault files. Once vault and working folders are
defined, tools in the Asset Manager can be used
to add, check in, check out, and examine revision
history.
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materials 2–862
mental ray material 2–863
night shader 2–852
ocean shader 2–871
submerge shader 2–871
using a shader as a map 2–846
water surface shader 2–871
wraparound shader 2–849

mental ray connection rollout 2–856
mental ray material

mental ray 2–863
mental ray materials 2–862
mental ray renderer

area lights 2–838
depth of field (DOF) 2–822
final gathering 2–835
global illumination 2–835
motion blur 2–818
reflections 2–810
reflective caustics 2–826
refraction 2–814
refractive caustics 2–831
sampling 2–806
trace depth 2–810

mental ray shaders 2–867, 2–871

merging content into a scene 2–272
merging files 3–111
mesh select modifier 1–108, 1–110
metal shader 1–119
mirror

skin settings 2–426
mirroring 1–102, 2–335
modeling

a bishop 1–29
a chess set 1–21, 1–29
a pawn 1–21
a rook 1–31
airplane 1–46
align 1–255
bones 2–361, 2–377, 2–379
dummy object 1–255
ear 1–101
editable poly 2–199
eye 1–98
facial expression 2–481
head 1–92 to 1–93, 1–97, 1–102, 1–105
improvements 1–78
level design 2–264
move/rotate/scale 1–255
planets 3–29
space scene 3–28 to 3–29

modes
in place 2–546
motion flow 2–607

modifiers 1–78
bend 3–4
cloth 2–793
editable patch 2–475
extrude 3–4
FFD 2–475 to 2–476
garment maker 2–793
hsds 1–89
mesh select 1–106, 1–108
morpher 2–475
parametric deformers 1–107
skin 2–426
spline IK control 2–330
surface 1–35
unwrap uvw 1–192
vertex weld 1–79

modifying
biped structure in figure mode 1–386
footsteps 1–312

monkey head 1–92
moon - creating for close-up shot 1–144
morph

morph objects and topology change 1–212
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morph targets
lip sync 2–481

morpher modifier - creating lip sync and facial
expression 2–481

morphing animation 1–204
motion

copy 2–614
random 2–617
transfer 2–614

motion blur 3–86
mental ray renderer 2–818

motion capture
importing data 2–621
layers 2–626

motion flow
add clip 2–607
clip creation 2–607
editing 2–606
loop 2–612
script 2–608
shared 2–614, 2–617
tutorial 2–606 to 2–608, 2–612, 2–614, 2–617

motion flow script
create 2–608

motion mixer 2–547
motion-capture

working with 2–621
mound on pool table surface - animating 3–133
mouth-shape targets for speech 2–481
move transform, animating a ball with 1–223
multi-layer shader 1–119
multi/sub-object materials - applying to a label and

bottle 1–136
multilegged

character 2–576
multiple booleans 2–171
multiple delegates and behaviors 2–641
multiple materials to one object 1–162
multiplier curves 1–223

N
naming

a sphere 3–20
selections 1–108

new feature in v8
animation tracks 1–270
asset tracking 2–937
biped retargeting 2–493
cloth modifier 2–793
euler rotations 2–502
function curves on bipeds 2–502
garment maker modifier 2–793
Inventor interoperability 2–125
Limit Controller 2–187

pelt mapping 2–243
twist links 2–498
vertex selection tools 2–442
Weight tool 2–435

night shader
mental ray 2–852

noise controller 1–223
noise controller, adjusting 1–237
nonlinear animation 1–223, 1–237
normal bump maps 2–251
normals 1–90
NURBS

creating contours 1–93
creating ear 1–101
creating eye 1–98
head - completing 1–105
head - mirroring and lofting 1–102
head - previewing 1–97
modeling with 1–92

O
object painter script 2–282
object space mapscaler 1–181, 1–186
object-space camera map modifier (OSM) 3–133
objects

assigning materials to 1–118
available for modeling 3–16
matte objects 3–126, 3–129 to 3–130
parametric objects 3–16
primitive objects 3–16
unselected - hiding 1–106, 1–112

ocean shader
mental ray 2–871

online support 1–3
online tutorials 1–4
opacity value of basic materials - changing 1–119
orange

applying basic materials to 1–119
creating orange 3–20
creating orange peel 3–20

oren-nayar-blinn shader 1–119
orientation constraint

character rigging 2–371

P
painting - vertex color 2–283
painting - with vertex color 2–280
panorama exporter 1–455
parameter collector 2–189

animating parameters 2–194
organizing 2–190
selecting parameters 2–190

parameter out of range curves 1–223
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parameter wiring
character rig 2–317, 2–321, 2–349
character rigging 2–371, 2–391

parametric objects - types of 3–16
parent overlap 1–400
particle flow

with blobmesh 1–473
particle systems

and explosions 1–464, 3–82, 3–84
and materials 3–83
creating cigarette smoke 1–457

path constraint 1–276, 2–330
paths 1–242
pelt mapping 2–243
Perforce 2–937
performance, rendering 1–441
phoneme targets for speech 2–481
phong shader 1–119
physique

applying 1–396
getting started 1–382
problem areas 1–404

ping-pong ball
adding squash and stretch to 1–240

pivot points
character rigging 2–311
joining 1–112
repositioning 1–230

pivots 2–67
plane 3–76
planets

modeling 3–28
player

ram 3–138
pool table surface

animating 3–133
applying a material to 3–133
applying an affect region modifier to 3–133
creating 3–132
creating and animating 3–132

pose
biped 1–386

position constraint
wiring weights 2–371

position list controller 1–223, 1–237
pratfall 1–332
preview window 2–691
previewing NURBS head 1–97
previewing reactor 2–683
primitive objects 3–16

move/rotate/scale 3–29
props

biped using 2–506

prow and the spire 2–172
proxy geometry 2–685

Q
quadruped

animation 2–576
character 2–576

quaternion rotation 2–383
quick render 1–107

R
radial blur 3–92
radial scale 1–400
radiosity 1–437

advanced lighting override material 1–446
and camera animation 1–440
creating a radiosity solution 1–438
glowing objects 1–446
improving quality 1–443
radiosity mesh 1–440
speeding up 1–443

radiosity adaptive subdivision 3–61
advanced lighting 3–68

rag doll tutorial 2–700
creating the animation 2–718
hinge constraint 2–706, 2–708
making objects physical 2–702
rag doll constraints 2–712
setting up hips back neck and shoulders 2–716
setting up knees elbows ankles and wrists 2–708

ram player 1–432, 3–138
random motion 2–617
raytrace map type 1–139
raytrace materials - applying to a bottle and knife 1–139
reaction manager 2–467
reactor

accuracy 2–691
assigning physical properties 2–682
compound rigid bodies 2–686
create animation 2–695
creating a deforming mesh 2–737
creating animation 2–683
creating cloth 2–719
creating ropes 2–728
creating soft bodies 2–731
deformable bodies tutorial 2–719
display proxies 2–689
fracture 2–696
hand animation 2–694
introduction to 2–681
keyframing 2–695
preview window 2–691
previewing animation 2–683
proxy geometry 2–685
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rag doll tutorial 2–700
reducing file size 2–695
rigid bodies 2–682
rigid body collections 2–683
simulating mass distribution 2–688
simulation accuracy 2–691
simulation geometry 2–684
simulations 2–683
substeps 2–691
unyielding rigid bodies 2–694
updating 3ds Max 2–691
using proxies 2–685

real-world map scale 2–135
real-world map size 3–65
real-world mapping 3–61
reduce mesh memory footprint 1–204
reducing keys 2–628
reference points for use with camera match 3–114 to 3–115
reflected light

global illumination 2–835
reflections

mental ray renderer 2–810
trace depth 2–810

refraction
mental ray renderer 2–814

region-select technique 1–108
relax tool 1–202
Reload 2–137
rename objects 2–337
render effects 1–477, 1–479 to 1–481, 3–88 to 3–90, 3–92
render to texture 2–80, 2–293
rendering 1–224

an arm 3–130
and antialiasing 1–440 to 1–441
animations - using render scene 3–26
checking resolution of background - for camera

match 3–119
creating a rendering 1–438
improving 1–441
introduction to 1–424
rendering daylight 1–448
setting up background - for camera match 3–118
speeding up 1–441
using environment 3–118

requirements for lip sync 2–481
resources 1–3
revit 2–133
Revit 2–132, 2–137
revit material 2–135
revolving door 3–95, 3–98, 3–101, 3–104, 3–107 to 3–108
rig

animation controllers 2–321
arms 2–371

custom attributes 2–317, 2–349
IK solver 2–305
legs and feet 2–349
pivot points 2–311
script controller 2–383
shapes 2–311
shoulder 2–391
skin modifier 2–325
wiring 2–317, 2–321, 2–349
wrist twist 2–383

rig - character 2–349
rigging

introduction 2–299
rigid body collections 2–683
rigid body properties 2–682
rigid vertices 1–400
ring effect 1–479
roof 2–165
roof, creating for museum 2–2
rotation - animating rotation changes 3–23
rotation boosting 2–628
rotation list 2–321
rotation smoothing 2–628
rotation windup 3–3
running

and jumping 1–312

S
sample files 1–3
sampling

mental ray renderer 2–806
scale operator (particle flow) 2–916
scaling maps in object space 1–181, 1–186
scaling maps in world space 1–186
scene state 3–61
scene states

restore 3–70
save 3–70

scenes, saving 1–282
schematic view 2–411

frozen objects 2–337
screen points - assigning in camera match 3–121
script

create 2–608
motion flow 2–608
use of 2–608

script controller
character rigging 2–383

scripting
camera manager 2–925
effects 2–925
unhide 2–930

secondary motion 2–444
seeking targets 2–904
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select region
circular 2–47
rectangular 2–47

selections - naming 1–108
self-illumination value of basic materials - changing 1–119
set key 2–452
shader

mental ray 2–846
shaders 1–119, 1–125, 1–221
shadow study 1–434, 2–18
shadows

choosing a shadow type 1–422
shape operators (particle flow)

shape facing 2–915
shapes

character rigging 2–311
shared

motion flow 2–614, 2–617
shock wave effect 2–892
shoulders

envelopes 1–404
simulating fractures with reactor 2–696
simulation accuracy 2–691
simulation geometry 2–684
site planning, conceptual modeling 2–162
site-specific design 2–153
skateboard

biped interacting with 2–506
skeleton

create 1–383
skin

applying to an apple 1–106
material 1–151

skin modifier 2–425 to 2–426
angle deformer 2–439
character rigging 2–325

skinning 1–396, 2–325
character 2–425

smoke trails effect 2–900, 2–912
smoothing

and compositing (camera tracker) 3–147
snaps 3–94
soft selection 1–29, 1–85, 1–108, 1–110

with flex modifier 2–444
software driver - installing 3–121
SourceSafe 2–937
spacing tool 2–12
spawning particles 2–912 to 2–913
special effects 2–925, 3–1
specular color - changing 1–119
speech target requirements 2–481
sphere 1–107

spheres
changing color of 3–20
creating 1–106, 3–20
naming 3–20
tapering 1–106
viewing 3–20

spline IK 2–330, 2–337, 2–342
spline IK solver 2–330

splines
placing around an arm 3–129

splines, drawing 1–21
split tests (particle flow) 2–893
sponsons - airplane 1–61
squash - adding to a ball 1–240
squash and stretch 1–223
stabilizer and rudders - airplane 1–57
standard lights 1–452
standard materials 1–155
standard primitives 3–16
star effect 1–480
stars 1–148
stem

adding to an apple 1–112
positioning with 3D Snap 1–112

still life
animating 3–26
creating 3–16

stop and start walking 1–317
strauss shader 1–119
streetlight using xrefs 2–274
strength parameter spinners - adjusting 1–110
stretch - adding to a ball 1–240
sub-object selections 1–108, 1–110
sub-surface scattering

fast skin shader 2–874
submerge shader

mental ray 2–871
substeps 2–691
substitute modifier 2–139

creating a substitute 2–141
support files 1–3
surface properties and displacement mapping 1–144
surface tools 1–35
sweep modifier 3–61 to 3–62
symmetry modifier 2–199
synchronizing animation with video 3–126

T
taper modifier 1–107

applying to a cylinder 1–112
applying to a sphere 1–106

targets for lip sync 2–481
TCB rotation 3–3
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terrain
adding materials to 2–158
creating 2–156

text 3–4
text - bending 3–1
texture coordinates

managing 1–192
texture mapping 1–202
textures

texture baking 2–293
texture coordinates 1–193
texture mapping 1–193

time tags - adding to video 3–126
topology changes and morph objects 1–212
trace depth

mental ray renderer 2–810
Track View 1–223, 1–230

and setting lip sync keys 2–481
training centers 1–3
trajectories 1–223
transfer

motion 2–614
transitions

use of 2–612
translucent shader 1–221
transparency (materials) 1–119, 1–123
trees 2–282
troubleshooting - camera match 3–124
troubleshooting drawing files 2–112 to 2–113, 2–117
tutorial

motion flow 2–606 to 2–608, 2–612, 2–614, 2–617
tutorial files cd 1–3
tutorials 2–766

audiences 1–1
introductory 1–1
sample files 1–3
where installed 1–3

twist links 2–498
adding 2–499
setting twist poses 2–499

U
unhide

scripting 2–930
uniform textures 1–181, 1–186
units 3–94
unwrap UVW 1–193, 1–202

mapping a character 2–236
unyielding rigid bodies 2–694
updates 1–3
use of

layers 2–612
script 2–608
transitions 2–612

users
beginning with 3D 1–1
familiar with other 3D programs 1–2

using
freeform animation 1–343

using filters 2–628
using in place mode 2–546
UVW

mapping characters 2–236
UVW map modifier, using to adjust floor tiles 1–180
UVW mapping 1–193

V
vaults

adding files 2–942
checking in files 2–944
creating 2–940
logging in 2–941
working folders 2–942

vertex color 2–283
vertex tangent handles - shaping a facial expression target

and 2–481
vertex weights 2–426
vertices

rigid 1–400
video

adding time tags to 3–126
synchronizing animation with 3–126

video post 3–1, 3–14
viewport background

setting up 1–48
viewport image 2–1
viewports

navigating 3–17
setting up background for camera match 3–120

visibility keys 3–85
volume fog 3–1
volume light 3–1

W
walk

creating 1–303
walk cycle 2–446
walking

stop and start 1–317
walkthrough 1–276
water surface shader

mental ray 2–871
weight

giving biped illusion of 2–506
weighted list controllers 1–223, 1–237
wings, airplane 1–51
wireframe material controls 1–119
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wiring 1–464
character rig 2–317, 2–321, 2–349
character rigging 2–391
particle systems 1–464

workbench 2–627
working online 1–4
world space mapscaler 1–186
world-space camera map modifier (WSM) 3–133
wraparound shader

mental ray 2–849
wrist

automatic twist 2–383
twist bones 2–345
twist rig 2–371

X
XML files 2–182
xrefs

and animating a spaceship 1–259
and merging 2–446






